Photoshop でパスコンポーネントを管理

Last updated on 2026年10月29日

パス選択ツールとダイレクト選択ツールを使って、ベクター要素を移動、コピー、整列、整理し、正確な編集を行います。

パスコンポーネントとは、パス内の個々のシェイプやセグメントのことで、同じパス内の他の要素に影響を与えずに、個別に移動、コピー、変形、整列、整理できます。これらの手法は、保存されたパス、作業用パス、シェイプレイヤー内のシェイプに適用されます。

パスコンポーネントの管理方法を理解することで、複雑なベクターアートワークの作成、正確な構成の作成、パターン用の要素の複製、そしてプロジェクト全体で整理されたパス構造の維持ができるようになります。

パスコンポーネントを移動

「パス」パネルでパス名を選択して表示します。

ツールバーでパス選択ツールを選択します。

移動するパスコンポーネントをクリックします。

コンポーネントを新しい位置にドラッグします。

メモ

パスコンポーネントをドラッグして、ポインターが別の開いている画像上に移動すると、そのコンポーネントがその画像にコピーされます。

パスコンポーネントをコピー

「パス」パネルでパス名を選択します。

パス選択ツールを選択し、コピーするパスコンポーネントをクリックします。

選択したコンポーネントを Alt キーを押しながらドラッグ (Windows) または Option キーを押しながらドラッグ (macOS) してコピーを作成します。

選択したコンポーネントをある画像ウィンドウから別の画像ウィンドウにドラッグするか、編集 > コピー と 編集 > 貼り付け を使用して、Photoshop ファイル間でコンポーネントをコピーすることもできます。

パスコンポーネントの変形

「パス」パネルでパス名を選択します。

ツールバーでダイレクト選択ツールを選択します。

変形するパスコンポーネントのアンカーポイントをクリックします。

ポイントまたはその方向線をドラッグして、シェイプを調整します。

パスコンポーネントの削除

「パス」パネルでパス名を選択します。

パス選択ツールを選択し、削除するコンポーネントをクリックします。

Backspace (Windows) または Delete (macOS) を押します。

パスコンポーネントを整列

パス選択 ツールを選択します。

最初のコンポーネントをクリックし、次に Shift キーを押しながら追加のコンポーネントをクリックして、複数の項目を選択します。

左エッジ、中央、右エッジ、上エッジ、中間、下エッジに揃えるには、オプションバーの「パスのアラインメント」ドロップダウンメニューから整列オプションを選択します。

メモ

別々のレイヤー上のシェイプを揃える場合は、代わりに「移動ツール」を使用します。

パスコンポーネントを均等配置

パス選択 ツールを選択します。

最初のコンポーネントをクリックし、次に Shift キーを押しながら追加のコンポーネントをクリックして、少なくとも 3 つのパスコンポーネントを選択します。

コンポーネントを均等な間隔で配置するには、オプションバーの「パス配置」ドロップダウンメニューから配置オプションを選択します。

パスの重なりモードを変更

パス選択 ツールを選択し、マーキーをドラッグして、結合するパス領域を選択します。

オプションバーの「パス操作」ドロップダウンメニューからオプションを選択します:

パス操作オプションには、シェイプを結合(領域を追加)、シェイプ領域から減算(選択した領域を削除)、シェイプ領域の交差(重なった部分のみを保持)、重なったシェイプ領域を除外(重なりを削除)があります。

重なっているコンポーネントを 1 つに結合

「パス」パネルでパス名を選択します。

パス選択 ツールを選択します。

重なっているすべてのコンポーネントを 1 つのコンポーネントに結合するには、オプションバーの「パス操作」ドロップダウンメニューから シェイプコンポーネントを結合 を選択します。

パスの表示と非表示

選択したパスの表示を切り替えるには、表示 > 表示 > ターゲットパス を選択します。

または、表示 > エクストラ を選択すると、ガイド、グリッド、その他の視覚要素と一緒にパスの表示と非表示を切り替えられます。

パスを複製する

「パス」パネルで、複製するパスを選択します。

パスをパネル下部の 新規パスボタン にドラッグします。

複製時に名前を付けるには、パスを Alt キーを押しながらドラッグ (Windows) または Option キーを押しながらドラッグ (macOS) して、「新規パスボタン」に移動します。

「パス」パネルでパスの順序を変更

「パス」パネルで、移動するパスを選択します。

パスを目的の位置まで上下にドラッグします。

ヒント

保存したパスの並べ替えはできますが、シェイプ、文字、またはベクトルマスクのパスは並べ替えできません。Photoshop では、Shift キーを押しながらクリック、または Ctrl キーを押しながらクリック (Windows)、Command キーを押しながらクリック (macOS) することで、複数のパスを同時に選択してドラッグできます。

個々のパスセグメントとアンカーポイントの操作の詳細については、パスセグメントの編集を参照してください。パスとパスセグメントの選択の詳細については、パスとパスセグメントの選択を参照してください。パスの概念と「パス」パネルの概要については、Photoshop のパスを参照してください。