レイヤーの結合とスタンプ

Last updated on 2026年10月29日

結合を使うとレイヤーを永久的に1つにまとめられ、スタンプを使うと非破壊の結合済みコピーを作成できます。

レイヤーを結合すると、ファイルの複雑さを減らし、作業を整理しやすくなります。結合ではレイヤーを 1 つに永久的にまとめます。一方、スタンプでは元のレイヤーを変更せずに新しい結合レイヤーを作成します。

結合操作ではレイヤーが永久的に 1 つにまとめられ、ドキュメントを保存した後は元に戻せません。編集が完了したら、結合を使ってレイヤー構造をシンプルにします。印鑑操作を使うと、結合したレイヤーのコンテンツを保持しながら、今後の色調補正のために元のレイヤーを残せます。すべてのレイヤーを背景に結合する、レイヤーの統合について詳しくは、詳細を見る。

  • ドキュメント内に少なくとも 2 つのレイヤーがあること
  • 結合対象の選択範囲の最下部にピクセルレイヤーがあること(色調補正レイヤーまたは塗りつぶしレイヤーは使用不可)
メモ

結合したドキュメントを保存すると、未結合の状態には戻せません。レイヤーは永久的に結合されます。

隣接する 2 つのレイヤーを結合

Layers パネルで、隣接する表示レイヤー 2 つのうち上のレイヤーを選択します。

下のレイヤーが、色調補正レイヤーや塗りつぶしレイヤーではなく、ピクセルレイヤーであることを確認します。

Layer > 「下のレイヤーと結合」 を選択するか、Ctrl + E (Windows) または Command + E (macOS) を押します。

選択した表示レイヤーを結合

結合したくないレイヤーは、Layers パネルで表示アイコンを選択して非表示にします。

ベースレイヤーとしてピクセルレイヤーを選択します。

Layer > 「表示レイヤーを結合」 を選択するか、Shift + Ctrl + E (Windows) または Shift + Command + E (macOS) を押します。

これにより、非表示レイヤーは保持したまま、表示レイヤーだけが選択したベースレイヤーに結合されます。

複数の選択レイヤーを結合

Layers パネルで、結合するすべてのレイヤー (ベクターまたはピクセルレイヤー) を選択します。

Layer > 「レイヤーを結合」 を選択するか、Ctrl + E (Windows) または Command + E (macOS) を押します。

リンクされたレイヤーを結合

すべてのリンクされたレイヤーを選択するには、「レイヤー」 > 「リンクしているレイヤーを選択」 を選択します。

「レイヤー」 > 「レイヤーを結合」 を選択するか、Ctrl + E (Windows) または Command + E (macOS) を押します。

クリッピングマスク内のレイヤーの結合

結合したくないレイヤーはすべて非表示にします。

「レイヤー」 パネルで、クリッピングマスク内のベースレイヤーを選択します。ベースレイヤーはラスターレイヤーである必要があります。

「レイヤー」 > 「クリッピングマスクを結合」 を選択します。

クリッピングマスクでレイヤーを表示する方法を確認してください。

アクティブレイヤーを新しいレイヤーにスタンプ

スタンプすると、元のレイヤーを保持したまま、結合されたコンテンツを含む新しいレイヤーが作成されます。この非破壊ワークフローでは、ソースレイヤーを永続的に変更せずに、結合したコンテンツに編集を適用できます。

「レイヤー」 パネルで、スタンプするレイヤーを選択します。

Alt + Ctrl + E (Windows) または Option + Command + E (macOS) を押します。

選択したすべてのレイヤーの結合済みコンテンツを含む新しいレイヤーが、選択範囲の上に表示されます。

表示されているレイヤーを新しいレイヤーにスタンプ

「レイヤー」 パネルで表示をオフにして、含めたくないレイヤーを非表示にします。

「レイヤー」 パネルで任意のレイヤーを選択します。

Shift + Alt + Ctrl + E (Windows) または Shift + Option + Command + E (macOS) を押します。

または、「レイヤー」 パネルメニューから 「表示レイヤーを結合」 を選択しながら、Alt (Windows) または Option (macOS) を押します。

ヒント

スタンプ操作は、複数のレイヤーに 1 つのユニットとしてフィルターや色調補正を適用しつつ、元のレイヤー構造の柔軟性も維持したい場合に使います。