レイヤーからの画像アセットの生成

Last updated on 2026年10月29日

ジェネレーターを使用して、.png や .jpg などの形式の拡張子をレイヤー名に追加することで、ファイルを自動的に作成します。

レイヤー名に拡張子を追加すると、保存するたびに Photoshop のジェネレーターがトリガーされ、画像ファイルが自動的に作成されます。これにより、複数の形式やサイズが必要な web、アプリ、マルチデバイスプロジェクトで、繰り返しの書き出し作業が不要になります。

このワークフローは、レスポンシブデザイン用に @1x、@2x、@3x バージョンを作成する場合など、複数の形式や解像度にわたって一貫した、繰り返し可能な書き出しが必要な場合に最適です。一度限りの書き出しを行う場合や、形式別のコントロールが必要な場合は、代わりにファイル > 書き出し > 書き出し形式を使用してください。

ジェネレーターは、アセット専用のフォルダーを作成し、作業中にファイルを自動的に更新します。1 つのレイヤーから複数の形式を生成したり、品質設定を指定したり、アセットを異なるサイズに拡大・縮小したり、出力をサブフォルダーに整理したりできます。これらはすべてレイヤーの命名規則で行えます。

  • 名前付きのレイヤーまたはレイヤーグループを含む Photoshop ドキュメント
  • 既知の場所に保存したドキュメント(保存していない場合、アセットはデスクトップに表示されます)
  • プロジェクトに必要な出力形式に関する知識

画像アセットの生成を有効にする

ファイル > 自動処理 > ジェネレータープラグイン > 画像アセット を選択します。

レイヤー パネルで、書き出すレイヤーまたはグループを見つけます。

拡張子(.jpg、.png、.gif、.svg のいずれか)を追加して、レイヤー名を変更します。例えば、「logo」を「logo.png」に変更します。

Ctrl + S (Windows) または Command + S (macOS) キーを押して、ドキュメントを保存します。

Photoshop は、保存したドキュメントの隣にあるサブフォルダーに画像ファイルを作成します。ドキュメントがまだ保存されていない場合、アセットはデスクトップ上の新しいフォルダーに表示されます。ジェネレーターはアクティブのままで、ジェネレーターが有効なレイヤーに変更を加えると、対応するアセットが自動的に更新されます。

メモ

レイヤー名には「:」(コロン)や「*」(アスタリスク)を含めることはできません。これらの文字が含まれていると、アセットが生成されません。

1 つのレイヤーから複数の形式を生成

1 つのレイヤーから、異なる形式、サイズ、品質レベルのアセットを同時に作成できます。レイヤー名内の各アセット指定は、カンマまたはプラス記号で区切ります。

レイヤーパネルでレイヤーを選択します。

レイヤー名をコンマ区切りの形式で変更します。例:button.png, button.jpg90, 200% button@2x.png。

文書を保存します。

Photoshop は同じレイヤーコンテンツから3つの別々のファイルを生成し、同じグラフィックを手動でさまざまな形式に書き出す必要がなくなります。

さまざまな画面向けにアセットの品質とサイズを調整

レイヤーパネルでレイヤーを選択します。

ファイル名に品質またはサイズのパラメーターを追加します。例:「button.jpg90」は JPEG の品質を 90% に設定し、「200% logo@2x.png」はアセットのサイズを 2 倍にします。

複数の解像度を指定する場合は、各指定をコンマで区切ります:「icon.png, 200% icon@2x.png, 300% icon@3x.png」。

ドキュメントを保存すると、すべてのバリエーションが生成されます。

品質サフィックスは、JPG ファイルの圧縮率 (1~100) と PNG ファイルのビット深度 (8、24、または 32) を制御します。サイズ接頭辞には、相対的な拡大縮小のパーセント値、または絶対的なピクセル寸法を指定できます。単位を混在させることができます。例:「10in x 5cm banner.jpg」。また、一方の寸法を省略すると、縦横比を維持したまま比例的に拡大縮小されます。例:「1080 x icon.png」は、縦横比を維持したまま幅を 1080 ピクセルに設定します。

ヒント

@2x と @3x の命名規則を使うと、レスポンシブな web プロジェクトやモバイルアプリ向けに Retina 版や高 DPI 版を自動的に生成できます。

相対的な拡大縮小の例:

200% logo.png はアセットのサイズを 2 倍にします

50% thumbnail.jpg はアセットのサイズを半分に縮小します

絶対サイズ指定の例:

300 x 200 hero.png は 300×200 ピクセルの画像を作成します

10in x 5cm banner.jpg は単位を混在させます (幅 10 インチ、高さ 5 センチメートル)

1080 x icon.png は幅を 1080 ピクセルに設定し、高さは縦横比を維持して拡大縮小されます

ヒント

ピクセル寸法を指定する場合は、単位表記なしで数値を直接入力します。「300px x 200px」ではなく「300 x 200」を使用します。

アセットをサブフォルダーに整理

デフォルトでは、生成されたすべてのアセットは PSD ファイルと同じ場所にある 1 つのフォルダーに保存されます。ファイル名の前にサブフォルダー名を追加すると、ジェネレーターはそのサブフォルダーを自動的に作成して使用します。これにより、フォルダーを手動で管理することなく、関連するアセットを整理できます。

レイヤー名にスラッシュを使用してサブフォルダーのパスを含めます。例:subfolder/filename.png または icons/logo.svg。assets/icons/logo.png のように、複数のレベルをネストできます。

特定のフォルダーにアセットを書き出す

ファイル名にサブフォルダーのパスを使用してレイヤー名を変更します。例:mobile/button.png, desktop/button.png。

文書を保存します。

Photoshop は自動的にフォルダー構造を作成し、各アセットを指定された場所に配置します。サブフォルダーとサイズの接頭辞、品質設定を組み合わせることで、アセットの整理を完全にコントロールできます:mobile/200% button@2x.png, desktop/button.jpg90。

ドキュメント全体のデフォルトを設定する

特別なレイヤーを作成して、生成されるすべてのアセットに適用されるベースライン設定を確立します。これにより、個々のレイヤー名でパラメーターを繰り返し指定する必要がなくなります。

空のレイヤーを作成し、名前を「default」で始め、その後に任意の設定を追加します。一般的な設定には、すべてのアセットを 200% に拡大する「default 200%」、すべてを assets サブフォルダーに保存する「default assets/」、すべてのファイル名に @2x サフィックスを追加する「default @2x」などがあります。

複数のデフォルトを組み合わせることもできます。「default 200% retina/ @2x」は、すべてのアセットを 200% に拡大し、retina サブフォルダーに保存して、ファイル名に @2x サフィックスを追加します。個々のレイヤー設定はドキュメントのデフォルト設定を上書きします。デフォルトで「default 200%」を指定していても、レイヤー名に「50% thumbnail.png」が含まれている場合、そのレイヤーは 50% で生成されます。

クラウドドキュメントの操作

クラウドドキュメントでは、生成されたアセットは PSD ファイルと直接同じ場所ではなく、ローカルに保存されます。Photoshop は、ローカルコンテンツとクラウド同期されたコンテンツを区別するためにこの分離を維持しています。

クラウドドキュメントのアセットは、次の場所に表示されます:

  • Windows:C:\Usersusername>\Documents\Adobe\Photoshop Cloud Associates
  • macOS:/Users//Documents/Adobe/Photoshop Cloud Associates

各クラウドドキュメントは、このディレクトリ内に専用のサブフォルダーを作成します。アセットは作業中に自動的に生成されますが、Creative Cloud で明示的に共有または同期するまでは、ローカルマシンに保持されます。

アセット生成を無効にする

画像アセットの生成は、一度有効にするとドキュメントに対して有効なままになり、セッションをまたいで保持されます。この機能は保存するたびにアセットを自動的に再生成するため、複雑なドキュメントではパフォーマンスが低下する場合があります。

現在のドキュメントの生成を無効にするには、ファイル > 自動処理 > ジェネレータープラグイン > 画像アセット の選択を解除します。これにより自動アセット作成は停止しますが、既存のアセットとレイヤー名はそのまま保持されます。

すべての文書でジェネレーターをグローバルに無効にするには、編集 > 環境設定 > プラグインを選択し、ジェネレーターを有効にするの選択を解除して、 OK を選択します。これにより、環境設定で再度有効にするまで、ジェネレーター機能が完全に無効になります。