画像内のオブジェクトをカウント

Last updated on 2026年10月29日

クリックしてカウントする方法または選択方法を使って、画像要素を数値化し、合計を計測ログに記録します。

画像内のオブジェクトをカウントすると、科学的な分析、在庫管理、品質コントロール、またはデータ収集ワークフローのために要素を数値化できます。Adobe Photoshop には、結果を計測ログに記録してトラッキングや書き出しに使える 2 つのカウント方法があります。

オブジェクトが視覚的にはっきり区別できても、色や形が異なる場合は、手動でクリックしてカウントするワークフローにカウントツールを使います。オブジェクトの色が似ていて、背景とのコントラストがはっきりしている場合は、選択を使った自動カウントを使用します。どちらの方法でも、測定を記録する前に「Count」データポイントを有効にする必要があります。

カウントツールは、画像上でクリックした場所をそれぞれ記録し、各位置に番号付きマーカーを表示します。複数のカウントグループを作成して、同じ画像内の異なる種類のオブジェクトを整理できます。各グループでは、色やマーカーサイズをカスタマイズできます。カウントマーカーは編集可能なままで、ドキュメントと一緒に保存されます。

自動カウントでは、選択ツールを使って、色の類似性に基づいて個別の領域を識別し、カウントします。この方法は、顕微鏡画像内のセルやコンベヤーベルト上の製品のように、周囲からはっきり目立つ均一なオブジェクトに最適です。

カウントツールでオブジェクトを手動でカウントする

ツールバーで、スポイトツールと同じグループにあるカウントツールを選択します。

オプションバーで、「カウントグループ」メニューから既存のグループを選択するか、フォルダーアイコンを使用して新しいグループを作成し、カウントグループの設定を行います。

カウントマーカーの「Color」、「Marker Size」(1-10)、「Label Size」(8-72) を設定します。

画像内の各オブジェクトをクリックして、番号付きカウントマーカーを追加します。再配置するときに Shift キーを押しながらドラッグすると、マーカーの移動を水平方向または垂直方向に制限できます。

「分析」/「データポイントを選択」/「カスタム」を選択し、「Count Tool」領域で「Count」データポイントを有効にします。

「ウィンドウ」/「計測ログ」を選択して、ログパネルを開きます。

「分析」/「測定を記録」を選択するか、「計測ログ」パネルで「測定を記録」を選択して、カウントデータを保存します。

ヒント

「表示」/「表示」/「Count」を選択して、カウントマーカーの表示を切り替えます。任意のマーカーを Alt キーを押しながらクリック(Windows)または Option キーを押しながらクリック(macOS)すると、そのマーカーが削除され、合計カウントが更新されます。

計測ログには、記録されたすべてのカウントが、ドキュメント名、タイムスタンプ、および尺度情報とともに保存されます。各カウントグループは独自の累計を保持し、記録時には別々の項目として表示されます。計測ログの設定方法および測定スケールの設定について詳しくは、測定の実行に計測ログを使用を参照してください。

選択範囲を使用してオブジェクトを自動的にカウント

自動選択ツールを選択するか、「選択範囲/色域指定」を選択して、選択方法を作成します。

カウントするすべてのオブジェクトを含む選択範囲を作成します。自動選択の場合は、許容値を調整してオブジェクトの選択を最適化し、「アンチエイリアス」と「隣接」のチェックを外します。色域指定の場合は、「あいまいさ」と「選択色」を調整して、選択した領域を絞り込みます。

「分析/データポイントを選択/カスタム」を選択します。

「選択範囲」領域で、「カウント」データポイントを有効にし、「OK」を選択します。

ログパネルがまだ表示されていない場合は、「ウィンドウ/計測ログ」を選択して開きます。

カウントツール以外のツールに切り替えてから、「分析/測定を記録」を選択するか、「計測ログ」パネルで「測定を記録」を選択します。

メモ

選択範囲からカウントを記録する場合は、カウントツールから切り替えておく必要があります。切り替えていないと、「測定を記録」オプションを使用できません。

Adobe Photoshop は、個別の選択範囲ごとにカウントし、合計を「カウント」列に記録します。複数の選択範囲がある場合は、累積データを示す概要行が 1 つ作成され、その後に各領域の個別の行が続きます。各選択範囲は、「ラベル」列に個別の項目として一覧表示され、一意の番号が割り当てられます。

自動選択ツールまたは「色域指定」コマンドを使用する高度な選択方法については、自動選択ツールを使って色で範囲を選択を参照してください。