Pattern Maker でパターンを生成

Last updated on 2026年10月29日

デスクトップ版 Adobe Photoshop でパターンメーカーを使って、画像領域をスライスして再構成し、継ぎ目なく繰り返すタイルを作成する方法を説明します。

パターンメーカーは Windows と macOS 向けのオプションのプラグインで、画像の一部を分析して再構成することで継ぎ目のないパターンを作成し、タイルサイズ、滑らかさ、ディテールの保持をコントロールできます。64-bit macOS を使用している場合は、Photoshop を 32-bit モードで実行する必要があります。

このフィルターは画像を分析してパターンを作成し、タイルサイズ、滑らかさ、ディテールをコントロールできます。レイヤーを直接塗りつぶしたり、個々のタイルを今後のプロジェクト用のプリセットとして保存したりできます各生成では、選択した領域をサンプリングしてアルゴリズムで再配置することで、独自のバリエーションが作成されます。

Pattern Maker をダウンロードして設定

パターンメーカーをオプションのプラグインページからダウンロードしてください。

提供されている手順に従ってプラグインをインストールします。

Photoshop が 32-bit モードで実行されるように設定します (64-bit macOS のみ)

引用元コンテンツを準備

引用元領域を含むレイヤーを選択します元の内容を保持するために複製を作成します

新しい場所にパターンを生成するには、長方形の選択範囲を作成し、「編集」>「コピー」を選択します。

新しいレイヤーを追加するか、目的のサイズで新しいファイルを作成します

パターンを生成して調整

「フィルター」>「パターンメーカー」を選択します。

前の手順でコンテンツをコピーした場合は、「Use Clipboard As Sample」を選択しますそれ以外の場合は、「選択範囲」ツールを使ってプレビュー内の領域を選択します

「幅」フィールドと「高さ」フィールドにピクセルサイズを入力するか、「画像サイズを使用」を選択して単一タイルのパターンを作成します

「滑らかさ」スライダーを調整して、パターン内の鋭いエッジを減らします

「サンプルの詳細」を設定してスライスサイズをコントロールします。値を高くすると元のディテールがより保持されますが、生成時間が長くなります。

生成を選択して、最初のパターンを作成します。

サンプルの詳細の値を高くすると、より精密なパターンが生成されますが、処理時間が長くなります。Esc を押すと生成をキャンセルできます。プレビューには、パターンが繰り返しタイルとして表示されます。表示メニューを使用して、生成されたプレビューとソース画像を切り替えます。タイルの境界を選択すると、個々のタイルの境界線が表示されます。オフセットメニューを使用してタイルのアラインメントを調整します。これにより、保存済みのプリセットに影響を与えずにタイルの位置を変更できます。

パターンのバリエーションを操作して保存

再度生成を選択すると、現在の設定で追加のバリエーションを作成できます。また、再生成する前にオプションを調整することもできます。

タイルヒストリーパネルの下部にあるナビゲーションボタンを使用して、生成されたすべてのパターンを確認します。

パターンプレビューを更新を選択または選択解除して、プレビュー領域に完全な繰り返しパターンを表示するかどうかを設定します。

お好みのタイルに移動し、プリセットパターンを保存ボタンを選択します。

プリセット名を入力し、OK を選択します。

保存したパターンプリセットには、生成された完全なパターンではなく、単一のタイルのみが含まれます。このタイルは、パターンツールを使用して適用するとシームレスに繰り返されます。

OK を選択すると、アクティブなレイヤーまたは選択範囲にパターンで塗りつぶされます。塗りつぶさずにプリセットパターンを保存するには、キャンセルを選択します。