画像スタックの作成と処理

Last updated on 2026年10月29日

Smart Object を使用して複数の画像を結合し、デスクトップ版の Adobe Photoshop でノイズの低減や不要なオブジェクトの削除を行います。

画像スタックを使用すると、複数の露光量を 1 つの強化された結果に結合する方法を正確にコントロールできます。

画像スタックは、フレーミングが似ているものの画質が異なる複数の画像を Smart Object に結合します。次に、スタックモードの処理オプションを適用して、すべてのレイヤーの対応するピクセルを分析し、ノイズ、ゆがみ、不要なオブジェクトを除去した合成画像を作成できます。画像スタックは、三脚で撮影した静止画像や固定したビデオカメラのフレームなど、同じ視点から撮影した同一サイズの画像で最も効果を発揮します。

レイヤーのアラインメントとモード選択を完全にコントロールするために画像スタックを手動で作成することも、Statistics スクリプトを使用してワークフロー全体を自動化することもできます。

画像を 1 つの複数レイヤードキュメントに結合

ファイル > スクリプト > ファイルをスタックに読み込み を選択するか、各画像を新規レイヤーとして手動でコピーします。

背景レイヤーが含まれている場合は、そのレイヤーを右クリックして背景からレイヤーへを選択し、通常のレイヤーに変換します。

ドキュメント内のすべてのレイヤーを選択するには、選択 > すべてのレイヤーを選択します。

編集 > レイヤーの自動アラインメントを選択し、アラインメントオプションとして自動を選択して、OKを選択します。

すべてのレイヤーが選択された状態のまま、レイヤー > Smart Object > Smart Object に変換を選択します。

レイヤー > Smart Object > スタックモードを選択し、ノイズを低減するには平均、オブジェクトを削除するには中央値などのレンダリングモードを選択します。

スタックモードのレンダリングは非破壊です。元の画像データを保持しながら、いつでもモードを変更して異なる効果を作成できます。一般的な用途としては、法医学、医療、天体フォト画像のノイズ低減や、建築フォトから歩行者や車両などの一時的な要素を削除することが挙げられます。レンダリングされた合成画像はすぐに表示されます。

Statistics スクリプトを使用してスタックを作成しレンダリングする

ファイル > スクリプト > Statistics を選択します。

スタックモードを選択メニューからスタックモードを選択し、参照を選択してファイルまたはフォルダーを選択することで、引用元の画像を指定します。

画像の位置合わせが必要な場合は、ソース画像の自動位置合わせを試みるを選択します。

「OK」を選択します。 Photoshop は画像を Smart Object に結合し、選択したスタックモードを自動的に適用します。

Statistics スクリプトは、スタックの作成とレンダリングのワークフロー全体を一度の操作で完了します。

画像スタックの内容を編集

スタックを含む Smart Object レイヤーを選択し、レイヤー > スマートオブジェクト > 内容を編集を選択します。

スタックドキュメント内の個々のレイヤーに変更を加えたら、ファイルを保存して閉じ、レンダリングされた合成を更新します。

画像のスタックレンダリングの削除

Smart Object レイヤーを選択し、レイヤー > スマートオブジェクト > スタックモード > なしを選択します。

スタックモードを削除すると、Smart Object はそのまま残りますが、合成レンダリングが無効になり、上位レイヤーのみが表示されます。

スタックを通常のレイヤーに変換

レイヤー > スマートオブジェクト > ラスタライズを選択すると、現在のスタックレンダリングが完全に適用され、スマートオブジェクトが標準レイヤーに変換されます。

ラスタライズする前に Smart Object レイヤーを複製しておくと、後で別のモードでスタックを再レンダリングできます。