Adobe Photoshop 起動時のジェネレーターエラーを解決

Last updated on 2026年10月29日

セキュリティ設定の確認、競合するプラグインの削除、ログの確認を行うことで、Adobe Photoshop のジェネレーターエラーを解決する方法について説明します。

ジェネレーターは、Photoshop とジェネレータープラグイン間の通信を処理する Node.js アプリケーションです。これは、書き出し形式と画像アセットのアセット作成ロジックを提供します。

Photoshop を起動するとき、または ファイル > 書き出し > 書き出し形式を選択すると、「ジェネレーターに問題があります。Photoshop を終了して再試行してください。 問題が解決しない場合は、サードパーティのプラグインを削除するか、Photoshop の再インストールを試してください。」

以下の解決策を順番に試します。

セキュリティソフトウェアがジェネレーターをブロックする

セキュリティソフトウェアまたはウイルス対策ソフトウェアが、ポート 8010 でのジェネレーターからの通信をブロックしたり、ノードプロセスの実行を妨げたりする場合があります。

セキュリティまたはウイルス対策の設定を開きます。

許可されたアプリケーションのリストに Photoshop を追加します。

ジェネレーター用にポート 8010 が開いていることを確認します。

Windows では、C:\Program Files\Adobe\Adobe Photoshop <version>\node.exe にある node.exe を許可されたアプリケーションのリストに追加します。

macOS では、/Applications/Adobe Photoshop <version>/Adobe Photoshop <version>.app/Contents/MacOS/node でノードプロセスを許可します。

Windows では、Photoshop による制御フォルダーへのアクセスを許可します。

Photoshop を再起動し、ファイル > 書き出し > 書き出し形式 を選択して、ジェネレーターをテストします。

サードパーティプラグインがジェネレーターと競合する

Photoshop のジェネレーターフォルダーにあるサードパーティプラグインは、現在のバージョンと互換性がない場合や、デフォルトの画像アセットプラグインと競合する場合があります。

Windows: C:\Program Files\Adobe\Adobe Photoshop <version>\Plug-ins\Generator

macOS: /Applications/Adobe Photoshop <version>/Plug-ins/Generator

デスクトップに Disabled Generator Plug-ins という名前の一時フォルダーを作成します。

サードパーティプラグインフォルダーを一時フォルダーに移動します。デフォルトの 画像アセット プラグインは ジェネレーター フォルダーにそのまま残します。

Photoshop を起動し、ファイル > 書き出し > 書き出し形式 を選択します。

エラーが解消された場合は、プラグインを 1 つずつ元に戻し、追加するたびに Photoshop を再起動して、エラーが再発するまで繰り返します。

デフォルトの Image Assets プラグインは Generator フォルダーに残します。個別にインストールしたプラグインのみを移動します。

Generator を起動できず、使用する必要もない

Export As または Image Assets を使用しない場合は、回避策として Generator を無効にします。

Photoshop を起動します。

Windows では、「編集」 > 「環境設定」 > 「プラグイン」 を選択します。macOS では、Photoshop / 設定 / プラグイン を選択します。

「ジェネレーターを有効にする」の選択を解除します。

「OK」 を選択し、Photoshop を再起動します。

「ファイル」 > 「書き出し」 > 「Export As」 を選択すると、Generator は再び有効になります。Export As が必要な場合は、ジェネレーターを無効のままにせず、ジェネレーターのエラーを解決してください。

Generator のログに起動エラーが表示される

Generator のログには、読み込みに失敗したプラグインや、Generator の起動を妨げているシステム上の問題に関する情報が含まれていることがあります。

Windows では、C:\Users\<username>\AppData\Roaming\Adobe\Adobe Photoshop <version>\Logs\Generator に移動します。

macOS では、/Users/<username>/Library/Logs/Adobe/Adobe Photoshop <version>/Generator に移動します。

最新の Generator ログを開き、エラーメッセージを探します。

Generator フォルダーが存在しない場合は、親フォルダーへの書き込み権限があることを確認します。

さらにサポートが必要な場合は、Adobe Log Collector Tool を使って診断ログを収集します。

Windows の AppData フォルダーと macOS の Library フォルダーは、デフォルトでは非表示です。Windows で非表示のファイルとフォルダーを表示する手順を参照すると、Windows のログを見つけるのに役立ちます。

Apple Silicon で Generator エラーが発生する

Apple シリコン搭載の Mac でジェネレーターが引き続き失敗する場合は、Rosetta を使用して Photoshop を実行すると、ネイティブモードの互換性が原因かどうかを判断するのに役立ちます。

Photoshop を終了します。

Finder で「アプリケーション」を開き、Adobe Photoshop を探します。

Adobe Photoshop を Control キーを押しながらクリックし、「情報を見る」 を選択します。

Rosetta を使用して開く を選択し、Photoshop を起動して Generator をテストします。

エラーが解消されない場合は、Adobe サポートに問い合わせる際に Generator のログを提供してください。ジェネレーターに関連しない「別名で書き出し」の問題については、書き出し操作と保存操作のトラブルシューティングガイダンスを参照してください。