スライスの作成

Last updated on 2026年10月29日

デスクトップ版の Adobe Photoshop で、スライスツール、Guides、またはレイヤーを使用して、Web 最適化のために画像を書き出し可能な領域に分割する方法を説明します。

スライスを使うと、画像を小さなセクションに分割し、個別に加工したり、異なる URL リンクを割り当てたりしてから、Web 用に書き出すことができます。

スライスツールでスライスを作成

ユーザースライスを作成すると、Photoshop は自動的にカバーされていない領域を自動スライスで埋めます。ユーザースライスは実線のボーダーで表示され、自動スライスは点線のボーダーで表示されます。

スライスをガイドや他のスライスに揃えるには、描画する前に 表示 > スナップ先 を選択します。

スライス ツールを選択します。

オプションバーで、ドロップダウンからスタイルを選択します:

  • 標準: 自由な形のスライスを描画します。
  • 固定縦横比: 縦横比を固定します。
  • 固定サイズ: 正確なピクセル寸法を指定します。

スライスを作成したい画像領域をドラッグします。

メモ

スライスを正方形に固定するには Shift を押しながらドラッグし、中心から描画するには Alt (Windows) または Option (macOS) を押しながらドラッグします。

同じ手順を繰り返して、スライスを追加で作成します。

ガイドからのスライスの作成

Guides からスライスを作成すると、ドキュメント内の既存のスライスがすべて削除されます。現在のスライス設定を保持する必要がある場合は、ファイルのコピーを保存してください。

表示 > Guides > 新規ガイド を選択し、希望するスライスの境界を定義する 垂直 または 水平 ガイドを設定し、OK を選択します。

スライス ツールを選択します。

オプションバーで Guides からスライス を選択します。

レイヤーからスライスを作成

レイヤーから作成したスライスは、レイヤーを移動または編集すると境界が自動的に調整されるため、動的なデザインに役立ちます。これらは実線のボーダーとレイヤーアイコンバッジで表示され、ユーザースライスに変換しない限りサイズを変更できません。

広い範囲にわたってアニメーション化する予定のレイヤーには、レイヤーベースのスライスを使用しないでください。スライスのサイズが非現実的なほど大きくなる可能性があります。

レイヤー パネルで、スライスするコンテンツを含むレイヤーを選択します。

レイヤー > 新規レイヤーベーススライス を選択します。

スライスを作成したら、スライス選択 ツールでスライスを選択し、移動、サイズ変更、プロパティの変更を行うことができます。ユーザースライスは、最も柔軟性があります。スライスの境界線を表示するには、表示 > 表示 > スライス を選択します。

ファイル > 書き出し > Web 用に保存 を選択し、各スライスの書き出しオプションを設定して、ファイルを保存します。Photoshop は各スライスを個別の画像ファイルとして書き出し、web ページにスライスを表示するために必要な HTML または CSS を生成します。