画像内のレイヤーを統合

Last updated on 2026年10月29日

ファイルサイズを縮小してドキュメントを簡素化するために、表示されているすべてのレイヤーを 1 つの背景レイヤーに統合します。

レイヤーの統合を行うと、表示されているすべてのレイヤーが 1 つの背景レイヤーに完全に結合され、ファイルが小さくなり管理しやすくなります。

統合処理を使用すると、表示されているすべてのレイヤーが背景に統合され、非表示レイヤーは破棄され、透明な領域は白で塗りつぶされます。このプロセスでは、複数のレイヤー、描画モード、レイヤー効果を保存するためのオーバーヘッドがなくなるため、ファイルサイズが大幅に縮小されます。特定のレイヤーを結合しながらレイヤー構造を維持する必要がある場合は、レイヤーの結合とスタンプの方法を確認してください。

すべての編集が完了し、個々の要素を調整する必要がなくなった場合は、フラット化を選択します。構成の他の部分で柔軟性を維持しながら、特定のレイヤーグループを簡素化したい場合は、レイヤーの統合を選択します。

警告

画像の統合は元に戻せず、データが失われます。破壊的な編集を避けるため、統合する前にレイヤー化されたファイルのコピーを保存してください。

画像全体を統合

レイヤー > 画像を統合 を選択します。

レイヤー パネルで、表示されているすべてのレイヤーが 1 つの 背景 レイヤーに統合されたことを確認します。

統合した画像を保存するには、ファイル/保存または別名で保存を選択します。

すべてのレイヤー効果を統合

ファイル > スクリプト > すべてのレイヤー効果を統合を選択します。

レイヤーを統合すると、効果が固定され、ベクターレイヤーがラスタライズされたピクセルレイヤーに変換されます。レイヤー構造を維持しつつ、効果をレイヤーのコンテンツにベイク処理したい場合は、このオプションを使用します。

すべてのマスクを統合

ファイル > スクリプト > すべてのマスクを統合を選択します。

マスクを統合すると、すべてのレイヤーマスクがそれぞれのレイヤーに完全に適用され、この変更は元に戻せません。マスクされた領域は削除され、残りの表示コンテンツはそのまま維持されます。この方法により、レイヤーを分離したままファイルの複雑さを軽減できます。

メモ

特定のカラーモード間で画像を変換すると、ファイルが自動的に統合されます。例えば、 RGB から Bitmap モードに切り替えると、すべてのレイヤーが削除されます。レイヤーデータがいつ保持されるかを理解するには、カラーモードとコンバージョンの詳細を見てください。

統合すると、ドキュメントのファイルサイズが小さくなり、保存が速くなり、共有も簡単になり、JPEG などの形式とも互換性を持つようになります。