طرق لدمج الكائنات

يمكنك دمج كائنات موجهة لإنشاء أشكال بطرق مختلفة في Illustrator. تختلف المسارات أو الأشكال الناتجة بناءً على الطريقة التي تستخدمها لتجميع الكائنات.

تأثيرات Pathfinder

تتيح لك تأثيرات Pathfinder تجميع كائنات متعددة باستخدام أوضاع التفاعل. ‏‫عند استخدام ‏‫تأثيرات Pathfinder‬، لا يمكنك تحرير التفاعلات بين الكائنات. راجع تجميع الكائنات باستخدام تأثيرات Pathfinder.

أشكال مركبة

تتيح لك الأشكال المركبة تركيب كائنات متعددة وتحديد كيف تفاعل كل كائن مع الكائنات الأخرى حسب رغبتك. تكون الأشكال المركبة أكثر مرونة من المسارات المركبة لأنها توفر أربعة أنواع من التفاعلات: إضافةً، واستقطاعًا، وتقاطعًا، واستثناءً. بالإضافة إلى ذلك، لا تتغير الكائنات السفلية، بحيث يمكنك تحديد كل كائن ضمن شكل مركب لتحريره أو تغيير وضع تفاعله. راجع تجميع الكائنات باستخدام الأشكال المركبة.

مسارات مركبة

تتيح لك المسارات المركبة أن تستخدم كائنًا لقطع أو خرق في كائن آخر. على سبيل المثال، يمكنك إنشاء شكل فطيرة دونت من دائرتين متداخلتين. بمجرد أن تقوم بإنشاء مسار مركب، فإن المسارات تعمل كما لو كانت كائنات مجموعة. يمكنك تحديد الكائنات ومعالجتها بشكل مستقل باستخدام أداة التحديد المباشر أو أداة التحديد الجماعي؛ أو يمكنك تحديد المسار المركب وتحريره. راجع تجميع الكائنات باستخدام المسارات المركبة.

ملاحظة:

يمكنك أيضًا إضافة كائن باستخدام أداة Blob Brush tool. عندما يمكنك استخدام هذه الفرشاة، فإن المسارات التي تطليها تضاف إلى المسارات المقابلة التي تستخدم خصائص تعبئة مطابقة. راجع رسم المسارات ودمجها باستخدام أداة Blob Brush وإنشاء أشكال جديدة باستخدام الأداة Shape Builder.

دمج الكائنات باستخدام تأثيرات Pathfinder

التنقل خلال لوحة Pathfinder

تستخدم لوحة Pathfinder (Window > Pathfinder) لتركيب الكائنات إلى أشكال جديدة.

لوحة Pathfinder نظرة عامة
لوحة Pathfinder

استخدم صف الأزرار العلوي الموجود في اللوحة لإنشاء المسارات أو المسارات المركبة. لعمل الأشكال المركبة، استخدم الأزرار في تلك الصفوف أثناء الضغط على مفتاح Alt أو Option. 

اختر من خيارات أوضاع الشكل التالية:

Add To Shape Area

يضيف مساحة المكون إلى الهندسة السفلية.

Subtract from Shape Area

يستقطع مساحة المكون من الهندسة السفلية.

Intersect Shape Areas

يستخدم مساحة المكونات لقطع الهندسة السفلية كما يفعل القناع.

Exclude Overlapping Shape Areas

يستخدم مساحة المكون لعكس الهندسة السفلية، لتحويل المناطق المعبئة إلى فجوات والعكس بالعكس.

استخدم الصف السفلي من الأزرار في اللوحة، يسمى تأثيرات Pathfinder، لإنشاء تجميعات أشكال نهائية عند أول نقرة. (راجع ‏‫تطبيق تأثيرات Pathfinder‬.)

تأثيرات Pathfinder
صيغة الشكل

A. كل المكونات في صيغة إضافة B. صيغة استقطاع مطبقة على مربعات C. صيغة تقاطع مطبقة على مربعات D. صيغة استثناء مطبقة على مربعات 

تحديد خيارات Pathfinder

قم بضبط Pathfinder Options من قائمة لوحة Pathfinder أو بالنقر المزدوج فوق تأثير Pathfinder في لوحة Appearance.

Precision

يؤثر على مدى دقة حساب تأثيرات Pathfinder لمسار كائن. كلما زادت دقة الحسابات، زادت دقة الرسم وزاد الوقت المتطلب لتوليد المسار الناتج.

Remove Redundant Points

إزالة النقاط غير الضرورية وأنت تنقر فوق الزر Pathfinder.

Divide And Outline Will Remove Unpainted Artwork

يحذف أي كائنات غير معبئة في العمل الفني المحدد وأنت تنقر فوق الزر Divide أو Outline.

تطبيق تأثير Pathfinder

تتيح لك تأثيرات Pathfinder إنشاء أشكال جديدة من الكائنات المتداخلة. قم بتطبيق تأثيرات Pathfinder باستخدام قائمة Effects أو لوحة Pathfinder.

  • يمكن تطبيق تأثيرات Pathfinder في قائمة Effects على مجموعات، وطبقات، وكائنات نصية. بعد تطبيق التأثير، يظل بإمكانك تحديد الكائنات الأصلية وتحريرها. يمكنك أيضًا استخدام لوحة Appearance لتعديل التأثير أو إزالته. راجع ‏‫تطبيق تأثير Pathfinder باستخدام قائمة Effects.

  • يمكن تطبيق تأثيرات Pathfinder في لوحة Pathfinder على أي تركيبة من الكائنات، والمجموعات، والطبقات. يتم إنشاء تركيبة الشكل النهائي عندما تقوم بنقر فوق زر Pathfinder؛ بعد ذلك، لا يمكنك تحرير الكائنات الأصلية. إذا نتج عن التأثير كائنات متعددة، فإنها تُجمع مع بعضها تلقائيًا. راجع ‏‫تطبيق تأثير Pathfinder باستخدام لوحة Pathfinder‬.

تطبيق تأثير Pathfinder باستخدام قائمة Effects

  1. قم بتنفيذ أحد الإجراءات التالية:
    • قم بتجميع الكائنات التي تريد استخدامها مع بعضها، وحدد المجموعة.

      -أو-

    • انقل الكائنات التي تريد استخدامها إلى طبقة مستقلة، واستهدف الطبقة.

  2. اختر Effect > Pathfinder واختر تأثير Pathfinder.

    ملاحظة:

    لتقوم بتطبيق نفس تأثير Pathfinder مرة أخرى بسرعة، اختر Effect > Apply [التأثير].

تطبيق تأثير Pathfinder باستخدام لوحة Pathfinder

  1. حدد الكائنات التي تريد تطبيق التأثير عليها.

    لتطبق تأثير Pathfinder على مجموعة أو طبقة، استهدف المجموعة أو الطبقة.

  2. في لوحة Pathfinder، انقر فوق الزر مستكشف المسارات (في الصف الأسفل)، أو انقر مع الضغط على مفتاح Alt (في Windows) أو مفتاح Option (في Mac OS) فوق الزر Shape Mode (في الصف الأعلى).

ملخص تأثيرات Pathfinder

Add

يتتبع الحد الخارجي لكل الكائنات كما لو كانوا كائنًا واحد، ممزوجًا. يأخذ الشكل الناتج خصائص الطلاء للكائن الأعلى.

Intersect

يتتبع الحد الخارجي لمنطقة متداخلة من كل الكائنات.

Exclude

يتتبع المساحات غير المتداخلة من الكائنات، ويصنع المساحات المتداخلة شفافة. حيث عندما يتقاطع عدد زوجي من الكائنات، فإن التداخل يصبح شفافًا. حيث عندما يتقاطع عدد فردي من الكائنات، فإن التداخل يصبح معبأ.

Subtract

يستقطع الكائنات الأمامية من الكائنات الخلفية. يمكنك استخدام هذا الأمر لحذف مساحات من التصميم بضبط ترتيب التراص.

Minus Back

يستقطع الكائنات الموجودة في الخلف من الكائن الموجود في المقدمة. يمكنك استخدام هذا الأمر لحذف مساحات من التصميم بضبط ترتيب التراص.

Divide

يفصل قطعة من العمل الفني إلى أوجهها المعبأة بالمكونات (الوجه هو مساحة لا يمكن تقسيمها بمقطع خط).

ملاحظة: عند استخدام الزر Divide في لوحة Pathfinder، يمكنك استخدام أداة التحديد المباشر أو أداة التحديد الجماعي لمعالجة الأوجه الناتجة بشكل مستقل عن بعضها البعض. يمكنك أيضًا احتيار حذف الكائنات غير معبئة أو الاحتفاظ بها عند تطبيق أمر Divide.

قطع‬

يزيل الجزء المخفي من الكائن المعبأ. يزيل أي حدود ولا يمزج الكائنات ذات اللون نفسه.

Merge

يزيل جزءًا من الكائن المعبأ الذي يكون مخفيًا. يزيل أي حدود ويدمج أي كائنات مجاورة أو متراكبة معبأة باللون نفسه.

Crop

يقسم العمل الفني إلى أوجهه المعبأ بالمكونات، ثم يحذف كل أجزاء العمل الفني التي تقع خارج محيط الكائن الأعلى. كما يزيل أي حدود.

Outline

يقسم كائنًا إلى مقاطع الخط المكونة، أو الحواف. هذا الأمر يفيد في تجهيز العمل الفني الذي يحتاج ملاءمة لكائنات الطباعة الفوقية. راجع إنشاء طباعة متراكبة.

ملاحظة: عند استخدام الزر Outline في لوحة Pathfinder، يمكنك استخدام أداة التحديد المباشر أو أداة التحديد الجماعي لمعالجة كل حافة بشكل مستقل. يمكنك أيضًا اختيار حذف الكائنات غير المعبأة أو الاحتفاظ بها عند تطبيق أمر Outline.

Hard Mix

يدمج الألوان باختيار القيمة الأعلى لكل مكونات اللون. على سبيل المثال، إذا كان اللون 1 هو 20% سماوي، 66% أرجواني، 40% أصفر، و0% أسود، واللون 2 هو 40% سماوي، 20% أرجواني، 30% أصفر، و10% أسود، فإن اللون القوي الناتج هو 40% سماوي، 66% أرجواني، 40% أصفر، و10% أسود.

Soft Mix

يجعل الألوان السفلية مرئية خلال العمل الفني المتداخل، ثم يقسم الصورة إلى وجوه للمكون. يمكنك تحديد نسبة الرؤية التي تريدها في الألوان المتداخلة.

Trap

تعوض الفجوات المتوقعة بين الألوان في العمل الفني بإنشاء مساحة صغيرة من التداخل (تسمى الملاءمة) بين لونين مختلطين.

تجميع الكائنات باستخدام الأشكال المركبة

الشكل المركب هو رسم يمكن تحريره مكون من كائنين أو أكثر، كل منهما له صيغة شكل. الأشكال المركبة تسهل إنشاء أشكال معقدة لأنه يمكنك بدقة معالجة صيغة الشكل، وترتيب التراص، والشكل، والمكان، ومظهر كل مسار متضمن.

الأشكال المركبة تعمل ككائنات مجموعة وتظهر كعناصر <Compound Shape> في لوحة Layers. يمكنك استخدام لوحة Layers لتظهر، وتحدد، وتعالج محتويات شكل مركب - على سبيل المثال، لتغيير ترتيب تراص مكوناته. يمكنك أيضًا استخدام أداة Direct Selection tool المباشر أو أداة Group Selection tool لتحديد مكونات شكل مركب.

عندما تقوم بإنشاء شكل مركب، فإنه يأخذ خصائص الطلاء والشفافية الخاصين بالمكون، الأعلى في وضع Add، أو Intersect، أو Exclude. بالتسلسل، يمكنك تغيير خصائص الطلاء، النمط، أو الشفافية للشكل المكون. يسهل Illustrator هذه العملية باستهداف الشكل المركب بأكمله تلقائيًا عندما تحدد أي جزء منه، إلا إذا قمت باستهداف مكون في لوحة Layers بوضوح.

أشكال مركبة
العمل بالأشكال المركبة

A. الكائنات الأصلية B. شكل مركب تم إنشاؤه C. أوضاع الشكل المنفردة مطبقة على كل مكون D. نمط مطبق على شكل مركب بأكمله 

إنشاء شكل مركب

  1. حدد كل الكائنات التي تريد أن تكون جزءًا من الشكل المركب.

    يمكنك تضمين مسارات، ومسارات مركبة، ومجموعات، وأشكال مركبة أخرى، ومزجات، ونصوص، ومظاريف، والتفافات في شكل مركب. أي مسارات مفتوحة تقوم بتحديدها يتم إغلاقها تلقائيًا.

  2. قم بتنفيذ أحد الإجراءات التالية:
    • في لوحة Pathfinder، انقر مع الضغط على مفتاح Alt (في نظام windows) أو مفتاح Option (في نظام Mac OS) فوق الزر Shape Modes. يتم تعيين كل مكون من الشكل المركب في وضع الشكل الذي تحدده.

      -أو-

    • حدد Make Compound Shape من قائمة لوحة Pathfinder. يتم تعيين كل مكون من الشكل المركب في وضع Add بشكل افتراضي.

  3. قم بتغيير وضع شكل أي مكون بتحديده باستخدام أداة التحديد المباشر أو لوحة Layers والنقر فوق الزر Shape Mode.

    ملاحظة: لست بحاجة مطلقًا إلى تغيير وضع المكون الأخير، لأن وضعه لا يناسب الشكل المركب.

    ملاحظة:

    لدعم الأداء الأقصى، قم بإنشاء أشكال معقدة مركبة بتداخل أشكال مركبة أخرى (احتواء حتى 10 مكونات لكل واحد) بدلاً من استخدام العديد من المكونات المنفردة.

تعديل شكل مركب

  1. استخدم أداة Direct Selection tool أو لوحة Layers لتحديد مكونات منفردة لشكل مركب.
  2. ابحث عن الزر Shape Mode البارز في لوحة Pathfinder لتحديد أي وضع يتم تطبيقه حاليًا على مكون محدد.

    ملاحظة:

    إذا قمت بتحديد مكونين أو أكثر يستخدمان أوضاعًا مختلفة، تظهر علامة استفهام على أزرار Shape Mode.

  3. في لوحة Pathfinder، انقر فوق الزر Shape Mode المختلف.

تحرير وتوسيع شكل مركب

تحرير شكل مركب يفصله إلى كائنات مستقلة. يحافظ توسيع الشكل المركب على شكل الكائن المركب، لكن لم يعد بإمكانك تحديد المكونات المنفردة.

  1. حدد الشكل المركب باستخدام أداة Selection tool أو لوحة Layers.
  2. قم بتنفيذ أحد الإجراءات التالية:
    • انقر فوق Expand في لوحة Pathfinder.

      -أو-

    • اختر Expand Compound Shape من قائمة لوحة Pathfinder.

      يتم تحويل الشكل المركب إلى عنصر <Path> أو <Compound Path> في لوحة Layers، طبقًا لوضع الشكل الذي يستخدمه.

      -أو-

    • اختر Release Compound Shape من قائمة لوحة Pathfinder.

نقل أشكال مركبة بين Illustrator وPhotoshop

إن طبقات الشكل ومسارات قطع الطبقة (قناع متجه) في Adobe Photoshop هي أنواع من الأشكال المركبة. يمكنك إدراج طبقات شكل ومسارات طبقة قطع في Illustrator كأشكال مركبة لمعالجتها باستمرار. إضافةً إلى ذلك، أنه يمكنك تصدير أشكال مركبة إلى Photoshop. تذكر ما يلي عند استخدام أشكال مركبة مع Photoshop:

  • يتم تصدير الأشكال المركبة التي تكون في المستوى الأعلى من هيكل الطبقة فقط إلى Photoshop كطبقات شكل.

  • الشكل المركب المطلي المزود بحد يستخدم وصلة غير دائرية، أو بسُمك من عدد غير صحيح من النقاط، يتم تنقيطه عند تصديره إلى تنسيق ملفات PSD.

تجميع الكائنات باستخدام المسارات المركبة

إن المسار المركب يحتوي على مسارين أو أكثر مطليين بحيث تظهر الثقوب عند تداخل المسارات. عندما تقوم بتعريف كائنات على أنها مسار مركب، فإن كل الكائنات في المسار المركب تأخذ خصائص الطلاء والنمط لآخر كائن في ترتيب التراص.

المسارات المركبة تعمل ككائنات مجموعة وتظهر كعناصر <Compound Path> في لوحة Layers. استخدم أداة Direct Selection tool أو أداة Group Selection tool لتحديد مكونات مسار مركب. يمكنك معالجة شكل المكونات المنفردة للمسار المركب، لكن لا يمكنك تغيير خصائص المظهر، أو أنماط الرسوم، أو تأثيرات المكونات المنفردة، ولا يمكنك معالجة المكونات بشكل منفرد في لوحة Layers.

ملاحظة:

إذا كنت تريد المزيد من المرونة أثناء إنشاء المسارات المركبة، يمكنك إنشاء شكل مركب ثم توسيعه.

قص فراغ في كائن باستخدام مسار مركب

  1. حدد الكائن الذي تريد استخدامه كفراغ، وضعه حيث تريد أن يتداخل مع الكائن ليقصه. قم بتكرار أي كائنات إضافية تريد استخدامها كفراغات.
  2. حدد كل الكائنات التي تريد أن تكون جزءًا من المسار المركب.
  3. اختر Object > Compound Path > Make.

تطبيق قوانين التعبئة على مسارات مركبة

يمكنك تحديد إما أن يكون المسار المركب مسارًا متعرجًا غير صفري أو أن يكون مسارًا زوجيًا-فرديًا.

قاعدة تعبئة متعرجة غير صفرية

تستخدم معادلات رياضية لتحديد إذا ما كانت النقطة خارج أو داخل شكل ما. يستخدم Illustrator القاعدة المتعرجة غير الصفرية كقاعدة افتراضية.

Even-odd fill rule

تستخدم معادلات رياضية لتحديد إذا ما كانت النقطة خارج أو داخل شكل ما. هذه القاعدة يمكن توقع نتائجها لأن كل منطقة أخرى ضمن مسار مركب زوجي-فردي هي فراغ، بصرف النظر عن اتجاه المسار. تستخدم بعض التطبيقات، مثل Adobe Photoshop، قاعدة زوجي-فردي بشكل افتراضي؛ بحيث تستخدم المسارات المركبة المستوردة من تلك التطبيقات قاعدة زوجي-فردي.

المسارات ذاتية التقاطع هي مسارات تتقاطع مع نفسها. يمكنك أن تختار أن تصنع تلك المسارات إما بتعرج غير صفري أو زوجي-فردي، حسب الطريقة التي تريدها أن تبدو بها.

المسارات المركبة
مسار ذاتي التقاطع مع الخيار Use Non-Zero Winding Fill Rule (يسار) بالمقارنة مع الخيار Use Even-Odd Fill Rule (يمين)

عندما تقوم بإنشاء مسار مركب متعرج غير صفري، يمكنك تحديد ما إذا كنت تريد أن تظهر المسارات المتداخلة بفراغات أو معبئة من خلال النقر فوق الزر Reverse Path Direction في لوحة Attributes.

أربعة مسارات دائرية
قواعد التعبئة

A. أربعة مسارات دائرية B. مسارات دائرية محددة، محولة إلى مسار مركب C. الخيار Reverse Path Direction مطبق على المسار الداخلي 

تغيير قاعدة التعبئة لمسار مركب

  1. حدد المسار المركب باستخدام أداة Selection tool أو لوحة Layers.
  2. في لوحة Attributes، انقر فوق الزر Use Non-Zero Winding Fill Rule أو الزر Use Even-Odd Fill Rule.

تغيير المسار المركب ككل إلى مساحة معبئة

  1. تأكد من أن المسار المركب يستخدم قاعدة تعبئة متعرجة غير صفرية.
  2. باستخدام أداة التحديد المباشر، حدد جزءًا من المسار المركب ليتم عكسه. لا تقم بتحديد المسار المركب بأكمله.

  3. في لوحة Attributes، انقر فوق الزر Reverse Path Direction Off أو الزر Reverse Path Direction On.

إرجاع مسار مركب إلى مكوناته الأصلية

  1. حدد المسار المركب باستخدام أداة Selection tool أو لوحة Layers.
  2. اختر Object > Compound Path > Release

تم ترخيص هذا العمل بموجب الترخيص العام غير المعدل الخاص بالإسناد وعدم التجارة والمشاركة الإصدار 3.0 ‏من ‏‏Creative Commons‏‏  إن بنود Creative Commons لا تشمل منشورات Twitter™‎ وFacebook.

إشعارات قانونية   |   سياسة الخصوصية على الإنترنت