دليل المستخدم إلغاء

دمج البيانات باستخدام لوحة Variables

  1. دليل مستخدم Illustrator
  2. التعرف على Illustrator
    1. مقدمة عن Illustrator
      1. الجديد في Illustrator
      2. الأسئلة الشائعة
      3. متطلبات النظام لبرنامج Illustrator
      4. Illustrator لمعالجات Apple Silicon
    2. مساحة العمل
      1. أساسيات مساحة العمل
      2. تعلّم أسرع في لوحة Discover في Illustrator
      3. إنشاء المستندات
      4. شريط الأدوات
      5. اختصارات لوحة المفاتيح الافتراضية
      6. تخصيص اختصارات لوحة المفاتيح
      7. مقدمة حول اللوحات الفنية
      8. إدارة اللوحات الفنية
      9. تخصيص مساحة العمل
      10. اللوحة Properties
      11. تعيين التفضيلات
      12. مساحة العمل Touch
      13. دعم Microsoft Surface Dial في Illustrator
      14. التراجع عن عمليات التحرير وإدارة محفوظات التصميم
      15. Rotate view
      16. المساطر والشبكات والأدلة
      17. إمكانية الوصول في Illustrator
      18. الوضع الآمن
      19. عرض الأعمال الفنية
      20. استخدام Touch Bar مع Illustrator
      21. الملفات والقوالب
    3. الأدوات في Illustrator
      1. لمحة عامة عن الأدوات
      2. تحديد الأدوات
        1. Selection
        2. التحديد المباشر
        3. تحديد مجموعة
        4. Magic Wand
        5. Lasso
        6. Artboard
      3. أدوات التصفح
        1. Hand
        2. Rotate View
        3. Zoom
      4. أدوات الطلاء
        1. Gradient
        2. Mesh
        3. Shape Builder
      5. أدوات النص
        1. Type
        2. Type on a Path
        3. Vertical Type
      6. أدوات الرسم
        1. Pen
        2. Add Anchor Point
        3. Delete Anchor Point
        4. نقطة الإرساء
        5. Curvature
        6. مقطع الخط
        7. مستطيل
        8. Rounded Rectangle
        9. الشكل البيضاوي
        10. المضلع
        11. نجمة
        12. Paintbrush
        13. Blob Brush
        14. قلم رصاص
        15. Shaper
        16. Slice
      7. أدوات التعديل
        1. التدوير
        2. Reflect
        3. Scale
        4. Shear
        5. العرض
        6. Free Transform
        7. Eyedropper
        8. Blend
        9. Eraser
        10. Scissors
        11. Dimension
    4. تقنية الذكاء الاصطناعي التوليدي (غير متوفرة في البر الرئيسي للصين)
      1. إنشاء رسم متجه باستخدام موجه النص
      2. إعادة تلوين عملك الفني باستخدام موجه النص
    5. الإجراءات السريعة
      1. النص القديم
      2. نص توهج نيون
      3. نص المدرسة القديمة
      4. إعادة التلوين
      5. تحويل الرسم إلى متجه
  3. Illustrator على الويب (Beta)
    1. نظرة عامة على Illustrator على الويب (Beta)
    2. الأسئلة الشائعة عن Illustrator على الويب (Beta)
    3. الأسئلة المتداولة حول استكشاف الأخطاء وإصلاحها
    4. اختصارات لوحة المفاتيح‬ في Illustrator على الويب (Beta)
    5. إنشاء الأشكال ودمجها على الويب
    6. إضافة النص وتحريره على شبكة الإنترنت
    7. إضافة الألوان والمكونات على الويب
    8. رسم المسارات وتحريرها على الويب
    9. العمل باستخدام المستندات السحابية على الويب
    10. دعوة المتعاونين للتحرير على الويب
  4. Illustrator على iPad
    1. مقدمة حول Illustrator على iPad
      1. نظرة عامة على Illustrator على iPad
      2. الأسئلة المتداولة عن Illustrator على iPad
      3. متطلبات النظام | Illustrator على iPad
      4. ما يمكن القيام به وما لا يمكن القيام به باستخدام Illustrator على iPad
    2. مساحة العمل
      1. مساحة عمل Illustrator على iPad
      2. اختصارات اللمس والإيماءات ذات الصلة
      3. اختصارات لوحة المفاتيح‬ في Illustrator على iPad
      4. إدارة إعدادات تطبيقك
    3. Documents
      1. العمل باستخدام المستندات في Illustrator على iPad
      2. استيراد مستندات Photoshop وFresco
    4. تحديد الكائنات وترتيبها
      1. إنشاء كائنات تكرار
      2. مزج‬ الكائنات
    5. الرسم
      1. رسم المسارات وتحريرها
      2. رسم الأشكال وتحريرها
    6. الكتابة
      1. العمل باستخدام الكتابة والخطوط
      2. إنشاء تصميمات نصية على طول مسار
      3. إضافة الخطوط الخاصة بك
    7. العمل باستخدام الصور
      1. توجيه الصور النقطية
    8. اللون
      1. تطبيق الألوان والتدرجات اللونية
  5. المستندات السحابية
    1. الأساسيات
      1. العمل باستخدام مستندات Illustrator السحابية
      2. المشاركة والتعاون في مستندات Illustrator السحابية
      3. مشاركة المستندات للمراجعة
      4. ترقية التخزين السحابي لبرنامج Adobe Illustrator
      5. مستندات Illustrator السحابية | الأسئلة الشائعة
    2. استكشاف الأخطاء وإصلاحها
      1. استكشاف الأخطاء المتعلقة بإنشاء مستندات Illustrator السحابية أو حفظها وإصلاحها
      2. استكشاف مشكلات مستندات Illustrator السحابية وإصلاحها
  6. إضافة المحتوى وتحريره
    1. الرسم وعمل الأبعاد
      1. أساسيات الرسم
      2. تحرير المسارات
      3. إنشاء عمل فني عالي الدقة
      4. الرسم باستخدام الأداة Pen أو Curvature أو Pencil
      5. رسم الخطوط والأشكال البسيطة
      6. رسم شبكات مستطيلة وقطبية
      7. رسم التوهجات وتحريرها
      8. تتبع الصور
      9. تبسيط المسار
      10. أدوات الترميز ومجموعات الرموز
      11. ضبط مقاطع المسار
      12. تصميم زهرة في 5 خطوات سهلة
      13. إنشاء شبكة المنظور وتحريرها
      14. رسم الكائنات وتعديلها على شبكة المنظور
      15. استخدم الكائنات كرموز للاستخدام المتكرر
      16. رسم مسارات محاذاة البكسل لعمليات سير عمل الويب
      17. قياس الأبعاد ورسمها
    2. الكائنات ثلاثية الأبعاد والمواد
      1. حول التأثيرات ثلاثية الأبعاد في Illustrator
      2. إنشاء رسومات ثلاثية الأبعاد
      3. تعيين عمل فني على كائنات ثلاثية الأبعاد
      4. إنشاء نص ثلاثي الأبعاد
      5. إنشاء الكائنات ثلاثية الأبعاد
    3. اللون
      1. حول الألوان
      2. تحديد الألوان
      3. استخدام حوامل العيّنات وإنشاؤها
      4. ضبط الألوان
      5. استخدام لوحة Adobe Color Themes
      6. مجموعات الألوان (الألوان المتناسقة)
      7. لوحة Color Themes
      8. إعادة تلوين عملك الفني
    4. الرسم
      1. حول الطلاء
      2. التلوين باستخدام التعبئات والحدود
      3. مجموعات Live Paint
      4. Gradients
      5. الفُرش
      6. صيغ الشفافية والمزج
      7. تطبيق الحد على كائن
      8. إنشاء أنماط وتحريرها
      9. الشبكات
      10. Patterns
    5. تحديد الكائنات وترتيبها
      1. تحديد الكائنات
      2. الطبقات
      3. تجميع الكائنات وتوسيعها‬
      4. نقل الكائنات ومحاذاتها وتوزيعها
      5. تكديس الكائنات    
      6. إقفال الكائنات وإخفائها وحذفها
      7. نسخ الكائنات وتكرارها
      8. تدوير الكائنات وعكسها
      9. تشابك الكائنات
      10. إنشاء نماذج فنية واقعية
    6. إعادة تشكيل الكائنات
      1. اقتصاص الصور
      2. تحويل الكائنات
      3. تجميع الكائنات
      4. قص الكائنات واقتطاعها وتقسيمها
      5. أداة Puppet Warp
      6. تحديد حجم الكائنات، وقصها، وتشويهها
      7. مزج‬ الكائنات
      8. إعادة التشكيل باستخدام المظاريف
      9. إعادة تشكيل الكائنات باستخدام التأثيرات
      10. إنشاء أشكال جديدة باستخدام أداتي Shaper وShape Builder
      11. التعامل مع Live Corners
      12. تدفقات عمل تغيير الشكل المحسنة مع دعم اللمس
      13. تحرير أقنعة القطع
      14. الأشكال المباشرة
      15. إنشاء أشكال باستخدام الأداة Shape Builder
      16. التحرير العمومي
    7. Type
      1. إضافة النص والعمل على كائنات الكتابة
      2. إنشاء قوائم ذات تعداد نقطي ورقمي
      3. إدارة منطقة النص
      4. الخطوط والطباعة
      5. تحويل النص داخل الصور إلى نص قابل للتحرير
      6. إضافة التنسيق الأساسي إلى النص
      7. إضافة التنسيق المتقدم إلى النص
      8. استيراد نص وتصديره
      9. تنسيق الفقرات
      10. الحروف الخاصة
      11. إنشاء كتابة على مسار
      12. أنماط الفقرات والحروف
      13. علامات التبويب
      14. البحث عن الخطوط المفقودة (سير عمل Typekit)
      15. الكتابة بالعربية والعبرية
      16. الخطوط | الأسئلة المتداولة وتلميحات استكشاف الأخطاء وإصلاحها
      17. إنشاء تأثير نص ثلاثي الأبعاد
      18. التصميمات الطباعية الإبداعية
      19. تغيير حجم الكتابة وتدويرها
      20. المسافات بين الأسطر والحروف
      21. الوصل وفواصل الأسطر
      22. التدقيق الإملائي وقواميس اللغة
      23. تنسيق الحروف الآسيوية
      24. أدوات التأليف للبرامج النصية الآسيوية
      25. إنشاء التصميمات النصية باستخدام كائنات المزج
      26. إنشاء ملصق نصي باستخدام تتبع الصورة
    8. إنشاء تأثيرات خاصة
      1. استخدام التأثيرات
      2. أنماط الرسوم
      3. سمات المظهر
      4. إنشاء مخططات رسم وفسيفساء
      5. الظلال الخلفية، والتوهجات، وتدرج الحواف
      6. ملخص التأثيرات
    9. رسومات الويب
      1. أفضل الممارسات لإنشاء رسومات الويب
      2. Graphs
      3. SVG
      4. الشرائح وخرائط الصور
  7. الاستيراد، والتصدير، والحفظ
    1. Import
      1. وضع ملفات متعددة
      2. إدارة الملفات المرتبطة والمضمنة
      3. معلومات الارتباطات
      4. إلغاء تضمين الصور
      5. استيراد عمل فني من Photoshop
      6. استيراد صور نقطية
      7. استيراد ملفات Adobe PDF
      8. إدراج ملفات EPS، وDCS، وAutoCAD
    2. Creative Cloud Libraries في Illustrator 
      1. Creative Cloud Libraries في Illustrator
    3. حفظ
      1. حفظ عمل فني
    4. تصدير
      1. استخدام عمل Illustrator الفني في Photoshop
      2. تصدير العمل الفني
      3. تجميع الأصول والتصدير في مجموعات
      4. حزم الملفات
      5. إنشاء ملفات Adobe PDF
      6. استخراج CSS‏ | Illustrator CC
      7. خيارات Adobe PDF
      8. اللوحة Document Info
  8. الطباعة
    1. الإعداد للطباعة
      1. إعداد المستندات للطباعة
      2. تغيير حجم الصفحة واتجاهها
      3. تعيين علامات قطع للقص أو المحاذاة
      4. بدء العمل باستخدام لوحة فنية كبيرة
    2. الطباعة
      1. الطباعة المتراكبة
      2. الطباعة باستخدام إدارة الألوان
      3. طباعة PostScript
      4. الإعدادات المسبقة للطباعة
      5. علامات الطابعة والتسييل
      6. طباعة العمل الفني الشفاف وحفظه
      7. التراكب
      8. طباعة رقائق فصل الألوان
      9. طباعة التدرجات، والشبكات، ومزيج الألوان
      10. الطباعة المتراكبة البيضاء
  9. تشغيل المهام تلقائيًا
    1. دمج البيانات باستخدام لوحة Variables
    2. التشغيل التلقائي باستخدام البرامج النصية
    3. التشغيل التلقائي باستخدام الإجراءات
  10. استكشاف الأخطاء وإصلاحها 
    1. المشكلات المعروفة
    2. مشكلات الأعطال
    3. استعادة الملفات بعد التعطل
    4. مشكلات الملفات
    5. تنسيقات الملفات المعتمدة
    6. مشكلات برنامج تشغيل جهاز وحدة معالجة الرسومات‬
    7. مشكلات أجهزة Wacom
    8. مشكلات ملفات DLL
    9. مشكلات الذاكرة
    10. مشكلات ملفات التفضيلات
    11. مشكلات الخطوط
    12. مشكلات الطابعة
    13. مشاركة تقرير الأعطال مع Adobe
    14. تحسين أداء Illustrator

ادمج أحد مستندات Illustrator مع ملف مصدر بيانات (CSV أو XML) من خلال لوحة Variables، لإنشاء أشكال متنوعة عديدة من عملك الفني. يمكنك تغيير أسماء المشاركين على شارات الحدث، أو تغيير الصور عبر شعارات الويب والبطاقات البريدية، دون الحاجة إلى إعادة عملك الفني. قم بإنشاء تصميم واحد ثم إنتاج أشكال متنوعة بشكل سريع عن طريق استيراد الأسماء أو الصور من ملف مصدر بيانات.

قم بإنشاء تنويعات مخصصة لقالب تصميمك لكائنات مختلفة، مثل ملصقات قابلة للطباعة، وشعارات ويب، وشارات أحداث، باستخدام لوحة Variables.

قبل المتابعة

كل ما تحتاجه لدمج البيانات هو ملف مصدر بيانات ومستند مستهدف. 

  • يحتوي ملف مصدر البيانات على معلومات تتباين في كل إصدار من المستند الهدف، مثل الأسماء والصور وعناوين المرسل إليهم نموذج رسالة. يمكن أن يكون ملف مصدر البيانات في تنسيق ملف مفصول بفاصلة (.csv) أو لغة التمييز القابلة للامتداد (.xml).
  • يعتبر المستند الهدف أحد مستندات Illustrator الذي يحتوي على العمل الفني الأساسي لاستخدامه كقالب. يمكن أن يحتوي هذا المستند على العنصر النائب لحقل البيانات والعناصر التي تظل كما هي في كل إصدار من المستند المدمج.

الوصول إلى وظيفة دمج البيانات

يمكن الوصول إلى وظيفة دمج البيانات من لوحة Variables في Illustrator (Window > Variables). تسرد اللوحة نوع كل متغير واسمه في المستند. إذا كان المتغير مرتبطًا بكائن، يعرض العمود Objects عندئذٍ اسم الكائن المرتبط كما يظهر في اللوحة Layers. يمكنك ترتيب الصفوف بالنقر فوق عناصر شريط الرأس: حسب اسم المتغير أو اسم الكائن أو نوع المتغير.

اللوحة Variables

A. مجموعة بيانات B. قائمة اللوحة C. التبديل بين مجموعات البيانات D. اسم الكائن المرتبط E. اسم المتغير F. نوع المتغير G. تأمين المتغيرات H. تحويل كائن إلى كائن ديناميكي I. تحويل الوضوح إلى ديناميكي J. فك ارتباط المتغيرات K. إنشاء المتغيرات L. حذف المتغيرات 

الخطوات السريعة لدمج البيانات

  1. قم بإنشاء مستند Illustrator لاستخدامه ليكون القالب.

  2. قم بإعداد ملف البيانات المصدر بتنسيق CSV أو XML. للحصول على مزيد من المعلومات، راجع إعداد ملف مصدر بيانات.

  3. قم باستيراد ملف مصدر بيانات في Illustrator باستخدام لوحة Variables. للحصول على مزيد من المعلومات، راجع استيراد ملف مصدر بيانات.

  4. قم بربط متغير بكائن في القالب الخاص بك. لمزيد من المعلومات، راجع ربط المتغيرات والكائنات.

  5. قم بمعاينة المستند مع كل مجموعة بيانات قبل تصدير جميع الملفات. للحصول على مزيد من المعلومات، راجع معاينة المستند مع كل مجموعة بيانات.

  6. قم بتصدير مجموعة من الملفات من البيانات باستخدام لوحة Actions في Illustrator. لمزيد من المعلومات، راجع تصدير الملفات باستخدام لوحة Actions.

إعداد ملف مصدر بيانات

يجب حفظ ملفات مصدر البيانات في تنسيق مقسوم بفاصلة (.csv) أو لغة التمييز القابلة للامتداد (.xml).

إعداد ملفات مصدر CSV

في ملف مقسوم بفاصلة (.csv)، تكون السجلات مفصولة عن بعضها البعض بفواصل فقرات، والحقول مفصولة بفاصلة أو بحرف جدولة. يمكن أن يحتوي ملف مصدر البيانات أيضًا على نصوص أو مسارات ترى الصور على القرص. قبل استيراد ملف CSV، قم بما يلي لتسمح لبرنامج Illustrator بتحديد نوع المتغير.

  1. افتح جدول البيانات.

  2. حدد اسم حقل البيانات في الصف الأول من جدول البيانات. ثم قم بما يلي:

    • في بداية اسم حقل البيانات، اكتب رمز (@) الخاص بعلامة "at" لإدخال مسار يشير إلى ملفات الصور. رمز @ مطلوب في السطر الأول فقط، وينبغي أن تحتوي السطور التالية على مسارات الصور.
    • بالمثل، في بداية اسم حقل البيانات، اكتب رمز "النسبة" (%) للرسومات ورمز "علامة التجزئة" (#) للوضوح.
    • لتحديد رؤية كائن ما، حدد صواب أو خطأ لكل حقل بيانات.
    ملاحظة:
    • يجب ألا تحتوي أسماء حقول البيانات في جدول البيانات على مسافات فارغة. على سبيل المثال، يمكنك تحديد حقل البيانات في صورة اسم_الشركة بدلاً من اسم الشركة
    • وبالمثل، يجب ألا تحتوي المسارات التي تشير إلى الصور وملفات الرسم البياني على أية مسافات فارغة. على سبيل المثال، يجب أن يكون مسار ملف الصورة C:\Photos\BillTucker بدلاً من C:\Photos\Bill Tucker.
    • يجب حفظ كل ملفات الرسومات البيانية المرتبطة من ملف مصدر البيانات كملفات منتهية بعلامة فاصلة (.csv).
    • إذا وجدت رسالة خطأ عندما تقوم بكتابة علامة @ في بداية الحقل، اكتب علامة (') قبل علامة @، على سبيل المثال '@Photos) للتحقق من الدالة. بعض التطبيقات، مثل Microsoft Excel، تستعمل علامة @ للدوال الخاصة بها.

    (في حالة نظام التشغيل Windows) مثال لمراجع صور ورسومات في ملف مصدر البيانات

    الاسم

    السن

    مكان الصور

    %الرسومات البيانية

    #Visibility

    Bill Tucker

    36

    C:\Photos\BillTucker.jpg

    C:\Photos\BillTucker.csv

    صواب

    Dat Nguyen

    53

    C:\MyDocuments\dat.jpg

    C:\MyDocuments\dat.csv

    صواب

    Maria Ruiz

    26

    C:\Photos\Ruiz.jpg

    C:\Photos\Ruiz.csv

    خطأ

    (في حالة نظام التشغيل macOS) مثال لمراجع صور ورسومات في ملف مصدر البيانات

    الاسم

    السن

    مكان الصور

    %الرسومات البيانية

    #Visibility

    Bill Tucker

    36

    /Users/photos/BillTucker.jpg

    /Users/photos/BillTucker.csv

    صواب

    Dat Nguyen

    53

    /Users/family/photos/dat.jpg

    /Users/family/photos/dat.csv

    صواب

    Maria Ruiz

    26

    /Users/alpha/photos/Ruiz.jpg

    /Users/alpha/photos/Ruiz.csv

    خطأ

  3. أدخل بياناتك في جدول البيانات.

  4. قم بتنفيذ أحد الإجراءات التالية:

    • قم بحفظ جداول البيانات التي تم إنشاؤها باستخدام أحدث إصدار من Microsoft Excel (إصدار 2016) إلى تنسيقات الملفات التالية:
      • CSV (مفصول بفاصلة) (*.csv)
      • CSV (MS-DOS) ‏(*.csv)
    • قم بحفظ جداول البيانات التي تم إنشاؤها باستخدام Apple Numbers إلى تنسيق CSV من خلال ترميز Unicode ‏(UTF-8‏).
    ملاحظة:

    حاليا، يتم دعم ملفات CSV التي تم تصديرها في التنسيقات المذكورة أعلاه في Illustrator. تنسيقات ملفات CSV الأخرى مثل Macintosh Comma Separated ‏(.csv) غير مدعومة لدمج البيانات.

إعداد ملف XML

  1. قم بتعريف متغير في مستندك. للحصول على تفاصيل، راجع ربط المتغيرات والكائنات.

  2. حدد الزر Capture Data Set  في لوحة Variables.

  3. بعد إنشاء العدد المطلوب من مجموعات البيانات، حدد Save Variable Library من قائمة لوحة Variables لحفظ مجموعات البيانات كملف XML. حدد اسم الملف والمكان، وحدد Save.

    تصدير المتغيرات التي قمت بإنشائها في Illustrator كملف XML

  4. قم الآن بتحرير ملف XML في تطبيق تحرير نص مثل Notepad ++ ‏(Windows) أو TextWrangler ‏(macOS) لتضمين مجموعات البيانات الخاصة بك في هذا الملف.

    مثال: تحرير ملف XML باستخدام أي تطبيق لتحرير النصوص

    A. استبدال مسار الصورة B. استبدال سلسلة النص  

  5. حدد Load Variable Library من قائمة لوحة Variables لاستيراد ملف XML في Illustrator. حدد ملف XML، وحدد Open.

    استيراد متغيرات إلى Illustrator

استيراد ملف مصدر بيانات

لربط المتغيرات بالبيانات المرغوبة، قم باستيراد مصدر بيانات في لوحة Variables. يمكن أن يكون لديك ملف مصدر بيانات واحد يتم تحديده لكل مستند.

  1. اختر Window > Variables.

  2. في لوحة Variables، حدد Import.

  3. في مربع حوار Load Variable Library حدد ملف مصدر بيانات بتنسيق CSV أو XML ثم حدد Open.

  4. يمكنك تحرير مجموعة البيانات أو إعادة تسميتها أو حذفها لاحقاً باختيارها أولاً من قائمة Data Set المنبثقة وتحرير خياراتها.

    • حدد مجموعة بيانات من القائمة Data Set في اللوحة Variables. يمكنك أيضًا تحديد الزر Previous Data Set  أو الزر Next Data Set .
    • لتطبيق البيانات الموجودة على لوحة الرسم على مجموعة البيانات الحالية، اختر Update Data Set  من قائمة اللوحة Variables.
    • لإعادة تسمية مجموعة بيانات، حرر النص مباشرة في مربع النص Data Set. يمكنك أيضًا النقر بشكل مزدوج فوق الكلمات Data Set (على يسار مربع النص Data Set)، ثم أدخل اسمًا جديدًا وحدد OK.
    • لحذف مجموعة بيانات، حدد أيقونة Delete. يمكنك أيضًا تحديد Delete Data Set من قائمة لوحة Variables.
    ملاحظة:

    لا يمكن استيراد ملفات CSV (محددة بفاصلة UTF-8) التي تحتوي على أحرف مزدوجة البايت التي تم إنشاؤها من خلال Excel في لوحة Variables. إذا قمت بفتح نفس الملف بتنسيق نصي ثم قمت بحفظه بتنسيق CSV بترميز UTF-8، فسيتم استيراد الملف بشكل صحيح.

ربط المتغيرات بالكائنات

استخدم المتغيرات لتحديد العناصر التي تريد تغييرها في القالب. يمكنك تعريف أربعة أنواع من المتغيرات وهي: متغير Visibility ومتغير Text String ومتغير Linked File ومتغير Graph Data. يشير نوع المتغير إلى خصائص الكائن القابلة للتغيير (الديناميكية). تسرد اللوحة نوع كل متغير واسمه في المستند. إذا كان المتغير مرتبطًا بكائن، يعرض العمود Objects عندئذٍ اسم الكائن المرتبط كما يظهر في اللوحة Layers.

نوع المتغير

أيقونة للإشارة إلى نوع المتغير

التعريف

متغيرات Visibility

إظهار العمل الفني أو إخفاؤه.

متغيرات Text String

استبدال سلسلة نص.

متغيرات Linked File

استبدال الكائن في لوحة الرسم بكائن من ملف آخر.

متغيرات Graph Data

استبدال القيم في رسم.

المتغير No Type (غير مرتبط)

غير مرتبط بأي كائن.

اتبع الخطوات التالية لتعريف المتغيرات في Illustrator:

  1. حدد كائنًا.

  2. في لوحة Variables (Window > Variables)، حدد المتغير الذي تريد ربطه به.

  3.  حدد الزر Make Object Dynamic  لربط الكائن بالمتغير.

اتبع الخطوات التالية لإنشاء متغير بدون ربطه بكائن:

  1. حدد الزر New Variable  في لوحة Variables.

  2. لربط أحد الكائنات بالمتغير بشكل متسلسل، حدد الكائن والمتغير ثم حدد الزر Make Visibility Dynamic  أو الزر Make Object Dynamic .

ملاحظة:

لا تدعم أسماء المتغيرات الزوج البديل والأحرف المكونة من 4 بايت. إذا كنت تستخدم هذه الأحرف في اسم متغير، فسيتم عرض رسالة خطأ.

العمل مع المتغيرات

يمكنك تحرير اسم متغير أو نوعه وفك ارتباط متغير فضلاً عن تأمين متغير باستخدام اللوحة Variables.

يؤدي فك ارتباط متغير إلى كسر الرابط بين المتغير وكائنه. بينما يمنعك تأمين المتغيرات من إنشاء خيارات المتغيرات وحذفها وتحريرها. ومع ذلك، يمكنك ربط كائنات بمتغيرات مؤمنة وفك تأمينها كذلك.

تغيير اسم متغير ونوعه

  1. حدد المتغير في اللوحة Variables ثم حدد Variable Options من قائمة اللوحة.

فك ارتباط متغير

  1. حدد الزر Unbind Variable  في لوحة Variables.

تأمين كل المتغيرات في مستند وإلغاء تأمينها

  1. حدد الزر Lock Variables  أو الزر Unlock Variablesفي لوحة Variables.

حذف المتغيرات

يؤدي حذف متغير إلى إزالته من اللوحة Variables. في حالة حذف متغير مرتبط بكائن ما، يصبح الكائن ثابتًا (إلا إذا كان الكائن مرتبطًا كذلك بمتغير من نوع مختلف).

  1. حدد متغيرًا تريد حذفه.

  2. اتبع أي خيار من الخيارات التالية:

    • حدد الزر Delete Variable  في لوحة Variables.

    • لحذف المتغير بدون تأكيد، اسحبه إلى الزر Delete Variable .

تحرير كائن ديناميكي

يمكنك تغيير البيانات المرتبطة بمتغير ما بتحرير الكائن المرتبطة به. على سبيل المثال، إذا كنت تعمل بأحد متغيرات Visibility فإنك تغير في حالة رؤية الكائن، في اللوحة Layers. يتيح لك تحرير الكائنات الديناميكية إنشاء مجموعات بيانات متعددة لاستخدامها في القالب.

  1. حدد كائنًا ديناميكيًا على لوح الرسم، أو قم بتنفيذ أحد الإجراءات التالية لتحدد كائنًا ديناميكيًا:

    • انقر مع الضغط على مفتاح Alt (في Windows) أو Option‑click (في macOS) فوق أحد المتغيرات في اللوحة Variables.

    • حدد أحد المتغيرات من اللوحة Variables ثم حدد Select Bound Object من قائمة لوحة Variables.

    • حدد All Bound Objects من قائمة لوحة Variables لتحديد جميع الكائنات المتحركة.

  2. حرر البيانات المرتبطة بالكائن كما يلي:

    • حرر الجملة النصية على لوح الرسم.

    • استبدل الصورة بلوحة Links أو أمر File > Place للملفات المرتبطة.

    • حرر البيانات للرسومات في مربع حوار Graph Data.

    • بالنسبة للكائنات ذات الرؤية الديناميكية، قم بتغيير حالة الرؤية للكائن من اللوحة Layers.

تعريف الكائنات الديناميكية باستخدام معرفات XML

تعرض اللوحة Variables أسماء الكائنات الديناميكية كما تظهر في اللوحة Layers. في حالة حفظ القالب بتنسيق SVG لاستخدامه مع منتجات Adobe أخرى، فإن أسماء تلك الكائنات يجب أن تتوافق مع اصطلاحات تسمية XML. فعلى سبيل المثال، يجب أن تبدأ أسماء XML بحرف، ثم شرطة سفلية أو نقطتين رأسيتين، ولا يمكن أن تحتوي على مسافات.

يقوم Illustrator تلقائيًا بتعيين معرف XML سليم لكل كائن ديناميكي تقوم بإنشائه. لعرض أسماء الكائنات وتحريرها وتصديرها باستخدام معرفات XML، اختر Edit > Preferences > Units (في Windows) أو Illustrator > Preferences > Units (في Mac OS)، ثم حدد معرف XML.

معاينة المستند مع كل مجموعة بيانات

للاطلاع على المظهر النهائي للرسومات، يمكنك المعاينة قبل تصدير كل الملفات. استخدم مفاتيح الأسهم بجانب Data Set في اللوحة Variables للتنقل ومعاينة مجموعة البيانات المرغوبة في المستند.

تصدير الملفات باستخدام لوحة Actions

بعد الانتهاء من تحديد المتغيرات ومجموعة بيانات واحدة أو أكثر، يمكنك إخراج العمل الفني في صيغة الحزمة، باستخدام قيم مجموعات البيانات. قم بما يلي:

  1. باستخدام لوحة Actions (Window > إجراءات)، قم بتسجيل إجراء لحفظ المستند الخاص بك بالتنسيق المرغوب. لمزيد من التفاصيل، راجع التشغيل التلقائي من خلال الإجراءات.

  2. اختر Batch من قائمة لوحة Actions وحدد الإجراء الذي أنشأته في الخطوة السابقة.

  3. بالنسبة لـ Source، حدد Data Sets لتشغيل إجراء على كل مجموعة بيانات في الملف الحالي.

  4. بالنسبة لـ Destination، حدد ما تريد فعله بالملفات المعالجة. يمكنك ترك الملفات مفتوحة بدون حفظ التغيرات (None) أو حفظ الملف وإغلاقه في مكانه الحالي (Save And Close) أو حفظ الملف في مكان مختلف (Folder).

    يمكنك إعداد الخيارات الإضافية لحفظ الملفات حسب خيار Destination. لمزيد من المعلومات، راجع تشغيل إجراء على مجموعة من الملفات.

  5. حدد OK.

حفظ قالب لدمج البيانات

عند تعريف متغيرات في مستند Illustrator، فإنك تُنشئ قالبًا لدمج البيانات. يمكنك حفظ القالب بتنسيق SVG لاستخدامه مع منتجات Adobe الأخرى، مثل Adobe® Graphics Server. على سبيل المثال، يمكن للمطور الذي يستخدم Adobe Graphics Server في عمله ربط المتغيرات في ملف SVG مباشرةً بقاعدة بيانات أو مصدر بيانات آخر.

  1. اختر File > Save As و أدخل اسم ملف وحدد SVG كتنسيق للملف، ثم انقر فوق Save.

  2. انقر فوق More Options، وحدد Include Adobe Graphics Server Data. يؤدي هذا الخيار إلى تضمين كل المعلومات المطلوبة لاستبدال المتغير في ملف SVG.

  3. انقر فوق OK.

هل تواجه مشكلات أثناء استيراد ملف CSV؟

إذا كنت تتلقى الخطأ: The incoming variable library is invalid أثناء تحميل ملف مصدر بيانات CSV، فتحقق مما يلي:

  • ملف CSV الخاص بك ليس فارغًا.
  • يتم حفظ جداول البيانات التي قمت بإنشائها باستخدام أحدث إصدار من Microsoft Excel كملف CSV (منتهي بعلامة فاصلة) (*.csv) أو CSV (MS-DOS) ‏(*.csv) ويتم حفظ تلك التي تم إنشاؤها باستخدام Apple Numbers بتنسيق CSV بترميز Unicode ‏(UTF-8). لا يتم دعم ملفات مصدر البيانات بأي تنسيق ملف مثل Macintosh Comma Separated ‏(*.csv) لدمج البيانات.
  • تحتوي كل الأعمدة على اسم حقل بيانات. على سبيل المثال ، يعرض Illustrator رسالة الخطأ عند احتواء أحد الأعمدة في ملف مصدر البيانات على بيانات ولكن لا يحتوي على اسم حقل بيانات.
  • لا يحتوي ملف مصدر البيانات على عمود فارغ بين أي أعمدة مملوءة. على سبيل المثال ، يعرض Illustrator رسالة الخطأ عند احتواء العمودين B وD في ملف مصدر البيانات على بيانات ولكن العمود C فارغ
مثال: الأخطاء أثناء إعداد ملف مصدر CSV لدمج البيانات

A. اسم حقل البيانات مفقود لعمود B. هناك عمود فارغ بين الأعمدة المملوءة 

  • لا تحتوي أسماء حقول البيانات في جدول البيانات على أي مسافات فارغة.
  • يجب ألا تحتوي المسارات التي تشير إلى الصور وملفات الرسم البياني في ملف المصدر على أية مسافات فارغة.
  • يتم حفظ كل ملفات الرسومات البيانية المرتبطة من ملف مصدر البيانات كملفات منتهية بعلامة فاصلة (.csv).

الموارد ذات الصلة

تواصل معنا

نحن نحب أن نسمع منك. شارك أفكارك مع مجتمع Adobe Illustrator

 Adobe

احصل على مساعدة بشكل أسرع وأسهل

مستخدم جديد؟