Kullanıcı Kılavuzu İptal

Web grafikleri oluşturmak için en iyi uygulamalar

  1. Illustrator Kullanıcı Kılavuzu
  2. Illustrator’ı tanıyın
    1. Illustrator’a giriş
      1. Illustrator’daki yenilikler
      2. Yaygın sorular
      3. Illustrator sistem gereksinimleri
      4. Apple silicon için Illustrator
    2. Çalışma alanı
      1. Çalışma alanı ile ilgili temel bilgiler
      2. Illustrator'daki Keşfedin paneli ile daha hızlı öğrenin
      3. Belge oluşturma
      4. Araç çubuğu
      5. Varsayılan klavye kısayolları
      6. Klavye kısayollarını özelleştirme
      7. Çalışma yüzeylerine giriş
      8. Çalışma yüzeylerini yönetme
      9. Çalışma alanını özelleştirme
      10. Özellikler paneli
      11. Tercihleri ayarlama
      12. Dokunmatik Çalışma Alanı
      13. Illustrator’da Microsoft Surface Dial desteği
      14. Düzenlemeleri geri alma ve tasarım geçmişini yönetme
      15. Görünümü döndürme
      16. Cetveller, ızgaralar ve kılavuzlar
      17. Illustrator’da erişilebilirlik
      18. Güvenli Mod
      19. Çizimi görüntüleme
      20. Illustrator’ı Touch Bar ile kullanma
      21. Dosyalar ve şablonlar
    3. Illustrator’da araçlar
      1. Bir bakışta araçlar
      2. Seçme araçları
        1. Seçim
        2. Doğrudan Seçim
        3. Grup Seçimi
        4. Sihirli Değnek
        5. Kement
        6. Çalışma Yüzeyi
      3. Gezinme araçları
        1. El
        2. Görünümü Döndür
        3. Yakınlaştır
      4. Boyama araçları
        1. Degrade
        2. Kafes
        3. Şekil Oluşturucu
      5. Metin araçları
        1. Yazım
        2. Yola Yazma
        3. Dikey Metin
      6. Çizim araçları
        1. Kalem
        2. Bağlantı Noktası Ekle
        3. Bağlantı Noktasını Sil
        4. Bağlantı Noktası
        5. Kavis
        6. Çizgi Parçası
        7. Dikdörtgen
        8. Yuvarlak Köşeli Dikdörtgen
        9. Elips
        10. Çokgen
        11. Yıldız
        12. Boya Fırçası
        13. Kabarcık Fırçası
        14. Kurşun Kalem
        15. Shaper
        16. Dilim
      7. Değiştirme araçları
        1. Döndür
        2. Yansıtma
        3. Ölçek
        4. Yamultma
        5. Genişlik
        6. Serbest Dönüştürme
        7. Damlalık
        8. Karışım
        9. Silgi
        10. Makas
    4. Hızlı eylemler
      1. Retro metni
      2. Neon ışıması metni
      3. Eski tip metin
      4. Yeniden Renklendir
      5. Taslağı vektöre dönüştür
  3. iPad’de Illustrator
    1. iPad’de Illustrator uygulamasına giriş
      1. iPad’de Illustrator’a genel bakış
      2. iPad’de Illustrator ile ilgili SSS
      3. Sistem gereksinimleri | iPad’de Illustrator
      4. iPad’de Illustrator uygulamasında yapabilecekleriniz veya yapamayacaklarınız
    2. Çalışma alanı
      1. iPad’de Illustrator çalışma alanı
      2. Dokunmatik kısayollar ve dokunma hareketleri
      3. iPad’de Illustrator için klavye kısayolları
      4. Uygulama ayarlarınızı yönetme
    3. Belgeler
      1. iPad’de Illustrator uygulamasında belgelerle çalışma
      2. Photoshop ve Fresco belgelerini içe aktarma
    4. Nesneleri seçme ve düzenleme
      1. Tekrar nesneleri oluşturma
      2. Nesneleri karıştırma
    5. Çizim yapma
      1. Yolları çizme ve düzenleme
      2. Şekil çizme ve düzenleme
    6. Yazım
      1. Yazım ve fontlarla çalışma
      2. Yol boyunca metin tasarımları oluşturma
      3. Kendi fontlarınızı ekleme
    7. Görüntülerle çalışma
      1. Raster görüntüleri vektörleştirme
    8. Renk
      1. Renkleri ve degradeleri uygulama
  4. Bulut belgeleri
    1. Temel bilgiler
      1. Illustrator bulut belgeleriyle çalışma
      2. Illustrator bulut belgelerini paylaşma ve bu belgelerde iş birliği yapma
      3. Belgeleri inceleme için paylaşma
      4. Adobe Illustrator için bulut depolama alanını yükseltme
      5. Illustrator bulut belgeleri | Yaygın sorular
    2. Sorun giderme
      1. Illustrator bulut belgelerinde oluşturma veya kaydetme sorunlarını giderme
      2. Illustrator bulut belgelerinde sorun giderme
  5. İçerik ekleme ve düzenleme
    1. Çizim yapma
      1. Çizim hakkında temel bilgiler
      2. Yolları düzenleme
      3. Piksel bakımından kusursuz resimler çizme
      4. Kalem, Kavis veya Kurşun Kalem aracıyla çizim yapma
      5. Basit çizgiler ve şekiller çizme
      6. Görüntü İzleme
      7. Yolu basitleştirme
      8. Perspektif ızgaralarını tanımlama
      9. Sembolizm araçları ve sembol kümeleri
      10. Yol parçalarını ayarlama
      11. 5 kolay adımda çiçek tasarlama
      12. Perspektif çizimi
      13. Semboller
      14. Web iş akışları için pikselle hizalanmış yollar çizme
    2. 3D nesneler ve malzemeler
      1. Illustrator’daki 3D efektler hakkında
      2. 3D grafikler oluşturma
      3. 3D nesneler üzerinde çizimi eşleme
      4. 3D metin oluşturma
    3. Renk
      1. Renk hakkında
      2. Renk seçme
      3. Renk örnekleri oluşturma ve kullanma
      4. Renkleri ayarlama
      5. Adobe Color Temaları panelini kullanma
      6. Renk grupları (renk uyumları)
      7. Renk Temaları paneli
      8. Çiziminizi yeniden renklendirme
    4. Boyama
      1. Boyama hakkında
      2. Dolgularla ve konturlarla boyama
      3. Canlı Boyama grupları
      4. Degradeler
      5. Fırçalar
      6. Saydamlık ve karıştırma modları
      7. Nesneye kontur uygulama
      8. Desen oluşturma ve düzenleme
      9. Kafesler
      10. Desenler
    5. Nesneleri seçme ve düzenleme
      1. Nesneleri seçme
      2. Katmanlar
      3. Nesneleri gruplama ve genişletme
      4. Nesneleri taşıma, hizalama ve dağıtma
      5. Nesneleri yığınlama    
      6. Nesneleri kilitleme, gizleme ve silme
      7. Nesneleri kopyalama ve çoğaltma
      8. Nesneleri döndürme ve yansıtma
      9. Nesnelere örgü uygulama
    6. Nesneleri yeniden şekillendirme
      1. Görüntüleri kırpma
      2. Nesneleri dönüştürme
      3. Nesneleri birleştirme
      4. Nesneleri kesme, bölme ve kırpma
      5. Kukla Çarpıt
      6. Nesneleri ölçekleme, yamultma ve deforme etme
      7. Nesneleri karıştırma
      8. Zarflar kullanarak yeniden şekillendirme
      9. Nesneleri efektlerle yeniden şekillendirme
      10. Shaper ve Şekil Oluşturucu araçlarını kullanarak yeni şekiller oluşturma
      11. Canlı Köşeler ile çalışma
      12. Dokunma desteği ile geliştirilmiş yeniden şekillendirme iş akışları
      13. Kırpma maskelerini düzenleme
      14. Canlı şekiller
      15. Şekil Oluşturucu aracını kullanarak şekiller oluşturma
      16. Genel düzenleme
    7. Yazım
      1. Metin ekleme ve yazım nesneleriyle çalışma
      2. Madde işaretli ve numaralandırılmış listeler oluşturma
      3. Metin alanını yönetme
      4. Fontlar ve tipografi
      5. Yazımı formatlama
      6. Metni içe ve dışa aktarma
      7. Paragrafları formatlama
      8. Özel karakterler
      9. Yola yazma oluşturma
      10. Karakter ve paragraf stilleri
      11. Sekmeler
      12. Metin ve yazım
      13. Eksik fontları bulma (Typekit iş akışı)
      14. Illustrator 10 metnini güncelleme
      15. Arapça ve İbranice fontlar
      16. Fontlar | SSS ve sorun giderme ipuçları
      17. 3D metin efekti oluşturma
      18. Kreatif tipografi tasarımları
      19. Yazımı ölçekleme ve döndürme
      20. Satır ve karakter aralığı
      21. Tireleme ve satır sonları
      22. Metin geliştirmeleri
      23. Yazım ve dil sözlükleri
      24. Asya dillerindeki karakterleri formatlama
      25. Asya dillerinde metinler için oluşturucular
      26. Karışım nesneleri ile metin tasarımları oluşturma
      27. Görüntü İzleme’yi kullanarak metin posteri oluşturma
    8. Özel efektler oluşturma
      1. Efektlerle çalışma
      2. Grafik stilleri
      3. Alt gölge oluşturma
      4. Görünüm nitelikleri
      5. Taslaklar ve mozaikler oluşturma
      6. Alt gölgeler, ışımalar ve geçiş yumuşatma
      7. Efektler özeti
    9. Web grafikleri
      1. Web grafikleri oluşturmak için en iyi uygulamalar
      2. Grafikler
      3. SVG
      4. Animasyon oluşturma
      5. Dilimler ve görüntü eşlemeleri
  6. İçe aktarma, dışa aktarma ve kaydetme
    1. İçe aktarma
      1. Birden çok dosya yerleştirme
      2. Bağlantılı ve gömülü dosyaları yönetme
      3. Bağlantı bilgileri
      4. Gömülü görüntüleri çıkarma
      5. Photoshop’tan çizimleri içe aktarma
      6. Bitmap görüntüleri içe aktarma
      7. Adobe PDF dosyalarını içe aktarma
      8. EPS, DCS ve AutoCAD dosyalarını içe aktarma
    2. Illustrator’da Creative Cloud Libraries 
      1. Illustrator’da Creative Cloud Libraries
    3. Kaydet
      1. Çizimi kaydetme
    4. Dışa Aktar
      1. Illustrator çizimini Photoshop’ta kullanma
      2. Çizimi dışa aktarma
      3. Varlıkları toplama ve toplu halde dışa aktarma
      4. Dosyaları paketleme
      5. Adobe PDF dosyaları oluşturma
      6. CSS dosyalarını ayıklama | Illustrator CC
      7. Adobe PDF seçenekleri
      8. Dosya bilgileri ve meta veriler
  7. Yazdırma
    1. Baskıya hazırlama
      1. Belgeleri baskı için ayarlama
      2. Sayfa boyutunu ve yönlendirmesini değiştirme
      3. Kırpma veya hizalama için kırpma işaretlerini belirleme
      4. Büyük tuval kullanmaya başlama
    2. Yazdırma
      1. Üst baskı
      2. Renk yönetimi ile yazdırma
      3. PostScript yazdırma
      4. Yazdırma hazır ayarları
      5. Yazıcı işaretleri ve taşma payları
      6. Saydam çizimleri yazdırma ve kaydetme
      7. Bindirme
      8. Renk ayrımlarını bastırma
      9. Degradeleri, kafesleri ve renk karışımlarını yazdırma
      10. Özel Üst Baskı
  8. Görevleri otomatikleştirme
    1. Değişkenler panelini kullanarak veri birleştirme
    2. Komut dosyaları ile otomasyon
    3. Eylemler ile otomasyon
  9. Sorun giderme 
    1. Çökme sorunları
    2. Çökmeden sonra dosyaları kurtarma
    3. Dosya sorunları
    4. Desteklenen dosya formatları
    5. GPU cihaz sürücüsü sorunları
    6. Wacom cihaz sorunları
    7. DLL dosyası sorunları
    8. Bellek sorunları
    9. Tercihler dosyası sorunları
    10. Font sorunları
    11. Yazıcı sorunları
    12. Kilitlenme raporunu Adobe ile paylaşma
    13. Illustrator performansını iyileştirme

Illustrator; web sayfalarına mizanpaj oluşturmak, web grafikleri oluşturmak ve en iyileştirmek için çeşitli araçlar sunar. Örneğin, web güvenli renkler kullanın, görüntü kalitesini dosya boyutuyla dengeleyin ve grafiğiniz için en iyi dosya formatını seçin. Web grafikleri; dilimlerden ve görüntü eşlemlerinden yararlanabilir. Ayrıca web’de dosyalarınızın düzgün görüntülenmesini sağlamak için çeşitli optimizasyon seçeneklerini kullanabilirsiniz.

Web grafikleri hakkında

Web için grafik tasarlarken, yazdırmak için grafik tasarlarken olduğundan farklı noktaları göz önüne almanız gerekir. 

Web grafikleri hakkında bilinçli kararlar verebilmenize yardımcı olması için aşağıdaki üç prensibi unutmayın:

Web uyumlu renkleri kullanın.

Renkler, çoğunlukla çizimin önemli bir özelliğidir. Ancak çiziminizde gördüğünüz renkler, Web tarayıcısında veya başka birinin sisteminde aynı şekilde görünmeyebilir. Web grafikleri oluştururken iki önlem alarak, renk taklidinin (mevcut olmayan renkleri taklit etme yöntemi) veya başka renk sorunlarının önüne geçebilirsiniz. Öncelikle, daima RGB renk modunda çalışın. İkinci olarak, Web uyumlu bir renk kullanın.

Görüntü kalitesiyle dosya boyutunu dengeleyin.

Görüntüleri Web’de dağıtmak için küçük boyutlu grafik dosyalar oluşturmak çok önemlidir. Daha küçük dosya boyutlarıyla, Web sunucuları, görüntüleri daha etkili şekilde depolayabilir ve aktarabilir. Görüntüleyenler ise bu dosyaları daha hızlı indirebilir. Web grafiğinin boyutunu ve tahmini indirme süresini, Web ve Cihazlar için Kaydet iletişim kutusunda görüntüleyebilirsiniz.

Grafiğiniz için en iyi dosya formatını seçin.

Farklı türden grafiklerin, en iyi şekilde görüntülenmek ve Web için uygun boyutta dosya boyutu oluşturmak için farklı dosya formatlarında kaydedilmesi gerekir. Tek tek formatlar hakkında daha fazla bilgi edinmek için bkz. Web grafiği en iyileştirme seçenekleri.

Not:

Web sayfaları ve reklam bantları dahil olmak üzere, özellikle Web için hazırlanmış birçok Illustrator şablonu vardır. Şablon seçmek için Dosya > Şablondan Yeni’yi seçin.

Piksel önizleme modu hakkında

Web tasarımcıların piksel açısından tutarlı tasarımlar oluşturmalarına olanak sağlamak için Illustrator’a piksel hizalama özelliği eklendi. Bir nesne için piksel hizalama özelliği etkinleştirildiğinde, nesnedeki tüm yatay ve dikey segmentler konturlara düzgün bir görünüm sağlayan piksel ızgarasına hizalanır. Tüm dönüştürmelerde, nesne için bu özellik ayarlandığı sürece, nesne yeni koordinatlarına göre piksel ızgarasına hizalanır. Dönüştür panelinden Piksel Izgarasına Hizala seçeneğini belirleyerek bu özelliği etkin hale getirebilirsiniz. Illustrator ayrıca belge düzeyinde, web belgeleri için varsayılan olarak etkin olan Yeni Nesneleri Piksel Izgarasına Hizala seçeneği sağlar. Bu özellik etkinken, çizdiğiniz her yeni nesne varsayılan olarak piksel hizalama özelliğine sahip olur.

Daha fazla bilgi için bkz. Web iş akışları için piksel hizalanmış yollar çizme .

Resmi JPEG, GIF veya PNG gibi bir bitmap formatında kaydettiğinizde Illustrator, resmi 72 piksel/inç değerinde rasterleştirir. Rasterleştirildiğinde nesnelerin nasıl görüneceğinin önizlemesini, Görünüm > Piksel Önizleme’yi seçerek görebilirsiniz. Bu, rasterleştirilmiş bir grafikte nesnelerin kesin yerleşimini, boyutunu ve kenar yumuşatmasını kontrol etmek istediğinizde özellikle  yararlıdır .

Illustrator uygulamasının nesneleri piksellere nasıl böldüğünü anlamak için, vektör nesneleri içeren bir dosya açın, Görünüm > Piksel Önizleme’yi seçin ve resmi, tek tek pikselleri görebileceğiniz kadar yakınlaştırın. Piksellerin yerleşimi, çalışma yüzeyini 1 puntoluk (1/72 inç) aralıklarla bölen piksel ızgarası tarafından belirlenir. Görünümü %600 yakınlaştırırsanız  piksel ızgarasını  görüntüleyebilirsiniz. Nesneyi taşıdığınızda, eklediğinizde veya dönüştürdüğünüzde, nesneler piksel ızgarasına hizalanır. Dolayısıyla, nesnenin ızgaraya "yapışan" kenarlarındaki (çoğunlukla sol ve üst kenarlardaki) kenar yumuşatma efekti yok olur. Şimdi, Görünüm > Piksele Yasla komutundaki seçimi kaldırın ve nesneyi taşıyın. Bu kez, nesneyi ızgara çizgilerinin arasına yerleştirmeniz mümkün olacaktır. Bunun, nesnedeki kenar yumuşatma efektini ne şekilde etkilediğine dikkat edin. Göreceğiniz gibi,  çok küçük ayarlamalar,  nesnenin ne şekilde rasterleştirileceğini etkileyebilir.

Piksel Önizleme kapalı (üstte) ve açık (altta)
Piksel Önizleme kapalı (üstte) ve açık (altta)

Not:

Piksel ızgarası, cetvel başlangıcına (0,0) duyarlıdır. Cetvelin başlangıcı kaydırıldığında, Illustrator uygulamasının çizimi nasıl rasterleştireceği de değişir.

Mobil cihazlar için Illustrator görüntüleri oluşturmaya yönelik ipuçları

Mobil cihazlar için grafik durumunu en iyileştirmek amacıyla, Illustrator'da oluşturulan çizimleri, özellikle mobil cihazlar için tasarlamış SVG-t dahil olmak üzere herhangi bir SVG formatında kaydedin.

Illustrator'da oluşturulan görüntülerin mobil cihazlarda da iyi görüntülenmesini sağlamak için aşağıdaki ipuçlarını kullanın:

  • İçerik oluşturmak için SVG standardını kullanın. Vektör grafikleri mobil cihazlarda yayınlamak için SVG kullanıldığında küçük dosya boyutu, görüntüleme bağımsızlığı, üstün renk kontrolü, yakınlaştırma yeteneği ve düzenlenebilir metin (kaynak kodda) elde edilir. Ayrıca SVG, XML tabanlı olduğu için görüntülere vurgulama, araç ipuçları, özel efektler, ses ve animasyon gibi etkileşimler katabilirsiniz.

  • Başlangıçtan itibaren hedef mobil cihazlarınızın kesin boyutları içinde çalışın. SVG ölçeklenebilir olsa da doğru boyutta çalışmak, son halini alan grafiklerin hedef cihazlar için boyut ve kalite bakımından en iyi durumda olmasını sağlar.

  • Illustrator renk modunu RGB olarak ayarlayın. SVG, monitör gibi bir RGB raster görüntüleme cihazlarında görüntülenir.

  • Dosya boyutunu küçültmek için nesne sayısını azaltmayı (gruplar dahil) ya da daha az karmaşık hale getirmeyi (daha az nokta) deneyin. Daha az nokta kullanmak, SVG dosyasındaki çizimi açıklamak için gerekli metin bilgilerinin miktarını belirgin şekilde azaltır. Noktaları azaltmak için Nesne > Yol > Basitleştir seçeneğini belirleyin. Kalite ve nokta sayısı arasında bir denge bulmak için farklı bileşimler deneyin.

  • Mümkün olduğunda semboller kullanın. Semboller, nesneyi birçok kez değil bir kez açıklayan vektörleri tanımlar. Bu, çizimde yeniden kullanılan düğme arka planları gibi nesneler varsa kullanışlıdır.

  • Grafiklere animasyon uygularken, dosya boyutunu küçültmek için kullanılan nesne sayısını sınırlayın ve nesneleri mümkün olduğunca yeniden kullanmaya çalışın. Kod tekrarını önlemek için animasyonları ayrı ayrı nesneler yerine nesne gruplarına uygulayın.

  • SVG’nin sıkıştırılmış gzip’li sürümü olan SVGZ kullanmayı deneyin. Sıkıştırma, içeriğe bağlı olarak dosya boyutunu belirgin şekilde küçültebilir. Metin genellikle yüksek oranda sıkıştırılabilir ancak gömülü rasterler (JPEG, PNG ya da GIF dosyaları) gibi ikili kodlanmış içerik fazla sıkıştırılamaz. SVGZ dosyalarının sıkıştırması, gzip’le sıkıştırılmış dosyaların sıkıştırmasını açan herhangi bir uygulama tarafından açılabilir. SGVZ’yi başarıyla kullanmak için hedef mobil cihazınızın gzip dosyalarının sıkıştırmasını açıp açamadığını kontrol edin.

Adobe logosu

Hesabınıza giriş yapın