Kullanıcı Kılavuzu İptal

Değişkenler panelini kullanarak veri birleştirme

  1. Illustrator Kullanıcı Kılavuzu
  2. Illustrator’ı tanıyın
    1. Illustrator’a giriş
      1. Illustrator’daki yenilikler
      2. Yaygın sorular
      3. Illustrator sistem gereksinimleri
      4. Apple silicon için Illustrator
    2. Çalışma alanı
      1. Çalışma alanı ile ilgili temel bilgiler
      2. Illustrator'daki Keşfedin paneli ile daha hızlı öğrenin
      3. Belge oluşturma
      4. Araç çubuğu
      5. Varsayılan klavye kısayolları
      6. Klavye kısayollarını özelleştirme
      7. Çalışma yüzeylerine giriş
      8. Çalışma yüzeylerini yönetme
      9. Çalışma alanını özelleştirme
      10. Özellikler paneli
      11. Tercihleri ayarlama
      12. Dokunmatik Çalışma Alanı
      13. Illustrator’da Microsoft Surface Dial desteği
      14. Düzenlemeleri geri alma ve tasarım geçmişini yönetme
      15. Görünümü döndür
      16. Cetveller, ızgaralar ve kılavuzlar
      17. Illustrator’da erişilebilirlik
      18. Güvenli Mod
      19. Çizimi görüntüleme
      20. Illustrator’ı Touch Bar ile kullanma
      21. Dosyalar ve şablonlar
    3. Illustrator’da araçlar
      1. Bir bakışta araçlar
      2. Seçme araçları
        1. Seçim
        2. Doğrudan Seçim
        3. Grup Seçimi
        4. Sihirli Değnek
        5. Kement
        6. Çalışma Yüzeyi
      3. Gezinme araçları
        1. El
        2. Görünümü Döndür
        3. Yakınlaştır
      4. Boyama araçları
        1. Degrade
        2. Kafes
        3. Şekil Oluşturucu
      5. Metin araçları
        1. Yazım
        2. Yola Yazma
        3. Dikey Metin
      6. Çizim araçları
        1. Kalem
        2. Bağlantı Noktası Ekle
        3. Bağlantı Noktasını Sil
        4. Bağlantı Noktası
        5. Kavis
        6. Çizgi Parçası
        7. Dikdörtgen
        8. Yuvarlak Köşeli Dikdörtgen
        9. Elips
        10. Çokgen
        11. Yıldız
        12. Boya Fırçası
        13. Kabarcık Fırçası
        14. Kurşun Kalem
        15. Şekillendirici
        16. Dilim
      7. Değiştirme araçları
        1. Döndür
        2. Yansıtma
        3. Ölçek
        4. Yamultma
        5. Genişlik
        6. Serbest Dönüştürme
        7. Damlalık
        8. Karışım
        9. Silgi
        10. Makas
        11. Boyut
    4. Üretken Yapay Zeka (Çin ana karasında kullanılamamaktadır)
      1. Metin istemi kullanarak vektör grafiği oluşturma
      2. Metin istemi kullanarak resimleri yeniden renklendirme
    5. Hızlı eylemler
      1. Retro metni
      2. Neon ışıması metni
      3. Eski tip metin
      4. Yeniden Renklendir
      5. Taslağı vektöre dönüştür
  3. Web'de Illustrator (beta)
    1. Web'de Illustrator (beta) sürümüne genel bakış
    2. Web'de Illustrator (beta) hakkında SSS
    3. Sorun giderme hakkında SSS
    4. Web'de Illustrator (beta) için Klavye kısayolları
    5. Web'de şekil oluşturma ve şekilleri birleştirme
    6. Web'de sayfalara metin ekleme ve metinleri düzenleme
    7. Web'de renk ve degrade uygulama
    8. Web'de yol çizme ve yolları düzenleme
    9. Web'de bulut belgeleriyle çalışma
    10. Ortak çalışanları web'de düzenlemeye davet etme
  4. iPad'de Illustrator
    1. iPad’de Illustrator uygulamasına giriş
      1. iPad’de Illustrator’a genel bakış
      2. iPad’de Illustrator ile ilgili SSS
      3. Sistem gereksinimleri | iPad’de Illustrator
      4. iPad’de Illustrator uygulamasında yapabilecekleriniz veya yapamayacaklarınız
    2. Çalışma alanı
      1. iPad’de Illustrator çalışma alanı
      2. Dokunmatik kısayollar ve dokunma hareketleri
      3. iPad’de Illustrator için klavye kısayolları
      4. Uygulama ayarlarınızı yönetme
    3. Belgeler
      1. iPad’de Illustrator uygulamasında belgelerle çalışma
      2. Photoshop ve Fresco belgelerini içe aktarma
    4. Nesneleri seçme ve düzenleme
      1. Tekrar nesneleri oluşturma
      2. Nesneleri karıştırma
    5. Çizim yapma
      1. Yolları çizme ve düzenleme
      2. Şekil çizme ve düzenleme
    6. Yazım
      1. Yazım ve fontlarla çalışma
      2. Yol boyunca metin tasarımları oluşturma
      3. Kendi fontlarınızı ekleme
    7. Görüntülerle çalışma
      1. Raster görüntüleri vektörleştirme
    8. Renk
      1. Renkleri ve degradeleri uygulama
  5. Bulut belgeleri
    1. Temel bilgiler
      1. Illustrator bulut belgeleriyle çalışma
      2. Illustrator bulut belgelerini paylaşma ve bu belgelerde iş birliği yapma
      3. Belgeleri inceleme için paylaşma
      4. Adobe Illustrator için bulut depolama alanını yükseltme
      5. Illustrator bulut belgeleri | Yaygın sorular
    2. Sorun giderme
      1. Illustrator bulut belgelerinde oluşturma veya kaydetme sorunlarını giderme
      2. Illustrator bulut belgelerinde sorun giderme
  6. İçerik ekleme ve düzenleme
    1. Çizim ve boyutlandırma
      1. Çizim hakkında temel bilgiler
      2. Yolları düzenleme
      3. Piksel bakımından kusursuz resimler çizme
      4. Kalem, Kavis veya Kurşun Kalem aracıyla çizim yapma
      5. Basit çizgiler ve şekiller çizme
      6. Dikdörtgen ve yuvarlak ızgaralar çizme
      7. Mercek parlamaları çizme ve düzenleme
      8. Görüntü İzleme
      9. Yolu basitleştirme
      10. Sembolizm araçları ve sembol kümeleri
      11. Yol parçalarını ayarlama
      12. 5 kolay adımda çiçek tasarlama
      13. Perspektif ızgarası oluşturma ve düzenleme
      14. Perspektif ızgarasında nesneler çizme ve değiştirme
      15. Nesneleri tekrar kullanmak üzere sembollere dönüştürme
      16. Web iş akışları için pikselle hizalanmış yollar çizme
      17. Boyutları ölçme ve çizme
    2. 3D nesneler ve malzemeler
      1. Illustrator’daki 3D efektler hakkında
      2. 3D grafikler oluşturma
      3. 3D nesneler üzerinde çizimi eşleme
      4. 3D metin oluşturma
      5. 3D nesneler oluşturma
    3. Renk
      1. Renk hakkında
      2. Renk seçme
      3. Renk örnekleri oluşturma ve kullanma
      4. Renkleri ayarlama
      5. Adobe Color Temaları panelini kullanma
      6. Renk grupları (renk uyumları)
      7. Renk Temaları paneli
      8. Resminizi yeniden renklendirme
    4. Boyama
      1. Boyama hakkında
      2. Dolgularla ve konturlarla boyama
      3. Canlı Boyama grupları
      4. Degradeler
      5. Fırçalar
      6. Saydamlık ve karıştırma modları
      7. Nesneye kontur uygulama
      8. Desen oluşturma ve düzenleme
      9. Kafesler
      10. Desenler
    5. Nesneleri seçme ve düzenleme
      1. Nesneleri seçme
      2. Katmanlar
      3. Nesneleri gruplama ve genişletme
      4. Nesneleri taşıma, hizalama ve dağıtma
      5. Nesneleri yığınlama    
      6. Nesneleri kilitleme, gizleme ve silme
      7. Nesneleri kopyalama ve çoğaltma
      8. Nesneleri döndürme ve yansıtma
      9. Nesnelere örgü uygulama
      10. Gerçekçi resim taslakları oluşturma
    6. Nesneleri yeniden şekillendirme
      1. Görüntüleri kırpma
      2. Nesneleri dönüştürme
      3. Nesneleri birleştirme
      4. Nesneleri kesme, bölme ve kırpma
      5. Kukla Çarpıt
      6. Nesneleri ölçekleme, yamultma ve deforme etme
      7. Nesneleri karıştırma
      8. Zarflar kullanarak yeniden şekillendirme
      9. Nesneleri efektlerle yeniden şekillendirme
      10. Şekillendirici ve Şekil Oluşturucu araçlarını kullanarak yeni şekiller oluşturma
      11. Canlı Köşeler ile çalışma
      12. Dokunma desteği ile geliştirilmiş yeniden şekillendirme iş akışları
      13. Kırpma maskelerini düzenleme
      14. Canlı şekiller
      15. Şekil Oluşturucu aracını kullanarak şekiller oluşturma
      16. Genel düzenleme
    7. Yazım
      1. Metin ekleme ve yazım nesneleriyle çalışma
      2. Madde işaretli ve numaralandırılmış listeler oluşturma
      3. Metin alanını yönetme
      4. Fontlar ve tipografi
      5. Görüntülerdeki metinleri düzenlenebilir metne dönüştürme
      6. Metne temel biçimlendirme ekleme
      7. Metne gelişmiş biçimlendirme ekleme
      8. Metni içe ve dışa aktarma
      9. Paragrafları formatlama
      10. Özel karakterler
      11. Yola yazma oluşturma
      12. Karakter ve paragraf stilleri
      13. Sekmeler
      14. Eksik fontları bulma (Typekit iş akışı)
      15. Arapça ve İbranice fontlar
      16. Fontlar | SSS ve sorun giderme ipuçları
      17. 3D metin efekti oluşturma
      18. Kreatif tipografi tasarımları
      19. Yazımı ölçekleme ve döndürme
      20. Satır ve karakter aralığı
      21. Tireleme ve satır sonları
      22. Yazım ve dil sözlükleri
      23. Asya dillerindeki karakterleri formatlama
      24. Asya dillerinde metinler için oluşturucular
      25. Karışım nesneleri ile metin tasarımları oluşturma
      26. Görüntü İzleme’yi kullanarak metin posteri oluşturma
    8. Özel efektler oluşturma
      1. Efektlerle çalışma
      2. Grafik stilleri
      3. Görünüm nitelikleri
      4. Taslaklar ve mozaikler oluşturma
      5. Alt gölgeler, ışımalar ve geçiş yumuşatma
      6. Efektler özeti
    9. Web grafikleri
      1. Web grafikleri oluşturmak için en iyi uygulamalar
      2. Grafikler
      3. SVG
      4. Dilimler ve görüntü eşlemeleri
  7. İçe aktarma, dışa aktarma ve kaydetme
    1. İçe aktarma
      1. Birden çok dosya yerleştirme
      2. Bağlantılı ve gömülü dosyaları yönetme
      3. Bağlantı bilgileri
      4. Gömülü görüntüleri çıkarma
      5. Photoshop’tan çizimleri içe aktarma
      6. Bitmap görüntüleri içe aktarma
      7. Adobe PDF dosyalarını içe aktarma
      8. EPS, DCS ve AutoCAD dosyalarını içe aktarma
    2. Illustrator’da Creative Cloud Libraries 
      1. Illustrator’da Creative Cloud Libraries
    3. Kaydet
      1. Çizimi kaydetme
    4. Dışa Aktar
      1. Illustrator çizimini Photoshop’ta kullanma
      2. Çizimi dışa aktarma
      3. Varlıkları toplama ve toplu hâlde dışa aktarma
      4. Dosyaları paketleme
      5. Adobe PDF dosyaları oluşturma
      6. CSS dosyalarını ayıklama | Illustrator CC
      7. Adobe PDF seçenekleri
      8. Belge bilgileri paneli
  8. Yazdırma
    1. Baskıya hazırlama
      1. Belgeleri baskı için ayarlama
      2. Sayfa boyutunu ve yönlendirmesini değiştirme
      3. Kırpma veya hizalama için kırpma işaretlerini belirleme
      4. Büyük tuval kullanmaya başlama
    2. Yazdırma
      1. Üst baskı
      2. Renk yönetimi ile yazdırma
      3. PostScript yazdırma
      4. Yazdırma hazır ayarları
      5. Yazıcı işaretleri ve taşma payları
      6. Saydam çizimleri yazdırma ve kaydetme
      7. Bindirme
      8. Renk ayrımlarını bastırma
      9. Degradeleri, kafesleri ve renk karışımlarını yazdırma
      10. Beyaz Üste Baskı
  9. Görevleri otomatikleştirme
    1. Değişkenler panelini kullanarak veri birleştirme
    2. Komut dosyaları ile otomasyon
    3. Eylemler ile otomasyon
  10. Sorun giderme 
    1. Bilinen sorunlar
    2. Çökme sorunları
    3. Çökmeden sonra dosyaları kurtarma
    4. Dosya sorunları
    5. Desteklenen dosya formatları
    6. GPU cihaz sürücüsü sorunları
    7. Wacom cihaz sorunları
    8. DLL dosyası sorunları
    9. Bellek sorunları
    10. Tercihler dosyası sorunları
    11. Font sorunları
    12. Yazıcı sorunları
    13. Kilitlenme raporunu Adobe ile paylaşma
    14. Illustrator performansını iyileştirme

Çiziminizin birden fazla çeşitlemesini oluşturmak için Değişkenler panelini kullanarak Illustrator belgesini veri kaynağı dosyasıyla (CSV veya XML dosyasıyla) birleştirin. Görüntünüzün üzerinde yeniden çalışmanıza gerek kalmadan etkinlik rozetleri üzerindeki katılımcı isimlerini değiştirebilir veya web afişlerindeki ve kartpostallardaki görsellerin versiyonlarını oluşturabilirsiniz. Tek bir tasarım oluşturun ve veri kaynak dosyasındaki adları veya görüntüleri içeri aktararak hızlı bir şekilde farklı versiyonlar hazırlayın.

Değişkenler panelini kullanarak yazdırılabilir posterler, web afişleri ve etkinlik rozetleri gibi farklı projeler için kendi tasarım şablonunuzun özel versiyonlarını oluşturun.

Devam etmeden önce

Veri birleştirme için ihtiyacınız olan yalnızca veri kaynak dosyası ve hedef belgedir. 

  • Veri kaynağı dosyası, hedef belgenin her versiyonunda değişen bilgiler (ör. form mektubu alıcılarının adları, fotoğrafları ve adresleri) içerir. Veri kaynak dosyası, virgülle sınırlanmış dosya (.csv) veya genişletilebilir biçimlendirme dili dosyası (.xml) olabilir. 
  • Hedef belge, şablon olarak kullanılacak ana resmi içeren bir Illustrator belgesidir. Bu belgede, veri alanı yer tutucu ve birleştirilen belgenin her versiyonunda korunan öğeler yer alabilir.

Veri birleştirme işlevine erişim

Veri birleştirme işlevine, Illustrator'daki Değişkenler panelinden erişilebilir (Pencere > Değişkenler). Belgedeki her değişkenin türü ve adı panelde listelenir. Değişken bir nesneye bağlıysa bağlı nesnenin adı Nesneler sütununda Katmanlar panelinde görüntülendiği şekilde belirtilir. Başlık çubuğundaki öğeleri tıklatarak satırları şunlara göre sıralayabilirsiniz: değişken adına, nesne adına veya değişken türüne göre.

Değişkenler paneli

A. Veri kümesi B. Panel menüsü C. Veri kümeleri arasında geçiş D. Bağlı nesnenin adı E. Değişken adı F. Değişken türü G. Değişkenleri kilitleme H. Nesneyi dinamikleştirme I. Görünürlüğü dinamikleştirme J. Değişkenlerin bağlantısını ayırma K. Değişken oluşturma L. Değişkenleri silme 

Veri birleştirmek için hızlı adımlar

  1. Şablon olarak kullanılacak bir Illustrator belgesi oluşturun.

  2. Kaynak veri dosyanızı CSV veya XML formatı olarak ayarlayın. Daha fazla bilgi için bkz. Veri kaynak dosyası hazırlama.

  3. Değişkenler panelini kullanarak Illustrator'a bir veri kaynak dosyası aktarın. Daha fazla bilgi için bkz. Veri kaynak dosyasını içe aktarma.

  4. Bir değişkeni şablonunuzdaki bir nesneye bağlayın. Daha fazla bilgi için bkz. Değişkenleri nesnelere bağlama.

  5. Tüm dosyaları dışa aktarmadan önce belgeyi her veri kümesiyle önizleyin. Daha fazla bilgi için bkz. Belgeyi her veri kümesiyle önizleme.

  6. Illustrator'daki Eylemler panelini kullanarak verilerden bir grup dosyayı dışa aktarın. Daha fazla bilgi için bkz. Eylemler panelini kullanarak dosyaları dışa aktarma.

Veri kaynak dosyası hazırlama

Veri kaynak dosyaları, virgülle sınırlanmış (.csv) veya Genişletilebilir Biçimlendirme Dili (.xml) formatında kaydedilmelidir.

CSV kaynak dosyaları oluşturma

Virgülle sınırlanmış (.csv) bir metin dosyasında kayıtlar paragraf kesmeleriyle, alanlarsa virgül veya sekmelerle ayrılır. Veri kaynak dosyası diskteki görüntülere referansta bulunan metin veya yollar da içerebilir. Bir CSV dosyasını içe aktarmadan önce Illustrator'ın değişken türünü belirlemesi için aşağıdaki işlemleri yapın.

  1. Elektronik tablonuzu açın.

  2. Elektronik tablonuzun ilk satırına veri alan adınızı girin. Ardından aşağıdaki işlemleri gerçekleştirin:

    • Görüntü dosyalarına referansta bulunan metin veya yollar eklemek için veri alanı adının başına "@" simgesi girin. @ simgesi sadece ilk satırda gereklidir; sonraki satırlar görüntü yollarını içermelidir.
    • Aynı şekilde, veri alan adının başına grafikler için bir "yüzde" (%) sembolü, görünürlük için "etiket" (#) sembolünü yazın.
    • Nesnenin görünürlüğünü tanımlamak üzere her veri alanı için doğru veya yanlış olarak belirtin.
    Not:
    • Elektronik tablonuzdaki veri alan adları boşluk içermemelidir. Örneğin, veri alanını Şirket Adı yerine Şirket_Adı olarak belirleyebilirsiniz. 
    • Aynı şekilde, bir görüntü veya grafik dosyasını referans alan yollar da boşluk içermemelidir. Örneğin, bir görüntü dosyasının yolu C:\Fotoğraflar\Bill Tucker yerine C:\Fotoğraflar\BillTucker şeklinde olmalıdır.
    • Veri kaynak dosyanızdan bağlanan tüm grafik dosyaları, virgülle sınırlanmış (.csv) dosyalar olarak kaydedilmelidir.
    • Alanın başına @ simgesini girdiğinizde hata mesajı alırsanız fonksiyonu doğrulamak için @ simgesinden önce tırnak işareti (') girin ('@Fotoğraflar gibi). Microsoft Excel gibi bazı uygulamalar @ simgesini fonksiyonlar için ayırır.

    (Windows) Veri kaynak dosyasındaki görüntü ve grafik referanslarına örnek

    Ad

    Yaş

    @Fotoğraflar

    %Grafikler

    #Görünürlük

    Bill Tucker

    36

    C:\Fotoğraflar\BillTucker.jpg

    C:\Fotoğraflar\BillTucker.csv

    Doğru

    Dat Nguyen

    53

    C:\Belgelerim\dat.jpg

    C:\Belgelerim\dat.csv

    Doğru

    Maria Ruiz

    26

    C:\Fotoğraflar\Ruiz.jpg

    C:\Fotoğraflar\Ruiz.csv

    Yanlış

    (macOS) Veri kaynak dosyasındaki görüntü ve grafik referanslarına örnek

    Ad

    Yaş

    @Fotoğraflar

    %Grafikler

    #Görünürlük

    Bill Tucker

    36

    /Users/photos/BillTucker.jpg

    /Users/photos/BillTucker.csv

    Doğru

    Dat Nguyen

    53

    /Users/family/photos/dat.jpg

    /Users/family/photos/dat.csv

    Doğru

    Maria Ruiz

    26

    /Users/alpha/photos/Ruiz.jpg

    /Users/alpha/photos/Ruiz.csv

    Yanlış

  3. Verilerinizi elektronik tabloya girin.

  4. Aşağıdakilerden birini yapın:

    • Microsoft Excel'in en yeni sürümü (2016 sürümü) ile oluşturulan elektronik tabloları aşağıdaki dosya formatlarında kaydedin:
      • CSV (Virgülle sınırlanmış) (*.csv).
      • CSV (MS-DOS) (*.csv)
    • Apple Numbers ile oluşturulan elektronik tabloları, Unicode (UTF-8) kodlaması ile CSV formatında kaydedin.
    Not:

    Şu anda, yukarıda belirtilen formatlarda dışa aktarılan CSV dosyaları Illustrator'da desteklenmektedir. Macintosh Virgülle Ayrılmış (.csv) gibi diğer CSV dosya formatları veri birleştirme için desteklenmez.

Bir XML dosyası hazırlama

  1. Belgenizde bir değişken tanımlayın. Daha fazla bilgi için bkz. Değişkenleri nesnelere bağlama.

  2. Değişkenler panelinde Veri Kümesini Yakala  düğmesini seçin.

  3. İstenen sayıda veri kümesi oluşturduktan sonra veri kümelerini XML dosyası olarak kaydetmek için Değişkenler panelinden Değişken Kitaplığını Kaydet seçeneğini belirleyin. Dosya adını ve konumu belirleyip Kaydet seçeneğini belirleyin.

    Illustrator'da oluşturduğunuz değişkenleri XML dosyası olarak dışa aktarma

  4. Şimdi veri kümelerinizi bu dosyaya eklemek için XML dosyasını Notepad++ (Windows) veya TextWrangler (macOS) gibi bir metin düzenleme uygulamasında düzenleyin.

    Örneğin: Herhangi bir metin düzenleme uygulamasını kullanarak bir XML dosyasını düzenleme

    A. Görüntünün yolunu değiştirme B. Metin dizesini değiştirme  

  5. Illustrator'da XML dosyanızı içe aktarmak için Değişkenler paneli menüsünden Değişken Kitaplığını Yükle seçeneğini belirleyin. XML dosyasını seçin ve seçeneğini belirleyin.

    Değişkenleri Illustrator'a İçe Aktarma

Veri kaynak dosyasını içe aktarma

Değişkenleri istenen verilere bağlamak için Değişkenler panelinde bir veri kaynağını içe aktarın. Her belge için yalnızca bir veri kaynak dosyası seçilebilir.

  1. Pencere > Değişkenler'i seçin.

  2. Değişkenler panelinde İçe Aktar seçeneğini belirleyin.

  3. Değişken Kitaplığını Yükle iletişim kutusunda, CSV veya XML formatında bir veri kaynağı dosyası seçin ve seçeneğini belirleyin.

  4. Veri Kümesi açılır menüsünden veri kümesini seçip seçeneklerini düzenleyerek veri kümesini düzenleyebilir, yeniden adlandırabilir veya silebilirsiniz.

    • Veri kümeleri arasında geçiş yapmak için Değişkenler panelinde Veri Kümesi listesinden bir veri kümesi seçin. Ayrıca Önceki Veri Kümesi  düğmesini veya Sonraki Veri Kümesi  düğmesini de seçebilirsiniz.
    • Çalışma yüzeyindeki verileri geçerli veri kümesine uygulamak için Değişkenler paneli menüsünden Veri Kümesini Güncelle seçeneğini belirleyin.
    • Veri kümesini yeniden adlandırmak için metni doğrudan Veri Kümesi metin kutusunda düzenleyin. Veri Kümesi sözcüklerini (Veri Kümesi metin kutusunun solunda) çift tıklatıp yeni bir ad girebilir ve Tamam'ı seçebilirsiniz.
    • Veri kümesini silmek için Sil simgesini seçin. Ayrıca Değişkenler paneli menüsünden Veri Kümesini Sil seçeneğini de belirleyebilirsiniz.
    Not:

    Excel aracılığıyla oluşturulan ve çift baytlı karakterler içeren CSV (UTF-8 Virgülle Ayrılmış) dosyaları, Değişkenler panelinde içe aktarılamaz. Aynı dosyayı metin formatında açar ve UTF-8 kodlamasıyla CSV olarak kaydederseniz dosya doğru şekilde içe aktarılır.

Değişkenleri nesnelere bağlama

Şablondaki değiştirmek istediğiniz öğeleri tanımlamak için değişkenleri kullanın. Dört farklı türde değişken tanımlayabilirsiniz: Görünürlük değişkeni, Metin Dizesi değişkeni, Bağlı Dosya değişkeni ve Grafik Verileri değişkeni. Değişkenin türü, hangi nesne niteliklerinin değiştirilebilir (dinamik) olduğunu belirtir. Belgedeki her değişkenin türü ve adı panelde listelenir. Değişken bir nesneye bağlıysa bağlı nesnenin adı Nesneler sütununda Katmanlar panelinde görüntülendiği şekilde belirtilir.

Değişken türü

Değişken türünü belirten simge

Tanım

Görünürlük değişkenleri

Resmi gösterir veya gizler.

Metin Dizesi değişkenleri

Bir metin dizesinin yerine kullanılır.

Bağlantılı Dosya değişkenleri

Çalışma yüzeyindeki nesnenin yerine başka bir dosyadaki nesneyi yerleştirir.

Grafik Verileri değişkeni

Bir grafikteki değerlerin yerine kullanılır.

Türsüz (bağlantısız) değişken

Hiçbir nesneye bağlı değildir.

Illustrator'da değişkenleri tanımlamak için şu adımları uygulayın:

  1. Bir nesne seçin.

  2. Değişkenler panelinde (Pencere > Değişkenler), nesneyi bağlamak istediğiniz değişkeni seçin.

  3.  Nesneyi değişkenle bağlamak için Nesneyi Dinamikleştir  düğmesini seçin.

Değişkeni bir nesneye bağlamadan oluşturmak için şu adımları uygulayın:

  1. Değişkenler panelinde Yeni Değişken  düğmesini seçin.

  2. Değişkene bir nesneyi bağlamak için nesneyi ve değişkeni seçip Görünürlüğü Dinamikleştir  düğmesini veya Nesneyi Dinamikleştir  düğmesini tıklatın.

Not:

Değişken adları, Geçici Çift ve 4 baytlık karakterleri desteklemez. Değişken adında bu karakterleri kullanırsanız bir hata mesajı görüntülenir.

Değişkenlerle çalışma

Değişkenler panelini kullanarak bir değişkenin adını veya türünü düzenleyebilir, bağlantısını ayırabilir ve bir değişkeni kilitleyebilirsiniz.

Değişkenin bağlantısı ayrıldığında, değişkenle nesneleri arasındaki bağlantı kesilir. Değişkenler kilitlendiğinde, değişken oluşturmanız, silmeniz ve değişken seçeneklerini düzenlemeniz engellenir. Ancak nesneleri, kilitli değişkenlere bağlayabilir ve bağlantısını ayırabilirsiniz.

Değişkenin adını ve türünü değiştirme

  1. Değişkenler panelinde değişkeni seçin ve panel menüsünden Değişken Seçenekleri'ni seçin.

Değişkenin bağlantısını ayırma

  1. Değişkenler panelinde Değişkeni Ayır  düğmesini seçin.

Belgedeki bütün değişkenleri kilitleme veya kilidini açma

  1. Değişkenler panelinde Değişkenleri Kilitle  düğmesini veya Değişkenlerin Kilidini Kaldırdüğmesini seçin.

Değişkenleri silme

Değişkenler panelinden kaldırmak için değişkeni silin. Nesneye bağlı bir değişkeni silerseniz nesne statik hale gelir (nesne aynı zamanda başka türden bir değişkene de bağlı değilse).

  1. Silmek istediğiniz değişkeni seçin.

  2. Şu seçeneklerden birini kullanın:

    • Değişkenler panelinde Değişkeni Sil  düğmesini seçin.

    • Değişkeni onaya gerek kalmadan silmek için Değişkeni Sil  düğmesinin üzerine sürükleyin.

Dinamik nesneleri düzenleme

Değişkenle ilişkilendirilmiş verileri, verilerin bağlı olduğu nesneyi düzenleyerek değiştirebilirsiniz. Örneğin, Görünürlük değişkeniyle çalışıyorsanız nesnenin görünürlük durumunu Katmanlar panelinde değiştirirsiniz. Dinamik nesneleri düzenleyerek şablonda birden çok veri kümesi oluşturabilirsiniz.

  1. Çalışma yüzeyinde dinamik nesneyi seçin veya bir dinamik nesneyi otomatik olarak seçmek için aşağıdakilerden birini yapın:

    • Alt (Windows) veya Option (macOS) tuşunu basılı tutarak Değişkenler panelinde bir değişkeni tıklatın.

    • Değişkenler panelinde bir değişken seçin ve Değişkenler panel menüsünden Bağlı Nesneyi Seç seçeneğini belirleyin.

    • Tüm dinamik nesneleri seçmek için Değişkenler paneli menüsünden Tüm Bağlı Nesneler'i seçin.

  2. Nesneyle ilişkilendirilmiş verileri şu şekilde düzenleyin:

    • Metin dizesini çalışma yüzeyinde düzenleyin.

    • Bağlantılı dosyalar için Bağlantılar paneliyle veya Dosya > Yerleştir komutuyla görüntüyü değiştirin.

    • Grafik Verileri iletişim kutusunda grafiklerin verilerini düzenleyin.

    • Dinamik görünürlüğe sahip tüm nesnelerde, nesnenin görünürlük durumunu Katmanlar panelinde değiştirin.

XML Kimliklerini kullanarak dinamik nesneler tanımlama

Değişkenler panelinde, dinamik nesnelerin adları Katmanlar panelinde görüntülendiği şekilde belirtilir. Şablonu başka Adobe ürünleriyle kullanmak üzere SVG formatında kaydederseniz bu nesne adlarının XML adlandırma kurallarına uygun olması gerekir. Örneğin, XML adlarının bir harfle, alt çizgiyle veya iki nokta üst üste simgesiyle başlaması ve boşluk içermemesi gerekir.

Illustrator, oluşturduğunuz her dinamik nesneye otomatik olarak geçerli bir XML Kimliği atar. Nesne adlarını XML Kimlikleri kullanarak görüntülemek, düzenlemek ve dışa aktarmak için Düzenle > Tercihler > Birimler'i (Windows) veya Illustrator > Tercihler > Birimler'i (Mac OS) seçin ve XML Kimliği'ni seçin.

Her veri kümesi içeren belgenin önizlemesini görüntüleme

Grafiklerinizin son halini görmek için tüm dosyaları dışa aktarmadan önce önizlemelerini görüntüleyebilirsiniz. Değişkenler panelinde, Veri Kümesinin yanındaki ok tuşlarını kullanarak belgenizdeki istediğiniz veri kümesini bulup önizleyin.

Eylemler panelini kullanarak dosyaları dışa aktarma

Değişkenleri ve bir ya da birkaç veri kümesini tanımladıktan sonra veri kümesi değerlerini kullanarak toplu iş modunda resimler oluşturabilirsiniz. Aşağıdakileri yapın:

  1. Eylemler panelini kullanarak (Pencere> Eylemler) bir eylem kaydı oluşturup belgenizi istediğiniz formatta kaydedin. Ayrıntılı bilgi için bkz. Eylemlerle otomasyon.

  2. Eylemler paneli menüsünden Toplu İş'i seçin ve bir önceki adımda oluşturduğunuz eylemi işaretleyin.

  3. Kaynak için Veri Kümeleri'ni seçerek eylemi geçerli dosyadaki her bir veri kümesine uygulayın.

  4. Hedef için, işlem gören dosyalarla ne yapmak istediğinizi belirleyin. Değişiklikleri kaydetmeden dosyaları açık bırakabilir (Yok), dosyaları bulundukları konuma kaydedip kapatabilir (Kaydet ve Kapat) veya dosyaları farklı bir konuma kaydedebilirsiniz (Klasör).

    Hedef seçeneğine bağlı olarak, dosyaların kaydedilmesinde ek seçenekler belirleyebilirsiniz. Daha fazla bilgi için bkz. Bir grup dosya üzerinde eylem yürütme.

  5. Tamam'ı seçin.

Veri birleştirme için şablon kaydetme

Illustrator belgesinde değişkenler tanımladığınızda veri birleştirme işlemi için bir şablon oluşturmuş olursunuz. Bu şablonu, Adobe® Graphics Server gibi farklı bir Adobe ürünüyle kullanmak için SVG formatında kaydedebilirsiniz. Örneğin, Adobe Graphics Server ile çalışan bir geliştirici, SVG dosyasındaki değişkenleri doğrudan bir veritabanına veya başka bir veri kaynağına bağlayabilir.

  1. Dosya > Farklı Kaydet'i seçin, bir dosya adı girin, dosya formatı olarak SVG'yi seçin ve Kaydet'i tıklatın.

  2. Daha Fazla Seçenek düğmesini tıklatın ve Adobe Graphics Server verilerini İçer'i seçin. Bu seçenek, SVG dosyasında değişken alternatifi için gereken tüm bilgileri dahil eder.

  3. Tamam seçeneğini tıklatın.

CSV dosyanızı içe aktarırken sorun mu yaşıyorsunuz?

CSV veri kaynak dosyasını yüklerken Gelen değişken kitaplığı geçerli değil hatasıyla karşılaşıyorsanız aşağıdakileri kontrol edin:

  • CSV dosyası boş değil.
  • Microsoft Excel'in en son sürümünü kullanarak oluşturduğunuz elektronik tablolar CSV (Virgülle sınırlanmış) (*.csv) ya da CSV (MS-DOS) (*.csv) olarak kaydedilmiştir ve Apple Numbers kullanılarak oluşturulanlar Unicode (UTF-8) kodlama içeren CSV formatında kaydedilmiştir. Macintosh Virgülle Ayrılmış (.csv) gibi başka bir CSV dosya formatında kaydedilmiş veri kaynak dosyaları, veri birleştirme için desteklenmez.
  • Her sütunun bir veri alan adı vardır. Örneğin, veri kaynak dosyanızda bir sütunda veri bulunduğunda ancak veri alan adı olmadığında Illustrator bir hata mesajı görüntüler.
  • Veri kaynak dosyasında dolu sütunlar arasında boş bir sütun yoktur. Örneğin, veri kaynak dosyanızda B sütununda ve D sütununda veri bulunuyorsa ancak C sütunu boşsa Illustrator bir hata mesajı görüntüler.
Örnek: veri birleştirme için bir CSV kaynak dosyası oluşturulurken hata meydana geldi

A. Bir sütunun veri alan adı yok B. Dolu sütunlar arasında boş bir sütun var 

  • Elektronik tablonuzdaki veri alan adları boşluk içermez.
  • Veri kaynak dosyanızdaki bir görüntü veya grafik dosyasını referans alan yollar da boşluk içermez.
  • Veri kaynak dosyasından bağlanan grafik dosyaları, virgülle sınırlanmış (.csv) dosyalar olarak kaydedilir.

ilgili kaynaklar

Bizimle iletişime geçin

Görüşlerinizi almak isteriz. Adobe Illustrator Topluluğu ile düşüncelerinizi paylaşın. 

 Adobe

Daha hızlı ve daha kolay yardım alın

Yeni kullanıcı mısınız?