تحديد النص

  1. باستخدام أداة Type، قم بأحد الإجراءات التالية:
    • اسحب مؤشر الشريط الرأسي الذي يتخذ شكل الحرف I أعلى حرف أو كلمة أو قالب نص لتحديده.
    • انقر نقرًا مزدوجًا فوق إحدى الكلمات لتحديدها. علمًا بأن المسافات التالية للكلمة لا يتم تحديدها.
    • انقر نقرًا ثلاثيًا في أي مكان على السطر لتحديد السطر بأكمله. في حالة عدم تحديد خيار تفضيلات Triple Click To Select A Line، فإن النقر الثلاثي يحدد الفقرة ككل.

    • إذا كان خيار النقر الثلاثي لتحديد السطر محددًا، قم بالنقر الرباعي في أي مكان من فقرة لتحديد الفقرة بأكملها.

    • قم بالنقر الخماسي لتحديد المجموعة النصية بالكامل، أو انقر في أي مكان في المجموعة النصية واختر Edit > Select All.

ملاحظة:

إذا قمت بتحديد النص الذي يحتوي على ملاحظة ربط، باستخدام الإجراء بأعلاه، والملاحظة ومحتوياتها يتم تحديدها أيضًا.

إذا لم يكن بمقدورك تحديد نص في إطار، فإن إطار النص يمكن أن يكون على طبقة مقفلة أو على صفحة أساسية. جرب أن إلغاء قفل الطبقة أو الانتقال إلى الصفحة الأساسية. قد يكون إطار النص أيضًا تحت إطار نص آخر أو كائن شفاف. راجع تحديد نص في إطار مغطى.

تغيير تأثيرات النقر الثلاثي

  1. اختر Edit > Preferences > Type (في Windows) أو InDesign > Preferences > Type (في Mac OS).
  2. حدد Triple Click To Select A Line لإتاحة النقر الثلاثي لتحديد سطر ما (هذا هو الافتراضي). لا تحدد هذا الخيار إذا أردت النقر الثلاثي أن يقوم بتحديد الفقرة.

تحديد نص في إطار مغطى

  1. باستخدام أداة Selection ، اضغط على مفتاح Ctrl (في حالة نظام التشغيل Windows) أو اضغط على مفتاح الأوامر (في حالة نظام التشغيل Mac OS) ثم انقر لتحديد الإطار.
  2. حدد أداة Type tool، ثم انقر داخل إطار نص أو حدد نصًا.

عرض الحروف المختفية (غير القابلة للطباعة)

  1. اختر Type > Show Hidden Characters.
  2. إذا كانت الحروف المخفية مازالت لا تظهر، فقم بإيقاف تشغيل وضع المعاينة. اختر View > Screen Mode > Normal واختر View >Overprint Preview لإلغاء تحديده.

سوف تظهر الحروف غير القابلة للطباعة مثل المسافات وحروف الجدولة ونهاية الفقرات ومبرزات الفهرس ونهايات المجموعات النصية. علمًا بأن هذه الحروف الخاصة تكون مرئية فقط في نافذة المستند ومربع حوار محرر المجموعة النصية ولكنها لا تظهر في مخرجات الطباعة أو عند التصدير إلى تنسيقات مثل PDF وXML. تظهر الحروف المختفية بنفس اللون مثل لون الطبقة.

الحروف غير القابلة للطباعة مختفية (لأعلى) ومرئية (لأسفل)
الحروف غير القابلة للطباعة مختفية (لأعلى) ومرئية (لأسفل)

تقدم آن ماري كوسبسيو قائمة شاملة بالحروف الخاصة في الدليل المجاني للحروف الخاصة في InDesign.

قائمة الحروف المخفية

حرف مخفي

ماذا يمثل

نهاية الفقرة

انكسار ناعم (انكسار بسيط)

الفراغ

نهاية المجموعة النصية

واصلة تقديرية

واصلة غير فاصلة

جدولة

مسافة بادئة من اليمين بمقدار حرف جدولة

مسافة بادئة إلى هنا

إنهاء النمط المتداخل هنا

Non-Joiner

مسافة إيديوغرامية

مسافة Em

مسافة En

مسافة غير فاصلة

مسافة غير منفصلة (ثابتة العرض)

مسافة ضئيلة

سدس مسافة

مسافة رفيعة

ربع مسافة

ثلث مسافة

مسافة علامة ترقيم

مسافة شكل

مسافة تسييل

فاصل عمود

فاصل إطار

فاصل صفحة

فاصل صفحة فردية

فاصل صفحة زوجية

سطر فاصل إجباري

ملاحظة InCopy

ملاحظة InCopy (في Story Editor)

علامة موضع (InCopy فقط)

مبرز فهرس

علامة فهرس (في Story Editor)

نص شرطي مخفي

نص شرطي مخفي (في Story Editor)

علامة إشارة مرجعية أو هدف رابط تشعبي (نقطة ربط نص غالبًا)

علامة إشارة مرجعية أو هدف رابط تشعبي (في Story Editor)

هدف الرابط التشعبي (في Story Editor)

فقرة مرجع تبادلي

رابط تشعبي لمرجع تبادلي (في Story Editor)

كائن مرتبط

كائن مرتبط (في Story Editor)

علامة تمييز XML

علامة تمييز XML (في Story Editor)

الحاشية السفلية (في Story Editor)

الجدول (في Story Editor)

المتغير (في Story Editor)

علامة فهرس (في Story Editor)

إضافة عامود وإطار وفواصل صفحة

يمكنك التحكم في عمود وإطار وفواصل الصفحة عن طريق إدراج حروف فاصلة خاصة في النص.

  1. باستخدام أداة Type tool، انقر لوضع نقطة الإدراج في الموضع الذي تريد أن يحدث الفاصل عنده.
  2. اختر Type > Insert Break Character، ثم اختر حرفا فاصلاً من القائمة الفرعية.

ملاحظة:

يمكنك أيضًا إنشاء فواصل عن طريق استخدام مفتاح Enter على لوحة المفاتيح الرقمية. لعمل فاصل عمود، اضغط على مفتاح Enter؛ ولعمل فاصل إطار، اضغط على مفتاحي Shift+Enter؛ ولعمل فاصل صفحة، اضغط على مفتاحي Ctrl+Enter (في Windows) أو مفتاحي Command+Enter (في Mac OS).

لإزالة حرف فاصل، اختر Type > Show Hidden Characters لكي تتمكن من رؤية الحروف غير القابلة للطباعة ثم حدد الحرف الفاصل واحذفه.

ملاحظة:

إذا قمت بإنشاء فاصل عن طريق تغيير إعدادات الفقرة (كما في مربع حوار Keep Options)، فإن الفاصل يسبق الفقرة التي تحتوي على الإعداد. إذا قمت بإنشاء فاصل باستخدام حرف خاص، فإن الفاصل يقع مباشرة بعد الحرف الخاص.

خيارات الفواصل

تظهر الخيارات التالية من خلال Type > Insert Break Character:

فاصل عمود

يعمل على تدفق النص للعمود التالي في إطار النص الحالي. إذا كان الإطار له عمود واحد، فإن النص يذهب للإطار المرتبط التالي.

فاصل إطار

يعمل على تدفق النص لإطار النص المرتبط التالي، بغض النظر عن إعداد عمود إطار النص الحالي.

فاصل صفحة

يعمل على تدفق النص للصفحة التالية إلى إطار النص المرتبط بإطار النص الحالي.

فاصل صفحة فردية

يعمل على تدفق النص للصفحة التالية ذات العدد الفردي إلى إطار النص المرتبط بإطار النص الحالي.

فاصل صفحة زوجية

يعمل على تدفق النص للصفحة التالية ذات العدد الزوجي إلى إطار النص المرتبط بإطار النص الحالي.

انكسار فقرة 

يؤدي إدراج حرف انكسار الفقرة إلى نفس التأثير الذي يسببه الضغط على مفتاح (Enter أو Return).

سطر فاصل إجباري 

يفرض كسر السطر حيث تمت إضافة الحرف، بادئًا سطر جديد بدون بدء فقرة جديدة (مثل Shift+Enter or Shift+Return). كما يسمى فاصل السطور المفروض باسم انكسار بسيط.

كسر سطر غير اعتيادي 

يشير إلى حيث يجب أن يتم كسر السطر إذا احتاج السطر للانكسار. هذا الانكسار التقديري للسطر يماثل الوصلة التقديرية، مع عدم إضافة واصلة مكان انكسار السطر.

تتوفر خيارات الفصل المتعلقة في مربع الحوار Keep Options ومربع الحوار Paragraph Style Options.

استخدام Story Editor

يمكنك تحرير النص في InDesign من خلال مخطط الصفحة أو باستخدام نافذة story editor. حيث إن الكتابة والتحرير من خلال نافذة story editor تتيح ظهور المجموعة النصية بأكملها بنفس خصائص مظهر الكتابة والحجم والمسافات التي قمت بتعيينها في Preferences ولكن بدون خصائص تخطيط الصفحة أو التنسيقات الزخرفية. يمثل Story Editor أيضًا المكان الذي يمكنك من خلاله عرض تتبع التغييرات على النص.

تظهر كل مجموعة نصية في نافذة story editor منفصلة. يتم عرض كل النص الموجود في المجموعة النصية في محرر المجموعة النصية، متضمنًا النص غير الظاهر. يمكنك فتح أكثر من نافذة story editor مختلفة في آن واحد، متضمنة نسخ مختلفة لنفس المجموعة النصية. تشير مسطرة العمق الرأسي إلى كمية النص التي تملأ الإطار ويشير السطر إلى مكان النص غير الظاهر.

عندما تقوم بتحرير مجموعة نصية، فإن كل التغييرات تنعكس على نافذة المخطط. المجموعات النصية المفتوحة تكون مدرجة في قائمة Window. لا يمكنك إنشاء مجموعة نصية جديدة في نافذة story editor.

نافذة Story Editor
نافذة Story Editor

A. أنماط الفقرات B. اسحب الفاصل حتى تحصل على العرض المناسب للعمود C. مسطرة العمق الرأسي D. مؤشر النص غير الظاهر 

يمكنك عرض وتحرير الجداول في Story Editor، حيث النص يكون معروضًا في أعمدة وصفوف متسلسلة لتسهيل التحرير. قم بتوسيع الجداول أو تقليصها، وحدد إذا ما كنت تعرضهم بالصف أو بالعامود.

يعرض Story Editor أيضًا النص الذي تمت إضافته أو إزالته أو تحريره في حالة تشغيل تتبع التغييرات. راجع تتبع التغييرات ومراجعتها.

فتح Story Editor

  1. حدد إطار النص ثم انقر فوق نقطة إدراج النص في إطار النص أو حدد أكثر من إطار من مجموعات نصية مختلفة.
  2. اختر Edit > Edit In Story Editor.

ملاحظة:

لفتح نسخة أخرى من نفس نافذة story editor، تأكد من أن محرر المجموعة النصية نشط، ثم اختر Window > Arrange > New Window.

الرجوع إلى نافذة التخطيط

  1. في Story Editor، قم بأحد الإجراءات التالية:
    • اختر Edit > Edit In Layout. عند استخدامك هذا الأسلوب، فسيعرض عرض المخطط موقع تحديد النص ذاته أو موقع نقطة الإدخال ذاته الذي تم عرضه مؤخرًا فيstory editor، وتظل نافذة المجموعة النصية مفتوحة ولكنها تتحرك إلى خلف نافذة المخطط.

    • انقر في نافذة المخطط. حيث إن نافذة المجموعة النصية تظل مفتوحة ولكن تتحرك خلف نافذة المخطط.

    • قم بإغلاق نافذة story editor.

    • اختر اسم المستند من أسفل قائمة Window.

إظهار أو إخفاء عناصر Story Editor

يمكنك إظهار عمود اسم النمط ومسطرة العمق أو إخفائهم، وتوسيع الحواشي أو تقليصها، وإظهار علامات انكسار الفقرة أو إخفائها لتشير إلى بداية فقرات جديدة. تؤثر هذه الإعدادات على كل نوافذ محرر المجموعة النصية المفتوحة وأي نافذة سيتم فتحها لاحقًا.

  • عندما يكون محرر المجموعة النصية نشط، اختر View > Story Editor > Show Style Name Column أو Hide Style Name Column. يمكنك أيضًا ضبط عرض العمود الخاص بأسماء الأنماط عن طريق سحب الشريط العمودي. علمًا بأن نوافذ محرر المجموعة النصية التالية سوف يكون لها نفس عرض العمود.
  • عندما يكون محرر المجموعة النصية نشط، اختر View > Story Editor > Show Depth Ruler أو Hide Depth Ruler.
  • في حالة تنشيط Story Editor، اختر View > Story Editor > Expand All Footnotes أو Collapse AllFootnotes.
  • مع وجود محرر المجموعة النصية في حالة نشطة، اختر View > Story Editor > Show Paragraph Break Marks أو Hide Paragraph Break Marks.

تفضيلات Story Editor

استخدم تفضيلات Story Editor Display لتغيير مظهر Story Editor. مع أن Story Editor يتجاهل كل أنماط النص ما عدا خصائص أنماط النص الأساسية، فأن بعض الكائنات والخصائص يتم تمثيلها، متضمنةً ما يلي:

الخاصية

الأيقونة

Table

كائنات داخل السطر

علامات تمييز XML

متغيرات

مصادر الارتباط التشعبي

روابط الارتباط التشعبي

مرجع تبادلي

نص شرطي مخفي

ملاحظة

Footnotes

مبرزات الفهرس

النص المحذوف.

النص المضاف

النص المنقول

 

خيارات عرض النص

اختر الخط، الحجم، المسافات بين السطور، لون النص، والخلفية. يمكنك أيضًا تعيين موضوع مختلف، مثل تحديد نظام تقليدي لعرض نص أصفر على خلفية سوداء. حيث أن هذه الإعدادات تؤثر في كيفية عرض النص في نافذة محرر المجموعة النصية، ولكنها لا تؤثر على كيفية ظهوره في نافذة مخطط الصفحات.

إتاحة الصقل

نعم الحواف المتعرجة للكتابة، واختر نوع الصقل: LCD محسن أو ناعم أو الإعداد الافتراضي، الذي يستخدم ظلال من اللون الرمادي لصقل النص. يستخدم خيار LCD المحسن الألوان، بدلاً من ظلال اللون الرمادي، لصقل النص، حيث يعمل بصورة جيدة على الخلفيات الملونة بألوان فاتحة بينما يكون النص أسود. يستخدم الخيار ناعم ظلال اللون الرمادي، ولكن ينتج عن استخدامه مظهر أفتح وأدق عن المظهر الافتراضي.

خيارات المؤشر

تغيير المظهر لمؤشر النص. على سبيل المثال، اختر Blink، إذا كنت تريد أن يظهر المؤشر على شكل وميض.

لا يظهر النص من إطارات ما بين السطور في نافذة محرر المجموعة النصية الرئيسية، ولكن من الممكن أن يظهر في نافذة محرر مجموعة نصية الخاصة بها.

استخدام النص الشرطي

إن النص الشرطي هو طريقة لإنشاء إصدارات مختلفة من نفس المستند. بعد أن تقوم بإنشاء الشروط، تقوم بتطبيقهم على نطاقات من النص. يمكنك عندئذ إنشاء إصدارات مختلفة من المستندات بشروط إظهار وإخفاء. على سبيل المثال، إذا كنت تقوم بإنشاء كتيب حاسب، يمكنك إنشاء شروط مستقلة لنظام تشغيل Mac OS و نظام تشغيل Windows. قبل أن تطبع إصدار Mac OS من دليل المستخدم، يمكنك إظهار كل النص المطبق عليه شرط "Mac" وإخفاء المطبق عليه شرط "Windows". يمكنك عندئذ عكس حالات الشروط لطباعة دليل المستخدم الخاص بنظام Windows.

النص الشرطي
نص شرطي ظاهر

A. كل الشروط ظاهرة B. مؤشرات شرطية 
تم إخفاء نص شرطي
تم إخفاء نص شرطي

A. شرط "Mac" مخفي B. رموز الشرط المخفي 

يمكن تطبيق الشروط على النص فقط. يمكنك جعل الكائنات المرتبطة شرطية، لكن بتحديد علامة كائن مرتبط فقط. يمكنك تطبيق الشروط على نص في خلايا جدول، لكن لا يمكنك تطبيق الشروط على خلايا، أعمدة، أو صفوف الجدول. لا يمكنك تطبيق الشروط على النص الموجود في مجموعات InCopy النصية المقفلة.

تخطيط المستندات الشرطية

عند التخطيط من أجل مشروع له شروط، اختبر نوعية المواد وانظر إلى كيف يمكن لعدة أشخاص العمل باستخدام المستند إذا تم تسليمها. خطط لمعالجة النص الشرطي بنفس الطريقة لتجعل المستند سهلة في الاستخدام والتعامل. استخدم الإرشادات التالية.

عدد الإصدارات

حدد كم الإصدارات التي سيحتويها مشروع المنتهي. على سبيل المثال، إذا كنت تقوم بإنشاء دليل استخدام يصف برنامج ما والذي يعمل على كل من نظام تشغيل Windows ونظام تشغيل Mac OS، قد ترغب في إنتاج إصدارين على الأقل: إصدار لنظام تشغيل Windows وإصدار لنظام تشغيل Mac OS. إذا كنت تريد إنتاج تلك الإصدارات مع تعليقات تحريرية مدرجة في النص أثناء عملية المراجعة، ستحتاج لإصدارات أكثر: إصدار Mac OS مع التعليقات، إصدار Mac OS بدون تعليقات، إصدار Windows مع التعليقات، وإصدار Windows بدون تعليقات.

للمستندات ذات الشروط الكثيرة، يمكنك تعريف مجموعات شروط يمكن تطبيقها على المستند من أجل الإصدار السريع.

عدد علامات تمييز الشروط المطلوب

حدد عدد علامات تمييز الشروط التي تحتاج لإنتاج الإصدارات المطلوبة. إن إصدار المستند يعرف بمجموعة فريدة من علامات تمييز الشرط. على سبيل المثال، إن إصدار Windows المنتهي من دليل المستخدم يمكن أن يعرف بإظهار علامة تمييز شرط Windows، وعلامة تمييز شرط Mac OS مخفية، وعلامة تمييز التعليقات مخفية. في هذا المثال، قد تحتاج أن تقرر إذا ما كنت تستخدم علامة تمييز شرط لتعليقات Windows وأخرى لتعليقات Mac OS، أو ما إذا كنت ستستخدم علامة تمييز واحدة لكل من تعليقات Windows وتعليقات Mac OS.

تنظيم المحتوى

قم بتقييم مدى شرطية المستند وكيف يمكنك تنظيم المواد لتبسيط التطوير والصيانة. على سبيل المثال، قد يمكنك تنظيم كتاب بحيث يكون النص الشرطي محدود في بضع مستندات. أو قد تختار الاحتفاظ بإصدارات من فصل معين في ملفات مستقلة بدلاً من وجودها في نص شرطي، ثم استخدام ملف كتاب مختلف لكل إصدار من الكتاب.

في بعض الحالات، مثل عندما تعمل باستخدام لغات متعددة، قد ترغب في إنشاء طبقات مستقلة يمكنك إظهارها أو إخفائها بدلاً من استخدام الشروط، مع احتواء كل طبقة على نص بلغة مختلفة.

إستراتيجية وضع علامات التمييز

حدد أصغر وحدة من النص الشرطي. على سبيل المثال، إذا كانت المستند ستترجم إلى لغة أخرى، يجب أن تكون الجملة الكاملة هي أصغر مقدار من النص يمكنك جعله شرطيًا. لأن ترتيب الكلمات يتغير عادة أثناء الترجمة، فإن استخدام النص الشرطي لجزء من الجملة قد يعقد عملية الترجمة.

عدم التناسق في تطبيق الشروط على المسافات وعلامات الترقيم يمكن أن يؤدي إلى مسافات إضافية أو كلمات خاطئة هجائيًا. قرر إذا ما كنت تريد جعل المسافات وعلامات الترقيم شرطية. إذا بدأ النص الشرطي بدأ أو انتهى بعلامة ترقيم، قم بجعل علامات الترقيم شرطية أيضًا. ذلك يجعل النص أسهل للقراءة عندما تعرض أكثر من إصدار.

لتجنب مشاكل المسافات بين الكلمات، مثل وجود مسافة غير شرطية متبوعة بمسافة غير شرطية، قم بوضع مواصفات لمعالجة المسافات التابعة للنص الشرطي (إما أن تكون شرطية دائمًا أو أن تكون غير شرطية دائمًا).

لتجنب التخبط، حدد ترتيب ظهور النص الشرطي واستخدم هذا الترتيب في كل المستند.

الفهارس والمراجع التبادلية

عند فهرسة مستند ما، انتبه إلى إذا ما كانت علامات الفهرس موضوعة داخل أو خارج النص الشرطي. تذكر أن علامات الفهرس الموجودة في النص الشرطي المخفي لن يتم تضمينها في الفهرس المولد.

إذا قمت بإنشاء مرجع تبادلي لنص شرطي، تأكد من أن النص المصدر له نفس الشرط. على سبيل المثال، إذا قمت بإضافة مرجع تبادلي في فقرة "Windows" وظهر رابط النص في شرط "Mac"، فلن تتم ترجمة المرجع التبادلي عندما يكون شرط "Mac" مخفيًا. يظهر "HT" بجوار المرجع التبادلي في لوحة Hyperlinks.

إذا قمت بإنشاء مرجع تبادلي لفقرة بها نص شرطي ثم قم بتغيير إعدادات الرؤية الشرطية، قم تحديث المرجع التبادلي.

إنشاء الشروط

يتم حفظ الشروط التي تقوم بإنشائها في المستند الحالية. إذا لم يكن هناك مستندات مفتوحة عندما تقوم بإنشاء شرط، فإن ذلك الشرط يظهر في كل المستندات الجديدة التي تقوم بإنشائها.

يمكنك تسهيل التعرف على النص الشرطي بتعيين مؤشرات للشرط، كخط سفلي متعرج.

  1. اختر Window > Type & Tables > Conditional Text لعرض لوحة Conditional Text.
  2. اختر New Condition من قائمة لوحة Conditional Text، واكتب اسمًا للشرط.
  3. في مجموعة المؤشر، حدد مظهر المؤشر الذي يطبق عليه الشرط.

    بشكل افتراضي، تضبط المؤشرات (مثل الخط السفلي المتعرج) بأن تظهر في المستند لكن لا تظهر في الطباعة أو الإخراج. يمكنك تحديد خيار من قائمة Indicators في لوحة Conditional Text لإخفاء المؤشرات أو لطباعهم وإخراجهم، مما يمكن أن يكون مفيدًا لأغراض المراجعة.

  4. انقر فوق OK.

تطبيق الشروط على النص

يمكنك تطبيق شروط متعددة على نفس النص. بشكل افتراضي، تعرف المؤشرات النص الشرطي. ومع ذلك، إذا كانت المؤشرات، يمكنك استخدام لوحة Conditional Text لتحدد أي الشروط تم تطبيقها على النص الحالي. تشير علامة التأشير الصلبة إلى الشروط المطبقة على النص الحالي. تشير علامة التأشير غير النشطة إلى أن الشروط تم تطبيقها على جزء من التحديد.

  1. حدد النص الذي تريد تطبيق الشرط عليه.
  2. في لوحة Conditional Text (Windows > Type & Tables > Conditional Text)، قم بأي من الأمور التالية:
    • لتطبيق شرط، انقر فوق الشرط، أو انقر فوق المربع المجاور لاسم الشرط.

    • لتطبيق وإزالة الشروط المطبقة على النص، انقر مع الضغط على Alt (في Windows) أو انقر مع الضغط على Option (في Mac OS) على شرط ما.

    • لإزالة شرط ما، انقر فوق المربع المجاور لاسم الشرط لإزالة علامة التأشير. أو، انقر فوق [غير شرطي] لإزالة كل الشروط من النص المحدد.

ملاحظة:

لا يمكنك تطبيق اختصار لوحة مفاتيح على شروط معينة. ومع ذلك، يمكنك تطبيق شروط باستخدام Quick Apply.

إظهار أو إخفاء الشروط

عندما تقوم بإخفاء شرط، فإن كل النص المطبق عليه الشرط يكون مخفيًا. يسبب إخفاء الشروط أن تتغير أرقام الصفحات في مستند أو كتاب. يمكنك استخدام ميزة إعادة تدفق النص الذكي لإضافة أو إزالة الصفحات آليًا وأنت تخفي أو تظهر الشروط.

يتم تجاهل النص الشرطي المخفي بصفة عامة في المستند. على سبيل المثال، لا يطبع النص المخفي أو يصدر، وتكون علامات الفهرس الموجودة في النص الشرطي المخفي غير متضمنة في الفهرس المولد، والنص الشرطي المخفي لا يتم تضمينه عند البحث أو التدقيق الإملائي للنص.

عندما تخفي شرط ما، فإن النص المخفي يتم تخزينه في رمز شرطي مخفي . إذا قمت بتحديد النص الذي يحتوي على رمز شرطي مخفي وحاول حذفه، يطلب InDesign منك تأكيد أنك تريد حذف النص الشرطي المخفي. لا يمكنك تطبيق الشروط، الأنماط، أو التنسيق الأخرى على نص شرطي مخفي.

إذا كان للنص شروط متعددة مطبقة عليه وهناك شرط واحد على الأقل من تلك الشروط ظاهر بينما الآخرين مخفيين، فإن النص لا يكون مخفيًا.

  • لإظهار أو إخفاء الشروط بشكل منفرد، انقر فوق مربع الرؤية المجاور لاسم الشرط. تشير أيقونة العين إلى أن الشرط ظاهر.
  • لإظهار أو إخفاء كل الشروط، اختر Show All أو Hide All من قائمة لوحة Conditional Text.

استخدام المجموعات الشرطية

تلتقط المجموعة الشرطية إعدادات الرؤية لكل الشروط بحيث يمكنك تطبيق تنقيحات مختلفة على المستند بسرعة. على سبيل المثال، بفرض أن لديك مستند معقدة بشروط بيئة العمل الخاصة بنظام تشغيل Mac OS، Windows XP، Vista، UNIX، وشروط اللغة الإنجليزية، الفرنسية، الألمانية، والأسبانية، والشروط التحريرية مثل المراجعة التحريرية والتعليقات الداخلية. لمراجعة إصدار Vista بالفرنسية، يمكنك إنشاء مجموعة تعرض فقط شروط Vista، French، وشروط المراجعة التحريرية، وإخفاء كل الباقي.

بينما المجموعات ليست ضرورية لعمل ذلك، إلا إنها تساعدك في تغيير إعدادات رؤية الشروط المختلفة بسرعة وفعالية.

  1. قم بتطبيق الشروط حسب الضرورة.
  2. إذا لم تظهر القائمة Set في لوحة Conditional Text، فاختر Show Options من قائمة لوحة Conditional Text.
  3. في لوحة Conditional Text، قم بجعل الشروط ظاهرة أو مخفية حسب الاحتياج.
  4. اختر Create New Set من قائمة Set، وحدد اسم للمجموعة، وانقر فوق OK.

    تصبح المجموعة الجديدة هي المجموعة النشطة.

  5. قم بأي من الأمور التالية:
    • لتطبيق المجموعة الشرطية على مستند ما، اختر اسم المجموعة الشرطية من قائمة Set.

    • لتخطي مجموعة شرطية، حدد المجموعة لتجعلها نشطة، وتغيير إعداد الرؤية لأي شرط. تظهر علامة زائد (+) بجوار المجموعة الشرطية. اختر المجموعة النصية مرة أخرى لإزالة التخطيات. اختر Redefine"[Condition Set]" لتحديث المجموعة الشرطية بإعدادات الرؤية الجديدة.

    • لحذف مجموعة شرطية، حدد المجموعة الشرطية، ثم اختر Delete "[Condition Set]." لا يؤدي حذف مجموعة شرطية إلى حذف شروط المجموعة، ولا يقوم بإزالة الشروط من أي مكان يتم تطبيقها.

إدارة الشروط

  1. قم بأي من الأمور التالية:

    حذف شرط

    حدد شرطًا وانقر فوق أيقونة Delete Condition في أسفل لوحة Conditional Text. حدد شرط ما واستبدل الشرط المحذوف وانقر فوق OK. الشرط الذي تقوم بتحديده لتطبيقه على كل النص والذي كان مطبق عليه الشرط المحذوف.

    لحذف شروط متعددة، انقر مع الضغط فوق مفتاح Shift لتحديد شروط متتالية، أو انقر مع الضغط فوق مفتاح Ctrl (في Windows) أو Command (في Mac OS) لتحدد شروط غير متتالية، ثم انقر فوق أيقونة حذف الشرط.

    إزالة شرط من نص ما

    إزالة علامة تمييز شرط من نص يختلف عن حذف علامة تمييز من مستند. عند إزالة علامة تمييز من نص، فإن علامة التمييز تبقى في المستند بحيث يمكن تطبيقها مرة أخرى لاحقًا.

    لإزالة شرط من النص، حدد النص وانقر فوق المربع المجاور للشرط لإزالة علامة التأشير، أو انقر فوق [Unconditional] لتزيل كل الشروط من النص المحدد.

    تحميل (استيراد) الشروط

    اختر Load Conditions (لتحمل الشروط فقط) أو Load Conditions And Sets من قائمة لوحة Conditional Text. حدد مستند InDesign تريد استيراد الشروط منها، وانقر فوق Open. يتم استبدال الشروط والمجموعات المحملة بأي شرط أو مجموعة لها نفس الاسم.

    لا يمكنك تحميل الشروط من ملف InCopy في InDesign، لكن يمكنك تحميل الشروط من ملف InDesign وInCopy.

    تتجاهل المجموعات المحملة إعدادات الرؤية من الشروط الموجودة حاليًا في لوحة Conditional Text.

    تزامن الشروط في كتاب

    لتتأكد من أنك تستخدم نفس الشروط في كل مستندات الكتاب، قم بإنشاء نفس الشروط في كل المستندات الموجودة في كتاب ما، قم بإنشاء شروط تريدها في مصدر نمط المستند، حدد إعدادات النص الشرطي في شاشة خيارات التزامن، ثم قم بتزامن الكتاب.

    إظهار أو إخفاء مؤشرات الشرط

    اختر Show أو Hide من القائمة Indicators في لوحة Conditional Text لإظهار أو إخفاء مؤشرات الشرط. إذا كنت تظهر إصدار وتريد أن ترى أي المساحات تكون شرطية، فقم بإظهار مؤشرات الشرط. إذا وجدت مؤشرات شرطية تتداخل أثناء عرض التخطيط، فقم بإخفاء مؤشرات الشرط. اختر Show And Print إذا كنت تريد طباعة المؤشرات وإخراجها.

    تغيير اسم شرط ما

    في لوحة Conditional Text، انقر فوق شرط ما، وتوقف مؤقتًا، ثم انقر فوق اسم الشرط لتحديده. اكتب اسم مختلف.

    قم بتحرير المؤشرات

    في لوحة Conditional Text، انقر نقرًا مزدوجًا فوق أحد الشروط، أو حدد شرطًا واختر Condition Options من قائمة اللوحة. حدد إعدادات المؤشر، وانقر فوق OK.

البحث واستبدال النص الشرطي

استخدم مربع الحوار Find/Change للعثور على نص مطبق عليه شرط أو أكثر واستبداله بشرط أو أكثر.

  1. إظهار النص الشرطي الذي تريد تضمينه في البحث.

    يتم استثناء النص المخفي من البحث.

  2. اختر Edit > Find/Change.
  3. إذا لم يظهر المربعان Find Format وChange Format في أسفل مربع الحوار، فانقر فوق More Options.
  4. انقر فوق المربع Find Format لعرض مربع الحوار Find Format Settings. تحت الشروط، حدد [أي شرط] للبحث عن النص الذي تم تطبيق أي شرط عليه، [غير شرطي] للبحث عن نص لم يطبق عليه أي شرط، أو حدد الشرط المعين أو الشروط المعينة التي تبحث عنها. انقر فوق OK.

    تبحث هذه الميزة عن النص الذي يطابق الشروط المحددة تمامًا. على سبيل المثال، إذا قمت بتحديد كلاً من الشرط 1 والشرط 2، فإن النص الذي ينطبق عليه أحد الشرطين فقط لا يتم العثور عليه، ولا النص الذي ينطبق عليه الشرطين مع شروط أخرى.

  5. انقر فوق المربع Change Format لعرض مربع الحوار Change Format Settings. حدد خيار التنسيق المختلف، مثل شرط أو نمط حرف، ثم انقر فوق OK.

    إذا قمت بتحديد قسم Conditions في مربع الحوار Change Format Settings، فإن [Any Condition] لا يقوم بإجراء التغييرات على النص الشرطي الذي تم العثور عليه. يفيد هذا الخيار إذا كنت تريد تطبيق تنسيق مختلف مثل نمط حرف. حدد [Unconditional] لإزالة كل الشروط من النص الذي تم العثور عليه. إذا قمت بتحديد شرط معين، حدد إذا ما كنت تريد استبدال أي شرط مطبق على النص المعثور عليه أو إضافة إليه.

  6. انقر فوق Find، ثم استخدم الأزرار Change، أو Change/Find، أو Change All لاستبدال الشرط.

تم ترخيص هذا العمل بموجب الترخيص العام غير المعدل الخاص بالإسناد وعدم التجارة والمشاركة الإصدار 3.0 ‏من ‏‏Creative Commons‏‏  إن بنود Creative Commons لا تشمل منشورات Twitter™‎ وFacebook.

إشعارات قانونية   |   سياسة الخصوصية على الإنترنت