دليل المستخدم إلغاء

الأزرار

  1. دليل مستخدم InDesign
  2. التعرّف على InDesign
    1. مقدمة عن InDesign
      1. الجديد في InDesign
      2. متطلبات النظام
      3. الأسئلة الشائعة
      4. استخدام Creative Cloud libraries
    2. مساحة العمل
      1. أساسيات مساحات العمل
      2. صندوق الأدوات
      3. تعيين التفضيلات
      4. مساحة العمل Touch
      5. اختصارات لوحة المفاتيح الافتراضية
      6. استرداد المستندات والتراجع
      7. ملحق Capture
  3. إنشاء المستندات وتخطيطها
    1. المستندات والصفحات
      1. إنشاء المستندات
      2. العمل باستخدام الصفحات الرئيسية
      3. العمل باستخدام صفحات المستندات
      4. تعيين حجم الصفحة والهوامش والتسييل
      5. العمل باستخدام الملفات والقوالب
      6. إنشاء ملفات كتاب
      7. إضافة ترقيم صفحات أساسي
      8. ترقيم الصفحات والفصول والأقسام
      9. تحويل مستندات QuarkXPress وPageMaker
      10. مشاركة المحتوى
      11. فهم سير العمل الأساسي لملف مدار
      12. حفظ المستندات
    2. الشبكات
      1. الشبكات
      2. تنسيق الشبكات
    3. الأدوات المساعدة للتخطيط‬
      1. المساطر
  4. إضافة المحتوى
    1. النص
      1. إضافة نص إلى الإطارات
      2. نص مؤشر الترابط
      3. ميزات اللغتين العربية والعبرية في InDesign
      4. إنشاء كتابة على مسار
      5. التعداد النقطي والرقمي
      6. الأحرف الرسومية والأحرف الخاصة
      7. تكوين النص
      8. متغيرات النص
      9. أنشاء أكواد QR
      10. تحرير النص
      11. محاذاة النص
      12. التفاف النص حول الكائنات
      13. الكائنات المرتبطة
      14. المحتوى المرتبط
      15. تنسيق الفقرات
      16. تنسيق الأحرف
      17. بحث /تغيير
      18. التدقيق الإملائي وقواميس اللغة
    2. أسلوب الطباعة
      1. استخدام الخطوط في InDesign
      2. تقنين الأحرف والتعقب
    3. تنسيق النص
      1. تنسيق النص
      2. الجدولة والمسافات البادئة
    4. مراجعة النص
      1. تتبع التغييرات ومراجعتها
      2. إضافة ملاحظات تحريرية في InDesign
      3. استيراد تعليقات PDF
    5. إضافة المراجع
      1. إنشاء جدول محتويات
      2. الحواشي السفلية
      3. إنشاء فهرس
      4. التعليقات الختامية
      5. التعليقات
    6. الأنماط
      1. أنماط الفقرة والحرف
      2. أنماط الكائنات
      3. الحروف الاستهلالية والأنماط المتداخلة
      4. العمل باستخدام الأنماط
      5. المسافة البادئة
    7. الجداول
      1. تنسيق الجداول
      2. إنشاء الجداول
      3. أنماط الجداول والخلايا
      4. تحديد الجداول وتحريرها
      5. حدود الجداول وتعبئاتها‬
    8. التفاعل
      1. الارتباطات التشعبية
      2. مستندات PDF الديناميكية
      3. الإشارات المرجعية
      4. الأزرار
      5. النماذج
      6. الرسومات المتحركة
      7. الإسنادات الترافقية
      8. بنية ملفات PDF
      9. انتقالات الصفحة
      10. الأفلام والأصوات
      11. النماذج
    9. الرسومات
      1. فهم المسارات والأشكال
      2. الرسم باستخدام أداة Pencil
      3. الرسم باستخدام الأداة Pen
      4. تطبيق إعدادات الخط (الحد) 
      5. المسارات والأشكال المركبة
      6. تحرير المسارات
      7. مسارات القطع
      8. تغيير مظهر الزاوية
      9. محاذاة الكائنات وتوزيعها
      10. الرسومات المرتبطة والمدرجة
      11. دمج AEM Assets
    10. اللون والشفافية
      1. تطبيق لون
      2. استخدام الألوان من الرسومات المستوردة
      3. العمل باستخدام العينات
      4. خلط الأحبار
      5. الصبغات
      6. فهم ألوان المعالجة والتركيز
      7. مزج الألوان
      8. المكونات
      9. تسوية عمل فني شفاف
      10. إضافة تأثيرات الشفافية
  5. Share
    1. المشاركة والتعاون        
    2. المشاركة للمراجعة
    3. معاينة مستند InDesign مشترك
    4. ادارة الملاحظات 
  6. Publish
    1. التصدير والنشر
      1. النشر عبر الإنترنت
      2. تصدير محتوى لـ EPUB
      3. خيارات Adobe PDF
      4. تصدير محتوى إلى HTML
      5. تصدير إلى Adobe PDF
      6. تصدير إلى تنسيق JPEG
      7. تصدير HTML
      8. نظرة عامة على DPS وAEM Mobile
    2. الطباعة
      1. طباعة كتيبات
      2. علامات الطابعة والتسييل
      3. طباعة المستندات
      4. الأحبار والفاصل وتردد الشاشة
      5. الطباعة المتراكبة
      6. إنشاء ملفات PostScript وEPS
      7. التحقق من صحة الملفات قبل التسليم
      8. طباعة الصور المصغرة والمستندات ذات الحجم الكبير
      9. إعداد ملفات PDF لموفري الخدمة
      10. التجهيز لطباعة الفواصل
  7. توسيع InDesign
    1. التشغيل التلقائي
      1. دمج البيانات
      2. المكونات الإضافية
      3. ملحق Capture في InDesign
      4. البرامج النصية
ملاحظة:

اللغة المنصفة: نحن نستبدل اللغة غير الشاملة من InDesign 2022 (الإصدار 17.0) وما بعده، لتعكس قيم Adobe الأساسية للشمولية. يتم استبدال أي إشارة إلى الصفحة الرئيسية بالصفحة الرئيسية في مقالات المساعدة الخاصة بنا للغات الإنجليزية والدانماركية والمجرية والإسبانية والإيطالية والبرازيلية والبرتغالية واليابانية.

ملاحظة:

بدءًا من الإصدار 15.0 من InDesign، لم تعد تنسيقات ملفات Flash‏ (.FLV و.F4V) متوفرة. تمت إزالة جميع الخيارات المتعلقة بهذه التنسيقات من اللوحات المعنية. لمزيد من المعلومات، راجع نهاية عمر Flash Player | التأثير في InDesign.

إنشاء الأزرار

يمكنك إنشاء أزرار تنفذ إجراء ما عندما يتم تصدير المستند إلى تنسيق EPUB أو PDF ذي التخطيط الثابت. على سبيل المثال، يمكنك إنشاء زر للانتقال إلى صفحة مختلفة أو لفتح موقع ويب.

إعداد زر لعرض فيلم في ملف PDF مُصدَّر

بعد إنشاء الزر، يمكنك عمل التالي:

ملاحظة:

عند العمل على الأزرار وتصميم مستندات ديناميكية، حدد مساحة العمل Interactive for PDF.

إنشاء زر

  1. استخدم أداة Pen أو أداة رسم، مثل أداة Rectangle أو أداة Ellipse، لرسم شكل الزر. وإذا لزم الأمر، فاستخدم أداة Type لإضافة نص إلى الزر، مثل "Next" أو "Purchase".
    ملاحظة:

    إذا كنت تقوم بإنشاء أزرار تصفح (مثل Next Page أو Previous Page) تظهر على عدة صفحات، فأضفها إلى صفحة رئيسية حتى لا تحتاج إلى إعادة إنشاء الأزرار على كل صفحة من صفحات المستند. نظهر هذه الأزرار على كل صفحات المستند التي تُطبق عليها الصفحة الرئيسية.

  2. استخدم أداة Selection لتحديد الصورة، أو الشكل، أو إطار النص الذي تريد تحويله.

    لا يمكنك تحويل فيلم، أو صوت، أو ملصق إلى زر.

  3. انقر فوق أيقونة Convert To Button في لوحة Buttons and Forms (اختر Window > Interactive > Buttons and Forms). أو اختر Object > Interactive > Convert to Button.

    Convert To Button

  4. في لوحة Buttons and Forms، قم بالإجراءات التالية:

    • حدد الزرمن قائمة Type المنسدلة.
    • في مربع النص Name حدد اسمًا للزر لتميزه عن الأزرار الأخرى التي تقوم بإنشائها.
    • حدد الحدثالذي سيؤدي إلى تشغيل الإجراء المطلوب.
    • حدد إجراءً واحدًا أو أكثرللزر لتحديد ما يحدث عند تشغيل الحدث في ملف PDF أو EPUB ذي التخطيط الثابت المُصدَّر. راجع جعل الأزرار تفاعلية.
  5. استخدم لوحة Preview (Window > Interactive > EPUB Interactivity Preview) لاختبار الزر قبل تصدير المستند إلى تنسيق PDF أو أو EPUB ذي التخطيط الثابت التفاعلي. يمكنك أيضًا نشر المستند عبر الإنترنت باستخدام Publish Online.

إضافة زر من لوحة Sample Buttons

تتضمن لوحة Sample Buttons عددًا من الأزرار المُنشأة مسبقًا والتي يمكنك سحبها إلى المستند. وتتضمن نماذج الأزرار هذه تأثيرات مثل تدرج الحواف والظلال المسقطة، مع مظهر مختلف قليلاً لمظهر Rollover. وللأزرار النموذجية إجراءات معينة لها أيضًا. على سبيل المثال، أزرار الأسهم النموذجية مُعيَّن لها مسبقًا الإجراءات Go To Next Page أو Go To Previous Page. ويمكنك تحرير هذه الأزرار لتلائم احتياجاتك.

تُعدّ لوحة Sample Buttons مكتبة للكائنات. ومثل أي مكتبة كائنات، يمكنك إضافة أزرار إلى اللوحة وإزالة الأزرار التي لا تريد استخدامها. (راجع استخدام مكتبات الكائنات.) يتم تخزين الأزرار النموذجية في ملف ButtonLibrary.indl، والموجود في المجلد Presets/Button Library في مجلد تطبيق InDesign.

  1. اختر Sample Buttons And Forms من قائمة لوحة Buttons and Forms لفتح لوحة Sample Buttons And Forms.

    لوحة Open Sample Buttons And Forms

  2. اسحب زرًا من لوحة Sample Buttons And Forms إلى المستند. إذا أردت ظهور أزرار التصفح في كل صفحة، فأضف الأزرار إلى صفحة رئيسية.

    Sample Buttons And Forms
    لوحة Sample Buttons And Forms

  3. حدد الزر باستخدام أداة Selection، ثم قم بتحرير الزر حسب الحاجة باستخدام لوحة Buttons and Forms.

    أثناء تحرير الأزرار النموذجية، تذكر ما يلي:

    • إذا قمت بإضافة نص إلى زر ما، فتذكر أن تنسخ النص وتلصقه من حالة الزر Normal إلى حالة الزر Rollover. وإلا، فإن النص الذي تقوم بإضافته لن يظهر عند مرور الماوس فوق الزر في ملف PDF أو EPUB ذي التخطيط الثابت.

    • يمكنك تغيير حجم الأزرار. إذا قمت بسحب زوج من أزرار الصفحة التالية والسابقة السهميين، قم بتغيير الزر الأول، ثم حدد الزر الثاني واختر Object > Transform Again > Transform Again.

  4. استخدم لوحة Preview (Window > Interactive > EPUB Interactivity Preview) لاختبار الزر قبل تصدير المستند إلى تنسيق PDF أو EPUB ذي التخطيط الثابت التفاعلي.  يمكنك أيضًا نشر المستند عبر الإنترنت باستخدام Publish Online.

تحويل زر إلى كائن

عند تحويل زر إلى كائن، تبقى محتويات الزر على الصفحة دون خصائص الزر. وتتم إزالة أي محتوى مرتبط بالحالات الأخرى للزر أيضًا.

  1. استخدم أداة Selection لتحديد الزر.
  2. اختر Object > Interactive > Convert To Object.

جعل الأزرار تفاعلية

تم ضبط الزر لتشغيل الصوت
تم تعيين هذا الزر لتشغيل صوت عند النقر فوق زر الماوس.

يمكنك إنشاء تأثيرات تفاعلية أو تحريرها أو إدارتها في InDesign. وعند تصدير المستند إلى تنسيق PDF أو EPUB ذي التخطيط الثابت، قد تكون هذه الإجراءات التفاعلية نشطة.

على سبيل المثال، لنفترض أنك تريد إنشاء زر لتشغيل صوت في مستند PDF. يمكنك وضع ملف الصوت في مستند InDesign، ثم إنشاء زر لتشغيل الصوت عند نقره في مستند PDF.

في هذا المثال، يمثل النقر بالماوس الحدث، أما تشغيل الصوت فهو الإجراء.

ملاحظة:

بعض الإجراءات مدعومة في كلٍّ من ملفات PDF وEPUB بينما البعض الآخر مدعوم في PDF أو أو EPUB فقط. عند اختيار إجراء ما، تجنب اختيار إجراء PDF فقط إذا كنت تقوم بالتصدير إلى EPUB ذي التخطيط الثابت. أيضا، تجنب اختيار إجراء EPUB فقط إذا كنت تقوم بالتصدير إلى PDF.

إضافة إجراءات للأزرار

يمكنك تعيين إجراءات لأحداث مختلفة. على سبيل المثال، في ملف PDF مُصدَّر، يمكنك تحديد صوت لتشغيله عند دخول مؤشر الماوس في مساحة الزر، وفيلم لتشغيله عند نقر زر الماوس وتحريره. كما يمكنك تعيين عدة إجراءات لنفس الحدث. على سبيل المثال، يمكنك إنشاء إجراء لتشغيل فيلم وتعيين نسبة تكبير/تصغير العرض على الحجم الحقيقي Actual Size.

  1. استخدم أداة Selection لتحديد الزر الذي أنشأته.
  2. في لوحة Buttons and Forms، اختر حدثًا، مثل On Release، الذي يحدد كيفية تنشيط الإجراءات.

  3. انقر فوق زر علامة الزائد المجاور لـ Actions، واختر الإجراء الذي تريد تعيينه للحدث.
  4. حدد الإعدادات الخاصة بالإجراء.

    على سبيل المثال، إذا اخترت Go To First Page، فحدد نسبة التكبير/التصغير. وإذا اخترت Go To URL، فحدد عنوان صفحة الويب. بعض الإجراءات مثل Go To Next View، ليس لها إعدادات إضافية.

  5. وإذا لزم الأمر، فاستمر في إضافة الإجراءات حسب الحاجة لأي حدث.
  6. لاختبار الزر، قم بتصدير المستند إلى تنسيق PDF أو EPUB ذي التخطيط الثابت واعرض الملف الذي تم تصديره. وإذا كنت تقوم بالتصدير إلى ملف PDF، فتأكد من تحديد الخيار Interactive Elements.

أنواع الحدث

تحدد الأحداث كيفية تنشيط الإجراءات في الأزرار عند تصدير المستند إلى EPUB أوPDF. (في Acrobat، تسمى الأحداث المُشغلات).

On Release or Tap

عند تحرير زر الماوس بعد النقر. وهذا هو أكثر الأحداث استخدامًا؛ لأنها تعطي المستخدم فرصة أخيرة لسحب المؤشر بعيدًا عن الزر ولا يتم تنشيط العملية.

On Click

عند نقر زر الماوس (دون تركه ما لم يكن لديك سبب محدد لاستخدام On Click، يُفضّل استخدام On Release بحيث يكون لدى المستخدمين فرصة لإلغاء الإجراء.

On Roll Over

عند دخول مؤشر الماوس في منطقة الزر المحددة بمربع حدود الزر.

On Roll Off

عند خروج مؤشر الماوس من منطقة الزر.

On Focus‏ (PDF)

عند تلقي الزر في ملف PDF لتركيز، إما عن طريق إجراء من الماوس أو ضغط مفتاح Tab.

On Blur‏ (PDF)

عند انتقال التركيز إلى زر مختلف أو حقل نموذج في ملف PDF.

أنواع الإجراءات

عند إنشاء إجراء، فإنك تشير إلى ما يحدث عند وقوع الحدث المحدد - عادة عند نقر الزر. ويمكنك تعيين الإجراءات التالية لتحدث عند تنشيط نوع الحدث:

Go To Destination

للانتقال إلى نقطة ارتساء النص المحددة الذي تم إنشاؤها باستخدام لوحة Bookmarks أو Hyperlinks. راجع إنشاء انتقالات إلى نقاط ارتساء النص.

Go To First/Last/Next/Previous Page

للانتقال إلى الصفحة الأولي، أو الأخيرة، أو التالية في ملف PDF أو EPUB ذي التخطيط الثابت. حدد خيارًا من قائمة Zoom لتحديد كيفية عرض الصفحة.

Go To URL

لفتح صفحة الويب الخاصة بعنوان URL المحدد.

Show/Hide Buttons and Forms

للتبديل بين إظهار الأزرار المحددة وإخفائها في ملف PDF أو EPUB ذي التخطيط الثابت المُصدَّر. على سبيل المثال، إذا أردت ظهور أحد الأزرار عند تحريك مؤشر الماوس فوق زر آخر، فإنه يمكنك إخفاء الزر المستهدف حتى يتم تشغيله وإنشاء إجراء لعرض الزر المخفي عند التمرير فوقه. راجع عرض زر مختلف عند التمرير الفوقي.

ينطبق على EPUB/Publish Online فقط

الرسومات المتحركة

يتيح لك تشغيل الرسوم المتحركة المحددة أو إيقافها مؤقتًا أو إيقافها أو استئناف تشغيلها. وتظهر الرسوم المتحركة التي تمت إضافتها فقط إلى المستند في قائمة Animation.

اذهب إلى صفحة

ينتقل إلى الصفحة في ملف EPUB الذي تحدده.

الانتقال إلى الحالة

للانتقال إلى حالة معينة في كائن متعدد الحالات. على سبيل المثال، إذا كان الكائن المتعدد الحالات يتضمن عدة صور مختلفة كحالات، ويمكنك استخدام هذا الإجراء لعرض صورة معينة.

Go To Next/Previous State

للانتقال إلى الحالة التالية أو السابقة في كائن متعدد الحالات. وتُفيد هذه الخيارات بشكل خاص عند النقر عبر عرض شرائح. راجع إنشاء كائنات متعددة الحالات.

Sound

يتيح لك تشغيل قصاصة الصوت المحددة أو إيقافها مؤقتًا أو إيقافها أو استئناف تشغيلها. وتظهر الأصوات التي تمت إضافتها إلى المستند فقط في قائمة Sound.

Video

يتيح لك عرض الفيلم المحدد أو إيقافه مؤقتًا أو إيقافه أو استئناف تشغيله. وتظهر الأفلام التي تمت إضافتها إلى المستند فقط في القائمة Video.

ينطبق على PDF فقط

Clear Form

يمسح جميع البيانات المملوءة في حقول النموذج ويجلب النموذج إلى حالته الأصلية.

الذهاب إلى المنظر التالي

للانتقال إلى صفحة بعد الانتقال إلى العرض السابق. وبنفس الطريقة التي ينشط بها زر Forward في متصفح الويب فقط بعد نقر زر Back، ينشط هذا الخيار فقط إذا كان المستخدم قد انتقل إلى عرض سابق.

الذهاب إلى المنظر السابق

للانتقال إلى آخر صفحة تم عرضها في مستند PDF، أو للرجوع إلى آخر حجم تكبير تم استخدامه.

فتح ملف

لفتح الملف الذي تحدده. إذا قمت بتحديد ملف غير PDF، يحتاج القارئ التطبيق الأصلي لفتحه بنجاح. حدد اسم مسار مطلق (مثل C:\docs\sample.pdf).

Print Form

يفتح مربع حوار الطباعة لطباعة النموذج.

تسليم النموذج

يرسل البيانات المعبأة في حقول النموذج إلى عنوان URL المذكور. تحتاج لإدخال mailto: في حقل URL ثم عنوان البريد الإلكتروني بعد ذلك لإرسال النموذج المعبأ إلى البريد الإلكتروني المذكور. تأكد من عدم وجود مسافة قبل النقطتين (:) وبعدهما.

تحجيم المنظر

لعرض الصفحة وفقًا لخيار التكبير الذي تحدده. يمكنك تغيير مستوى التكبير (مثل Actual Size)، تخطيط الصفحة (مثل Continuous - Facing)، أو اتجاه التدوير.

تحرير إجراءات الزر أو حذفها

  1. استخدم أداة Selection لتحديد الزر.
  2. في لوحة Buttons and Forms، قم بأحد الإجراءات التالية:

    • لإلغاء تنشيط الإجراءات، ألغِ تحديد مربع الاختيار المجاور للعنصر. ويمكن أن يكون إلغاء تنشيط الأحداث مفيدًا لأغراض الاختبار.
    • لتغيير الترتيب، اسحب الإجراءات وأفلتها.
    • لحذف إجراء، حدد الإجراء في مربع القائمة، وانقر زر Delete Selected Action.
    • لتحرير إجراء، اختر الحدث المُعيَّن له الإجراء، وحدد الإجراء في مربع القائمة، وقم بتغيير الإعدادات. إذا احتجت لاستبدال إجراء لحدث موجود، احذف الإجراء، ثم أضف الإجراء الجديد للحدث.

إنشاء انتقالات إلى نقاط ارتساء نص

إذا أنشأت نقطة ارتساء نص في مستند InDesign، يمكنك إنشاء زر للانتقال إلى نقطة الارتساء هذه، حتى وإن كان في مستند InDesign آخر. استخدم لوحة Bookmarks ولوحة Hyperlinks لإضافة نقاط ارتساء نص. لا يمكن إنشاء انتقالات من الأزرار إلى الإشارات المرجعية التي لا تمثل نقاط ارتساء نص.

ملاحظة:

إذا قمت بتعيين وجهة ارتباط تشعبي إلى زر، فلن يكون للارتباط التشعبي تأثير في مستند PDF أو EPUB ذي التخطيط الثابت المُصدَّر.

  1. استخدم أداة Selection لتحديد الزر.
  2. في لوحة Buttons and Forms، اختر الحدث مثل On Release الذي سيشغل الانتقال.

  3. انقر زر علامة زائد الموجود بجوار Actions، واختر Go To Destination.
  4. حدد مستندًا من مستندات InDesgin المفتوحة من قائمة Documents، أو انقر أيقونة المجلد الموجودة على يمين القائمة وحدد الملف.
  5. حدد نقطة ارتساء نص تم إنشاؤها باستخدام لوحة Bookmarks أو لوحة Hyperlinks.
  6. حدد خيارًا من قائمة Zoom لتحديد كيفية عرض الصفحة.
ملاحظة:

إذا قمت بتعيين نقطة ارتساء نص في مستند مختلف، فتذكر أن تقوم بتصدير المستند المستهدف إلى ملف PDF، واستخدم نفس اسم مستند InDesign، مع استبدال الامتداد INDD بالامتداد PDF. أيضًا، احفظ مستندات PDF في نفس المجلد للتأكد من بقاء الروابط سليمة في Acrobat وReader.

تغيير مظهر الزر للتمرير الفوقي والنقر

يتكون الزر من مجموعة من الكائنات المفردة التي يمثل كلٌّ منها مظهرًا لزر (أحيانًا يسمى "حالة"). ويمكن أن يتضمن كل زر حتى ثلاثة مظاهر هي: Normal وRollover وClick. في الملف المُصدَّر، يُستخدم المظهر Normal ما لم يتحرك مؤشر الماوس في المنطقة (Rollover) أو يتم نقر زر الماوس في منطقة الزر (Click). ويمكنك جعل كل مظهر مختلف عن الآخر لتوفير ملاحظات مرئية.

افتراضيًا، يتم تحديد أي زر تنشئه بالمظهر Normal الذي يحتوي على نص الزر أو صورته. وعند تنشيط مظهر جديد، يتم نسخ المظهر Normal. لتمييز مظهر عن غيره من المظاهر، يمكنك تغيير اللون أو إضافة نص أو صورة.

حالات الزر

A. المؤشر ليس فوق مساحة الزر (Normal) B. المؤشر في منطقة الزر (Rollover) C. المؤشر ينقر (Click) 

ملاحظة:

المنطقة التي يمكن النقر فيها، أو النقطة الفعّالة، للزر هي المربع المحيط بأكبر حالة في الزر. على سبيل المثال، الزر المستدير له نقطة فعّالة مربعة.

تغيير مظاهر الزر

إذا كنت تقوم بإنشاء زر يتضمن مظاهر متعددة (Normal وRollover وClick)، فمن الأفضل إنهاء تصميم الزر قبل تنشيط المظاهر الأخرى. عند تنشيط المظهر Rollover أو Click، يتم نسخ المظهر Normal.

تؤثر بعض التغييرات في المظاهر المحددة فقط، بينما تؤثر تغييرات أخرى في جميع المظاهر النشطة. وإذا قمت بتحديد مظهر وقمت بتطبيق لون خلفية مختلف أو تحرير النص، فلن يؤثر التغيير إلا في المظهر المحدد. وإذا استخدمت أداة Selection لنقل الزر أو تغيير حجمه، فسيؤثر التغيير في كل المظاهر.

  1. اختر Window > Interactive > Buttons and Forms لعرض لوحة Buttons and Forms.

  2. باستخدام أداة Selection ، حدد الزر الموجود في التخطيط الذي تريد تحريره.
  3. انقر [Rollover] لتنشيط مظهر Rollover.

    يتم نسخ المظهر Normal إلى Rollover.

  4. مع تحديد المظهر Rollover، قم بتغيير مظهر الزر.
    • لتغيير اللون، اختر عينة ألوان من القائمة Stroke أو Fill في لوحة Control.
    • لوضع صورة في المظهر، حدد الصورة الموجودة باستخدام أداة Direct Selection أو انقر بشكل مزدوج فوق صورة الزر الموجودة، ثم اختر File > Place وانقر نقرًا مزدوجًا فوق ملف ما.
    • للصق صورة في إطار نص، انسخها إلى الحافظة، وحدد المظهر في اللوحة Buttons، ثم اختر Edit > Paste Into.
    • لكتابة النص، حدد أداة Type، وانقر الزر، واكتب النص. يمكنك أيضًا اختيار Edit > Paste Into لنسخ إطار نص ملصوق.
  5. لإضافة المظهر Click، انقر [Click] لتنشيطه، ثم اتبع الإجراء نفسه لتغيير مظهره.
  6. استخدم لوحة Preview لاختبار مظاهر الأزرار المختلفة.
ملاحظة:

لتغيير حجم صور State Appearance المصغرة في لوحة Buttons and Forms، اختر Panel Options من قائمة لوحة Buttons and Forms، وحدد خيارًا، وانقر فوق OK.

حذف المظاهر وتعطيلها

  1. حدد المظهر في لوحة Buttons and Forms.

  2. قم بأي مما يلي:
    • لحذف المظهر Rollover أو Click، انقر الأيقونة Delete بأسفل اللوحة. يُفيد حذف المظاهر بشكل خاص إذا كنت تقوم بتحرير المظهر Normal كثيرًا، وأردت وضع المظهر Rollover أو انقر فوق مظهر Normal الجديد.
    • لتعطيل مظهر دون حذفه، انقر فوق أيقونة العين Eye بجوار المظهر لإلغاء تحديده. ولا يتم تصدير الحالات المعطلة إلى ملف PDF أو EPUB ذي التخطيط الثابت.
ملاحظة:

لا يمكنك حذف الحالة Normal أو تعطيلها.

إنشاء كائنات متعددة الحالات

تتيح لوحة حالات الكائن إنشاء عدة إصدارات من أحد الكائنات. الحالة هي إصدار من عنصر صفحة. يُطلق على الكائن الذي يتضمن حالات متعددة كائن متعدد الحالات.

لا يوجد حد لعدد الحالات التي يمكنك إنشاؤها لأحد الكائنات باستخدام لوحة حالات الكائن. وفي كل وقت تقوم فيه بإنشاء حالة، فأنت تقوم بإنشاء إصدار آخر لعنصر الصفحة. لا تظهر سوى حالة واحدة على الصفحة في المرة. بالنسبة للطباعة ومخرجات PDF، تظهر الحالة النشطة فقط في المخرجات النهائية.

إنشاء عرض شرائح لكائن متعدد الحالات

يعتبر أحد الاستخدامات الشائعة لكائن متعدد الحالات هو عرض الشرائح المتتالي الذي يتيح لمشاهد ملف EPUB النقر لاستعراض مجموعة من الصور. فعلى سبيل المثال، يمكنك إنشاء عرض شرائح يتكون من 20 صورة بدون الحاجة إلى تضمين الصور في 20 صفحة مختلفة.

  1. قم بتضمين الصور التي ستظهر في عرض الشرائح.

    للحصول على أفضل النتائج، احرص على أن تكون إطارات الصور بالحجم نفسه.

    لا يتحتم أن تكون الحالة عبارة عن عنصر فردي—بل يمكن أن تكون مجموعة من العناصر.

  2. لرص الصور، حددها وانقر محاذاة أفقية إلى المنتصف  ومحاذاة رأسية إلى المنتصف  في لوحة Control.

  3. مع الاستمرار في تحديد الصور، افتح لوحة Object States (Window > Interactive > Object States)، وانقر فوق زر Convert Selection To Multi-State Object.

    تظهر الصور كحالات في لوحة Object States وتحيط حدود إطارية متقطعة بالصور المحددة.

    تحويل التحديد إلى كائن متعدد الحالات

  4. قم بإنشاء أزرار تصفح تقوم بتشغيل الإجراءين Go To Next State وGo To Previous State عند تحرير زر الماوس. راجع إنشاء الأزرار.

  5. استخدم لوحة Preview‏ (Window > Interactive > EPUB Interactivity Preview) لاختبار أزرار التنقل.

  6. تصدير المستند إلى تنسيق EPUB. راجع المستندات التفاعلية.

تحرير كائن متعدد الحالات

  1. حدد أحد الكائنات متعددة الحالات.

  2. في لوحة حالات الكائن، نفذ أيًا مما يلي:

    • لتحرير حالة، حدد الحالة في لوحة حالات الكائن، ثم قم بتحرير الكائن. فعلى سبيل المثال، يمكنك إضافة حد للكائن أو تعبئته أو تغيير حجمه.

    • لإضافة كائن إلى حالة موجودة، حدد كلاً من الكائن والكائن متعدد الحالات، وانقر زر إضافة كائنات إلى الحالة المرئية .

    • لإضافة كائن إلى كائن موجود متعدد الحالات، حدد كلاً من الكائن والكائن متعدد الحالات، ثم انقر على الزر \"تحويل التحديد إلى كائن متعدد الحالات\" .

    • لمضاعفة حالة، حدد حالة لتكون الأساس الذي تستند إليه الحالة الجديدة، واختر حالة جديدة من قائمة اللوحة. أضف محتوى إلى تلك الحالة أو قم بإزالته أو تحريره.

    • للصق كائنات داخل حالة موجودة، قم بقص أو نسخ كائن أو أكثر، وحدد الكائن متعدد الحالات، ثم الحالة من لوحة حالات الكائن، واختر لصق في الحالة من قائمة لوحة حالات الكائن.

    • لتحويل كائن متعدد الحالات مرة أخرى إلى مجموعة من الكائنات المستقلة، حدد الحالة في لوحة حالات الكائن واختر تحرير الحالة إلى كائن من قائمة اللوحة. لتحويل كل الحالات الموجودة في كائن متعدد الحالات إلى كائنات، اختر تحرير جميع الحالات إلى كائنات.

    • لحذف حالة وإزالة محتوياتها، حدد الحالة واختر حذف حالة من قائمة اللوحة.

    • لإخفاء كائن متعدد الحالات في الملف الذي تم تصديره حتى يتم تشغيله باستخدام أحد الأزرار، اختر إخفاء حتى يتم التشغيل من قائمة اللوحة.

    • لإعادة ضبط كل الكائنات متعددة الحالات في المستند إلى الحالة الأولى، اختر تحرير جميع الكائنات متعددة الحالات إلى الحالة الأولى من قائمة اللوحة. عند تحديد إحدى الحالات، يبقى الكائن في هذه الحالة، حتى إذا قمت بإغلاق المستند وإعادة فتحه. يتيح هذا الخيار سرعة إعادة ضبط كل الكائنات متعددة الحالات.

إنشاء نقاط فعّالة للأزرار

قد تحتاج أحيانًا إلى جعل منطقة الزر (تسمى "النقطة الفعّالة" أو "الرابط الفعّال") مخفية إلى أن يتم تمرير مؤشر الماوس فوقها. على سبيل المثال، عندما تقوم بتحريك المؤشر فوق زر في خريطة، يمكن عرض صورة تمثل منطقة ما، ويمكن إخفاء الصورة عندما يتحرك المؤشر بعيدًا عن المنطقة.

في ملف PDF المُصدَّر، يؤدي تثبيت المؤشر فوق نقطة فعّالة إلى ظهور الصورة.

عرض صورة مخفية عند التمرير الفوقي

تتمثل إحدى طرق تحقيق تأثير "النقطة الفعّالة" في تطبيق صورة على حالة Rollover في اللوحة Buttons. للقيام بذلك، أنشئ زرًا تعرض فيه الحالة [Rollover] صورة، بينما لا تعرض الحالة [Normal] الصورة.

  1. حدد الصورة التي تريد استخدامها كنقطة فعّالة. تأكد من عدم احتواء إطار الصورة على حدود أو خلفية.

  2. في لوحة Buttons and Forms (اختر Window > Interactive > Buttons and Forms)، ثم انقر فوق مظهر [Normal] لتحويل الصورة المحددة إلى زر.

  3. انقر فوق المظهر [Rollover] في لوحة Buttons and Forms لتنشيطه.

  4. انقر المظهر [Normal] مرة أخرى. حدد بعد ذلك الصورة باستخدام أداة Direct Selection واحذف الصورة.

    تأكد من أنك تحذف الصورة (محتويات الإطار)، وليس الإطار ومحتوياته. فحذف الإطار يؤدي إلى حذف الزر بالكامل.

  5. استخدم لوحة Preview لمعاينة تأثير النقطة الفعّالة.

عرض زر مختلف عند التمرير الفوقي

يمكنك إنشاء نقطة فعّالة، يؤدي نقر كائن بها أو تمرير الماوس فوقه إلى عرض كائن آخر. للقيام بذلك، قم بإنشاء زرين وإخفاء أحدهما، ثم استخدم الإجراء Show/Hide Button لإظهار الزر المستهدف وإخفائه.

  1. أنشئ كائنًا لاستخدامه كزر مصدر. من لوحة Buttons and Forms، انقر فوق أيقونة Convert Object To A Button.

  2. قم بتضمين الصورة التي تريد استخدامها كزر مستهدف، ثم قم بالتحويل إلى زر.
  3. حدد الصورة المستهدفة وحدد Hidden Until Triggered بأسفل لوحة Buttons and Forms.

    يجب إخفاء الصورة في المستند المُصدَّر حتى يمكن عرضها عند النقر فوق الزر المصدر.

  4. حدد الزر المصدر وقم بإنشاء إجراءين مختلفين، واحد لإظهار الصورة المستهدفة والآخر لإخفائها.

    إذا أردت إظهار الصورة عند التمرير بالماوس فوق الزر المصدر، فاستخدم الحدثين On Roll Over وOn Roll Off. وإذا أردت إظهار الصورة عند نقر الزر المصدر وإخفاءها عند تحريره، فاستخدم الحدثين On Click وOn Release. في كلتا الحالتين، استخدم الإجراء Show/Hide Buttons لعرض الزر المستهدف وإخفائه. راجع جعل الأزرار تفاعلية.

  5. استخدم لوحة Preview لاختبار الأزرار.

تغيير خيارات PDF للأزرار

  1. استخدم أداة Selection لتحديد الزر.
  2. من قائمة لوحة Buttons and Forms، حدد PDF Options.

  3. اكتب وصفًا يعمل كنص بديل للمستخدمين المعاقين بصريًا.
  4. حدد ما إذا كنت تريد طباعة الزر في ملف PDF، ثم انقر فوق OK.

تعيين ترتيب علامات تبويب الأزرار

يحدد ترتيب الجدولة الحقل التالي (أو السابق) الذي يتم تنشيطه عندما يقوم مستخدم بضغط مفتاح الجدولة (أو Shift+Tab) في مستند PDF. يشمل ترتيب علامات التبويب الأزرار الموجودة في طبقات مخفية، وليس الأزرار الموجودة في الصفحات الرئيسية.

  1. انتقل إلى الصفحة التي تحتوي على الأزرار.
  2. اختر Object > Interactive > Set Tab Order.

  3. حدد كل زر تريد نقله وسحبه إلى موضعه الجديد، أو انقر الأزرار Move Up وMove Down. بعد الانتهاء، انقر فوق OK.

إذا استخدمت Acrobat لتحرير مستند PDF ولإضافة المزيد من الأزرار إلى الصفحة، فقد تحتاج إلى تحديد ترتيب جديد لعلامات الجدولة في Acrobat.

الموضوعات ذات الصلة

شعار Adobe

تسجيل الدخول إلى حسابك