问题

启动或使用 After Effects CS3、CS4 或 CS5 时,出现以下错误:

“After Effects 错误:无法转换 Unicode 字符。(23::46)”

解决方案

解决方案 1:对文件名、路径和硬盘使用单字节字符。

将多字节字符(如中文、希伯来文或日文字符)的实例更改为单字节字符(如英文字符)。 

解决方案 2:替换目标语言的 AMT.zdct 文件。

Mac OS

  1. 打开 Applications/Adobe After Effects CS5(或者 CS3 或 CS4)文件夹。
  2. 右键单击 Adobe After Effects CS4 应用程序图标,然后选择“显示包内容”。

  3. 打开 Content/Resources/AMT Languages 文件夹。

  4. 记下此文件夹中 .txt 文件的名称,它是安装的 After Effects 语言版本的语言代码。该语言为目标语言。例如,美国英语对应的语言代码为 en_US,土耳其语为 tr_TR,俄语为 ru_RU 等。此处提供了常用语言代码列表。

  5. 返回 Resources 文件夹并打开 AMT 文件夹。

  6. 打开以在第 4 步中确定的目标语言代码命名的文件夹。

  7. 在 AMT.zdct 文件名的开头添加一个波形字符 (~)。此步骤会导致 After Effects 忽略该文件,但会保留该文件作为备份。

  8. 返回 AMT 文件夹并打开 en_US 的文件夹。(您也可以选择不受此问题影响的其他语言,如与法语对应的 fr_FR 以及与西班牙语对应的 es_ES。)

  9. 将此文件夹中的 AMT.zdct 文件复制到第 6 步中的目标语言文件夹。要复制该文件,请在按住 Option 键的同时将文件从一个文件夹拖动到另一个文件夹。或者,选择该文件并选择“文件”>“复制”,然后将文件移至另一个文件夹并删除文件名末尾的“副本”。

  10. 启动 After Effects。

Windows

  1. 打开 Program Files\Adobe\Adobe After Effects CS4(或 CS3)\Support Files\AMT Languages 文件夹。
  2. 记下此文件夹中 .txt 文件的名称,它是安装的 After Effects 语言版本的语言代码。该语言为目标语言。例如,美国英语对应的语言代码为 en_US,土耳其语为 tr_TR,俄语为 ru_RU 等。此处提供了常用语言代码列表。

  3. 返回 Support Files 文件夹,然后打开 AMT 文件夹。

  4. 打开以在第 2 步中确定的目标语言代码命名的文件夹。

  5. 在 AMT.zdct 文件名的开头添加一个波形字符 (~)。此步骤会导致 After Effects 忽略该文件,但会保留该文件作为备份。

  6. 返回 AMT 文件夹并打开 en_US 的文件夹。(您也可以选择不受此问题影响的其他语言,如与法语对应的 fr_FR 以及与西班牙语对应的 es_ES。)

  7. 将此文件夹中的 AMT.zdct 文件复制到第 4 步中的目标语言文件夹。选择该文件,选择“编辑”>“复制”,导航回目标语言文件夹,然后选择“编辑”>“粘贴”。

  8. 启动 After Effects。

其他信息

AMT.zdct 文件包含已翻译为特定语言的菜单项的文本短语。如果操作系统语言不支持在某些语言中使用的特殊字符,则一旦 After Effects 出现问题,便会导致无法正确翻译这些字符。

换言之,安装了 After Effects 的使用非罗马 Unicode 或 Cyrillic 字符集的某个语言版本,但操作系统的语言版本与之不同。例如,在英语操作系统上安装了 After Effects 的土耳其语版本。

受影响的语言包括:

  • 阿拉伯语
  • 简体中文
  • 繁体中文
  • 希腊语
  • 希伯来语
  • 日语
  • 朝鲜语
  • 罗马尼亚语
  • 俄语
  • 土耳其语
  • 乌克兰语

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略