دليل المستخدم إلغاء

إنشاء رسومات مستندة إلى البيانات

  1. دليل مستخدم Photoshop
  2. مقدمة إلى Photoshop
    1. احلم، وحقق الحلم.
    2. ما هو الجديد في Photoshop
    3. تحرير صورك الأولى
    4. إنشاء المستندات
    5. Photoshop | الأسئلة الشائعة
    6. متطلبات النظام في Photoshop
    7. تعرف على Photoshop
  3. Photoshop ومنتجات Adobe وخدماتها الأخرى
    1. استخدِم الأعمال الفنية لبرنامج Illustrator في Photoshop
    2. استخدم ملفات Photoshop في InDesign
    3. مواد Substance 3D لبرنامج Photoshop
    4. استخدام ملحق Capture داخل التطبيق في Photoshop
  4. Photoshop على iPad (غير متوفر في البر الرئيسي للصين)
    1. Photoshop على جهاز iPad | الأسئلة الشائعة
    2. التعرف على مساحة العمل
    3. متطلبات النظام | Photoshop على جهاز iPad
    4. إنشاء المستندات وفتحها وتصديرها
    5. إضافة الصور
    6. العمل باستخدام الطبقات
    7. الرسم والطلاء بالفرش
    8. إجراء تحديدات وإضافة إخفاءات
    9. تنقيح الصور المركّبة
    10. العمل باستخدام طبقات الضبط
    11. ضبط الدرجة اللونية للصورة المركّبة من خلال Curves
    12. تطبيق عمليات التحويل
    13. اقتصاص المجموعات المركّبة وتدويرها
    14. تدوير لوحة الرسم وتحريكها وتكبيرها/تصغيرها وإعادة تعيينها
    15. استخدام طبقات Type
    16. استخدام Photoshop وLightroom
    17. الحصول على الخطوط المفقودة في Photoshop على أجهزة iPad
    18. النص الياباني في Photoshop على جهاز iPad
    19. إدارة إعدادات التطبيق
    20. اختصارات اللمس والإيماءات ذات الصلة
    21. اختصارات لوحة المفاتيح
    22. تحرير حجم صورتك
    23. البث المباشر أثناء الإنشاء في Photoshop على جهاز iPad
    24. تصحيح العيوب باستخدام Healing Brush
    25. إنشاء الفرش في Capture واستخدامها في Photoshop
    26. استخدام ملفات Camera Raw
    27. إنشاء الكائنات الذكية واستخدامها من خلال Smart Objects
    28. اضبط التعريض في صورك باستخدام أداتَي Dodge وBurn
  5. Photoshop على الويب (غير متوفر في البر الرئيسي للصين)
    1. الأسئلة الشائعة
    2. متطلبات النظام
    3. اختصارات لوحة المفاتيح
    4. أنواع الملفات المدعومة
    5. مقدمة إلى مساحة العمل
    6. فتح المستندات السحابية واستخدامها
    7. مزايا الذكاء الاصطناعي التوليدي
    8. مفاهيم التحرير الأساسية
    9. الإجراءات السريعة
    10. العمل باستخدام الطبقات
    11. تنقيح الصور وإزالة العيوب
    12. إجراء عمليات تحديد سريعة
    13. تحسينات للصور باستخدام طبقات الضبط
    14. نقل الصور وتحويلها واقتصاصها
    15. الرسم والتلوين
    16. استخدام طبقات Type
    17. العمل مع أي شخص على الويب
    18. إدارة إعدادات التطبيق
  6. Photoshop (نسخة beta) (غير متوفر في البر الرئيسي للصين)
    1. بدء استخدام تطبيقات Creative Cloud (نسخة Beta)
    2. Photoshop (نسخة beta) لسطح المكتب
  7. تقنية الذكاء الاصطناعي التوليدي (غير متوفرة في البر الرئيسي للصين) 
    1. الأسئلة الشائعة حول الذكاء الاصطناعي التوليدي في Photoshop
    2. أداة Generative Fill في Photoshop على سطح المكتب
    3. Generative Expand في Photoshop على سطح المكتب
    4. أداة Generative Fill في Photoshop على جهاز iPad
    5. Generative Expand في Photoshop على جهاز iPad
    6. التنوعات التوليدية في Photoshop على جهاز iPad
    7. مزايا الذكاء الاصطناعي التوليدي في Photoshop على الويب
  8. موثوقية المحتوى (غير متوفرة في البر الرئيسي للصين)
    1. Content credentials في Photoshop
    2. الهوية ومصدر رموز NFT
    3. ربط الحسابات للحصول على ترخيص الأعمال الإبداعية
  9. المستندات السحابية (غير متوفرة في البر الرئيسي للصين)
    1. مستندات Photoshop السحابية | الأسئلة الشائعة
    2. مستندات Photoshop السحابية | أسئلة حول سير العمل
    3. إدارة مستندات السحابة واستخدامها في Photoshop
    4. ترقية التخزين على السحابة لـ Photoshop
    5. تعذر إنشاء مستند على السحابة أو حفظه
    6. حل أخطاء مستندات Photoshop على السحابة
    7. جمع سجلات مزامنة المستندات السحابية
    8. دعوة الآخرين لتحرير المستندات السحابية الخاصة بك
    9. مشاركة الملفات والتعليقات داخل التطبيق
  10. مساحة العمل
    1. أساسيات مساحة العمل
    2. Preferences
    3. تعلّم أسرع مع لوحة Discover في Photoshop
    4. إنشاء المستندات
    5. إدراج الملفات
    6. اختصارات لوحة المفاتيح الافتراضية
    7. تخصيص اختصارات لوحة المفاتيح
    8. معارض الأدوات
    9. تفضيلات الأداء
    10. استخدام الأدوات
    11. الإعدادات المسبقة
    12. الشبكة والأدلة
    13. إيماءات اللمس
    14. استخدام Touch Bar مع Photoshop
    15. إمكانيات اللمس ومساحات العمل القابلة للتخصيص
    16. المعاينات التقنية
    17. البيانات الأولية والملاحظات
    18. إمكانيات اللمس ومساحات العمل القابلة للتخصيص
    19. وضع صور Photoshop في تطبيقات أخرى
    20. المساطر
    21. إظهار الإضافات غير القابلة للطباعة أو إخفاؤها
    22. تحديد الأعمدة لصورة
    23. التراجع والمحفوظات
    24. اللوحات والقوائم
    25. تعيين موضع العناصر بواسطة الإطباق
    26. تحديد الموضع باستخدام الأداة Ruler
  11. تصميم التطبيقات ومواقع الويب والشاشات
    1. Photoshop للتصميم
    2. لوحات الأعمال الفنية
    3. ميزة Device Preview
    4. نسخ CSS من الطبقات
    5. تقسيم صفحات ويب إلى شرائح
    6. خيارات HTML للشرائح
    7. تعديل تخطيط الشريحة
    8. العمل باستخدام رسومات الويب
    9. إنشاء معارض صور ويب
  12. أساسيات الصور والألوان
    1. كيفية تغيير حجم الصور
    2. العمل مع الصور النقطية والمتجهات
    3. حجم الصورة ودقة وضوحها
    4. الحصول على صور من كاميرات وماسحات ضوئية
    5. إنشاء الصور وفتحها واستيرادها
    6. عرض الصور
    7. خطأ علامة JPEG غير صالحة | فتح الصور
    8. عرض صور متعددة
    9. تخصيص منتقيات الألوان والمربعات اللونية
    10. صور النطاق الديناميكي العالي
    11. مطابقة الألوان في صورتك
    12. التحويل بين صيغ الألوان
    13. أوضاع الألوان
    14. محو أجزاء من صورة
    15. صيغ المزج
    16. اختيار الألوان
    17. تخصيص جداول الألوان المفهرسة
    18. معلومات الصورة
    19. عوامل تصفية التشويه غير متوفر
    20. حول الألوان
    21. عمليات ضبط الصور الملونة والصور الأحادية اللون باستخدام القنوات
    22. اختيار الألوان في لوحتي Color وSwatches
    23. Sample
    24. صيغة اللون أو صيغة الصورة
    25. اللون غير الحقيقي
    26. إضافة تغيير صيغة شرطي إلى إجراء
    27. إضافة مربعات لونية من HTML CSS وSVG
    28. عمق البت والتفضيلات
  13. الطبقات
    1. أساسيات الطبقات
    2. التحرير غير المتلف
    3. إنشاء الطبقات والمجموعات وإدارتها
    4. تحديد الطبقات وتجميعها وربطها
    5. وضع الصور في إطارات
    6. عتامة الطبقة والمزج
    7. طبقات الأقنعة
    8. تطبيق Smart Filters
    9. تركيبات الطبقة
    10. نقل الطبقات وتجميعها وإقفالها
    11. تقنيع الطبقات بواسطة أقنعة المتجهات
    12. إدارة طبقات ومجموعات
    13. تأثيرات الطبقة والأنماط
    14. تحرير أقنعة الطبقة
    15. استخراج الأصول
    16. كشف الطبقات بواسطة أقنعة اقتطاع
    17. إنشاء أصول صور من طبقات
    18. استخدام الكائنات الذكية
    19. صيغ المزج
    20. دمج صور متعددة في صورة مجموعة
    21. دمج الصور بواسطة مزج الطبقات آليًا
    22. محاذاة الطبقات وتوزيعها
    23. نسخ CSS من الطبقات
    24. تحميل تحديدات من طبقة أو حدود قناع طبقة
    25. التقدم يكشف المحتوى من طبقات أخرى
  14. التحديدات
    1. بدء استخدام التحديدات
    2. إجراء تحديدات في المركّبات
    3. مساحة العمل Select and Mask
    4. التحديد باستخدام أدوات المحيطات المنقطة
    5. التحديد باستخدام أدوات lasso
    6. ضبط تحديدات وحدات بكسل
    7. تحريك وحدات بكسل محددة ونسخها وحذفها
    8. إنشاء قناع سريع مؤقت
    9. تحديد مجموعة ألوان في صورة
    10. التحويل بين المسارات وحدود التحديد
    11. أساسيات القناة
    12. حفظ التحديدات وأقنعة قناة ألفا
    13. تحديد نواحي الصورة موضع التركيز
    14. تكرار القنوات وتقسيمها ودمجها
    15. عمليات القناة الحسابية
  15. عمليات ضبط الصورة
    1. استبدال ألوان الكائنات
    2. التواء المنظور
    3. تقليل التمويه بسبب اهتزاز الكاميرا
    4. أمثلة Healing brush
    5. تصدير جداول البحث عن الألوان
    6. ضبط وضوح وتمويه الصورة
    7. فهم عمليات ضبط الألوان
    8. تطبيق ضبط Brightness/Contrast
    9. ضبط تفاصيل التظليل والإبراز
    10. ضبط Levels
    11. ضبط تدرج الألوان والتشبع
    12. ضبط حيوية الصورة
    13. ضبط تشبع اللون في مساحات الصورة
    14. إجراء عمليات ضبط سريعة للدرجات اللونية
    15. تطبيق تأثيرات لونية خاصة على الصور
    16. تحسين صورتك من خلال عمليات ضبط توازن اللون
    17. صور النطاق الديناميكي العالي
    18. عرض الرسوم البيانية وقيم البكسل
    19. مطابقة الألوان في صورتك
    20. اقتصاص الصور وتسويتها
    21. تحويل صورة ملونة إلى أبيض وأسود
    22. طبقات الضبط والتعبئة
    23. ضبط Curves
    24. صيغ المزج
    25. استهداف الصور للمطابع
    26. ضبط اللون والدرجات اللونية بواسطة Levels وCurves Eyedroppers
    27. ضبط التعريض للضوء والدرجات اللونية في HDR
    28. إنقاص كثافة مساحات الصورة أو زيادتها
    29. إجراء عمليات ضبط انتقائية للألوان
  16. Adobe Camera Raw
    1. متطلبات النظام لـ Camera Raw
    2. ما الجديد في Camera Raw
    3. مقدمة إلى Camera Raw
    4. إنشاء صور بانورامية
    5. العدسات المدعومة
    6. عوامل التصفية Vignette وGrain وDehaze في Camera Raw
    7. اختصارات لوحة المفاتيح الافتراضية
    8. تصحيح المنظور التلقائي في Camera Raw
    9. المرشح الشعاعي في Camera Raw
    10. إدارة إعدادات Camera Raw
    11. فتح الصور في Camera Raw ومعالجتها وحفظها
    12. تصحيح الصور باستخدام الأداة Enhanced Spot Removal في Camera Raw
    13. تدوير الصور واقتصاصها وتعديلها
    14. ضبط عرض اللون في Camera Raw
    15. معالجة الإصدارات في Camera Raw
    16. إجراء عمليات ضبط محلية في Camera Raw
  17. إصلاح الصور واستعادتها
    1. إزالة كائنات من صورك باستخدام Content-Aware Fill
    2. الأداتان Content-Aware Patch وContent-Aware Move
    3. تنقيح الصور وإصلاحها
    4. تصحيح تشوه الصورة والتشويش
    5. الخطوات الأساسية لاستكشاف معظم المشاكل وإصلاحها
  18. تحسين الصورة وتحويلها
    1. استبدال السماء في صورك
    2. تحويل الكائنات
    3. ضبط القص، والتدوير، وحجم قماش الرسم
    4. كيفية اقتصاص الصور وتسويتها
    5. إنشاء صور بانورامية وتحريرها
    6. إجراء التواء للصور والأشكال والمسارات
    7. ميزة Vanishing Point
    8. تغيير المقياس مع مراعاة المحتوى
    9. تحويل الصور والأشكال والمسارات
  19. الرسم والطلاء
    1. رسم أنماط متناظرة
    2. رسم مستطيلات وتعديل خيارات الخطوط المحيطة
    3. حول الرسم
    4. رسم الأشكال وتحريرها
    5. أدوات الرسم
    6. إنشاء الفرش وتعديلها
    7. صيغ المزج
    8. إضافة لون إلى المسارات
    9. تحرير المسارات
    10. الرسم باستخدام فرشاة المازج
    11. الإعدادات المسبقة للفرشاة
    12. التدرجات
    13. الاستيفاء المتدرج
    14. التعبئة وتطبيق ضربات الفرشاة على التحديدات والطبقات والمسارات
    15. الرسم باستخدام أدوات Pen
    16. إنشاء الأنماط
    17. إنشاء نقش باستخدام Pattern Maker
    18. التعامل مع المسارات
    19. إدارة مكتبات النماذج والإعدادات المسبقة
    20. الرسم أو الطلاء باستخدام جهاز لوحي للرسم
    21. إنشاء فرش المادة
    22. إضافة عناصر ديناميكية إلى الفرش
    23. Gradient
    24. رسم ضربات مميزة باستخدام Art History Brush
    25. الرسم باستخدام نمط
    26. مزامنة الإعدادات المسبقة على أجهزة متعددة
    27. ترحيل الإعدادات المسبقة والإجراءات والإعدادات
  20. النص
    1. إضافة نص وتحريره
    2. محرك Unified Text Engine
    3. العمل بخطوط OpenType SVG
    4. تنسيق الأحرف
    5. تنسيق الفقرات
    6. كيفية إنشاء تأثيرات الكتابة
    7. تحرير النص
    8. تباعد الأسطر والأحرف
    9. الكتابة العربية والعبرية
    10. الخطوط
    11. استكشاف أخطاء الخطوط وإصلاحها
    12. الكتابة الآسيوية
    13. إنشاء الكتابة
  21. المرشحات والتأثيرات
    1. استخدام مرشح Liquify
    2. استخدام Blur Gallery
    3. أساسيات المرشح
    4. مرجع تأثيرات الترشيح
    5. إضافة Lighting Effects
    6. استخدام مرشح Adaptive Wide Angle
    7. استخدام المرشح Oil Paint
    8. استخدام مرشح Liquify
    9. تأثيرات الطبقة والأنماط
    10. تطبيق مرشحات محددة
    11. تلطيخ مساحات الصورة
  22. الحفظ والتصدير
    1. حفظ ملفاتك في Photoshop
    2. تصدير الملفات في Photoshop
    3. تنسيقات الملفات المعتمدة
    4. حفظ الملفات بتنسيقات الرسومات
    5. انقل التصميمات بين Photoshop وIllustrator
    6. حفظ وتصدير الفيديو والرسوم المتحركة
    7. حفظ ملفات PDF
    8. حماية حقوق النسخ لـ Digimarc
  23. إدارة الألوان
    1. فهم إدارة الألوان
    2. إبقاء الألوان متسقة
    3. إعدادات الألوان
    4. الفرز الثنائي
    5. العمل باستخدام ملفات تعريف اللون
    6. إدارة ألوان المستندات لعرضها عبر الإنترنت
    7. إدارة ألوان مستندات عند الطباعة
    8. إدارة ألوان الصور المستوردة
    9. إجراء تجربة للألوان
  24. تصميم التطبيقات ومواقع الويب والشاشات
    1. Photoshop للتصميم
    2. لوحات الأعمال الفنية
    3. ميزة Device Preview
    4. نسخ CSS من الطبقات
    5. تقسيم صفحات ويب إلى شرائح
    6. خيارات HTML للشرائح
    7. تعديل تخطيط الشريحة
    8. العمل باستخدام رسومات الويب
    9. إنشاء معارض صور ويب
  25. الفيديو والرسوم المتحركة
    1. تحرير الفيديو في Photoshop
    2. تحرير طبقات الفيديو والرسوم المتحركة
    3. نظرة عامة على الفيديو والرسوم المتحركة
    4. معاينة الفيديو والرسوم المتحركة
    5. طلاء الإطارات في طبقات الفيديو
    6. استيراد ملفات الفيديو وتسلسلات الصور
    7. إنشاء إطارات رسوم متحركة
    8. Creative Cloud 3D Animation (Preview)‎
    9. إنشاء الرسوم المتحركة للخط الزمني
    10. إنشاء صور للفيديو
  26. الطباعة
    1. طباعة كائنات ثلاثية الأبعاد
    2. الطباعة من Photoshop
    3. طباعة باستخدام إدارة الألوان
    4. رقائق المصغرات والعروض التقديمية بتنسيق PDF
    5. طباعة صور في تخطيط حزمة الصور
    6. الطباعة بألوان التركيز
    7. طباعة صور على مطبعة تجارية
    8. تحسين المطبوعات الملونة من Photoshop
    9. استكشاف مشكلات الطباعة وإصلاحها | Photoshop
  27. التشغيل التلقائي
    1. إنشاء إجراءات
    2. إنشاء رسوم تستند إلى البيانات
    3. البرمجة النصية
    4. معالجة حزمة من الملفات
    5. تشغيل العمليات وإدارتها
    6. إضافة إجراءات مشروطة
    7. حول الإجراءات ولوحة Actions
    8. تسجيل الأدوات في الإجراء الذي تنفذه
    9. إضافة تغيير صيغة شرطي إلى إجراء
    10. مجموعة أدوات واجهة المستخدم في Photoshop للأدوات الإضافية والبرامج النصية
  28. استكشاف الأخطاء وإصلاحها
    1. المشاكل التي تم إصلاحها 
    2. المشاكل المعروفة
    3. تحسين الأداء في Photoshop
    4. استكشاف الأخطاء الرئيسية وإصلاحها
    5. استكشاف الأعطال أو حالات التوقف عن التشغيل وإصلاحها
    6. استكشاف أخطاء البرنامج وإصلاحها
    7. استكشاف أخطاء أقراص التسويد الممتلئة وإصلاحها
    8. استكشاف مشاكل وحدة معالجة الرسومات وبرنامج تشغيل الرسومات وحلها
    9. العثور على الأدوات المفقودة
    10. Photoshop | أسئلة شائعة حول مزايا 3D التي تم إلغاؤها

استخدام الرسومات المستندة إلى البيانات مع القوالب التي تم إنشاؤها في Photoshop

إليك السيناريو الآتي: 

إنه أسبوعك الأول في العمل وتحتاج إلى إنشاء خمس نسخ من شعار ويب تتضمن نصوصًا وصورًا مختلفة باستخدام تصميم قالب واحد.

هل تعلم أن الرسومات المستندة إلى البيانات ستكون أفضل طريقة لإنجاز عملك؟

اتبع هذه الخطوات العامة لإنشاء تصميمات متناسقة تتضمن نصوصًا وصورًا مختلفة باستخدام مجموعات البيانات:

  1. أنشئ الرسم الأساسي الذي تريد استخدامه كقالب. 

    استخدم الطبقات لفصل العناصر التي تريد تغييرها في الرسم.

  2. عرِّف المتغيرات في الرسم. كما نعلم، تحدد المتغيرات أجزاءَ الصورة التي تحتاج إلى تغيير.

  3. أنشئ مجموعات البيانات أو قم باستيرادها. أنشئ مجموعات البيانات في القالب، أو قم باستيرادها من ملف نصي. 

  4. قم بمعاينة المستند مع كل مجموعة بيانات. قبل تصدير الملف، حدِّد خيار preview لترى كيف ستبدو الصورة النهائية. 

  5. أنشئ الرسومات عن طريق تصديرها مع البيانات. نوصي باستخدام تنسيق Photoshop (PSD). 

    استخدام المتغيرات لإنشاء إصدارات مختلفة من صورة في Photoshop
    استخدام المتغيرات لإنشاء نسخ مختلفة من صورة

المتغيرات

استخدِم المتغيرات لتعريف العناصر التي تحتاج إلى تغييرها في القالب. ويمكنك تعريف ثلاثة أنواع من المتغيرات.

يُظهر متغير Visibility محتويات الطبقة أو يخفيها.

تستبدل متغيرات Text Replacement سلسلة نصية في طبقة الكتابة.

تستبدل متغيرات Pixel Replacement وحدات البكسل في الطبقة بوحدات بكسل من ملف صورة آخر.

ملاحظة:

لا يمكنك تعريف المتغيرات عند العمل على طبقة Background

استخدام أحد المتغيرات

  1. انتقل إلى Image >‏ Variables >‏ Define.

  2. حدِّد الطبقة التي تفضلها من قائمة Layer المنبثقة التي فيها المحتوى المراد تعريفه كمتغير.

  3. حدِّد نوعًا واحدًا أو أكثر من المتغيرات الآتية: Visibility، وPixel Replacement، وText Replacement.

    Visibility: إظهار محتوى الطبقة أو مجموعة الطبقات أو إخفاؤه

    Pixel Replacement: استبدال وحدات البكسل في الطبقة بوحدات بكسل من ملف صورة آخر

    Text Replacement: استبدال سلسلة نصية في طبقة الكتابة

  4. قم بأحد الأمور الآتية:

    • أدخِل اسمًا للمتغير في حقل Name. يمكن أن تبدأ أسماء المتغيرات بحرف أو شرطة سفلية أو علامة النقطتين. ولا يمكن أن تحتوي على مسافات أو أحرف خاصة (باستثناء النقاط والواصلات والشرط السفلية وعلامات النقطتين).

      أو،

    • اختر متغيرًا موجودًا من قائمة Name المنسدلة لربط الطبقة به. تَظهر الطبقات المرتبطة بالمتغير نفسه إلى جانب قائمة Name، مع أيقونة الربط.

  5. اتَّبع هذه الخطوات عند استخدام متغيرات Pixel Replacement.

    1. اختر الطريقة التي تفضلها لتغيير حجم الصورة البديلة:
      • تقوم طريقة Fit بتغيير حجم الصورة لتلائم مربع الإحاطة مع الحفاظ على النِسَب.
      • تقوم طريقة Fill بتغيير حجم الصورة لملء مربع الإحاطة مع الحفاظ على النِسَب. وقد تتداخل الحواف في أحد البُعدَين.
      • تحافظ طريقة As Is على حجم الصورة البديلة. وقد تتداخل الحواف في أحد البُعدين أو كليهما. 
      • تقوم طريقة Conform بتغيير حجم الصورة لملء مربع الإحاطة. وقد لا تحافظ على النِسَب الأصلية. 
    2. حدِّد مقبضًا على أيقونة المحاذاة لاختيار محاذاة لوضع الصورة داخل مربع الإحاطة. (هذا الخيار غير متاح لطريقة الاستبدال Conform).
    3. حدِّد Clip To Bounding Box لقص مساحات الصورة التي لا يمكن ملاءمتها في مربع الإحاطة. هذا الخيار متاح فقط عند تحديد طريقة الاستبدال Fill أو As Is. (هذا الخيار غير متاح لطريقة الاستبدال Conform).
    تقوم طريقة Fit بتغيير حجم الصورة لتلائم مربع الإحاطة مع الحفاظ على النِسَب.
    تقوم طريقة Fit بتغيير حجم الصورة لتلائم مربع الإحاطة مع الحفاظ على النِسَب.

  6. لتعريف متغيرات طبقة أخرى، اختر طبقة من قائمة Layer المنبثقة ثُم حدِّد OK.

    تظهر علامة نجمية إلى جانب اسم الطبقة التي تحتوي على متغيرات. يمكنك استخدام أسهم التصفح للتنقل بين الطبقات.

إعادة تسمية متغير

  1. انتقل إلى Image >‏ Variables >‏ Define.

  2. اختر الطبقة التي تحتوي على المتغير من قائمة Layer المنبثقة.

  3. لإعادة تسمية المتغير، أدخِل اسمًا في مربع النص Name.

    يجب أن تبدأ أسماء المتغيرات بحرف أو شرطة سفلية أو علامة النقطتين، ولا يمكنها أن تحتوي على مسافات أو حروف خاصة (ما عدا النقاط والواصلات والشرط السفلية وعلامات النقطتين).

  4. ألغِ تحديد المتغير لإزالته.

مجموعات البيانات

إن مجموعة البيانات هي مجموعة من المتغيرات والبيانات المرتبطة. يمكنك تعريف مجموعة بيانات لكل نسخة رسم ترغب في إنشائها.

  1. قم بأحد الأمور الآتية:

    • انتقل إلى Image >‏ Variables >‏ Data Sets

    أو،

    • إذا كان مربع الحوار Variables مفتوحًا، فحدِّد Data Sets من القائمة المنسدلة أو حدِّد Next.
    ملاحظة:

    يجب تعريف متغير واحد على الأقل قبل تحرير مجموعة البيانات الافتراضية. 

  2. حدِّد زر مجموعة البيانات الجديدة () لإنشاء مجموعة بيانات جديدة تستند إلى مجموعة البيانات الحالية.

  3. حدِّد متغيرًا من قائمة Name المنسدلة.

  4. حرِّر بيانات المتغير:

    • بالنسبة إلى متغيرات Visibility، حدِّد Visible (لإظهار محتوى الطبقة) أو Invisible (لإخفاء محتوى الطبقة).

    • بالنسبة إلى متغيرات Pixel Replacement، حدِّد Select File ثم ملف الصورة البديلة. وحدِّد Do Not Replace قبل تطبيق مجموعة البيانات لترك الطبقة في حالتها الحالية.

    ملاحظة:

    لا يقوم زر Do Not Replace بإعادة تعيين الملف إلى حالته الأصلية إذا سبق أن تم تطبيق بديل آخر.

    • بالنسبة إلى متغيرات Text Replacement، أدخِل سلسلة نصية في مربع النص Value.
  5. عرِّف مجموعات بيانات إضافية لكل نسخة رسم ترغب في إنشائها.

يمكنك تحرير مجموعة البيانات أو إعادة تسميتها أو حذفها عن طريق اختيارها أولاً من قائمة Data Set وتعديل الخيارات. استخدِم أيقونات الأسهم للتنقل بين مجموعات البيانات. انقر فوق الأيقونة Delete لحذف مجموعة بيانات.

معاينة مجموعة بيانات أو تطبيقها

يمكنك تطبيق محتويات مجموعة البيانات على الصورة الأساسية بل ومع الحفاظ على المتغيرات ومجموعات البيانات كما هي.

سيؤدي ذلك إلى تغيير طريقة عرض الصورة بحيث تحتوي على قِيَم مجموعة البيانات. استخدِم الخيار Preview لترى كيفية ظهور كل نسخة مع كل مجموعة بيانات.

انتقل إلى Image >‏ Apply Data Set لتحديد مجموعة البيانات من القائمة ومعاينة الصورة في نافذة المستند.

حدِّد Apply لتطبيق مجموعة البيانات. انقر فوق Cancel إذا كنت تريد معاينة الصورة الأساسية فقط ولا تريد تغييرها.

يمكنك كذلك تطبيق مجموعة بيانات ومعاينتها عن طريق الانتقال إلى Image >‏ Variables >‏ Data Sets وتحديد مربع الاختيار Preview.

ملاحظة:

يؤدي تطبيق مجموعة بيانات إلى استبدال المستند الأصلي.

إنشاء رسومات باستخدام مجموعات البيانات

بمجرد تعريف المتغيرات ومجموعة بيانات واحدة أو أكثر، يمكنك إنشاء صور مخرجات في الوضع الدفعي باستخدام قِيَم مجموعة البيانات هذه. وستكون صور المخرجات التي تم إنشاؤها على شكل ملفات بتنسيق PSD.

  1. انتقل إلى File >‏ Export >‏ Data Sets As Files.

  2. أدخل اسمًا أساسيًا لكل الملفات التي أُنشِئت. يمكنك إنشاء نظام خاص بك لتسمية الملفات، إن أردت ذلك.
  3. استخدِم الزر Select Folder لتحديد دليل الوجهة لملفاتك.

  4. اختر مجموعات البيانات المُراد تصديرها وانقر فوق OK.

إنشاء مجموعات بيانات في ملفات خارجية

يمكنك أن تُنشئ بسرعة عددًا كبيرًا من مجموعات البيانات عن طريق استخدام ملف نصي خارجي يحتوي على كل معلومات المتغيرات واستيراده في مستند PSD الخاص بك الذي يحتوي على المتغيرات.

تقضي إحدى الطرق بإدخال بياناتك في ملف نصي أو جدول بيانات في Microsoft Excel ثم تصديره إلى ملف مقسوم بعلامات جدولة أو فواصل.

اتَّبع البناء الموضح أدناه للملف النصي الخارجي (حيث يشكّل كل سطر يبدأ بـ "Variable" أو "Value" سطرًا بحد ذاته في ملفك):

VariableName1<sep>VariableName2<sep> <sep>VariableNameN <nl> 
Value1-1<sep>Value2-1<sep><sep>ValueN-1<nl> 
Value1-2<sep>Value2-2<sep><sep>ValueN-2<nl> 
Value1-M<sep>Value2-M<sep><sep>ValueN-M<nl>

تكون كل أسماء المتغيرات مسرودة على السطر الأول، حسب الترتيب المحدد للقيم في الأسطر التالية. يمثل كل سطر تالٍ مجموعة بيانات، مع قيم كل متغير محدد.

ملاحظة:

لإنشاء أسطر متعددة من النص في سطر نص واحد في مجموعة بيانات، يجب تضمين النص ضمن علامات اقتباس مزدوجة وإدراج علامات الرجوع في الملف المفصول بعلامات جدولة أو فواصل في المكان الذي تريد أن تظهر فيه فواصل الأسطر.  

الملف النصي الخارجي عناصر البناء

<sep>

ملف مقسوم بفواصل (CSV) أو علامات جدولة (tab-delimited) يفصل كلَّ اسم متغير أو قيمته

<nl>

حرف سطر جديد يُنهي مجموعة بيانات ويمكن أن يكون علامة سطر أو علامة رجوع أو كلتيهما

“true” و“false”

القِيَم المسموحة لمتغير visibility

المسافات

تُزال المسافات من حول المحدِّد عند تحليل الملف؛ يتم الحفاظ على المسافات بين الكلمات في سلسلة قيمة (على سبيل المثال، two of a kind) ويتم الحفاظ على المسافات البادئة واللاحقة إذا تم تضمينها بين علامات اقتباس مزدوجة (على سبيل المثال “one kind ”)

علامات الاقتباس المزدوجة

يمكنها أن تشكّل جزءًا من قيمة إذا كانت مسبوقة بعلامة اقتباس مزدوجة أخرى (على سبيل المثال، قد يكون ““B”” على الشكل “B” في مجموعة البيانات)

إذا كان <sep> أو <nl> جزءًا من قيمة المتغير، فيجب تضمين القيمة بأكملها ضمن علامات اقتباس مزدوجة.

يجب تعريف كل المتغيرات المعرَّفة الموجودة ضمن ملف PSD في الملف النصي، وإلا فسيظهر خطأ إذا لم يكن هناك تطابق بين عدد المتغيرات في الملف النصي والمستند الخاص بك.

مثال لمجموعة البيانات

أنشئ ملفًا نصيًا باستخدام قالب للزهور يحتوي على متغيرات لزهور التوليب ودوار الشمس. ويمكن أن يكون كما هو موضح هنا:

{contents of FlowerShow.txt} 
Variable 1, Variable 2, Variable 3 
true, TULIP, c:\My Documents\tulip.jpg 
false, SUNFLOWER, c:\My Documents\sunflower.jpg 
false, CALLA LILY, c:\My Documents\calla.jpg 
true, VIOLET, c:\My Documents\violet.jpg
ملاحظة:

يمكنك استخدام مسار نسبي لموقع الصورة إذا كان الملف النصي في المجلد نفسه حيث يوجد ملف الصورة. على سبيل المثال، العنصر الأخير في المثال يمكن أن يكون: true, VIOLET, violet.jpg.

استيراد مجموعة بيانات

  1. قم بأحد الأمور الآتية:

    • انتقل إلى File >‏ Import >‏ Variable Data Sets.

    أو،

    • انتقل إلى Image >‏ Variables >‏ Data Sets واستخدم الزر Import للانتقال إلى الملف النصي المُراد استيراده.
  2. قم بإعداد خيارات الاستيراد.

    • Use First Column For Data Set Names: تسمية كل مجموعة بيانات باستخدام محتوى العمود الأول من الملف النصي (قِيَم المتغير الأول مسرودة). وإلا، فستتم تسمية مجموعات البيانات Data Set 1 وData Set 2 وهكذا.
    • Replace Existing Data Sets: حذف أي مجموعات بيانات موجودة قبل الاستيراد
  3. عيّن تشفير الملف النصي أو اترك الإعداد Automatic قبل تحديد OK.

 Adobe

احصل على مساعدة بشكل أسرع وأسهل

مستخدم جديد؟