مقاطع المسار ومكوناته ونقاطه

يتكون المسار من مقطع مستقيم أو منحنٍ واحد أو أكثر. نقاط الربط تعلّم نقاط النهاية لكل مقطع من المسار. على المقاطع المنحنية، تعرض كل نقطة إرساء محددة خط اتجاه أو خطي اتجاه، وتنتهي عند نقاط الاتجاه‎. تحدد مواضع خطوط الاتجاه ونقاط الاتجاه حجم وشكل المقطع المنحني. يؤدي تحريك هذه العناصر إلى إعادة تشكيل المنحنيات في مسار.

أجزاء المسار في Photoshop
مسار

A. جزء خط منحني B. نقطة اتجاه C. خط اتجاه D. نقطة إرساء محددة E. نقطة إرساء غير محددة 

بإمكان المسار أن يكون مغلقًابدون بداية أو نهاية (على سبيل المثال، الدائرة)، أو مفتوحًا، له نقاط نهاية محددة (على سبيل المثال، الخط المتموج).

المنحنيات المصقولة تتصل عن طريق نقاط إرساء تسمى نقاط مصقولة. المسارات ذات المنحنيات الحادة تتصل عن طريق نقاط الركن.

النقطة المصقولة والنقطة الركن في Photoshop
النقطة المصقولة والنقطة الركن

عند قيامك بتحريك خط اتجاه على نقطة مصقولة، فإنه يتم ضبط الأجزاء المنحنية الواقعة على جانبي النقطة في وقت واحد. بالمقارنة، عند قيامك بتحريك خط اتجاه على نقطة ركن، فإنه يتم ضبط المنحنى الواقع على نفس جانب النقطة جهة خط الاتجاه فقط.

ضبط النقطة المصقولة والنقطة الركن في Photoshop
ضبط النقطة المصقولة ونقطة الركن

لا يجب أن يكون المسار على هيئة أجزاء متتابعة متصلة. من المحتمل أن يحتوي على أكثر من مكون مسار مميز ومنفصل. كل شكل في طبقة الشكل هو مكون مسار كما هو موصف بواسطة قناع قطع الطبقة.

تحديد مكونات مسار منفصلة في Photoshop
مكونات مسار منفصلة محددة

تحديد مسار

يؤدي تحديد مكون مسار أو مقطع مسار إلى عرض كل نقاط الإرساء الواقعة على هذا المقطع، بما فيها كل خطوط الاتجاه ونقاط الاتجاه إذا كان المقطع المحدد منحنيًا. تظهر مقابض الاتجاه كدوائر معبأة، ونقاط الإرساء المحددة كمربعات معبأة، ونقاط الإرساء غير المحددة كمربعات فارغة.

  1. قم بأحد الأمور التالية:
    • لتحديد مكون مسار (متضمناً شكل في طبقة الشكل)، اختر الأداة Path Selection ، ثم انقر في أي موضع داخل مكون المسار. إذا كان المسار يتكون من مكونات مسار متعددة، فإنه يتم تحديد مكون المسار الواقع أسفل المؤشر فقط.

    • لتحديد مقطع من مسار، حدد الأداة Direct Selection ، ثم انقر فوق أي من نقاط الإرساء الواقعة على هذا المقطع أو اسحب مستطيل التحديد على هذا المقطع من المسار.

    الأداة Direct Selection في Photoshop
    اسحب مستطيل التحديد لتحديد الأجزاء.

  2. لتحديد مكونات مسار أو أجزاء إضافية، اختر أداة Path Selection أو أداة Direct Selection واضغط على مفتاح Shift أثناء تحديد مسارات أو أجزاء إضافية.

    ملاحظة:

    عندما تكون أداة التحديد المباشر محددة، يمكنك تحديد المسار بأكمله أو مكون مسار عن طريق الضغط على مفتاح Alt (في حالة نظام التشغيل Windows) أو الضغط على مفتاح Option (في حالة نظام التشغيل Mac OS) داخل المسار. لتنشيط أداة التحديد المباشر عندما تكون معظم الأدوات الأخرى محددة، ضع المؤشر أعلى نقطة إرساء ثم اضغط مفتاح Ctrl (في حالة نظام التشغيل Windows) أو اضغط مفتاح Command (في حالة نظام التشغيل Mac OS).

تحديد مسارات متعددة | Photoshop CC

يمكنك تحديد عدة مسارات على الطبقة نفسها أو عبر طبقات مختلفة.

  1. في لوحة Paths ، قم بأي مما يلي لجعل المسارات مرئية:

    • انقر مع الضغط على المفتاح Shift لتحديد مسارات متجاورة.
    • انقر مع ضغط مفتاح Ctrl (في Windows) أو مفتاح Command (في Mac OS) لتحديد مسارات غير متجاورة.
  2. حدد الأداة Path Selection أو الأداة Direct Selection، وقم بأي مما يلي:

    • اسحب فوق المقاطع.
    • انقر فوق المسارات مع ضغط المفتاح Shift.
  3. لتحديد مكونات أو مقاطع مسار مختلفة، حدد الأداة Path Selection أو الأداة Direct Selection، ثم اضغط على المفتاح Shift أثناء تحديد مسارات أو مقاطع إضافية.

    ملاحظة:

    يمكنك أن تختار العمل باستخدام المسارات في صيغة العزل. لعزل فقط الطبقة التي تحتوي على مسار، انقر نقرًا مزدوجًا باستخدام أداة تحديد عندما يكون المسار نشطًا. كما يمكنك عزل طبقة واحدة أو عدة طبقات باستخدام عنصر القائمة Select/Isolate Layers أو بتعيين Layer Filtering إلى Selected.

    يمكنك الخروج من صيغة العزل باستخدام عدة طرق، مثل:

    • إيقاف تشغيل Layer Filtering
    • تبديل Layer Filtering إلى شيء آخر غير Selected
    • النقر المزدوج بعيدًا عن مسار باستخدام أدوات التحديد 

إعادة ترتيب المسارات

يمكنك إعادة ترتيب المسارات التي ليست عبارة عن مسارات شكل أو نوع أو قناع متجه في لوحة Paths .

  1. في لوحة Paths ، اسحب المسار إلى الموضع الذي تريد. في Photoshop CC، يمكنك تحديد وسحب أكثر من مسار واحد في الوقت نفسه.

تكرار المسارات

  1. في لوحة Paths ، حدد المسار الذي تريد تكراره. في Photoshop CC، يمكنك تحديد أكثر من مسار واحد.

  2. قم بأحد الأمور التالية:

    • اسحب المسارات مع ضغط مفتاح Alt (في Windows) أو مفتاح Option (في Mac OS).
    • اختر Duplicate Path من قائمة اللوحة.

تحديد خيارات المسار

يمكنك تحديد لون خطوط المسار وسمكها لتناسب ذوقك ولسهولة رؤيتها. أثناء إنشاء مسار — باستخدام أداة Pen مثلاً — انقر فوق رمز الترس () في شريط Options. والآن حدد لون خطوط المسار وسمكها. يمكنك أيضًا تحديد ما إذا كنت تريد معاينة مقاطع المسار أثناء تحريك المؤشر بين النقرات (تأثير Rubber Band).

path-options
خيارات المسار: السمك واللون

ضبط مقاطع المسار

يمكنك تحرير مقطع مسار في أي وقت، لكن تحرير مقاطع موجودة يختلف بعض الشيء عن رسمها. تذكر ما يلي عند تحرير المقاطع:

  • إذا كانت نقطة الربط تصل بين مقطعين، فإن نقل نقطة الربط تلك دائمًا ما يغير كلا المقطعين.

  • عند الرسم باستخدام الأداة Pen، يمكنك تنشيط الأداة Direct Selection بشكل مؤقت بحيث يمكنك ضبط المقاطع التي سبق لك رسمها؛ اضغط على المفتاح Ctrl (في Windows) أو Command (في Mac OS) أثناء الرسم.

  • عندما تقوم برسم نقطة المصقولة باستخدام أداة Pen، فإن سحب نقطة الاتجاه يغير طول اتجاه الخط على جانبي النقطة. على أي حال، عندما تقوم بتحرير نقطة المصقولة موجودة باستخدام أداة Direct Selection، فأنت تغير طول خط الاتجاه فقط على الجانب الذي تسحبه.

حرك المقاطع المستقيمة

  1. باستخدام الأداة Direct Selection ، حدد المقطع الذي تريد ضبطه.
  2. اسحب المقطع إلى موضعه الجديد.

ضبط طول أو زاوية المقاطع المستقيمة

  1. باستخدام الأداة Direct Selection ، حدد نقطة ربط على المقطع الذي تريد ضبطه.

  2. اسحب نقطة الربط إلى الموضع المرغوب. اسحب مع الضغط على Shift لتقييد الضبط بمضاعفات 45 درجة.

ضبط موضع أو شكل مقاطع المنحنية

  1. باستخدام الأداة ، حدد مقطعًا منحنيًا، أو نقطة إرساء على أي من طرفي المقطع المنحني. تظهر خطوط الاتجاه، إن وجد أي منها. (بعض المقاطع المنحنية تستخدم خط اتجاه واحد فقط.)
  2. قم بأحد الأمور التالية:
    • لضبط موضع المقطع، اسحب المقطع. اسحب مع الضغط على Shift لتقييد الضبط بمضاعفات 45 درجة.

    النقر لتحديد المقطع المنحني في Photoshop
    انقر لتحدد المقطع المنحني. ثم اسحب للضبط.

    • لضبط شكل المقطع على أي من جانبي نقطة الربط المحددة، اسحب نقطة الربط أو نقطة الاتجاه. اسحب مع الضغط على العالي لتحافظ على الضبط بتحركات بمضاعفات 45°.

    سحب نقطة الربط، أو نقطة الاتجاه في Photoshop
    سحب نقطة الربط، أو سحب نقطة الاتجاه.

    ملاحظة:

    ضبط قطاع مسار يؤدي أيضًا إلى ضبط المقاطع ذات الصلة، مما يتيح لك إجراء تحوّل لأشكال المسارات بطريقة بديهية. لتحرير المقاطع بين نقاط الإرساء المحددة فقط، بطريقة مماثلة لإصدارات Photoshop السابقة، حدد Constrain Path Dragging في شريط الخيارات.

    ملاحظة:

    يمكنك أيضاً تطبيق تحويل، مثل القياس أو التدوير، على مقطع أو نقطة ربط.

حذف مقطع

  1. (اختياري) إذا كنت تريد إنشاء فتحة في مسار مغلق، فحدد الأداة Add Anchor Point ، وأضف نقطتين في المكان حيث تريد أن يحدث القطع.
  2. حدد أداة Direct Selection ، وحدد المقطع الذي تريد حذفه.
  3. اضغط على مفتاح Backspace (في Windows) أو على مفتاح Delete (في Mac OS) لحذف المقطع المحدد. ضغط المسافة الخلفية أو الحذف مرة أخرى يمسح بقية المسار.

حذف سطر الاتجاه الخاص بنقطة إرساء

تمديد مسار مفتوح

  1. باستخدام أداة Pen، ضع المؤشر على نقطة نهاية المسار المفتوح الذي تريد تمديده. يتغير المؤشر عند وضعه بدقة فوق نقطة النهاية.
  2. انقر فوق نقطة النهاية.
  3. قم بأحد الأمور التالية:
    • لإنشاء نقطة ركن، ضع الأداة Pen حيث تريد أن تنهي المقطع الجديد، وانقر. إذا كنت تقوم بتمديد مسار ينتهي عند نقطة مصقولة، فسيؤدي خط الاتجاه الموجود إلى انحناء المقطع الجديد.

    • لإنشاء نقطة مصقولة، ضع الأداة Pen حيث تريد أن تنهي مقطع المنحنى الجديد، واسحب.

وصل مسارين مفتوحين

  1. باستخدام أداة Pen، ضع المؤشر على نقطة نهاية المسار المفتوح الذي تريد توصيله بمسار آخر. يتغير المؤشر عند وضعه بدقة فوق نقطة النهاية.
  2. انقر فوق نقطة النهاية.
  3. قم بأحد الأمور التالية:
    • لوصل المسار بمسار آخر مفتوح، انقر نقطة نهاية على المسار الآخر. عند وضع الأداة Pen بدقة على نقطة نهاية المسار، تظهر علامة دمج صغيرة  بجوار المؤشر.

    • لوصل مسار جديد إلى مسار موجود، ارسم المسار الجديد بالقرب من المسار الموجود، ثم حرك أداة Pen، إلى نقطة نهاية المسار الموجود (غير المحدد). انقر نقطة النهاية تلك عندما ترى علامة الدمج الصغيرة التي تظهر بجوار المؤشر.

نقل أو دفع نقاط ربط أو مقاطع باستخدام لوحة المفاتيح

  1. حدد نقطة الربط أو مقطع المسار.
  2. انقر أو اضغط أي مفاتيح أسهم على لوحة المفاتيح لنقل بمقدار 1 بيكسل في المرة الواحدة في اتجاه السهم.

ابق مفتاح العالي مضغوطاً بالإضافة إلى مفتاح السهم للنقل بمقدار 10 بيكسل في المرة الواحدة.

إضافة نقاط الإرساء أو حذفها

يمكن أن تمنحك إضافة نقاط ربط المزيد من التحكم في المسار، أو يمكن أن تمدد مسار مفتوح. ومع ذلك، حاول عدم إضافة نقاط أكثر من اللازم. المسار ذو النقاط القليلة يكون أسهل في التحرير، العرض، والطباعة. يمكنك خفض تعقيد مسار بحذف النقاط غير الضرورية.

يحتوي مربع الأدوات على ثلاثة أدوات لإضافة النقاط أو حذفها وهي: أداة Pen  وأداة Add Anchor Point  وأداة Delete Anchor Point .

بشكل افتراضي، تتغير أداة Pen إلى أداة إضافة نقطة ربط بمجرد وضعها على المسار المحدد، أو أداة حذف نقطة ربط بمجرد وضعها على نقطة ربط. يجب تحديد Auto Add/Delete في شريط الخيارات لتمكين الأداة Pen من أن تتغيّر تلقائيًا إلى الأداة Add Anchor Point أو الأداة Delete Anchor Point.

يمكنك تحديد عدة مسارات وتحريرها في الوقت نفسه. كما يمكنك إعادة تشكيل مسار أثناء إضافة نقاط إرساء بالنقر والسحب أثناء إضافتها.

ملاحظة:

لا تستخدم مفتايح الحذف أو الرجوع أو أمر تحرير > قص أو تحرير > مسح لحذف نقاط ربط. تلك المفاتيح والأوامر تحذف النقطة ومقطع الخط المتصل بتلك النقطة.

إضافة نقاط الإرساء أو حذفها

  1. حدد المسار الذي تريد تعديله.
  2. حدد أداة Pen ، أداة إضافة نقطة ربط ، أو أداة حذف نقطة ربط .
  3. لإضافة نقطة ربط، ضع المؤشر على مقطع مسار، وانقر. لحذف نقطة ربط، ضع المؤشر على نقطة الربط، وانقر.

إيقاف أو تخطي مؤقت الانتقال إلى أداة Pen آلياً

يمكنك تخطي الانتقال الآلي لأداة Pen إلى أداة إضافة نقطة ربط أو أداة حذف نقطة ربط. يكون ذلك مفيداً عندما تريد أن تبدأ مسار جديد أعلى المسار الموجود.

  • في Photoshop، قم بإلغاء تحديد Auto Add/Delete في شريط الخيارات.

التحويل بين نقاط مصقولة ونقاط الركن

  1. حدد المسار الذي تريد تعديله.
  2. حدد أداة Convert Point أو استخدم أداة Pen واضغط على مفتاح Alt (في حالة نظام التشغيل Windows) أو اضغط على مفتاح Option (في حالة نظام التشغيل Mac OS).

    ملاحظة:

    لتنشيط أداة Convert Point بينما أداة التحديد المباشر محددة، ضع المؤشر أعلى نقطة إرساء واضغط على مفتاحي Ctrl+Alt (في حالة نظام التشغيل Windows) أو اضغط على مفتاحي Command+Option (في حالة نظام التشغيل Mac OS).

  3. ضع أداة Convert Point أعلى نقطة الإرساء التي تريد تحويلها، ثم قم بتنفيذ إحدى الخيارات التالية:
    • لتحويل نقطة ركن إلى نقطة مصقولة، اسحب بعيداً عن نقطة الركن لإظهار خطوط الاتجاه.

    التحويل بين نقاط مصقولة ونقاط الركن في Photoshop
    سحب نقطة اتجاه بعيداً عن نقطة ركن لإنشاء نقطة مصقولة

    • لتحويل نقطة مصقولة إلى نقطة ركن بدون خطوط اتجاه، انقر النقطة المصقولة.

    نقر نقطة مصقولة لإنشاء نقطة ركن في Photoshop
    نقر نقطة مصقولة لإنشاء نقطة ركن

    • لتحويل نقطة ركن بدون خطوط اتجاه إلى نقطة ركن غير معتمدة على خطوط اتجاه، اسحب نقطة الاتجاه أولاً بعيداً عن نقطة الركن (يجعلها نقطة مصقولة ذات خطوط اتجاه). اترك زر الماوس فقط (لا تترك أي المفاتيح التي قد تكون ضغطت عليها لتنشيط أداة Convert Point إرساء) ثم اسحب أي من نقاط الاتجاه.

    • لتحويل نقطة مصقولة إلى نقطة ركن معتمدة على خطوط اتجاه، اسحب نقطة الاتجاه.

    تحويل نقطة مصقولة إلى نقطة ركن في Photoshop
    تحويل نقطة مصقولة إلى نقطة ركن

ضبط مكونات المسار

يمكنك تغيير موضع مكون مسار (متضمناً شكل في طبقة الشكل) في أي موقع داخل الصورة. يمكنك نسخ المكونات داخل صورة أو بين صورتين من صور Photoshop. باستخدام أداة تحديد المسار، يمكنك دمج المكونات المتداخلة إلى مكون واحد مفرد. كل الكائنات المتجهة، سواء كانوا موصفين من خلال مسار محفوظ، مسار عمل، أو قناع متجه، يمكن تحريكهم، إعادة تشكيلهم، نسخهم، أو حذفهم.

كما يمكنك استخدام أوامر النسخ واللصق لمضاعفة الكائنات المتجهة بين صورة Photoshop وصورة في تطبيق أخر، مثل Adobe Illustrator.

تغيير صيغة التداخل لمكون المسار المحدد

  1. باستخدام الاداة Path Selection ، اسحب محيطًا منقطًا لتحديد مناطق المسار الموجود.
  2. اختر أحد خيارات مساحة شكل من قائمة Path Operations المنسدلة في شريط الخيارات:

    Combine Shapes 

    يضيف مساحة المسار إلى مساحات المسار المتداخلة.

    Subtract From Shape Area 

    يحذف مساحة المسار من مساحات المسار المتداخلة.

    Intersect Shape Areas 

    يقصر المساحة على التقاطع بين مساحة المسار المحددة ومساحات المسار المتداخلة.

    Exclude Overlapping Shape Areas 

    يستخرج المساحة المتداخلة.

إظهار أو إخفاء مكون المسار المحدد

قم بأحد الأمور التالية:

  • اختر View >‏ Show >‏ Target Path.
  • اختر View‏ > Extras. كما يقوم هذا الأمر بإظهار أو إخفاء الشبكة والأدلة وحواف التحديدات والتعليقات الإيضاحية والشرائح.

تحريك مسار أو مكون مسار

  1. حدد اسم المسار في لوحة Paths، واستخدم الأداة Path Selection  لتحديد المسار في الصورة. لتحديد مكونات مسار متعددة، اضغط على مفتاح Shift وانقر كل مكون مسار إضافي لكي تتم إضافته إلى المكونات المحددة.
  2. اسحب المسار إلى موقعه الجديد. إذا قمت بتحريك أي جزء خارج نطاق مساحة العمل، يظل الجزء المختفي من المسار متاحًا.
    سحب مسار إلى موقع جديد في Photoshop
    سحب مسار إلى موقع جديد

    ملاحظة:

    إذا قمت بسحب مسار إلى أن يصبح مؤشر الفأرة أعلى صورة أخرى مفتوحة، فإنه يتم نسخ المسار إلى هذه الصورة.

إعادة تشكيل مكون مسار

  1. حدد اسم المسار في لوحة Paths، واستخدام الاداة Direct Selection  لتحديد نقطة إرساء في المسار.
  2. اسحب النقطة أو مقابضها إلى موقع جديد.

دمج مكونات المسار المتداخلة

  1. حدد اسم المسار في اللوحة Paths، وحدد الأداة Path Selection .
  2. لإنشاء مكوّن فردي من كل المكونات المتداخلة، اختر Merge Shape Components من قائمة Path Operations المنسدلة في شريط الخيارات.

نسخ مكون مسار أو مسار

قم بأحد الأمور التالية:

  • لنسخ مكون مسار بينما تقوم بتحريكه، حدد اسم المسار في اللوحة Paths، ثم انقر فوق مكون مسار باستخدام الأداة Path Selection . ثم اضغط المفتاح Alt (في Windows) أو المفتاح Option (في Mac OS) أثناء سحب المسار المحدد.
  • لنسخ مسار بدون إعادة تسميته، اسحب اسم المسار في اللوحة Paths إلى الزر New Path  في أسفل اللوحة.
  • لنسخ مسار وإعادة تسميته، اضغط المفتاح Alt (في Windows) أو المفتاح Option (في Mac OS) أثناء سحب المسار في اللوحة Paths إلى الزر New Path في أسفل اللوحة. أو حدد المسار لنسخه/ ثم اختر Duplicate Path من قائمة اللوحة Paths. أدخل اسمًا جديدًا للمسار في شاشة Duplicate Path، ثم انقر فوق OK.
  • لنسخ مسار أو مكون مسار إلى مسار آخر، حدد المسار أو مكون المسار الذي تريد نسخه ثم اختر Edit ‏> Copy. بعد ذلك، حدد مسار الوجهة، واختر Edit ‏> Paste.

نسخ مكونات مسار بين ملفين من ملفات Photoshop

  1. افتح كلا الصورتين.
  2. في الصورة المصدر، استخدم الأداة Path Selection  لتحديد المسار بأكمله أو مكونات المسار التي تريد نسخها.
  3. لنسخ مكون مسار، قم بتنفيذ أي من الخيارات التالية:
    • اسحب مكون المسار من الصورة المصدر إلى الصورة المستهدفة. يتم نسخ مكون المسار إلى المسار النشط في لوحة المسارات.

    • في الصورة المصدر، حدد اسم المسار في اللوحة Paths، ثم اختر Edit > Copy لنسخ المسار. في الصورة المستهدفة، اختر Edit > Paste. كما يمكنك استخدام هذه الطريقة لتجميع المسارات في نفس الصورة.

    • للصق مكون المسار إلى الصورة المستهدفة، حدد مكون المسار في الصورة المصدر، ثم اختر Edit > Copy. في الصورة المستهدفة، اختر Edit > Paste.

حذف مكون مسار

  1. حدد اسم المسار في اللوحة Paths، وانقر فوق مكون مسار باستخدام الأداة Path Selection .
  2. اضغط على مفتاح Backspace (في Windows) أو على مفتاح Delete (في Mac OS) لحذف مكون المسار المحدد.

محاذاة وتوزيع مكونات المسار

يمكنك محاذاة وتوزيع مكونات المسار الموصفة في مسار واحد مفرد. على سبيل المثال، يمكنك محاذاة الحواف اليسرى لأشكال عديدة موجودة في طبقة واحدة أو توزيع مكونات متعددة في مسار عمل بناء على مراكزهم الأفقية.

ملاحظة:

لمحاذاة الأشكال الواقعة على طبقات منفصلة، استخدم الأداة Move.

  • لمحاذاة المكوّنات، استخدم الأداة Path Selection  لتحديد المكوّنات التي تريد محاذاتها. ثم اختر خيارًا من قائمة Path Alignment المنسدلة في شريط الخيارات.
خيارات المحاذاة في Photoshop
خيارات المحاذاة

  • لتوزيع المكوّنات، حدد ثلاثة مكوّنات على الأقل تريد توزيعها. ثم اختر خيارًا من قائمة Path Arrangement المنسدلة في شريط الخيارات.
خيارات التوزيع في Photoshop
خيارات التوزيع

فيديو تعليمي | تلميحات بشأن العمل مع المتجهات في Photoshop

فيديو تعليمي | تلميحات بشأن العمل مع المتجهات في Photoshop
في هذه الحلقة من The Complete Picture، توضح Julieanne خمس ميزات من ميزاتها المفضلة للعمل مع المتجهات في Photoshop.
Julieanne Kost

تم ترخيص هذا العمل بموجب الترخيص العام غير المعدل الخاص بالإسناد وعدم التجارة والمشاركة الإصدار 3.0 ‏من ‏‏Creative Commons‏‏  إن بنود Creative Commons لا تشمل منشورات Twitter™‎ وFacebook.

إشعارات قانونية   |   سياسة الخصوصية على الإنترنت