מסמך זה מסביר כיצד להגדיר לחצני פעולה בטופסי PDF. (אם אתה מחפש מידע על יצירת טפסים מאפס והפצה, מעקב אחר טפסים או מילוי וחתימה על טפסים, לחץ על הקישור המתאים לעיל. כדי לעיין בתשובות לשאלות נפוצות על טפסים, לחץ על הקישור 'שאלות נפוצות על טפסים').

 

אודות לחצנים

לחצנים משויכים בדרך כלל לטפסים, אך ניתן להוסיפם לכל מסמך. לחצנים יכולים לפתוח קובץ, להשמיע קובץ קול או להקרין סרטון, למסור נתונים לשרת אינטרנט ועוד. כשמחליטים כיצד ליזום פעולה, יש לזכור כי לחצנים מציעים את היכולות הבאות, שסימניות וקישורים אינם יכולים להציע:

  • לחצן יכול להפעיל פעולה בודדת או סדרה של פעולות.

  • לחצן יכול לשנות מראה בתגובה לפעולות עכבר.

  • ניתן להעתיק לחצן בקלות לעמודים רבים.

  • פעולות עכבר יכולות להפעיל לחצנים שונים. לדוגמה, Mouse Down (לחיצה), Mouse Up (שחרור לאחר לחיצה), Mouse Enter (הזזת המצביע מעל הלחצן) ו- Mouse Exit (הזזת המצביע הרחק מהלחצן) יכולות להפעיל פעולה שונה עבור אותו לחצן.

    לחצנים מאפשרים למשתמשים ליזום פעולה במסמכי PDF בצורה קלה ואינטואיטיבית. ניתן ליצור שילוב של תוויות וסמלים בלחצנים שינחו את המשתמש במהלך סדרת פעולות או אירועים, וישתנו בהתאם לתנועת העכבר. לדוגמה, ניתן ליצור לחצנים עם התוויות והסמלים "הפעלה", "השהיה" ו"עצירה". לאחר מכן, ניתן להגדיר ללחצנים אלה פעולות כך שהם יפעילו , ישהו ויעצרו הפעלה של קובץ מולטימדיה. ניתן לבחור כל שילוב של התנהגויות עכבר ללחצן, ולציין כל שילוב של פעולות להתנהגות של העכבר.

הוספת לחצן לטופס PDF של Acrobat

  1. ודא שאתה נמצא במצב עריכה על-ידי בחירה ב- Tools ‏> Prepare Form ולאחר מכן בחר ב- Button בסרגל הכלים. הסמן משנה את צורתו לצורת צלב דק.

  2. לחץ בעמוד במקום שברצונך להוסיף בו את הלחצן כדי ליצור לחצן בגודל ברירת המחדל. ללחצן בגודל מותאם אישית, גררו מלבן לסימון גודל הלחצן.
  3. לחץ פעמיים על שדה הלחצן וציין שם, מלל לעצת הכלי ומאפיינים נפוצים אחרים.
  4. לחץ על הכרטיסייה Appearance וציין אפשרויות כדי לקבוע את מראה הלחצן בעמוד. זכור: אם תבחר צבע רקע, לא תוכל לראות את התמונות שמאחורי הלחצן. אפשרויות המלל משפיעות על התווית שתציין בכרטיסייה Options, ולא על שם הלחצן בכרטיסייה General.

    הערה:

    אם בוחרים באפשרות Enable Right-To-Left Language Options בחלונית International בתיבת הדו-שיח Preferences, הכרטיסייה Appearance תכלול אפשרויות לשינוי סגנון הספרות וכיוון המלל בלחצנים.

  5. לחץ על הכרטיסייה Options, ובחר באפשרויות שיקבעו את אופן הצגת הסמלים והתוויות בלחצן.
  6. לחץ על הכרטיסייה Actions, וציין אפשרויות שיקבעו מה יתבצע בלחיצה על הלחצן, כגון מעבר לעמוד אחר או הפעלת קובץ מולטימדיה.
  7. לחץ על Close.

    הערה:

    בשעת יצירת סדרת לחצנים, ניתן להצמיד את העצם לקווי רשת או לקווי עזר.

  8. כדי להציג תצוגה מקדימה של הלחצן ולבדוק אותו, לחץ על Preview בקצה הימני של סרגל הכלים. לאחר שתסיים, תוכל ללחוץ על Edit כדי לחזור לכלי Prepare Form, או ללחוץ על סמל הצלב בקצה הימני של סרגל הכלים כדי לסגור את הכלי.

הוספת לחצן מסירה

כשמפיצים טופס, Acrobat בודקת אוטומטית את הטופס. אם היא אינה מוצאת לחצן מסירה, היא מוסיפה את הלחצן Submit Form לשרות ההודעות של המסמך. המשתמשים יכולים ללחוץ על לחצן זה כדי לשלוח את הטפסים לאחר המילוי בחזרה אליך. אם אין בכוונתך להשתמש בלחצן Submit Form שנוצר על-ידי Acrobat, באפשרותך להוסיף לחצן שליחה מותאם אישית לטופס.

  1. אם אינך במצב עריכת טופס, בחר Tools ‏> Prepare Form.

  2. באמצעות הכלי לחצן , גררו לאורך האזור הרצוי להצגת הלחצן. לחץ פעמיים על הלחצן וקבע אפשרויות בכרטיסיות General וOptions.

  3. בכרטיסייה Options, בחר אפשרות מהתפריט Layout לתווית הלחצן, לתמונת הסמל או לשתיהן. בצע אחד מהצעדים הבאים או את שניהם:

    • הקלד מלל בתיבה Label לזיהוי הלחצן כלחצן מסירה.

    • לחץ על Choose Icon והקלד את הנתיב לקובץ תמונה, או לחץ על Browse ואתר את קובץ התמונה שברצונך להשתמש בו.

  4. בכרטיסייה Actions, בחר Submit A Form בתפריט Select Action ולאחר מכן לחץ על Add.

  5. בתיבת הדו-שיח Submit Form Selections, בצע אחת מהפעולות הבאות:
    • כדי לאסוף נתוני טופס בשרת, הקלד את המיקום בתיבה Enter a URL for this link. לדוגמה, http://www.[דומיין]/[תיקייה]/[תת-תיקייה]/ לכתובת אינטרנט או \\[שרת]\[תיקייה]\[תת-תיקייה]\ למיקום ברשת מקומית.

    • לאיסוף הנתונים כקבצים מצורפים מהודעות דוא"ל, הקלד mailto:‎ וכתובת דוא"ל. לדוגמה, mailto:nobody@adobe.com.

  6. בחר אפשרויות עבור Export Format‏, Field Selection ו-Date Options ולחץ על OK.

  7. לחץ על Close.

  8. כדי להציג תצוגה מקדימה של הלחצן ולבדוק אותו, לחץ על Preview בקצה הימני של סרגל הכלים. לאחר שתסיים, תוכל ללחוץ על Edit כדי לחזור לכלי Prepare Form, או ללחוץ על סמל הצלב בקצה הימני של סרגל הכלים כדי לסגור את הכלי.

הערה:

אם הנתונים יוחזרו בתבנית FDF או XFDF, כתובת URL של השרת חייבת להסתיים בסיומת ‎#FDF; לדוגמה, http://myserver/cgi-bin/myscript#FDF.

אפשרויות בחירה למסירת טופס

האפשרויות הבאות זמינות בתיבת הדו-שיח Submit Forms Selections:

Enter a URL for this link

ציון כתובת ה- URL לאיסוף נתוני הטופס.

FDF

מחזיר את הקלט של המשתמש ללא קובץ PDF שנשלח במקור למשתמש. באפשרותך לבחור אפשרויות כדי לכלול את Field Data‏, Comments ו- Incremental Changes To The PDF.

הערה:

בחירה באפשרות של שינויים הדרגתיים היא שימושית לקבלת חתימות דיגיטליות באופן קל לקריאה ולשחזור בשרת.

HTML

מחזיר את הטופס ב- Hypertext Markup Language.

XFDF

מחזיר את הקלט של המשתמש כקובץ XML. ניתן לכלול הערות בנתוני השדה או רק את נתוני השדה.

PDF

מחזיר את כל קובץ PDF עם הקלט של המשתמש.

Field Selection

מציין אילו שדות יוחזרו. כדי לקבל רק חלק מנתוני השדה שהושלמו, בחר Only These, לחץ על Select Fields ובחר את השדות שיש לכלול או לא לכלול בתיבת הדו-שיח Field Selection.

לדוגמה, תוכל להשתמש באפשרות זו כדי שלא לכלול חלק מהשדות המחושבים או הכפולים המופיעים בטופס לנוחיותו של המשתמש אך אינם כוללים נתונים חדשים.

Date Options

קביעת תבנית התאריכים שיזין המשתמש.

שינוי מראה של לחצנים

לחצן יכול לכלול תווית, סמל או את שניהם. ניתן לשנות את המראה של לחצן בכל אחד ממצבי העכבר (Up‏, Down‏, ו- Rollover). לדוגמה, באפשרותך ליצור תווית “Home” עד שהמצביע יזוז מעל הלחצן והיא עשויה להשתנות לתווית “Click to return to home page”.

ניתן ליצור סמלי לחצנים מכל תבנית קובץ שתוכנת Acrobat יכולה להציג, כולל PDF, ‏JPEG, ‏GIF ותבניות תמונה אחרות. לכל תבנית שתבחר ישמש העמוד כולו, כך שאם ברצונך להשתמש רק בחלק מהעמוד כסמל, יש לחתוך את העמוד או את התמונה לפני שתמשיך בביצוע הליך זה. גודל עמוד PDF הקטן ביותר המותר הוא 1 על 1 אינץ' (2.54 על 2.54 ס"מ). אם ברצונך שהסמל ייראה קטן מ- 1 על 1 אינץ', הקטן אותו כך שיתאים לגודל התיבה שצוירה בעזרת הכלי Button. לחיצה על Advanced בכרטיסייה Options של תיבת הדו-שיח Button Properties מאפשרת לך לקבוע כיצד קנה המידה של סמל לחצן משתנה כדי להתאים ללחצן.

פריסות לחצנים
פריסות לחצנים

A. תווית בלבד B. סמל בלבד C. סמל למעלה, תווית למטה D. תווית למעלה, סמל למטה E. סמל משמאל, תווית מימין F. תווית משמאל, סמל מימין G. תווית על גבי סמל 

עריכת לחצן

  1. אם אינך במצב עריכת טופס, בחר Tools ‏> Prepare Form.

  2. בחר בשדה Button ובצע אחת מהפעולות הבאות:
    • כדי לערוך את מאפייני שדה הלחצן, לחץ פעמיים על הלחצן.

    • כדי לשנות את מראה הלחצנים, השתמש באפשרויות המראה בכרטיסייה Appearance של תיבת הדו-שיח Button Properties.

    • כדי ליישר, למרכז או לפזר את הלחצן בין שדות טופס אחרים, או כדי לשנות את גודלו או לשכפל אותו, לחץ עליו לחיצה ימנית ובחר אפשרות מהתפריט תלוי-ההקשר.

  3. סגור את כל תיבות הדו-שיח הפתוחות, אם קיימות. לחץ על סמל הצלב בקצה הימני של סרגל הכלים של Prepare Form כדי לסגור את הכלי.

קביעת מאפייני תצוגה של לחצן ב- Acrobat

  1. אם אינך במצב עריכת טופס, בחר Tools ‏> Prepare Form.

  2. לחץ לחיצה כפולה על לחצן קיים ולחץ על הכרטיסייה Options בתיבת הדו-שיח Button Properties.
  3. באפשרות Layout, בחר בסוג תצוגת התווית הרצוי. (לקבלת מידע על שינוי גודל של סמלי לחצן, ראה ההליך הבא).
  4. באפשרות Behavior, ציין את מראה הלחצן בעת לחיצה עליו:
  5. כדי להגדיר את התווית או הסמל שמופיעים על הלחצן, בצע את הפעולות הבאות:
    • אם נבחרה אפשרות תווית מתפריט Layout, הקלד את המלל בתיבה Label.

    • אם אפשרות סמל נבחרת מהתפריט Layout, לחץ על Choose Icon, לחץ על Browse ובחר את הקובץ. ‏(לחץ על Clear כדי להסיר את הסמל שנבחר).

  6. סגור את כל תיבות הדו-שיח הפתוחות, אם קיימות. לחץ על סמל הצלב בקצה הימני של סרגל הכלים של Prepare Form כדי לסגור את הכלי.

אפשרויות Button Behavior

None

משאיר את מראה הלחצן ללא שינוי.

Push

מציין מראה במצבי העכבר ‏Up‏, Down או Rollover. בחר אפשרות תחת State וציין אפשרות תווית או סמל:

Up

קובע את מראה הלחצן כשלא לוחצים על לחצן העכבר.

Down

קובע את מראה הלחצן כשלוחצים על לחצן העכבר, לפני שמשחררים אותו.

Rollover

קובע את מראה העכבר כשמחזיקים את המצביע על לחצן.

Outline

מסמן את גבולות הלחצן.

Invert

מחליף בין הגוונים הכהים והבהירים של הלחצן.

שינוי גודל ומיקום של לחצנים

  1. אם אינך במצב עריכת טופס, בחר Tools ‏> Prepare Form.

  2. לחץ לחיצה כפולה על לחצן קיים כדי לפתוח את תיבת הדו-שיחButton Properties.
  3. לחץ על הכרטיסייה Options, בחר אחת מאפשרויות הסמלים מהתפריט Layout ולחץ על Advanced.

    הערה:

    הלחצן Advanced אינו זמין אם אתה בוחר Label Only מהתפריט Layout.

  4. בחר אפשרות מהתפריט When To Scale:

    Always

    משנה את גודל הסמל כפי שמוגדר, ללא קשר לגודלו ביחס לגודל הלחצן.

    Never

    שומר על גודלו המקורי של הסמל; גבולות הלחצן חותכים את הסמל אם הוא אינו מתאים לשטח הלחצן. אם נבחרה האפשרות Never, אפשרויות שינוי הגודל אינן זמינות.

    Icon Is Too Big

    משנה את גודל הסמל כפי שהוגדר, רק אם הסמל גדול מהלחצן.

    Icon Is Too Small

    משנה את גודל הסמל כפי שהוגדר, רק אם הסמל קטן מהלחצן.

  5. מהתפריט Scale, בחר אם לשנות או לא לשנות את גודל הסמל באופן פרופורציונלי. אם גודל הסמל משתנה בצורה לא פרופורציונלית, הסמל עלול להופיע נטוי.

  6. כדי לוודא שהשוליים העליונים, התחתונים, הימניים והשמאליים מוצמדים לקצות הלחצן, בחר Fit To Bounds‏.

  7. כדי להגדיר היכן הסמל ימוקם בתוך הלחצן, גררו את חיצי המחוון. מיקום סמל מוגדר בהתאם לאחוזי הרווח שנשמרים בין הסמל והגבול השמאלי של השדה ובין הסמל והגבול התחתון של השדה. הגדרת ברירת המחדל (50, 50) ממקמת את הסמל במרכז השדה. ניתן ללחוץ על Reset בכל עת כדי לחזור לקביעת המיקום המהווה ברירת מחדל.

  8. לחץ על OK ולאחר מכן על Close.

  9. כדי להציג תצוגה מקדימה של הלחצן ולבדוק אותו, לחץ על Preview בקצה הימני של סרגל הכלים. לאחר שתסיים, תוכל ללחוץ על Edit כדי לחזור לכלי Prepare Form, או ללחוץ על סמל הצלב בקצה הימני של סרגל הכלים כדי לסגור את הכלי.

הסתרת לחצן של Acrobat, פרט למצב הצבעה על הלחצן

במקרים מסוימים, ייתכן שתרצה שאזור הלחצן לא יהיה גלוי, עד שמזיזים אליו את המצביע. באמצעות הצגה והסתרה של לחצן לחלופין, ניתן ליצור אפקטים חזותיים מעניינים במסמך. לדוגמה, כשמזיזים את המצביע לעיר במפה, ניתן להציג מפה מפורטת של העיר, והמפה המפורטת יכולה להיעלם כשמזיזים את המצביע מהעיר.

הצגה והסתרה של סמלים
הצגה והסתרה של סמלים

A. המצביע אינו נמצא על לחצן B. המצביע נכנס לאזור הלחצן C. המצביע יוצא מאזור הלחצן 
  1. אם אינך במצב עריכת טופס, בחר Tools ‏> Prepare Form.

  2. באמצעות הכלי לחצן , גררו לאזור הרצוי לתצוגת הלחצן הנפתח. לדוגמה, אם מסמך PDF כולל מפה של צרפת, גררו לאזור שברצונך לפתוח בו מפה מפורטת של פריס.

  3. לחץ פעמיים על הלחצן ולאחר מכן לחץ על הכרטיסייה Options ובחר Icon Only מהתפריט Layout.

  4. בחר באפשרות Push מהתפריט Behavior, ולאחר מכן בחר באפשרות Rollover מהרשימה State.

  5. לחץ על Choose Icon ולאחר מכן לחץ על Browse. בחר בסוג הקובץ מהתפריט הנפתח File Of Type, נווט למיקום של קובץ התמונה ולחץ פעמיים על הקובץ. בדוגמה זו, תבחר מפה של פריס. לחץ על OK כדי לקבל את התצוגה המקדימה של התמונה כתמונת הלחצן.

  6. לחץ על הכרטיסייה Appearance. במידת הצורך, בטל את הסימון באפשרויות Border Color ו- Fill Color ולחץ על Close.

  7. אם אתה נמצא במצב עריכה, לחץ על Preview. שדה התמונה שהגדרת מופיע כשהמצביע נכנס לאזור הלחצן, ונעלם כשהמצביע יוצא מאזור הלחצן.

    הערה:

    אם ברצונך שהתמונה תהיה גדולה יותר מאזור הלחצן במצב הצבעה, או אם ברצונך שהתמונה תופיע במיקום שונה ממיקום הלחצן הנפתח, השתמש בפעולה Show/Hide A Field. ראשית, יש לציין סמל ללחצן שיוצג ויוסתר. לאחר מכן יש ליצור לחצן שני שיפעל כנקודה חמה כשהמצביע יזוז אליו. אל תשייך סמל ללחצן השני. במקום זאת, השתמש בכרטיסייה Actions כדי להציג את הלחצן הראשון כשמצביע העכבר נכנס לאזור הלחצן השני, וכדי להסתיר את הלחצן הראשון כשמצביע העכבר יוצא מאזור זה

  8. לאחר שתסיים, תוכל ללחוץ על Edit כדי לחזור לכלי Prepare Form, או ללחוץ על סמל הצלב בקצה הימני של סרגל הכלים כדי לסגור את הכלי.

עבודה זו בוצעה ברישיון של Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  הודעות המתפרסמות ב- Twitter™‎ ו- Facebook אינן מכוסות בתנאי Creative Commons.

הצהרות משפטיות   |   מדיניות פרטיות מקוונת