Дізнайтеся, як можна підвищити швидкість і ефективність Illustrator у macOS.

Швидкодія та ефективність Adobe Illustrator залежить від декількох факторів: наприклад, від налаштувань операційної системи та апаратного забезпечення, робочих процесів, обраних опцій. Якщо ви помітили, що Illustrator працює повільніше, ніж завжди, можна спробувати застосувати деякі прийоми для оптимізації продуктивності, причому не тільки для Illustrator, але також і інших додатків.

Підвищення продуктивності більш помітно при роботі з файлами великих об'ємів.

До початку роботи

До виконання вказаних нижче дій переконайтеся, що у вас установлена остання версія Illustrator або всі оновлення версії, що використовується. В оновленнях ПЗ часто усунені проблеми, пов'язані з продуктивністю.

Якщо ви використовуєте Illustrator CC, то можете оновити Illustrator, використовуючи настільний додаток Creative Cloud.

Оптимізація macOS

При налаштуванні операційної системи з метою забезпечення її ефективності збільшується об'єм пам'яті, доступної для додатків. В результаті забезпечується стабільність роботи. Спробуйте ці методи для оптимізації macOS і підвищення продуктивності Illustrator.

Управління шрифтами

Кожний шрифт, що використовується, збільшує об'єм оперативної пам'яті, що використовується macOS. Встановіть тільки ті шрифти, які вам необхідні, щоб підвищити швидкодію системи та продуктивність додатків, які використовують шрифти. Використовуйте спеціальну утиліту для управління багатьма шрифтами.

Використовуйте драйвер принтера PostScript

Драйвери принтера, що не є принтером PostScript, можуть конфліктувати з Illustrator. Тому Adobe рекомендує налаштувати принтер PostScript як принтер за замовчуванням у macOS.

Крок 1. Налаштуйте принтер PostScript як принтер за замовчуванням

Примітка.

Для завершення процедури переконайтеся, що принтер PostScript підключений до комп'ютера напряму чи через мережу.

  1. У меню Apple виберіть System Preferences (установки системи), а потім клацніть Printers & Scanners (принтери та сканери).

  2. Якщо принтер PostScript не наведений у списку, клацніть +, перейдіть до принтера PostScript і клацніть Add (додати).

  3. Виберіть принтер PostScript у спливаючому меню Default (принтер за замовчуванням).

Крок 2. Налаштуйте в Illustrator друк на принтер, що не є принтером за замовчуванням

  1. Відкрийте будь-який документ в Illustrator, потім оберіть File (файл) > Print (друк).

  2. У діалоговому вікні Print (друк) оберіть Adobe PostScript File (файл Adobe PostScript) або ім'я принтера в меню Printer (принтер).

  3. Натисніть кнопку Save (Зберегти).

Оптимізація налаштувань апаратного забезпечення

Апаратне забезпечення, що використовується, впливає на продуктивність Illustrator: чим швидше працює процесор або жорсткий диск, тим вище швидкість обробки інформації в Illustrator. Інші вдосконалення апаратного забезпечення, такі як встановлення додаткового об'єму оперативної пам'яті, використання багатопроцесорної системи або оптимізація чи дефрагментація дисків, також можуть підвищити продуктивність. Нижче наводяться деякі кроки, які можна виконати для оптимізації налаштувань апаратного забезпечення та підвищення продуктивності Illustrator.

Використання більш швидкого процесора

Швидкість центрального процесору комп'ютера (CPU) впливає на швидкість Illustrator. Оскільки Illustrator оперує великими об'ємами даних та виконує багато обчислень, його швидкодія залежить від швидкості процесора. Спробуйте використовувати комп'ютер з більш швидким процесором.

Встановлення додаткового об'єму оперативної пам'яті

Якщо Illustrator має недостатній об'єм оперативної пам'яті, то для обробки інформації він використовує місце на жорсткому диску (наприклад, на тимчасовому диску). Illustrator працює з найбільшою швидкістю, якщо може обробити інформацію в пам'яті без використання жорсткого диска.

Оптимізація дискового простору

Нижче наводяться декілька способів оптимізації дискового простору:

  • Перевірте жорсткий диск на наявність помилок або виконайте дефрагментацію файлів за допомогою утиліти стороннього розробника для перевірки диска (наприклад, Norton Utilities). Якщо ви працюєте в macOS, то диск не потребує дефрагментації, але може знадобитися відновлення за допомогою утиліти стороннього розробника.
  • Збережіть файли на диски з більш високою швидкість доступу. Наприклад, використовуйте внутрішній жорсткий диск, а не мережевий сервер (мережевий диск) або зовнішній диск.

Ефективне використання можливостей Illustrator

Спосіб роботи в Illustrator, особливо по відношенню до перегляду своєї графіки, може вплинути на продуктивність Illustrator. Нижче наводяться деякі способи використання можливостей програми, що дозволяють забезпечити стабільну роботу Illustrator.

Робота в режимі Outline view (показ контуру)

В режимі Outline View (показ контуру) приховані атрибути фарби, а графіка відображається як незаповнені контури. Робота в режимі Outline View дозволяє прискорити відображення складної графіки, такої як об'єкти, що містять градієнти або комбінації об'єктів. Режим Outline View (показ контуру) також дозволяє забезпечити редагування об'єктів, прихованих за іншими заповненими об'єктами.

Для відображення документа Illustrator у режимі Outline View (показ контуру) оберіть View (вид) > Outline (контур).

Створення видів користувача

Можна створити види користувача для свого документа. Види користувача дозволяють швидко змінити налаштування режиму перегляду, збільшення зображення, прокрутки та шарів.

Щоб створити вид користувача документа Illustrator, налаштуйте атрибути перегляду, які ви бажаєте зберегти. Потім оберіть View (вид) > New View (новий вид) і введіть ім'я в діалоговому вікні New View (новий вид). Користувацьке подання відобразиться в меню View (вид).

Змініть налаштування растрових ефектів

Можете змінити дозвіл растрових ефектів, щоб оптимізувати продуктивність Illustrator.

Щоб змінити дозвіл растрових ефектів, оберіть Effect (ефект) > Document Raster Effects Settings (налаштування растрових ефектів документа), оберіть один із наведених нижче пунктів розкривного списку Resolution (дозвіл) .

  • При редагуванні файлів клацніть Screen (екран). Illustrator використовує дозвіл 72 пікселя на дюйм для растрових ефектів, збільшуючи швидкість відображення.
  • Якщо ви друкуєте файли, клацніть High (високий). Illustrator використовує дозвіл 300 пікселів на дюйм для растрових ефектів, знижуючи швидкість друку, але підвищуючи якість друку.

Потім натисніть кнопку «OK».

Приховування шарів та видалення ескізів

Illustrator перемальовує екран швидше, якщо приховати шари, які містять складну графіку або растрові зображення з високим дозволом.

Щоб приховати шар, клацніть значок "око" зліва від найменування шару, очистіть Show Layer (відобразити шар) , а потім клацніть OK. Щоб приховати все, крім обраного шару, утримуючи клавішу Alt, клацніть значок "око".

В панелі "Шари" можуть відображуватися ескізи для шарів верхнього рівня, вкладені шари, групи та об'єкти. Для скорочення кількості ескізів з метою більш швидкого оновлення екрану в Illustrator оберіть Panel Options (налаштування панелі) в меню панелі Layers (шари), потім скоротіть кількість ескізів.

  • Щоб видалити всі ескізи з панелі Layers (шари), оберіть Small (маленький) в розділі Row Size (розмір рядку), а потім клацніть OK.
  • Щоб видалити значки для особливих елементів в панелі Layers (шари), відмініть вибір параметру Layers (шари), Groups (групи) або Objects (об'єкти) в розділі Thumbnails (ескізи) та клацніть OK.

Відключіть попередній перегляд друку Overprint Preview

Попередній перегляд друку Overprint Preview надає «перегляд фарб», що являє собою наближення до того, як прозорість, накладання та переходи будуть виглядати при виведенні з кольороподілом. Для підвищення продуктивності уникайте використання попереднього перегляду Overprint Preview.

Щоб включити або відключити попередній перегляд Overprint Preview, оберіть View (вид) > Overprint Preview (попередній перегляд друку).

Видалення монтажних областей, що не використовуються

Монтажні області – це області, в яких можуть знаходитися ілюстрації для друку. Для оптимізації продуктивності розгляньте варіант видалення монтажних областей, що не використовуються або непотрібні.

Щоб керувати монтажними областями, оберіть Window (вікно) > Artboards (монтажні області). Потім оберіть монтажну область, яку ви бажаєте видалити, та клацніть Delete (видалити).

Зміни налаштувань для призначеного робочого диска

Коли ви працюєте з убудованими растровими зображеннями, а ваша система не має достатньої оперативної пам'яті, Illustrator використовує місце на жорсткому диску в якості тимчасового диску. Для доступу до інформації на жорсткому диску потрібно більше часу, ніж до інформації з пам'яті. Тому використання частини жорсткого диску в якості віртуальної пам'яті може знизити продуктивність. Якщо потрібно більше пам'яті для роботи в Illustrator, спробуйте додати більший об'єм оперативної пам'яті.

За замовчанням Illustrator використовує системний диск як основний тимчасовий диск. Змініть налаштування, задавши в якості основного тимчасового диска Illustrator найбільш швидкий жорсткий диск.

Щоб змінити налаштування тимчасового диску, виконайте наступні дії:

  1. Виберіть Illustrator > Preferences (особисті налаштування) > Plug-ins & Scratch Disk (плагіни та тимчасовий диск).

  2. Виберіть жорсткий диск у спливаючому меню Primary (основний). Якщо ви збираєтеся працювати з великими зображеннями та маєте більше одного жорсткого диску, оберіть інший диск у спливаючому меню Secondary (другорядний).
  3. Клацніть OK та перезапустіть Illustrator.

Видалення елементів, що не використовуються, з профілів документа

Профілі документа Illustrator містять шаблони за замовчанням, градієнти, графічні дизайни, кольори, бібліотеки кольорів та пензлі, які відображаються в нових документах Illustrator. Ці файли також визначають рівень масштабування, розмір вікна, особисті налаштування перегляду, а також положення прокрутки для нових документів. Мінімізуйте розмір файлу для нових документів, видаливши непотрібні палітри та пензлі з профілів нового документу Illustrator.

Для отримання інструкцій зі створення профілів користувача документа, див.Startup Profiles (профілі для початку роботи): відмінний інструмент для налаштування нових документів.

Видаліть з шаблонів елементи, які не використовуються

Шаблони дають змогу створювати документи зі спільними загальними параметрами й елементами дизайну. Ви можете мінімізувати розмір файлу для нових документів, видаливши непотрібні палітри, символи, стилі графіки та пензлі з шаблонів.

Для отримання інструкцій зі створення шаблонів файлів див. Файли та шаблони.

Активація зв'язків із зображеннями

Вбудовані растрові зображення (наприклад, TIFF, BMP або Photoshop EPS) можуть значно збільшити розмір документу Illustrator, негативно позначаючись на швидкодії. Щоб покращити продуктивність, активуйте опцію Link (зв'язок) при розміщенні растрового зображення. При використанні цієї опції розміщуване зображення посилається на жорсткий диск.

  • Перейдіть у меню File (файл) > Place (розмістити). В діалоговому вікні Place оберіть Link (зв'язок).

Якщо для бюро переддрукової підготовки потрібне вбудоване зображення, то зберігайте копії файлів. Виберіть Include Linked Files (увімкнути пов'язані файли) в діалоговому вікні Illustrator Native Format Options (опції власних форматів Illustrator) або EPS Format Options (опції формату EPS).

Попередній перегляд з невеликим дозволом EPS

Якщо документ містить пов'язані зображення EPS, які мають можливість попереднього перегляду з високим дозволом, Illustrator перемальовує екран повільніше по мірі редагування графіки. Щоб Illustrator зміг перемалювати екран швидше, використовуйте попередній перегляд з низьким дозволом EPS. Виконайте такі дії:

  1. Виберіть Illustrator > Preferences (особисті налаштування) > File Handling & Clipboard (обробка файлів і буфер обміну).

  2. Виберіть Use Low Resolution Proxy For Linked EPS (використовувати проксі з низьким дозволом для пов'язаних файлів EPS) та клацніть OK.

Відключення параметру "Показати взаємодію формату DCS і &прозорості"

Діалогове вікно Links Panel Options (налаштування панелі зв'язків) включає опцію Show DCS Transparency Interactions (відобразити взаємодію прозорості в форматі DCS). Якщо ця опція вибрана, панель Links (зв'язки) відображає жовтий значок, щоб ідентифікувати пов'язану графіку DCS EPS, що є прозорою або такою, що перекриває прозорі об'єкти. Оскільки через цю опцію Illustrator повинен регулярно визначати, чи є взаємодія пов'язаних файлів EPS з прозорістю, це може привести до зниження продуктивності.

Щоб відключити опцію Show Transparency Interactions (відображення взаємодії прозорості), виконайте такі дії:

  1. Оберіть Window (вікно) > Links (зв'язки). У меню панелі Links (зв'язки) виберіть Panel Options (опції панелі).

  2. Скасуйте вибір опції Show DCS Transparency Interactions (відобразити взаємодію прозорості) та клацніть OK.

Приховування панелі «Навігатор»

Панель «Навігатор» відображає вид ескізів вашої поточної графіки для зручної навігації. Час обробки, потрібний для оновлення ескізів при кожній зміні документу, залежить від складності графіки. Щоб покращити швидкість перемалювання екрану та підвищити швидкодію для складного документу, приховайте панель «Навігатор».

  • В меню "Вікно" скасуйте вибір параметра «Навігатор».

Ви можете налаштувати види користувачів, щоб здійснювалось ефективніше масштабування певних частин документа.

Відключення згладжування графіки

Опція Anti-alias Artwork (згладжування графіки) дозволяє згладити текст і графіку шляхом змішування кольорів пікселей по краях об'єкта з кольором сусідніх пікселей. Проте цей процес може призвести до повільного перемалювання екрану. Щоб відключити цю опцію, виконайте наступне:

  1. Виберіть Illustrator > Preferences (особисті налаштування) > General (загальні).

  2. Очистіть Anti-aliased Artwork (згладжування графіків) і клацніть OK.

Застосування команди Simplify (спростити)

Команда Simplify (спростити) знижує кількість вузлових точок в контурі і формах контуру, зменшуючи розмір файлу та підвищуючи продуктивність. Щоб застосувати команду Simplify (спростити), виберіть потрібний контур чи об'єкт, а потім клацніть Object (об'єкт) > Path (контур) > Simplify (спростити).

Для отримання додаткових відомостей про команду Simplify (спростити) див. розділ про редагування контуру.

Відключення Smart Guides (Швидкі напрямні)

Функція Smart Guides (Швидкі напрямні) дозволяє створювати, вирівнювати, редагувати та перетворювати об'єкти Illustrator в прив'язанні до інших об'єктів. Якщо ваша графіка містить багато об'єктів, для Illustrator потрібно більше часу, щоб відобразити Smart Guides (Швидкі напрямні).

  • Щоб відключити Smart Guides (Швидкі напрямні), клацніть меню View (Перегляд) та скасуйте вибір Smart Guides (Швидкі напрямні).

Дізнатися більше про Smart Guides (Швидкі напрямні).

Цей документ захищено ліцензією Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Публікації Twitter™ і Facebook не підпадають під умови ліцензії Creative Commons.

Юридична інформація   |   Політика мережевої конфіденційності