Criar uma camada de câmera e alterar as configurações da câmera

É possível exibir as camadas 3D a partir de qualquer ângulo e distância usando camadas de câmera. Assim como é mais fácil no mundo real mover câmeras ao longo e em torno de uma cena do que mover e girar a cena em si, geralmente é mais fácil obter exibições diferentes de uma composição configurando uma camada de câmera e movendo-a em torno de uma composição.

Você pode modificar e animar as configurações da câmera para configurar a câmera para corresponder à câmera real e às configurações usadas para fazer a gravação com a qual você está compondo. Também é possível usar configurações da câmera para adicionar comportamentos idênticos ao da câmera – desde desfoque de profundidade de campo a deslocamentos e disparos – para efeitos e animações sintéticos.

As câmeras afetam apenas camadas 3D e as camadas 2D com um efeito com um atributo Câmera de composição. Com efeitos que possuem um atributo Câmera de composição, você pode usar a câmera ou as luzes para exibir ou clarear um efeito de vários ângulos e simular efeitos 3D mais sofisticados.

É possível optar por exibir uma composição com a câmera ativa ou por uma câmera personalizada nomeada. A câmera ativa é a câmera na extremidade superior do painel Linha de tempo atual, para a qual a opção Vídeo está selecionada. A exibição da câmera ativa é o ponto de exibição usado para criar o resultado final e aninhar composições. Se você não criou uma câmera personalizada, então a câmera ativa é a mesma à da exibição da composição padrão.

Todas as câmeras são listadas no menu Exibição 3D na parte inferior do painel Composição, onde você pode acessá-las a qualquer momento.

Geralmente é mais fácil ajustar a câmera usando uma das exibições 3D personalizadas. Não é possível, com certeza, ver a câmera para manipulá-la quando você estiver olhando através da câmera em si.

Exemplo de uma câmera
Exemplo de uma câmera

A. Ponto de interesse B. Quadro C. Câmera 

Criar uma camada de câmera

  1. Escolha Camada > Nova > Câmera ou pressione Ctrl+Alt+Shift+C (Windows) ou Command+Option+Shift+C (Mac OS).

    Observação:

    Por padrão, as novas camadas começam no início da duração da composição. Em vez disso, você pode escolher que as novas camadas tenham início no tempo atual desmarcando a preferência Criar camadas na hora de início da composição (Editar > Preferências > Geral (Windows) ou After Effects > Preferências > Geral (Mac OS)).

Alterar configurações da câmera

Você pode alterar as configurações da câmera a qualquer momento.

  1. Clique duas vezes na camada no painel Linha de tempo, ou selecione a camada e escolha Camada > Configurações da câmera.

Observação:

Por padrão, a opção Visualizar na caixa de diálogo Configurações da câmera está selecionada. Essa opção mostra as alterações na composição conforme você as faz na caixa de diálogo Configurações da câmera.

Configurações da câmera

Você pode alterar as configurações da câmera a qualquer momento clicando duas vezes na camada no painel Linha de tempo ou selecionando a camada e escolhendo Camada > Configurações da câmera.

Observação:

Selecione Visualizar na caixa de diálogo Configurações da câmera para mostrar os resultados no painel Composição conforme você modifica as configurações na caixa de diálogo.

Observação:

As três coisas que afetam a profundidade de campo são distância focal, abertura e distância do foco. A profundidade de campo rasa (pequena) é um resultado da distância focal longa, distância do foco curta e uma abertura maior (menor Parada F). Uma profundidade de campo mais rasa significa um resultado de um desfoque da profundidade de campo maior. O oposto de uma profundidade de campo rasa é o foco profundo, o que significa um desfoque de profundidade de campo menor porque está mais em foco.  

As propriedades da câmera em relação ao desfoque e a forma de objetivos incluem a forma da íris, rotação da íris, arredondamento da íris, a proporção da íris, margem de difração Iris, o ganho de realce, o limite de realce, e a saturação de realce.

Tipo

Câmera de um nó ou Câmera de dois nós. Uma câmera de um nó é orientada em torno de si, enquanto uma câmera de dois nós tem um ponto de interesse e é orientada ao redor desse ponto. Tornar uma câmera em uma câmera de dois nós equivale a definir a opção de orientação automática de uma câmera (Camada > Transformar > Orientação automática) para Orientar ao ponto de interesse. (Consulte Opções de Orientação automática.)

Nome

O nome da câmera. Por padrão, a Câmera 1 é o nome da primeira câmera criada em uma composição e todas as câmeras subsequentes são numeradas em ordem crescente. Escolha nomes diferentes para várias câmeras para que seja mais fácil distingui-las.

Predefinição

O tipo de configurações da câmera que você deseja usar. As predefinições são nomeadas de acordo com as distâncias focais. Cada predefinição deverá representar o comportamento de uma câmera de 35 mm com uma lente de uma determinada distância focal. Consequentemente, a predefinição também define os valores Ângulo de visão, Zoom, Distância do foco, Distância focal e Abertura. A predefinição padrão é 50 mm. Você também pode criar uma câmera personalizada especificando novos valores para qualquer das configurações.

Aplicar zoom

Distância da lente ao plano da imagem. Em outras palavras, uma camada que está afastada da distância de Zoom é exibida no tamanho total, uma camada que está afastada duas vezes da distância de Zoom é exibida com metade da altura e largura, e assim por diante.

Ângulo de visão

A largura de cena capturada na imagem. Os valores Distância focal, Tamanho do filme e Zoom determinam o ângulo de visão. Um ângulo de visão mais amplo cria o mesmo resultado de uma lente com grande abertura angular.

Profundidade de campo

Aplica variáveis personalizadas às configurações Distância do foco, Abertura, Parada F e Nível de desfoque. Usando essas variáveis, é possível manipular a profundidade de campo para criar efeitos de foco de câmera mais realistas. (A profundidade de campo é o intervalo de distância em que a imagem está em foco. As imagens fora do intervalo de distância são desfocadas.)

Distância do foco

A distância da câmera ao plano que está em foco perfeito.

Observação:

Para bloquear o plano focal no ponto de interesse da câmera para que o ponto de interesse esteja em foco, adicione esta expressão à propriedade Distância focal: length(position, pointOfInterest)

Bloquear para zoom

Faz com que o valor Distância do foco corresponda ao valor Zoom.

Observação:

Se você alterar as configurações das opções Zoom ou Distância do foco no painel Linha de tempo, o valor Distância do foco será desbloqueado a partir do valor Zoom. Se for necessário alterar valores e desejar que os valores continuem bloqueados, então use a caixa de diálogo Configurações da câmera em vez do painel Linha de tempo. Alternativamente, é possível adicionar uma expressão à propriedade Distância do foco no painel Linha de tempo: selecione a propriedade Distância do foco, e escolha Animação > Adicionar expressão, e arraste o ícone de expressão para a propriedade Zoom. (Consulte Noções básicas de expressões.)

Abertura

O tamanho da abertura da lente. A configuração de abertura também afeta a profundidade de campo – ao aumentar a abertura aumenta o desfoque da profundidade de campo. Quando você modifica a Abertura, os valores Parada F mudam em conformidade.

Observação:

Em uma câmera real, aumentar a abertura também permite mais luz, o que afeta a exposição. Como a maioria dos aplicativos de composição e animação 3D, o After Effects ignora esse resultado da mudança nos valores de abertura

Parada F

Representa a taxa da distância focal para a abertura. A maioria parte das câmeras especificam o tamanho da abertura usando a medição de parada F; assim, muitos fotógrafos preferem definir o tamanho de abertura em unidades de parada f. Quando você modifica a parada F, a abertura muda em conformidade.

Nível de desfoque

A quantidade de desfoque do campo de profundidade em uma imagem. Uma configuração de 100% cria um desfoque natural conforme ditado pelas configurações da câmera. Valores menores reduzem o desfoque.

Tamanho do filme

O tamanho da área filme exposta, que está diretamente relacionado com o tamanho da composição. Quando você altera o Tamanho do filme, o valor de Zoom muda para corresponder à perspectiva de uma câmera real.

Distância focal

Distância do plano de filme à lente da câmera. No After Effects, a posição da câmera representa o centro da lente. Quando você modifica a Distância focal, o valor de Zoom muda para corresponder à perspectiva de uma câmera real. Além disso, os valores Predefinição, Ângulo de visão e Abertura mudam consequentemente.

Unidades

As unidades de medida em que os valores de configuração de câmera são expressos.

Medir tamanho do filme

As dimensões usadas para descrever o tamanho do filme.

Observação:

Para obter melhores resultados, trabalhe em 32 bpc com Linearizar espaço de trabalho selecionado nas configurações do projeto.

Comandos da câmera

O After Effects tem comandos de câmera que podem ser usados separadamente ou com a função Criar equipamento 3D estéreo. Para usar os comandos da câmera, selecione uma camada de câmera e escolha Camada > Câmera.

Vincular distância do foco até o ponto de interesse

Cria uma expressão na propriedade de distância do foco da camada selecionada da câmera, definindo o valor da propriedade para a distância entre a câmera e o ponto de interesse.

Vincular distância do foco até a camada

Cria uma expressão na propriedade de distância do foco da camada selecionada da câmera para a distância entre a posição da câmera e a outra camada. Este método permite que o foco siga a outra camada automaticamente.

Definir distância do foco até a camada

Define o valor da propriedade Distância do foco no tempo atual para a distância no tempo atual entre a câmera e a camada selecionada.

Recursos online sobre câmeras

Para assistir a um tutorial em vídeo que mostra como criar e modificar uma câmera e usar as ferramentas Câmera, consulte o site da Adobe.

Dale Bradshaw oferece um script e projeto de amostra para automatizar a ajustagem de uma câmera no site da Creative Workflow Hacks.

Mark Christiansen fornece dicas e técnicas detalhadas para trabalhar com câmeras no capítulo “Virtual Cinematography in After Effects” em After Effects Studio Techniques no site da Peachpit Press. Este capítulo inclui informações sobre combinação de distorção de lentes, execução de movimentos da câmera, execução de projeção da câmera (mapeamento da câmera), uso do foco de rack, criação do desfoque de boke, uso de granulação e seleção de uma taxa de quadros para combinar com seu conto de histórias.

Trish e Chris Meyer oferecem um tutorial para o uso de camadas 3D, luzes e câmeras em um trecho em PDF de seu livro After Effects Apprentice no site da Focal Press.

Andrew Kramer fornece um tutorial em vídeo de duas partes em seu site Video Copilot que demonstra o mapeamento de câmera e projeção da câmera básicos. O tutorial mostra como projetar uma imagem em camadas 3D com luzes e propriedades de transmissão de luz.

Criar uma luz e alterar configurações de luz

Uma camada de luz pode afetar as cores das camadas 3D em que brilha, dependendo das configurações da luz e as propriedades Opções de material das camadas 3D. Cada luz, por padrão, aponta para seu ponto de interesse.

As luzes podem ser usadas para iluminar camadas 3D e projetar sombras. Você pode usar luzes para atender as condições de iluminação da cena em que você está compondo ou para criar mais resultados visuais interessantes. Por exemplo, você pode usar as camadas de luz para criar a aparência de fluxo de transmissão de luz através de uma camada de vídeo como se fosse feito de vitral.

Você pode animar todas as configurações, exceto para o tipo de luz e a propriedade Projeta sombras.

Tipos de Luz: Spot (superior esquerda); Ponto (superior direita); Paralelo (inferior esquerda); Ambiente (inferior direita)
Tipos de Luz: Spot (superior esquerda); Ponto (superior direita); Paralelo (inferior esquerda); Ambiente (inferior direita)

A. Ponto de interesse B. Ícone de luz 

Você pode especificar quais camadas 3D uma luz afeta designando a luz como uma camada de ajuste: coloque a luz no painel Linha de Tempo acima das camadas que deseja que tenha brilho. As camadas que estão acima da camada de ajuste da luz na ordem de empilhamento de camadas no painel Linha de tempo não recebem a luz, independentemente das posições das camadas no painel Composição.

Criar uma luz

  1. Escolha Camada > Nova > Luz ou pressione Ctrl+Alt+Shift+L (Windows) ou Command+Option+Shift+L (Mac OS).

    A luz que você cria inclui o nome do tipo de luz. Por exemplo, se você adicionar um holofote, será chamado “Holofote 1.”

    Se você alterar o tipo de luz, o nome do tipo de luz mudará automaticamente. O nome da luz é alterado se o não for modificado e isso só ocorre quando o tipo de luz não for alterado no painel Linha de tempo. Por exemplo, se você altera a “Holofote 1” para uma luz pontual, o After Effects renomeia automaticamente a luz para “Luz pontual 1.”

    Observação:

    Por padrão, as novas camadas começam no início da duração da composição. Em vez disso, você pode escolher que as novas camadas tenham início no tempo atual desmarcando a preferência Criar camadas na hora de início da composição (Editar > Preferências > Geral (Windows) ou After Effects > Preferências > Geral (Mac OS)).

Alterar configurações de luz

  1. Clique duas vezes em uma camada de luz no painel Linha de tempo ou selecione a camada e escolha Camada > Configurações de luz.

    Observação:

    Selecione Visualizar na caixa de diálogo Configurações de luz para mostrar os resultados no painel Composição conforme você modifica as configurações na caixa de diálogo.

Configurações de luz

Tipo de luz

Paralelo emite luz direcional e sem restrição de uma origem distante infinita, aproximando a luz de uma fonte como o Sol. Spot emite luz de uma fonte que está restringida por um cone, como uma lanterna elétrica ou um projetor usado em produções de palco. Ponto emite luz unidirecional sem restrição, como os raios de uma lâmpada desencapada. Ambiente cria a luz que não tem fonte, mas contribui para o brilho geral de uma cena e não projeta sombras.

Observação:

Como a posição no espaço de uma luz Ambiente não afeta a sua influência sobre outras camadas, uma luz Ambiente não tem um ícone no painel Composição.

Intensidade

O brilho da luz. Valores negativos criam ausência de luz. A ausência de luz subtrai cor de uma camada. Por exemplo, se uma camada já está iluminada, criando uma luz direcional com valores negativos também apontando para essa camada escurece uma área na camada.

Cor

A cor da luz.

Ângulo do cone

O ângulo do cone que envolve a fonte da luz, que determina a largura do feixe a uma distância. Esse controle ficará ativo somente se Spot for selecionado para o Tipo de luz. O ângulo do cone de uma luz Spot será indicado pela forma do ícone de luz no painel Composição.

Observação:

No After Effects CS6 ou posterior, um cone da luz Spot selecionado pode ser estendido ao ponto de interesse.

Difusão de cone

A suavidade da borda de uma luz de spot. Esse controle ficará ativo somente se Spot for selecionado para o Tipo de luz.

Queda

O tipo de declínio por um paralelo, um ponto ou um ponto de luz. A queda descreve como a intensidade da luz é diminuída à distância.

Para obter detalhes, tutorias e recursos sobre queda de luz, consulte este artigo on site da Adobe.

Os tipos de queda incluem o seguinte:

Nenhum

A iluminação não diminui conforme a distância entre a camada e a luz aumenta.

Suave

Indica uma queda linear suave no raio de Início da queda e se estendendo ao comprimento especificado pela Distância de queda.

Quadrado inverso fixado

Indica uma queda fisicamente precisa no raio de Início da queda e diminuindo proporcionalmente ao quadrado inverso da distância.

Raio

Especifica o raio da queda de uma luz. Dentro dessa distância, a luz é constante. Fora dessa distância, ocorre queda de luz.

Distância de queda

Especifica a distância a que ocorre uma queda de luz.

Projeta sombras

Especifica se a fonte de luz faz com que uma camada projete uma sombra. A opção de material Aceita sombras deve estar Ativa para uma camada receber uma sombra; esta configuração é a padrão. A opção de material Projeta sombras deve estar ativa para uma camada projetar sombras; esta configuração não é padrão.

Observação:

Pressione Alt+Shift+C (Windows) ou Option+Shift+C (Mac OS) para alternar sombras projetadas para camadas selecionadas. Para visualizar as propriedades de Opções de material no painel Linha de tempo, pressione AA

Escuridão da sombra

Define a escuridão da sombra. Esse controle ficará ativo somente se a opção Sombras projetadas estiver selecionada.

Difusão de sombra

Define a suavidade de uma sombra com base na sua distância aparente da camada de sombreamento. Valores maiores criam sombras mais suaves. Este controle ficará ativo somente se a opção Projeta sombras estiver selecionada.

Recursos online sobre luzes

Eran Stern oferece um tutorial em vídeo no site da Creative COW que demonstra o uso de luzes como camadas de ajuste para controlar com precisão que camadas são afetadas por quais luzes.

Chris e Trish Meyer oferecem algumas dicas sobre sombras e luzes 3D em um artigo do site da ProVideo Coalition.

Trish e Chris Meyer oferecem um tutorial para o uso de camadas 3D, luzes e câmeras em um trecho em PDF de seu livro After Effects Apprentice no site da Focal Press.

Chris e Trish Meyer oferecem um tutorial no site da Artbeats que demonstra como usar luzes e camadas 3D para criar um vídeo em outras camadas, como em uma parede.

Ajustar uma exibição 3D ou mover uma câmera, luz ou ponto de interesse

As camadas de câmera e camadas de luz incluem uma propriedade Ponto de interesse, que especifica o ponto na composição na qual a câmera ou luz aponta. Por padrão, o ponto de interesse está no centro da composição. É possível mover o ponto de interesse a qualquer momento.

Uma câmera de um nó ignora o ponto de interesse. (Consulte Configurações da câmera.)

Para fazer uma luz ignorar seu ponto de interesse, selecione uma opção diferente de Orientar ao ponto de interesse nas opções Orientação automática da luz. (Consulte Opções de Orientação automática.)

Observação:

Como ocorre com todas as propriedades, é possível também modificar uma câmera ou propriedades da luz diretamente no painel Linha de tempo.

Mover uma câmera, luz ou ponto de interesse com as ferramentas Seleção e Rotação

  1. Selecione uma camada de luz ou câmera.
  2. Usando a ferramenta Seleção ou Rotação, siga um destes procedimentos:
    • Para mover a câmera ou luz e seu ponto de interesse, posicione o ponteiro sobre o eixo que você deseja ajustar e arraste.

    • Para mover a câmera ou a luz ao longo de um único eixo sem mover o ponto de interesse, com a tecla Ctrl pressionada (Windows) ou Command (Mac OS), arraste o eixo.

    • Para mover a câmera ou a luz livremente sem mover o ponto de interesse, arraste o ícone da câmera ou o ícone da luz.

    • Para mover o ponto de interesse, arraste o ícone de ponto de interesse .

Mover ou ajustar uma câmera ou exibição 3D de trabalho com as ferramentas Câmera

Você pode definir as propriedades Posição e Ponto de interesse de uma camada de câmera usando as ferramentas Câmera no painel Composição.

Você também pode usar as ferramentas Câmera para ajustar uma exibição 3D de trabalho, uma exibição 3D que não esteja associada a uma camada de câmera. Imagine as exibições 3D como sendo câmeras virtuais em que você pode exibir e visualizar uma composição. As exibições 3D de trabalho incluem as exibições personalizadas e exibições ortográficas fixas (Frente, Esquerda, Cima, Trás, Direita, Baixo). As visualizações 3D de trabalho são úteis para inserir e visualizar elementos em uma cena 3D. Se você usar uma ferramenta Câmera para ajustar uma exibição 3D de trabalho, nenhum valor da propriedade de camada será afetado.

Depois que você modificou uma exibição 3D, você poderá restaurá-la escolhendo Exibir > Redefinir exibição 3D.

Não é possível usar a ferramenta Câmera orbital em exibições ortográficas fixas.

Para obter informações sobre como selecionar e usar exibições 3D, consulte Escolher uma exibição 3D.

  1. No menu Exibição 3D na parte inferior do painel Composição, escolha a câmera ou a exibição 3D a ser ajustada.
  2. Ative uma ferramenta Câmera.

    Você pode ativar uma ferramenta Câmera selecionando no painel Ferramentas ou pressionando C para navegar entre as ferramentas Câmera. A maneira mais fácil para alternar entre as várias ferramentas de Câmera é selecionar a ferramenta Câmera unificada e usar os botões em um mouse de três botões.

    Câmera orbital

    Gira a exibição 3D ou câmera movendo em torno de um ponto de interesse. (Para ativar temporariamente a ferramenta Câmera orbital quando a ferramenta Câmera unificada está selecionada, mantenha o botão esquerdo do mouse pressionado.)

    Observação:

    Ao fazer Shift+arrastar com a ferramenta Câmera unificada selecionada, você ativa temporariamente a ferramenta Câmera orbital e restringe a rotação para um eixo.

    Rastrear câmera XY

    Ajusta a exibição 3D ou câmera na horizontal ou na vertical. (Para ativar temporariamente a ferramenta Rastrear câmera XY quando a ferramenta Câmera unificada está selecionada, mantenha pressionado o botão do meio do mouse.)

    Rastrear câmera Z

    Ajusta a exibição 3D ou câmera na linha até ao ponto de interesse. Se você estiver usando uma exibição ortográfica, essa ferramenta ajusta a escala da exibição. (Para ativar temporariamente a ferramenta Rastrear câmera Z quando a ferramenta Câmera unificada está selecionada, mantenha pressionado o botão direito do mouse.)

  3. Arraste no painel Composição. Você pode continuar a operação de arrastar para fora do painel depois que você tiver começado a arrastar no painel.

Depois que você modificou uma exibição 3D, você poderá restaurá-la escolhendo Exibir > Redefinir exibição 3D.

Mover ou ajustar uma câmera ou exibição 3D de trabalho para examinar camadas

Você também pode mover uma câmera ou ajustar uma exibição 3D para examinar camadas selecionadas ou todas elas. O After Effects altera o ponto de exibição e direção de exibição para incluir as camadas selecionadas.

  • Para ajustar uma exibição 3D ou mover uma câmera para examinar camadas selecionadas, escolha Exibir > Examinar camadas selecionadas.
  • Para ajustar uma exibição 3D ou mover uma câmera para examinar todas as camadas, escolha Exibir > Examinar todas as camadas.

Para atalhos do teclado para esses comandos, consulte Camadas 3D (atalhos do teclado).

Dicas e recursos online para mover e animar câmaras e luzes

Antes de mover uma câmera, escolha uma exibição diferente da Câmera ativa. Se você usar a exibição Câmera ativa, você está monitorando pela câmera, que torna mais difícil gerenciar.

Por padrão, o wireframe de uma câmera é visível somente quando a câmera está selecionada. Para mostrar sempre o wireframe da câmera, defina as opções de exibição para o painel Composição (Exibir > Opções de exibição). (Consulte Mostrar ou ocultar controles de camada no painel Composição.)

Ao trabalhar com uma câmera ou camada de luz, crie uma camada de objeto nulo e use uma expressão para vincular a propriedade Ponto de interesse da câmera ou luz à propriedade Posição da camada nula. Você pode depois animar a propriedade Ponto de interesse movendo o objeto nulo. Geralmente é mais fácil selecionar e visualizar um objeto nulo que selecionar e visualizar o ponto de interesse.

No After Effects, há um comando da câmera, “Criar órbita nula”. Isso cria uma relação de pai entre a camada de câmera selecionada da câmera e uma nova camada nula. A nova camada nula é renomeada, com base no nome da câmera adicionada com Órbita nula

Trish e Chris Meyer mostram como usar o comando da câmera Criar órbita nula neste tutorial em vídeo no Adobe TV.

Para assistir a um tutorial em vídeo que mostra como criar e modificar uma câmera e usar as ferramentas Câmera, consulte o site da Adobe.

Trish e Chris Meyer oferecem um tutorial para o uso de camadas 3D, luzes e câmeras em um trecho em PDF de seu livro After Effects Apprentice no site da Focal Press.

Mark Christiansen fornece dicas e técnicas detalhadas para trabalhar com câmeras no capítulo “Virtual Cinematography in After Effects” em After Effects Studio Techniques no site da Peachpit Press. O capítulo inclui informações sobre combinação de distorção de lentes, execução de movimentos da câmera, execução de projeção da câmera (mapeamento da câmera), uso do foco de rack, criação do desfoque de bokeh, uso de granulação e seleção de uma taxa de quadros para combinar com seu conto de histórias.

Rich Young oferece um conjunto de expressões no site da AE Portal que usa o método toWorld que liga uma câmera e luz a uma camada com o efeito Esfera do CC.

Andrew Devis da Creative Cow criou uma série de 3 tutoriais sobre Animar uma câmera:

Este vídeo do Video2brain demonstra o comando usado para criar uma órbita nula de câmera.

Propriedades Opções de material

As camadas 3D têm propriedades de Opções de material, que determinam como uma camada 3D interage com a luz e a sombra.

Projeta sombras

Especifica se uma camada projeta sombras em outras camadas. A direção e o ângulo das sombras são determinados pela direção e o ângulo de fontes de luz. Defina Projeta sombras para Somente se você desejar que a camada seja invisível, mas ainda projete uma sombra.

Observação:

Use a configuração Somente e uma configuração de Transmissão de luz não zero para projetar as cores de uma camada invisível para outra camada. Steve Holmes oferece um tutorial em vídeo no site da Artbeats no qual ele demonstra como usar camadas com Sombras projetadas definido para Somente para projetar sombras de formas específicas em uma cena 3D.

Transmissão de luz

A porcentagem de luz que brilha através de uma camada, projetando as cores da camada em outras camadas como uma sombra. 0% especifica que nenhuma luz passa pela camada, projetando uma sombra preta. 100% especifica que valores completos de cores da camada de projeção de sombra são projetados na camada que aceita a sombra.

Observação:

Use a transmissão de luz parcial para criar a aparência de luz passando por uma janela de vitral.

Aceita sombras

Especifica se a camada mostra as sombras projetadas nela por outras camadas. Há uma opção “Somente” em Aceita sombras para quando quiser renderizar somente uma sombra em uma camada.

Aceita luzes

Especifica se a luz que a alcança afeta a cor de uma camada. Essa configuração não afeta as sombras.

Ambiente

Refletividade ambiente (não direcional) da camada. 100% especifica a maioria de refletividade; 0% não especifica nenhuma refletividade ambiente.

Difusão

Refletividade difusa (omnidirecional) da camada. Aplicar refletividade difusa a uma camada é como drapejar uma planilha opaca, plástica sobre ela. A luz que cai sobre essa camada reflete igualmente em todas as direções. 100% especifica a maioria da refletividade; 0% não especifica nenhuma refletividade difusa.

Especular

Refletividade especular (direcional) da camada. A luz especular reflete da camada como se fosse de um espelho. 100% especifica a maioria da refletividade; 0% não especifica nenhuma refletividade especular.

Brilho

Determina o tamanho do realce especular. Esse valor é ativado somente se a configuração Especular for maior que zero. 100% especifica um reflexo com um realce especular pequeno. 0% especifica um reflexo com grande realce especular.

Metal

A contribuição de cor da camada para a cor do realce especular. 100% especifica que a cor do realce é a cor da camada. Por exemplo, com um valor Metal de 100%, uma imagem de um anel de ouro reflete a luz dourada. 0% especifica que a cor de realce especular é a cor da fonte de luz. Por exemplo, uma camada com um valor Metal de 0% em uma luz branca tem um realce branco.

Especificar resolução a usar para renderizar sombras

O plug-in de renderização 3D avançado é usado para renderizar composições que contêm camadas 3D de interseção. Para renderizar sombras, o plug-in usa mapas de sombra, que são imagens renderizadas do ponto de exibição de cada fonte de luz. Normalmente, a resolução de sombra é calculada automaticamente com base na resolução da composição e configurações de qualidade das camadas. Se a resolução normal não criar a qualidade desejada ou renderizar muito lentamente, você pode ajustar a resolução do mapa de sombra. Por exemplo, se as sombras estão desfocadas e a opção de material Difusão de sombra estiver definida como 0, aumente a resolução do mapa de sombra. Ou, se as sombras renderizarem muito lentamente, diminua a resolução do mapa de sombra.

Quando uma camada de projeção de sombra faz interseção com outra camada, às vezes uma pequena lacuna ocorre atrás da interseção que deveria ser sombreada. Para diminuir o tamanho da lacuna, aumente a resolução do mapa de sombra.

3D estereoscópico

Você pode usar o Adobe After Effects para criar vídeos estereoscópicos em 3D.

Para obter tutoriais, detalhes e recursos sobre o 3D estereoscópico, consulte este artigo no site da Adobe.

Para obter uma visão geral do fluxo de trabalho 3D estereoscópico no After Effects, consulte Análise do 3D estereoscópico no After Effects.

Mark Christiansen mostra a composição de gravações 3D estereoscópicas (usandoclipesgratuitos da Art Beats).

Equipamento da câmera 3D estereoscópica

O After Effects possui um comando de menu Criar equipamento 3D estéreo, permitindo que você transforme uma composição 3D em uma composição 3D estereoscópica. O Equipamento 3D estéreo cria todos os elementos para você, incluindo o efeito Óculos 3D.

Crie um equipamento de câmera 3D estereoscópica criando primeiro uma composição com elementos 3D nela. Uma composição que contenha itens como uma pré-composição recolhida 3D ou elementos 3D na composição em si funciona bem. Se você já tiver uma câmera em uso, você pode selecioná-la ao criar o equipamento de câmera 3D estereoscópica. Se nenhuma câmera estiver selecionada, então uma nova câmera (chamada Câmera mestre) é criada. Escolha Camada > Câmera > Criar equipamento 3D estéreo. O equipamento funciona somente com câmeras de dois nós.

O equipamento é produzido criando uma câmera mestre ou usando a câmera selecionada existente na composição. Há composições olho esquerdo [comparado com Olho esquerdo] e olho direito [comparado com Olho direito]. Cada composição tem uma câmera vinculada à câmera mestre, a composição original aninhada nelas e uma composição 3D estéreo de saída [comparada com 3D estéreo]. A composição 3D estéreo de saída aninha as composições de olho e contém uma camada chamada Controles 3D estéreo. Esta camada contém um efeito Controles 3D estéreo para controlar o equipamento e um efeito Óculos 3D que corresponde às composições de olho esquerdo e direito em uma imagem estéreo. (Consulte Efeito Óculos 3D.)

Observação:

O efeito Controles 3D estéreo é um efeito criado como parte do equipamento 3D estéreo e não reside no painel Efeitos e predefinições.

O efeito Controles 3D estéreo tem as seguintes configurações para a Separação da câmera e Convergência:

Configuração

Centro posiciona a câmera esquerda e direita em ambos os lados da câmera mestre. Herói à esquerda posiciona a câmera esquerda no mesmo ponto que a câmera mestre com a câmera direita à direita. Inversamente, Herói à direita posiciona a câmera direita na posição da câmera mestre com a câmera esquerda à esquerda.

Profundidade de cena estéreo

Controla a separação interaxial entre as câmeras como uma porcentagem da largura da composição. Desse modo, se a composição for redimensionada, o valor de separação é constante. Essa configuração começa baixa com um valor de 3% para manter o efeito sutil. Idealmente, esse valor não precisa aumentar mais de 14%-30% para gravações 3D razoáveis. No entanto, pode ser mais amplo dependendo do conteúdo da cena (objetos estão muito perto juntos) e do campo de exibição da câmera, por exemplo.

Observação:

a alteração desse valor afeta a profundidade do Stereo 3D ao entrar e sair da cena. A elevação muito alta de valores pode causar compressão ocular.  

Convergir câmeras

Quando desligadas, as câmeras permanecem paralelas à câmera mestre, mas deslocadas para ambos os lados. Quando ligadas, a posição permanece deslocada. Contudo, o Ponto de interesse das câmeras esquerda e direita junta-se ao local baseado nestas duas propriedades que se seguem.

Convergir para e Deslocamento de convergência Z

Determina a distância Z longe da câmera que a tela parece estar quando olhando através dos óculos 3D. Todo o restante no espaço Z parece ser inserido na tela, e tudo próximo parece saltar fora da tela. Ao trabalhar sem a caixa de verificação de convergência das câmaras ativada, e as câmaras estiverem paralelas, alterando a convergência de cena tem o mesmo efeito que alterar o deslocamento Z. Use o modo diferença para definir diferentes elementos na cena para selecionar o espaço nesse caso. (Consulte Efeito Óculos 3D.)

Introdução ao 3D estereoscópico

Se estiver trabalhando com 3D estereoscópico, você não precisa necessariamente de uma televisão 3D. Por exemplo, você pode usar os óculos 3D anaglifos (vermelho ciano) e exibir gravação estereoscópica 3D no painel Composição. Contudo, você pode usar uma televisão 3D para fazer edições em tempo real com uma televisão 3D e as lentes ativas do obturador, também. Para esse fluxo de trabalho, você precisa de algumas coisas antes de começar:

  • Um monitor ou televisão que suporte exibição 3D estereoscópica.
  • Óculos para exibição de televisão 3D estereoscópica.

Observação:

Para este fluxo de trabalho, use as lentes ativas do obturador que requerem um dispositivo emissor. Certifique-se de estar usando as lentes que o fabricante de televisão recomenda.

  • Gravação estereoscópica ou uma composição 3D.

Após obter esses itens, faça o seguinte:

  1. Conecte a TV 3D no computador com um cabo HDMI (DVI é aceitável se HDMI não estiver disponível).

  2. Crie uma composição 3D no After Effects. Certifique-se de que o tamanho de composição corresponde à resolução atual do monitor de saída.

  3. Crie um novo painel Composição para a composição 3D estéreo. Bloqueie a composição e arraste-a para o monitor de TV 3D.

  4. Verifique se o painel Composição está definido para 100%.

  5. Pressione Control + \ (barra invertida) duas vezes para definir a composição para tela cheia para a TV 3D. Defina as dimensões da composição e TV 3D para serem as mesmas.

  6. Alterne a exibição 3D no efeito Óculos 3D para um dos seguintes:

    • Par estéreo

    • Acima e abaixo

    • Entrelaçado

  7. Ative o modo 3D na TV 3D e faça corresponder o formato para o que foi definido na exibição 3D para o efeito Óculos 3D. (Par estéreo e Acima e abaixo são suportados na maioria das TVs 3D.)

  8. Coloque seus óculos 3D e edite a composição em 3D estereoscópico verdadeiro.

Dicas sobre 3D estereoscópico

  • Se você estiver trabalhando com uma gravação estereoscópica 3D no painel Composição e não tiver uma televisão 3D, você pode trabalhar com o formato de anaglifo. Os óculos 3D anaglifos vermelho ciano comuns funcionam melhor para este fluxo de trabalho estereoscópico 3D.

  • Aumente ou diminua a Profundidade de cena estéreo para alterar a profundidade da aparência do ambiente 3D.

  • Ative Convergir câmeras e altere o Deslocamento de convergência Z para mover objetos diferentes atrás de e em frente da tela. Os objetos mais próximos da câmera que o deslocamento Z aparecem na frente da tela, objetos mais afastados aparecem atrás da tela.

  • É possível fazer com que a profundidade de campo da composição corresponda à convergência da câmera estereoscópica seguindo um destes procedimentos:

    • Ao usar “Vincular distância do foco até o ponto de interesse” na câmera mestre e convergir câmeras para o equipamento, a profundidade de campo e convergência 3D estereoscópica correspondem.

    • Se desejar que a profundidade de campo mude com o tempo, você pode animar a distância do foco da câmera mestre. Em seguida, defina o ponto de convergência para convergir da “Posição da câmera” e defina uma expressão vinculando o Deslocamento de convergência Z à Distância do foco da câmera mestre

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online