Use este documento para aprender as Noções básicas de composição do After Effects

Sobre composições

Uma composição é a estrutura de um filme. Cada composição tem sua própria linha de tempo. Uma composição típica inclui várias camadas que representam componentes como itens de áudio e vídeo de gravação, gráficos animados de texto ou de vetor, imagens estáticas e luzes. Adicione um item de gravação a uma composição criando uma camada para a qual o item da gravação é a origem. Depois, você organiza as camadas no espaço e no tempo dentro de uma composição e compõe usando recursos de transparência para determinar quais partes de camadas subjacentes aparecem através das camadas empilhadas em cima delas. (Consulte Camadas e propriedades e Transparência e composição.)

Uma composição no After Effects é semelhante a um clipe de filme no Flash Professional ou uma sequência no Premiere Pro.

Você renderiza uma composição para criar os quadros de um filme de saída final, que é codificado e exportado para vários formatos. (Consulte Noções básicas de renderização e exportação.)

Os projetos simples podem incluir apenas uma composição; os projetos complexos podem incluir centenas de composições para organizar grandes quantidades de gravação ou vários efeitos.

Em alguns locais na interface do usuário do After Effects, a composição é abreviada como comp.

Cada composição tem uma entrada no painel Projeto. Clique duas vezes em uma entrada de composição no painel Projeto para abrir a composição em seu próprio painel Linha de tempo. Para selecionar uma composição no painel Projeto, clique com o botão direito do mouse (Windows) ou Ctrl+clique (Mac OS) no painel Composição ou painel Linha de tempo da composição e selecione Revelar composição no projeto no menu de contexto.

Use o painel Composição para visualizar uma composição e modificar manualmente o conteúdo. O painel Composição contém o quadro de composição e um espaço de trabalho fora do quadro que você pode usar para mover camadas para dentro e para fora do quadro da composição. As extensões externas das camadas (as partes que não estão no quadro de composição) são mostradas como contornos retangulares. Somente a área dentro do quadro de composição é renderizada para visualizações e saída final.

O quadro de composição no painel Composição no After Effects é semelhante ao Stage no Flash Professional.

Ao trabalhar com um projeto complexo, pode ser mais fácil organizar o projeto aninhando composições – colocando uma ou mais composições em outra composição. Você pode criar uma composição de qualquer número de camadas pré-compondo as mesmas. Após alterar algumas camadas da composição, você pode pré-compor essas camadas e depois pré-renderizar a pré-composição, substituindo-a por um filme renderizado. (Consulte Pré-composição, aninhamento e pré-renderização.)

Você pode navegar em uma hierarquia de composições aninhadas com o Navegador de composição e o Minifluxograma da composição. (Consulte Abrir e navegar em composições aninhadas.)

Use o painel Fluxograma para ver a estrutura de uma composição complexa ou rede de composições.

Botão Linha de tempo

 Clique nesse botão na parte inferior do painel Composição e ative o painel Linha de tempo para a composição atual.

Observação:

Pressione a tecla de barra invertida (\) para alternar a ativação entre o painel Composição e o painel Linha de tempo para a composição atual.

Botão Composição

 Clique nesse botão no canto superior direito do painel Linha de tempo e ative o painel Composição para a composição atual.

Botão Fluxograma

 Clique nesse botão na parte inferior do painel Composição e ative o painel Fluxograma para a composição atual.

Criar uma composição

Você pode alterar as configurações da composição a qualquer momento. No entanto, convém especificar configurações como a taxa de proporção do quadro e o tamanho do quadro quando criar a composição, tendo a saída final em mente. Como o After Effects baseia certos cálculos nas configurações de composição, alterá-los no final do seu fluxo pode afetar a saída final.

Observação:

É possível substituir algumas configurações de composição ao renderizar a saída final. Por exemplo, você pode utilizar tamanhos de quadro diferentes para o mesmo filme. Para obter mais informações, consulte Configurações de renderização e Módulos de saída e configurações de módulos de saída.

Ao criar uma composição sem alterar as configurações na caixa de diálogo Configurações da composição, a nova composição usa as configurações da última vez em que foram definidas.

Observação:

As novas composições não herdam as configurações anteriores da opção Preservar taxa de quadros quando aninhados ou na fila de renderização e Preservar resolução quando aninhados.

Jeff Almasol fornece um script em seu site redefinery que cria e salva um novo projeto para cada composição selecionada no projeto atual. Se uma pasta estiver selecionada no painel Projeto ao criar uma nova composição, a nova composição será colocada na pasta selecionada.

Criar uma composição e configurar manualmente as configurações da composição

  1. Escolha Composição > Nova composição ou pressione Ctrl+N (Windows) ou Command+N (Mac OS).

Criar uma composição a partir de um único item de gravação

  1. Arraste o item de gravação para o botão Criar uma nova composição na parte inferior do painel Projeto ou escolha Arquivo > Nova composição da seleção.

    As configurações de composição, incluindo tamanho do quadro (largura e altura) e taxa de proporção de pixels, são definidas automaticamente para corresponder às características do item de gravação.

Criar uma composição única a partir de vários itens de gravação

  1. Selecione itens de gravação no painel Projeto.
  2. Arraste os itens de gravação selecionados para o botão Criar uma nova composição na parte inferior do painel Projeto, ou escolha Arquivo > Nova composição da seleção.
  3. Selecione Composição única e outras configurações na caixa de diálogo Nova composição da seleção:

    Usar dimensões de

    Escolha o item de gravação do qual a nova composição obtém as configurações da composição, incluindo tamanho do quadro (largura e altura) e taxa de proporção de pixels.

    Duração estática

    A duração das imagens estáticas que estão sendo adicionadas.

    Adicionar à fila de renderização

    Adicione a nova composição à fila de renderização.

    Camadas de sequência, Sobreposição, Duração e Transição

    Organize as camadas em uma sequência, sobrepostas opcionalmente no tempo, ajuste a duração das transições e selecione um tipo de transição.

Criar várias composições a partir de vários itens de gravação

  1. Selecione itens de gravação no painel Projeto.
  2. Arraste os itens de gravação selecionados para o botão Criar uma nova composição na parte inferior do painel Projeto, ou escolha Arquivo > Nova composição da seleção.
  3. Selecione Várias composições e outras configurações na caixa de diálogo Nova composição da seleção:

    Duração estática

    A duração das composições criadas a partir de imagens estáticas.

    Adicionar à fila de renderização

    Adicione as novas composições à fila de renderização.

Observação:

Se você selecionar vários itens de gravação, a caixa de diálogo Nova composição da seleção será exibida. Você pode escolher se deseja criar uma única composição com todos os itens de gravação ou várias composições para cada item individual da gravação.

Seleção de composição
Seleção de composição

Duplicar uma composição

  1. Selecione a composição no painel Projeto.
  2. Escolha Editar > Duplicar ou pressione Ctrl+D (Windows) ou Command+D (Mac OS).

Painel Linha de tempo

Cada composição tem seu próprio painel Linha de tempo. Use o painel Linha de tempo para executar várias tarefas, como animar propriedades de camada, organizar camadas no tempo e configurar modos de mesclagem. As camadas na parte inferior da ordem de empilhamento da camada no painel Linha de tempo são renderizadas primeiro e – no caso de camadas de imagem 2D – aparecem mais atrás no painel Composição e no composto final.

Observação:

Para avançar entre os painéis Linha de tempo, pressione Alt+Shift+ponto (.) (Windows) ou Option+Shift+ponto (.) (Mac OS). Para se deslocar para trás nos painéis Linha de tempo, pressione Alt+Shift+vírgula (,) (Windows) ou Option+Shift+vírgula (,) (Mac OS).

O tempo atual de uma composição é exibida pelo indicador de tempo atual (CTI), a linha vermelha vertical do gráfico de tempo. O tempo atual de uma composição também aparece na exibição do tempo atual no canto superior esquerdo do painel Linha de tempo. Para obter mais informações sobre como mover o indicador do tempo atual, consulte Mover o indicador do tempo atual.

O lado esquerdo do painel Linha de Tempo consiste nas colunas dos controles para camadas. O lado direito do painel Linha de tempo, o gráfico de tempo, contém uma escala de tempo, marcadores, quadros-chave, expressões, barras de duração de camadas (no modo de barra de camada) e o Editor de gráfico (no modo Editor de gráfico).

Timeline Panel AE

Observação:

Pressione a tecla de barra invertida (\) para alternar a ativação entre o painel Composição e o painel Linha de tempo para a composição atual.

Configurações da composição

É possível inserir configurações de composição manualmente ou usar predefinições das configurações de composição para ajustar automaticamente o tamanho do quadro (largura e altura), a taxa de proporção de pixels e a taxa de quadros para diversos formatos de saída comuns. Você também pode criar e salvar suas próprias predefinições de configurações personalizadas de composição para uso futuro. As configurações Resolução, Timecode de início (ou Quadro inicial), Duração e Composição avançada não são salvas com as predefinições das configurações de composição.

Observação:

O limite de duração da composição é três horas. Você pode usar os itens de gravação mais de três horas, mas o tempo após três horas não será exibido corretamente. O tamanho máximo da composição serão é 30.000 x 30.000 pixels. Uma imagem 30.000x30.000 de 8 bpc exige cerca de 3,5 GB; seu tamanho máximo de composição pode ser menor, dependendo de seu sistema operacional e RAM disponível.

Trabalhar com configurações da composição

  • Para abrir a caixa de diálogo Configurações da composição para alterar as configurações da composição, siga um destes procedimentos:

    • Selecione uma composição no painel Projeto ou ative o painel Linha de tempo ou Composição de uma composição e escolha Composição > Configurações da composição ou pressione Ctrl+K (Windows) ou Command+K (Mac OS).

    • Clique com o botão direito (Windows) ou Ctrl+clique (Mac OS) em uma composição no painel Projeto ou no painel Composição (não em uma camada) e selecione Configurações da composição no menu de contexto.

  • Para salvar uma predefinição de configurações de composição personalizada, ajuste os valores de Largura, Altura, Taxa de proporção de pixels e Taxa de quadros na caixa de diálogo Configurações de composição e clique no botão Salvar .

  • Para excluir uma predefinição de configuração de composição, selecione-a no menu Predefinição na caixa de diálogo Configurações da composição e clique no botão Excluir .

  • Para restaurar as predefinições das configurações de composição padrão, pressione Alt (Windows) ou Option (Mac OS) e clique no botão Excluir , ou no botão Salvar na caixa de diálogo Configurações de composição.

Observação:

Não é possível mover predefinições das configurações de composição personalizadas de um sistema para outro, porque elas estão incorporadas ao arquivo de preferências.

  • Para dimensionar uma composição inteira, escolha Arquivo > Scripts > Scale Composition.jsx.

Observação:

Garanta que todas as camadas estejam desbloqueadas na composição selecionada ou o script falhará.

Jeff Almasol fornece um script em seu site de redefinery para definir a taxa de quadros e a duração da composição atual e todas as composições aninhadas dentro dela.

Christopher Green fornece um script (Selected_Comps_Changer.jsx) em seu site com o qual você pode alterar as configurações da composição das configurações selecionadas no painel Projeto.

Configurações da composição básicas

Timecode de início ou Quadro inicial

Timecode ou número do quadro atribuído ao primeiro quadro da composição. Este valor não afeta a renderização; especifica apenas quando iniciar a contagem.

Cor de fundo

Use a amostra de cor ou o conta-gotas para selecionar a cor de fundo de uma composição. (Consulte Selecionar uma cor ou editar um gradiente.)

Nota: quando você adiciona uma composição a outra (aninhamento), a cor de fundo da composição receptora fica preservada e o fundo da composição aninhada se torna transparente. Para preservar a cor de fundo da composição aninhada, crie uma camada de cor sólida para usar como uma camada de fundo na composição aninhada.

Para obter informações sobre as configurações da composição básicas específicas não listadas aqui, consulte as seções afins:

Configurações da composição avançadas

Âncora

Clique em um botão de seta para ancorar camadas em um canto ou uma borda da composição como redimensionada.

Preservar resolução quando aninhado e Preservar a taxa de quadros quando aninhado ou na fila de renderização

Para uma composição manter sua própria resolução ou taxa de quadros e não herdar as configurações da composição de conteúdo. Por exemplo, se você usou deliberadamente uma taxa de quadros baixa em uma composição para criar um resultado irregular, animado manualmente, deve-se preservar a taxa de quadros dessa composição quando estiver aninhada. Semelhantemente, os resultados de rotoscopia podem parecer errados quando convertidos em uma taxa de quadros ou com uma resolução diferente. Use esta configuração em vez do efeito Posterizar tempo, que é menos eficiente.

Configurações de Desfoque de movimento

  • Ângulo do obturador: o ângulo do obturador é medido em graus, simulando a exposição permitida por um obturador de rotação. O ângulo do obturador usa a taxa de quadros de gravação para determinar a exposição simulada, que afeta a quantidade de desfoque de movimento. Por exemplo, inserir 90° (25% de 360°) para uma gravação de 24 fps cria uma exposição efetiva de 1/96 de segundo (25% de 1/24 de segundo). Ao inserir 1º quase não aplica desfoque de movimento e ao inserir 720° aplica uma grande quantidade de desfoque.
  • Fase do obturador: A fase do obturador também é medida em graus. Define um deslocamento que determina quando o obturador abre em relação ao início de um quadro. Ajustar esse valor pode ajudar se um objeto com desfoque de movimento aplicado parece não acompanhar a posição do objeto sem desfoque de movimento aplicado.
  • Amostras por quadro: o número mínimo de amostras. Esse mínimo é o número de amostras usadas nos quadros para os quais o After Effects não pode determinar a taxa de amostragem adaptável com base em movimento da camada. Esta taxa de amostragem é usada para camadas 3D e camadas de forma.
  • Limite adaptável da amostra: o número máximo de amostras.

Para informações sobre as configurações da composição avançadas específicas não listadas aqui, consulte as seções relacionadas:

Configurações de renderização 3D

Você pode usar as opções na guia do renderizador 3D para escolher o renderizador 3D certo para a sua composição. É possível escolher um dos seguintes renderizadores no menu de Renderização:

  • 3D Clássico
  • CINEMA 4D
  • Rastreado de raio 3D

O recurso 3D do renderizador de composição CINEMA 4D e do renderizador Rastreado de raio 3D são quase idênticos à extrusão de texto 3D e camadas de forma e a dobradura de outras camadas 3D (sólidas, de gravação e assim por diante) em planos curvos. Entretanto, os resultados renderizados talvez não sejam iguais porque geram resultados usando renderizadores diferentes e oferecem suporte para conjuntos de recursos diferentes. Por exemplo, há diferenças nas opções de material da camada 3D e em outros comportamentos da camada. 

O renderizador CINEMA 4D renderiza camadas 3D, incluindo texto e formas de extrusão e planos 2D curvos, para facilitar o processo de animação de textos e logotipos 3D. O desempenho do renderizador CINEMA 4D é muito mais rápido do que o desempenho baseado apenas no CPU do renderizador rastreado de raio 3D.

Guia do renderizador 3D
Guia do renderizador 3D

Renderizador 3D clássico

O 3D clássico é renderizador tradicional e padrão. As camadas são posicionadas como planos no espaço 3D.

Opções do renderizador CINEMA 4D

Qualidade: o nível de Qualidade configurado no controle deslizante afeta os parâmetros que determinam como o Renderizador de composição CINEMA 4D projeta as camadas 3D. Você pode ver os parâmetros resultantes do renderizador nas caixas Opções, Suavização de borda e Reflexão. A configuração de Qualidade facilita a escolha de uma combinação equilibrada da velocidade de renderização e a qualidade de renderização 3D aceitável sem que você precise entender e modificar os diversos parâmetros de qualidade de renderização.

Os parâmetros a seguir são alterados quando você ajusta o controle deslizante de Qualidade:

  • Limite do raio: esse valor ajuda a otimizar o tempo de renderização. 
  • Profundidade do raio: A profundidade do raio determina quantos objetos transparentes (ou áreas transformadas em invisíveis por meio do canal alfa) podem ser penetrados pelo renderizador. 
  • Profundidade do reflexo: quando um raio é enviado para a cena, ele pode ser refletido pelas superfícies reflexivas. Quanto maior a Profundidade do reflexo, maior será o nível de acompanhamento dos raios na cena e nos resultados renderizados.
  • Profundidade da sombra: a profundidade da sombra se comporta de maneira semelhante à Profundidade do reflexo. A configuração de Profundidade da sombra define a profundidade da sombra com que os raios visíveis da sombra são calculados. 

Suavização de borda: a geometria é a configuração de suavização de borda padrão que suaviza todas as bordas do objeto (automaticamente com subpixels 16x16).

Reflexão: a amostra de camada é a configuração de Reflexão padrão que define a qualidade dos reflexos foscos.

Ao selecionar CINEMA 4D na caixa suspensa Renderizador, a coluna Ativado exibe as opções 3D que estão ativadas e a coluna Desativado exibe as opções 3D que não estão disponíveis.

Opções de renderização do CINEMA 4D
Opções de renderização do CINEMA 4D

Para escolher um nível de qualidade para sua renderização 3D, clique no botão Opções após selecionar CINEMA 4D como o renderizador e defina o nível de qualidade usando o controle deslizante Qualidade. Verifique os valores de alteração das propriedades Opções, Suavização de borda e Reflexão.

Configurações do controle deslizante de Qualidade
Configurações do controle deslizante de Qualidade

O After Effects instala um Renderizador padrão no seu computador. É possível alterar o Renderizador para uma versão de varejo completa do CINEMA 4D, caso esteja instalada.

O Editor padrão é a versão instalada mais recente do CINEMA 4D ou CINEMA 4D Lite.

Para selecionar outra instalação do CINEMA 4D, clique em Escolher instalação e selecione o caminho para o instalador nas caixas Renderização e Instalação.

Escolher a instalação do CINEMA 4D
Escolher a instalação do CINEMA 4D

Opções do renderizador com rastreado de raio 3D

Clique no botão Opções para abrir a caixa de diálogo Opções do renderizador com rastreado de raio 3D. Você também pode pressionar Ctrl (Windows) ou Command (Mac OS) e clicar no botão Indicador do renderizador atual no canto superior direito do painel Composição para abrir a caixa de diálogo.

Aqui é possível escolher:

  • Qualidade de rastreamento de raio: clique na configuração de qualidade de rastreamento de raio para alterá-la de acordo com o fluxo de trabalho.
    • Os valores mais altos de qualidade de rastreamento de raio reduzem o ruído, mas aumentam o tempo de renderização.
      A qualidade do rastreamento de raio controla o número de raios disparados por pixel (por exemplo, um valor de 4 dispara 16 ou 4x4 raios e 8 dispara 64 raios).
    • Um número maior produz um pixel mais preciso, mas aumenta o tempo de processamento.
    • Um valor de 1 fornece um melhor desempenho, mas não haverá nenhum desfoque de reflexo (por exemplo, é sempre nítido), sombra suave, profundidade de campo ou desfoque de movimento.

Aumentar o valor da Qualidade de rastreamento de raio não aumenta a nitidez. Na verdade, isso reduz o ruído inerente nessa amostragem de ponto. Use o menor valor que produza uma intensidade de ruído aceitável ou nenhum ruído.

  • Filtro de suavização de borda: controla o método do cálculo da média dos raios disparados para um pixel. Nenhum dispara todos os raios dentro dos limites de um pixel, enquanto os outros propagam a grade de raios disparados parcialmente pelos pixels adjacentes para produzir uma média melhor. Caixa, Barraca e Cúbicos (que não é bicúbico) são listados em ordem de melhor qualidade.
    • Nenhum
    • Caixa
    • Barraca
    • Cúbico

O filtro de suavização de borda controla a intensidade do nível de desfoque. Nenhum dá o resultado mais nítido, mas as bordas do coletor de projeção podem parecer com borda, com desfoque de Caixa, Triângulo e Cúbico a produzirem resultados mais desfocados.

Observação:

As camadas com rastreado de raio 3D usam a Qualidade de rastreamento de raio para controlar a aparência de desfoque de movimento.

Os cálculos da profundidade de campo em rastreado de raio 3D são mais precisos do que em 3D clássico (e anteriormente em 3D avançado).

Imagens em miniatura da composição

É possível escolher o quadro de uma composição para mostrar como uma imagem em miniatura (quadro de pôster) para a composição no painel Projeto. Por padrão, a imagem em miniatura é o primeiro quadro da composição, com as partes transparentes mostradas em preto.

  • Para ajustar a imagem em miniatura para uma composição, mova o indicador de tempo atual para o quadro desejado da composição no painel Linha de tempo e escolha Composição > Definir hora do pôster.
  • Para adicionar uma grade de transparência na exibição de miniatura, selecione Grade de transparência de miniatura no menu do painel Projeto.
  • Para ocultar imagens em miniatura no painel Projeto, escolha Editar > Preferências > Exibição (Windows) ou After Effects > Preferências > Exibição (Mac OS) e selecione Desativar miniaturas no painel Projeto.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online