Guia do Usuário Cancelar

Pré-composição, aninhamento e pré-renderização

  1. Guia do usuário do After Effects
  2. Versões beta
    1. Visão geral do programa Beta
    2. Página inicial do After Effects Beta
  3. Introdução
    1. Introdução ao After Effects
    2. Novidades no After Effects 
    3. Notas de versão | After Effects
    4. Requisitos de sistema do After Effects
    5. Atalhos de teclado no After Effects
    6. Formatos de arquivo compatíveis | After Effects
    7. Recomendações de hardware
    8. After Effects para Apple Silicon
    9. Planejamento e configuração
  4. Espaços de trabalho
    1. Itens gerais da interface do usuário
    2. Conheça a interface do After Effects
    3. Fluxos de trabalho
    4. Espaços de trabalho, painéis e visualizadores
  5. Projetos e composições
    1. Projetos
    2. Noções básicas da composição
    3. Pré-composição, aninhamento e pré-renderização
    4. Exibir informações detalhadas de desempenho com o Criador de perfil de composição
    5. Renderizador de composição CINEMA 4D
  6. Importação de gravação
    1. Preparação e importação de imagens estáticas
    2. Importação do After Effects e do Adobe Premiere Pro
    3. Importação e interpretação de vídeo e áudio
    4. Preparo e importação de arquivos de imagem 3D
    5. Importação e interpretação de itens de gravação
    6. Trabalhar com itens de gravação
    7. Detectar pontos de edição usando a Detecção de edição de cena
    8. Metadados XMP
  7. Textos e gráficos
    1. Texto
      1. Formatação de caracteres e o painel Caractere
      2. Efeitos de texto
      3. Criação e edição de camadas de texto
      4. Formatação de parágrafos e o painel Parágrafo
      5. Extrusão de texto e camadas de forma
      6. Animação de texto
      7. Exemplos e recursos de animação de texto
      8. Modelos de texto dinâmico
    2. Animações
      1. Trabalhar com Modelos de animações no After Effects
      2. Usar expressões para criar listas suspensas em Modelos de animações
      3. Trabalhar com propriedades essenciais para criar Modelos de animações
      4. Substituir imagens e vídeos em Modelos de animações e Propriedades essenciais
      5. Anime de maneira mais rápida e fácil usando o painel Propriedades
  8. Desenho, pintura e caminhos
    1. Visão geral de camadas de forma, caminhos e gráficos vetoriais
    2. Ferramentas de pintura: Pincel, Carimbo e Borracha
    3. Traçados de forma cônica
    4. Atributos de forma, operações de pintura e operações de caminho para camadas de forma
    5. Use o efeito de forma Deslocar caminhos para alterar formas
    6. Criação de formas
    7. Criar máscaras
    8. Remover objetos de seus vídeos com o painel Preenchimento com reconhecimento de conteúdo
    9. Pincel tipo rotoscópio e Refinar fosco
  9. Camadas, marcadores e câmera
    1. Seleção e organização de camadas
    2. Modos de mesclagem e estilos de camadas
    3. Camadas 3D
    4. Propriedades da camada
    5. Criação de camadas
    6. Gerenciamento de camadas
    7. Marcadores de camada e de composição
    8. Câmeras, luzes e pontos de interesse
  10. Animação, quadros-chave, rastreamento de movimento e chaveamento
    1. Animação
      1. Noções básicas de animação
      2. Animação com ferramentas Marionete
      3. Gerenciamento e animação de caminhos de forma e máscaras
      4. Animação de desenho e captura de formas usando o After Effects
      5. Ferramentas de animação diversas
      6. Trabalhar com animação orientada por dados
    2. Quadro-chave
      1. Interpolação do quadro-chave
      2. Definir, selecionar e excluir quadros-chave
      3. Editar, mover e copiar quadros-chave
    3. Rastreamento de movimento
      1. Rastrear e estabilizar movimento
      2. Reconhecimento facial
      3. Rastreamento de máscara
      4. Referência de máscara
      5. Velocidade
      6. Esticamento e remapeamento de tempo
      7. Timecode e unidades de exibição de tempo
    4. Aplicação de máscara
      1. Aplicação de máscara
      2. Efeitos de máscara
  11. Transparência e composição
    1. Visão geral e recursos da composição e transparência
    2. Canais alfa e máscaras
    3. Foscos de controle e foscos móveis
  12. Ajustar cor
    1. Noções básicas de cores
    2. Gerenciamento de cores
    3. Efeitos de correção de cores
    4. Gerenciamento de cores OpenColorIO e ACES
  13. Predefinições de animação e efeitos
    1. Visão geral das predefinições de animação e efeitos
    2. Lista de efeitos
    3. Gerenciador de efeitos
    4. Efeitos de simulação
    5. Efeitos de estilo
    6. Efeitos de áudio
    7. Efeitos de distorção
    8. Efeitos de perspectiva
    9. Efeitos de canal
    10. Efeitos de geração
    11. Efeitos de transição
    12. O efeito Reparo do obturador de rolagem
    13. Efeitos Desfoque e Tornar nítido
    14. Efeitos de Canal 3D
    15. Efeitos de utilitários
    16. Efeitos de fosco
    17. Efeitos Ruído e Granulação
    18. Efeito de ampliação com preservação de detalhes
    19. Efeitos obsoletos
  14. Expressões e automação
    1. Expressões
      1. Noções básicas de expressão
      2. Entender sobre a linguagem de expressões
      3. Utilização de controles de expressão
      4. Diferenças de sintaxe entre os mecanismos de expressão Javascript e Legacy ExtendScript
      5. Edição de expressões
      6. Erros de expressão
      7. Utilização do editor de expressões
      8. Usar expressões para editar e acessar propriedades de texto
      9. Referência de idioma de expressão
      10. Exemplos de expressão
    2. Automação
      1. Automação
      2. Scripts
  15. Vídeo imersivo, VR e 3D
    1. Construa ambientes VR no After Effects
    2. Aplicar efeitos de vídeo imersivo
    3. Ferramentas de composição para vídeos VR/360
    4. Renderizador 3D avançado
    5. Importar e adicionar modelos 3D à composição
    6. Importação de modelos 3D das bibliotecas da Creative Cloud
    7. Iluminação com base na imagem
    8. Extração e animação de luzes e câmeras de modelos 3D
    9. Rastreamento de movimento de câmera 3D
    10. Projetar e aceitar sombras
    11. Animações de modelos 3D incorporadas
    12. Coletor de sombras
    13. Extração de dados de profundidade 3D
    14. Trabalhar no Espaço de design 3D
    15. Gizmos de transformação 3D
    16. Faça mais com a animação 3D
    17. Visualização de alterações em projetos 3D em tempo real com o mecanismo Mercury 3D.
    18. Adicionar design responsivo aos gráficos 
  16. Exibições e visualizações
    1. Visualizar
    2. Visualização de vídeo com o Mercury Transmit
    3. Modificação e utilização de exibições
  17. Renderização e exportação
    1. Noções básicas de renderização e exportação
    2. Codificação em H.264 no After Effects
    3. Exportar um projeto do After Effects como um projeto do Adobe Premiere Pro
    4. Conversão de filmes
    5. Renderização de vários quadros
    6. Renderização automatizada e renderização de rede
    7. Renderização e exportação de imagens estáticas e sequências de imagens estáticas
    8. Utilização do codec GoPro CineForm no After Effects
  18. Trabalho com outros aplicativos
    1. Dynamic Link e After Effects
    2. Trabalhar com o After Effects e outros aplicativos
    3. Sincronizar configurações no After Effects
    4. Bibliotecas da Creative Cloud no After Effects
    5. Plug-ins
    6. Cinema 4D e Cineware
  19. Colaboração: Frame.io e Team Projects
    1. Colaboração no Premiere Pro e After Effects
    2. Frame.io
      1. Instalar e ativar o Frame.io
      2. Usar Frame.io com Premiere Pro e After Effects
      3. Perguntas frequentes
    3. Team Projects
      1. Introdução ao Team Projects
      2. Criar um Projeto de equipe
      3. Colaborar com o Team Projects
  20. Memória, armazenamento e desempenho
    1. Memória e armazenamento
    2. Como o After Effects lida com problemas de memória insuficiente durante uma visualização    
    3. Melhorar o desempenho
    4. Preferências
    5. GPU e os requisitos de driver de GPU para o After Effects
  21. Knowledge Base
    1. Problemas conhecidos
    2. Problemas corrigidos
    3. Perguntas frequentes
    4. After Effects e macOS Ventura
    5. Como o After Effects lida com problemas de memória insuficiente durante uma visualização

Sobre pré-composição e aninhamento

Se quiser agrupar algumas camadas já presentes em uma composição, pré-componha essas camadas. A pré-composição de camadas insere-as em uma nova composição, que substitui as camadas na composição original. A nova composição aninhada se torna a origem de uma única camada na composição original. A nova composição aparece no painel Projeto e está disponível para renderização ou uso em qualquer outra composição. É possível aninhar composições adicionando uma composição já existente a outra, exatamente como você faria com qualquer outro item de gravação a uma composição. Pré-compor uma única camada é útil para adicionar propriedades de transformação a uma camada e influenciar a ordem em que os elementos de uma composição são renderizados.

O aninhamento é a inclusão de uma composição em outra. A composição aninhada aparece como uma camada na composição que a contém.

Uma composição aninhada geralmente é chamada de pré-composição, que pode ser abreviada no uso casual para precomp ou pre-comp. Quando uma pré-composição é usada como o item de gravação de origem de uma camada, ela é chamada de camada de pré-composição.

Durante a renderização, pode-se considerar que os dados da imagem e outras informações fluem de cada composição aninhada para a composição que a contém. Por essa razão, as composições aninhadas são às vezes chamadas de ascendentes das composições que as contêm, e as composições que as contêm são chamadas de descendentes das composições aninhadas que elas contêm. Um conjunto de composições conectadas pelo aninhamento é chamado de rede de composição. É possível navegar em uma rede de composição com o Minifluxograma e o Navegador da composição. (Consulte Abrir e navegar em composições aninhadas).

As pré-composições no After Effects são semelhantes aos Objetos Inteligentes no Adobe Photoshop.

Usos da pré-composição e do aninhamento

A pré-composição e o aninhamento são úteis para gerenciar e organizar composições complexas. Ao pré-compor e aninhar, você poderá fazer o seguinte:

  • Aplicar alterações complexas em uma composição inteira — você pode criar uma composição que contenha várias camadas, aninhar a composição na composição total e animar e aplicar efeitos à composição aninhada para que todas as camadas sejam alteradas da mesma forma durante o mesmo período.
  • Reutilizar tudo o que criar — você pode criar uma animação em sua própria composição e depois arrastar essa composição para outras, quantas vezes desejar.
  • Atualizar em uma etapa — quando você faz alterações em uma composição aninhada, essas alterações afetam todas as composições em que ela é usada, assim como as alterações feitas em um item de gravação de origem afetam todas as composições em que ele é usado.
  • Alterar a ordem de renderização padrão de uma camada — é possível especificar a renderização de uma transformação (rotação, por exemplo) no After Effects antes de renderizar os efeitos, para que eles sejam aplicados à gravação girada.
  • Adicionar outro conjunto de propriedades de transformação a uma camada — a camada que representa a composição tem suas propriedades, além das propriedades das camadas que ela contém. Isso permite aplicar um conjunto adicional de transformações a uma camada ou conjunto de camadas.

Preferências e configurações de composição que afetam composições aninhadas

Como uma pré-composição é em si uma camada, você pode controlar seu comportamento usando opções de camada e de composição no painel Linha do tempo. Você pode escolher se as alterações feitas nas opções na composição que as contém serão propagadas para a composição aninhada. Para impedir que as opções de camada afetem as composições aninhadas, escolha Editar > Preferências > Geral (Windows) ou After Effects > Preferências > Geral (Mac OS) e desmarque Opções afetam composições aninhadas.

Na guia Avançado da caixa de diálogo Configurações de composição (Composição > Configurações de composição), escolha “Preservar resolução quando aninhado” ou “Preservar taxa de quadros quando aninhado ou na fila de renderização” para uma composição para manter sua própria resolução ou taxa de quadros e não herdar essas configurações da composição que a contém. Por exemplo, se você deliberadamente usou uma taxa de quadros baixa em uma composição para criar um resultado irregular, animado manualmente, preserve a taxa de quadros dessa composição quando ela for aninhada. Da mesma forma, os resultados da rotoscopia podem parecer errados quando convertidos para uma taxa de quadros ou resolução diferente. Use esta configuração em vez do efeito Posterizar tempo, que é menos eficiente.

Alterar o tempo atual em um painel atualiza o tempo atual em outros painéis associados à composição. Por padrão, o tempo atual também é atualizado para todas as composições relacionadas à composição atual por aninhamento. Para impedir que as composições relacionadas por aninhamento atualizem os tempos atuais ao alterar o tempo atual em uma composição, desmarque a preferência Sincronizar tempo de todos os itens relacionados (Editar > Preferências > Geral (Windows) ou After Effects > Preferências > Geral (Mac OS)).

Recursos online sobre pré-composição e aninhamento

Chris e Trish Meyer compartilham dicas sobre como configurar uma hierarquia de composição para facilitar as alterações em um projeto neste artigo do site ProVideo Coalition.

Consulte nesta página do site aescripts o script Un-Precompose, que extrai camadas de uma pré-composição .

Consulte nesta página do site aescripts o script Zorro-The Layer Tagger, que permite agrupar camadas na composição usando tags em vez de pré-composição.

Camadas de pré-composição

A pré-composição de camadas as colocam em uma nova composição (às vezes chamada de pré-composição), que substitui as camadas na composição original. Pré-compor uma única camada é útil para adicionar propriedades de transformação a uma camada e influenciar a ordem em que os elementos de uma composição são renderizados.

  1. Selecione as camadas no painel Linha do tempo e escolha Camada > Pré-composição ou pressione Ctrl+Shift+C (Windows) ou Command+Shift+C (Mac OS).
  2. Selecione uma das seguintes opções:

    Deixar todos os atributos em

    Deixa as propriedades e os quadros-chave da camada pré-composta na composição original, aplicada à nova camada que representa a pré-composição. O tamanho do quadro da nova composição é igual ao tamanho da camada selecionada. Essa opção não estará disponível se você selecionar mais de uma camada, uma camada de texto ou uma camada de forma.

    Mover todos os atributos para a nova composição

    Move as propriedades e os quadros-chave das camadas pré-compostas um nível além da composição raiz na hierarquia da composição. Ao usar essa opção, as alterações aplicadas às propriedades das camadas permanecem com as camadas individuais na pré-composição. O tamanho do quadro da nova composição é igual ao tamanho do quadro da composição original.

Efeitos podem incluir máscaras e efeitos de outras camadas

Os efeitos que usam camadas como uma entrada, como - Definir fosco e Mapa de deslocamento direcionam às máscaras e aos efeitos da camada de entrada. É possível usar essas camadas sem precisar fazer pré-composição com a finalidade de ser referenciado por um efeito. 

O controle é similar à função do menu Exibir na parte inferior do painel do visualizador de camada, que permite renderizar a camada a partir de posições diferentes na ordem de renderização: da origem, das máscaras ou dos efeitos individuais.
Para efeitos com propriedades de camada, abra o menu Parâmetro de entrada à direita da seleção de camada e escolha a camada de entrada de destino, por exemplo:

  • Origem: enfoca somente a origem da camada. As máscaras e os efeitos são ignorados.
  • Máscaras: enfoca a camada depois que as máscaras são aplicadas. Os efeitos são ignorados.
  • Efeitos e máscaras: enfoca a camada após as máscaras e efeitos serem aplicados.

 

Abrir e navegar em composições aninhadas

As composições aninhadas são às vezes chamadas de ascendentes das composições que as contêm e as composições que as contém são chamadas de descendentes das composições aninhadas que elas contêm. A composição raiz é a mais descendente e a composição mais profundamente aninhada é a mais ascendente. O caminho de fluxo da composição é uma cadeia de composições relacionadas por estarem contidas ou aninhadas entre si. Uma rede de composição é o conjunto inteiro de composições que estão relacionadas entre si por aninhamento.

O After Effects fornece diversas maneiras para abrir uma composição aninhada (pré-composição):

  • Clique duas vezes na entrada da composição no painel Projeto.
  • Clique duas vezes em uma camada de pré-composição no painel Linha de tempo. Alt+clicar duas vezes (Windows) ou Option+clicar duas vezes (Mac OS) para abrir a camada de pré-composição como uma camada no painel Camada.
Observação:

Ao clicar duas vezes em uma camada de pré-composição quando uma ferramenta de pintura ou a ferramenta Pincel tipo rotoscópio estiver ativa, abre a camada no painel Camada.

  • Para abrir a composição ativada mais recentemente na mesma rede de composição que a composição atualmente ativa, pressione Shift+Esc.

  • Use o Navegador de composição.

  • Use o Minifluxograma da composição.

O Navegador de composição

O Navegador de composição é uma barra na borda superior do painel Composição que mostra a composição ativa nesse visualizador em relação a outras composições na mesma rede de composição. As composições exibidas são as composições ativas mais recentes no caminho de fluxo da composição ativa no momento.

Navegador de composição

A. Composição (atual) ativa B. Seta para abrir o Minifluxograma da composição C. Botão do menu Painel D. Reticências 

As setas entre os nomes da composição indicam a direção em que as informações de pixels fluem para esse caminho de fluxo. O padrão é mostrar composições na barra do Navegador de composição com composições descendentes à esquerda e composições ascendentes à direita. Este padrão é indicado pela opção Fluir da direita para a esquerda no menu do painel Composição. Para mostrar composições na outra ordem, escolha Fluir da esquerda para a direita. Essa configuração é uma preferência global, se aplicando a todas as composições e à exibição Minifluxograma da composição.

Os nomes de composições descendentes são esmaecidos para indicar que o conteúdo não é usado ou mostrado na composição ativa.

  • Para mostrar ou ocultar a barra do Navegador de composição, escolha Mostrar navegador de composição no menu do painel Composição.

  • Para ativar qualquer composição mostrada na barra do Navegador de composição, clique no nome da composição.

  • Se o caminho do fluxo é longo demais para mostrar no painel Composição, um botão de reticências aparece na extremidade esquerda ou direita da barra do Navegador de composição. Para mostrar temporariamente todo o caminho do fluxo, clique no botão de reticências.

Observação:

Para navegar por um caminho longo do fluxo, posicione o ponteiro sobre um botão de composição no Navegador de composição e gire a roda do mouse.

O Minifluxograma da composição

O Minifluxograma da composição é um controle transitório que você pode usar para navegar rapidamente em uma rede de composição. Quando você abre o Minifluxograma da composição, são mostradas as composições imediatamente ascendentes e descendentes da composição selecionada.

As cores no Minifluxograma da composição se baseiam nas cores de rótulos atribuídas às composições no painel Projeto. Se uma composição for usada várias vezes dentro de uma composição, as várias instâncias da composição aninhada aparecem como uma entrada com um número entre parênteses indicando a quantidade de instâncias.

Para abrir o Minifluxograma da composição, siga um destes procedimentos:

Minifluxograma da composição

A. Indicador de que a composição não flui em outras composições B. Direção do fluxo C. Composição (atual) ativa 

  • Pressione a tecla tab quando um painel Composição, Camada ou Linha do tempo estiver ativo.
  • Clique na seta para a direita do nome de uma composição na barra do Navegador de composição.

  • Escolha Minifluxograma da composição no menu Composição, no menu do painel Composição ou no menu do painel Linha de tempo.

  • Clique no botão Minifluxograma da composição na parte superior do painel Linha do tempo.

Tal como com o Navegador de composição, você pode optar por mostrar a direção do fluxo da esquerda para a direita ou da direita para a esquerda. As setas indicam a direção do fluxo. Se uma composição tiver ao lado dela em vez de uma seta, então a composição não tem composições fluindo para ela ou não flui para nenhuma composição.

As composições ascendentes no Minifluxograma da composição são organizadas de cima para baixo, alfabeticamente ou pela ordem de camadas. Para alternar essas ordens de classificação, pressione a tecla S quando o Minifluxograma da composição estiver aberto. Para classificar por ordem de camadas, uma composição usada várias vezes é classificada de acordo com sua instância mais alta na ordem de empilhamento. As composições descendentes são classificadas sempre alfabeticamente.

Para navegar e selecionar composições no Minifluxograma da composição, use as teclas de seta ou clique na seta ou botões em ambos os lados de uma composição. Para ativar a composição selecionada, pressione a barra de espaço ou Enter (Windows) ou Return (Mac OS). Para fechar o Minifluxograma da composição sem fazer nenhuma ação, pressione Esc, toque em Shift ou clique fora do Minifluxograma da composição.

Rich Young fornece informações adicionais sobre o painel Fluxograma e o Minifluxograma da composição no site After Effects Portal.

Pré-renderizar uma composição aninhada

Uma composição aninhada complexa pode levar um longo tempo para renderizar, tanto para visualizações quanto para a saída final. Se você tiver uma composição aninhada na qual não espera trabalhar mais, é possível economizar tempo durante cada operação de renderização pré- renderizando a composição aninhada em um filme e substituindo a composição pelo filme renderizado. Você ainda pode modificar a composição aninhada original, pois ela permanece no painel Projeto. Caso faça uma alteração significativa à composição aninhada original, renderize-a novamente.

Pré-renderizar uma composição aninhada é especialmente benéfico quando você planeja usá-la várias vezes em um projeto.

Observação:

Aplique as configurações da saída final quando você pré-renderizar a composição aninhada.

  1. Selecione a composição no painel Projeto ou Composição.
  2. Escolha Composição > Pré-renderização.

    O comando Pré-renderizar adiciona a composição à fila de renderização e define a ação de pós-renderização Importar e substituir uso para substituir a composição pelo filme renderizado.

  3. No painel Fila de renderização, ajuste as configurações conforme necessário e clique no botão Renderizar para renderizar a composição.
Observação:

Uma alternativa para substituir a composição pelo filme é usar o filme renderizado como proxy para a composição aninhada.

Ordem de renderização e transformações recolhidas

Uma composição consiste em camadas empilhadas umas sobre as outras no painel Linha de tempo. Quando a composição é renderizada – para visualização ou para saída final – a camada da parte inferior é renderizada primeiro. Em cada camada rasterizada (não vetor), os elementos são aplicados nesta ordem: máscaras, efeitos, transformações e estilos de camada. Para camadas de vetor rasterizadas continuamente, a ordem de renderização padrão é máscaras, seguidas de transformações e em seguida efeitos.

As transformações são alterações a essas propriedades agrupadas sob a categoria Transformar no painel Linha de tempo, incluindo Ponto de ancoragem, Posição, Escala, Rotação e Opacidade. O que você vê no painel Camada é o resultado da renderização antes de as transformações serem executadas.

Observação:

Para ter mais controle sobre o momento em que as transformações são executadas, você pode aplicar o efeito Transformar e reorganizá-lo com relação a outros efeitos.

Em um grupo de efeitos ou máscaras, os itens serão processados de cima para baixo. Por exemplo, se você aplicar o efeito Círculo e aplicar o efeito Ampliar, o círculo será ampliado. No entanto, se você arrastar o efeito Ampliar acima (antes) do efeito Círculo no painel Controles do efeito ou painel Linha do tempo, o círculo será desenhado após a ampliação e não é ampliado.

Depois que uma camada é renderizada, a renderização inicia para a próxima camada. A camada renderizada abaixo pode ser usada como entrada para a renderização da camada acima – por exemplo, para determinar o resultado de um modo de mesclagem.

Se uma composição tiver outras composições aninhadas nela, a composição aninhada será renderizada antes de outras camadas na composição que a contém.

Observação:

Alguns efeitos ignoram máscaras na camada na qual são aplicados. Para que esse efeito opere em uma camada mascarada, pré-componha a camada com a máscara aplicada e aplique o efeito à camada pré-composta. (Consulte Sobre pré-composição e aninhamento).

Recolher transformações

Se a opção Recolher transformações estiver selecionada para uma composição aninhada, as transformações dela não serão executadas até que as máscaras e efeitos da composição que a contém sejam renderizados. Essa ordem de renderização permite que as transformações da composição aninhada e a composição que a contém sejam combinadas – ou recolhidas – e executadas em conjunto. O mesmo se aplica para camadas vetoriais que não são rasterizadas continuamente.

Observação:

Em vez de uma opção Recolher transformações, as camadas vetoriais têm uma opção Rasterizar continuamente no mesmo local. As camadas vetoriais incluem camadas de forma, camadas de texto e camadas com arquivos gráficos vetoriais como a gravação de origem. As camadas de texto e camadas de forma sempre são rasterizadas continuamente.

A opção Recolher transformações pode, por exemplo, preservar a resolução quando uma camada é reduzida pela metade em uma composição aninhada, e a composição aninhada é ampliada por um fator de dois na composição que a contém. Nesse caso, em vez de executar ambas as transformações e perder dados de imagem no processo, uma transformação pode ser executada – sem fazer nada, porque as transformações individuais cancelam uma a outra.

Se as transformações não estiverem recolhidas, uma composição aninhada que contenha camadas 3D é renderizada como uma imagem 2D da disposição 3D, usando a câmera de composição padrão. Essa renderização evita que a composição aninhada faça a intersecção com camadas 3D, projetando sombras em camadas 3D e recebendo sombras de camadas 3D na composição que a contém. A composição aninhada também não é controlada pelas câmeras e luzes da composição que a contém.

Se as transformações estiverem recolhidas, as propriedades 3D das camadas na composição aninhada ficam expostas à composição que as contém. Assim, a composição aninhada pode fazer intersecção com camadas 3D, projetar sombras em camadas 3D e receber sombras das camadas 3D na composição que a contém. A câmera e as luzes da composição que contém a composição aninhada também podem controlar a composição aninhada.

Essencialmente, recolher transformações de uma composição aninhada diz ao After Effects para não nivelar e cortar as camadas na pré-composição. Como uma camada de ajuste funciona na composição de todas as camadas abaixo dela dentro da mesma composição, uma camada de ajuste dentro de uma composição aninhada com transformações recolhidas forçará o nivelamento e o corte que a opção Recolher transformações normalmente impediria.

Quando uma máscara fechada (com o modo de máscara diferente de Nenhum), um estilo de camada ou um efeito é aplicado a uma composição aninhada com transformações recolhidas, as camadas na composição aninhada são renderizadas primeiro sozinhas, em seguida, as máscaras e os efeitos são aplicados e o resultado é composto na composição principal. Essa ordem de renderização significa que os modos de mesclagem das camadas aninhadas não são aplicados a nenhuma camada subjacente na composição principal e as camadas 3D acima e abaixo da camada recolhida não podem fazer intersecção ou projetar sombras umas nas outras.

Recursos online

Chris e Trish Meyer explicam as transformações recolhidas e a rasterização contínua neste artigo no site da ProVideo Coalition.

 Adobe

Receba ajuda com mais rapidez e facilidade

Novo usuário?

Adobe MAX 2024

Adobe MAX:
a conferência da criatividade

14 a 16 de outubro, Miami Beach e online

Adobe MAX

A conferência da criatividade

14 a 16 de outubro, Miami Beach e online

Adobe MAX 2024

Adobe MAX:
a conferência da criatividade

14 a 16 de outubro, Miami Beach e online

Adobe MAX

A conferência da criatividade

14 a 16 de outubro, Miami Beach e online