Guia do Usuário Cancelar

Visão geral de camadas de forma, caminhos e gráficos vetoriais

  1. Guia do usuário do After Effects
  2. Versões beta
    1. Visão geral do programa Beta
    2. Página inicial do After Effects Beta
    3. Recursos na versão beta
      1. Painel Propriedades (Beta)
      2. Importação de modelo 3D (beta)
      3. Gerenciamento de cores OpenColorIO e ACES (Beta)
  3. Introdução
    1. Introdução ao After Effects
    2. Novidades no After Effects 
    3. Notas de versão | After Effects
    4. Requisitos de sistema do After Effects
    5. Atalhos de teclado no After Effects
    6. Formatos de arquivo compatíveis | After Effects
    7. Recomendações de hardware
    8. After Effects para Apple Silicon
    9. Planejamento e configuração
  4. Espaços de trabalho
    1. Itens gerais da interface do usuário
    2. Conheça a interface do After Effects
    3. Fluxos de trabalho
    4. Espaços de trabalho, painéis e visualizadores
  5. Projetos e composições
    1. Projetos
    2. Noções básicas da composição
    3. Pré-composição, aninhamento e pré-renderização
    4. Exibir informações detalhadas de desempenho com o Criador de perfil de composição
    5. Renderizador de composição CINEMA 4D
  6. Importação de gravação
    1. Preparação e importação de imagens estáticas
    2. Importação do After Effects e do Adobe Premiere Pro
    3. Importação e interpretação de vídeo e áudio
    4. Preparo e importação de arquivos de imagem 3D
    5. Importação e interpretação de itens de gravação
    6. Trabalhar com itens de gravação
    7. Detectar pontos de edição usando a Detecção de edição de cena
    8. Metadados XMP
  7. Textos e gráficos
    1. Texto
      1. Formatação de caracteres e o painel Caractere
      2. Efeitos de texto
      3. Criação e edição de camadas de texto
      4. Formatação de parágrafos e o painel Parágrafo
      5. Extrusão de texto e camadas de forma
      6. Animação de texto
      7. Exemplos e recursos de animação de texto
      8. Modelos de texto dinâmico
    2. Animações
      1. Trabalhar com Modelos de animações no After Effects
      2. Usar expressões para criar listas suspensas em Modelos de animações
      3. Trabalhar com propriedades essenciais para criar Modelos de animações
      4. Substituir imagens e vídeos em Modelos de animações e Propriedades essenciais
  8. Desenho, pintura e caminhos
    1. Visão geral de camadas de forma, caminhos e gráficos vetoriais
    2. Ferramentas de pintura: Pincel, Carimbo e Borracha
    3. Traçados de forma cônica
    4. Atributos de forma, operações de pintura e operações de caminho para camadas de forma
    5. Use o efeito de forma Deslocar caminhos para alterar formas
    6. Criação de formas
    7. Criar máscaras
    8. Remover objetos de seus vídeos com o painel Preenchimento com reconhecimento de conteúdo
    9. Pincel tipo rotoscópio e Refinar fosco
  9. Camadas, marcadores e câmera
    1. Seleção e organização de camadas
    2. Modos de mesclagem e estilos de camadas
    3. Camadas 3D
    4. Propriedades da camada
    5. Criação de camadas
    6. Gerenciamento de camadas
    7. Marcadores de camada e de composição
    8. Câmeras, luzes e pontos de interesse
  10. Animação, quadros-chave, rastreamento de movimento e chaveamento
    1. Animação
      1. Noções básicas de animação
      2. Animação com ferramentas Marionete
      3. Gerenciamento e animação de caminhos de forma e máscaras
      4. Animação de desenho e captura de formas usando o After Effects
      5. Ferramentas de animação diversas
      6. Trabalhar com animação orientada por dados
    2. Quadro-chave
      1. Interpolação do quadro-chave
      2. Definir, selecionar e excluir quadros-chave
      3. Editar, mover e copiar quadros-chave
    3. Rastreamento de movimento
      1. Rastrear e estabilizar movimento
      2. Reconhecimento facial
      3. Rastreamento de máscara
      4. Referência de máscara
      5. Velocidade
      6. Esticamento e remapeamento de tempo
      7. Timecode e unidades de exibição de tempo
    4. Aplicação de máscara
      1. Aplicação de máscara
      2. Efeitos de máscara
  11. Transparência e composição
    1. Visão geral e recursos da composição e transparência
    2. Canais alfa e máscaras
    3. Foscos de controle e foscos móveis
  12. Ajustar cor
    1. Noções básicas de cores
    2. Gerenciamento de cores
    3. Efeitos de correção de cores
  13. Predefinições de animação e efeitos
    1. Visão geral das predefinições de animação e efeitos
    2. Lista de efeitos
    3. Efeitos de simulação
    4. Efeitos de estilo
    5. Efeitos de áudio
    6. Efeitos de distorção
    7. Efeitos de perspectiva
    8. Efeitos de canal
    9. Efeitos de geração
    10. Efeitos de transição
    11. O efeito Reparo do obturador de rolagem
    12. Efeitos Desfoque e Nitidez
    13. Efeitos de Canal 3D
    14. Efeitos de utilitários
    15. Efeitos de fosco
    16. Efeitos Ruído e Granulação
    17. Efeito Ampliação com preservação de detalhes
    18. Efeitos obsoletos
  14. Expressões e automação
    1. Expressão
      1. Noções básicas de expressão
      2. Entender sobre a linguagem de expressões
      3. Utilização de controles de expressão
      4. Diferenças de sintaxe entre os mecanismos de expressão Javascript e Legacy ExtendScript
      5. Edição de expressões
      6. Erros de expressão
      7. Utilização do editor de expressões
      8. Usar expressões para editar e acessar propriedades de texto
      9. Referência de linguagem de expressão
      10. Exemplos de expressão
    2. Automação
      1. Automação
      2. Scripts
  15. Vídeo imersivo, VR e 3D
    1. Criar ambientes de VR no After Effects
    2. Aplicar efeitos de vídeo imersivo
    3. Ferramentas de composição para vídeos VR/360
    4. Rastreamento de movimento de câmera 3D
    5. Trabalhar no Espaço de design 3D
    6. Gizmos de transformação 3D
    7. Faça mais com a animação 3D
    8. Visualização de alterações em projetos 3D em tempo real com o mecanismo Mercury 3D.
    9. Adicionar design responsivo aos gráficos 
  16. Exibições e visualizações
    1. Visualizar
    2. Visualização de vídeo com o Mercury Transmit
    3. Modificação e utilização de exibições
  17. Renderização e exportação
    1. Noções básicas de renderização e exportação
    2. Codificação em H.264 no After Effects
    3. Exportar um projeto do After Effects como um projeto do Adobe Premiere Pro
    4. Conversão de filmes
    5. Renderização de vários quadros
    6. Renderização automatizada e renderização de rede
    7. Renderização e exportação de imagens estáticas e sequências de imagens estáticas
    8. Utilização do codec GoPro CineForm no After Effects
  18. Trabalho com outros aplicativos
    1. Dynamic Link e After Effects
    2. Trabalhar com o After Effects e outros aplicativos
    3. Sincronizar configurações no After Effects
    4. Bibliotecas da Creative Cloud no After Effects
    5. Plug-ins
    6. Cinema 4D e Cineware
  19. Colaboração: Frame.io e Team Projects
    1. Colaboração no Premiere Pro e After Effects
    2. Frame.io
      1. Instalar e ativar o Frame.io
      2. Usar Frame.io com Premiere Pro e After Effects
      3. Perguntas frequentes
    3. Team Projects
      1. Introdução ao Team Projects
      2. Criar um Projeto de equipe
      3. Colaborar com o Team Projects
  20. Memória, armazenamento e desempenho
    1. Memória e armazenamento
    2. Como o After Effects lida com problemas de memória insuficiente durante uma visualização    
    3. Melhorar o desempenho
    4. Preferências
    5. GPU e os requisitos de driver de GPU para o After Effects

Sobre gráficos vetoriais e imagens rasterizadas

Os gráficos vetoriais são compostos por linhas e curvas definidas por objetos matemáticos chamados de vetores, que descrevem uma imagem de acordo com suas características geométricas. Exemplos de elementos gráficos vetoriais no After Effects incluem caminhos de máscara, formas em camadas de forma e texto em camadas de texto.

As imagens rasterizadas (às vezes chamadas de imagens de bitmap) usam uma grade retangular de elementos de imagem (pixels) para representar imagens. É atribuído a cada pixel um local específico e um valor de cor. A gravação de vídeo, as sequências de imagens transferidas de filme e muitos outros tipos de imagens importadas para o After Effects são imagens rasterizadas.

Os gráficos vetoriais mantêm bordas nítidas e não perdem nenhum detalhe quando redimensionadas, porque são independentes da resolução. Essa independência em termos de resolução faz dos gráficos vetoriais uma boa opção para os elementos visuais, como logotipos, que serão usados em diversos tamanhos.

Exemplo de um gráfico vetorial em diferentes níveis de ampliação
Exemplo de um gráfico vetorial em diferentes níveis de ampliação

As imagens rasterizadas consistem em um número fixo de pixels e são consequentemente dependentes da resolução. As imagens rasterizadas podem perder detalhes e parecerem irregulares (pixeladas) se forem aumentadas.

Exemplo de uma imagem rasterizada em diferentes níveis de ampliação
Exemplo de uma imagem rasterizada em diferentes níveis de ampliação

Algumas imagens são criadas como gráficos vetoriais em outro aplicativo, mas são convertidas em pixels (rasterizadas) quando são importadas para o After Effects. Se uma camada for rasterizada continuamente, o After Effects converte novamente os gráficos vetoriais em pixels quando a camada é redimensionada, preservando as arestas nítidas. Os gráficos vetoriais de arquivos SWF, PDF, EPS e do Illustrator podem ser rasterizados continuamente.

O tutorial em vídeo de Aharon Rabinowitz “O que são gráficos rasterizados e vetoriais?”, Tutorial em vídeo, parte da série Multimedia 101 no site Creative COW, fornece uma introdução geral às imagens rasterizadas e gráficos vetoriais.

Sobre caminhos

Vários recursos do After Effects — incluindo máscaras, formas, traçados de tinta e caminhos de movimento — baseiam-se no conceito de um caminho. As ferramentas e técnicas para criar e editar esses vários tipos de caminhos se sobrepõem, mas cada tipo de caminho tem seus próprios aspectos únicos.

Um caminho é composto por segmentos e vértices. Os segmentos são as linhas e curvas que conectam vértices. Os vértices definem onde cada segmento de um caminho inicia e termina. Alguns aplicativos da Adobe usam os termos ponto de ancoragem e ponto de caminho para fazer referência a um vértice.

É possível alterar a forma de um caminho arrastando seus vértices, as alças de direção no final das linhas de direção (ou tangentes) de cada vértice, ou o próprio segmento de caminho.

Como em um caminho existe um vértice, o ângulo e comprimento da linha de direção de saída desse vértice determinam o caminho. À medida que o caminho se aproxima do próximo vértice, o caminho é menos influenciado pela linha de direção de saída do vértice anterior e mais influenciado pela linha de direção de entrada do próximo vértice.

Componentes de um caminho
Componentes de um caminho

A. Vértice selecionado B. Vértice selecionado C. Vértice não selecionado D. Segmento de caminho curvado E. Linha de direção (tangente) F. Alça de direção 

Os caminhos podem ter dois tipos de vértices: pontos de vértice e pontos suaves. Em um ponto suave, os segmentos do caminho são conectados como uma curva suave; as linhas de direção de entrada e de saída estão na mesma linha. Em um ponto de vértice, o caminho muda repentinamente de direção; as linhas de direção de entrada e de saída estão em linhas diferentes. É possível desenhar um caminho usando qualquer combinação de pontos de vértice e pontos suaves. Se você desenhar o tipo errado de ponto, é possível alterá-lo mais tarde.

Pontos em um caminho
Pontos em um caminho

A. Quatro pontos de vértice B. Quatro pontos suaves C. Combinação de pontos de vértice e pontos suaves 

Quando você move a linha de direção em um ponto suave, as curvas dos dois lados do ponto se ajustam simultaneamente. Entretanto, ao mover uma linha de direção em um ponto de vértice, só é ajustada a curva do mesmo lado do ponto que a linha de direção.

Ajuste das linhas de direção em um ponto suave (esquerda) e em um ponto de vértice (direita)
Ajuste das linhas de direção em um ponto suave (esquerda) e em um ponto de vértice (direita)

Um caminho pode ser aberto ou fechado. Um caminho aberto tem um ponto de partida que não é igual ao seu ponto final; por exemplo, uma linha reta é um caminho aberto. Um caminho fechado é contínuo e não tem início ou fim; Por exemplo, um círculo é um caminho fechado.

Você pode desenhar caminhos em formas geométricas comuns – incluindo polígonos, elipses e estrelas – com as ferramentas de forma, ou pode usar a ferramenta Caneta para desenhar um caminho arbitrário. Os caminhos desenhados com a ferramenta Caneta são caminhos de Bézier manual ou caminhos de RotoBézier. A principal diferença entre RotoBézier e caminhos de Bézier manual é que as linhas de direção são calculadas automaticamente para caminhos de RotoBézier, tornando-os mais fácil e mais rápido para desenhar.

Ao usar as ferramentas de forma (Retângulo, Retângulo arredondado, Elipse, Polígono ou Estrela) para desenhar um caminho de forma em uma camada de forma, crie um de dois tipos de caminhos: um caminho de forma paramétrica ou caminho de forma Bézier. (Consulte Sobre formas e camadas de forma.)

É possível vincular caminhos de máscara, caminhos de traçado de tinta e caminhos de forma de Bézier usando expressões. Você também pode copiar e colar entre caminhos de máscara, caminhos de traçado de tinta, caminhos de forma de Bézier, caminhos de movimento e caminhos do Adobe Illustrator, Photoshop e Adobe Fireworks. (Consulte Criar formas e máscaras.)

Para caminhos de forma, você pode usar a operação de caminho Mesclar Caminhos (semelhante aos efeitos do Pathfinder no Adobe Illustrator) para combinar vários caminhos em um caminho. (Consulte Opções de Mesclar caminhos.)

Quando você deseja que um texto ou um efeito siga um caminho, o caminho deve ser um caminho da máscara.

Um caminho propriamente dito não tem aparência visual de saída renderizada; é essencialmente uma coleção de informações sobre como inserir ou modificar outros elementos visuais. Para tornar um caminho visível, aplique um traçado ao mesmo. No caso de um caminho da máscara, aplique o efeito Traçado. No caso de um caminho para um objeto de camada de forma, o padrão é para que o caminho seja criado com um grupo de propriedades de traçado (atributo) depois do conjunto de propriedades de caminho no painel Linha de tempo.

Uma cor ou um gradiente aplicado a área dentro da área delimitada por um caminho é um preenchimento.

Observação:

Para especificar o tamanho das alças de direção de Bézier e dos vértices para máscaras e formas, escolha Editar > Preferências > Geral (Windows) ou After Effects > Preferências > Geral (Mac OS) e edite o valor Tamanho de ponto do caminho.

Sobre formas e camadas de forma

As camadas de forma contêm objetos gráficos vetoriais chamados formas. Por padrão, uma forma é composta por um caminho, um traçado e um preenchimento. (Consulte Sobre caminhos e Traçados e preenchimentos de formas.)

Você pode criar camadas de forma desenhando no painel Composição com as ferramentas de forma ou a ferramenta Caneta. (Consulte Criar formas e máscaras.)

Os caminhos de forma têm duas variedades: caminhos de forma paramétricos e caminhos de forma Bézier. Os caminhos de forma paramétrica são definidos numericamente, por propriedades que você pode modificar e animar após o desenho, no painel Linha de tempo. Os caminhos de forma Bézier são definidos por uma coleção de vértices (pontos de caminho) e segmentos que você pode modificar no painel Composição. Trabalhe com caminhos de forma Bézier da mesma forma que trabalha com caminhos de máscara. Todos os caminhos de máscara são caminhos de Bézier.

É possível modificar um caminho da forma aplicando operações de caminho, como Caminhos de chocalho e Dobrar e inchar. Você pode aplicar um traçado a um caminho ou preencher a área definida por um caminho com cor aplicando operações de pintura. (Consulte Atributos de forma, operações de pintura e operações de caminho para camadas de forma.)

Os caminhos de forma e as operações de pintura para formas são coletivamente denominados atributos de forma. Adicione atributos de forma usando o menu Adicionar no painel Ferramentas ou no painel Linha de tempo. Cada atributo de forma é representado por um grupo de propriedades no painel Linha de tempo, com propriedades que você pode animar, assim como faz com qualquer outra propriedade de camada. (Consulte Sobre animação, quadros-chave e expressões.)

A profundidade de bits de cor de uma camada de forma é a mesma que o projeto como um todo: 8, 16 ou 32 bpc. (Consulte Intensidade de cor e cor de intervalo dinâmico alto.)

As camadas de forma não são baseadas em itens de gravação. As camadas que não são baseadas em itens de gravação são às vezes chamadas de camadas sintéticas. As camadas de texto também são camadas sintéticas e são compostas também por objetos gráficos vetoriais, por isso muitas das regras e diretrizes aplicadas a camadas de texto também se aplicam às camadas de forma. Por exemplo, você não pode abrir uma camada de forma no painel Camada, tal como não pode abrir uma camada de texto em um painel Camada.

Observação:

Você pode salvar suas formas favoritas como predefinições de animação. (Consulte Salvar uma predefinição de animação.)

Recursos online para camadas de forma

Para assistir a um tutorial em vídeo sobre a criação de camadas de forma Camadas de vetora, visite a página de Tutoriais de.

Trish e Chris Meyer oferecem uma introdução às camadas de forma em um trecho em PDF do capítulo “Camadas de forma” do seu livro Creating Motion Graphics with After Effects (5ª edição).

Chris Zwar fornece uma animação predefinida no seu site que cria um alvo com mira usando uma única camada de forma, com uma grande variedade de propriedades personalizadas que tornam o controle e a modificação de animação do alvo de mira fácil e óbvio.

Grupos e ordem de renderização de formas e atributos de forma

Embora o padrão seja para uma forma composta por um único caminho, um único traçado e um único preenchimento — organizados de cima para baixo no painel Linha de tempo — muito do poder e flexibilidade das camadas de forma suscita da capacidade de adicionar e reordenar atributos de forma e criar formas compostas mais complexas.

É possível agrupar as formas ou atributos de forma que estejam no mesmo nível de agrupamento em uma única camada de forma.

Um grupo é uma coleção de atributos de forma: caminhos, preenchimentos, traçados, operações de caminho e outros grupos. Cada grupo tem seu próprio modo de mesclagem e seu próprio conjunto de propriedades de transformação. Ao montar formas em grupos, é possível trabalhar com várias formas simultaneamente; como redimensionar todas as formas no grupo pelo mesmo valor ou aplicar o mesmo traçado a cada forma. Você pode até mesmo colocar formas individuais ou atributos de forma individuais em seus próprios grupos para isolar transformações. Por exemplo, você pode redimensionar um caminho sem redimensionar seu traçado, agrupando o caminho sozinho.

Quando você adiciona um atributo de forma usando o menu Adicionar no painel Ferramentas ou painel Linha de tempo, o atributo será adicionado ao grupo selecionado. Você pode arrastar grupos e atributos para reordená-los no painel Linha de tempo. Ao reordenar e agrupar formas e atributos de forma, é possível alterar a ordem de renderização com relação a outras formas e atributos da forma.

Grupos e ordem de renderização de formas e atributos de forma

A. Duas formas em um grupo B. Dois caminhos em uma forma composta C. Caminho circular com Caminhos de chocalho aplicados D. Um traçado aplicado a todos os caminhos acima dele E. Caminho de estrelas em um grupo sozinho F. Um preenchimento aplicado a todos os caminhos acima dele G. Um caminho com dois traçados 

Ordem de renderização de formas em uma camada de forma

As regras para renderizar uma camada de forma são semelhantes às regras para renderizar uma composição que contém composições aninhadas:

  • Em um grupo, a forma na parte inferior da ordem de empilhamento do painel Linha de tempo é renderizada primeiro.

  • Todas as operações de caminho em um grupo são executadas antes das operações de pintura. Isso significa, por exemplo, que o traçado segue as distorções no caminho feitas pela operação de caminho Caminhos de chocalho. As operações de caminho em um grupo são executadas de cima para baixo. (Consulte Alterar formas com operações de caminho.)

  • As operações de pintura em um grupo são executadas de baixo para cima na ordem de empilhamento do painel Linha de tempo. Isso significa, por exemplo, que um traçado é renderizado sobre (acima) um traçado que aparece depois dele no painel Linha do tempo. Para substituir esse comportamento padrão para um preenchimento ou traçado específico, escolha Acima do anterior no mesmo grupo para a propriedade Composta do preenchimento ou traçado no painel Linha de tempo. (Consulte Traçados e preenchimentos de formas.)

As operações de caminho e operações de pintura se aplicam a todos os caminhos acima dele no mesmo grupo.

Propriedades de transformação de grupos de formas e caminhos de forma

Cada grupo tem seus próprios grupos de propriedade Transformar. Este grupo de propriedades Transformar é representado no painel Linha de tempo com um grupo de propriedades chamado Transformação: [nome do grupo] e no painel Composição como uma caixa tracejada com alças. É possível agrupar um caminho sozinho e transformar apenas o caminho usando o novo grupo de propriedades Transformar.

Inserir um grupo de propriedades Transformar adicional para um único caminho é útil, por exemplo, para criar movimento complexo – como rotação sobre um ponto de ancoragem enquanto gira também em uma órbita. As transformações de um grupo afetam todos as formas dentro do grupo; este comportamento é o mesmo comportamento de pai de camada. (Consulte Camadas pai e filho.)

Cada caminho de forma também tem propriedades intrínsecas que afetam a posição e a forma do caminho. Para caminhos de forma paramétrica, essas propriedades (como Posição e Tamanho) são parâmetros visíveis no painel Linha de tempo. Para caminhos de forma de Bézier, estas propriedades são definidas para cada vértice, mas contidos na propriedade Caminho. Quando você modifica um caminho de Bézier usando a caixa delimitadora de transformação livre, você modifica as propriedades intrínsecas para os vértices que constituem esse caminho. (Consulte Sobre formas e camadas de forma.)

Agrupar formas ou atributos de forma

  1. Selecione uma ou mais formas ou atributos de formato e siga um destes procedimentos:
    • Escolha Camada > Caminho de máscara e forma > Agrupar formas.
    • Pressione Ctrl+G (Windows) ou Command+G (Mac OS).

Ao agrupar formas, o ponto de ancoragem do grupo é colocado no centro da caixa delimitadora para o grupo.

Desagrupar formas ou atributos de forma

  1. Selecione um único grupo e siga um destes procedimentos:
    • Escolha Camada > Caminho de máscara e forma > Desagrupar formas.
    • Pressione Ctrl+Shift+G (Windows) ou Command+Shift+G (Mac OS).

Criar um grupo de forma vazio

  1. Escolha Grupo (vazio) no menu Adicionar no painel Ferramentas ou no painel Linha de tempo.
Logotipo da Adobe

Fazer logon em sua conta