Jeff Almasol fornece um script em seu site de redefinery que renderiza e exporta cada uma das camadas separadamente. Por exemplo, use esse script se as camadas representam diferentes versões de um efeito ou diferentes partes de um efeito que deseja renderizar como passagens separadas para flexibilidade em como são compostos.

Visualizar e alterar informações de camada

  • Para renomear uma camada ou grupo de propriedades, siga um destes procedimentos:
    • Selecione o item no painel Linha de tempo, pressione Enter (Windows) ou Return (Mac OS) e digite o novo nome.

    • Clique com o botão direito do mouse (Windows) ou com a tecla Control pressionada (Mac OS) no item do painel Linha de tempo, escolha Renomear e digite o novo nome.

  • Para alternar entre a exibição dos nomes dos itens da gravação de origem e os nomes de camadas o painel Linha de tempo, clique no cabeçalho da coluna Nome da camada/Nome de origem no painel Linha de tempo.

Observação:

Quando o nome da camada e o nome da gravação de origem forem iguais, os colchetes exibidos no nome de camada no nome da camada, como este: [nome da camada]

  • Para mostrar o nome do arquivo de gravação de origem para uma camada selecionada no painel Informações, pressione Ctrl+Alt+E (Windows) ou Command+Option+E (Mac OS).
  • Para ver qual item da gravação é a origem para uma camada, clique com o botão direito do mouse (Windows) ou com a tecla Control pressionada (Mac OS) na camada do painel Linha de tempo e escolha Revelar origem da camada no projeto.

O item de gravação de origem é selecionado no painel Projeto.

É possível filtrar camadas no painel Linha de tempo para mostrar apenas camadas com propriedades correspondentes a uma sequência de pesquisa ou outros recursos. Consulte Pesquisar e filtrar nos painéis Linha do tempo, Projeto e Efeitos e definições e Mostrar propriedades e grupos no painel Linha do tempo (atalhos de teclado).

Jeff Almasol fornece um script em seu site de redefinery que grava automaticamente informações especificadas sobre os itens de gravação ou camadas nos campos Comentário para os respectivos itens no painel Projeto ou Linha de tempo.

Christopher Green fornece um script (Selected_Layers_Renamer.jsx) em seu site com o qual você pode renomear múltiplas camadas selecionadas no painel Linha de tempo. Você pode pesquisar e substituir texto em nomes, adicionar caracteres a o começo ou final de nomes, aparar um determinado número de caracteres no início ou fim do nome ou substituir os nomes por números em uma série.

Opções de camada e colunas no painel Linha de tempo

Muitas das características de uma camada são determinadas pelas opções de camada, que são organizadas no painel Linha de tempo em colunas. Por padrão, a coluna Recursos de A/V aparece à esquerda do nome da camada, e as colunas Opções e Modos (controles de transferência) aparecem à direita, mas é possível ordenar colunas em uma ordem diferente. (Consulte Colunas.)

Para mostrar ou ocultar colunas no painel Linha do tempo, clique nas Opções de camada , Controles de transferência ou no botão Entrada/Saída/Duração/Esticar no canto inferior esquerdo do painel Linha do tempo. Pressione Shift+F4 para mostrar ou ocultar a coluna pai. Pressione F4 para alternar as colunas Opções e Modos.

Os resultados de algumas configurações de opções de camada dependem das configurações de opções de composição, no canto superior direito do contorno da camada no painel Linha de tempo.

Observação:

Altere rapidamente o estado de uma opção para várias camadas clicando na opção para uma camada e arrastando para cima ou para baixo essa coluna para as camadas adjacentes.

Jeff Almasol fornece um script em seu site de redefinery que cria um painel com o qual você pode salvar e restaurar as configurações de opção de camada para todas as camadas em uma composição.

Opções na coluna Recursos de A/V

Vídeo 

Ativa ou desativa os elementos visuais da camada. (Consulte Alternar a visibilidade ou a influência de uma camada ou a grupo de propriedades.)

Áudio 

Ativa ou desativa os sons da camada.

Isolar 

Inclui a camada atual em exibições e renderiza, ignorando as camadas sem este conjunto de opções. (Consulte Isolar uma camada.)

Bloquear 

Bloqueia conteúdo da camada, evitando alterações. (Consulte Bloquear ou desbloquear uma camada.)

Opções na coluna Opções

Recuar 

Oculta a camada atual quando a opção de composição Ocultar camadas inativas está selecionada. (Consulte Mostrar e ocultar camadas no painel Linha de tempo.)

Recolher transformações/Rasterizar continuamente

Recolhe as transformações se a camada for uma pré-composição; rasteriza continuamente se a camada for uma camada de forma, camada de texto ou camada com um arquivo de gráficos vetoriais (como um arquivo do Adobe Illustrator) como a gravação de origem. Selecionar essa opção para uma camada de vetor faz com que o After Effects rasterize a camada para cada quadro, que melhora a qualidade da imagem, mas também aumenta o tempo necessário para visualizar e renderizar. (Consulte Ordem de renderização e recolher transformações e Rasterizar continuamente uma camada que contenha gráficos vetoriais.)

Qualidade 

Alterna entre opções Melhor e Rascunho para qualidade da camada para renderização, incluindo renderização para a tela para exibições. (Consulte Qualidade de imagem da camada e do posicionamento de subpixel.)

Efeito 

Selecione para renderizar a camada com efeitos. A opção não afeta a configuração para efeitos individuais na camada. (Consulte Excluir ou desativar predefinições de efeitos e animação.)

Mesclagem de quadros 

Define a mescla de quadros a um destes três estados: Mistura de quadros , Movimento de pixel  ou desativado. Se a opção de composição Ativar mesclagem de quadros não for selecionada, a configuração de mesclagem de quadros da camada é irrelevante. (Consulte Mesclagem de quadros.)

Desfoque de movimento 

Ativa ou desativa o desfoque de movimento para a camada. Se a opção de composição Ativar desfoque de movimento não estiver selecionada, a configuração de desfoque de movimento da camada é irrelevante. (Consulte Desfoque de movimento.)

Camada de ajuste 

Identifica a camada como uma camada de ajuste. (Consulte Camadas de ajuste.)

Camada 3D 

Identifica a camada como uma camada 3D. Se a camada é uma camada 3D com subcamadas 3D, como é o caso para uma camada de texto com propriedades 3D por caractere, a opção usa este ícone: . (Consulte Visão geral e recursos de camadas 3D.)

Alternar visibilidade ou influência de uma camada ou grupo de propriedades

A opção Vídeo para uma camada controla se as informações visuais de camada são renderizadas para visualizações ou para o resultado final. Se a camada é uma camada de ajuste, a opção Vídeo controla se os efeitos na camada são aplicados ao composto das camadas abaixo dela. Se a camada for uma câmera ou luz, a opção Vídeo controla se a camada está ativada ou desativada.

Vários componentes de camadas – como traçados de tinta, operações de caminhos em camadas de forma e animadores de texto em camadas de texto – cada uma tem suas próprias opções de vídeo. Você pode usar a opção Vídeo para alternar a visibilidade e influenciar esses itens individualmente.

  • Para desativar a visibilidade de uma camada desmarque a opção Vídeo para camada.
  • Para selecionar a opção Vídeo para todas as camadas, escolha Camada >Opções > Mostrar todo o vídeo.
  • Para desmarcar a opção Vídeo para todas as camadas exceto as camadas selecionadas, escolha Camada >Opções > Ocultar outro vídeo.

Isolar uma camada

Você pode isolar uma ou mais camadas para animação, exibição ou saída final isolando . Isolar exclui todas as outras camadas do mesmo tipo sendo renderizadas – para exibições no painel Composição e para a saída final. Por exemplo, se você isolar uma camada de vídeo, quaisquer camadas de vídeo ou áudio não são afetadas, então elas aparecem quando você exibe ou renderiza a composição. Contudo, as outras camadas de vídeo não serão exibidas.

  • Para isolar uma ou mais camadas, selecione as camadas no painel Linha de tempo e clique no ícone Isolar à esquerda dos nomes da camada.
  • Para isolar uma camada e não isolar todas as outras camadas, clique com a tecla Alt pressionada (Windows) ou clique com Option (Mac OS) no ícone Isolar à esquerda do nome da camada.

A opção Vídeo fica esmaecida para outras camadas quando uma camada é solada, indicando que as outras camadas não estão visíveis.

Lloyd Alvarez oferece um script em seu site After Effects Scripts com o qual você pode rotular camadas e, então, selecionar, desativar e isolar camadas de acordo com seus rótulos. As tags são adicionadas aos comentários na coluna Comentários do painel Linha de tempo.

Bloquear ou desbloquear uma camada

A opção Bloquear evita que as camadas sejam editadas por engano. Quando uma camada está bloqueada, você não pode selecioná-la nos painéis Composição ou Linha de tempo. Se você tentar selecionar ou modificar uma camada bloqueada, a camada pisca no painel Linha de tempo.

Quando uma camada é bloqueada, o ícone Bloquear aparece na coluna Recursos de A/V, que aparece por padrão à esquerda do nome da camada no painel Linha de tempo.

  • Para bloquear ou desbloquear uma camada, clique na opção Bloquear para a camada no painel Linha de tempo.
  • Para desbloquear todas as camadas na composição ativa, escolha Camada > Opções > Desbloquear todas as camadas.

Rótulos de cor para camadas, composições e itens de gravação

Você pode usar rótulos (caixas coloridas na coluna Rótulo) no painel Projeto e no painel Linha de tempo para organizar e gerenciar composições, itens de gravação e camadas. Por padrão, diferentes cores de rótulos indicam diferentes tipos de itens de gravação, mas você pode atribuir cores de rótulos para indicar qualquer categoria que você escolher.

Observação:

Renomeie grupos de rótulos para ajudá-lo a organizar e categorizar camadas e itens de gravação. Para ver os nomes de rótulos na coluna Rótulo, alargue a coluna maior que a largura padrão.

  • Para selecionar todas as camadas com a mesma cor do rótulo, selecione uma camada com a cor do rótulo e escolha Editar > Rótulo > Selecionar grupo de rótulos.
  • Para alterar a cor do rótulo de uma camada, clique no rótulo no painel Linha de tempo e escolha uma cor.
  • Para alterar a cor do rótulo de todas as camadas com a cor do rótulo, selecione uma das camadas que pertence ao grupo de rótulos, escolha Editar > Rótulo > Selecionar grupo de rótulos e escolha Editar > Rótulo > [nome da cor].
  • Para alterar os nomes e cores padrão para rótulos, escolha Editar > Preferências >Rótulos (Windows) ou After Effects > Preferências > Rótulos (Mac OS).
  • Para alterar as associações padrão de cores de rótulo com tipos de fontes, escolha Editar > Preferências > Rótulos (Windows) ou After Effects > Preferências > Rótulos (Mac OS).
  • Para desativar o uso da cor do rótulo de uma camada para as alças de camada e caminhos de movimento, escolha Editar > Preferências > Aparência (Windows) ou After Effects > Preferências > Aparência (Mac OS), e desmarque Usar cores de rótulo para alças e caminhos de camada.
  • Para desativar o uso da cor do rótulo de uma camada, item de gravação ou composição nas guias de painéis correspondentes, escolha Editar > Preferências > Aparência (Windows) ou After Effects > Preferências > Aparência (Mac OS) e desmarque Usar cores de rótulo para guias relacionadas.

Observação:

Por padrão, as cores do rótulo do painel não respondem ao controle Brilho nas preferências Aparência. Para fazer com que o controle Brilho afete as cores de rótulos do painel, selecione a opção Afeta cores de rótulos nas preferências Aparência.

Mostrar e ocultar camadas no painel Linha de tempo

Você pode marcar uma camada como inativa e, então, usar a opção de composição Ocultar camadas inativas no topo do painel Linha de tempo para ocultar todas as camadas inativas no contorno da camada do painel Linha de tempo. Tornar camadas inativas é útil para liberar espaço no painel Linha de tempo e exibir as camadas e as propriedades da camada que você deseja ajustar.

O ícone na coluna Opções indica se uma camada é inativa ou não inativa .

As camadas inativas continuam sendo renderizadas, para exibições e para a saída final. Para excluir camadas de exibições ou saída final, use a opção Vídeo ou faça a camada uma camada de guia.

  • Para alternar uma camada entre inativa e não inativa, clique na opção Recuar para a camada, ou selecione a camada no painel Linha de tempo e escolha Camada > Opções > Recuar.
  • Para alternar entre ocultar e mostrar todas as camadas esmaecidas, marque ou desmarque a opção de composição Ocultar camadas esmaecidas na parte superior do painel Linha do tempo, ou escolha Ocultar camadas esmaecidas no menu Linha de tempo.

Também é possível filtrar camadas no painel Linha de tempo para mostrar apenas camadas com propriedades correspondentes a uma sequência de pesquisa ou determinadas outras características. Consulte Pesquisar e filtrar nos painéis da Linha do tempo, Projeto e Efeitos e definições e Mostrar propriedades e grupos no painel Linha do tempo (atalhos de teclado).

Lloyd Alvarez oferece um script em seu site After Effects Scripts com o qual você pode rotular camadas e, então, selecionar, desativar e isolar camadas de acordo com seus rótulos. Os rótulos são adicionados aos comentários no campo Comentários do painel Linha de tempo.

Qualidade da imagem da camada e posicionamento de subpixels

A configuração da qualidade de uma camada determina com que precisão é renderizada, bem como influencia a precisão de outros cálculos que envolvem a camada, como o controle de movimento e uso da camada como uma camada de controle para um efeito composto.

Camadas duplicadas ou divididas mantêm a configuração da qualidade da camada original.

Você pode escolher entre três opções de qualidade: Melhor, Rascunho e Wireframe. Ao selecionar a opção Melhor, é possível selecionar entre amostragem bilinear e bicúbica, que são descritas na próxima seção. 

Para alternar entre as qualidades Melhor (amostragem bilinear), Rascunho e Melhor (amostragem bicúbica) das camadas selecionadas, clique no botão Qualidade no painel Linha do tempo. Para escolher dentre essas opções, além de Wireframe, selecione Camada > Qualidade:

Melhor

Exibe e renderiza uma camada usando o posicionamento de subpixels, suavização de borda, sombreamento em 3D e o cálculo total de todos os efeitos aplicados. Requer mais tempo para renderização – para exibições e para a saída final.

Rascunho

Exibe uma camada para poder vê-la, mas apenas com qualidade precária. A qualidade Rascunho exibe e renderiza uma camada sem suavização de bordo e posicionamento de subpixels, e alguns efeitos não são calculados com precisão.

Wireframe

Exibe uma camada como uma caixa, sem o conteúdo da camada. Os wireframes de camada são exibidos e renderizados mais rapidamente que as camadas renderizadas com as configurações de qualidade melhor ou de rascunho.

Amostragem bilinear e bicúbica

Para as camadas com qualidade definida como Melhor, é possível selecionar entre amostragem bicúbica e bilinear. Essa configuração por camada determina como ocorre a amostragem dos pixels para transformações, como dimensionamento.

Os atalhos padrão do teclado para a configuração do método de amostragem das camadas selecionadas são Alt+B (Windows) e Opção+B (Mac OS) para Melhor/Bilinear, e Alt+Shift+B (Windows) e Opção+Shift+B (Mac OS) para Melhor/Bicúbico.

A amostragem bicúbica exige mais do processador do que a bilinear, além de não ser a opção de maior qualidade em todos os casos. É fácil exibir os artefatos com a amostragem bicúbica em alguns casos, como ringing e overshoots em uma transição de uma cor para outra. A amostragem bicúbica tende a ser a melhor opção nos casos em que as transições de uma cor para outra são mais graduais, como ocorre em praticamente todas as imagens fotográficas reais, mas não necessariamente para gráficos de bordas sólidas. A amostragem bicúbica ajuda mais ao ampliar do que para reduzir.

Observação:

As texturas no renderizador 3D traçado não usam amostragem bicúbica; elas sempre usam amostragem bilinear. As transformações nos efeitos também usam amostragem bilinear, exceto quando o efeito implementa especificamente outro método (assim como um plug-in de dimensionamento ou efeito de distorção dedicado).

Posicionamento de subpixels

Os valores Propriedade (como Posição e Ponto de ancoragem) no After Effects não são restringidos a valores inteiros; podem ter valores fracionários, também. Isso permite a animação suave, como um valor é interpolado de um quadro-chave para outro. Por exemplo, se um valor de posição for de [0,0,0] em um quadro-chave na hora 0 em um valor [0,0,80] na hora 1 em uma composição de 25 quadros por segundo, o valor no quadro 1 é [0,0,3.2].

O After Effects calcula os valores espaciais, como Posição e pontos de controle de efeito para uma precisão de 1/65,536 de um pixel. Isso é chamado de precisão de subpixel.

Se os pixels de uma camada não forem posicionados diretamente nos limites de pixel da composição, uma pequena quantidade de desfoque ocorre – muito parecido com suavização de borda. Esse desfoque não é um problema para um objeto em movimento, como os objetos em movimento têm desfoque de movimento, mas pode suavizar pequenos detalhes em uma imagem estática. Além disso, se uma imagem estiver se movendo lentamente ou apenas na velocidade incorreta, a imagem pode parecer oscilar entre a nitidez e borrões.

Como o ponto de ancoragem padrão para uma camada será o centro de um objeto, os objetos impares dimensionados têm pontos de ancoragem não inteiros e aparecerão suaves quando posicionados em valores inteiros. Para minimizar níveis de desfoque e zoom no resultado de foco, siga estas instruções:

  • Crie gráficos com dimensões pares ou ímpares, com base nas dimensões da composição. Por exemplo, se a composição for 640x480 pixels, crie gráficos com as dimensões pares (como os pixels 100x100); se a composição for 99x99 pixels, crie gráficos com dimensões ímpares (como os pixels 75x53).

  • Defina informações de posição para gráficos (incluindo os quadros-chave de propriedade e posição final) para números inteiros e números não fracionários.

Rasterizar continuamente uma camada contendo gráficos vetoriais

Quando você importa gráficos vetoriais, o After Effects os rasteriza automaticamente. Contudo, se quiser dimensionar uma camada que contenha gráficos vetoriais acima de 100%, você precisa rasterizar continuamente a camada para manter a qualidade da imagem. É possível rasterizar continuamente gráficos vetoriais em camadas baseadas em arquivos do Illustrator, SWF, EPS e PDF. A rasterização contínua faz com After Effects rasterize o arquivo conforme necessário com base na transformação para cada quadro. Uma camada rasterizada continuamente geralmente produz resultados de maior qualidade, mas pode renderizar mais lentamente.

As camadas de forma e camadas de texto sempre serão rasterizadas continuamente.

Quando você aplica um efeito a uma camada rasterizada continuamente, os resultados podem variar dos resultados de aplicar o efeito a uma camada sem rasterização contínua. Essa diferença nos resultados deve-se à ordem de renderização padrão para as mudanças da camada. A ordem de renderização padrão para uma camada sem rasterização contínua é máscaras, seguida de efeitos e transformações; enquanto a ordem de renderização padrão para uma camada rasterizada continuamente é máscaras, seguida de transformações e efeitos.

Mesmo que você rasterize ou não continuamente, se você exibir e renderizar uma composição usando Melhor qualidade, o After Effectssuaviza os gráficos vetoriais.

Não é possível abrir ou interagir com uma camada rasterizada continuamente em um painel Camada. O resultado dessa limitação é que você não pode pintar diretamente em uma camada rasterizada continuamente. No entanto, você pode copiar e colar traçados de tinta das outras camadas.

Imagem de um arquivo importado do Illustrator com camada rasterizada
Imagem de arquivo importado do Illustrator

A. Original B. Ampliada com a opção Rasterizar continuamente desativada C. Ampliada com a opção Rasterizar continuamente ativada 
  1. No painel Linha de tempo, clique na opção da camada Rasterizar continuamente , que é semelhante à opção Recolher transformações para camadas de pré-composição.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online