Trabalhar com animação orientada por dados

  1. Guia do usuário do After Effects
  2. Versões beta
    1. Visão geral do programa Beta
    2. Página inicial do After Effects Beta
  3. Introdução
    1. Introdução ao After Effects
    2. Novidades no After Effects 
    3. Notas de versão | After Effects
    4. Requisitos de sistema do After Effects
    5. Atalhos de teclado no After Effects
    6. Formatos de arquivo compatíveis | After Effects
    7. Recomendações de hardware
    8. Planejamento e configuração
    9. Configuração e instalação
  4. Espaços de trabalho
    1. Itens gerais da interface do usuário
    2. Conheça a interface do After Effects
    3. Fluxos de trabalho
    4. Espaços de trabalho, painéis e visualizadores
  5. Projetos e composições
    1. Projetos
    2. Noções básicas da composição
    3. Pré-composição, aninhamento e pré-renderização
    4. Exibir informações detalhadas de desempenho com o Criador de perfil de composição
    5. Renderizador de composição CINEMA 4D
  6. Importação de gravação
    1. Preparação e importação de imagens estáticas
    2. Importação do After Effects e do Adobe Premiere Pro
    3. Importação e interpretação de vídeo e áudio
    4. Preparo e importação de arquivos de imagem 3D
    5. Importação e interpretação de itens de gravação
    6. Trabalhar com itens de gravação
    7. Metadados XMP
  7. Trabalho com texto e gráficos
    1. Texto
      1. Formatação de caracteres e o painel Caractere
      2. Efeitos de texto
      3. Criação e edição de camadas de texto
      4. Formatação de parágrafos e o painel Parágrafo
      5. Extrusão de texto e camadas de forma
      6. Animação de texto
      7. Exemplos e recursos de animação de texto
      8. Modelos de texto dinâmico
    2. Animações
      1. Trabalhar com Modelos de animações no After Effects
      2. Usar expressões para criar listas suspensas em Modelos de animações
      3. Trabalhar com propriedades essenciais para criar Modelos de animações
      4. Substituir imagens e vídeos em Modelos de animações e Propriedades essenciais
  8. Desenho, pintura e caminhos
    1. Visão geral de camadas de forma, caminhos e gráficos vetoriais
    2. Ferramentas de pintura: Pincel, Carimbo e Borracha
    3. Como afunilar traçados de forma
    4. Atributos de forma, operações de pintura e operações de caminho para camadas de forma
    5. Use o efeito de forma Deslocar caminhos para alterar formas
    6. Criação de formas
    7. Criar máscaras
    8. Remover objetos de seus vídeos com o painel Preenchimento com reconhecimento de conteúdo
    9. Pincel tipo rotoscópio e Refinar fosco
  9. Trabalho com camadas
    1. Seleção e organização de camadas
    2. Modos de mesclagem e estilos de camadas
    3. Camadas 3D
    4. Propriedades da camada
    5. Criação de camadas
    6. Gerenciamento de camadas
    7. Marcadores de camada e de composição
    8. Câmeras, luzes e pontos de interesse
  10. Animação, quadro-chave, rastreamento de movimento e chaveamento
    1. Animação
      1. Noções básicas de animação
      2. Animação com ferramentas Marionete
      3. Gerenciamento e animação de caminhos de forma e máscaras
      4. Animação de desenho e captura de formas usando o After Effects
      5. Ferramentas de animação diversas
      6. Trabalhar com animação orientada por dados
    2. Quadro-chave
      1. Interpolação do quadro-chave
      2. Definir, selecionar e excluir quadros-chave
      3. Editar, mover e copiar quadros-chave
    3. Rastreamento de movimento
      1. Rastrear e estabilizar movimento
      2. Reconhecimento facial
      3. Rastreamento de máscara
      4. Referência de máscara
      5. Velocidade
      6. Esticamento e remapeamento de tempo
      7. Timecode e unidades de exibição de tempo
    4. Aplicação de máscara
      1. Aplicação de máscara
      2. Efeitos de máscara
  11. Transparência e composição
    1. Visão geral e recursos da composição e transparência
    2. Canais alfa, máscaras e foscos
  12. Ajustar cor
    1. Noções básicas de cores
    2. Uso da extensão de temas do Adobe Color
    3. Gerenciamento de cores
    4. Efeitos de correção de cores
  13. Efeitos e predefinições de animação
    1. Visão geral dos efeitos e predefinições de animação
    2. Lista de efeitos
    3. Efeitos de simulação
    4. Efeitos de estilo
    5. Efeitos de áudio
    6. Efeitos de distorção
    7. Efeitos de perspectiva
    8. Efeitos de canal
    9. Efeitos de geração
    10. Efeitos de transição
    11. O efeito Reparo do obturador de rolagem
    12. Efeitos Desfoque e Nitidez
    13. Efeitos de Canal 3D
    14. Efeitos de utilitários
    15. Efeitos de fosco
    16. Efeitos Ruído e Granulação
    17. Efeito Ampliação com preservação de detalhes
    18. Efeitos obsoletos
  14. Expressões e automação
    1. Expressão
      1. Noções básicas de expressão
      2. Entender sobre a linguagem de expressões
      3. Utilização de controles de expressão
      4. Diferenças de sintaxe entre os mecanismos de expressão Javascript e Legacy ExtendScript
      5. Edição de expressões
      6. Erros de expressão
      7. Utilização do editor de expressões
      8. Usar expressões para editar e acessar propriedades de texto
      9. Referência de linguagem de expressão
      10. Exemplos de expressão
    2. Automação
      1. Automação
      2. Scripts
  15. Vídeo imersivo, VR e 3D
    1. Criar ambientes de VR no After Effects
    2. Aplicar efeitos de vídeo imersivo
    3. Ferramentas de composição para vídeos VR/360
    4. Rastreamento de movimento de câmera 3D
    5. Trabalhar no Espaço de design 3D
    6. Visualização de alterações em projetos 3D em tempo real com o Mecanismo em tempo real
    7. Adicionar design responsivo aos gráficos 
  16. Exibições e visualizações
    1. Visualizar
    2. Visualização de vídeo com o Mercury Transmit
    3. Modificação e utilização de exibições
  17. Renderização e exportação
    1. Noções básicas de renderização e exportação
    2. Exportar um projeto do After Effects como um projeto do Adobe Premiere Pro
    3. Conversão de filmes
    4. Renderização de vários quadros
    5. Renderização automatizada e renderização de rede
    6. Renderização e exportação de imagens estáticas e sequências de imagens estáticas
    7. Utilização do codec GoPro CineForm no After Effects
  18. Trabalho com outros aplicativos
    1. Dynamic Link e After Effects
    2. Trabalhar com o After Effects e outros aplicativos
    3. Sincronizar configurações no After Effects
    4. Colaborar com o Team Projects
    5. Compartilhar e gerenciar alterações com colaboradores de Team Projects
    6. Bibliotecas da Creative Cloud no After Effects
    7. Plug-ins
    8. CINEMA 4D e Cineware
  19. Memória, armazenamento e desempenho
    1. Memória e armazenamento
    2. Melhorar o desempenho
    3. Preferências
    4. GPU e os requisitos de driver de GPU para o After Effects

Use o documento para aprender a trabalhar com animação orientada por dados

As animações orientadas por dados são criadas com dados dinâmicos coletados de diversas fontes de dados que orientam as animações na composição. Você pode usar dados de várias fontes de dados. Os dados podem ser estáticos ou variáveis com o tempo. Você pode importar os dados para seu projeto do After Effects e usá-los como entrada para animar gráficos, personagens, controlar efeitos visuais e títulos de filmes, além de outras animações.

Exemplo de animação orientada por dados
Exemplo de animação orientada por dados

Fontes de dados

Você pode usar dados de quase todas as fontes possível, como:

  • Arquivos de dados gerados pelo dispositivo: dados de dispositivos, como monitores de atividade física, que registram a atividade por meio de sensores e armazenam os dados em formatos de arquivo diferentes. Estes dados com variação de tempo incluem: velocidade, altitude, distância, frequência cardíaca e outros parâmetros de atividade do usuário.
  • Dados estáticos gerados pelo usuário: dados estáticos globais como resultados de pesquisa que podem ser alterados para orientar gráficos. Um arquivo de dados criado pelo usuário pode fornecer um fluxo de trabalho para dados globais.
  • URL: os dados em tempo real de sites como caminho de entrada e saída de um usuário que navega por uma página da Web.
  • Metadados: dados inseridos nos Metadados do arquivo de vídeo.

Formatos de entrada

É possível importar arquivos de dados nos seguintes formatos:

  • JSON
  • MGJSON
  • CSV
  • TSV

Caso os arquivos de dados estejam em outro formato, converta-os para algum dos formatos de arquivo suportados e importe-os para o projeto do After Effects. Existem várias ferramentas de conversão disponíveis para converter arquivos de dados em formatos compatíveis com o After Effects.

Animação orientada por dados

Suporte a JSON padrão (.json)

Você pode importar um arquivo padrão JSON para o After Effects como gravação e os arquivos de dados funcionarão no plano de fundo. O After Effects faz referência direta aos dados nesses arquivos de dados para orientar animações dentro dos projetos. A gravação JSON não é representada como fluxos de dados no painel Linha de tempo. Você pode referenciar os dados usando expressões como um objeto JSON avaliado.

Você pode modificar as expressões para alterar como os dados são consultados. Você pode gravar os dados em um editor de texto, consultado pelo After Effects para orientar animações. O suporte a JSON é baseado no esquema JSON, que especifica e define como um aplicativo usa e modifica dados JSON.

Os tipos de dados básicos de JSON são:

  • Número: um número decimal assinado.
  • Sequência de caracteres: uma sequência de nenhum ou mais caracteres Unicode.
  • Booleano: valores true ou false.
  • Matriz: uma lista ordenada de zero ou mais valores.
  • Objeto: uma coleção ordenada de pares de nome ou de valor, na qual os nomes (chaves) são sequências de caracteres.
  • Nulo: um valor vazio, usando a palavra “nulo”.

Trabalhar com um arquivo JSON no After Effects

Para trabalhar com um arquivo JSON padrão, siga estas etapas:

  1. Selecione Arquivo > Importar.

  2. Para importar, selecione  um  arquivo JSON e clique em Abrir.

  3. O arquivo é adicionado à janela do projeto. Crie uma composição com a gravação.

  4. Adicione um sólido à composição. Para adicionar um sólido, selecione Camada > Sólido.

  5. No painel Linha de tempo, gire para abrir as propriedades da camada do sólido e Alt+Clique no parâmetro Opacidade.

  6. Altere os dados na expressão para modificar sua animação. Você pode controlar os dados JSON e os dados referenciados do arquivo de dados no qual todas as informações estão armazenada.

  7. Você também pode substituir o arquivo JSON por outro arquivo JSON a fim de alterar os dados consultados. Para substituir, selecione Substituir gravação > Arquivo e abra o novo arquivo no computador.

Para usar os dados, aplique uma expressão na propriedade na qual deseja orientar os dados, e depois:

  1. Use o atributo sourceData para ler os dados em um arquivo .JSON. Por exemplo:

    var sampleData = footage("sample.json").sourceData;
  2. Para retornar o valor, referencie a propriedade específica dentro dos dados JSON. Por exemplo,

    myData.engineData.RPM or myData.latitude.value.

Suporte a animações JSON (.mgjson)

Você pode importar um arquivo de dados MGJSON como uma gravação para seu projeto. Ao adicionar a gravação de dados a uma composição, os fluxos de propriedades de dados são agrupados em um conjunto de nível superior, “Dados”. O grupo Dados exibe dados de gravação como Propriedades. Cada propriedade no grupo de dados é a expressão vinculada de volta ao arquivo de gravação que acessa o valor do arquivo de dados usando expressão footage("foo.mgjson").dataValue(N). Aqui N é o caminho para o fluxo de dados no arquivo. O MGJSON funciona com base em um esquema, que é criado para simplificar a referenciação e importação de fluxos de dados no After Effects.

Cada propriedade de dados tem uma expressão aplicada que vincula a propriedade aos dados no arquivo MGJSON. Se o arquivo de origem MGJSON for alterado, os valores da propriedade de dados serão atualizados automaticamente.

No painel Linha de tempo, você pode girar para abrir as Camadas de dados e usar a seleção para vincular parâmetros a outros parâmetros. As alterações são preenchidas automaticamente.

Trabalhar com gravações MGJSON no After Effects

Para trabalhar com um arquivo MGJSON, siga estas etapas:

  1. Selecione Arquivo > Importar.

  2. Para importar, selecione um arquivo MGJSON e clique em Abrir.

  3. O arquivo é adicionado à janela do projeto. Crie uma composição com a gravação.

  4. Importe um ativo para o projeto e adicione-o à composição.

  5. No painel Linha de tempo, gire para abrir as propriedades da gravação.

  6. Escolha uma das propriedades do ativo, por exemplo Rotação, para um dos fluxos de dados na camada de dados. A propriedade do ativo agora consulta os dados da camada de dados. Cada fluxo de dados refletido tem uma expressão que atrai o valor do arquivo de gravação.

  7. Quando você visualiza a gravação, o ativo é animado com base no fluxo de dados da camada de dados.

Você também pode converter as amostras de dados do arquivo de dados em quadros-chave. Para converter em quadros-chave, siga estas etapas:

  1. Importe o arquivo MGJSON no projeto e arraste-o para o painel Linha do tempo.

  2. Clique com o botão direito do mouse na camada de dados e selecione Assistente de quadros-chave > Criar quadros-chave a partir dos dados no menu Assistente de camadas e de quadros-chave.

  3. Para exibir os quadros-chave, gire para abrir a camada de dados.

Observação:

Após a conversão do quadro-chave, os dados não serão mais dinâmicos e não serão referenciados no arquivo de dados.

Você também pode exibir dados em tempo real como um gráfico no Editor de gráficos. Para visualizar, clique no ícone Editor de gráficos no painel Linha de tempo.

A animação orientada por dados usa referência da expressão. Para ter mais informações, consulte Animação orientada por dados (referência da expressão).

Alinhar vídeo ao tempo dos dados mgJSON

O comando Camada > Tempo > Alinhar vídeo aos dados desloca as camadas de vídeo em vários quadros, como especificado em um arquivo mgJSON. É possível esse comando para alinhar vídeos ao tempo das amostras de dados armazenadas em um arquivo mgJSON correspondente. Por exemplo, se você capturou dados durante uma corrida, mas o tempo de início do vídeo não corresponde ao tempo de início dos dados capturados, é possível especificar o deslocamento para que os dados sejam alinhados automaticamente.

Para alinhar o vídeo ao tempo dos dados mgJSON, siga estas etapas:

  1. Adicione o arquivo .mgJSON a uma composição que também tenha as camadas de destino.
  2. Selecione a camada .mgJSON e as camadas de destino.
  3. Selecione Camada > Tempo > Alinhar vídeo aos dados.

Para que isso funcione, o arquivo mgJSON deve conter um grupo videoSyncTimeList com:

  • O nome de uma ou mais camadas de destino (fileName)
  • O número de quadros para deslocar (frameNumber) as camadas do início da camada de dados.

Por exemplo:

"videoSyncTimeList": [
  {
    "fileName": "sample1.mp4",
    "frameNumber": 1000
  },

  {
    "fileName": "sample2.mp4",
    "frameNumber": -1000
  }

Um valor fileName deve ser o nome da camada selecionada, e não o nome de origem da camada. Se você alterar o nome de uma camada com uma origem na composição, por exemplo, renomear a camada "sample1.mp4" para "Race Camera 1", também será necessário alterar o valor fileName no arquivo mgJSON para corresponder a ela. As camadas referenciadas por fileName não precisam ser itens de gravação com um arquivo de origem. Elas também podem ser composições sólidas, alinhadas ou outros tipos de camadas.

Valores frameNumber positivos deslocam a camada de destino para a esquerda (antes da camada de dados). Valores frameNumber negativos deslocam a camada de destino para a direita (depois da camada de dados). Um valor de frameNumber 0 alinha o início da camada de destino ao início da camada de dados.

Compatível com CSV (.csv) e TSV (.tsv ou .txt)

É possível importar arquivos comma-separated value (.csv) e Tab-separated value (.tsv or .txt) como gravação para o After Effects e usá-los como fontes de dados. Arquivos CSV e TSV armazenam dados tabulares em formato de texto simples com valores separados por vírgulas ou caracteres de tabulação. Os arquivos de dados CSV e TSV funcionam de forma semelhante aos arquivos JSON.

Para usar os arquivos CSV ou TSV no After Effects, siga estas etapas:

  1. Importe o arquivo CSV ou TSV para o seu projeto como gravação, de maneira parecida com como a importação de um vídeo, áudio ou outros arquivos. Use as seguintes formas para importar os arquivos como gravação:
    • Selecione Arquivo > Importar.
    • Clique com o botão direito no painel Projetos e selecione Importar > Tipo de arquivo.
    • Clique com o botão direito no painel Projetos.
  2. O arquivo é adicionado à janela do projeto. Crie uma composição com o arquivo.

  3. No painel Linha do tempo, gire para abrir as propriedades da gravação. Vincule as propriedades de dados da camada na composição a outra camada com o ícone de seleção de expressão ou o ícone de seleção Vincular propriedade. Para abrir o campo de texto de expressões, pressioneShift e clique no ícone de cronômetro ao lado do nome da camada. Também é possível vincular por meio do comando Editar > Copiar com vínculos de propriedade .

    Para saber mais sobre as propriedades de dados na Linha do tempo, consulte Noções básicas das propriedades de dados.

  4.  Para referenciar o arquivo de gravação de dados, use uma expressão na propriedade em que você deseja orientar os dados. Use o atributo de gravação dataValue() para ler os dados de uma linha e coluna específicas. Linhas e colunas são indexadas com zero. Por exemplo, footage("sample.tsv").dataValue([15,1]) retorna o valor na linha 16 da segunda coluna.

Noções básicas de propriedades de dados

Ao adicionar um arquivo JSON, CSV ou TSV a uma composição e abrir as propriedades, elas conterão apenas um grupo de propriedades de Dados, em vez do grupo de propriedades Transformar. O grupo de propriedades de Dados contém a hierarquia dos dados conforme definido no arquivo.

Grupo de propriedades de Dados JSON no painel Linha do tempo

Grupo de propriedades de Dados CSV e TSV no painel Linha do tempo

Esse grupo de dados é parecido a como o After Effects trata os arquivos de animação JSON (.mgJSON). A diferença é que JSON, CSV e TSV só podem conter valores de dados estáticos, e .mgJSON pode conter dados dinâmicos (dados que mudam com o tempo).

Cada propriedade de dados individual tem uma expressão aplicada que vincula essa propriedade aos dados no arquivo JSON, CSV ou TSV.  Se você alterar o arquivo de dados de origem, os valores da propriedade de dados refletirão a alteração.

Vincular propriedades ao ícone de seleção Vincular propriedade

Caso você não deseje escrever expressões complexas, é possível usar o ícone de seleção Vincular propriedadeou o comando Editar > Copiar com vínculos de propriedade para vincular as propriedades de dados às propriedades de outras camadas. Ao vincular as camadas, o ícone de seleção Vincular propriedadeescreve automaticamente as expressões.

Bibliotecas de função de expressão personalizada - JSX

No After Effects 15.0, era possível importar um arquivo JSON que definia as funções JavaScript, que poderiam ser usadas como uma biblioteca de funções de expressão personalizadas. No After Effects 15.1, os objetos do JavaScrpt não são uma sintaxe legal para JSON. O After Effects 15.1 usa um analisador rigoroso, que não permite a importação de um arquivo JSON com sintaxe ilegal.

Se você tentar importar um arquivo JSON com uma função de JavaScript definida no After Effects 15.1 ou abrir um projeto que tenha um arquivo assim, o After Effects exibirá um erro.

Para evitar o problema, é possível importar um arquivo de extensão de sintaxe JavaScript (.jsx) para o After Effects 15.1. O conteúdo do arquivo JSX pode ser o mesmo que um arquivo JSON importado para o After Effects 15.0, só é necessário alterar a extensão do nome do arquivo para .jsx. Se você abrir um projeto existente que tenha um arquivo JSON que não funcione, vá em Arquivo > Substituir gravação para substituir o arquivo JSON pelo arquivo JSX. As referências de expressão ao arquivo JSON são substituídas pelas referências ao arquivo JSX.

Problemas conhecidos com a animação orientada por dados

Ao trabalhar com animações orientadas por dados no After Effects, é possível que você enfrente alguns problemas. Para ver uma lista completa, consulte problemas conhecidos com animações orientadas por dados.

Logotipo da Adobe

Fazer logon em sua conta