Criar e modificar formas e máscaras usando as ferramentas de forma e caneta e os caminhos de cópia no After Effects a partir do Illustrator e do Photoshop.

Crie uma camada de forma desenhando no painel Composição com uma ferramenta de forma ou a ferramenta Caneta. Você pode depois adicionar atributos de forma a formas existentes ou criar novas formas nessa camada de forma. Por padrão, ao desenhar no painel Composição quando uma camada de forma estiver selecionada, você cria uma nova forma em essa camada de forma, acima das formas ou do grupo de formas selecionadas. Quando estiver selecionada uma camada de imagem diferente da camada de forma e você desenhar no painel Composição com uma ferramenta Forma ou Caneta, você cria uma máscara. Para obter mais informações, consulte Criar máscaras no After Effects.

O atalho da ferramenta Forma é Q, e o da ferramenta Caneta é G.

Heroimage

Observação:

Antes de desenhar no painel Composição para criar uma camada de forma, pressione F2 para desmarcar todas as camadas.

Na maioria dos casos, uma nova forma tem um preenchimento e um traçado que corresponda às configurações Preenchimento e Traçado no painel Ferramentas quando a forma é desenhada. Você pode usar os mesmos controles no painel Ferramentas para alterar esses atributos para uma forma selecionada após ter sido desenhada. As formas criadas a partir de texto são criadas com preenchimentos e traçados que correspondem aos preenchimentos e traçados do texto original.

Converter gravação de imagens de arte vetorial em formas

Agora é possível criar uma camada de forma a partir de uma camada de gravação de arte vetorial e depois modificar a camada de forma. Com as funções de chanfro e extrusão de objetos no After Effects, também é possível excluir o trabalho artístico, como logotipos. Para obter mais informações, consulte Extrusão de texto e camadas de forma.

Para converter uma camada de gravação de arte vetorial em uma camada de forma, selecione Camada > Criar > Criar formas a partir da camada de vetor. Aparecerá uma camada de forma correspondente acima da camada de gravação, que será silenciada.

  • Nem todos os recursos de arquivos do Illustrator continuam ativos. São exemplos: opacidade, imagens e gradientes.
  • As formas convertidas ignoram as substituições PAR especificadas na caixa de diálogo Interpretar gravação.
  • Gradientes e tipos não compatíveis podem aparecer como formas 50% cinzas.
  • Arquivos com milhares de caminhos podem ser importados muito lentamente sem feedback.
  • O comando de menu funciona em uma só camada selecionada por vez.
  • Se você importar um arquivo do Illustrator como composição (ou seja, várias camadas), não será possível converter todas as camadas de uma vez. No entanto, é possível importar o arquivo como gravação e usar o comando para converter a camada única de gravação em formas.

Criar uma forma arrastando com as ferramentas de forma

As ferramentas de forma são as ferramentas Retângulo , Retângulo arredondado , Elipse , Polígono e Estrela .

Observação:

Para ativar e percorrer as ferramentas de forma, pressione Q.

Um polígono é uma estrela sem uma propriedade Raio interno ou Arredondamento interno. Por isso o nome da forma criada para um polígono ou uma estrela é o mesmo: poliestrela.

Você pode criar uma máscara arrastando com uma ferramenta de forma em uma camada selecionada no painel Composição ou no painel Camada. Você pode criar uma forma arrastando com uma ferramenta de forma em uma camada de forma selecionada no painel Composição. Se você arrastar com uma ferramenta de forma no painel Composição sem nenhuma camada selecionada, você cria uma forma em uma nova camada de forma.

Observação:

Para desenhar uma máscara em uma camada de forma, clique em Criar máscara no painel Ferramentas com uma ferramenta de forma ativada.

Ao criar uma forma arrastando com uma ferramenta de forma no painel Composição, você cria um caminho de forma paramétrica. Para criar um caminho da forma de Bézier, pressione a tecla Alt (Windows) ou Option (Mac OS) antes de clicar para começar a arrastar. Solte a tecla antes de concluir a operação de arrastar. Todos os caminhos de máscara são caminhos de Bézier. (Consulte Sobre formas e camadas de forma.)

A operação de arrastar começa quando você clica no painel Composição ou no painel Camada para começar a desenhar e termina quando você solta o botão do mouse. Pressionar teclas modificadoras em momentos diferentes durante uma operação de arrastar gera resultados diferentes:

  • Para reposicionar uma forma ou uma máscara enquanto estiver desenhando, mantenha a barra de espaço ou o botão do meio do mouse pressionados ao arrastar.

  • Para redimensionar um círculo, elipse, quadrado, quadrado arredondado, retângulo ou retângulo arredondado ao redor de seu centro enquanto desenha, mantenha pressionada a tecla Ctrl (Windows) ou Command (Mac OS) depois de começar a arrastar. Não solte a tecla até você soltar o botão do mouse para terminar de desenhar.

  • Para cancelar a operação de desenho, pressione Esc.

Observação:

Cada ferramenta de forma mantém as configurações da operação de desenho mais recente com essa ferramenta. Por exemplo, se você desenhar uma estrela e modificar o número de pontos para ser 10, então a próxima estrela que você desenhar também terá 10 pontos. Para redefinir as configurações de uma ferramenta e criar uma forma com as configurações padrão, clique duas vezes na ferramenta no painel Ferramentas. (Consulte Criar uma forma ou máscara com o tamanho da camada.)

Desenhar retângulos, retângulo arredondados, quadrados e quadrados arredondados

  1. Selecione a ferramenta Retângulo ou Retângulo arredondado e faça o seguinte:
    • Para desenhar um retângulo ou um retângulo arredondado, arraste na diagonal.
    • Para desenhar um quadrado ou um quadrado arredondado, pressione Shift e arraste na diagonal.
Rectangle

2.  (Opcional) Se desenhar um retângulo arredondado ou quadrado arredondado, faça o seguinte antes de soltar o botão do mouse:

  • Para aumentar ou diminuir o arredondamento do canto, pressione a tecla de seta para cima ou para baixo ou mova a roda do mouse para a frente ou para trás.
  • Para definir o arredondamento do canto para o mínimo ou o máximo, pressione a tecla de seta para a esquerda ou para a direita.

3.  Termine de desenhar soltando o botão do mouse. Se desenhar um quadrado ou um quadrado arredondado, solte a tecla Shift após soltar o botão do mouse.

Observação:

Os quadrados são criados para serem quadrados de acordo com as proporções de pixel da composição. Se as proporções de pixel da composição não forem 1, os quadrados aparecem no painel Composição somente se o botão Alternar proporções de pixel estiver selecionado na parte inferior do painel Composição.

Desenhar elipses e círculos

  1. Selecione a ferramenta Elipse e siga um destes procedimentos:
    • Para desenhar uma elipse, arraste na diagonal.
    • Para desenhar um círculo, pressione a tecla Shift e arraste na diagonal.
  2. Solte o do mouse para terminar de desenhar. Se desenhar um círculo, solte a tecla Shift após soltar o botão do mouse.
Circle

Observação:

Os círculos são criados para serem circulares de acordo com as proporções de pixel da composição. Se as proporções de pixel da composição não forem 1, os círculos aparecem no painel Composição somente se o botão Alternar proporções de pixel estiver selecionado na parte inferior do painel Composição.

Desenhar polígonos e estrelas

  1. Selecione a ferramenta Polígono ou Estrela e faça o seguinte:
    • Arraste para redimensionar e girar o polígono ou estrela enquanto desenha.
    • Pressione a tecla Shift e arraste para dimensionar polígono ou a estrela enquanto desenha, impedindo a rotação.
Starploygon

2.  (Opcional) Faça o seguinte antes de soltar o botão do mouse:

  • Para adicionar ou remover pontos, pressione a tecla de seta para cima ou para baixo ou rode movimente a roda do mouse para a frente ou para trás.
  • Para aumentar ou diminuir o arredondamento externo, pressione a tecla de seta para a esquerda ou para a direita.
  • Para manter o raio interno de uma constante em estrela à medida que você move o mouse para aumentar o raio externo, mantenha pressionada a tecla Ctrl (Windows) ou Command (Mac OS).
  • Para aumentar ou diminuir o arredondamento interno de uma estrela, pressione a tecla Page Up ou Page Down.

3.  Solte o botão do mouse para terminar de desenhar. Se arrastar com a tecla Shift pressionada para impedir a rotação, solte a tecla Shift após soltar o botão do mouse.

Crie uma forma ou uma máscara de Bézier usando a ferramenta Caneta

Você pode criar uma máscara de Bézier usando a ferramenta Caneta em uma camada selecionada no painel Composição ou no painel Camada. Você pode criar uma forma com um caminho de Bézier usando a ferramenta Caneta em uma camada de forma selecionada no painel Composição. Se você desenhar com a ferramenta Caneta no painel Composição sem nenhuma camada selecionada, você cria uma forma em uma nova camada de forma.

Crie um caminho de RotoBézier é semelhante à criação de um caminho de Bézier manual. A principal diferença é que as linhas de direção de vértices e a curvatura de segmentos de caminho são calculadas automaticamente.

Criar um caminho de Bézier manual usando a ferramenta Caneta

  1. Com a ferramenta Caneta selecionada e a opção RotoBézier desmarcada no painel Ferramentas, clique no painel Composição onde deseja inserir o primeiro vértice.
  2. Clique onde deseja colocar o próximo vértice. Para criar um segmento curvado, arraste a alça da linha de direção para criar a curva desejada.

    Observação:

    Para reposicionar um vértice depois que você clicou para posicioná-lo, mas antes tiver soltado o botão do mouse, mantenha pressionada a barra de espaço enquanto arrasta.

    O último vértice que você adiciona aparece como um quadrado sólido, indicando que ele está selecionado. Os vértices adicionados anteriormente tornam-se vazados e desmarcados, ao adicionar mais vértices.

  3. Repita a etapa 2 até que você esteja pronto para finalizar o caminho.
  4. Finalize o caminho executando um dos seguintes procedimentos:
    • Para fechar o caminho, posicione o ponteiro sobre o primeiro vértice e, quando o ícone de círculo fechado aparecer junto ao ponteiro , clique no vértice. Também é possível fechar um caminho clicando duas vezes no último vértice ou selecionando Camada > Caminho de máscara e de forma > Fechado.
    • Para deixar o caminho aberto, ative uma ferramenta diferente, ou pressione F2 para desmarcar o caminho.

Desenhar segmentos de caminho de Bézier manuais retos com a ferramenta Caneta

O caminho mais simples que você pode desenhar com a ferramenta Caneta é uma linha reta, que é feita clicando com a ferramenta Caneta para criar dois vértices. Se você continuar clicando, é possível criar um caminho composto de segmentos de linha reta conectados por pontos de vértice.

  1. Posicione a ferramenta Caneta onde deseja que o segmento reto inicie e clique para posicionar um vértice. (Não arraste.)
    Clicar com a ferramenta Caneta cria segmentos retos
    Clicar com a ferramenta Caneta cria segmentos retos.
  2. Clique novamente onde você deseja que o segmento termine. (Clique com a tecla Shift pressionada para restringir o ângulo entre segmentos no ponto de vértice a um múltiplo inteiro de 45°.)
  3. Continue clicando para definir vértices para segmentos retos adicionais.

Desenhar segmentos de caminho de Bézier manuais curvados com a ferramenta Caneta

Crie um segmento de caminho curvado arrastando as linhas de direção. O comprimento e a direção das linhas de direção determinam a forma da curva.

Observação:

Arraste com a tecla Shift pressionada para restringir o ângulo das linhas de direção a múltiplos inteiros de 45°. Arraste com a tecla Alt (Windows) ou com a tecla Option (Mac OS) pressionada para modificar apenas a linha de direção de saída.

1.  Posicione a ferramenta Caneta no local onde deseja que a curva inicie e mantenha o botão do mouse pressionado. É exibido um vértice, e o ponteiro da ferramenta Caneta muda para uma seta.

2.  Arraste para alterar o comprimento e a direção de ambas as linhas de direção de um vértice e depois solte o botão do mouse.

Desenhando o primeiro vértice em um caminho curvado
Desenhando o primeiro vértice em um caminho curvado

A. Posicionando a ferramenta Caneta B. Começando a arrastar (botão do mouse pressionado) C. Arrastando para estender as linhas de direção 

3.  Posicione a ferramenta Caneta no local em que deseja que o segmento curvado termine e execute um dos procedimentos a seguir:

  • Para criar uma curva em forma de C, arraste na direção oposta da direção que você arrastou a linha de direção anterior e depois solte o botão do mouse.
Desenhando o segundo vértice em um caminho curvado
Desenhando o segundo vértice em um caminho curvado

A. Começando a arrastar B. Arrastando longe da linha de direção anterior, criando uma curva C C. Resultado após soltar o botão do mouse 
  • Para criar uma curva em S, arraste na mesma direção da linha de direção anterior e depois solte o botão do mouse.
Desenho de uma curva S
Desenho de uma curva S

A. Começando a arrastar B. Arrastando na mesma direção da linha de direção anterior, criando uma curva S C. Resultado após soltar o botão do mouse 

4.  Continue arrastando a ferramenta Caneta a partir de locais diferentes para criar uma série de curvas suaves.

Criar uma forma ou máscara com o tamanho da camada

  1. Selecione o destino da nova forma:

    • Para criar uma forma em uma camada de forma existente, selecione a camada de forma.
    • Para criar uma forma em uma nova camada de forma com as dimensões da composição, desmarque todas as camadas pressionando F2.
    • Para substituir um caminho de forma, selecione o caminho da forma (não o grupo) no painel Composição ou no painel Linha de tempo.
  2. No painel Ferramentas, clique duas vezes na ferramenta Retângulo , Retângulo arredondado , Elipse , Polígono ou Estrela .

Criar formas a partir de caracteres de texto

O comando Criar formas a partir de texto extrai os contornos de cada caractere, cria formas a partir dos contornos e coloca as formas em uma nova camada de forma. Você pode usar essas formas como qualquer outra.

O comando Criar máscaras a partir de textoextrai os contornos de cada caractere, cria máscaras a partir dos contornos e coloca as máscaras em uma nova camada de cor sólida. Você pode usar essas máscaras como usa qualquer outra máscara.

Observação:

Algumas famílias de fontes, como Webdings, incluem caracteres que são imagens gráficas, em vez de texto. Converter o texto de essas famílias de fontes pode ser uma boa maneira de iniciar com elementos gráficos simples em camadas de forma.

criar forma a partir do texto
  1. Selecione o texto a ser convertido para formas:
    • Para criar formas para todos os caracteres em uma camada de texto, selecione a camada de texto no painel Linha de tempo ou no painel Composição.
    • Para criar formas para caracteres específicos, selecione os caracteres no painel Composição.
  2. Siga um destes procedimentos:
    • Selecione Escolha Camada > Criar formas a partir do texto
    • Clique com o botão direito (Windows) ou clique com a tecla Control (Mac OS) na camada ou texto e escolha Criar formas a partir do texto no menu de contexto.

  • A opção Vídeo para a camada de texto está desativada.
  • A nova camada de forma é criada no topo da ordem de empilhamento de camadas. A nova camada contendo um grupo de formas para cada caractere selecionado, mais as propriedades de preenchimento e traçado que correspondem aos preenchimentos e traçados do texto.
  • Para caracteres que consistem em caminhos composto, como i e e, vários caminhos são criados e combinados com a operação de caminho Mesclar caminhos.
  • Os efeitos, máscaras, estilos de camada e quadros-chave e expressões para propriedades no grupo de propriedades Transformar da camada de texto são copiados para a nova camada de forma ou camada de cor sólida.

Copiar um caminho do Illustrator ou do Photoshop

copiar um caminho do Illustrator ou do After Effects

É possível copiar um caminho do Illustrator ou Photoshop e colá-lo no After Effects como um caminho de máscara ou de forma.

Para disponibilizar dados copiados do Illustrator compatíveis com o After Effects, a opção AICB deve estar selecionada na seção Arquivos e área de transferência na caixa de diálogo Preferências do Adobe Illustrator.

Para um caminho importado do Photoshop ser dimensionado corretamente, o documento do Photoshop deve ter uma resolução de 72 dpi. 72 dpi é a configuração de resolução de documentos criados no Photoshop usando uma predefinição Filme e Vídeo.

Você também pode usar um caminho copiado do Illustrator ou Photoshop como um caminho de movimento do After Effects. Para obter mais informações, consulte Criar um caminho de movimento a partir de um caminho de máscara, forma ou pintura.

Caminho desenhado no Adobe Illustrator (esquerda) e colado no After Effects como máscara (direita)
Caminho desenhado no Adobe Illustrator (esquerda) e colado no After Effects como máscara (direita)
  1. No Illustrator ou no Photoshop, selecione um caminho inteiro e escolha Editar > Copiar.

  2. No After Effects, siga um destes procedimentos para definir um destino para a operação de colagem:
    • Para criar uma máscara, selecione uma camada.
    • Para substituir um caminho de máscara ou de forma existente, selecione sua propriedade Caminho.

    Observação:

    Para colar um caminho como um caminho de forma, selecione a propriedade Caminho de uma forma existente em uma camada de forma. Essa seleção indica ao After Effects onde é o destino da operação de colagem; caso o destino não seja especificado dessa maneira, o After Effects supõe que o destino seja a camada inteira e desenha consequentemente uma nova máscara. Se não houver nenhuma propriedade Caminho – talvez porque a camada de forma esteja vazia – então você pode desenhar um caminho de espaço reservado com a ferramenta Caneta e colar o caminho do Illustrator no caminho de espaço reservado.

  3. Escolha Editar > Colar. Se você colar vários caminhos em um caminho de forma, o primeiro caminho vai para o caminho de forma e os caminhos restantes serão colados em novos caminhos de máscara.

Criar uma forma a partir de um caminho de movimento

Você pode copiar quadros-chave de posição, quadros-chave de ponto de ancoragem ou quadros-chave de ponto de controle do efeito e colar esses quadros-chave em um caminho de máscara ou caminho de forma selecionado. Quando você cria caminhos de máscara ou caminhos de forma a partir de caminhos de movimento, certifique-se de que copia quadros-chave de uma única propriedade Posição somente – não copie os quadros-chave de qualquer outra propriedade.

Observação:

Desenhe um caminho de movimento com Desenho de trajetória e depois cole o caminho em um caminho de máscara ou caminho de forma.

Criar uma máscara ou forma a partir de um caminho de movimento
O caminho de movimento da nave espacial copiado para a camada de plano de fundo e com animação

Criar um caminho de forma a partir de um caminho de movimento

  1. No painel Linha de tempo, clique no nome da propriedade Posição ou propriedade Ponto de ancoragem a partir do qual deseja copiar o caminho de movimento. (Isso seleciona todos os quadros-chave. Para selecionar apenas alguns quadros-chave de um caminho de movimento, clique neles com a tecla Shift pressionada.)
  2. Escolha Editar > Copiar.
  3. Para criar uma nova camada de forma, pressione F2 para desmarcar todas as camadas e, em seguida, clique no painel Composição com a ferramenta Caneta para criar um caminho de Bézier de ponto único.

  4. Pressione SS para revelar a propriedade Caminho da forma. Clique no nome da propriedade Caminho em que deseja colar os quadros-chave do caminho de movimento.
  5. Escolha Editar > Colar.

Criar um caminho de máscara a partir de um caminho de movimento

Duplicar um grupo de formas durante a transformação

Quando um grupo de formas é selecionado no modo de seleção de grupo, é possível duplicar o grupo enquanto o move, gira ou redimensiona no painel Composição.

Mantenha a tecla Alt (Windows) ou Option (Mac OS) pressionada enquanto arrasta para transformar um grupo.

O ponteiro se transforma em um ponteiro de duplicação ( ou ) enquanto você pressiona a tecla e posiciona o ponteiro próximo da caixa de transformação do grupo.