Guia do Usuário Cancelar

Dynamic Link e After Effects

  1. Guia do usuário do After Effects
  2. Versões beta
    1. Visão geral do programa Beta
    2. Página inicial do After Effects Beta
  3. Introdução
    1. Introdução ao After Effects
    2. Novidades no After Effects 
    3. Notas de versão | After Effects
    4. Requisitos de sistema do After Effects
    5. Atalhos de teclado no After Effects
    6. Formatos de arquivo compatíveis | After Effects
    7. Recomendações de hardware
    8. Planejamento e configuração
    9. Configuração e instalação
  4. Espaços de trabalho
    1. Itens gerais da interface do usuário
    2. Conheça a interface do After Effects
    3. Fluxos de trabalho
    4. Espaços de trabalho, painéis e visualizadores
  5. Projetos e composições
    1. Projetos
    2. Noções básicas da composição
    3. Pré-composição, aninhamento e pré-renderização
    4. Exibir informações detalhadas de desempenho com o Criador de perfil de composição
    5. Renderizador de composição CINEMA 4D
  6. Importação de gravação
    1. Preparação e importação de imagens estáticas
    2. Importação do After Effects e do Adobe Premiere Pro
    3. Importação e interpretação de vídeo e áudio
    4. Preparo e importação de arquivos de imagem 3D
    5. Importação e interpretação de itens de gravação
    6. Trabalhar com itens de gravação
    7. Metadados XMP
  7. Trabalho com texto e gráficos
    1. Texto
      1. Formatação de caracteres e o painel Caractere
      2. Efeitos de texto
      3. Criação e edição de camadas de texto
      4. Formatação de parágrafos e o painel Parágrafo
      5. Extrusão de texto e camadas de forma
      6. Animação de texto
      7. Exemplos e recursos de animação de texto
      8. Modelos de texto dinâmico
    2. Animações
      1. Trabalhar com Modelos de animações no After Effects
      2. Usar expressões para criar listas suspensas em Modelos de animações
      3. Trabalhar com propriedades essenciais para criar Modelos de animações
      4. Substituir imagens e vídeos em Modelos de animações e Propriedades essenciais
  8. Desenho, pintura e caminhos
    1. Visão geral de camadas de forma, caminhos e gráficos vetoriais
    2. Ferramentas de pintura: Pincel, Carimbo e Borracha
    3. Como afunilar traçados de forma
    4. Atributos de forma, operações de pintura e operações de caminho para camadas de forma
    5. Use o efeito de forma Deslocar caminhos para alterar formas
    6. Criação de formas
    7. Criar máscaras
    8. Remover objetos de seus vídeos com o painel Preenchimento com reconhecimento de conteúdo
    9. Pincel tipo rotoscópio e Refinar fosco
  9. Trabalho com camadas
    1. Seleção e organização de camadas
    2. Modos de mesclagem e estilos de camadas
    3. Camadas 3D
    4. Propriedades da camada
    5. Criação de camadas
    6. Gerenciamento de camadas
    7. Marcadores de camada e de composição
    8. Câmeras, luzes e pontos de interesse
  10. Animação, quadro-chave, rastreamento de movimento e chaveamento
    1. Animação
      1. Noções básicas de animação
      2. Animação com ferramentas Marionete
      3. Gerenciamento e animação de caminhos de forma e máscaras
      4. Animação de desenho e captura de formas usando o After Effects
      5. Ferramentas de animação diversas
      6. Trabalhar com animação orientada por dados
    2. Quadro-chave
      1. Interpolação do quadro-chave
      2. Definir, selecionar e excluir quadros-chave
      3. Editar, mover e copiar quadros-chave
    3. Rastreamento de movimento
      1. Rastrear e estabilizar movimento
      2. Reconhecimento facial
      3. Rastreamento de máscara
      4. Referência de máscara
      5. Velocidade
      6. Esticamento e remapeamento de tempo
      7. Timecode e unidades de exibição de tempo
    4. Aplicação de máscara
      1. Aplicação de máscara
      2. Efeitos de máscara
  11. Transparência e composição
    1. Visão geral e recursos da composição e transparência
    2. Canais alfa, máscaras e foscos
  12. Ajustar cor
    1. Noções básicas de cores
    2. Uso da extensão de temas do Adobe Color
    3. Gerenciamento de cores
    4. Efeitos de correção de cores
  13. Efeitos e predefinições de animação
    1. Visão geral dos efeitos e predefinições de animação
    2. Lista de efeitos
    3. Efeitos de simulação
    4. Efeitos de estilo
    5. Efeitos de áudio
    6. Efeitos de distorção
    7. Efeitos de perspectiva
    8. Efeitos de canal
    9. Efeitos de geração
    10. Efeitos de transição
    11. O efeito Reparo do obturador de rolagem
    12. Efeitos Desfoque e Nitidez
    13. Efeitos de Canal 3D
    14. Efeitos de utilitários
    15. Efeitos de fosco
    16. Efeitos Ruído e Granulação
    17. Efeito Ampliação com preservação de detalhes
    18. Efeitos obsoletos
  14. Expressões e automação
    1. Expressão
      1. Noções básicas de expressão
      2. Entender sobre a linguagem de expressões
      3. Utilização de controles de expressão
      4. Diferenças de sintaxe entre os mecanismos de expressão Javascript e Legacy ExtendScript
      5. Edição de expressões
      6. Erros de expressão
      7. Utilização do editor de expressões
      8. Usar expressões para editar e acessar propriedades de texto
      9. Referência de linguagem de expressão
      10. Exemplos de expressão
    2. Automação
      1. Automação
      2. Scripts
  15. Vídeo imersivo, VR e 3D
    1. Criar ambientes de VR no After Effects
    2. Aplicar efeitos de vídeo imersivo
    3. Ferramentas de composição para vídeos VR/360
    4. Rastreamento de movimento de câmera 3D
    5. Trabalhar no Espaço de design 3D
    6. Visualização de alterações em projetos 3D em tempo real com o Mecanismo em tempo real
    7. Adicionar design responsivo aos gráficos 
  16. Exibições e visualizações
    1. Visualizar
    2. Visualização de vídeo com o Mercury Transmit
    3. Modificação e utilização de exibições
  17. Renderização e exportação
    1. Noções básicas de renderização e exportação
    2. Exportar um projeto do After Effects como um projeto do Adobe Premiere Pro
    3. Conversão de filmes
    4. Renderização de vários quadros
    5. Renderização automatizada e renderização de rede
    6. Renderização e exportação de imagens estáticas e sequências de imagens estáticas
    7. Utilização do codec GoPro CineForm no After Effects
  18. Trabalho com outros aplicativos
    1. Dynamic Link e After Effects
    2. Trabalhar com o After Effects e outros aplicativos
    3. Sincronizar configurações no After Effects
    4. Colaborar com o Team Projects
    5. Compartilhar e gerenciar alterações com colaboradores de Team Projects
    6. Bibliotecas da Creative Cloud no After Effects
    7. Plug-ins
    8. CINEMA 4D e Cineware
  19. Memória, armazenamento e desempenho
    1. Memória e armazenamento
    2. Melhorar o desempenho
    3. Preferências
    4. GPU e os requisitos de driver de GPU para o After Effects

Sobre o Dynamic Link

Antigamente, compartilhar ativos de mídia entre aplicativos de pós-produção exigia a renderização e exportação do trabalho do aplicativo antes de importá-lo para outro. Esse fluxo de trabalho era ineficiente e demorado. Se quisesse alterar o ativo original, era necessário renderizar e exportar o ativo novamente. Várias versões renderizadas e exportadas de um ativo consomem espaço em disco, e podem levar a desafios de gerenciamento de arquivos.

O Dynamic Link oferece uma alternativa para este fluxo de trabalho. É possível criar links dinâmicos entre o After Effects e o Adobe Premiere Pro. Criar um link dinâmico é tão simples como importar qualquer outro tipo de ativo. Os ativos vinculados dinamicamente aparecem com ícones exclusivos e cores de etiquetas para ajudá-lo a identificá-los. Os links dinâmicos são salvos em projetos gerados por esses aplicativos.

Criar e vincular a composições do After Effects com Dynamic Link

É possível criar novas composições do After Effects e vinculá-las dinamicamente a partir do Adobe Premiere Pro. Também é possível vincular dinamicamente a composições do After Effects existentes do Adobe Premiere Pro.

Criar uma composição de clipes no Adobe Premiere Pro

É possível substituir os clipes selecionados no Adobe Premiere Pro com uma composição do After Effects vinculados dinamicamente baseados nos clipes. A nova composição herda as configurações de sequência do Adobe Premiere Pro.

  1. Abra o Premiere Pro e selecione os clipes que deseja substituir.

  2. Clique com o botão direito do mouse em qualquer um dos clipes selecionados.
  3. Selecione Substituir por composição do After Effects.

    O After Effects é aberto (se ainda não estiver aberto) e uma nova composição vinculada é criada.

Criar uma composição dinamicamente vinculada do Adobe Premiere Pro

Criar uma nova composição vinculada dinamicamente a partir do Adobe Premiere Pro inicia o After Effects. O After Effects cria um projeto e uma composição com as dimensões, a taxa de proporção de pixels, a taxa de quadros e a taxa de amostragem de áudio do projeto de origem. (Se o After Effects já estiver em execução, isso criará uma composição no projeto atual.) O nome da nova composição se baseia no nome do projeto do Adobe Premiere Pro, seguido por Composição vinculada [x].

  1. No Adobe Premiere Pro, escolha Arquivo > Adobe Dynamic Link > Nova composição do After Effects. Na versão 2014 do Premiere Pro, você poderá importar composições com o Navegador de mídia. Consulte as seguintes seções no Premiere Pro para obter mais informações:

  2. Se a caixa de diálogo Salvar como do After Effects for exibida, digite um nome e um local para o projeto do After Effects e clique em Salvar.

    Observação:

    Ao criar uma composição vinculada dinamicamente do After Effects, a duração da composição será definida a 30 segundos. Para alterar a duração, selecione a composição no After Effects, selecione Composição > Configurações de composição. Clique na guia Básico e especifique um novo valor para Duração.

Para obter melhores resultados, faça a correspondência entre as configurações da composição (como dimensões, taxa de proporção de pixel e taxa de quadros) e as configurações do Adobe Premiere Pro.

  1. Siga um destes procedimentos:
    • No Adobe Premiere Pro, selecione Arquivo > Adobe Dynamic Link > Importar composição do After Effects. Escolha um arquivo de projeto do After Effects (.aep) e escolha uma ou mais composições.

    • No Adobe Premiere Pro, escolha um arquivo do projeto do After Effects e clique em Abrir. Em seguida, selecione uma composição exibida na caixa de diálogo e clique em OK.

    • Arraste uma ou mais composições do painel Projeto do After Effects para o painel Projeto do Adobe Premiere Pro.

    • Arraste um arquivo de projeto do After Effects para o painel Projeto Premiere Pro. Se o arquivo de projeto do After Effects contiver várias composições, a caixa de diálogo Importar composição será aberta.

Observação:

É possível vincular a uma única composição do After Effects várias vezes em um único projeto do Adobe Premiere Pro.

Modificar uma composição dinamicamente vinculada no After Effects

Use o comando Editar original no Adobe Premiere Pro para modificar composições vinculadas do After Effects. Quando a composição é aberta no After Effects, é possível alterar a composição sem precisar usar novamente o comando Editar original.

  1. Selecione a composição do After Effects no Adobe Premiere Pro ou escolha um clipe vinculado na Linha de tempo e escolha Editar > Editar original.

  2. Altere a composição no After Effects. Em seguida, volte para o Adobe Premiere Pro para exibir as alterações.

As alterações feitas no After Effects são exibidas no Adobe Premiere Pro. O Adobe Premiere Pro interrompe o uso de todos os arquivos de visualização renderizados para o clipe antes das alterações.

Observação:

É possível alterar o nome da composição no After Effects após criar um link dinâmico para ela no Adobe Premiere Pro. O Adobe Premiere Pro não atualiza o nome da composição vinculada no painel Projeto. No entanto, o Adobe Premiere Pro retém o link dinâmico.

Excluir uma composição ou clipe vinculado dinamicamente

É possível excluir uma composição vinculada de um projeto do Adobe Premiere Pro a qualquer momento, mesmo se a composição estiver sendo usada em um projeto.

Você também pode excluir clipes vinculados da linha de tempo de uma sequência do Adobe Premiere Pro ou da linha de tempo a qualquer momento.

  1. No Adobe Premiere Pro, selecione a composição ou o clipe vinculado e pressione a tecla Delete.

Criar uma sequência no Adobe Premiere Pro com o Dynamic Link

Criar uma sequência do Adobe Premiere Pro a partir do After Effects inicia o Adobe Premiere Pro. O Adobe Premiere Pro cria um projeto e uma sequência com as dimensões, a taxa de proporção de pixels, a taxa de quadros e a taxa de amostragem de áudio do projeto de origem. (Se o Adobe Premiere Pro já estiver em execução, ele criará uma sequência no projeto atual.)

  1. No After Effects, escolha Arquivo > Adobe Dynamic Link > Nova sequência do Premiere Pro.

Para obter melhores resultados, combine as configurações de sequência e configurações de projetos no Adobe Premiere Pro (como dimensões, taxa de proporção de pixels e taxa de quadro) para essas configurações no projeto do After Effects.

Siga um destes procedimentos:

  • No After Effects, escolha Arquivo > Adobe Dynamic Link > Importar sequência do Premiere Pro. Escolha um projeto do Adobe Premiere Pro e, em seguida, selecione uma ou mais sequências.

  • Arraste uma ou mais sequências do painel Projeto do Adobe Premiere Pro para o painel Projeto do After Effects.

Desempenho do Dynamic Link

Um clipe vinculado pode se referir a uma composição complexa de origem. As ações executadas na composição de origem exigem um tempo de processamento adicional dependendo da complexidade. O After Effects aplica as ações e disponibiliza os dados finais para o Adobe Premiere Pro usando o cache de desempenho global e os recursos de cache de disco persistentes. Esses recursos melhoram o desempenho do After Effects usando os quadros armazenados em cache quando o Premiere Pro os solicita.

Para reduzir os atrasos de reprodução, siga um destes procedimentos:

  • Coloque a composição vinculada offline

  • Desativar um clipe vinculado para parar temporariamente a referência a uma composição

  • Substitua a composição vinculada dinamicamente com o arquivo renderizado usando o recurso Renderizar e substituir no Premiere Pro (Clipe > Renderizar e substituir).  

Se você trabalhar normalmente com composições de origem complexa, adicione RAM ou faça upgrade para um processador mais rápido.

Observação:

Uma composição do After Effects vinculada não oferecerá suporte ao multiprocessamento Renderizar vários quadros simultaneamente. Consulte Melhorar o desempenho otimizando a memória, o cache e as configurações de multiprocessamento.

Exportar para o Adobe Media Encoder

Para codificar composições do After Effects, você deve adicionar o item à fila de codificação no Adobe Media Encoder e, em seguida, selecionar as predefinições de codificação ou criar configurações personalizadas para renderização. No After Effects, você pode adicionar uma composição à fila do Media Encoder usando uma destas opções:

  • Arquivo > Exportar > Adicionar à fila do Media Encoder
  • Composição > Adicionar à fila do Media Encoder

Quando você adiciona uma composição ou um projeto à fila do Adobe Media Encoder, o After Effects inicia o Adobe Media Encoder com as composições listadas na fila.

O processo de codificação é explicado nestes artigos:

Logotipo da Adobe

Fazer logon em sua conta