Guia do Usuário Cancelar

Scripts

  1. Guia do usuário do After Effects
  2. Versões beta
    1. Visão geral do programa Beta
    2. Página inicial do After Effects Beta
  3. Introdução
    1. Introdução ao After Effects
    2. Novidades no After Effects 
    3. Notas de versão | After Effects
    4. Requisitos de sistema do After Effects
    5. Atalhos de teclado no After Effects
    6. Formatos de arquivo compatíveis | After Effects
    7. Recomendações de hardware
    8. After Effects para Apple Silicon
    9. Planejamento e configuração
  4. Espaços de trabalho
    1. Itens gerais da interface do usuário
    2. Conheça a interface do After Effects
    3. Fluxos de trabalho
    4. Espaços de trabalho, painéis e visualizadores
  5. Projetos e composições
    1. Projetos
    2. Noções básicas da composição
    3. Pré-composição, aninhamento e pré-renderização
    4. Exibir informações detalhadas de desempenho com o Criador de perfil de composição
    5. Renderizador de composição CINEMA 4D
  6. Importação de gravação
    1. Preparação e importação de imagens estáticas
    2. Importação do After Effects e do Adobe Premiere Pro
    3. Importação e interpretação de vídeo e áudio
    4. Preparo e importação de arquivos de imagem 3D
    5. Importação e interpretação de itens de gravação
    6. Trabalhar com itens de gravação
    7. Detectar pontos de edição usando a Detecção de edição de cena
    8. Metadados XMP
  7. Textos e gráficos
    1. Texto
      1. Formatação de caracteres e o painel Caractere
      2. Efeitos de texto
      3. Criação e edição de camadas de texto
      4. Formatação de parágrafos e o painel Parágrafo
      5. Extrusão de texto e camadas de forma
      6. Animação de texto
      7. Exemplos e recursos de animação de texto
      8. Modelos de texto dinâmico
    2. Animações
      1. Trabalhar com Modelos de animações no After Effects
      2. Usar expressões para criar listas suspensas em Modelos de animações
      3. Trabalhar com propriedades essenciais para criar Modelos de animações
      4. Substituir imagens e vídeos em Modelos de animações e Propriedades essenciais
      5. Anime de maneira mais rápida e fácil usando o painel Propriedades
  8. Desenho, pintura e caminhos
    1. Visão geral de camadas de forma, caminhos e gráficos vetoriais
    2. Ferramentas de pintura: Pincel, Carimbo e Borracha
    3. Traçados de forma cônica
    4. Atributos de forma, operações de pintura e operações de caminho para camadas de forma
    5. Use o efeito de forma Deslocar caminhos para alterar formas
    6. Criação de formas
    7. Criar máscaras
    8. Remover objetos de seus vídeos com o painel Preenchimento com reconhecimento de conteúdo
    9. Pincel tipo rotoscópio e Refinar fosco
  9. Camadas, marcadores e câmera
    1. Seleção e organização de camadas
    2. Modos de mesclagem e estilos de camadas
    3. Camadas 3D
    4. Propriedades da camada
    5. Criação de camadas
    6. Gerenciamento de camadas
    7. Marcadores de camada e de composição
    8. Câmeras, luzes e pontos de interesse
  10. Animação, quadros-chave, rastreamento de movimento e chaveamento
    1. Animação
      1. Noções básicas de animação
      2. Animação com ferramentas Marionete
      3. Gerenciamento e animação de caminhos de forma e máscaras
      4. Animação de desenho e captura de formas usando o After Effects
      5. Ferramentas de animação diversas
      6. Trabalhar com animação orientada por dados
    2. Quadro-chave
      1. Interpolação do quadro-chave
      2. Definir, selecionar e excluir quadros-chave
      3. Editar, mover e copiar quadros-chave
    3. Rastreamento de movimento
      1. Rastrear e estabilizar movimento
      2. Reconhecimento facial
      3. Rastreamento de máscara
      4. Referência de máscara
      5. Velocidade
      6. Esticamento e remapeamento de tempo
      7. Timecode e unidades de exibição de tempo
    4. Aplicação de máscara
      1. Aplicação de máscara
      2. Efeitos de máscara
  11. Transparência e composição
    1. Visão geral e recursos da composição e transparência
    2. Canais alfa e máscaras
    3. Foscos de controle e foscos móveis
  12. Ajustar cor
    1. Noções básicas de cores
    2. Gerenciamento de cores
    3. Efeitos de correção de cores
    4. Gerenciamento de cores OpenColorIO e ACES
  13. Predefinições de animação e efeitos
    1. Visão geral das predefinições de animação e efeitos
    2. Lista de efeitos
    3. Gerenciador de efeitos
    4. Efeitos de simulação
    5. Efeitos de estilo
    6. Efeitos de áudio
    7. Efeitos de distorção
    8. Efeitos de perspectiva
    9. Efeitos de canal
    10. Efeitos de geração
    11. Efeitos de transição
    12. O efeito Reparo do obturador de rolagem
    13. Efeitos Desfoque e Tornar nítido
    14. Efeitos de Canal 3D
    15. Efeitos de utilitários
    16. Efeitos de fosco
    17. Efeitos Ruído e Granulação
    18. Efeito de ampliação com preservação de detalhes
    19. Efeitos obsoletos
  14. Expressões e automação
    1. Expressões
      1. Noções básicas de expressão
      2. Entender sobre a linguagem de expressões
      3. Utilização de controles de expressão
      4. Diferenças de sintaxe entre os mecanismos de expressão Javascript e Legacy ExtendScript
      5. Edição de expressões
      6. Erros de expressão
      7. Utilização do editor de expressões
      8. Usar expressões para editar e acessar propriedades de texto
      9. Referência de idioma de expressão
      10. Exemplos de expressão
    2. Automação
      1. Automação
      2. Scripts
  15. Vídeo imersivo, VR e 3D
    1. Construa ambientes VR no After Effects
    2. Aplicar efeitos de vídeo imersivo
    3. Ferramentas de composição para vídeos VR/360
    4. Renderizador 3D avançado
    5. Importar e adicionar modelos 3D à composição
    6. Importação de modelos 3D das bibliotecas da Creative Cloud
    7. Iluminação com base na imagem
    8. Extração e animação de luzes e câmeras de modelos 3D
    9. Rastreamento de movimento de câmera 3D
    10. Projetar e aceitar sombras
    11. Animações de modelos 3D incorporadas
    12. Coletor de sombras
    13. Extração de dados de profundidade 3D
    14. Trabalhar no Espaço de design 3D
    15. Gizmos de transformação 3D
    16. Faça mais com a animação 3D
    17. Visualização de alterações em projetos 3D em tempo real com o mecanismo Mercury 3D.
    18. Adicionar design responsivo aos gráficos 
  16. Exibições e visualizações
    1. Visualizar
    2. Visualização de vídeo com o Mercury Transmit
    3. Modificação e utilização de exibições
  17. Renderização e exportação
    1. Noções básicas de renderização e exportação
    2. Codificação em H.264 no After Effects
    3. Exportar um projeto do After Effects como um projeto do Adobe Premiere Pro
    4. Conversão de filmes
    5. Renderização de vários quadros
    6. Renderização automatizada e renderização de rede
    7. Renderização e exportação de imagens estáticas e sequências de imagens estáticas
    8. Utilização do codec GoPro CineForm no After Effects
  18. Trabalho com outros aplicativos
    1. Dynamic Link e After Effects
    2. Trabalhar com o After Effects e outros aplicativos
    3. Sincronizar configurações no After Effects
    4. Bibliotecas da Creative Cloud no After Effects
    5. Plug-ins
    6. Cinema 4D e Cineware
  19. Colaboração: Frame.io e Team Projects
    1. Colaboração no Premiere Pro e After Effects
    2. Frame.io
      1. Instalar e ativar o Frame.io
      2. Usar Frame.io com Premiere Pro e After Effects
      3. Perguntas frequentes
    3. Team Projects
      1. Introdução ao Team Projects
      2. Criar um Projeto de equipe
      3. Colaborar com o Team Projects
  20. Memória, armazenamento e desempenho
    1. Memória e armazenamento
    2. Como o After Effects lida com problemas de memória insuficiente durante uma visualização    
    3. Melhorar o desempenho
    4. Preferências
    5. GPU e os requisitos de driver de GPU para o After Effects
  21. Knowledge Base
    1. Problemas conhecidos
    2. Problemas corrigidos
    3. Perguntas frequentes
    4. After Effects e macOS Ventura
    5. Como o After Effects lida com problemas de memória insuficiente durante uma visualização

Um script é uma série de comandos que instrui um aplicativo a executar uma série de operações. É possível usar scripts na maioria dos aplicativos da Adobe para automatizar tarefas repetitivas, executar cálculos complexos e utilizar alguma funcionalidade não exposta diretamente na interface gráfica do usuário. Por exemplo, é possível direcionar o After Effects para reorganizar as camadas em uma composição, localizar e substituir o texto de origem em camadas de texto, ou para enviar um email quando a renderização estiver concluída.

Os scripts do After Effects usam a linguagem Adobe ExtendScript, que é uma forma de JavaScript estendido. Os arquivos do ExtendScript têm a extensão de nome de arquivo JSX ou JSXBIN.

Para uma descrição dos recursos de script disponíveis no After Effects, consulte o Guia de scripts do After Effects no Centro do desenvolvedor do After Effects.

Carregar e executar scripts

Quando o After Effects é iniciado, ele carrega os scripts da pasta Scripts. Por padrão, a pasta Scripts está nos seguintes locais do After Effects:

  • Windows: Arquivos de Programas\Adobe\Adobe After Effects <version>\Support Files

  • macOS: Aplicativos/Adobe After Effects <version>

O After Effects vem com vários scripts e que são automaticamente instalados na pasta Scripts. Todos os scripts carregados estão disponíveis no menu Arquivo > Scripts.

Observação:
  • Se você editar um script quando o After Effects estiver em execução, será necessário salvar as alterações para que as alterações sejam aplicadas.
  • Se inserir um script na pasta Scripts enquanto o After Effects estiver em execução, será necessário reiniciá-lo para que ele seja exibido no menu Scripts, embora seja possível executar o novo script imediatamente usando o comando Executar arquivo de script.

Os scripts na pasta ScriptUI Panels estão disponíveis na parte inferior do menu Janela. Se um script é escrito para fornecer uma interface em um painel encaixável, o script precisa ser colocado na pasta ScriptUI. Os painéis do ScriptUI funcionam da mesma forma que os painéis padrão na interface do After Effects.

Observação:

Por padrão, não é permitido que os scripts gravem arquivos ou enviem e recebam comunicações pela rede. Para permitir que os scripts gravem arquivos e se comuniquem em uma rede,

  • Windows : selecione Editar > Preferências > Scripts e expressões > e selecione Permitir que scripts gravem arquivos e acessem a rede.
  • macOS: selecione After Effects > Preferências > Scripts e expressões > e selecione Permitir que scripts gravem arquivos e acessem a rede.
  • Para executar um script carregado, escolha Arquivo > Scripts > [nome do script].

  • Para executar um script que não foi carregado, escolha Arquivo > Scripts > Executar arquivo de script, localize e selecione um script e clique em Abrir.

  • Para interromper um script em execução, pressione Esc.

  • Para executar um script a partir da linha de comando, invoque afterfx.exe na linha de comando. Use o comutador -r e o caminho completo do script a ser executado como argumentos. Este comando não abre uma nova instância do aplicativo do After Effects, ele executa o script na instância já existente.

    Exemplo (Windows): afterfx -r c:\caminho_do_script\script_de_exemplo.jsx

Observação:

Você pode usar essa técnica de linha de comando, junto com o software que vem com um teclado personalizável, para vincular a invocação de um script a um atalho de teclado.

É possível visualizar a lista dos dez scripts executados mais recentemente no After Effects. Para ver a lista, selecione Arquivo > Scripts > Arquivos de script recentes.

Para executar novamente qualquer um dos dez scripts executados mais recentemente,

  • macOS: Cmd + Option + Shift + D
  • Windows: Ctrl + Alt + Shift + D
Observação:

No site AE Scripts, Lloyd Alvarez fornece uma dica sobre como executar scripts JSXBIN quando você não tem acesso às pastas Scripts ou Painéis ScriptUI.

Scripts incluídos no After Effects

O After Effects fornece vários scripts pré-gravados para auxiliar na realização de tarefas comuns e fornecer uma base para que você altere e crie seus próprios scripts.

Dica:

Execute o script de amostra Demo Palette.jsx para ter uma ideia do que é possível fazer com scripts.

Gravar e modificar scripts

Você pode gravar seus próprios scripts para usar no After Effects usando o editor de scripts, que faz parte do ExtendScript Toolkit. O ExtendScript Toolkit fornece uma interface conveniente para criar, depurar e testar seus próprios scripts. Às vezes, tudo o que é necessário fazer é uma pequena modificação de um script existente para que ele faça aquilo que você pretende; normalmente podem ser realizadas pequenas alterações com alguns dados acerca da programação do computador e as linguagens de script.

Para iniciar o editor de scripts, escolha Arquivo > Scripts > Abrir Editor de scripts.

Consulte o Guia de scripts do After Effects para obter mais informações.

Acesso a scripts

Acesso a scripts de modelos de animações

Os scripts podem adicionar propriedades ao painel Gráficos essenciais e exportar um Modelo de animações, por meio dos seguintes métodos de script:

  • Método de propriedade canAddToMotionGraphicsTemplate()
app.project.item(index).layer(index).propertySpec.canAddToMotionGraphicsTemplate(comp) 

Teste se a propriedade pode ser adicionada ao painel Gráficos essenciais para a composição especificada. Retornará true se a propriedade puder ser adicionada; caso contrário, retornará false. Se a propriedade não puder ser adicionada, é porque não é um dos tipos de propriedade suportados ou já foi adicionada a essa composição. O After Effects apresenta uma caixa de diálogo de aviso.

Tipos de propriedade compatíveis:

  • Caixa de seleção
  • Cor
  • Controle deslizante numérico (uma propriedade numérica de valor único, como Transformar > Opacidade ou o efeito de controle de expressão do Controle deslizante)
  • Texto de origem

Parâmetros:

comp

A composição para a qual deseja testar a adição de propriedades: compItem.

Retorna: booleano.


  • Método de propriedade addToMotionGraphicsTemplate()
app.project.item(index).layer(index).propertySpec.addToMotionGraphicsTemplate(comp)

Adicione a propriedade ao painel Gráficos essenciais para a composição especificada. Retornará true se a propriedade for adicionada com sucesso; caso contrário, retornará false. Se a propriedade não for adicionada, é porque não se encaixa em um dos tipos de propriedade suportados ou já foi adicionada a essa composição. O After Effects apresentará uma caixa de diálogo de aviso. Use o método canAddToMotionGraphicsTemplate() para testar se a propriedade pode ser adicionada a um Modelo de animações.

Parâmetros:

comp

A composição para a qual deseja testar a adição de propriedades: compItem.

Retorna: booleano.


  • Atributo CompItem motionGraphicsTemplateName 
app.project.item(index).motionGraphicsTemplateName

Leia ou grave a propriedade nome no painel Gráficos essenciais para a composição. O nome no painel Gráficos essenciais é usado para o nome de arquivo de um Modelo de animações exportado, por exemplo, Meu modelo.mogrt. O exemplo a seguir define o nome para a composição ativa e o retorna como um alerta:

app.project.activeItem.motionGraphicsTemplateName = “Meu modelo”;
alert(app.project.activeItem.motionGraphicsTemplateName);

Tipo: String; leitura/gravação.


  • Método CompItem exportAsMotionGraphicsTemplate()
app.project.item(index).exportAsMotionGraphicsTemplate(doOverWriteFileIfExisting, file_path)

Exporta a composição como um Modelo de animações. Retornará verdadeiro se o Modelo de animações for exportado com sucesso; caso contrário, retornará falso. O nome no painel Gráficos essenciais é usado para o nome de arquivo do Modelo de animações, por exemplo, Meu modelo.mogrt. Use o atributo motionGraphicsTemplateName para definir o nome. Opcionalmente, especifique o caminho para a pasta na qual o arquivo de Modelo de animações é salvo. Se não especificado, o arquivo será salvo na pasta de Gráficos essenciais do usuário atual:

  • macOS:  /Users/Library/Application Support/Adobe/Common/Essential Graphics/
  • Windows: C:\Usuários\AppData\Roaming\Adobe\Common\Essential Graphics\

Se o projeto tiver sido alterado desde a última vez em que foi salvo, o After Effects solicitará que o usuário salve o projeto. Para evitar isso, use o método save() do projeto antes de exportar o Modelo de animações.

Parâmetros:

doOverWriteFileIfExisting

Se substituirá ou não um arquivo existente com o mesmo nome, booleano. Obrigatório.

file_path

Caminho para a pasta na qual o arquivo será salvo. Opcional.

Retorna: booleano.


  • Método CompItem openInEssentialGraphics()
app.project.item(index).openInEssentialGraphics() 

Onde encontrar scripts úteis adicionais

Encontre scripts, projetos e outros itens úteis no site Adobe Add-ons.

O fórum AE Enhancers oferece scripts de exemplo e informações úteis sobre scripts (bem como expressões e predefinições de animação) no After Effects.

 Adobe

Receba ajuda com mais rapidez e facilidade

Novo usuário?

Adobe MAX 2024

Adobe MAX:
a conferência da criatividade

14 a 16 de outubro, Miami Beach e online

Adobe MAX

A conferência da criatividade

14 a 16 de outubro, Miami Beach e online

Adobe MAX 2024

Adobe MAX:
a conferência da criatividade

14 a 16 de outubro, Miami Beach e online

Adobe MAX

A conferência da criatividade

14 a 16 de outubro, Miami Beach e online