Příručka uživatele Zrušit

Doplňování tvarů

  1. Příručka uživatele aplikace Adobe Animate
  2. Úvod do aplikace Animate
    1. Novinky v aplikaci Animate
    2. Grafický glosář
    3. Systémové požadavky pro aplikaci Animate
    4. Klávesové zkratky aplikace Animate
    5. Práce s různými typy souborů v aplikaci Animate
  3. Animace
    1. Základy animování v aplikaci Animate
    2. Používání snímků a klíčových snímků v aplikaci Animate
    3. Animace po jednotlivých snímcích v aplikaci Animate
    4. Práce s animacemi klasických doplnění v aplikaci Animate
    5. Nástroj Štětec
    6. Vodítko pohybu
    7. Doplnění pohybu a ActionScript 3.0
    8. O animacích s doplněními pohybu
    9. Animace s doplněním pohybu
    10. Vytvoření animace s doplněním pohybu
    11. Používání klíčových snímků vlastností
    12. Animování polohy pomocí doplnění
    13. Úpravy doplnění pohybu v editoru pohybu
    14. Úpravy cesty pohybu u animace s doplněním
    15. Úpravy doplnění pohybu
    16. Přidání vlastního náběhu nebo doběhu
    17. Vytváření a aplikování přednastavení pohybu
    18. Nastavení rozsahu doplnění animace
    19. Práce s doplněními pohybu uloženými jako soubory XML
    20. Srovnání doplnění pohybu a klasických doplnění
    21. Doplňování tvarů
    22. Používání animací nástroje Kost v aplikaci Animate
    23. Sestavování postav v aplikaci Animate
    24. Používání vrstev masek v aplikaci Adobe Animate
    25. Práce se scénami v aplikaci Animate
  4. Interaktivita
    1. Vytváření tlačítek v aplikaci Animate
    2. Převod projektů aplikace Animate na jiné typy dokumentů
    3. Vytváření a publikování dokumentů HTML5 Canvas v aplikaci Animate
    4. Přidání interaktivity pomocí fragmentů kódu v aplikaci Animate
    5. Vytváření vlastních komponent HTML5
    6. Používání komponent v dokumentech HTML5 Canvas
    7. Vytváření vlastních komponent: Příklady
    8. Fragmenty kódu pro vlastní komponenty
    9. Osvědčené postupy – Tvorba reklam v aplikaci Animate
    10. Vytváření a publikování virtuální reality
  5. Pracovní plocha a pracovní postupy
    1. Vytváření a správa malířských štětců
    2. Používání písem Google v dokumentech HTML5 Canvas
    3. Používání knihoven Creative Cloud v aplikaci Adobe Animate
    4. Používání vymezené plochy a panelu nástrojů v aplikaci Animate
    5. Pracovní postupy a pracovní plocha aplikace Animate
    6. Používání webových písem v dokumentech HTML5 Canvas
    7. Časové osy a ActionScript
    8. Práce s více časovými osami
    9. Nastavení předvoleb
    10. Používání vývojových panelů aplikace Animate
    11. Vytváření vrstev časové osy v aplikaci Animate
    12. Export animací pro mobilní aplikace a herní moduly
    13. Přemísťování a kopírování objektů
    14. Předlohy
    15. Příkaz Hledat a nahradit v aplikaci Animate
    16. Vrácení akce, její zopakování a panel Historie
    17. Klávesové zkratky
    18. Používání časové osy v aplikaci Animate
    19. Vytvoření rozšíření HTML
    20. Možnosti optimalizace obrázků a animovaných souborů GIF
    21. Export nastavení pro obrázky a soubory GIF
    22. Panel Datové zdroje v aplikaci Animate
  6. Multimédia a video
    1. Transformace a kombinování grafických objektů v aplikaci Animate
    2. Vytváření a práce s instancemi symbolů v aplikaci Animate
    3. Vektorizace obrazu
    4. Používání zvuku v aplikaci Adobe Animate
    5. Export souborů SVG
    6. Vytváření souborů videa používaných v aplikaci Animate
    7. Přidání videa v aplikaci Animate
    8. Práce se startovacími body videa
    9. Kreslení a vytváření objektů v aplikaci Animate
    10. Změna čar a tvarů
    11. Tahy, výplně a přechody v aplikaci Animate
    12. Práce s aplikacemi Adobe Premiere Pro a After Effects
    13. Panely barev v aplikaci Animate
    14. Otevírání souborů aplikace Flash CS6 v aplikaci Animate
    15. Práce s klasickým textem v aplikaci Animate
    16. Vložení grafiky do aplikace Animate
    17. Importované bitmapy v aplikaci Animate
    18. 3D grafika
    19. Práce se symboly v aplikaci Animate
    20. Kreslení čar a tvarů v aplikaci Adobe Animate
    21. Práce s knihovnami v aplikaci Animate
    22. Export zvuků
    23. Výběr objektů v aplikaci Animate
    24. Práce se soubory aplikace Illustrator (AI) v aplikaci Animate
    25. Nanášení vzorů pomocí nástroje Stopa spreje
    26. Používání režimů prolnutí
    27. Uspořádání objektů
    28. Automatizace úloh pomocí nabídky Příkazy
    29. Vícejazyčný text
    30. Používání kamery v aplikaci Animate
    31. Používání aplikace Animate s nástrojem Adobe Scout
    32. Práce se soubory aplikace Fireworks
    33. Grafické filtry
    34. Zvuk a ActionScript
    35. Předvolby kreslení
    36. Kreslení nástrojem Pero
  7. Platformy
    1. Převod projektů aplikace Animate na jiné typy dokumentů
    2. Podpora vlastní platformy
    3. Vytváření a publikování dokumentů HTML5 Canvas v aplikaci Animate
    4. Vytvoření a publikování dokumentu ve formátu WebGL
    5. Balení aplikací pro prostředí AIR for iOS
    6. Publikování aplikací prostředí AIR for Android
    7. Publikování pro prostředí Adobe AIR pro počítače
    8. Nastavení publikování jazyka ActionScript
    9. Osvědčené postupy – Uspořádání ActionScriptu v aplikaci
    10. Používání jazyka ActionScript v aplikaci Animate
    11. Osvědčené postupy – Pravidla usnadnění přístupu
    12. Usnadnění přístupu v pracovním prostoru aplikace Animate
    13. Psaní a správa skriptů
    14. Povolení podpory vlastních platforem
    15. Přehled podpory vlastních platforem
    16. Vytváření přístupného obsahu
    17. Práce se zásuvným modulem pro podporu vlastní platformy
    18. Ladění jazyka ActionScript 3.0
    19. Povolení podpory vlastních platforem
  8. Export a publikování
    1. Export souborů z aplikace Animate
    2. Publikování OAM
    3. Export souborů SVG
    4. Export grafiky a videa v aplikaci Animate
    5. Publikování dokumentů AS3
    6. Export animací pro mobilní aplikace a herní moduly
    7. Export zvuků
    8. Export videosouborů QuickTime
    9. Ovládání externího přehrávání videa s použitím jazyka ActionScript
    10. Osvědčené postupy – Tipy pro vytváření obsahu pro mobilní zařízení
    11. Osvědčené postupy – Konvence videa
    12. Osvědčené postupy – Pravidla pro vývoj aplikací SWF
    13. Osvědčené postupy – Strukturování souborů FLA
    14. Osvědčené postupy pro optimalizaci souborů FLA pro Animate
    15. Nastavení publikování jazyka ActionScript
    16. Nastavení publikování v aplikaci Animate
    17. Export souborů projektoru
    18. Export obrázků a animovaných souborů GIF
    19. Předlohy publikování HTML
    20. Práce s aplikacemi Adobe Premiere Pro a After Effects
    21. Rychlé sdílení a publikování animací

Při doplňování tvaru nakreslíte vektorový tvar v jednom snímku v časové ose a v jiném snímku tento tvar změníte nebo nakreslíte jiný. Animate potom interpoluje přechodné tvary v mezilehlých snímcích a tím vytvoří animaci, ve které přechází jeden tvar do druhého.

V aplikaci Animate můžete přidávat doplnění tvarů do plných rovnoměrných tahů i do nerovnoměrných ozdobných tahů. Doplnění tvarů lze rovněž přidávat k tahům vylepšeným pomocí nástroje Proměnlivá šířka. Experimentujte s tvary, které chcete použít, a posuďte výsledky. Pomocné body tvaru použijte, když chcete aplikaci Animate sdělit, jaké body počátečního tvaru mají odpovídat konkrétním bodům koncového tvaru.

Můžete také doplnit pozici a barvu tvarů v rámci doplnění tvaru.

Chcete-li aplikovat doplnění tvarů do skupin, instancí nebo bitmapových obrazů, tyto prvky rozdělte. Chcete-li použít doplnění tvarů pro text, převeďte text na objekty dvojím rozdělením tohoto textu. Viz téma Rozdělení instance symbolu.

Vytvoření doplnění tvaru

Následující kroky ukazují, jak vytvářet doplnění tvaru ze snímku 1 do snímku 30 na časové ose. Můžete však vytvářet doplnění v jakékoliv části časové osy, kterou si vyberete.

  1. Ve snímku 1 vykreslete obdélník nástrojem Obdélník.
  2. Zvolte snímek 30 ve stejné vrstvě a přidejte prázdný klíčový snímek vybráním položky Vložit > Časová osa > Prázdný klíčový snímek nebo stiskněte klávesu F7.

  3. Na ploše nakreslete kruh nástrojem Ovál na snímku 30.

    Teď máte na snímku 1 klíčový snímek se čtvercem a na snímku 30 klíčový snímek s kruhem.

  4. V časové ose vyberte jeden ze snímků mezi dvěma klíčovými snímky ve vrstvě obsahující oba tvary.

  5. Zvolte Vložit > Doplnění tvaru.

    Aplikace Animate interpoluje tvary ve všech snímcích mezi dvěma klíčovými snímky.

  6. Chcete-li zobrazit náhled doplnění, přetáhněte přehrávací hlavu přes snímky v časové ose nebo stiskněte klávesu Enter.

  7. Pokud chcete kromě tvaru doplnit i pohyb, přesuňte tvar ze snímku 30 do jiného umístění, kromě snímku 1.

    Zobrazte náhled animace stisknutím klávesy Enter.

  8. Chcete-li doplnit barvu tvaru, vytvořte tvar ve snímku 1 odlišné barvy, než jakou má tvar ve snímku 30.
  9. Pokud chcete k doplnění přidat náběh/výběh, vyberte některý ze snímků a v inspektoru vlastností zadejte hodnotu do pole Náběh/výběh.

    Chcete-li vytvořit náběh na začátku doplnění, zadejte zápornou hodnotu. Chcete-li vytvořit doběh na konci doplnění, zadejte kladnou hodnotu.

Vytváření přednastavení náběhu/doběhu nebo vlastních náběhů/doběhů

Přednastavení náběhu/doběhu jsou předem konfigurované náběhy/doběhy, které lze použít u objektu na ploše.

Pro doplnění tvaru je k dispozici sada často používaných přednastavení náběhu/doběhu. Vyberte přednastavení náběhu/doběhu ze seznamu a použijte ho u vybrané vlastnosti.U doplnění tvaru také můžete použít vlastní náběh/doběh.

  1. Klikněte na vrstvu, která na časové ose aplikace Animate obsahuje doplnění tvaru.

  2. Pokud chcete otevřít vlastnosti doplnění, klikněte na panelu vlastností na kategorii Doplnění.

    Vlastnosti doplnění
    Vlastnosti doplnění

  3. Vyberte požadované přednastavení náběhu/doběhu v rozevírací nabídce a dvakrát klikněte na požadovaný typ přednastavení. 

    Pokud se rozhodnete použít klasický náběh/doběh, můžete posunutím jezdce zvýšit nebo snížit jeho intenzitu. 

    Typy přednastavení náběhu/doběhu
    Typy přednastavení náběhu/doběhu

  4. Chcete-li použít vlastní náběh/doběh, klikněte vedle možnosti Náběh/doběh na ikonu Upravit.

    Dialogové okno Vlastní náběh/doběh zobrazuje graf představující míru pohybu během času. Vodorovná osa představuje snímky a svislá osa představuje procentuální hodnotu změny. První klíčový snímek je uveden jako 0 % a poslední klíčový snímek je uveden jako 100 %.

    Sklon křivky grafu představuje rychlost změny objektu. Když je křivka vodorovná (beze sklonu), rychlost je nulová; když je křivka svislá, vyskytla se mžiková rychlost změny.

    Můžete uložit vlastní náběh/doběh a znovu ho použít výběrem ze seznamu Vlastní. Po provedení změn v režimu úprav klikněte na tlačítko Uložit a použít. Na následujícím snímku obrazovky si můžete prohlédnout vlastní náběh/doběh s názvem MyEase1.

    Přednastavený náběh/doběh můžete použít ve více rozpětích na časové ose tak, že vyberete odpovídající rozsahy a použijete požadovaný náběh/doběh.

    Přednastavený náběh/doběh pro více rozpětí
    Použití přednastaveného náběhu/doběhu pro více rozpětí

Řízení změn tvaru s použitím pomocných bodů tvaru

Chcete-li nastavit složitější nebo nepravděpodobné změny tvaru, můžete použít pomocné body tvaru. Pomocné body tvaru identifikují body, které odpovídají počátečním a konečným tvarům. Pokud například doplňujete kresbu tváře, která mění výraz, můžete použít pomocný bod tvaru pro označení každého oka. Pak místo toho, aby se z tváře při změně tvaru stala beztvará změť, každé oko zůstane rozpoznatelné a během transformace se mění samostatně.

Pomocné body tvaru jako písmena
Pomocné body tvaru jako písmena

Pomocné body tvaru obsahují písmena (od a do z) pro identifikaci bodů, které si odpovídají v počátečním a koncovém tvaru. Můžete použít až 26 pomocných bodů tvaru.

Pomocné body tvaru jsou žluté v počátečním klíčovém snímku, zelené v koncovém klíčovém snímku a červené, když nejsou na křivce.

Nejlepších výsledků při doplňování tvarů dosáhnete, když se budete řídit těmito pravidly:

  • U složitého doplňování tvarů nedefinujte pouze počáteční a koncový tvar, místo toho vytvořte přechodné tvary a doplňte je.

  • Ujistěte se, že jsou pomocné body tvaru logické. Pokud například používáte tři pomocné body tvaru pro trojúhelník, tyto body musejí být v původním trojúhelníku a v doplňovaném trojúhelníku ve stejném pořadí. Toto pořadí nemůže být a, b, c v prvním klíčovém snímku a a, c, b v druhém.

  • Pomocné body tvaru fungují nejlépe, když je začnete umísťovat v levém horním rohu tvaru a pokračujete proti směru hodinových ručiček.

Používání pomocných bodů tvaru

  1. Vyberte první klíčový snímek v sekvenci s doplňováním tvaru.
  2. Zvolte Změnit > Tvar > Přidat pomocný bod tvaru. Počáteční pomocný bod tvaru se zobrazí někde na tvaru jako červený kroužek označený písmenem a.

  3. Přesuňte pomocný bod tvaru do bodu, který chcete označit.
  4. Vyberte poslední klíčový snímek v sekvenci doplnění. Koncový pomocný bod tvaru se zobrazí jako zelený kruh s písmenem a někde na tvaru.

  5. Přesuňte pomocný bod tvaru do bodu koncového tvaru, který odpovídá prvnímu označenému bodu.

  6. Chcete-li si prohlédnout, jak pomocné body tvaru mění doplnění tvarů, přehrajte si znovu animaci. Chcete-li doladit doplnění, pomocné body tvaru podle potřeby přesouvejte.
  7. Chcete-li přidat další pomocné body tvaru, opakujte tento postup. Nové pomocné body se zobrazují s následujícími písmeny (b, c a tak dále).

Zobrazení všech pomocných bodů tvaru

  1. Zvolte Zobrazit > Zobrazit pomocné body tvaru. Vrstva a klíčový snímek obsahující pomocné body tvaru musejí být aktivní, jinak příkaz Zobrazit pomocné body tvaru nebude dostupný.

Odstranění pomocného bodu tvaru

  1. Přetáhněte pomocný bod tvaru mimo vymezenou plochu.

Odstranění všech pomocných bodů tvaru

  1. Zvolte Změnit > Tvar > Odstranit všechny pomocné body.

Přidání doplnění tvarů do tahů s proměnlivou šířkou

Aplikace Animate umožňuje přidávat doplnění tvarů do tahů s proměnlivou šířkou. Dříve aplikace Animate podporovala vytváření doplnění tvarů pouze u plných rovnoměrných tahů a tvarů. To návrháře omezovalo, protože nemohli vytvářet doplnění tvarů u nerovnoměrných tahů, například u tahů vylepšených pomocí nástroje Proměnlivá šířka. Doplňování tahů s proměnlivou šířkou v aplikaci Animate výrazně rozšiřuje možnosti návrhu.

Přidávání doplnění tvarů do ozdobných tahů se neliší od doplňování tvaru nebo plného rovnoměrného tahu. Pracovní postup vyžaduje, abyste definovali počáteční a koncový tvar doplnění, a aplikace Animate vytvoří přechodové snímky doplnění.

O nástroji Proměnlivá šířka

Nástroj Proměnlivá šířka umožňuje vylepšit plné rovnoměrné tahy a vytvořit z nich nádherné ozdobné tahy.

Přidání doplnění tvarů do tahů s proměnlivou šířkou

  1. V aplikaci Animate CC nakreslete čáru pomocí nástroje Čára.

    Čára s hodnotou tahu nastavenou na 2 obr. body
    Čára nakreslená na ploše pomocí nástroje Čára, hodnota Tah je nastavena na 2 obrazové body.

  2. Pomocí nástroje Proměnlivá šířka rozšiřte prostřední část tahu (viz obrázek níže). Informace o používání nástroje Proměnlivá šířka naleznete v části Vylepšování tahů pomocí nástroje Proměnlivá šířka.

    Tah s proměnlivou šířkou s hodnotou 68 obr. bodů
    Tah s proměnlivou šířkou vytvořený nástrojem Proměnlivá šířka, hodnota Tah je nastavena na 68 obr. bodů.

  3. Vyberte na časové ose další snímek, například snímek 30, a vytvořte konečný tvar doplňovaného tahu.

    Konečný tvar přidaný do posledního klíčového snímku doplnění tvaru
    Konečný tvar přidaný do posledního klíčového snímku doplnění tvaru

  4. Pravým tlačítkem klikněte na libovolný snímek mezi snímky 1 až 30 a vyberte možnost Vytvořit doplnění tvaru.

Přidání doplnění tvarů do profilů proměnlivých tlouštěk

Animate umožňuje přidávat doplnění tvarů také k ozdobným tahům, které jsou uloženy jako profily proměnlivých tlouštěk. Profily tloušťky můžete použít u počátečních a konečných tvarů doplnění a pak nechat aplikaci Animate vytvořit plynulé doplnění tvaru.

Profily tloušťky jsou ozdobné tahy, které byly vytvořeny a uloženy nástrojem Proměnlivá šířka, abyste je mohli snadno znovu použít. Postup přidání doplnění tvarů k profilům proměnlivých tlouštěk:

  1. V Animate nakreslete na ploše čáru pomocí nástroje Čára.

    Čára s hodnotou tahu nastavenou na 2 obr. body
    Čára nakreslená na ploše pomocí nástroje Čára, hodnota Tah je nastavena na 2 obr. body.

  2. V inspektoru vlastností vyberte z rozevíracího seznamu Šířka položku Profil tloušťky a použijte ji.

    Tah s proměnlivou šířkou s hodnotou 68 obr. bodů
    Tah s proměnlivou šířkou vytvořený nástrojem Proměnlivá šířka, hodnota Tah je nastavena na 68 obr. bodů.

  3. Na časové ose vyberte jiný snímek, třeba snímek 30, a v Inspektoru vlastností vyberte v rozevíracím seznamu Šířka požadovaný profil tloušťky.

  4. Chcete-li přidat doplnění tvaru do vybraných profilů tloušťky, klikněte pravým tlačítkem na libovolný snímek v intervalu 1 až 30 a vyberte Vytvořit doplnění tvaru.

Logo Adobe

Přihlaste se ke svému účtu.