Formátování kódu

Kód, který píšete, můžete formátovat a odsazovat automaticky. Pokud používáte dynamické mapování písma, zkontrolujte, že se pro vícejazyčný text používají správná písma.

Nastavení voleb automatického formátování

  1. Proveďte jeden z následujících úkonů:
    • Z nabídky panelu  (v pravém horním rohu panelu Akce) vyberte Předvolby.

    • V okně Skript vyberte Úpravy > Předvolby (Windows) nebo Animate > Předvolby (Mac).

  2. V dialogovém okně Předvolby vyberte Automaticky formátovat.
  3. Vyberte libovolné z voleb automatického formátování.

    Když nastavíte volby automatického formátování, nastavení se automaticky aplikují u kódu, který napíšete, avšak nikoli u již existujícího kódu; u existujícího kódu musíte nastavení aplikovat ručně.

Formátování kódu podle nastavení automatického formátování

  • Klikněte na Automaticky formátovat  na panelu Akce nebo na panelu nástrojů okna Skript.
  • Z nabídky panelu (v pravém horním rohu panelu Akce) vyberte Automaticky formátovat.
  • Stiskněte Ctrl+Shift+F (Windows) nebo Command+Shift+F (Mac).
  • V okně Skript vyberte Nástroje > Automaticky formátovat.

Použití dynamického mapování písma

  1. Chcete-li zapnout nebo vypnout dynamické mapování písma, vyberte nebo odznačte Použít dynamické mapování písma v dialogovém okně Předvolby.

    Dynamické mapování písma je standardně vypnuté, protože prodlužuje provádění při skriptování. Pokud pracujete s vícejazyčným textem, dynamické mapování písma zapněte, protože pomáhá zajistit použití správných písem.

Používání automatického odsazení

  1. Chcete-li zapnout nebo vypnout automatické odsazování, vyberte nebo odznačte Automatické odsazení v dialogovém okně Předvolby.

    Když je automatické odsazování zapnuté, text, který zadáváte za počáteční kulatou závorkou „(“ nebo počáteční složenou závorkou „{“, se automaticky odsazuje podle nastavení Velikost tabulátoru v předvolbách ActionScriptu.

    V skriptu můžete odsadit řádek tím, že ho vyberete a stisknete klávesu tabulátoru. Chcete-li odsazení odstranit, vyberte řádek a stiskněte Shift+Tab.

Zakomentování částí kódu

Komentáře jsou části kódu, který kompilátor jazyka ActionScript ignoruje. Pomocí řádek s komentáři můžete vysvětlit, co daný kód dělá, anebo dočasně deaktivovat kód, který nechcete odstranit. Řádek kódu zakomentujete, když na začátek řádku napíšete dvě lomítka (//). Kompilátor ignoruje na dané řádce celý text za dvěmi lomítky. Zakomentovat můžete také větší bloky kódu, když na začátek bloku umístíte lomítko a hvězdičku (/*) a na konec bloku hvězdičku a lomítko (*/).

Tyto značky komentáře můžete zapsat ručně, nebo je můžete přidat pomocí tlačítek nahoře v panelu Akce nebo v okně Skript.

Zakomentování řádku kódu

  1. Umístěte textový kurzor na začátek řádku nebo před znak, kde má komentář začínat.
  2. Klikněte pravým tlačítkem myši a vyberte možnost Komentář. Můžete použít klávesové zkratky Ctrl + M (Windows) či Apple + M nebo přejít do nabídky Úpravy > Přidat poznámku k výběru.

V místě kurzoru se vloží dvě lomítka (//).

Zakomentování více řádků kódu

  1. Vyberte řádky, které chcete zakomentovat. (První a poslední řádek výběru mohou být vybrané jen částečně.)
  2. Klikněte pravým tlačítkem myši a vyberte možnost Komentář. Můžete použít klávesové zkratky Ctrl + M (Windows) či Apple + M nebo přejít do nabídky Úpravy > Přidat poznámku k výběru.

Znaky bloku komentáře se umístí na začátek (/*) a konec (*/) výběru.

Poznámka:

Pokud se komentáře nachází mezi vybranými řádky textu, bude na všechny vybrané řádky použit řádkový komentář.

Odstranění komentáře

  1. Umístěte kurzor do řádku, který obsahuje komentář, nebo vyberte blok kódu, který je zakomentovaný.
  2. Klikněte pravým tlačítkem myši a vyberte možnost Odebrat poznámku. Můžete použít klávesové zkratky Ctrl + Shift + M (Windows) či Apple + Shift + M nebo přejít do nabídky Úpravy > Odebrat poznámku u výběru.

Používání barevného zvýraznění syntaxe

V jazyce ActionScript, jako v každém jazyce, je syntaxe způsob skládání elementů dohromady, aby výsledek měl význam. Pokud použijete nesprávnou syntaxi ActionScriptu, skripty nebudou fungovat.

Chcete-li zvýraznit syntaktické chyby, nastavte barevná označení pro části skriptů. Předpokládejme například, že jste nastavili předvolby barevného zvýrazňování syntaxe tak, aby se klíčová slova zobrazovala modře. Když napíšete var, slovo var se zobrazí modře. Když ale chybně napíšete vae, slovo vae zůstane černé a to značí, že jste udělali překlep.

Proveďte jeden z následujících úkonů:

  • Vyberte položky Úpravy > Předvolby (Windows) nebo Animate > Předvolby (Mac), klikněte na Editor kódu v seznamu Kategorie a určete nastavení pro Barevné zvýraznění syntaxe.

  • S textovým kurzorem v dílčím panelu Skript stiskněte Ctrl-U (Windows) nebo Command-U (Mac).

Poznámka:

Když píšete skripty v panelu Akce, příkazy, které nejsou podporované cílovou verzí přehrávače, se v panelu nástrojů Akce zobrazují žlutě. Pokud je například v souboru Flash Player SWF nastavená verze na Flash 7, ActionScript, který je podporován pouze v přehrávači Flash Player 8, se v panelu nástrojů Akce zobrazuje žlutě.

Použití seznamu identifikátorů a klíčových slov za běhu

Při spuštění aplikace Animate jsou ze zdrojového souboru načteny seznamy identifikátorů a klíčových slov a uloženy do mezipaměti. Kromě čtení výchozích seznamů ze zdroje také vyhledává další seznamy klíčových slov a identifikátorů ve složce předvoleb. Další klíčová slova a identifikátory lze přidat přidáním souborů TXT do následujících složek:

  • C:\Users\<Jméno uživatele>[AppData]\Roaming\Adobe\Animate\13.0[ActionscriptKeywords]\

  • C:\Users\<Jméno uživatele>[AppData]\Roaming\Adobe\Animate\13.0[ActionscriptIdentifiers]\

  • C:\Users\<Jméno uživatele>[AppData]\Roaming\Adobe\Animate\13.0[JavascriptKeywords]\

  • C:\Users\<Jméno uživatele>[AppData]\Roaming\Adobe\Animate\13.0[JavascriptIdentifiers]\

Používání čísel řádků a zalamování řádků

Když upravujete nebo měníte kód, čísla řádků usnadňují rolování a analýzu. Zalamování řádků pomáhá vyhnout se potřebě vodorovného posouvání dlouhých řádků kódu (zvláště při používání vývojového prostředí nebo při malém rozlišení obrazovky).

Zapnutí nebo vypnutí čísel řádků

  • V okně Skript vyberte příkaz Zobrazení > Čísla řádků.
  • Stiskněte Ctrl+Shift+L (Windows) nebo Command+Shift+L (Mac).

Zvýraznění určitého řádku

  • V okně Skript vyberte Úpravy > Přejít na řádek.

Zapnutí nebo vypnutí zalamování řádků

  • V okně Skript vyberte příkaz Zobrazení > Zalamování řádků.
  • Stiskněte Ctrl+Shift+W (Windows) nebo Command+Shift+W (Mac).

Zobrazení skrytých znaků

Znaky jako mezery, tabulátory a konce řádků jsou v kódu jazyka ActionScript skryté. Může se stát, že budete potřebovat tyto znaky zobrazit, například budete muset najít a odstranit dvoubytové mezery, které nejsou součástí řetězcové hodnoty, protože způsobují chyby kompilátoru.

  • Stiskněte Ctrl+Shift+8 (Windows) nebo Command+Shift+8 (Mac).

K zobrazení skrytých znaků slouží následující symboly.

Skrytý znak

Symbol

Jednobytová mezera

.

Dvoubytová mezera

l

Tabulátor

>>

zalomení řádku


Hledání textu ve skriptu

Nástroj Hledat umožňuje hledat a nahrazovat textové řetězce ve skriptech.

Poznámka:

Pokud chcete hledat text ve všech skriptech dokumentu Animate, použijte Průzkumníka filmu.

Hledání textu

  1. V panelu Akce nebo v okně Skript klepněte na Hledat  nebo stiskněte Ctrl+F (Windows) nebo Command+F (Mac).
  2. Zadejte hledaný řetězec.
  3. Klikněte na Hledat další.

Hledání a nahrazování textu ve skriptu

  1. V panelu Akce nebo v okně Skript klepněte na Hledat  nebo stiskněte Ctrl+F (Windows) nebo Command+F (Mac).
  2. Zadejte hledaný řetězec.
  3. Do pole Nahradit zadejte nový řetězec.
  4. Klikněte na Hledat další.
  5. Chcete-li řetězec nahradit, klikněte na Nahradit, chcete-li nahradit všechny výskyty řetězce, klikněte na Nahradit vše.

(Zastaralé v aplikaci Animate CC) Opakování hledání na panelu Akce

  1. Z nabídky panelu  (v pravém horním rohu panelu Akce) vyberte možnost Hledat znovu.

(Zastaralé v aplikaci Animate CC) Opakování hledání v okně Skript

  1. Vyberte možnost Úpravy > Hledat znovu.

(Zastaralé v aplikaci Animate CC) Kontrola syntaxe a interpunkce

Můžete provést rychlou kontrolu kódu ActionScriptu bez publikování souboru FLA.

Když kontrolujete syntaxi, kontroluje se aktuální skript. Pokud aktuální skript volá třídy jazyka ActionScript, budou tyto třídy také zkontrolovány. Ostatní skripty, které mohou být v souboru FLA, zkontrolovány nebudou.

U souborů jazyka ActionScript 2.0 spustí příkaz Zkontrolovat syntaxi kód v kompilátoru, který vygeneruje chyby syntaxe a kompilátoru.

U souborů jazyka ActionScript 3.0 zkontroluje příkaz Zkontrolovat syntaxi pouze chyby syntaxe. Chcete-li vygenerovat chyby kompilátoru, například překlepy, nesprávné návratové hodnoty a chyby v názvech proměnných nebo metod, je třeba použít příkaz Ovládání > Testovat.

Kontrola syntaxe

Kontrolu syntaxe provedete tímto postupem:

  • V panelu Akce nebo v okně Skript klikněte na Zkontrolovat syntaxi .
  • Klikněte v panelu Skript a poté stiskněte tlačítka Ctrl+T (Windows) nebo Command+T (Mac). Panel Skript bude aktivní, pokud v něm kliknete nebo začnete psát. Pokud je aktivní objekt na ploše, je místo tohoto panelu otevřen panel Transformace.

Seznam syntaktických chyb se zobrazí v panelu Chyby kompilátoru.

Poznámka:

V souboru externích tříd jazyka ActionScript v okně Skript ovlivňuje kontrolu syntaxe nastavení globální cesty pro třídy (AS2) nebo zdrojové cesty (AS3). I když jsou globální cesta pro třídy nebo zdrojová cesta nastaveny správně, můžete vygenerovat chyby, protože kompilátor nemá informace o tom, že je kompilována tato třída.

Kontrola párovosti interpunkce

  1. Klikněte mezi složené závorky {}, hranaté závorky [] nebo kulaté závorky () ve skriptu.
  2. Ve Windows stiskněte Ctrl+' (apostrof), na Macu stiskněte Command+' (apostrof). Text mezi složenými, hranatými nebo kulatými závorkami se zvýrazní a vy můžete zkontrolovat, zda počáteční závorka má odpovídající koncovou závorku.

(Zastaralé v aplikaci Animate CC) Import a export skriptů

Skript můžete importovat do panelu Akce nebo do okna Skript. Skripty může také exportovat z panelu Akce do externích souborů ActionScript. (Když používáte okno Skript, export není nezbytný, protože místo toho můžete soubor AS uložit.)

Pokud text ve skriptech nevypadá po otevření nebo importu souboru podle očekávání, změňte předvolbu importu kódování.

Importování externího souboru AS

  1. V panelu Skript umístěte textový kurzor do místa, kam chcete umístit první řádek externího skriptu.
  2. Proveďte jeden z následujících úkonů:
    • V panelu Akce vyberte z nabídky panelu Importovat skript nebo stiskněte Ctrl+Shift+I (Windows) nebo Command+Shift+I (Mac).

    • V okně Skript vyberte příkaz Soubor > Importovat skript nebo stiskněte klávesy Ctrl+Shift+I (v systému Windows) nebo Command+Shift+I (na počítačích Mac).

Exportování skriptu z panelu Akce

  1. Vyberte skript, který chcete exportovat. Pak z nabídky panelu Akce vyberte Exportovat skript, nebo stiskněte Ctrl+Shift+X (Windows) nebo Command+Shift+X (Mac).
  2. Uložte soubor jazyka ActionScript (AS).

Nastavení voleb kódování textu

  1. Vyberte Úpravy > Předvolby (Windows) nebo Animate > Předvolby (Mac) a v seznamu Kategorie vyberte ActionScript.

  2. Nastavte libovolné z těchto voleb:

    Otevřít/importovat

    Vyberte kódování UTF-8, chcete-li otevírat nebo importovat pomocí kódování Unicode, nebo vyberte Výchozí kódování, chcete-li otevírat nebo importovat pomocí kódování, které právě používá váš systém.

    Uložit/exportovat

    Vyberte kódování UTF-8, chcete-li ukládat nebo exportovat pomocí kódování Unicode, nebo vyberte Výchozí kódování, chcete-li ukládat nebo exportovat pomocí kódování, které právě používá váš systém.

Zapnutí nebo vypnutí upozornění na kódování při exportu

  1. Vyberte Úpravy > Předvolby (Windows) nebo Animate > Předvolby (Mac) a vyberte Upozornění v seznamu Kategorie.

  2. Vyberte nebo odznačte Upozornit na konflikty kódování při exportu souborů ActionScript.

(Zastaralé v aplikaci Animate CC) Kódování importovaných a exportovaných skriptů

Chcete-li určit typ kódování, který se má používat při importu nebo exportu souborů ActionScript, můžete nastavit předvolby jazyka ActionScript. Kódování UTF-8 je 8-bitový formát Unicode, který umožňuje vložit do souboru text ve více jazycích; Výchozí kódování je kódování podporované jazykem, který právě váš systém používá, a které se také nazývá tradiční kódová stránka.

Poznámka:

Když používáte jinou než anglickou aplikaci na anglickém systému, příkaz Testovat film skončí chybou, pokud libovolná část cesty souboru SWF obsahuje znaky, které nelze vyjádřit pomocí schématu kódování vícebytových znakových sad (MBCS-Multibyte Character Sets). Například cesty s japonštinou, které fungují na japonském systému, nebudou fungovat na anglickém systému. Na anglických systémech používejte pouze názvy cest s anglickými písmeny. Toto omezení platí pro všechny části aplikace, které používají testovací přehrávač filmů.

Přidržení skriptů na panelu Akce

Pomocí funkce Přidržet skript můžete připínat skripty ke kartám jednotlivých skriptů na panelu Skript a podle potřeby je přesouvat. Tato funkce se hodí, když v rámci souboru FLA nemáte všechen kód uspořádaný do jednoho centrálního umístění anebo pokud používáte víc skriptů najednou.

Přidržením skriptu uložíte aktuální umístění kódu na panelu Akce a budete moct přepínat mezi různými otevřenými skripty. To se hodí zejména při ladění. 

Můžete připínat a uvolňovat jednotlivé skripty nebo je pomocí panelu Akce připnout či uvolnit všechny najednou.

V následujícím obrázku je skript přiřazený aktuální poloze v časové ose umístěn ve snímku Frame 1 vrstvy s názvem Cleanup. (Záložka zcela vlevo vždy uvádí vaši polohu na časové ose.) Tento skript je také přidržený (zobrazuje se v záložce zcela vpravo). Následující dva skripty jsou přidržené:

  • Na snímku 1
  • Na snímku 15 ve vrstvě nazvané Intro

Mezi připnutými skripty můžete přepínat kliknutím na záložky nebo pomocí klávesových zkratek. Přepínání mezi jednotlivými přidrženými skripty nemění aktuální polohu na časové ose.Když v navigátoru skriptů na panelu Akce vyberete nový skript, přepne se zobrazení na první snímek, tj. snímek 1.

Poznámka:

Pokud se obsah panelu Skript nemění podle místa vybraného na časové ose, nejspíš to znamená, že na panelu Skript je zobrazen přidržený skript. Kliknutím na záložku aktuálního snímku v levé horní části panelu Skript zobrazíte skript spojený s daným místem na časové ose.

Přidržený skript

Přidržení skriptu

  1. Klikněte na časovou osu, čímž na záložce aktuálního snímku v levé horní části podokna Skript na panelu Akce zobrazíte příslušný skript.

  2. Proveďte jeden z následujících úkonů:
    • Klikněte na ikonu připínáčku vpravo od záložky.
    • Volbou Vybrat > Přidržet skript aktivujete přidržení skriptu.

     

Uvolnění všech skriptů

  1. Na panelu Akce vyberte přidržený skript.

  2. Volbou Zobrazení > Uvolnit skript uvolníte vybraný skript z panelu Akce.

  3. Volbou Zobrazení > Uvolnit všechny skripty uvolníte všechny skripty z panelu Akce.

Možnosti uvolnění

Klávesové zkratky pro přidržené skripty

Když je textový kurzor v panelu Skript, můžete pro práci s přidrženými skripty používat následující klávesové zkratky.

Akce

Windows 

Mac

Přidržet skript

Control+Shift+= (znaménko rovná se)

Command+Shift+=

Uvolnit skript

Ctrl+Shift+- (znaménko mínus)

Command+Shift+-

Vkládání cílových cest

Mnoho akcí ve skriptech je určeno k ovlivňování filmových klipů, tlačítek a jiných instancí symbolů. V kódu se můžete na tyto instance symbolů v časové ose odkazovat vložením cílové cesty, neboli adresy instance, kterou chcete zpracovat. Můžete nastavit buď absolutní, nebo relativní cílovou cestu. Absolutní cesta obsahuje celou adresu instance. Relativní cesta obsahuje pouze část adresy, která se liší od adresy samotného skriptu v souboru FLA, a nebude fungovat, pokud skript přesunete do jiného místa.

  1. V panelu Akce klepněte na akci ve skriptu.
  2. Klikněte na Cílová cesta .
  3. Zadejte cestu k cílové instanci nebo vyberte cíl ze seznamu.
  4. Vyberte volbu cesty buď Absolutní nebo Relativní.

Používání rad při psaní kódu

Když pracujete v panelu Akce nebo v okně Skript, software může zjistit, jakou akci zadáváte, a zobrazit radu při psaní kódu. Existují dva druhy rad při psaní kódu: rozbalovací popisy, které obsahují úplnou syntaxi pro danou akci, a rozbalovací nabídky, které obsahují přehled možných elementů jazyka ActionScript, jako jsou názvy metod nebo vlastností (někdy zmiňované jako forma doplňování kódu).

Rady při psaní kódu jsou standardně zapnuté. Nastavením předvoleb můžete rady při psaní kódu vypnout nebo určit, jako rychle se mají zobrazovat. I když jsou rady při psaní kódu v předvolbách vypnuté, můžete ručně zobrazit radu při psaní kódu pro určitý příkaz.

Poznámka:

Když se vám nedaří zobrazit rady při psaní kódu pro určitou proměnnou nebo objekt vytvořený v ActionScriptu 2.0, ale přitom v předvolbách ActionScriptu jsou rady při psaní kódu povolené, zkontrolujte, jestli jste proměnnou nebo objekt nazvali správnou příponou nebo jestli jste pro proměnnou nebo objekt nastavili přísné typování.

Zapnutí rad při psaní kódu

Rady při psaní kódu můžete spouštět různými způsoby.

Přísné typování objektů

Když používáte ActionScript 2.0 a přísné typování pro proměnnou, která je odvozená od vestavěné třídy (jako je Button, Array apod.), zobrazí se pro proměnnou v panelu Skript rady při psaní kódu. Předpokládejme například, že jste zadali následující dva řádky kódu:

var foo:Array = new Array(); 
foo.

Jakmile zapíšete tečku (.), aplikace Animate zobrazí v rozbalovací nabídce seznam metod a vlastností dostupných pro objekty Array, protože jste proměnnou zadali jako pole.

Přípony a rady při psaní kódu

Pokud použijete ActionScript 1.0 nebo pokud chcete zobrazit rady při psaní kódu pro objekty bez přísného typování, přidejte při vytváření každého objektu k jeho názvu příponu. Například přípona, která vyvolá radu při psaní pro třídu Camera, je _cam. Předpokládejme, že jste zadali následující kód: var my_array = new Array(); var my_cam = Camera.get();

Když zadáte my_cam a za tím tečku, zobrazí se rady při psaní kódu pro objekt Camera.

Pro objekty, které se zobrazují ve vymezené ploše, použijte příponu v poli Název instance v inspektoru Vlastnosti. Chcete-li například zobrazit rady při psaní kódu pro objekty MovieClip, pomocí inspektoru Vlastnosti přiřaďte příponu _mc k názvům všech instancí objektů MovieClip. Pokaždé, když pak napíšete název instance a za ním tečku, zobrazí se rady při psaní kódu.

var my_array = new Array(); 
var my_cam = Camera.get();

Poznámka:

Přestože přípony nejsou pro zobrazení rad při psaní kódu nutné, když pro objekt použijete přísné typování, jejich důsledné používání zlepšuje srozumitelnost kódu.

V následující tabulce je seznam přípon, které spouštějí rady při psaní kódu v ActionScriptu 2.0:

Typ objektu

Přípona proměnné

Array

_array

Button

_btn

Camera

_cam

Color

_color

ContextMenu

_cm

ContextMenuItem

_cmi

Date

_date

Error

_err

LoadVars

_lv

LocalConnection

_lc

Microphone

_mic

MovieClip

_mc

MovieClipLoader

_mcl

PrintJob

_pj

NetConnection

_nc

NetStream

_ns

SharedObject

_so

Sound

_sound

String

_str

TextField

_txt

TextFormat

_fmt

Video

_video

XML

_xml

XMLNode

_xmlnode

XMLSocket

_xmlsocket

Komentáře a rady při psaní kódu

Chcete-li určit třídu objektu pro rady při psaní kódu, můžete použít také komentáře jazyka ActionScript. V následujícím příkladu poznámka říká jazyku ActionScript, že třída instance theObject je Object a tak dále.

// Object theObject;// Array theArray;// MovieClip theMC;

Když pak následně zapíšete theMC a za tím tečku, zobrazí se rady při psaní kódu, která uvádí přehled metod a vlastností pro MovieClip. Když zapíšete theArray a za tím tečku, zobrazí se rady při psaní kódu, která uvádí přehled metod a vlastností pro Array a tak dále.

Místo tohoto postupu ale Adobe doporučuje použití přísného typování nebo přípon, protože tyto postupy povolují rady při psaní kódu automaticky a zlepšují srozumitelnost kódu.

Nastavení předvoleb pro automatické rady při psaní kódu

  • Na panelu Akce nebo v okně Skript vyberte položky Úpravy > Předvolby (Windows) nebo Animate > Předvolby (Mac), klikněte na Editor kódu v seznamu Kategorie a pak povolte nebo zakažte Rady při psaní kódu.

(Zastaralé v aplikaci Animate CC) Nastavení zpoždění rad při psaní kódu

  1. V panelu Akce nebo v okně Skript vyberte Úpravy > Předvolby (Windows) nebo Animate > Předvolby (Mac).

  2. V seznamu Kategorie klikněte na ActionScript.
  3. Pomocí jezdce nastavte požadovanou dobu zpoždění v sekundách.

Používání rozbalovacích popisů rad při psaní kódu

  1. Radu při psaní kódu můžete zobrazit zapsáním počáteční závorky „(“ za element, který vyžaduje uvozovky (například za název metody nebo příkazu, jako je if nebo do.while a podobně).
    Počáteční závorka vyvolá rady při psaní kódu

  2. Zadejte hodnotu parametru.

    Pro více parametrů oddělte hodnoty čárkou. Pro funkce nebo příkazy, jako je for opakovat, oddělte parametry středníkem.

    U přetížených příkazů (funkce nebo metody, které mohou být vyvolány s různými sadami parametrů), jako jsou gotoAndPlay() nebo for, se zobrazí indikátor, který umožňuje vybrat parametr, který chcete nastavit. Parametr vyberte klepnutím na některou z malých šipek nebo stiskem klávesové zkratky Ctrl+šipka vlevo nebo Ctrl+šipka vpravo.

    Rada při psaní kódu s více sadami parametrů

  3. Chcete-li radu při psaní kódu zrušit, proveďte jeden z následujících úkonů:
    • Zapište koncovou závorku „)“.

    • Klepněte mimo příkaz.

    • Stiskněte Esc.

Používání rozbalovacích nabídek rad při psaní kódu:

  1. Radu při psaní kódu můžete zobrazit zapsáním tečky za název proměnné nebo objektu.
    Rozbalovací nabídka rad při psaní kódu

  2. Chcete-li procházet rady při psaní kódu, použijte klávesy se šipkou dolů a nahoru.
  3. Chcete-li vybrat položku v nabídce, stiskněte klávesu Enter nebo klávesu tabulátoru, nebo na položku dvakrát klikněte.
  4. Chcete-li radu při psaní kódu zrušit, proveďte jeden z následujících úkonů:
    • Vyberte jednu z položek nabídky.

    • Klepněte nad nebo pod okno nabídky.

    • Pokud jste již zapsali počáteční závorku „(“, zapište koncovou závorku „)“.

    • Stiskněte Esc.

Ruční zobrazení rady při psaní kódu

  1. Klikněte do místa v kódu, kde se rada při psaní kódu může zobrazit, například do následujících míst:
    • Za tečku (.) následující za instrukcí nebo příkazem, kde se musí zadat vlastnost nebo metoda

    • Mezi závorky [()] za názvem metody

  2. Proveďte jeden z následujících úkonů:
    • Chcete-li rady při psaní kódu povolit ručně, vyberte položky Zobrazit > Zobrazit radu při psaní kódu.

    • Stiskněte klávesy Ctrl+mezerník (Windows) nebo Command+mezerník (Mac).

Rady při psaní kódu u vlastních tříd

Když vytváříte vlastní třídy jazyka ActionScript 3.0, aplikace Animate tyto třídy analyzuje a určí v nich obsažené objekty, vlastnosti a metody. Aplikace Animate pak může při psaní kódu poskytovat rady odkazující na vlastní třídy. Dokončování kódu vlastních tříd se automaticky provádí u všech tříd, které pomocí příkazu import provážete s jiným kódem.

Díky radům při psaní kódu mohou vývojáři pracovat rychleji, protože si nemusí pamatovat všechny objekty, metody a vlastnosti, které ta která třída používá. Návrháři zase mohou pracovat s třídami, které sami nenapsali, protože není nutné, aby měli přímé znalosti postupů práce s konkrétní třídou.

Rady při psaní kódu obsahují tyto funkce:

  • Rady při psaní kódu pro vnořené odkazy na třídy

    Při psaní vložených odkazů vám budou rady při psaní kódu neustále pomáhat.

  • Rady při psaní kódu pro výraz „this“

    Když v souboru třídy zadáte výraz „this“, zobrazí se rady při psaní kódu na stejnou třídu.

  • Rady při psaní kódu pro výraz „new+<mezera>“

    Když zadáte výraz „new+<mezera>“, aplikace Animate zobrazí seznam dostupných tříd a balíčků.

  • Rady při psaní kódu pro výraz „import“

    Když zadáte výraz „import+ <mezera>“, aplikace Animate zobrazí seznam všech zabudovaných i vlastních balíčků.

  • Rady při psaní kódu pro knihovny SWC

    Když k cestě knihovny přidáváte knihovnu SWC nebo cestu externí knihovny, povolí aplikace Animate rady při psaní kódu pro všechny třídy obsažené v tomto souboru SWC.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online