Příručka uživatele Zrušit

Vytvoření rozšíření HTML

  1. Příručka uživatele aplikace Adobe Animate
  2. Úvod do aplikace Animate
    1. Novinky v aplikaci Animate
    2. Grafický glosář
    3. Systémové požadavky pro aplikaci Animate
    4. Klávesové zkratky aplikace Animate
    5. Práce s různými typy souborů v aplikaci Animate
  3. Animace
    1. Základy animování v aplikaci Animate
    2. Používání snímků a klíčových snímků v aplikaci Animate
    3. Animace po jednotlivých snímcích v aplikaci Animate
    4. Práce s animacemi klasických doplnění v aplikaci Animate
    5. Nástroj Štětec
    6. Vodítko pohybu
    7. Doplnění pohybu a ActionScript 3.0
    8. O animacích s doplněními pohybu
    9. Animace s doplněním pohybu
    10. Vytvoření animace s doplněním pohybu
    11. Používání klíčových snímků vlastností
    12. Animování polohy pomocí doplnění
    13. Úpravy doplnění pohybu v editoru pohybu
    14. Úpravy cesty pohybu u animace s doplněním
    15. Úpravy doplnění pohybu
    16. Přidání vlastního náběhu nebo doběhu
    17. Vytváření a aplikování přednastavení pohybu
    18. Nastavení rozsahu doplnění animace
    19. Práce s doplněními pohybu uloženými jako soubory XML
    20. Srovnání doplnění pohybu a klasických doplnění
    21. Doplňování tvarů
    22. Používání animací nástroje Kost v aplikaci Animate
    23. Sestavování postav v aplikaci Animate
    24. Používání vrstev masek v aplikaci Adobe Animate
    25. Práce se scénami v aplikaci Animate
  4. Interaktivita
    1. Vytváření tlačítek v aplikaci Animate
    2. Převod projektů aplikace Animate na jiné typy dokumentů
    3. Vytváření a publikování dokumentů HTML5 Canvas v aplikaci Animate
    4. Přidání interaktivity pomocí fragmentů kódu v aplikaci Animate
    5. Vytváření vlastních komponent HTML5
    6. Používání komponent v dokumentech HTML5 Canvas
    7. Vytváření vlastních komponent: Příklady
    8. Fragmenty kódu pro vlastní komponenty
    9. Osvědčené postupy – Tvorba reklam v aplikaci Animate
    10. Vytváření a publikování virtuální reality
  5. Pracovní plocha a pracovní postupy
    1. Vytváření a správa malířských štětců
    2. Používání písem Google v dokumentech HTML5 Canvas
    3. Používání knihoven Creative Cloud v aplikaci Adobe Animate
    4. Používání vymezené plochy a panelu nástrojů v aplikaci Animate
    5. Pracovní postupy a pracovní plocha aplikace Animate
    6. Používání webových písem v dokumentech HTML5 Canvas
    7. Časové osy a ActionScript
    8. Práce s více časovými osami
    9. Nastavení předvoleb
    10. Používání vývojových panelů aplikace Animate
    11. Vytváření vrstev časové osy v aplikaci Animate
    12. Export animací pro mobilní aplikace a herní moduly
    13. Přemísťování a kopírování objektů
    14. Předlohy
    15. Příkaz Hledat a nahradit v aplikaci Animate
    16. Vrácení akce, její zopakování a panel Historie
    17. Klávesové zkratky
    18. Používání časové osy v aplikaci Animate
    19. Vytvoření rozšíření HTML
    20. Možnosti optimalizace obrázků a animovaných souborů GIF
    21. Export nastavení pro obrázky a soubory GIF
    22. Panel Datové zdroje v aplikaci Animate
  6. Multimédia a video
    1. Transformace a kombinování grafických objektů v aplikaci Animate
    2. Vytváření a práce s instancemi symbolů v aplikaci Animate
    3. Vektorizace obrazu
    4. Používání zvuku v aplikaci Adobe Animate
    5. Export souborů SVG
    6. Vytváření souborů videa používaných v aplikaci Animate
    7. Přidání videa v aplikaci Animate
    8. Práce se startovacími body videa
    9. Kreslení a vytváření objektů v aplikaci Animate
    10. Změna čar a tvarů
    11. Tahy, výplně a přechody v aplikaci Animate
    12. Práce s aplikacemi Adobe Premiere Pro a After Effects
    13. Panely barev v aplikaci Animate
    14. Otevírání souborů aplikace Flash CS6 v aplikaci Animate
    15. Práce s klasickým textem v aplikaci Animate
    16. Vložení grafiky do aplikace Animate
    17. Importované bitmapy v aplikaci Animate
    18. 3D grafika
    19. Práce se symboly v aplikaci Animate
    20. Kreslení čar a tvarů v aplikaci Adobe Animate
    21. Práce s knihovnami v aplikaci Animate
    22. Export zvuků
    23. Výběr objektů v aplikaci Animate
    24. Práce se soubory aplikace Illustrator (AI) v aplikaci Animate
    25. Nanášení vzorů pomocí nástroje Stopa spreje
    26. Používání režimů prolnutí
    27. Uspořádání objektů
    28. Automatizace úloh pomocí nabídky Příkazy
    29. Vícejazyčný text
    30. Používání kamery v aplikaci Animate
    31. Používání aplikace Animate s nástrojem Adobe Scout
    32. Práce se soubory aplikace Fireworks
    33. Grafické filtry
    34. Zvuk a ActionScript
    35. Předvolby kreslení
    36. Kreslení nástrojem Pero
  7. Platformy
    1. Převod projektů aplikace Animate na jiné typy dokumentů
    2. Podpora vlastní platformy
    3. Vytváření a publikování dokumentů HTML5 Canvas v aplikaci Animate
    4. Vytvoření a publikování dokumentu ve formátu WebGL
    5. Balení aplikací pro prostředí AIR for iOS
    6. Publikování aplikací prostředí AIR for Android
    7. Publikování pro prostředí Adobe AIR pro počítače
    8. Nastavení publikování jazyka ActionScript
    9. Osvědčené postupy – Uspořádání ActionScriptu v aplikaci
    10. Používání jazyka ActionScript v aplikaci Animate
    11. Osvědčené postupy – Pravidla usnadnění přístupu
    12. Usnadnění přístupu v pracovním prostoru aplikace Animate
    13. Psaní a správa skriptů
    14. Povolení podpory vlastních platforem
    15. Přehled podpory vlastních platforem
    16. Vytváření přístupného obsahu
    17. Práce se zásuvným modulem pro podporu vlastní platformy
    18. Ladění jazyka ActionScript 3.0
    19. Povolení podpory vlastních platforem
  8. Export a publikování
    1. Export souborů z aplikace Animate
    2. Publikování OAM
    3. Export souborů SVG
    4. Export grafiky a videa v aplikaci Animate
    5. Publikování dokumentů AS3
    6. Export animací pro mobilní aplikace a herní moduly
    7. Export zvuků
    8. Export videosouborů QuickTime
    9. Ovládání externího přehrávání videa s použitím jazyka ActionScript
    10. Osvědčené postupy – Tipy pro vytváření obsahu pro mobilní zařízení
    11. Osvědčené postupy – Konvence videa
    12. Osvědčené postupy – Pravidla pro vývoj aplikací SWF
    13. Osvědčené postupy – Strukturování souborů FLA
    14. Osvědčené postupy pro optimalizaci souborů FLA pro Animate
    15. Nastavení publikování jazyka ActionScript
    16. Nastavení publikování v aplikaci Animate
    17. Export souborů projektoru
    18. Export obrázků a animovaných souborů GIF
    19. Předlohy publikování HTML
    20. Práce s aplikacemi Adobe Premiere Pro a After Effects
    21. Rychlé sdílení a publikování animací

Aplikaci Animate je možné doplňovat o rozšíření HTML. K vytváření rozšíření HTML pro aplikaci Animate slouží nástroj Adobe Extension Builder 3. V minulosti bylo možné v aplikaci Animate používat pouze rozšíření SWF. Adobe Extension Builder 3 však umožňuje vytvářet rozšíření HTML pro aplikace Creative Cloud. Abyste mohli začít, musíte stáhnout a nainstalovat Eclipse a Extension Builder 3.0.

Vytvoření rozšíření HTML

Rozšíření HTML vytvoříte následujícím postupem:

  1. Spusťte prostředí Eclipse. 
  2. V průvodci novým projektem vytvořte nový projekt rozšíření aplikace. Zadejte pro projekt příhodný název a klikněte na tlačítko Next (Další).
  3. Na panelu New Adobe Application Extension Project (Nový projekt rozšíření aplikace Adobe) vyberte Adobe Animate. Klikněte na Další.
  4. Ke konfiguraci rozšíření použijte dostupné možnosti:
    1. Bundle ID (ID kompletu) jednoznačně identifikuje rozšíření.
    2. Menu name (Název v nabídce) je zobrazovaný název rozšíření. Tento název se v aplikaci Animate zobrazí v nabídce Okno > Rozšíření.
    3. Window Details (Podrobnosti okna) – tyto možnosti slouží k přizpůsobení typu a velikosti okna rozšíření.

      Klikněte na tlačítko Next (Další).
  5. Na dalších obrazovkách můžete dále upravit referenční knihovny svého rozšíření.
    1. CEP Interface Library (Knihovna rozhraní CEP) poskytuje funkce pro interakce s hostitelskou aplikací. Ve výchozím nastavení je tato možnost vybrána.
    2. Frameworks (Rámce) jsou určeny pro společné knihovny JavaScriptu, jako je jQuery.
    3. Services (Služby) zahrnují sadu nástrojů Adobe pro komunikaci IPC, která umožňuje komunikaci mezi aplikacemi, rozšířeními a externími aplikacemi Adobe. Poskytuje protokol pro zasílání zpráv prostřednictvím nástroje CEP Service Manager, který funguje jako komunikační centrum služby Creative Cloud.

      Kliknutím na tlačítko Finish (Dokončit) vytvoříte nový projekt Eclipse.

Ladění rozšíření v aplikaci Animate 

Rozšíření můžete spustit přímo v prostředí Eclipse:

  1. Klikněte pravým tlačítkem na projekt a vyberte Run As (Spustit jako) > Adobe Flash Extension (Rozšíření aplikace Adobe Flash). Tím spustíte aplikaci Animate.
  2. V Animate vyberte položku nabídky Okno > Rozšíření. Otevře se panel Rozšíření.

Export rozšíření

Chcete-li svoje rozšíření distribuovat, musíte je exportovat jako balíček ZXP. Balíček ZXP pak bude stažen a spuštěn nástrojem Adobe Extension Manager v aplikacích Creative Cloud:

  1. V prostředí Eclipse přejděte do okna Script Explorer (Prohlížeč skriptu), klikněte pravým tlačítkem na svůj projekt a vyberte příkaz Export (Exportovat) > Adobe Extension Builder 3 > Application Extension (Rozšíření aplikace). Zobrazí se průvodce exportem.
  2. Musíte mít k dispozici certifikát, abyste mohli balíček rozšíření podepsat. Vyhledejte stávající certifikát nebo klikněte na položku Create (Vytvořit) a vytvořte nový.
  3. Klikněte na tlačítko Finish (Dokončit).
  4. Po dokončení exportu naleznete balíček ZXP vašeho rozšíření připravený k distribuci ve složce projektu.

Poznámka: K instalaci budete potřebovat přístup k souboru <rozšíření>\.staged-extension\CSXS\manifest.xml, kde provedete aktualizaci tagu host nastavením minimální verze aplikace Animate na 13.0.

Instalace rozšíření do aplikace Animate 

Rozšíření HTML lze nainstalovat do aplikace Animate pomocí nástroje Adobe Extension Manager. Rozšíření HTML mohou usnadnit doplňování funkcí a možností aplikace Animate.

Doplňování možností interakce do rozšíření HTML

Rozšíření HTML můžete vytvořit tak, aby spolupracovalo s aplikací Animate – přidáním ovládacích prvků a definováním chování – a získávalo informace o hostitelském prostředí (zahrnuje Animate a operační systém). Toho lze dosáhnout dvěma způsoby:

  1. Pomocí knihovny rozhraní CEP: Knihovna rozhraní CEP obsahuje rozhraní API pro získávání informací o hostitelském prostředí a vyhodnocovací skript, který umožňuje spouštění souborů JSFL. Chcete-li získat více informací o knihovně rozhraní CEP, otevřete v prostředí Eclipse nabídku Help (Nápověda) > Help Contents (Obsah nápovědy) > Adobe Extension Builder > References (Odkazy).
  2. Pomocí jazyka JSFL: Skripty JSFL je možné spouštět pomocí rozhraní API skriptu Eval obsažených v knihovně rozhraní CEP.

    Infrastruktura CEP v aplikaci Animate nabízí kromě skriptů JSFL také následující události, které lze používat pouze na panelech HTML:
    • Událost com.adobe.events.flash.documentChanged se spouští při změně aktuálního aktivního dokumentu.
    • Událost com.adobe.events.flash.timelineChanged se spouští, když uživatel provede změnu na časové ose aktuálního aktivního dokumentu.
    • Událost com.adobe.events.flash.documentSaved se spouští, když uživatel uloží aktuální dokument.
    • Událost com.adobe.events.flash.documentOpened se spouští, když uživatel otevře nový dokument.
    • Událost com.adobe.events.flash.documentClosed se spouští, když uživatel zavře aktuální aktivní dokument.
    • Událost com.adobe.events.flash.documentNew se spouští, když uživatel vytvoří nový dokument.
    • Událost com.adobe.events.flash.layerChanged se spouští, když uživatel vybere jinou vrstvu.
    • Událost com.adobe.events.flash.frameChanged se spouští, když uživatel vybere jiný snímek.
    • Událost com.adobe.events.flash.selectionChanged se spouští, když uživatel vybere jiný objekt na ploše.
    • Událost com.adobe.events.flash.mouseMove se spouští, když uživatel přesune ukazatel myši na ploše.

Příklad

csinterface.addEventListener(&quot;com.adobe.events.flash.selectionChanged&quot;, CallbackFunction)

Ve fragmentu kódu výše:

  • csinterface: objekt knihovny rozhraní CEP
  • com.adobe.events.flash.selectionChanged: událost, která spouští změnu výběru objektu; je možné použít také kteroukoli událost uvedenou výše
  • CallbackFunction: metoda, která naslouchá spuštěné události
Logo Adobe

Přihlaste se ke svému účtu.