O animacích klasických doplnění

Poznámka:

Podobně jako většina věcí v aplikaci Animate nevyžaduje animace žádný ActionScript. Pokud však chcete, můžete animaci pomocí ActionScriptu vytvořit.

Klasická doplnění jsou starším způsobem vytváření animací v aplikaci Animate. Tato doplnění jsou podobná novějším doplnění pohybu, ale jejich vytváření je o něco složitější a méně flexibilní. Na druhou stranu však klasická doplnění nabízí některé typy ovládání animace, které doplnění pohybu nenabízí. Většina uživatelů si pro práci zvolí novější doplnění pohybu, ale někteří uživatelé budou stále raději používat klasická doplnění. Další informace o těchto rozdílech viz téma Rozdíly mezi doplněními pohybu a klasickými doplněními.

Na úvod:

Než se pustíte do práce s klasickými doplněními, mějte na paměti následující body:

  • Klasická doplnění jsou starším způsobem vytváření doplňované animace v aplikaci Animate. Novější a snadnější způsob je použití doplnění pohybu. Viz téma Animace doplnění pohybu.

  • Klasickými doplněními nelze doplnit 3D vlastnosti.

Ukázky klasických doplňovaných animací najdete na stránce ukázek aplikace na adrese www.adobe.com/go/learn_fl_samples_cz. K dispozici jsou následující ukázky:

  • Animovaný vržený stín: Chcete-li zobrazit tuto ukázku, stáhněte a dekomprimujte soubor zip s ukázkami a přejděte do složky Graphics\AnimatedDropShadow.

  • Animace a přechody: Chcete-li zobrazit tuto ukázku, stáhněte a dekomprimujte soubor zip s ukázkami a přejděte do složky Graphics\AnimationAndGradients.

Vytváření a úpravy klíčových snímků pro animaci klasického doplnění

Poznámka:

Toto téma pojednává o vytváření klíčových snímků pro starší klasická doplnění. Nápovědu k vlastnostem klíčových snímků pro nová doplnění pohybu získáte v tématu Vytváření animace doplnění.

Změny v animaci klasického doplnění definuje klíčový snímek. V doplňované animaci definujete klíčové snímky ve významných bodech v animaci a aplikace Animate vytvoří obsah snímků mezi nimi. Interpolované snímky doplňované animace se zobrazují jako světle modré nebo světle zelené se šipkou nakreslenou mezi klíčovými snímky. Protože dokumenty aplikace Animate uchovávají tvary v každém klíčovém snímku, vytvářejte klíčové snímky pouze v těch bodech kresby, kde se něco mění.

Klíčové snímky jsou vyznačeny v časové ose: plný kroužek představuje klíčový snímek s uloženým obsahem a prázdný kroužek před snímkem představuje prázdný klíčový snímek. Následující snímky přidávané do stejných vrstev mají stejný obsah jako klíčový snímek.

V klasických doplněních lze upravovat pouze klíčové snímky. Doplněné snímky můžete prohlížet, ale nemůžete je přímo upravovat. Chcete-li upravit doplněné snímky, změňte jeden z definujících klíčových snímků nebo vložte nový klíčový snímek mezi počáteční a koncový klíčový snímek. Pokud chcete přidat položky do aktuálního klíčového snímku, přetáhněte položky z panelu Knihovna na vymezenou plochu.

Chcete-li zobrazit a upravit více než jeden snímek najednou, podívejte se na téma Použití průsvitek.

Postup vytváření klíčových snímků

  1. Proveďte jeden z následujících úkonů:
    • Vyberte snímek v časové ose a vyberte Vložit > Časová osa > Klíčový snímek.

    • Klepněte pravým tlačítkem (Windows) nebo s klávesou Ctrl (Macintosh) na snímek v časové ose a vyberte Vložit klíčový snímek.

Vkládání snímků na časovou osu

  • Pokud chcete vložit nový snímek, vyberte možnosti Vložit > Časová osa > Snímek.

  • Chcete-li vytvořit nový klíčový snímek, vyberte možnosti Vložit > Časová osa > Klíčový snímek, nebo klepněte pravým tlačítkem (Windows) nebo s klávesou Ctrl (Macintosh) na snímek, na který chcete umístit klíčový snímek, a vyberte příkaz Vložit klíčový snímek.

  • Chcete-li vytvořit nový prázdný klíčový snímek, vyberte Vložit > Časová osa > Prázdný klíčový snímek, nebo klepněte pravým tlačítkem (Windows) nebo s klávesou Ctrl (Macintosh) na snímek, na který chcete umístit klíčový snímek, a vyberte Vložit prázdný klíčový snímek.

Odstranění nebo změna snímku nebo klíčového snímku

  • Chcete-li odstranit snímek, klíčový snímek nebo sekvenci snímků, vyberte je a klikněte pravým tlačítkem (Windows) nebo s klávesou Ctrl (Macintosh) a vyberte Odstranit snímky. Okolní snímky zůstanou nezměněné.

  • Chcete-li přemístit klíčový snímek nebo sekvenci snímků a jejich obsah, vyberte je a přetáhněte je do požadované polohy.

  • Chcete-li prodloužit trvání klíčového snímku, přetáhněte ho na poslední snímek nové sekvence se stisknutou klávesou Alt.

  • Chcete-li kopírovat a vložit snímek nebo sekvenci snímků, vyberte je a zvolte Úpravy > Časová osa > Kopírovat snímky. Vyberte snímek nebo sekvenci, které chcete nahradit, a vyberte Úpravy > Časová osa > Vložit snímky.Pokud chcete na cílovou časovou osu vložit přesný počet kopírovaných snímků a nahradit je, použijte možnost Vložit a přepsat snímky.

  • Chcete-li klíčový snímek převést na běžný snímek, vyberte příslušný klíčový snímek a zvolte Změnit > Časová osa > Vymazat klíčový snímek, nebo na něj klikněte pravým tlačítkem (Windows) nebo s klávesou Ctrl (Macintosh) a vyberte Vymazat klíčový snímek. Vymazaný klíčový snímek a všechny snímky až po následný klíčový snímek se nahradí obsahem snímku předcházejícího vymazaný klíčový snímek.

  • Chcete-li kopírovat klíčový snímek nebo sekvenci snímků přetažením, vyberte je a přetáhněte je se stisknutou klávesou Alt do nové polohy.

  • Chcete-li změnit délku doplněné sekvence, přetáhněte počáteční nebo koncový klíčový snímek doleva nebo doprava.

  • Chcete-li přidat položku knihovny do aktuálního klíčového snímku, přetáhněte ji z panelu Knihovna na vymezenou plochu.

  • Chcete-li obrátit sekvenci animace, vyberte příslušné snímky v jedné nebo více vrstvách a zvolte Změnit > Časová osa > Obrátit snímky. Klíčové snímky musí být na začátku nebo na konci sekvence.

Přidání animace klasického doplnění k instanci, skupině nebo textu.

Poznámka:

Toto téma pojednává o vytváření starších klasických doplnění. Nápovědu k vytváření novějších doplnění pohybu najdete v tématu Vytváření animace doplnění.

Chcete-li doplnit změny vlastností instancí, skupin a typu, můžete použít klasické doplnění. Aplikace Animate může doplnit polohu, velikost, natočení a zkosení instancí, skupin a textu. Kromě toho může doplnit barvu instancí a textu a vytvořit tak postupné posuny barev, případně nechat instanci postupně objevit nebo zmizet.

Abyste mohli doplnit barvu skupin nebo textu, musíte je nejdříve převést na symboly. Abyste mohli animovat jednotlivé znaky v bloku textu samostatně, musíte nejdříve umístit každý znak do samostatného textového bloku.

Pokud aplikujete klasické doplnění a pak změníte počet snímků mezi oběma klíčovými snímky nebo přemístíte skupinu nebo symbol v některém z klíčových snímků, aplikace Animate snímky automaticky znovu doplní.

 

Vytvoření animace klasického doplnění

  1. Kliknutím na název vrstvy změňte tuto vrstvu na aktivní a vyberte prázdný klíčový snímek ve vrstvě, ve které má animace začít. Tento snímek bude prvním snímkem klasického doplnění.
  2. Chcete-li do tohoto prvního snímku klasického doplnění přidat obsah, proveďte jeden z následujících kroků:
    • Vytvořte grafický objekt pomocí nástroje pero, elipsa, obdélník, tužka nebo štětec a pak ho převeďte na symbol.

    • Ve vymezené ploše vytvořte instanci, skupinu nebo textový blok.

    • Přetáhněte instanci symbolu z panelu Knihovna.

    Poznámka:

    Chcete-li vytvořit doplnění, musíte mít ve vrstvě pouze jednu položku.

  3. Vytvořte druhý klíčový snímek, kterým má animace končit, a nechte nový klíčový snímek vybraný.
  4. Chcete-li změnit položku v zakončujícím snímku, proveďte libovolné z následujících úkonů:
    • Přemístěte položku do nové polohy.

    • Změňte velikost, natočení nebo zkosení položky.

    • Změňte barvu položky (pouze instance nebo textový blok). Chcete-li doplnit barvu jiných prvků než instancí nebo textových bloků, použijte doplnění tvarů.

  5. Klasické doplnění vytvoříte jedním z následujících postupů:
    • Klepněte v rozsahu snímků doplnění na libovolný snímek a vyberte příkaz Vložit > Klasické doplnění.

    • Klepněte pravým tlačítkem (Windows) nebo s klávesou Ctrl (Macintosh) na kterýkoli snímek v rozsahu snímků doplnění a z kontextové nabídky vyberte příkaz Vytvořit klasické doplnění.

    Pokud jste v kroku 2 vytvořili grafický objekt, aplikace Animate automaticky převede tento objekt na symbol a nazve ho tween1.

  6. Pokud jste ve čtvrtém kroku změnili velikost položky, vyberte v inspektoru vlastností v části Doplnění položku Měřítko a doplňte velikost vybrané položky.
  7. Chcete-li vytvořit realističtější dojem pohybu, aplikujte na klasické doplnění náběh/doběh. Chcete-li na klasické doplnění aplikovat náběh/doběh, určete hodnotu náběhu a doběhu pro každé vytvářené klasické doplnění v inspektoru vlastností v části Doplnění v poli Náběh/doběh. Chcete-li ovládat rychlost klasického doplnění přesněji, použijte dialogové okno Vlastní nastavení náběhu/doběhu.

    Chcete-li nastavit rychlost změny mezi doplňovanými snímky, přetáhněte hodnotu v poli Náběh/doběh nebo nějakou hodnotu zadejte:

    • Chcete-li klasické doplnění zahájit pomalu a ke konci animace doplnění zrychlovat, zadejte zápornou hodnotu mezi ‑1 a ‑100.

    • Chcete-li klasické doplnění zahájit rychle a ke konci animace doplnění zpomalovat, zadejte kladnou hodnotu mezi ‑1 a ‑100.

    • Chcete-li v rozsahu snímků doplnění vytvořit složitější změny rychlosti, otevřete klepnutím na tlačítko Upravit vedle pole Náběh/doběh dialogové okno Vlastní nastavení náběhu/doběhu.

      Standardně je rychlost změny mezi doplňovanými snímky konstantní. Náběh/doběh vytváří přirozenější dojem zrychlení nebo zpomalení postupným nastavením rychlosti změny.

  8. Chcete-li vybranou položku během doplnění otáčet, vyberte v inspektoru vlastností volbu z nabídky Otočit:
    • Chcete-li zabránit otáčení, vyberte Žádné (výchozí nastavení).

    • Chcete-li objekt otočit jednou ve směru vyžadujícím nejmenší pohyb, vyberte Automaticky.

    • Chcete-li otočit objekt určeným směrem, zadejte číslo určující počet otáček a vyberte Doprava (po směru hodinových ručiček) nebo Doleva (proti směru hodinových ručiček).

    Poznámka:

    Otáčení v kroku 8 se provede navíc k případnému natočení, které jste aplikovali na konečný snímek v kroku 4.

  9. Pokud používáte cestu pohybu a chcete orientovat účaří doplňovaného prvku podle cesty pohybu, vyberte v inspektoru vlastností volbu Orientovat podle cesty.
  10. Chcete-li synchronizovat animaci instance grafického symbolu s hlavní časovou osou, vyberte v inspektoru vlastností volbu Synch.

    Poznámka:

    Volba Synch. i volba Změnit > Časová osa > Synchronizovat symboly znovu přepočítávají počet snímků v doplnění, aby souhlasil s počtem snímků, který je pro ně vyhrazený v časové ose. Volbu Synch. použijte tehdy, pokud počet snímků v sekvenci animace uvnitř symbolu není celým násobkem počtu snímků, které instance grafiky v dokumentu zabírá.

  11. Pokud používáte cestu pohybu a chcete připojit doplňovaný prvek k cestě pohybu podle jeho vztažného bodu, vyberte Přitahovat.

Práce s klasickými doplněními uloženými jako soubory XML

V aplikaci Animate lze pracovat s klasickými doplněními jako se soubory XML. Aplikace Animate umožňuje používat u libovolného klasického doplnění nativně tyto příkazy:

  • Kopírovat pohyb jako XML

  • Exportovat pohyb jako XML

  • Importovat pohyb jako XML

 

Kopírovat pohyb jako XML

Umožňuje kopírování vlastností pohybu aplikovaných na libovolný objekt na vymezené ploše v daném snímku.

  1. Vytvoření klasického doplnění

  2. Vyberte libovolný snímek na časové ose.

  3. Klikněte na položku Příkazy > Kopírovat pohyb jako XML.

Vlastnosti pohybu se zkopírují do schránky jako data XML. Se souborem XML pak můžete pracovat v libovolném textovém editoru.

Exportovat pohyb jako XML

Slouží k exportu vlastností pohybu aplikovaných na libovolný objekt na vymezené ploše do souboru XML, který lze uložit.

  1. Vytvoření klasického doplnění

  2. Klikněte na položku Příkazy > Exportovat pohyb jako XML.

  3. Přejděte do vhodného umístění, kam chcete soubor uložit.

  4. Zadejte název souboru XML a klikněte na tlačítko Uložit.

Klasické doplnění bude vyexportováno jako soubor XML do zadaného umístění.

Importovat pohyb jako XML

Umožňuje importovat stávající soubor XML, který má definovány vlastnosti pohybu.

  1. Vyberte libovolný objekt na vymezené ploše.

  2. Klikněte na položku Příkazy > Importovat pohyb jako XML.

  3. Přejděte do příslušného umístění a vyberte soubor XML. Klikněte na tlačítko OK.

  4. V dialogu Vložit pohyb jinak vyberte vlastnosti, které chcete použít u vybraného objektu.

  5. Klikněte na tlačítko OK.

Vytvoření pohyblivé vrstvy vodítek

Chcete-li ovládat pohyb objektů v klasické doplněné animaci, vytvořte vrstvu vodítek pohybu.

Nemůžete přetáhnout vrstvy doplnění pohybu nebo inverzní kinematické vrstvy pozic na vrstvu vodítek.

  1. Přetáhněte normální vrstvu na vrstvu vodítek. Toto převádí vrstvu vodítek do vrstvy vodítek pohybu a spojte normální vrstvu k nové vrstvě vodítek pohybu.

    Poznámka:

    Aby nedošlo k náhodnému převedení vrstvy vodítek, umístěte všechny vrstvy vodítek pod ostatní vrstvy.

Vytváření klasického doplnění pohybu podél cesty

Poznámka:

Toto téma pojednává o práci se staršími klasickými doplněními. Nápovědu pro novější doplnění pohybu pomocí cest pohybu uvádí téma Úpravy cesty pohybu animace doplnění.

Vodítko pohybu vrstvy umožňuje nakreslit cesty, podél nichž je možné animovat doplňované instance, skupiny nebo textové bloky. Můžete navázat více vrstev na vrstvu vodítka pohybu a nechat více objektů sledovat stejnou cestu. Z normální vrstvy, která je navázaná na vrstvu vodítka pohybu, se stává vrstva řízená vodítkem.

Cesta pohybu
V tomto příkladě jsou dva objekty v samostatných vrstvách připojené ke stejné cestě pohybu.

Vytvoření cesty pohybu pro klasickou doplňovanou animaci

  1. Vytvořte sekvenci klasické doplňované animace.

    Pokud v inspektoru vlastností vyberete volbu Orientovat podle cesty, účaří doplňovaného prvku se orientuje podle cesty pohybu. Pokud vyberete Přitahovat, vztažný bod doplňovaného prvku se přitahuje na cestu pohybu.

  2. Klikněte pravým tlačítkem (Windows) nebo s klávesou Ctrl (Macintosh) na název vrstvy, která obsahuje klasické doplnění, a zvolte příkaz Přidat vodítko klasického pohybu.

    Aplikace Animate nad vrstvu klasického doplnění přidá vrstvu vodítka pohybu a název klasické vrstvy doplnění odsadí, aby ukázala, že je spojená s vrstvou vodítka pohybu.

    Poznámka:

    Pokud už v časové ose vrstvu vodítka máte, můžete vrstvu obsahující klasické doplnění přetáhnout pod vrstvu vodítka a tím vrstvu vodítka převést na vodítko pohybu a svázat s ním klasické doplnění.

    Vrstva vodítka pohybu
    Vrstva vodítka pohybu nad vrstvou, která obsahuje klasické doplnění.

  3. Chcete-li vodit klasické doplnění, přidejte do vrstvy vodítka pohybu cestu: Vyberte vrstvu vodítka pohybu a nakreslete požadovanou cestu pomocí nástroje pero, tužka, čára, kruh, obdélník nebo štětec.

    Také můžete do vrstvy vodítka pohybu vložit tah.

  4. Chcete-li objekt, který doplňujete, přitáhnout k počátku čáry v prvním snímku a na konec čáry v posledním snímku, přetáhněte ho tam.
    Obrázek přitáhnutý na počátek tahu vodítka
    Obrázek auta přitáhnutý na počátek tahu vodítka

    Poznámka:

    Přitahování bude nejlépe fungovat tehdy, když symbol přetáhnete za jeho transformační bod.

  5. Chcete-li vrstvu vodítka pohybu a cestu skrýt, aby byl při práci viditelný pouze pohyb objektu, klepněte ve vrstvě vodítka pohybu do sloupce s ikonou oka.

    Při přehrávání animace skupina nebo symbol sleduje cestu pohybu.

Pokud se chcete dozvědět něco více o průvodci animací na základě tahu proměnlivé šířky a proměnlivé barvy, získáte informace v tématu Vodítko animace

  1. Proveďte jeden z následujících úkonů:
    • Přetáhněte stávající vrstvu pod vrstvu vodítka pohybu. Vrstva pod vrstvou vodítka pohybu je odsazená. Všechny objekty v této vrstvě se automaticky přitahují k cestě pohybu.

    • Vytvořte novou vrstvu pod vrstvou vodítka pohybu. Objekty, které doplníte v této vrstvě, se automaticky doplňují podél cesty pohybu.

    • Vyberte vrstvu pod vrstvou vodítka pohybu. Zvolte Změnit > Časová osa > Vlastnosti vrstvy a vyberte Vodítko.

  1. Vyberte vrstvu, kterou chcete oddělit, a proveďte jeden z následujících úkonů:
    • Přetáhněte vrstvu nad vrstvu vodítka pohybu.

    • Zvolte Změnit > Časová osa > Vlastnosti vrstvy a jako typ vrstvy vyberte Normální.

Vložení vlastností animace klasického doplnění

Poznámka:

Toto téma pojednává o vkládání vlastností starších klasických doplnění. Nápovědu pro vkládání vlastností novějších doplnění pohybu získáte v tématu Kopírování a vkládání vlastností doplnění pohybu.

Příkaz Vložit pohyb umožňuje klasické doplnění zkopírovat a vložit pouze určité vlastnosti, které chcete aplikovat na jiný objekt.

  1. V časové ose vyberte snímky obsahující klasické doplnění, které chcete kopírovat. Snímky, které vyberete, musejí být obsaženy ve stejné vrstvě, nemusejí ale zahrnovat pouze klasické doplnění. Výběr může zahrnovat doplnění, prázdné snímky, případně dvě nebo více doplnění.
  2. Zvolte Úpravy > Časová osa > Kopírovat pohyb.
  3. Vyberte instanci symbolu, na který chcete uplatnit zkopírované klasické doplnění.
  4. Vyberte položky Úpravy > Časová osa > Vložit pohyb jinak. Vyberte určité vlastnosti klasického doplnění, které chcete do instance symbolu vložit. Vlastnosti klasického doplnění jsou tyto:

    Poloha X

    Vzdálenost, na kterou se objekt přemístí ve směru x.

    Poloha Y

    Vzdálenost, na kterou se objekt přemístí ve směru y.

    Vodorovné měřítko

    Poměr mezi aktuální velikostí objektu a jeho přirozenou velikostí ve vodorovném směru (X).

    Svislé měřítko

    Určuje poměr mezi aktuální velikostí objektu a jeho přirozenou velikostí ve svislém směru (Y).

    Natočení a zkosení

    Natočení a zkosení objektu. Tyto vlastnosti se musí na objekt aplikovat společně. Zkosení je hodnota natočení ve stupních, a když aplikujete natočení i zkosení, obě vlastnosti se navzájem ovlivňují.

    Barva

    Na daný objekt se aplikují všechny hodnoty barvy, například Odstín, Jas a Alfa.

    Filtry

    Všechny hodnoty a změny filtrů pro vybraný rozsah snímků. Pokud se na objekt aplikují filtry, vloží se filtr s veškerými hodnotami nedotčenými a jeho stav (povolený nebo zakázaný) se aplikuje na nový objekt také.

    Režim prolnutí

    Aplikuje režim prolnutí objektu.

    Nahradit vlastnosti měřítka cíle

    Pokud je tato volba nezaškrtnutá, znamená to, že všechny vlastnosti budou vloženy relativně vzhledem k cílovému objektu. Když je zaškrtnutá, změní tato volba vlastnosti měřítka cíle.

    Nahradit vlastnosti otočení a zkosení cíle

    Pokud je tato volba nezaškrtnutá, znamená to, že všechny vlastnosti budou vloženy relativně vzhledem k cílovému objektu. Když je zaškrtnutá, vložené vlastnosti změní stávající vlastnosti otočení a velikosti objektu.

    Potřebné informace snímků, doplnění a symbolů se vloží tak, aby tyto prvky odpovídaly původnímu, kopírovanému doplnění.

    Chcete-li zkopírovat klasické doplnění symbolu do panelu Akce nebo je použít v jiném projektu jako kód jazyka ActionScript, použijte příkaz Kopírovat pohyb jako ActionScript 3.0.

Vytváření přednastavení náběhu/doběhu

Přednastavení náběhu/doběhu jsou předem konfigurované náběhy/doběhy, které lze použít u objektu na ploše.

Pro klasické doplnění je k dispozici sada často používaných přednastavení náběhu/doběhu. Vyberte přednastavení náběhu/doběhu ze seznamu a použijte ho u vybrané vlastnosti.

  1. Klikněte na vrstvu, která na časové ose aplikace Animate obsahuje doplnění.

  2. Pokud chcete otevřít vlastnosti doplnění, klikněte na panelu vlastností na kategorii Doplnění. V rozevírací nabídce náběhu/doběh můžete zvolit náběh/doběh pro jednotlivé vlastnosti.

    property-dropdown-ease
    Vlastnosti doplnění

    Pro klasické doplnění pohybu můžete použít přednastavení náběhu/doběhu pro jednotlivé vlastnosti. Na panelu vlastnosti si můžete zvolit náběh/doběh pro jednotlivé vlastnosti. Na tuto možnost klikněte, pokud chcete pro každou vlastnost použít různé předvolby náběhu/doběhu. Jestliže chcete pro všechny vlastnosti doplnění použít stejný náběh/doběh, zvolte možnost Všechny vlastnosti společně, jak je zobrazeno na následujícím snímku obrazovky.

  3. Vyberte požadované přednastavení náběhu/doběhu v rozevírací nabídce a klikněte na tlačítko Použít.

    Pokud se rozhodnete použít klasický náběh/doběh, můžete posunutím jezdce zvýšit nebo snížit jeho intenzitu. 

    property-wise-presets
    Seznam přednastavení náběhu/doběhu
  4. Chcete-li použít vlastní náběh/doběh, klikněte vedle možnosti Náběh/doběh na ikonu Upravit.

Pokud používáte dokument HTML5 Canvas, můžete získat optimalizovaný výstupní soubor js pro přednastavení náběhu/doběhu. HTML5 Canvas používá při vytváření výstupu funkce náběhu/doběhu pro doplnění souboru JS. 

Použití vlastního nastavení náběhu/doběhu u animace klasického doplnění

Poznámka:

Toto téma pojednává o přidání náběhu/doběhu do starších klasických doplnění. Nápovědu pro přidání náběhu/doběhu do novějších doplnění pohybu viz Náběhy/doběhy animací doplnění .

Dialogové okno Vlastní nastavení náběhu/doběhu zobrazuje graf představující míru pohybu během času. Vodorovná osa představuje snímky a svislá osa představuje procentuální hodnotu změny. První klíčový snímek je uveden jako 0 % a poslední klíčový snímek je uveden jako 100 %.

Sklon křivky grafu představuje rychlost změny objektu. Když je křivka vodorovná (beze sklonu), rychlost je nulová; když je křivka svislá, vyskytla se mžiková rychlost změny.

Graf Vlastní nastavení náběhu/doběhu
Graf Vlastní nastavení náběhu/doběhu zobrazující konstantní rychlost. Toto dialogové okno otevřete výběrem snímku v klasickém doplnění a kliknutím na tlačítko Upravit v části Náběh/doběh v inspektoru vlastností.

Uložení vlastního náběhu/doběhu

Pouhým kliknutím na tlačítko můžete uložit vlastní náběh/doběh a znovu ho použít výběrem ze seznamu vlastních náběhů/doběhů. Po provedení změn v režimu úprav klikněte na tlačítko Uložit a použít. Na následujícím snímku obrazovky si můžete prohlédnout vlastní náběh/doběh s názvem MyEase1.

saving-custom-ease
Customized easing preset

Přednastavený náběh/doběh můžete použít ve více rozpětích na časové ose tak, že vyberete odpovídající rozsahy a použijete požadovaný náběh/doběh.

multi-span
Easing preset across multiple spans

Další ovládací prvky pro dialogové okno Vlastní nastavení náběhu/doběhu

Zaškrtávací políčko Použít jedno nastavení pro všechny vlastnosti

Ve výchozím nastavení je toto políčko zaškrtnuté; zobrazená křivka se použije pro všechny vlastnosti a rozbalovací nabídka Vlastnosti je vypnutá. Není-li zaškrtávací políčko zaškrtnuté, rozbalovací nabídka Vlastnosti je zapnutá a každá vlastnost má samostatnou křivku definující rychlost této vlastnosti.

Rozbalovací nabídka Vlastnosti

Je zapnutá pouze tehdy, když není vybrané zaškrtávací políčko Použít jedno nastavení pro všechny vlastnosti. Když je zapnutá, pro každou z pěti vlastností zobrazených v nabídce se ponechává samostatná křivka. Když vyberete určitou vlastnost z nabídky, zobrazí se její příslušná křivka. Jedná se o následující vlastnosti:

Poloha

Určuje nastavení vlastního náběhu/doběhu pro polohu animovaného objektu na vymezené ploše.

Natočení

Určuje nastavení vlastního náběhu/doběhu pro otáčení animovaného objektu. Například můžete doladit, jak rychle nebo pomalu se animovaný znak na vymezené ploše otočí kolem dokola, než se obrátí k uživateli.

Změna velikosti

Určuje nastavení vlastního náběhu/doběhu pro změnu velikosti animovaného objektu. Například můžete snadněji přizpůsobit změnu velikosti objektu, aby to vypadalo, že se vzdaluje od pozorovatele, pak se přiblíží a pak se znovu vzdálí.

Barva

Určuje nastavení vlastního náběhu/doběhu pro přechody barev aplikované na animovaný objekt.

Filtry

Určuje nastavení vlastního náběhu/doběhu pro filtry aplikované na animovaný objekt. Například můžete řídit nastavení náběhu/doběhu vrženého stínu, který simuluje změnu směru zdroje světla.

Tlačítka Spustit a Zastavit

Umožňují zobrazit náhled animace na vymezené ploše s použitím všech aktuálních křivek rychlosti definovaných v dialogovém okně Vlastní nastavení náběhu/doběhu.

Tlačítko Obnovit

Umožňuje obnovit křivku rychlosti do výchozího lineárního stavu.

Poloha vybraného řídicího bodu

Numerická hodnota v pravém dolním rohu dialogového okna vyjadřuje klíčový snímek a polohu vybraného řídicího bodu. Pokud není vybraný žádný řídicí bod, nezobrazuje se žádná hodnota.

Chcete-li k čáře přidat řídicí bod, jednou klepněte na diagonální čáru. Chcete-li dosáhnout přesného stupně ovládání pohybu objektu, přetáhněte polohy řídicích bodů.

S použitím indikátorů snímků (představovaných čtvercovými táhly) klepněte na místo, kde má objekt zpomalit nebo zrychlit. Kliknutím na čvercové táhlo řídicího bodu se tento řídicí bod vybere a na jeho obou stranách se zobrazí tangenciální body. Prázdné kroužky představují tangenciální body. Přetáhněte řídicí bod nebo jeho tangenciální body myší nebo k jejich přemístění použijte klávesy se šipkami.

Tip: Ve výchozím nastavení se řídicí body přitahují na mřížku. Přitahování můžete vypnout stiskem klávesy X při přetahování řídicího bodu.

Kliknutím na oblast křivky mimo všech řídicích bodů se do křivky v tomto bodě přidá nový řídicí bod, aniž by se změnil tvar křivky. Kliknutím mimo křivku a řídicí body se aktuálně vybraný řídicí bod odznačí.

Přidání vlastního náběhu/doběhu

  1. V časové ose vyberte vrstvu, na kterou jste aplikovali klasické doplnění.

  2. Klikněte na tlačítko Upravit vedle jezdce Náběh/doběh ve snímku inspektoru vlastností.
  3. (Volitelně) Chcete-li zobrazit křivku pro určitou doplněnou vlastnost, odznačte možnost Použít jedno nastavení pro všechny vlastnosti a vyberte vlastnost v nabídce.
  4. Chcete-li přidat řídicí bod, klikněte pravým tlačítkem (Windows) nebo s klávesou Ctrl (Macintosh) na diagonální čáru.
  5. Chcete-li zvýšit rychlost objektu, přetáhněte řídicí bod nahoru; chcete-li zpomalit rychlost objektu, přetáhněte ho dolů.
  6. Pokud chcete dále nastavit křivku náběhu/doběhu a doladit hodnotu náběhu/doběhu doplnění, přetáhněte vrcholová táhla.
  7. Chcete-li zobrazit animaci ve vymezené ploše, klikněte na tlačítko přehrávání v levém dolním rohu.
  8. Nastavujte ovládací prvky, dokud nedosáhnete požadovaného efektu.

Poznámka:

Pokud aplikujete na snímek vlastní nastavení náběhu/doběhu s použitím dialogového okna Vlastní nastavení náběhu/doběhu, je v okně úprav zobrazujícím hodnotu náběhu/doběhu uvedeno '--'. Pokud aplikujete na snímek hodnotu náběhu/doběhu s použitím okna Úpravy nebo rozbalovacího jezdce, graf Vlastní nastavení náběhu/doběhu se nastaví na ekvivalentní křivku a je zaškrtnuté políčko Použít jedno nastavení pro všechny vlastnosti.

Kopírování a vkládání křivky náběhu/doběhu

  • Chcete-li kopírovat aktuální křivku náběhu/doběhu, stiskněte Ctrl+C (Windows) nebo Apple+C (Macintosh).

  • Chcete-li vložit zkopírovanou křivku do jiné křivky náběhu/doběhu, stiskněte Ctrl+V (Windows) nebo Apple+V (Macintosh).

    Křivku náběhu/doběhu můžete kopírovat a vkládat. Zkopírovaná křivka zůstává k dispozici, dokud neukončíte aplikaci Animate.

Nepodporované křivky náběhu/doběhu

Určité typy křivek náběhu/doběhu nejsou podporované. Žádná část grafu nemůže představovat nelineární křivku (například kruh).

Dialogové okno Vlastní nastavení náběhu/doběhu automaticky zabraňuje přemístění řídicího bodu nebo tangenciálního táhla do polohy, která by způsobila vykreslení neplatné křivky:

  • Všechny body musí existovat na grafu. Řídicí body nelze přemístit mimo hranice grafu.

  • Všechny segmenty křivky musí existovat v rozmezí grafu. Tvar křivky se zploští, aby se zabránilo jejímu rozšíření za hranice grafu.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online