Vytváření a uspořádání vrstev

Pomocí vrstev můžete uspořádat kresby v dokumentu. Můžete kreslit a upravovat objekty v jedné vrstvě, aniž by to mělo vliv na objekty v jiné vrstvě. V oblastech vymezené plochy, kde ve vrstvě nic není, jsou skrz vidět vrstvy ležící pod ní.

Chcete-li kreslit, malovat nebo jinak modifikovat vrstvu nebo složku, aktivujte požadovanou vrstvu tím, že ji vyberete v časové ose. Ikona tužky vedle názvu vrstvy nebo složky v časové ose značí, že je vrstva nebo složka aktivní. V určitém okamžiku může být aktivní jen jedna vrstva (přestože lze vybrat i více vrstev najednou).

Když vytvoříte dokument aplikace Animate CC (dříve Flash Professional CC), obsahuje jen jednu vrstvu. Abyste mohli uspořádat kresby, animace a další prvky v dokumentu, přidejte do něho další vrstvy. Vrstvy také můžete skrýt, zamknout nebo změnit jejich pořadí. Počet vrstev, které lze vytvořit, je omezen pouze velikostí paměti vašeho počítače, přičemž vrstvy velikost publikovaného souboru SWF nezvětšují. Velikost souboru zvětšují pouze objekty, které do vrstev vložíte.

Abyste mohli vrstvy lépe spravovat, vytvořte si složky vrstev a do nich umístěte jednotlivé vrstvy. V časové ose můžete složky vrstev rozbalovat a sbalovat bez ovlivnění toho, co vidíte ve vymezené ploše. Používejte samostatné vrstvy nebo složky pro zvukové soubory, ActionScript, popisy snímků a komentáře snímků. Budete je tak moci rychleji vyhledat, až je budete chtít upravit.

Abyste mohli lépe vytvářet složité efekty, používejte speciální vrstvy vodítek, které usnadňují kreslení a úpravy, a také vrstvy masek.

V aplikaci Animate existuje pět druhů vrstev, které můžete používat:

  • Normální vrstvy obsahují většinu kreseb v souboru FLA.

  • Vrstvy masek obsahují objekty používané jako masky k ukrytí vybraných částí vrstev pod nimi. Další informace viz Používání vrstev masek.

  • Maskované vrstvy jsou vrstvy pod vrstvou masek, které přiřazujete k vrstvě masek. Viditelná je pouze část maskované vrstvy, která není zakryta maskou. Další informace viz Používání vrstev masek.

  • Vrstvy vodítek obsahují tahy, které mohou být použity jako vodítko k uspořádání objektů v jiných vrstvách. Můžete je také použít jako vodítko pohybu v animacích klasického doplnění v jiných vrstvách. Další informace naleznete v tématech Vrstvy vodítek a Vytváření klasického doplnění pohybu podél cesty.

  • Vodicí vrstvy jsou vrstvy přiřazené k vrstvě vodítek. Objekty na vodicích vrstvách mohou být uspořádány nebo animovány podél tahů ve vodicí vrstvě. Vodicí vrstvy mohou obsahovat statické kresby a klasická doplnění, nikoli však doplnění pohybu.

  • Vrstvy doplnění pohybu obsahují objekty animované doplněním pohybu. Další informace viz O doplňované animaci.

  • Vrstvy armatur obsahují objekty s připojenými inverzními kinematickými kostmi. Další informace naleznete v části Použití nástroje Kost k animaci inverzní kinematiky.

Normální vrstvy, vrstvy masek, maskované vrstvy a vrstvy vodítek mohou obsahovat doplnění pohybu nebo inverzní kinematické kosti. Pokud se tyto položky nacházejí v jedné z uvedených vrstev, existují omezení typů obsahu, který je možné do vrstvy přidat. Další informace naleznete v částech Doplnění pohybu a Použití nástroje Kost k animaci inverzní kinematiky.

Vytvoření vrstvy

Když vytvoříte novou vrstvu, zobrazí se nad vybranou vrstvou. Nově přidaná vrstva se stane aktivní vrstvou.

  1. Proveďte jeden z následujících úkonů:
    • Dole na časové ose klikněte na tlačítko nová vrstvy .

    • Zvolte Vložit > Časová osa > Vrstva.

    • Klikněte pravým tlačítkem (Windows) nebo se stisknutou klávesou Ctrl (Mac) na název vrstvy v časové ose a z kontextové nabídky vyberte příkaz Vložit vrstvu.

Vytvoření složky vrstev

  1. Proveďte jeden z následujících úkonů:
    • Vyberte vrstvu nebo složku v časové ose a zvolte Vložit > Časová osa > Složka vrstev.

    • Klikněte pravým tlačítkem (Windows) nebo se stisknutou klávesou Ctrl (Mac) na název vrstvy v časové ose a z kontextové nabídky vyberte příkaz Vložit složku. Nová složka se zobrazí nad vybranou vrstvou nebo složkou.

    • Dole na časové ose klikněte na ikonu nové složky . Nová složka se zobrazí nad vybranou vrstvou nebo složkou.

Uspořádání vrstev a složek vrstev

Chcete-li uspořádat dokument, upravte pořadí vrstev a složek v časové ose.

Složky vrstev napomáhají lépe organizovat postup práce tím, že umožňují uspořádat vrstvy do stromové struktury. Chcete-li zobrazit vrstvy obsažené ve složce bez vlivu na to, jaké vrstvy jsou viditelné ve vymezené ploše, rozbalte nebo sbalte požadovanou složku. Složky mohou obsahovat vrstvy a také další složky, takže můžete vrstvy uspořádat velmi podobně jako soubory v počítači.

Ovládací prvky vrstev v časové ose ovlivňují všechny vrstvy ve složce. Například při uzamčení složky vrstev se zamknou všechny vrstvy v dané složce.

  • Chcete-li vrstvu nebo složku vrstev přesunout do určité složky vrstev, přetáhněte její název na název cílové složky.
  • Chcete-li změnit pořadí vrstev nebo složek, přetáhněte jednu nebo více vrstev nebo složek v časové ose do požadované polohy.
  • Chcete-li rozbalit nebo sbalit složku, klikněte na trojúhelník vlevo od názvu složky.
  • Chcete-li rozšířit nebo sbalit všechny složky, klikněte pravým tlačítkem (Windows) nebo se stisknutou klávesou Ctrl (Mac) a zvolte příkaz Rozbalit všechny složky nebo Sbalit všechny složky.

Přejmenování vrstvy nebo složky

Aplikace Animate názvy nových vrstev standardně přiřazuje podle pořadí, ve kterém byly vytvořeny: Vrstva 1, Vrstva 2 a tak dále. Vrstvy přejmenujte, aby názvy lépe odrážely svůj obsah.

  1. Proveďte jeden z následujících úkonů:
    • Dvakrát klikněte na název vrstvy nebo složky v časové ose a zadejte nový název.

    • Klikněte pravým tlačítkem (Windows) nebo se stisknutou klávesou Ctrl (Mac) na název vrstvy nebo složky a z kontextové nabídky vyberte příkaz Vlastnosti. Zadejte nový název do pole Název a klikněte na tlačítko OK.

    • V časové ose vyberte vrstvu nebo složku a zvolte Změnit > Časová osa > Vlastnosti vrstvy. Zadejte nový název do pole Název klikněte na tlačítko OK.

Výběr vrstvy nebo složky

  1. Proveďte jeden z následujících úkonů:
    • Klikněte na název vrstvy nebo složky v časové ose.

    • Klikněte na libovolný snímek v časové ose vrstvy, kterou chcete vybrat.

    • Vyberte ve vymezené ploše objekt, který je umístěn ve vrstvě, kterou chcete vybrat.

    • Chcete-li vybrat více sousedících vrstev nebo složek, klikněte v časové ose na jejich názvy se stisknutou klávesou Shift.

    • Chcete-li vybrat více nesousedících vrstev nebo složek, klikněte v časové ose na jejich názvy se stisknutou klávesou Ctrl (Windows) nebo Command (Mac).

Kopírování snímků z jedné vrstvy

  1. Vyberte rozsah snímků ve vrstvě. Chcete-li vybrat celou vrstvu, klikněte na její název v časové ose.
  2. Zvolte Úpravy > Časová osa > Kopírovat snímky.

  3. Klikněte na snímek, od kterého chcete začít vkládat další snímky, a vyberte Úpravy > Časová osa > Vložit snímky. Pokud chcete na cílovou časovou osu vložit přesný počet kopírovaných snímků a nahradit je, použijte možnost Vložit a přepsat snímky.

    Overwrite_frames_process_1
    Pracovní postup vložení a přepsání snímků

    A. Vyberte snímky a zkopírujte je. B. Pravým tlačítkem myši klikněte na snímek, do kterého chcete snímky vložit, a vyberte Vložit a přepsat snímky. C. Vložené snímky přepíší přesný počet snímků na časové ose. 

Kopírování snímků ze složky vrstev

  1. Složku sbalte (kliknutím na trojúhelník vlevo od názvu složky v časové ose) a kliknutím na její název ji celou vyberte. 

  2. Zvolte Úpravy > Časová osa > Kopírovat snímky.

  3. Chcete-li vytvořit složku, zvolte Vložit > Časová osa > Složka vrstev.

  4. Klikněte na novou složku a zvolte Úpravy > Časová osa > Vložit snímky.

Odstranění vrstvy nebo složky

  1. Chcete-li vybrat vrstvu nebo složku, klikněte na její název v časové ose nebo na libovolný snímek v dané vrstvě.
  2. Proveďte jeden z následujících úkonů:
    • V časové ose klikněte na tlačítko Odstranit vrstvu.

    • Přetáhněte vrstvu nebo složku na tlačítko Odstranit vrstvu.

    • Klikněte pravým tlačítkem (Windows) nebo se stisknutou klávesou Ctrl (Mac) na název vrstvy nebo složky a z kontextové nabídky vyberte příkaz Odstranit vrstvu.

    Poznámka:

    Když odstraníte složku vrstev, odstraní se všechny vrstvy, které jsou v ní zahrnuté, i všechen jejich obsah.

Zamykání a odemykání jedné nebo více vrstev nebo složek

  • Chcete-li zamknout vrstvu nebo složku, klikněte do sloupce Zamknout vpravo od jejího názvu. Chcete-li vrstvu nebo složku odemknout, klikněte do sloupce Zamknout znovu.

  • Chcete-li zamknout všechny vrstvy a složky, klikněte na ikonu zámku. Chcete-li všechny vrstvy a složky odemknout, klikněte na ni znovu.

  • Chcete-li zamknout nebo odemknout více vrstev nebo složek, táhněte ve sloupci Zamknout.

  • Chcete-li zamknout všechny ostatní vrstvy nebo složky, klikněte se stisknutou klávesou Alt do sloupce Zamknout. Chcete-li všechny vrstvy a složky odemknout, klikněte znovu do sloupce Zamknout se stisknutou klávesou Alt.

Kopírování a vkládání vrstev (pouze CS5.5)

Můžete kopírovat celé vrstvy a složky vrstev v časové ose a vkládat je do stejné časové osy nebo do jiných časových os. Kopírovat lze libovolný typ vrstvy.

Při kopírování a vkládání vrstev je struktura složek kopírovaných vrstev zachována.

  1. Kliknutím na název vrstvy vyberte jednu nebo více vrstev v časové ose. Sousedící vrstvy lze vybrat kliknutím se stisknutou klávesou Shift. Nesousedící vrstvy lze vybrat kliknutím se stisknutou klávesou Ctrl (Windows) nebo Command (Mac).

  2. Zvolte Úpravy > Časová osa > Kopírovat vrstvy nebo Vyjmout vrstvy. Můžete rovněž kliknout pravým tlačítkem na vrstvy a z kontextové nabídky zvolit příkaz Kopírovat vrstvy nebo Vyjmout vrstvy.

  3. V časové ose vyberte vrstvu bezprostředně pod místem, kam chcete vkládané vrstvy vložit.

  4. Zvolte Úpravy > Časová osa > Vložit vrstvy.

Vrstvy se objeví v časové ose nad vrstvou, kterou jste vybrali. Pokud jste vybrali složku vrstev, objeví se vložené vrstvy uvnitř této složky.

Chcete-li vrstvu umístit do vrstvy masek nebo vodítek, je nutné před vložením nejprve vybrat vrstvu pod touto maskou nebo vodítkem. Vrstvu masek, vodítek nebo složek nelze vložit pod vrstvu masek nebo vodítek.

Vrstvy můžete také duplikovat tak, že vrstvy vyberete a zvolíte Úpravy > Časová osa > Duplikovat vrstvy. Nové vrstvy budou mít k názvu vrstvy připojeno slovo „kopie“.

Nastavení vlastností více vrstev

  1. V aplikaci Animate CC vytvořte nový nebo otevřete stávající soubor FLA.

  2. Vyberte vrstvy, jejichž vlastnosti chcete změnit, klikněte na ně pravým tlačítkem a zvolte Vlastnosti.

  3. V dialogovém okně Vlastnosti vrstvy změňte požadované vlastnosti.

  4. Klikněte na tlačítko OK.

Zobrazení nebo skrytí vrstvy nebo složky

Červené přeškrtnutí (X) vedle názvu vrstvy nebo složky v časové ose značí, že je vrstva nebo složka skrytá. V Nastavení publikování můžete zvolit, zda mají být při publikování souboru SWF zahrnuty i skryté vrstvy.

  • Chcete-li vrstvu nebo složku skrýt, klikněte do sloupce s ikonou oka vpravo od názvu vrstvy nebo složky v časové ose. Chcete-li vrstvu nebo složku zobrazit, klikněte do něj znovu.

  • Chcete-li skrýt všechny vrstvy a složky v časové ose, klikněte na ikonu oka. Chcete-li všechny vrstvy a složky zobrazit, klikněte na ni znovu.

  • Chcete-li zobrazit nebo skrýt více vrstev nebo složek, táhněte ve sloupci s ikonou oka.

  • Pokud chcete skrýt všechny vrstvy a složky s výjimkou aktuální vrstvy nebo složky, klikněte se stisknutou klávesou Alt do sloupce s ikonou oka. Chcete-li všechny vrstvy a složky zobrazit, klikněte do něj se stisknutou klávesou Alt znovu.

Zobrazení obsahu vrstvy ve formě obrysů

Chcete-li rozlišit, do které vrstvy určitý objekt patří, zobrazte všechny objekty ve vrstvě jako barevné obrysy.

  • Chcete-li všechny objekty v určité vrstvě zobrazit jako obrysy, klikněte do sloupce Obrys vpravo od názvu vrstvy. Chcete-li zobrazení obrysů vypnout, klikněte do něj znovu.

  • Chcete-li zobrazit objekty ve všech vrstvách jako obrysy, klikněte na ikonu obrysu. Chcete-li zobrazení obrysů ve všech vrstvách vypnout, klikněte na ni znovu.

  • Chcete-li zobrazit objekty ve všech vrstvách s výjimkou aktuální vrstvy, klikněte se stisknutou klávesou Alt do sloupce Obrys. Chcete-li zobrazení obrysů ve všech vrstvách vypnout, klikněte do něj se stisknutou klávesou Alt znovu.

Poznámka:

Barvu obrysu vrstvy používají také cesty pohybu na vrstvě.

Změna barvy obrysu vrstvy

  1. Proveďte jeden z následujících úkonů:
    • V časové ose dvakrát klikněte na ikonu vrstvy (vlevo od názvu vrstvy).

    • Klikněte pravým tlačítkem (Windows) nebo se stisknutou klávesou Ctrl (Mac) na název vrstvy a z kontextové nabídky vyberte Vlastnosti.

    • V časové ose vyberte vrstvu a zvolte Změnit > Časová osa > Vlastnosti vrstvy.

  2. V dialogovém okně Vlastnosti vrstvy klikněte na pole Barva obrysu, vyberte novou barvu a klikněte na tlačítko OK.

Zobrazování vrstev a složek vrstev

Zobrazení nebo skrytí vrstvy nebo složky

Červené přeškrtnutí vedle názvu vrstvy nebo složky v časové ose značí, že je vrstva nebo složka skrytá. V Nastavení publikování můžete zvolit, zda mají být při publikování souboru SWF zahrnuty i skryté vrstvy.

  • Chcete-li vrstvu nebo složku skrýt, klikněte do sloupce s ikonou oka vpravo od názvu vrstvy nebo složky v časové ose. Chcete-li vrstvu nebo složku zobrazit, klikněte do něj znovu.

  • Chcete-li skrýt všechny vrstvy a složky v časové ose, klikněte na ikonu oka. Chcete-li všechny vrstvy a složky zobrazit, klikněte na ni znovu.

  • Chcete-li zobrazit nebo skrýt více vrstev nebo složek, táhněte ve sloupci s ikonou oka.

  • Pokud chcete skrýt všechny vrstvy a složky s výjimkou aktuální vrstvy nebo složky, klikněte se stisknutou klávesou Alt do sloupce s ikonou oka. Chcete-li všechny vrstvy a složky zobrazit, klikněte do něj se stisknutou klávesou Alt znovu.

Zobrazení obsahu vrstvy ve formě obrysů

Chcete-li rozlišit, do které vrstvy určitý objekt patří, zobrazte všechny objekty ve vrstvě jako barevné obrysy.

  • Chcete-li všechny objekty v určité vrstvě zobrazit jako obrysy, klikněte do sloupce Obrys vpravo od názvu vrstvy. Chcete-li zobrazení obrysů vypnout, klikněte do něj znovu.

  • Chcete-li zobrazit objekty ve všech vrstvách jako obrysy, klikněte na ikonu obrysu. Chcete-li zobrazení obrysů ve všech vrstvách vypnout, klikněte na ni znovu.

  • Chcete-li zobrazit objekty ve všech vrstvách s výjimkou aktuální vrstvy, klikněte se stisknutou klávesou Alt do sloupce Obrys. Chcete-li zobrazení obrysů ve všech vrstvách vypnout, klikněte do něj se stisknutou klávesou Alt znovu.

Změna barvy obrysu vrstvy

  1. Proveďte jeden z následujících úkonů:
    • V časové ose dvakrát klikněte na ikonu vrstvy (vlevo od názvu vrstvy).

    • Klikněte pravým tlačítkem (Windows) nebo s podrženou klávesou Ctrl (Mac) na název vrstvy a v kontextové nabídce vyberte Vlastnosti.

    • V časové ose vyberte vrstvu a zvolte Změnit > Časová osa > Vlastnosti vrstvy.

  2. V dialogovém okně Vlastnosti vrstvy klikněte na pole Barva obrysu, vyberte novou barvu a klikněte na tlačítko OK.

Poznámka:

Barvu obrysu vrstvy používají také cesty pohybu na vrstvě.

Nastavení průhlednosti vrstvy

  1. V aplikaci Animate CC vytvořte nový nebo otevřete stávající soubor FLA.

  2. Se stisknutou klávesou Shift klikněte v časové ose na sloupec s ikonou oka, čímž viditelnost nastavíte na průhlednou.

    Poznámka:

    U skrytých vrstev nemá kliknutí s podrženou klávesou Shift žádný vliv.

    Nastavení průhlednosti vrstvy
    Nastavení průhlednosti vrstvy
  3. K nastavení průhlednosti vrstvy použijte některou z následujících možností:

    • Klikněte na vrstvu pravým tlačítkem a v kontextové nabídce vyberte Vlastnosti. V dialogovém okně Vlastnosti vrstvy zvolte Viditelnost > Průhledná.
    • Klikněte pravým tlačítkem na kteroukoli vrstvu a zvolte Zobrazovat ostatní průhledně.
    Vlastnosti vrstvy
    Vlastnosti vrstvy
  4. Klikněte na tlačítko OK.

Poznámka:

Průhlednost vrstev se nijak neprojevuje na skrytých vrstvách. 

Používání rozšířených vrstev

V aplikaci Animate CC můžete používat režim rozšířených vrstev, ve kterém jsou všechny vrstvy na časové ose prezentovány jako symboly. V režimu rozšířených vrstev můžete používat následující funkce:

Ve výchozím nastavení je režim rozšířených vrstev povolen. Rozšířené vrstvy můžete povolit nebo zakázat pomocí nastavení Změnit > Dokument. Po provedení změn můžete kliknutím na tlačítkoNastavit jako výchozí zachovat aktuální nastavení pro následující dokumenty a relace aplikace Animate. 

Režim rozšířených vrstev
Režim rozšířených vrstev

Pokud chcete k těmto symbolům přistupovat pomocí skriptu v aplikaci Animate, je nutné při volání symbolu použít vrstvu jako objekt. Když rozšířené vrstvy nepoužíváte, můžete k symbolu přímo přistupovat pomocí skriptu podobného následující ukázce:

getchildbyname("symbol1");

Pokud však rozšířené vrstvy používáte, můžete k symbolu přistupovat pouze prostřednictvím vrstvy pomocí skriptu podobného následující ukázce:

Layer=getchildbyname("L1");

Layer.getchildbyname("symbol1");

Vzorový kód pro přístup k symbolům pomocí rozšířených vrstev pro typ dokumentu AS3:

Var Layer:MovieClip =MovieClip(getchildbyname("L1"));
Layer.getchildbyname("symbol1");

Vzorový kód pro přístup k symbolům pomocí rozšířených vrstev pro typ dokumentu HTML5 Canvas:

Layer=this.getchildbyname("L1");
Layer.getchildbyname("symbol1");

Následující obrázek zobrazuje možnosti přístupu k symbolu pomocí skriptu s rozšířenými vrstvami a bez nich. 

Obrázek možností přístupu k symbolu s rozšířenými vrstvami a bez nich
Obrázek možností přístupu k symbolu s rozšířenými vrstvami a bez nich

Poznámka:

Při použití rozšířených vrstev v aplikaci Animate se může zvětšit velikost publikovaných animací. Pokud při používání funkcí kamery nebo hloubky vrstev dochází k problémům, zkontrolujte, zda jsou rozšířené vrstvy zapnuty. Pokud jsou vypnuty, zapněte je, abyste získali očekávané chování. 

Používání efektů vrstvy

Filtry a barevné efekty se používaly pouze na filmové klipy. Rozšířené vrstvy nyní umožňují použít filtry a barevné efekty na vybrané snímky, kde se následně použijí na veškerý obsah včetně tvarů, kreslených objektů, grafických symbolů atd. Efekty vrstvy lze také doplnit použitím klasických doplnění, doplnění tvaru a doplnění inverzní kinematiky mezi snímky.

Efekty vrstvy můžete použít na jednotlivé snímky nebo na více snímků výběrem požadovaných snímků. Efekty vrstvy můžete také použít na všechny snímky vrstvy výběrem celé vrstvy. Efekty vrstvy mohou být také použity na časové ose symbolu, jako je filmový klip a grafický symbol, a na všech scénách.

Poznámka:

Efekty vrstvy lze použít pouze v případě, že je zapnutý režim rozšířených vrstev. Možná budete muset povolit režim rozšířených vrstev explicitně pro soubory, aby používaly tuto funkci.

Používání filtrů na snímky

Chcete-li přidat filtry na konkrétní snímek, musíte jej nejprve vybrat. Do panelu Inspektor vlastností se načtou vlastnosti vybraného snímku. Klikněte na ikonu + v rozevíracím seznamuFiltry

Filtry snímků
Filtry snímků

Po přidání filtrů do snímků bude inspektor vlastností vypadat tak, jak je znázorněno na následujícím snímku obrazovky. 

Můžete nastavit vlastnosti pro každý z filtrů podle vašich požadavků a filtry pak aplikovat na úrovni snímku. Doplnění je možné použít pro všechny filtry snímků. 

Vlastnosti filtrů snímků v inspektoru vlastností
Vlastnosti filtrů snímků v inspektoru vlastností

Poznámka:

Efekty vrstvy jsou podporovány pouze v dokumentech typu ActionScript 3. Doplnění pohybu a vrstvy kamery nepodporují efekty vrstvy. 

Používání barevných efektů

Chcete-li přidat barevný efekt na konkrétní snímek, musíte nejprve vybrat požadovaný snímek. Do panelu Inspektor vlastností se načtou vlastnosti vybraného snímku. V panelu poté vyberte libovolnou požadovanou vlastnost barvy.

Barevné efekty
Barevné efekty

Používání hloubky vrstvy

Animátoři mohou umisťovat vrstvy do různých rovin 2D animace a vytvořit tak iluzi hloubky. 

Na panelu Hloubka vrstvy můžete hloubku vrstev dynamicky měnit. Tento panel otevřete kliknutím na Okno > Hloubka vrstvy.

Panel Hloubka vrstvy s jednotlivými vrstvami
Panel Hloubka vrstvy s jednotlivými vrstvami

Poznámka:

Minimální a maximální hodnoty hloubky vrstvy můžete nastavit v rozsahu -5000 až 10000.

Jak je vidět na obrázku výše, zobrazují se hodnoty hloubky vrstvy vedle názvu každé vrstvy daného snímku.

  • Umístěte kurzor na každou hodnotu, klikněte na ni a přetáhněte jezdce doleva nebo doprava.
  • Chcete-li hloubku zmenšit, přetáhněte jezdce doleva. Chcete-li hloubku zvětšit, přetáhněte jezdce doprava. 
  • Nižší hodnoty použijte pro bližší objekty a vyšší hodnoty použijte pro vzdálené objekty.

Můžete doplnit hodnoty hloubky vrstvy v jakémkoli rozsahu doplnění animace. 

Každá vrstva je na panelu Hloubka vrstvy znázorněna čarou, která má jedinečnou barvu. Barvy, které znázorňují jednotlivé vrstvy, si můžete prohlédnout na časové ose. 

Pokud chcete zvýšit nebo snížit hloubku objektů v každé vrstvě, přesuňte různobarevné čáry nahoru nebo dolů.

  • Chcete-li hloubku objektů ve vrstvě zmenšit, klikněte a přetáhněte čáru směrem nahoru.
  • Chcete-li hloubku objektů ve vrstvě zvětšit, klikněte a přetáhněte čáru směrem dolů.

Obrázek zobrazující animace s použitou funkcí Hloubka vrstvy a bez ní:

Obsah bez použití funkce Hloubka vrstvy
Obsah bez použití funkce Hloubka vrstvy
Obsah s použitím funkce Hloubka vrstvy
Obsah s použitím funkce Hloubka vrstvy

Obrázek zobrazující animaci s aplikovanou hloubkou vrstvy:

Použitím kamery na vrstvách s více rovinami můžete vytvořit paralaxní efekt nebo přiblížit obsah na ploše. Můžete také zamknout kameru na konkrétní vrstvě nebo aplikovat efekty kamery za běhu pomocí interaktivních rozhraní API. Další informace naleznete v tématu Vytvoření paralaxního efektu pomocí kamery a hloubky vrstvy.

Poznámka:

Hloubku vrstvy lze použít pouze na hlavní časové ose.

Zachování velikosti pro hloubku vrstvy

Hloubku vrstvy s objekty můžete měnit bez vlivu na velikost a umístění objektů. Chcete-li použít funkci pro zachování velikosti, klikněte na tlačítko Udržovat velikost v pravém horním rohu panelu Hloubka vrstvy.

Možnost zachování velikosti můžete používat dvěma způsoby:

  • Klikněte na políčko Udržovat velikost a změňte hloubku požadované vrstvy.Tlačítko Udržovat velikost se automaticky přepne.
  • Stisknutím a podržením klávesy Alt dočasně povolte možnost Udržovat velikost během přetahování hodnot hloubky vrstvy.
Zachování velikosti pro hloubku vrstvy
Zachování velikosti pro hloubku vrstvy

Používání hloubky vrstvy za běhu

Můžete také za běhu zavést kameru k objektům a aplikovat efekty pomocí rozhraní API kamery. Další informace naleznete v tématu Používání interaktivní kamery za běhu.

Rozhraní API hloubky vrstvy pro AS3

Pomocí rozhraní API můžete spravovat vrstvy za běhu. Pokud například chcete za běhu přidat do animace další vrstvu nebo zmenšit hloubku jedné vrstev v animaci. 

Metoda Prototyp Příklad Popis
setLayerZDepth fl.Layer.setLayerZDepth(timeline,
layerName,zDepth)
fl.Layer.setLayerZDepth("layerName", 100); Nastaví hodnotu hloubky Z konkrétní vrstvy.
getLayerZDepth fl.Layer.getLayerZDepth(layerName) :zDepth fl.Layer.getLayerZDepth("layerName"); Vrátí hodnotu hloubky Z konkrétní vrstvy.
addNewLayer fl.Layer.addNewLayer(layerName,
zDepth=0)
fl.Layer.addNewLayer("layerName",-80); Přidá novou vrstvu na časovou osu a nastaví hloubku Z.
removeLayer fl.Layer.removeLayer(layerName) fl.Layer.removeLayer("layerName"); Odebere vrstvu z časové osy.

Rozhraní API hloubky vrstvy pro HTML Canvas

Metoda Prototyp Příklad Popis
setLayerZDepth AdobeAn.Layer.setLayerZDepth(layerName,
zDepth)
console.log(fl.Layer.setLayerZDepth
("layerName",100));
Nastaví hodnotu hloubky Z konkrétní vrstvy.
getLayerZDepth AdobeAn.Layer.getLayerZDepth(layerName)
:zDepth
console.log(fl.Layer.getLayerZDepth
("layerName"));
Vrátí hodnotu hloubky Z konkrétní vrstvy..

Hierarchické uspořádání vrstev

V aplikaci Animate můžete vytvářet nadřízené a podřízené vrstvy. Toto hierarchické uspořádání vrstev představuje snadný způsob, jak může jedna vrstva/objekt animace řídit jinou vrstvu/objekt. Animátoři nebo herní vývojáři tak mohou zrychlit vytváření animací, protože mohou snadno ovládat pohyby různých částí postavy.

Chcete-li používat hierarchické uspořádání vrstev, musí být povoleny rozšířené vrstvy. Ve výchozím nastavení jsou rozšířené vrstvy pro nové soubory zapnuté. Hierarchické uspořádání vrstev povolíte kliknutím na ikonu hierarchie v pravém horním rohu časové osy.

Zobrazení hierarchického uspořádání vrstev
Zobrazení hierarchického uspořádání vrstev

Poznámka:

Hierarchické uspořádání vrstev pro pokřivené objekty funguje pouze tehdy, když je bod transformace objektu podřízené vrstvy na objektu nadřazené vrstvy.

Nadřízené a podřízené vrstvy

Když po aktivaci hierarchického uspořádání přesunete vrstvu 1 nad vrstvu 2, bude vrstva 1 podřízená vrstvě 2. Objekt na podřízené vrstvě si ponechává své vlastnosti, ale dědí pozici a otáčení objektu na nadřízené vrstvě. Když tedy přesouváte nebo otáčíte nadřízenou vrstvu/objekt, přesouváte nebo otáčíte zároveň i podřízenou vrstvu/objekt. Můžete vytvářet více vztahů nadřízenosti a podřízenosti, čímž vytvoříte hierarchii.

Nastavení nadřízenosti mezi vrstvami

Jednou vrstvu můžete připojit k jiné vrstvě kliknutím na úchyt vrstvy (barevný symbol) a jeho přetažením přes druhou vrstvu. Případně můžete kliknout kdekoli na vodorovnou obdélníkovou oblast vedle názvu vrstvy a přetáhnout ji přes druhou vrstvu. Můžete také kliknout na libovolnou vrstvu a v rozevíracím seznamu zvolit její nadřazenou vrstvu. 

Když kliknete na barvu vrstvy, zobrazí se vedle ní tečkovaná čára, kterou můžete přetáhnout. Vztah nadřízenosti a podřízenosti se mezi dvěma vrstvami vytvoří, jakmile uvolníte tlačítko myši a dokončíte tím přetažení.

Nastavení nadřízené vrstvy
Nastavení nadřízené vrstvy

Barevný symbol zcela vlevo v hierarchickém uspořádání vrstev představuje hlavní nadřazenou vrstvu. Hierarchie nadřízenosti a podřízenosti postupuje zleva doprava.

Propojení vrstev můžete odstranit kliknutím na barevný symbol kterékoli vrstvy a následným přetažením a uvolněním tečkované čáry. Můžete také kliknout na vodorovnou oblast a potom kliknout na Odebrat nadřazenou vrstvu, jak je zobrazeno na snímku obrazovky níže. 

Odebrání nadřazené vrstvy
Odebrání nadřazené vrstvy

Na následujících snímcích obrazovky si můžete prohlédnout, jak vypadá zobrazení vrstev před a po aktivaci hierarchie vrstev a nastavení nadřízenosti mezi vrstvami.

Před a po nastavení hierarchického uspořádání vrstev
Před a po nastavení hierarchického uspořádání vrstev

Níže je zobrazen ukázkový obrázek znázorňující použití nadřízenosti mezi vrstvami pro části lidského těla.

Ukázkový obrázek částí těla s hierarchickým uspořádáním vrstev
Ukázkový obrázek částí těla s hierarchickým uspořádáním vrstev

Na výše uvedeném obrázku platí následující vztahy:

  • Trup je nadřízenou vrstvou všech částí těla.
  • Vrstva Stehno je nadřízená dalším částem nohou, jako je teniska, lýtko a kotník.
  • Hlava je podřízená vrstvě Krk a vrstva Trup je nadřízená vrstvě Krk. Kdykoli tedy přetáhnete krk, pohybuje se zároveň s ním i hlava.

Poznámka:

Určení nadřízenost je vlastnost snímku, kterou je potřeba nastavit pro každý klíčový snímek na podřízené vrstvě. Na klíčovém snímku můžete podřízenou vrstvu oddělit nebo pro ni nastavit jinou nadřazenou vrstvu.

Výuková lekce o hierarchickém uspořádání vrstev

Výuková lekce o hierarchickém uspořádání vrstev
Zjistěte, jak můžete definovat nadřízené a podřízené vrstvy a vytvořit hierarchické uspořádání vrstev, které vám usnadní manipulaci s kompozicemi.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online