Příručka uživatele Zrušit

Jak přidat video v aplikaci Animate

  1. Příručka uživatele aplikace Adobe Animate
  2. Úvod do aplikace Animate
    1. Novinky v aplikaci Animate
    2. Grafický glosář
    3. Systémové požadavky pro aplikaci Animate
    4. Klávesové zkratky aplikace Animate
    5. Práce s různými typy souborů v aplikaci Animate
  3. Animace
    1. Základy animování v aplikaci Animate
    2. Používání snímků a klíčových snímků v aplikaci Animate
    3. Animace po jednotlivých snímcích v aplikaci Animate
    4. Práce s animacemi klasických doplnění v aplikaci Animate
    5. Nástroj Štětec
    6. Vodítko pohybu
    7. Doplnění pohybu a ActionScript 3.0
    8. O animacích s doplněními pohybu
    9. Animace s doplněním pohybu
    10. Vytvoření animace s doplněním pohybu
    11. Používání klíčových snímků vlastností
    12. Animování polohy pomocí doplnění
    13. Úpravy doplnění pohybu v editoru pohybu
    14. Úpravy cesty pohybu u animace s doplněním
    15. Úpravy doplnění pohybu
    16. Přidání vlastního náběhu nebo doběhu
    17. Vytváření a aplikování přednastavení pohybu
    18. Nastavení rozsahu doplnění animace
    19. Práce s doplněními pohybu uloženými jako soubory XML
    20. Srovnání doplnění pohybu a klasických doplnění
    21. Doplňování tvarů
    22. Používání animací nástroje Kost v aplikaci Animate
    23. Sestavování postav v aplikaci Animate
    24. Používání vrstev masek v aplikaci Adobe Animate
    25. Práce se scénami v aplikaci Animate
  4. Interaktivita
    1. Vytváření tlačítek v aplikaci Animate
    2. Převod projektů aplikace Animate na jiné typy dokumentů
    3. Vytváření a publikování dokumentů HTML5 Canvas v aplikaci Animate
    4. Přidání interaktivity pomocí fragmentů kódu v aplikaci Animate
    5. Vytváření vlastních komponent HTML5
    6. Používání komponent v dokumentech HTML5 Canvas
    7. Vytváření vlastních komponent: Příklady
    8. Fragmenty kódu pro vlastní komponenty
    9. Osvědčené postupy – Tvorba reklam v aplikaci Animate
    10. Vytváření a publikování virtuální reality
  5. Pracovní plocha a pracovní postupy
    1. Vytváření a správa malířských štětců
    2. Používání písem Google v dokumentech HTML5 Canvas
    3. Používání knihoven Creative Cloud v aplikaci Adobe Animate
    4. Používání vymezené plochy a panelu nástrojů v aplikaci Animate
    5. Pracovní postupy a pracovní plocha aplikace Animate
    6. Používání webových písem v dokumentech HTML5 Canvas
    7. Časové osy a ActionScript
    8. Práce s více časovými osami
    9. Nastavení předvoleb
    10. Používání vývojových panelů aplikace Animate
    11. Vytváření vrstev časové osy v aplikaci Animate
    12. Export animací pro mobilní aplikace a herní moduly
    13. Přemísťování a kopírování objektů
    14. Předlohy
    15. Příkaz Hledat a nahradit v aplikaci Animate
    16. Vrácení akce, její zopakování a panel Historie
    17. Klávesové zkratky
    18. Používání časové osy v aplikaci Animate
    19. Vytvoření rozšíření HTML
    20. Možnosti optimalizace obrázků a animovaných souborů GIF
    21. Export nastavení pro obrázky a soubory GIF
    22. Panel Datové zdroje v aplikaci Animate
  6. Multimédia a video
    1. Transformace a kombinování grafických objektů v aplikaci Animate
    2. Vytváření a práce s instancemi symbolů v aplikaci Animate
    3. Vektorizace obrazu
    4. Používání zvuku v aplikaci Adobe Animate
    5. Export souborů SVG
    6. Vytváření souborů videa používaných v aplikaci Animate
    7. Přidání videa v aplikaci Animate
    8. Kreslení a vytváření objektů v aplikaci Animate
    9. Změna čar a tvarů
    10. Tahy, výplně a přechody v aplikaci Animate
    11. Práce s aplikacemi Adobe Premiere Pro a After Effects
    12. Panely barev v aplikaci Animate
    13. Otevírání souborů aplikace Flash CS6 v aplikaci Animate
    14. Práce s klasickým textem v aplikaci Animate
    15. Vložení grafiky do aplikace Animate
    16. Importované bitmapy v aplikaci Animate
    17. 3D grafika
    18. Práce se symboly v aplikaci Animate
    19. Kreslení čar a tvarů v aplikaci Adobe Animate
    20. Práce s knihovnami v aplikaci Animate
    21. Export zvuků
    22. Výběr objektů v aplikaci Animate
    23. Práce se soubory aplikace Illustrator (AI) v aplikaci Animate
    24. Používání režimů prolnutí
    25. Uspořádání objektů
    26. Automatizace úloh pomocí nabídky Příkazy
    27. Vícejazyčný text
    28. Používání kamery v aplikaci Animate
    29. Grafické filtry
    30. Zvuk a ActionScript
    31. Předvolby kreslení
    32. Kreslení nástrojem Pero
  7. Platformy
    1. Převod projektů aplikace Animate na jiné typy dokumentů
    2. Podpora vlastní platformy
    3. Vytváření a publikování dokumentů HTML5 Canvas v aplikaci Animate
    4. Vytvoření a publikování dokumentu ve formátu WebGL
    5. Balení aplikací pro prostředí AIR for iOS
    6. Publikování aplikací prostředí AIR for Android
    7. Publikování pro prostředí Adobe AIR pro počítače
    8. Nastavení publikování jazyka ActionScript
    9. Osvědčené postupy – Uspořádání ActionScriptu v aplikaci
    10. Používání jazyka ActionScript v aplikaci Animate
    11. Usnadnění přístupu v pracovním prostoru aplikace Animate
    12. Psaní a správa skriptů
    13. Povolení podpory vlastních platforem
    14. Přehled podpory vlastních platforem
    15. Práce se zásuvným modulem pro podporu vlastní platformy
    16. Ladění jazyka ActionScript 3.0
    17. Povolení podpory vlastních platforem
  8. Export a publikování
    1. Export souborů z aplikace Animate
    2. Publikování OAM
    3. Export souborů SVG
    4. Export grafiky a videa v aplikaci Animate
    5. Publikování dokumentů AS3
    6. Export animací pro mobilní aplikace a herní moduly
    7. Export zvuků
    8. Osvědčené postupy – Tipy pro vytváření obsahu pro mobilní zařízení
    9. Osvědčené postupy – Konvence videa
    10. Osvědčené postupy – Pravidla pro vývoj aplikací SWF
    11. Osvědčené postupy – Strukturování souborů FLA
    12. Osvědčené postupy pro optimalizaci souborů FLA pro Animate
    13. Nastavení publikování jazyka ActionScript
    14. Nastavení publikování v aplikaci Animate
    15. Export souborů projektoru
    16. Export obrázků a animovaných souborů GIF
    17. Předlohy publikování HTML
    18. Práce s aplikacemi Adobe Premiere Pro a After Effects
    19. Rychlé sdílení a publikování animací
  9. Řešení problémů
    1. Opravené problémy
    2. Známé problémy

 

Aplikace Animate nabízí několik způsobů, jak do dokumentu Animate včlenit video a přehrávat ho uživatelům.

Na úvod

Než v aplikaci Animate začnete pracovat s videem, je důležité si uvědomit následující skutečnosti:

  • Aplikace Animate umožňuje přehrávat pouze určité formáty videa.

    Jsou to formáty FLV, F4V a MPEG. Pokyny k převedení videa z jiných formátů najdete v části Vytvoření videa určeného k použití v aplikaci Animate.

  • K převodu jiných formátů videa do formátu F4V použijte samostatnou aplikaci Adobe Media Encoder (dodává se s aplikací Animate). Pokyny najdete v části Vytvoření videa určeného k použití v aplikaci Animate.

  • Přidání videa do aplikace Animate lze provést několika způsoby. Každý z nich je vhodný v jiné situaci. Seznam způsobů přidání videa najdete níže.

  • Aplikace Animate obsahuje Průvodce importem videa, kterého zobrazíte výběrem příkazu Soubor > Importovat > Importovat video.

  • Nejsnáze přehrávání videa v souboru aplikace Animate zajistíte pomocí komponenty FLVPlayback.

    Pokyny najdete v části Postupné stahování videa z webového serveru.

Způsoby používání videa Animate

Video lze v aplikaci Animate používat různými způsoby:

  • Postupné stahování z webového serveru

    Při použití tohoto způsobu je soubor videa oddělen od souboru aplikace Animate a výsledného souboru SWF. Soubor SWF tak má malou velikost. Jedná se o nejčastější způsob použití videa v aplikaci Animate.

  • Streamování videa ze serveru Adobe Media Server

    Při použití tohoto způsobu je soubor videa rovněž oddělen od souboru aplikace Animate. Server Adobe Media Streaming Server kromě plynulého přehrávání streamovaného videa zajišťuje i bezpečnou ochranu jeho obsahu.

  • Vložení dat videa přímo do souboru aplikace Animate

    Soubory Animate vytvořené tímto způsobem mají značnou velikost, proto se tato metoda doporučuje pouze u krátkých videoklipů. Pokyny najdete v části Vkládání videa do souboru Animate.

Postupné stahování videa z webového serveru

Postupné stahování umožňuje používat komponentu FLVPlayback nebo vytvořený skript jazyka ActionScript k načtení externích souborů videa FLV nebo F4V do souboru SWF a jejich přehrávání za běhu.

Protože se obsah videa uchovává odděleně od ostatního obsahu aplikace Animate, je možné jej relativně snadno aktualizovat, aniž by bylo nutné soubor SWF znovu publikovat.

Postupné stahování poskytuje oproti vložení videa do časové osy následující výhody:

  • Pokud chcete v průběhu tvorby testovat veškerý obsah Animate nebo jeho část, případně zobrazit jeho náhled, stačí publikovat pouze soubor SWF. Zkrátí se tak doba nutná k zobrazení náhledu a k urychlení cyklu opakovaných experimentů.

  • Během přehrávání se video začíná přehrávat, jakmile se první segment stáhne a uloží do vyrovnávací paměti na disku lokálního počítače.

  • Přehrávač Flash Player za běhu načítá soubory videa z disku počítače do souboru SWF, bez omezení velikosti souboru videa nebo doby trvání. Neexistují žádné problémy se synchronizací zvuku ani žádná omezení týkající se paměti.

  • Kmitočet snímků souboru videa může být odlišný od kmitočtu snímků souboru SWF, takže můžete obsah Animate vytvářet pružněji.

Import videa pro postupné stahování

Můžete importovat soubor videa umístěný v místním počítači a po importu do souboru FLA jej odeslat na server. Když v aplikaci Animate importujete video pro postupné stahování, ve skutečnosti pouze přidáváte odkaz na soubor videa. Aplikace Animate podle tohoto odkazu vyhledá video v místním počítači nebo na webovém serveru.

Rovněž můžete importovat soubor videa, který už byl odeslán na standardní webový server, server AMS nebo do služby FVSS.

  1. Chcete-li videoklip importovat do aktuálního dokumentu Animate, vyberte Soubor > Importovat > Importovat video.

    Okno pro výběr videa
    Okno pro výběr videa

  2. Vyberte videoklip, který chcete importovat. Můžete buď vybrat videoklip umístěný v místním počítači, nebo zadat adresu URL videa, které už bylo odesláno na webový server nebo server Adobe Media Server.

    • Chcete-li importovat video umístěné v místním počítači, vyberte možnost Načíst externí video s komponentou pro přehrávání.

    • Chcete-li importovat video, které již bylo nasazené na webový server, server Adobe Media Server nebo službu Flash Video Streaming, vyberte možnost Již nasazené na webový server, službu FVSS nebo server Adobe Media Server a zadejte adresu URL videoklipu.

     Adresa URL pro videoklip umístěný na webovém serveru bude používat komunikační protokol HTTP. Adresa URL pro videoklip umístěný na serveru Adobe Media Server nebo ve službě FVSS bude používat komunikační protokol RTMP.

  3. Vyberte vzhled pro svůj videoklip. 

    Výběr vzhledu pro videoklip
    Výběr vzhledu pro videoklip

    Můžete provést následující:

    • Pokud nechcete s komponentou FLVPlayback použít vzhled, vyberte možnost Žádný.

    • Vyberte jeden z předdefinovaných vzhledů komponenty FLVPlayback. Aplikace Animate vzhled zkopíruje do stejné složky jako soubor FLA.

     Vzhledy komponenty FLVPlayback se mírně liší podle toho, zda vytváříte dokument Animate AS2 nebo AS3.

    • Můžete si vybrat také vzhled podle vlastního návrhu – stačí zadat jeho adresu URL na webovém serveru.

     Pokud zvolíte, že chcete používat vlastní vzhled získaný ze vzdáleného umístění, živý náhled nebude pro video na ploše dostupný.

  4. Průvodce importem videa vytvoří na ploše komponentu videa FLVPlayback, kterou můžete používat k místnímu testování přehrávání videa. Když dokončíte vytváření dokumentu Animate a chcete výsledný soubor SWF a videoklip nasadit, odešlete na webový server nebo server AMS, kde video hostujete, následující data:

    • Pokud používáte místní kopii videoklipu, odešlete videoklip. (Videoklip je umístěn ve stejné složce jako vybraný zdrojový videoklip s příponou .flv.)

     Aplikace Animate používá k odkazu na soubor FLV nebo F4V relativní cestu (vztaženou k souboru SWF), takže můžete lokálně použít stejnou adresářovou strukturu jako na serveru. Pokud bylo příslušné video dříve umístěné na vašem FMS nebo na FVSS hostujícím vaše videa, můžete tento krok přeskočit.

    • Vzhled videa (pokud jste se rozhodli vzhled použít)

      Chcete-li použít předdefinovaný vzhled, zkopíruje aplikace Animate příslušný vzhled do stejné složky jako soubor FLA.

    • Komponenta FLVPlayback

      Chcete-li upravit pole URL komponenty FLVPlayback na URL webového serveru nebo serveru AMS, do kterého video odesíláte, upravte pomocí inspektoru komponent (Okno > Inspektor komponent) parametr contentPath.

Streamování videa ze serveru Adobe Media Server

Server Adobe Media Server v reálném čase zasílá mediální streamy do přehrávače Flash Player a prostředí AIR. Server AMS používá detekci šířky pásma připojení, aby mohl při zasílání obsahu videa nebo zvuku vycházet z připojení, které má uživatel k dispozici.

Streamování videa pomocí serveru Adobe Media Server poskytuje oproti vloženému a postupně stahovanému videu následující výhody:

  • Přehrávání videa se spouští dříve než s využitím jiných metod začleňování videa.

  • Streamování využívá méně paměti klientského počítače a méně místa na jeho disku, protože klientské počítače nemusejí stahovat celý soubor.

  • Síťové prostředky se využívají efektivněji, protože se na klientský počítač zasílají pouze části videa, které si uživatel prohlíží.

  • Zasílání médií je bezpečnější, protože se média při streamování neukládají do vyrovnávací paměti klientského počítače.

  • Streamování videa poskytuje lepší možnosti pro sledování, hlášení a zaznamenávání.

  • Streamování umožňuje zasílat živé video prezentace a zvukové prezentace nebo snímat video z webové kamery nebo digitální videokamery.

  • Adobe Media Server umožňuje vícesměrové a víceuživatelské streamování pro online aplikace video diskuzí, zasílání video zpráv a videokonferencí.

  • Pomocí skriptů na straně serveru k řízení streamovaného videa a zvukových streamů můžete vytvářet seznamy skladeb na straně serveru a synchronizované streamy a využívat další volby inteligentního zasílání vycházejícího z rychlosti připojení klienta.

Další informace o serveru Adobe Media Server najdete na stránce www.adobe.com/go/flash_media_server_cz.

Další informace o službě Flash Video Streaming naleznete na stránce www.adobe.com/go/learn_fvss_cz.

Vkládání souborů videa do souborů aplikace Animate

Při vložení souboru videa se veškerá data z tohoto souboru přidají do souboru Animate. Značně se tak zvýší velikost souboru Animate a následně i souboru SWF. Video je umístěno do časové osy, kde můžete prohlížet jednotlivé snímky videa znázorněné ve snímcích časové osy. Protože je každý snímek videa představován jedním snímkem v časové ose, musí být kmitočet snímků videoklipu a souboru SWF stejný. Pokud použijete různý kmitočet snímků pro soubor SWF a pro vložený videoklip, bude přehrávání videa nestabilní.

Poznámka: Pokud chcete používat proměnný kmitočet snímků, streamujte video s použitím postupného stahování nebo pomocí serveru Adobe Media Server. Při importu souborů videa s použitím kterékoli z těchto metod jsou soubory FLV nebo F4V samostatné a spouštějí se s kmitočtem snímků, který je jiný než všechny ostatní kmitočty snímků časové osy obsažených v souboru SWF.

Vložené video funguje nejlépe pro menší videoklipy s časem přehrávání kratším než 10 sekund. Pokud používáte videoklipy s delší dobou přehrávání, zvažte, zda nebude lepší použít postupně stahované video nebo streamované video s použitím serveru Adobe Media.

Mezi omezení vloženého videa patří:

  • Pokud budou výsledné soubory SWF příliš velké, můžete se setkat s problémy. Flash Player si při stahování a přehrávání velkých souborů SWF s vloženým videem vyhrazuje velké množství paměti, což může způsobit jeho selhání.

  • Delší soubory videa (více než 10 sekund) mají často potíže se synchronizací mezi částí videa a zvukovou částí videoklipu. Zvukové stopy se postupně začnou přehrávat mimo sekvenci videa, což má za následek zhoršení zážitku ze sledování videoklipu.

  • Chcete-li přehrávat video vložené do souboru SWF, před zahájením přehrávání videa musí být stažený celý soubor videa. Pokud vložíte nadměrně velký soubor videa, může trvat značný čas, než se soubor SWF stáhne celý a než se spustí přehrávání.

  • Po importování již videoklip nemůžete upravovat. Místo toho je nutné soubor videa znovu upravit a importovat.‏

  • Při publikování souboru SWF prostřednictvím webu je třeba do počítače uživatele stáhnout nejdříve celé video a teprve pak může začít přehrávání.

  • Celé video se musí za běhu vejít do místní paměti počítače provádějícího přehrávání.

  • Délka importovaného souboru videa musí být menší než 16 000 snímků.

  • Kmitočet snímků videa musí být stejný jako kmitočet snímků časové osy aplikace Animate. Nastavte kmitočet snímků souboru aplikace Animate tak, aby odpovídal kmitočtu snímků vloženého videa.

Náhled snímků vloženého videa můžete zobrazit tažením přehrávací hlavy po časové ose. Během přetažení se zvuková stopa videa nepřehrává. Pokud chcete zobrazit náhled videa se zvukem, použijte příkaz Testovat film.

Vložení videa do souboru Animate

  1. Chcete-li videoklip importovat do aktuálního dokumentu Animate, vyberte postupně Soubor > Importovat > Importovat video.

  2. Vyberte jednu z těchto možností:

    Načíst externí video s komponentou pro přehrávání: Tato volba importuje video a vytvoří instanci komponenty FLVPlayback pro řízení přehrávání videa.

    Vložit soubor FLV do SWF a přehrát v časové ose: Vloží soubor FLV do dokumentu aplikace Animate a umístí ho na časovou osu.

    Vložit video H.264 do časové osy: Vkládá videa H.264 do dokumentu aplikace Flash. Pokud k importu videa použijete tuto možnost, můžete video, které je umístěné na ploše, použít při návrhu jako vodítko animace. Při procházení videa nebo přehrávání na časové ose se snímky videa vykreslují na ploše. Přehrává se také zvuk příslušných snímků.

     Když se pokusíte publikovat soubor FLA s videem H.264 ve vrstvě, která není vodicí ani skrytá, zobrazí se upozornění, že platforma použitá k publikování nepodporuje vložená videa H.264.

  3. Klikněte na Procházet, vyberte v počítači soubor videa a klikněte na Další.

    Volitelné: Pokud máte na počítači nainstalovanou aplikaci Adobe Media Encoder a chcete v ní video převést na jiný formát, klikněte na Převést video.

  4. Zvolte typ symbolu, se kterým chcete video vložit.

    Výběr typu symbolu
    Výběr typu symbolu

    Vložené video

    Pokud používáte videoklip pro lineární přehrávání na časové ose, nejvhodnější metodou je import videa do časové osy.

    Filmový klip

    Osvědčeným způsobem je umístit video dovnitř instance filmového klipu, protože tak získáte největší kontrolu nad obsahem. Časová osa videa se přehrává nezávisle na hlavní časové ose. Pokud chcete vložit video, nemusíte rozšiřovat svou hlavní časovou osu o velký počet snímků, to by totiž mohlo znesnadnit práci se souborem FLA.

    Grafika

    Když vložíte videoklip jako grafický symbol, nemůžete interaktivně pracovat s videem s použitím jazyka ActionScript (grafické symboly se obvykle používají pro statické obrazy a k vytváření opakovaně použitelných částí animace, které jsou spojené s hlavní časovou osou).

  5. Importujte videoklip přímo do plochy (a do časové osy) nebo jako položku knihovny.

    Aplikace Animate standardně umísťuje importované video na plochu. Chcete-li importovat pouze do knihovny, odznačte Umístit instanci na plochu.

    Pokud vytváříte jednoduchou video prezentaci s lineárním komentářem a minimální až žádnou interakcí, potvrďte výchozí nastavení a importujte video na plochu. Chcete-li vytvořit dynamičtější prezentaci, pracovat s více videoklipy nebo přidávat dynamické přechody nebo jiné prvky s použitím ActionScriptu, naimportujte video do knihovny. Jakmile je videoklip v knihovně, přizpůsobte ho převedením na objekt MovieClip, který můžete snadněji ovládat pomocí ActionScriptu.

    Aplikace Animate ve výchozím nastavení rozšiřuje časovou osu, aby ji přizpůsobila délce přehrávání vkládaného videoklipu.

    Pokud soubor videa obsahuje zvuk, který nechcete importovat, zrušte zaškrtnutí políčka Zahrnout zvuk.  

  6. Klikněte na tlačítko Další. Přečtěte si potvrzovací zprávy a klikněte na Dokončit.

    Průvodce importem videa vloží video do souboru SWF. Video se zobrazí na ploše nebo v knihovně, podle vámi zvolených voleb vkládání.

    Dialogové okno Dokončit import videa
    Dialogové okno Dokončit import videa

  7. V inspektoru vlastností (Okna > Vlastnosti) přidělte videoklipu název instance a proveďte libovolné úpravy vlastností videoklipu.

    Název instance videoklipu
    Název instance videoklipu

Import souborů videa do knihovny

Pokud chcete importovat videa ve formátu FLV, F4V nebo H.264, použijte příkazy Importovat > Importovat video nebo Importovat do knihovny.

Chcete-li vytvořit svůj vlastní přehrávač videa, který dynamicky načítá soubory FLV nebo F4V z externího zdroje, umístěte své video dovnitř symbolu filmového klipu. Pokud načítáte soubory FLV nebo F4V dynamicky, nastavte rozměry filmového klipu tak, aby odpovídaly skutečným rozměrům souboru videa, a změňte velikost videa změnou velikosti filmového klipu.

 Osvědčeným způsobem je umístit video dovnitř instance filmového klipu, protože tak získáte největší možnosti řízení obsahu. Časová osa videa se přehrává nezávisle na hlavní časové ose. Pokud chcete vložit video, nemusíte rozšiřovat svou hlavní časovou osu o mnoho snímků; to by totiž mohlo znesnadnit práci s vaším souborem FLA.

  1. Pokud chcete do knihovny importovat soubor videa FLV, SWF nebo H.264, použijte jednu z následujících možností:

    • Vyberte Soubor > Importovat > Importovat do knihovny.

    • V panelu Knihovna vyberte libovolný existující videoklip a v nabídce panelu Knihovna vyberte Vlastnosti. Můžete také kliknout pravým tlačítkem na soubor videa a v místní nabídce vybrat příkaz Vlastnosti. Klikněte na tlačítko Import. Najděte soubor, který chcete importovat, a klikněte na Otevřít.

    Možnost Importovat do knihovny
    Možnost Importovat do knihovny

Změna vlastností videoklipu

V Inspektoru vlastností můžete změnit vlastnosti pro instanci vloženého videoklipu na ploše, přiřadit instanci název a změnit její šířku, výšku a polohu na ploše. Můžete také zaměnit instanci videoklipu – přiřadit k instanci videoklipu jiný symbol. Přiřazení jiného symbolu k instanci zobrazuje jinou instanci na ploše, ale ponechává všechny ostatní vlastnosti instance (jako rozměry a vztažný bod) beze změn.

V dialogovém okně Vlastnosti videa můžete provést následující úkony:

  • Zobrazit informace o importovaném videoklipu, včetně jeho názvu, cesty, data vytvoření, rozměrů v obrazových bodech, délky a velikosti souboru

  • Změnit název videoklipu

  • Aktualizovat videoklip, pokud ho změníte v externím editoru

  • Nahradit vybraný klip importovaným souborem FLV nebo F4V

  • Exportovat videoklip jako soubor FLV nebo F4V

Změna vlastností instance videa v Inspektoru vlastností

  1. Na ploše vyberte instanci vloženého nebo připojeného videoklipu.
  2. Vyberte Okno > Vlastnosti a proveďte libovolné z následujících úkonů:

    • Vlevo v inspektoru Vlastnosti v textovém poli Název zadejte název instance.

    • Zadáním hodnot pro Š a V změňte rozměry instance videa.

    • Zadáním hodnot pro X a Y změňte polohu levého horního rohu instance na ploše.

    • Klepněte na Zaměnit. Vyberte videoklip a zaměňte jím klip aktuálně přiřazený k dané instanci.

     Vložený videoklip můžete zaměnit pouze jiným vloženým videoklipem a připojený videoklip můžete zaměnit pouze jiným připojeným videoklipem.

Zobrazení vlastností videoklipu v dialogovém okně Vlastnosti videa

  1. V panelu Knihovna vyberte videoklip.
  2. V nabídce panelu Knihovna vyberte Vlastnosti, nebo klikněte na tlačítko Vlastnosti umístěné ve spodní části panelu Knihovna. Zobrazí se dialogové okno Vlastnosti videa.

Přiřazení nového názvu, aktualizace nebo nahrazení videa

  1. V panelu Knihovna vyberte videoklip a v nabídce panelu Knihovna vyberte Vlastnosti.
  2. Proveďte jeden z následujících úkonů:

    • Chcete-li přiřadit nový název, zadejte název v textovém poli Název.

    • Chcete-li video aktualizovat, vyhledejte aktualizovaný soubor videa a klikněte na Otevřít.

    • Chcete-li video nahradit, klikněte na Importovat, přejděte k souboru FLV, F4V nebo H.264, který chcete vložit místo aktuálního klipu, a klikněte na tlačítko Otevřít.

Ovládání přehrávání videa pomocí časové osy

Ovládání přehrávání vloženého souboru videa se provádí řízením časové osy, která obsahuje příslušné video. Pokud byste například chtěli pozastavit přehrávání videa na hlavní časové ose, volali byste akci stop(), která spouští danou časovou osu. Podobně můžete řídit objekt videa v symbolu filmového klipu řízením přehrávání časové osy tohoto symbolu.

U objektů importovaného videa ve filmových klipech můžete použít následující akce: goTo, play, stop, toggleHighQuality, stopAllSounds, getURL, FScommand, loadMovie, unloadMovie, ifFrameLoadedonMouseEvent. Chcete-li aplikovat akce na objekt videa, převeďte nejprve objekt videa na filmový klip.

Chcete-li zobrazit živé streamované video z kamery, použijte ActionScript. Nejprve výběrem položky Nový objekt videa v panelu Knihovna umístěte objekt videa na plochu. Chcete-li k objektu videa připojit streamované video, použijte Video.attachVideo.

Viz též Video a attachVideo (metoda Video.attachVideo) v dokumentu ActionScript 2.0 Language Reference (Referenční příručka jazyka ActionScript 2.0) a fl.video v dokumentu ActionScript 3.0 Language Reference (Referenční příručka jazyka ActionScript 3.0).

Aktualizace vloženého videa po úpravě zdrojového souboru

  1. V panelu Knihovna vyberte videoklip.
  2. Vyberte Vlastnosti a klikněte na Aktualizovat.

    Vložený videoklip se zaktualizuje upraveným souborem. Na aktualizovaný klip se znovu aplikuje nastavení komprese, které jste vybrali, když jste importovali video poprvé.

 Adobe

Získejte pomoc rychleji a snáze

Nový uživatel?

Adobe MAX 2024

Adobe MAX
Konference věnovaná tvořivosti

14.–16. října Miami Beach a online

Adobe MAX

Konference věnovaná tvořivosti

14.–16. října Miami Beach a online

Adobe MAX 2024

Adobe MAX
Konference věnovaná tvořivosti

14.–16. října Miami Beach a online

Adobe MAX

Konference věnovaná tvořivosti

14.–16. října Miami Beach a online