Export obrazů a grafiky

Sekvence PNG

Můžete exportovat řadu obrazových souborů z jednoho filmového klipu, tlačítka nebo grafického symbolu v knihovně nebo na vymezené ploše V průběhu exportu vytvoří aplikace Animate CC (dříve Flash Professional CC) samostatný obrazový soubor pro každý rámec v symbolu. Při exportu z vymezené plochy budou ve výstupu obrazu zachovány všechny transformace (například škálování), které jste na instanci symbolu použili.

Export sekvence PNG:

  1. Vyberte jeden filmový klip, tlačítko nebo grafický symbol v knihovně nebo na ploše.

  2. Klikněte na ně pravým tlačítkem myši a vyberte možnost Exportovat sekvenci PNG.

    select-png-sequence
  3. V dialogovém okně Uložit jako vyberte umístění výstupu a klikněte na tlačítko OK.

     

  4. V dialogovém okně Exportovat sekvenci PNG nastavte požadované možnosti. 

    export-pngsequence

    Šířka – šířka obrazového výstupu. Velikost výstupu je možné měnit změnou této hodnoty. Výchozí je šířka obsahu symbolu.

    Výška – výška obrazového výstupu. Velikost výstupu je možné měnit změnou této hodnoty. Výchozí je výška obsahu symbolu.

    Rozlišení – rozlišení obrazového výstupu. Výchozí hodnota je 72 dpi.

    Barvy – hloubka barev obrazového výstupu. Můžete vybrat 8, 24 nebo 32 bitů. Výchozí hodnota je 32 bitů, což podporuje průhlednost. Pokud vyberete 24 bitů nebo 8 bitů, což průhlednost nepodporuje, nastavení pozadí se změní na hodnotu Plocha. Viz dále.

    Pozadí – barva, která se ve výstupu obrazu použije jako barva pozadí. Toto nastavení je k dispozici pouze v případě, kdy je možnost Barvy nastavena na 8 nebo 24 bitů. Když jsou barvy nastaveny na 32 bitů, je pozadí obrazu vždy průhledné. Když je možnost Barvy nastavena na 8 nebo 24 bitů, bude ve výchozím nastavení pro možnost Pozadí použita hodnota Plocha. U 8bitových nebo 24bitových obrázků můžete nastavení změnit na Neprůhledný a poté vybrat barvu pozadí pomocí nástroje Výběr barvy. Případně průhlednost vytvořte zvolením alfa hodnoty pro pozadí.

    Vyhladit – přepíná, zda má být použito vyhlazení okrajů obrazového výstupu. Tuto možnost vypněte, pokud nepoužíváte průhledné pozadí a u obrázků je použita jiná barva pozadí, než je aktuální barva plochy.

  5. Kliknutím na tlačítko Exportovat exportujte sekvenci PNG.

Export animovaného souboru ve formátu GIF

V Animate můžete exportovat animované soubory ve formátu GIF provedením následujících kroků: 

  1. Přejděte do nabídky Soubor > Export > Exportovat animovaný GIF.

    Zobrazí se dialogové okno. 

    export-animated-gif
  2. V dialogovém okně vyberte požadované možnosti a kliknutím na tlačítko Hotovo exportujte animaci jako animovaný soubor GIF.

    animated-gif-dialog

    Můžete také exportovat statický soubor GIF kliknutím na Soubor > Export > Exportovat obraz.

Export obrázků a grafiky do CC knihovny

Chcete-li exportovat obrázky nebo grafiku do CC knihovny, klikněte na nabídku Okno > CC knihovna

Zobrazí se okno CC knihovny. 

add-to-cc-library

V levém dolním rohu okna CC knihovny klikněte na ikonu + a vyberte obrázky nebo grafické soubory. Poté klikněte na tlačítko Přidat.

Formát FXG (graphic interchange format) (vyřazený v aplikaci Animate CC)

O souborech FXG

FXG je formát GIF (Graphic Interchange Format) pro platformu Animate/Flash. Formát FXG je založen na podmnožině MXML, programovacího jazyka založeného na jazyce XML, který se používá v platformě Flex. Formát FXG pomáhá designérům a vývojářům v efektivnější spolupráci tím, že jím umožňuje uskutečňovat výměnu grafického obsahu s vysokou věrností. Designéři mohou vytvářet grafiku pomocí nástrojů společnosti Adobe a exportovat je do formátu FXG. Soubor FXG můžete používat v nástrojích, jako je Adobe Flash Builder a Adobe Flash Catalyst k vývoji multimediálních internetových aplikací.

Při vytváření souboru FXG se vektorová grafika ukládá přímo do souboru. Prvky, pro které ve formátu FXG neexistuje odpovídající tag, jsou exportovány jako bitmapová grafika, na kterou se v souboru FXG vytvoří odkaz. Patří mezi ně bitmapy, některé filtry a režimy prolnutí, přechody, masky a 3D. Některé z těchto efektů lze exportovat jako formát FXG, ale nelze je aplikací, která soubor FXG otevírá, importovat.

Pokud exportujete soubor obsahující vektorové nebo bitmapové obrázky pomocí exportu FXG, společně se souborem FXG se vytvoří samostatná složka. Tato složka má název <filename.assets> a obsahuje bitmapové obrazy související se souborem FXG.

Další informace o formátu souborů FXG naleznete ve specifikacích FXG 2.0.

Omezení exportu do formátu FXG

Aplikace Animate umožňuje vybrat na vymezené ploše k exportu do formátu FXG jeden nebo více objektů. Názvy objektů a vrstev jsou při exportu do formátu FXG zachovány.

Při ukládání do souboru FXG jsou omezeny následující položky:

  • Sítě Scale-9: jsou exportovány, ale lze je číst pouze v aplikaci Adobe Ilustrator.

  • Zvuk a video: nejsou exportovány.

  • Komponenty: nejsou exportovány.

  • Doplnění a animace s více snímky: nejsou exportovány, ale vybraný snímek se exportuje jako statický objekt.

  • Vložená písma: nejsou exportována.

  • Symboly tlačítek: aplikace Animate exportuje pouze tlačítka stavu Nahoře.

  • Vlastnosti 3D: nejsou exportovány.

  • Vlastnosti Inverzní Kinematiky (IK): nejsou exportovány.

  • Atributy textu: některé atributy nemusí být exportovány.

Export obsahu Animate do formátu FXG

V aplikaci Animate lze obsah exportovat do formátu FXG dvěma způsoby:

  • Jestliže chcete objekty ve vymezené ploše exportovat do souboru FXG, vyberte tyto objekty a zvolte příkaz Export > Exportovat výběr. Potom v nabídce Typ souboru vyberte formát FXG.

  • Chcete-li do souboru FXG uložit celou vymezenou plochu, zvolte příkaz Export > Exportovat obraz a z nabídky Typ souboru vyberte formát Adobe FXG.

Sekvence JPEG a obraz JPEG

Tyto možnosti jsou stejné jako možnosti Nastavení publikování JPEG. Volba Přizpůsobit obrazovce přizpůsobuje exportovaný obraz velikosti obsahu aplikace Animate tak, jak se zobrazuje na obrazovce. Volba Přizpůsobit film přizpůsobuje obraz JPEG obsahu Animate a zachovává poměr stran původního obrazu.

Sekvence PNG a obraz PNG

Volby nastavení exportu PNG jsou podobné jako volby nastavení publikování PNG (které můžete rovněž aplikovat), s následujícími výjimkami:

Rozměry

Nastavuje velikost exportovaného bitmapového obrazu na počet obrazových bodů, který zadáte do polí Šířka a Výška.

Rozlišení

Zadejte rozlišení v dpi. Chcete-li použít rozlišení obrazovky a zachovat poměr stran původního obrazu, vyberte volbu Přizpůsobit obrazovce.

Barvy

Stejné jako volba Bitová hloubka na záložce Nastavení publikování PNG. Nastavuje počet bitů na obrazový bod, který se má použít při vytváření obrazu. Pro obraz s 256 barvami vyberte 8bitovou hloubku; pro tisíce barev vyberte 24 bitů na kanál; pro tisíce barev s průhledností (32 bitů na kanál) vyberte 24 bitů na kanál s alfou. Čím vyšší bitová hloubka, tím větší bude soubor.

Zahrnout

Vyberte, zda se má exportovat minimální oblast obrazu, nebo určete plnou velikost dokumentu.

Poznámka:

Rozměry exportovaného souboru GIF musí být menší než 4000 obrazových bodů. Toto omezení platí pro aplikaci od verze CS6.

Poznámka:

Možnost Rozklad plných barev nefunguje, pokud je vybrána možnost 256 barev. To znamená, že obrázek GIF nebude rozložen, pokud je jako schéma barev obrázku GIF vybrána možnost 256 barev.

(Ve verzi Animate CC vyřazeno) Bitmapový obraz (BMP)

Vytvořte bitmapové obrazy pro použití v jiných aplikacích. Dialogové okno Export bitmapy má následující volby:

Rozměry

Nastavuje velikost exportovaného bitmapového obrazu v obrazových bodech. Velikost, kterou určíte, má vždy stejný poměr stran jako váš původní obraz.

Rozlišení

Nastaví rozlišení exportovaného bitmapového obrazu v bodech na palec (dpi) a automaticky vypočítá šířku a výšku založenou na velikosti vaší kresby. Chcete-li nastavit rozlišení, které bude odpovídat vašemu monitoru, vyberte položku Přizpůsobit obrazovce.

Barevná hloubka

Určuje bitovou hloubku obrazu. Některé aplikace Windows nepodporují novější hloubku 32 bitů na kanál pro bitmapové obrazy. Pokud máte problémy s použitím formátu 32 bitů na kanál, použijte formát 24 bitů na kanál.

Vyhladit

Aplikuje vyhlazení na exportovanou bitmapu. Vyhlazení zvýší kvalitu bitmapového obrazu, ale může vytvořit aureolu z šedých obrazových bodů kolem obrazu umístěného na barevném pozadí. Odznačte, pokud se objeví aureola.

Dokument Animate (SWF)

Chcete-li umístit obsah Animate do jiné aplikace, například do Dreamweaveru, exportujte celý dokument jako soubor SWF. Aplikace Animate soubor SWF exportuje s použitím aktuálního nastavení v souboru FLA na záložce Nastavení publikování.

Export videí HD pomocí aplikace Adobe Media Encoder

Aplikace Animate CC umožňuje export doplňků, symbolů a grafik do videí s vysokým rozlišením různých formátů. Videa HD exportovaná pomocí aplikace Animate lze používat v aplikacích s podporou komunikace, pro konferenční videohovory, streamování a sdílení.

Ve výchozím nastavení dokáže aplikace Animate exportovat pouze do souborů QuickTime Movie (.MOV). Funkce exportu vyžaduje instalaci nejnovější verze přehrávače QuickTime Player, protože aplikace Animate při exportu souborů MOV využívá knihovny QuickTime.

Postup exportu videa byl přepracován, protože aplikace Animate je nyní integrována do programu Adobe Media Encoder. Nové pojetí umožňuje převádět soubory MOV na různé jiné formáty. Program Adobe Media Encoder byl optimalizován, aby uváděl pouze ty formáty exportu, jež jsou relevantní pro obsah Animate. Další informace o kódování a exportu videí pomocí programu Adobe Media Encoder najdete v tématu Kódování a export videa a zvuku.

Poznámka:

Program Adobe Media Encoder se nainstaluje automaticky při instalaci aplikace Animate CC z počítačové aplikace Creative Cloud.

Rozdíl mezi předchozím a nejnovějším pracovním postupem pro export videa

Nový pracovní postup se od postupu exportu videí v aplikaci CS6 a starších verzí liší.

Hlavní rozdíly jsou následující:

  • Integrace s programem Adobe Media Encoder: Aplikace Animate CC byla integrována do programu Adobe Media Encoder 7.0. Starší verze nebyly na programu AME závislé.
  • Formáty exportu: Aplikace Animate CC může exportovat soubory pouze ve formátu videa QuickTime.
  • Videa HD: Aplikace Animate CC umožňuje export videí HD.

Ve verzi CS6 docházelo k následujícím problémům v pracovních postupech:

  • Pracovní postup exportu ve formátu MOV pomocí softwaru QuickTime byl náchylný k chybám a náročný na paměť.
  • Export ve formátu AVI nepodporoval filmové klipy.

Ve verzi Animate CC byly výše uvedené problémy opraveny, včetně problému se ztrátou snímků. Pracovním postupem s použitím programu Adobe Media Encoder tak můžete v aplikaci Animate CC exportovat do souborů MOV zcela bez problémů. Nový pracovní postup programu AME umožňuje obsah Animate exportovat do souborů MOV a ty později v aplikaci AME převést na libovolný požadovaný výstup.

Export začíná snímkem 2.

V závislosti na struktuře časové osy může být exportované video výsledkem kteréhokoli z následujících scénářů:

  1. Pokud je na kořenové časové ose více než jeden snímek, export začne od snímku 2.
  2. Pokud je na kořenové časové ose pouze jediný snímek, bude export zahrnovat také snímek 1.
  3. Pokud je na kořenové časové ose více než jeden snímek a ke snímku 1 je přidán prvek ActionScript nebo zvuk, nebude vyvolán.

Export videa HD

Před exportováním proveďte následující úkon:

  • Instalace aplikace QuickTime
  • Nastavte snímkovou frekvenci na hodnotu rovnou nebo nižší než 60sn./s. Další informace naleznete v části Základní informace o animacích.
  1. Vytvořte nebo otevřete existující soubor FLA.

  2. Přejděte do nabídky Soubor > Export > Exportovat video.

    export-video
    Dialogové okno Exportovat video

  3. V dialogovém okněExportovat video položky Šířka vykreslení a Výška vykreslení představují hodnoty šířky a výšky pro velikost plochy.

  4. V dialogovém okně Exportovat video nastavte požadované možnosti:

    • Velikost vykreslení Výška a Šířka: Nakonfigurujte velikost vykreslení podle rozlišení, ve kterém chcete export provést, podle toho, zda chcete exportovat video v HD kvalitě nebo v normální kvalitě. Nastavte hodnoty odpovídající šířce a výšce vymezené plochy v uvedeném pořadí. Chcete-li hodnoty Šířka vykreslení a Výška vykreslení změnit, upravte podle toho velikost vymezené plochy. Aplikace Animate udržuje poměr stran podle rozměrů vymezené plochy.
    • Ignorovat barvu plochy (generovat kanál alfa): Vytvoří kanál alfa pomocí barvy vymezené plochy. Kanál alfa je zakódován jako průhledná stopa. Umožňuje překrývat obsah exportovaným filmem formátu QuickTime a tím změnit barvu pozadí nebo scénu.
    • Převést video v aplikaci Adobe Media Encoder: Tuto volbu vyberte, chcete-li exportovaný soubor MOV převést pomocí programu AME do jiného formátu. Je-li tato volba vybrána, program AME se spustí, jakmile aplikace Animate dokončí export videa.
    • Zastavit export: Určete, kdy má aplikace Animate export zastavit.
      • Při dosažení posledního snímku: Tuto volbu vyberte, chcete-li export ukončit po posledním snímku.
      • Po uplynutí času: Tuto volbu vyberte a určete dobu, po jejímž uplynutí se export ukončí. Tato volba umožňuje exportovat samostatné části videa.
    • Cesta exportovaného videa: Zadejte nebo vyhledejte umístění, do kterého se má video exportovat.
  5. Klikněte na tlačítko Exportovat. Pokud vyberete volbu Převést video v aplikaci Adobe Media Encoder, program AME se spustí a exportovaný soubor MOV bude dostupný v nové frontě. Další informace o kódování a převodu videí pomocí aplikace AME najdete v tématu Kódování a export videa a zvuku.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online