Příručka uživatele Zrušit

Práce s klasickým textem v Animate

  1. Příručka uživatele aplikace Adobe Animate
  2. Úvod do aplikace Animate
    1. Novinky v aplikaci Animate
    2. Grafický glosář
    3. Systémové požadavky pro aplikaci Animate
    4. Klávesové zkratky aplikace Animate
    5. Práce s různými typy souborů v aplikaci Animate
  3. Animace
    1. Základy animování v aplikaci Animate
    2. Používání snímků a klíčových snímků v aplikaci Animate
    3. Animace po jednotlivých snímcích v aplikaci Animate
    4. Práce s animacemi klasických doplnění v aplikaci Animate
    5. Nástroj Štětec
    6. Vodítko pohybu
    7. Doplnění pohybu a ActionScript 3.0
    8. O animacích s doplněními pohybu
    9. Animace s doplněním pohybu
    10. Vytvoření animace s doplněním pohybu
    11. Používání klíčových snímků vlastností
    12. Animování polohy pomocí doplnění
    13. Úpravy doplnění pohybu v editoru pohybu
    14. Úpravy cesty pohybu u animace s doplněním
    15. Úpravy doplnění pohybu
    16. Přidání vlastního náběhu nebo doběhu
    17. Vytváření a aplikování přednastavení pohybu
    18. Nastavení rozsahu doplnění animace
    19. Práce s doplněními pohybu uloženými jako soubory XML
    20. Srovnání doplnění pohybu a klasických doplnění
    21. Doplňování tvarů
    22. Používání animací nástroje Kost v aplikaci Animate
    23. Sestavování postav v aplikaci Animate
    24. Používání vrstev masek v aplikaci Adobe Animate
    25. Práce se scénami v aplikaci Animate
  4. Interaktivita
    1. Vytváření tlačítek v aplikaci Animate
    2. Převod projektů aplikace Animate na jiné typy dokumentů
    3. Vytváření a publikování dokumentů HTML5 Canvas v aplikaci Animate
    4. Přidání interaktivity pomocí fragmentů kódu v aplikaci Animate
    5. Vytváření vlastních komponent HTML5
    6. Používání komponent v dokumentech HTML5 Canvas
    7. Vytváření vlastních komponent: Příklady
    8. Fragmenty kódu pro vlastní komponenty
    9. Osvědčené postupy – Tvorba reklam v aplikaci Animate
    10. Vytváření a publikování virtuální reality
  5. Pracovní plocha a pracovní postupy
    1. Vytváření a správa malířských štětců
    2. Používání písem Google v dokumentech HTML5 Canvas
    3. Používání knihoven Creative Cloud v aplikaci Adobe Animate
    4. Používání vymezené plochy a panelu nástrojů v aplikaci Animate
    5. Pracovní postupy a pracovní plocha aplikace Animate
    6. Používání webových písem v dokumentech HTML5 Canvas
    7. Časové osy a ActionScript
    8. Práce s více časovými osami
    9. Nastavení předvoleb
    10. Používání vývojových panelů aplikace Animate
    11. Vytváření vrstev časové osy v aplikaci Animate
    12. Export animací pro mobilní aplikace a herní moduly
    13. Přemísťování a kopírování objektů
    14. Předlohy
    15. Příkaz Hledat a nahradit v aplikaci Animate
    16. Vrácení akce, její zopakování a panel Historie
    17. Klávesové zkratky
    18. Používání časové osy v aplikaci Animate
    19. Vytvoření rozšíření HTML
    20. Možnosti optimalizace obrázků a animovaných souborů GIF
    21. Export nastavení pro obrázky a soubory GIF
    22. Panel Datové zdroje v aplikaci Animate
  6. Multimédia a video
    1. Transformace a kombinování grafických objektů v aplikaci Animate
    2. Vytváření a práce s instancemi symbolů v aplikaci Animate
    3. Vektorizace obrazu
    4. Používání zvuku v aplikaci Adobe Animate
    5. Export souborů SVG
    6. Vytváření souborů videa používaných v aplikaci Animate
    7. Přidání videa v aplikaci Animate
    8. Práce se startovacími body videa
    9. Kreslení a vytváření objektů v aplikaci Animate
    10. Změna čar a tvarů
    11. Tahy, výplně a přechody v aplikaci Animate
    12. Práce s aplikacemi Adobe Premiere Pro a After Effects
    13. Panely barev v aplikaci Animate
    14. Otevírání souborů aplikace Flash CS6 v aplikaci Animate
    15. Práce s klasickým textem v aplikaci Animate
    16. Vložení grafiky do aplikace Animate
    17. Importované bitmapy v aplikaci Animate
    18. 3D grafika
    19. Práce se symboly v aplikaci Animate
    20. Kreslení čar a tvarů v aplikaci Adobe Animate
    21. Práce s knihovnami v aplikaci Animate
    22. Export zvuků
    23. Výběr objektů v aplikaci Animate
    24. Práce se soubory aplikace Illustrator (AI) v aplikaci Animate
    25. Nanášení vzorů pomocí nástroje Stopa spreje
    26. Používání režimů prolnutí
    27. Uspořádání objektů
    28. Automatizace úloh pomocí nabídky Příkazy
    29. Vícejazyčný text
    30. Používání kamery v aplikaci Animate
    31. Používání aplikace Animate s nástrojem Adobe Scout
    32. Práce se soubory aplikace Fireworks
    33. Grafické filtry
    34. Zvuk a ActionScript
    35. Předvolby kreslení
    36. Kreslení nástrojem Pero
  7. Platformy
    1. Převod projektů aplikace Animate na jiné typy dokumentů
    2. Podpora vlastní platformy
    3. Vytváření a publikování dokumentů HTML5 Canvas v aplikaci Animate
    4. Vytvoření a publikování dokumentu ve formátu WebGL
    5. Balení aplikací pro prostředí AIR for iOS
    6. Publikování aplikací prostředí AIR for Android
    7. Publikování pro prostředí Adobe AIR pro počítače
    8. Nastavení publikování jazyka ActionScript
    9. Osvědčené postupy – Uspořádání ActionScriptu v aplikaci
    10. Používání jazyka ActionScript v aplikaci Animate
    11. Osvědčené postupy – Pravidla usnadnění přístupu
    12. Usnadnění přístupu v pracovním prostoru aplikace Animate
    13. Psaní a správa skriptů
    14. Povolení podpory vlastních platforem
    15. Přehled podpory vlastních platforem
    16. Vytváření přístupného obsahu
    17. Práce se zásuvným modulem pro podporu vlastní platformy
    18. Ladění jazyka ActionScript 3.0
    19. Povolení podpory vlastních platforem
  8. Export a publikování
    1. Export souborů z aplikace Animate
    2. Publikování OAM
    3. Export souborů SVG
    4. Export grafiky a videa v aplikaci Animate
    5. Publikování dokumentů AS3
    6. Export animací pro mobilní aplikace a herní moduly
    7. Export zvuků
    8. Export videosouborů QuickTime
    9. Ovládání externího přehrávání videa s použitím jazyka ActionScript
    10. Osvědčené postupy – Tipy pro vytváření obsahu pro mobilní zařízení
    11. Osvědčené postupy – Konvence videa
    12. Osvědčené postupy – Pravidla pro vývoj aplikací SWF
    13. Osvědčené postupy – Strukturování souborů FLA
    14. Osvědčené postupy pro optimalizaci souborů FLA pro Animate
    15. Nastavení publikování jazyka ActionScript
    16. Nastavení publikování v aplikaci Animate
    17. Export souborů projektoru
    18. Export obrázků a animovaných souborů GIF
    19. Předlohy publikování HTML
    20. Práce s aplikacemi Adobe Premiere Pro a After Effects
    21. Rychlé sdílení a publikování animací

O klasickém textu

Jako klasický text je v aplikaci Animate označován starší textový modul. Modul klasického textu je k dispozici i v aplikaci CS5 a novějších. Klasický text může být vhodnější pro určité typy obsahu, například pro mobilní zařízení, kde je nutné, aby velikost souboru SWF byla co nejmenší. V některých případech, například při požadavku na přesnou kontrolu rozvržení textu, je však lepší použít nový text TLF. Informace o textu TLF viz Práce s textem TLF (Text Layout Framework).

Pokud u jednotlivého textového objektu na ploše chcete určit, zda má používat klasický textový modul nebo textový modul TLF, vyberte tento textový objekt a poté v inspektoru vlastností textu vyberte požadovaný textový modul.

 Textový modul používaný textovým objektem můžete kdykoli změnit. Další informace o převodu klasického textu na text TLF najdete v části Převod mezi klasickým textem a textem TLF.

Klasický text můžete do aplikací vytvořených v aplikaci Animate zahrnout řadou různých způsobů. Můžete vytvořit textová pole obsahující statický text, který vytváříte při sestavování dokumentu. Můžete také vytvořit dynamická textová pole, která zobrazují aktualizující se text, například ceny akcií nebo novinové titulky, a vstupní textová pole, která umožňují uživatelům zadávat text pro formuláře nebo průzkumy.

Animate umožňuje mnoho způsobů práce s textem. Například můžete text orientovat vodorovně nebo svisle; nastavovat atributy jako písmo, velikost, styl, barvu a řádkování; kontrolovat pravopis; transformovat text otočením, zkosením nebo převrácením; vytvářet odkazy na text; změnit text na vybratelný; animovat text; ovládat nahrazování písem a používat písmo jako součást sdílené knihovny. Dokumenty Animate mohou používat pouze písma typu 1 PostScript®, TrueType® a rastrová písma (pouze Mac).

V textových polích můžete zachovávat bohaté formátování textu s použitím tagů a atributů HTML. Pokud použijete text HTML pro obsah dynamického nebo vstupního textového pole, text může obtékat obraz, například soubor SWF nebo JPEG nebo filmový klip. Další informace najdete v části o používání textu ve formátu HTML v dokumentu Učíme se jazyk ActionScript 2.0.

Podobně jako instance filmových klipů jsou také instance textových polí objekty jazyka ActionScript®, které mají vlastnosti a metody. Jakmile přidělíte textovému poli název instance, můžete s ním pracovat pomocí jazyka ActionScript. Nemůžete ale psát kód ActionScriptu uvnitř instance textu, protože instance textu nemají časové osy.

Můžete používat ActionScript k formátování vstupního a dynamického textu a k vytváření rolovacích textových polí. ActionScript obsahuje události pro dynamická a vstupní textová pole, jež můžete zachycovat a používat ke spouštění skriptů. Další informace o používání jazyka ActionScript k ovládání textu naleznete v části o práci s textem a řetězci v dokumentu Učíme se jazyk ActionScript 2.0.

O klasických textových polích

Můžete vytvářet tři typy klasických textových polí: statická, dynamická a vstupní.

  • Statická textová pole zobrazují text, který nemění znaky dynamicky.

  • Dynamická textová pole zobrazují dynamicky aktualizovaný text, například ceny akcií nebo předpověď počasí.

  • Vstupní textová pole umožňují uživatelům zadávat text ve formulářích nebo průzkumech.

    Můžete vytvářet vodorovný text (s natékáním zleva doprava) nebo statický svislý text (s natékáním buď zprava doleva, nebo zleva doprava). Upozorňujeme, že jazyky s vodorovným obousměrným natékáním textu (hebrejština, arabština apod.) nejsou v klasických textových polích podporovány.

    Při vytváření statického textu můžete umístit text na jediný řádek, který se při psaní zvětšuje, nebo do pole s pevnou šířkou (u vodorovného textu) nebo s pevnou výškou (u svislého textu), které se automaticky zvětšuje a zalamuje text po slovech. Při vytváření dynamického nebo vstupního textu můžete umístit text na jediný řádek nebo vytvořit textové pole s pevnou šířkou a výškou.

     Při práci se statickým svislým textem je pole šířky v Inspektoru vlastností zakázáno. Změnou výšky se automaticky upraví také hodnota šířky. Podobně je také při práci se statickým vodorovným textem pole výšky v Inspektoru vlastností zakázáno. Změnou šířky se automaticky upraví také hodnota výšky.

     

    Všechna klasická textová pole podporují kódování Unicode.

    Animate zobrazuje v rohu každého textového pole táhlo, které odlišuje typ textového pole:

  • U statického vodorovného textu, který se rozšiřuje, se v pravém horním rohu textového pole zobrazuje kruhové táhlo.

  • U statického vodorovného textu, který má pevnou šířku, se v pravém horním rohu textového pole zobrazuje čtvercové táhlo.

  • U statického svislého textu, který má natékání zprava doleva a zvětšuje se, se v levém dolním rohu textového pole zobrazuje kruhové táhlo.

  • U statického svislého textu, který má natékání zprava doleva a pevnou výšku, se v levém dolním rohu textového pole zobrazuje čtvercové táhlo.

  • U statického svislého textu, který má natékání zleva doprava a zvětšuje se, se v pravém dolním rohu textového pole zobrazuje kruhové táhlo.

  • U statického svislého textu, který má natékání zleva doprava a pevnou výšku, se v pravém dolním rohu textového pole zobrazuje čtvercové táhlo.

  • U dynamických nebo vstupních textových polí, která se zvětšují, se v pravém dolním rohu textového pole zobrazuje kruhové táhlo.

  • U dynamického nebo vstupního textu, který má definovanou výšku a šířku, se v pravém dolním rohu textového pole zobrazuje čtvercové táhlo.

  • U dynamických rolovacích textových polí obsahujících klasický text se kruhové nebo čtvercové táhlo změní z prázdného na plný černý tvar.

    Chcete-li na ploše vytvořit textová pole, která se při zadávání textu nezvětšují, se stisknutou klávesou Shift dvakrát klikněte na táhlo dynamického nebo vstupního textového pole. To vám umožní vytvořit textové pole o pevné velikosti a vyplnit je větším množstvím textu, než může zobrazit, díky použití rolujícího textu.

    Po vytvoření textového pole textovým nástrojem použijte inspektor Vlastnosti k určení typu textového pole a k nastavení hodnot, které určují způsob zobrazení textového pole a jeho obsahu v souboru SWF.

Vytváření a úpravy textových polí

Text je ve výchozím nastavení vodorovný, statický text se ale může zarovnávat také svisle.

Při úpravách textu v Animate můžete používat většinu obvyklých postupů z textových editorů. Příkazy Vyjmout, Kopírovat a Vložit můžete používat k přesunutí textu uvnitř dokumentu Animate i mezi Animate a jinými aplikacemi.

Přidání textu na plochu

  1. Vyberte textový nástroj .
  2. V nabídce Textový modul v horní části Inspektoru vlastností textu vyberte možnost Klasický text.
  3. V Inspektoru vlastností (Okno > Vlastnosti) určete typ textového pole výběrem typu textu z rozbalovací nabídky:

    Dynamický text

    Vytvoří pole, které zobrazuje dynamicky aktualizovaný text.

    Vstupní text

    Vytvoří pole, ve kterém mohou uživatelé zadávat text.

    Statický text

    Vytvoří pole, které se nemůže aktualizovat dynamicky.

  4. Pouze u statického textu: V Inspektoru vlastností textu vyberte z nabídky Orientace textu směr orientace textu a tok. (výchozí nastavení je vodorovně).
  5. Na ploše proveďte jeden z následujících úkonů:
    • Chcete-li vytvořit textové pole, které zobrazuje text v jediném řádku, klikněte na místo, kde chcete začít psát text.

    • Chcete-li vytvořit textové pole s pevnou šířkou (u vodorovného textu) nebo pevnou výškou (u svislého textu), umístěte ukazatel na místo, kde chcete začít psát text, a přetáhněte do požadované šířky nebo výšky.

     Pokud vytvoříte textové pole, které se při psaní zvětšuje mimo okraje plochy, text se neztratí. Chcete-li znovu zpřístupnit táhlo, vložte zalomení řádků, přemístěte textové pole nebo vyberte Zobrazení > Pracovní plocha.

  6. V inspektoru Vlastnosti vyberte atributy textu.

Změna velikosti textového pole

  1. Přetáhněte táhlo pro změnu velikosti textového pole.

    Modrý ohraničovací rámeček u vybraného textu umožňuje změnit velikost textového pole přetažením jednoho z jeho táhel. Statická textová pole mají čtyři táhla, která umožňují změnit velikost textového pole ve vodorovném směru. Dynamická textová pole mají osm táhel, která umožňují změnit velikost textového pole ve svislém nebo vodorovném směru nebo úhlopříčně.

Přepínání textového pole mezi pevnou šířkou (nebo pevnou výškou) a zvětšováním

  1. Dvakrát klikněte na táhlo pro změnu velikosti.

Vybírání znaků v textovém poli

  1. Vyberte textový nástroj .
  2. Proveďte jeden z následujících úkonů:
    • Tažením vyberte znaky.

    • Poklepáním vyberte slovo.

    • Kliknutím označte začátek výběru a kliknutím se stisknutou klávesou Shift označte konec výběru.

    • Stisknutím kláves Ctrl+A (Windows) nebo Command+A (Macintosh) vyberte všechen text v poli.

Výběr textových polí

  1. Nástrojem pro výběr klikněte na textové pole. Kliknutím se stisknutou klávesou Shift vyberte více textových polí.

Nastavení voleb dynamického a vstupního textu

  1. Klikněte na existující dynamické textové pole.
  2. V Inspektoru vlastností zkontrolujte, jestli se v rozbalovací nabídce zobrazuje Dynamické nebo Vstupní.
  3. Zadejte název instance pro textové pole.
  4. Určete výšku, šířku a umístění textu.
  5. Vyberte písmo a styl.
  6. V části Odstavec v Inspektoru vlastností zadejte jednu z následujících možnosti v nabídce Chování:

    Jeden řádek

    Zobrazí text jako jeden řádek.

    Víceřádkový

    Zobrazí text ve více řádcích.

    Víceřádkový bez zalamování

    Zobrazí text ve více řádcích, které se zalamují pouze tehdy, pokud je posledním znakem zalomení, například Enter (Windows) nebo Return (Mac).

  7. Chcete-li povolit, aby uživatelé mohli vybírat dynamický text, klepněte na Lze vybrat . Pokud chcete uživatelům zabránit ve výběru dynamického textu, zrušte označení této volby.
  8. Chcete-li zachovat bohaté formátování textu (například písma a hypertextové odkazy) s příslušnými tagy HTML, klikněte na Interpretovat text jako HTML .
  9. Chcete-li u textového pole zobrazit černý okraj a bílé pozadí, klikněte na Zobrazit okraje kolem textu .
  10. (Volitelně) V poli Prom. zadejte název proměnné pro textové pole (tato volba se používá pouze při vytváření dokumentů pro Macromedia Flash Player 5 nebo starší od Adobe).

    Počínaje programem Macromedia Flash MX (verze 6) se textovému poli přiřazuje název instance s použitím Inspektoru vlastností. Ačkoli můžete použít metodu názvu proměnné u dynamických textových polí pro zpětnou kompatibilitu s Macromedia Flash 5 a staršími verzemi, Adobe to nedoporučuje, protože nemůžete řídit další vlastnosti textového pole ani aplikovat nastavení kaskádových stylů.

  11. (Volitelné) Kliknutím na možnost Vložit zobrazte dialogové okno Vkládání písem. Další informace najdete v části Vkládání písem k zajištění konzistentního vzhledu textu.

Nastavení předvoleb pro svislý text

  1. Vyberte Úpravy > Předvolby (Windows) nebo Animate > Předvolby (Mac) a v dialogovém okně Předvolby klikněte na kategorii Text.

  2. V části Svislý text nastavte libovolné z těchto voleb:

    Výchozí orientace textu

    Automaticky nastaví u nových textových polí svislou orientaci.

    Natékání textu zprava doleva

    Určuje, že se má stránka vyplnit řádky svislého textu zprava doleva.

    Bez vyrovnání párů

    Zabrání aplikování vyrovnání párů na svislý text (vyrovnání párů zůstane povolené pro vodorovný text).

Nastavení atributů klasického textu

O atributech klasického textu

 Chcete-li použít kaskádové styly (CSS), aplikujte styl pomocí jazyka ActionScript. Další informace najdete v tématu Použití šablony stylů CSS v Příručce pro vývojáře jazyka ActionScript 3.0.

Můžete nastavit písmo a atributy odstavce textu. Mezi atributy písma patří rodina písma, velikost v bodech, styl, barva, mezery mezi znaky, automatické vyrovnání párů a poloha znaku. Mezi atributy odstavce patří zarovnání, okraje, odsazení a řádkování.

U statického textu se obrysy písma exportují v publikovaném souboru SWF. U vodorovného statického textu můžete místo exportu obrysů písma použít písma zařízení.

U dynamického nebo vstupního textu ukládá Animate názvy písem a Flash Player pak v systému uživatele vyhledá totožná nebo podobná písma. Do dynamických nebo vstupních textových polí je také možné vkládat obrysy písma. Vkládání obrysů písma může zvětšit velikost souboru, ale zaručuje, že uživatelé budou mít správné informace písma.

Animate používá při tvorbě nového textu atributy textu, které jsou aktuálně nastavené v inspektoru Vlastnosti. Když vyberete existující text, pomocí Inspektoru vlastností můžete změnit písmo nebo atributy odstavce a dát pokyn, aby Animate místo vložení informací obrysu písma použilo písma ze zařízení.

Nastavení písma, velikosti v bodech, stylu a barvy

  1. Nástrojem pro výběr vyberte jedno nebo více textových polí na ploše.
  2. V Inspektoru vlastností (Okno > Vlastnosti) vyberte písmo z rozbalovací nabídky Písmo nebo zadejte název písma.

     Písma _sans, _serif, _typewriter a písma zařízení lze použít pouze pro statický vodorovný text.

  3. Zadejte hodnotu velikosti písma.

    Velikost písma se nastavuje v bodech, bez ohledu na aktuální jednotky pravítka.

  4. Chcete-li použít tučný styl nebo styl kurzíva, vyberte tento styl z nabídky Styl.

    Pokud vybrané písmo tučný styl nebo styl kurzíva nezahrnuje, nezobrazí se tento styl ani v nabídce. Z nabídky Text můžete vybrat styly Umělé tučné nebo Umělá kurzíva (Text > Styl > Umělé tučné nebo Umělá kurzíva). Operační systém přidá styly Umělé tučné a Umělá kurzíva do standardního stylu. Může se stát, že umělé styly nebudou vypadat stejně dobře, jako písma, která zahrnuje skutečný tučný styl nebo styl kurzíva.

  5. Chcete-li optimalizovat text, vyberte metodu vykreslení písma z rozbalovací nabídky Vyhlazení (přímo pod ovladačem Barva).
  6. Chcete-li vybrat barvu výplně pro text, klikněte na ovladač barev a proveďte jeden z následujících úkonů:
    • Vyberte barvu z nabídky Barva.

    • Do pole v levém horním rohu zadejte hexadecimální hodnotu barvy.

    • Klikněte na Výběr barvy a vyberte barvu ze systémového výběru barvy. (Při nastavování barvy textu používejte pouze plné barvy, ne přechody. Chcete-li aplikovat na text přechod, text rozdělte a převeďte na jeho složkové čáry a výplně.)

Nastavení mezer mezi znaky, vyrovnání párů a polohy znaků

Funkce Mezery mezi znaky vkládá mezi znaky volné místo jednotné velikosti. Mezery mezi znaky se používají k nastavení mezer u vybraných znaků nebo celých bloků textu.

Vyrovnání párů určuje velikost mezery mezi dvojicemi znaků. Mnoho písem má vestavěné informace vyrovnání párů. Například, A a V jsou k sobě často blíž než A a D. Animate poskytuje vodorovné prostrkání a vyrovnání párů (pro vodorovný text) a svislé prostrkání a vyrovnání párů (pro svislý text).

U svislého textu můžete automatické vyrovnávání párů vypnout v předvolbách Animate. Pokud to uděláte a necháte volbu vyrovnání párů v inspektoru Vlastnosti vybranou, vyrovnání párů se pak bude používat pouze na vodorovný text.

  1. Textovým nástrojem vyberte na ploše jednu nebo více vět, slovních spojení nebo textových polí.
  2. V Inspektoru vlastností (Okno > Vlastnosti) nastavte následující volby:
    • Chcete-li určit mezery mezi znaky (sledování a vyrovnávání), zadejte hodnotu do pole Mezery mezi znaky.

    • Chcete-li použít informace vyrovnání párů vestavěné v písmu, vyberte Automatické vyrovnání párů.

    • Chcete-li nastavit polohu znaku na horní nebo dolní index, klikněte na tlačítko Přepnout na horní index nebo Přepnout na dolní index. Výchozí polohu představuje možnost Normální. Normální umísťuje text na účaří, Horní index umísťuje text nad účaří (vodorovný text) nebo vpravo do účaří (svislý text) a Dolní index umísťuje text pod účaří (vodorovný text) nebo vlevo od účaří (svislý text).

Nastavení zarovnání, okrajů, odsazení a řádkování

Zarovnání určuje polohu každého řádku textu v odstavci vzhledem k okrajům textového pole. Vodorovný text se zarovnává vzhledem k levému a pravému okraji textového pole a svislý text se zarovnává vzhledem k hornímu a dolnímu okraji textového pole. Text lze zarovnat k jednomu okraji textového pole, na střed textového pole nebo k oběma okrajům textového pole (zarovnání do bloku).

Okraje určují velikost mezery mezi hranicí textového pole a jeho textem. Odsazení určuje vzdálenost mezi okrajem odstavce a začátkem prvního řádku.

Řádkování určuje vzdálenost mezi po sobě jdoucími řádky v odstavci. U svislého textu řádkování nastavuje mezeru mezi svislými sloupci.

Práce s vodorovným textem

  1. Textovým nástrojem vyberte na ploše jedno nebo více textových polí.
  2. V Inspektoru vlastností (Okno > Vlastnosti) nastavte následující volby:
    • Pokud chcete nastavit zarovnání, klikněte na zarovnání vlevo, na střed, vpravo nebo do bloku.

    • Chcete-li nastavit levý nebo pravý okraj, zadejte hodnoty do textových polí Okraje v části Odstavec v Inspektoru vlastností.

    • Chcete-li specifikovat odsazení, zadejte hodnotu do textového pole Odsazení v části Odstavec v Inspektoru vlastností.

    • Chcete-li specifikovat řádkování, zadejte hodnotu do textového pole Řádkování v části Odstavec v Inspektoru vlastností.

Práce se svislým textem

  1. Textovým nástrojem vyberte na ploše jedno nebo více textových polí.
  2. V Inspektoru vlastností (Okno > Vlastnosti) nastavte následující volby:
    • Pokud chcete nastavit zarovnání, klikněte na zarovnání nahoru, na střed, dolů nebo do bloku.

    • Chcete-li nastavit horní nebo dolní okraj, zadejte hodnoty do textových polí Okraje v části Odstavec v Inspektoru vlastností.

    • Chcete-li specifikovat odsazení, zadejte hodnotu do textového pole Odsazení v části Odstavec v Inspektoru vlastností.

    • Chcete-li specifikovat řádkování, zadejte hodnotu do textového pole Řádkování v části Odstavec v Inspektoru vlastností.

Vyhlazení klasického textu

Vyhlazení umožňuje vyrovnat okraje textu na obrazovce. Volby vyhlazení jsou účinné zejména pro vykreslování menších velikostí písma. Je-li vyhlazení zapnuté, ovlivní veškerý text v aktuálním výběru. Vyhlazení funguje stejným způsobem u textu všech bodových velikostí.

Vyhlazení je podporováno u statického, dynamického i vstupního textu, pokud má uživatel Flash® Player 7 nebo novější. Pokud má uživatel starší verzi aplikace Flash Player, je podporováno pouze u statického textu.

Pokud v dokumentu Animate používáte malý text, nezapomínejte na následující pravidla:

  • U malých velikostí se zobrazuje zřetelněji text v bezpatkovém písmu, například Helvetica nebo Arial, než v písmu patkovém.

  • Některé styly textu, například tučné písmo a kurzíva, mohou snížit čitelnost textu u malých velikostí.

  • V určitých případech se text zobrazuje o něco menší než text o stejné bodové velikosti v jiných aplikacích.

Modul vykreslování textu v aplikaci Animate zajišťuje hladké, velmi kvalitní vykreslování textu v dokumentech Animate (FLA) i publikovaných souborech SWF. Nastavení Vyhladit pro čitelnost změní text na čitelnější, zejména u malých velikostí písma. Vlastní vyhlazení umožňuje určit tloušťku a ostrost písem používaných v jednotlivých textových polích.

Velmi kvalitní vyhlazení se automaticky zapíná, kdykoli publikujete do přehrávače Flash Player 8 nebo novějšího a je vybraná volba Vyhladit pro čitelnost nebo Vlastní vyhlazení. Volba Vyhladit pro čitelnost může způsobit mírnou prodlevu při načítání souborů SWF aplikace Animate, zejména pokud v prvním snímku dokumentu Animate používáte čtyři nebo pět různých znakových sad. Velmi kvalitní vyhlazení může také zvýšit velikost paměti využívané přehrávačem Flash Player. Například použití čtyř nebo pěti písem může zvýšit využití paměti přibližně o 4 MB.

Pokud máte u souboru nastavené publikování pro Adobe® Flash® Player 8 nebo novější a jako volbu vyhlazení máte nastaveno Vyhladit pro čitelnost nebo Vlastní vyhlazení, bude se kvalitní vyhlazení používat u následujících položek:

  • Netransformovaný text, který má změněnou velikost nebo je otočený

     Přestože je možné měnit měřítko textu a otáčet ho, musí zůstat rovný (to znamená netransformovaný). Pokud například písma zkosíte nebo jinak upravíte tvary písma, volba Vyhladit pro čitelnost se automaticky vypne.

  • Všechny rodiny písem (včetně tučného textu, kurzívy a tak dále)

  • Velikosti zobrazení až do 255 bodů

  • Export do většiny formátů, které nepatří k aplikaci Animate (např. GIF nebo JPEG)

Velmi kvalitní vyhlazení je zakázané za následujících podmínek:

  • Vybraná verze přehrávače Flash Player je Flash Player 7 nebo starší.

  • Je vybraná jiná volba vyhlazení než Vyhladit pro čitelnost nebo Vlastní vyhlazení.

  • Text je zkosený nebo převrácený.

  • Soubor FLA je exportovaný do souboru PNG.

Práce s vyhlazením textu

Animate zajišťuje vylepšené rastrování písem, díky kterému si u písem můžete nastavit vlastnosti vyhlazování. Vylepšené možnosti vyhlazení jsou dostupné pouze pro soubory SWF publikované pro Flash Player 8 nebo novější. Pokud publikujete soubory pro starší verze Flash Playeru, můžete použít pouze funkci Vyhladit pro animaci.

 Vyhlazení vyžaduje, aby písma používaná textovým polem byla vložena. Pokud písma nevložíte, může se textové pole pro klasický text zobrazovat prázdné. Pokud změna nastavení vyhlazení na možnost Použít písma zařízení způsobí, že text je zobrazen nesprávně, je třeba vložit písma. Animate automaticky vloží písma textu, který už existuje v textovém poli vytvořeném na ploše. Chcete-li však povolit změny textu za běhu, měli byste písma vložit ručně. Pokyny naleznete v části Vkládání písem k zajištění konzistentního vzhledu textu.

Výběr volby vyhlazení pro vybraný text

  1. V Inspektoru vlastností zvolte z rozbalovací nabídky Vyhlazení jednu z následujících voleb:

    Použít písma zařízení

    Určuje, že soubor SWF má k zobrazení písem použít písma instalovaná v místním počítači. Písma zařízení jsou obvykle čitelná při většině velikostí písem. Tato volba nezvětšuje velikost souboru SWF, při jejím použití se ale musíte spoléhat na zobrazení písma s použitím písem instalovaných v počítači uživatele. Při použití písem zařízení vybírejte pouze obvykle instalované rodiny písem.

    Písma zařízení nelze používat u otočeného nebo svislého klasického textu. Chcete-li použít otočený nebo svislý klasický text, vyberte jiný režim vyhlazení a vložte písma používaná textovým polem.

    Bitmapový text (žádné vyhlazení)

    Vypne vyhlazení a neposkytuje žádné vyhlazení textu. Text se zobrazuje s ostrými okraji a velikost výsledného souboru SWF se zvětší, protože se do souboru vkládají obrysy písma. Bitmapový text je v exportované velikosti ostrý, ale špatně se zvětšuje.

    Vyhladit pro animaci

    Vytvoří hladší animaci, protože ignoruje informace zarovnání a vyrovnání párů. Tato volba vytvoří větší soubor SWF, protože se vkládají obrysy písma. Pokud tuto možnost zadáte, použijte kvůli lepší čitelnosti text o velikosti alespoň 10 bodů.

    Vyhladit pro čitelnost

    Použije modul aplikace Animate pro vykreslování textu, který zlepšuje čitelnost písma, zejména při malých velikostech. Tato volba vytvoří větší soubor SWF, protože se vkládají obrysy písma. Pokud chcete použít tuto volbu, musíte publikovat pro Flash Player 8 nebo novější (nepoužívejte tuto volbu, pokud máte v úmyslu animovat text; namísto toho použijte Vyhladit pro animaci).

    Vlastní vyhlazení

    Umožňuje upravit vlastnosti písma. Volbu Ostrost můžete použít k určení hladkosti přechodu mezi okraji textu a pozadím. Volbu Tloušťka můžete použít, chcete-li určit, jak široký se má zobrazovat přechod vyhlazení písma (větší hodnoty způsobí, že znaky budou vypadat tlustší). Při použití volby Vlastní vyhlazení vznikne větší soubor SWF, protože se vkládají obrysy písma. Pokud chcete použít tuto volbu, musíte publikovat pro Flash Player 8 nebo novější.

Aktualizace obsahu pro vyhlazení Flash 8 nebo novější

  1. Otevřete soubor FLA vytvořený pro použití s Flash Playerem 7 nebo starším.
  2. V dialogovém okně Nastavení publikování (Soubor > Nastavení publikování) vyberte z rozbalovací nabídky Verze volbu Flash Player 8 nebo Flash Player 9.
  3. Vyberte textové pole, na které chcete aplikovat volbu Vyhladit pro čitelnost nebo Vlastní vyhlazení.
  4. V Inspektoru vlastností vyberte z rozbalovací nabídky Metoda vykreslení písma volbu Vyhladit pro čitelnost nebo Vlastní vyhlazení.

Změna klasického textu na vybratelný

U statického vodorovného textu nebo dynamického textu můžete nastavit, aby ho uživatelé používající vaši aplikaci Animate mohli vybírat. (Vstupní text se dá vybírat už ve výchozím nastavení). Jakmile uživatel vybere text, může ho kopírovat, vyjmout a pak vložit do samostatného dokumentu.

  1. Textovým nástrojem vyberte vodorovný text, který chcete změnit na vybratelný.
  2. V Inspektoru vlastností (Okno > Vlastnosti) vyberte Statický text nebo Dynamický text.
  3. Klikněte na Lze vybrat .

Transformace textu

Transformací textových polí můžete vytvářet textové efekty. Například můžete otáčet, zkosit a převracet textová pole a měnit jejich velikost. (Když měníte velikost textového pole jako objektu, v Inspektoru vlastností se neprojevuje zvětšení nebo zmenšení bodové velikosti.) Text v transformovaném textovém poli je dále možné upravovat, podstatné transformace ale mohou zhoršit jeho čitelnost.

Text také můžete animovat s použitím efektů časové osy. Například můžete nechat text odskakovat, objevovat se, mizet nebo explodovat.

Rozdělení klasického textu

Klasický text můžete rozdělit a umístit každý znak do samostatného textového pole. Pak můžete rychle rozmístit textová pole do samostatných vrstev a každé pole animovat. Není však možné rozdělit klasický text v rolovacích textových polích.

Text můžete také převést na složkové čáry a výplně a následně měnit jeho tvar, mazat ho a jinak s ním manipulovat stejně jako s grafikou. Stejně jako u libovolného jiného tvaru můžete tyto převedené znaky jednotlivě seskupovat nebo je měnit na symboly a animovat je. Po převedení textu na čáry a výplně jej již nelze upravovat.

 U klasického textu se příkaz Rozdělit vztahuje pouze na obrysová písma (například na písma TrueType). Když rozdělíte bitmapová písma, zmizí z obrazovky. Písma PostScript lze rozdělit pouze na Macu.

  1. Nástrojem pro výběr klikněte na textové pole.
  2. Zvolte Změnit > Rozdělit.

    Každý znak ve vybraném textu se umístí do samostatného textového pole. Text zůstává na ploše ve stejné poloze.

  3. Pokud chcete znaky na ploše převést na tvary, vyberte znovu Změnit > Rozdělit.

Vytvoření hypertextového odkazu v textu

  1. Vyberte text nebo textové pole:
    • Textovým nástrojem vyberte text v textovém poli.

    • Pokud chcete propojit veškerý text v textovém poli, nástrojem pro výběr vyberte textové pole.

  2. V textovém poli Odkaz v Inspektoru vlastností (Okno > Vlastnosti) zadejte adresu URL místa, se kterým chcete textového pole propojit.

 Chcete-li vytvořit odkaz na e-mailovou adresu, použijte mailto:URL. Například zadejte mailto:adamdvorak@priklad.com.

Vytvoření rolovacího klasického textu

Rolovací text lze v aplikaci Animate vytvořit několika způsoby:

  • Převeďte dynamická nebo vstupní textová pole na rolovací pomocí příkazů nabídky nebo táhla textového pole. Tímto způsobem se do textového pole nepřidá posuvník, ale uživatel bude moci posouvat text pomocí šipek (u textových polí nastavených jako vybratelných) a kolečka myši. Uživatel musí do textového pole nejprve kliknout, aby se aktivovalo.

  • Přidáním komponenty ActionScript 3.0 UIScrollbar změňte textové pole na rolovací.

  • V jazyce ActionScript 3.0 použijte vlastnosti scrollH a scrollV třídy TextField.

  • Přidáním komponenty ActionScript 2.0 ScrollBar změňte textové pole na rolovací. Další informace najdete v tématu o komponentě UIScrollBar v referenční příručce jazyka ActionScript 2.0 a jeho komponent.

  • V jazyce ActionScript 2.0 použijte k ovládání svislého rolování vlastnosti objektu TextField scroll a maxscroll, zatímco k ovládání vodorovného rolování použijte hscroll a maxhscroll. Další informace najdete v příkladu vytváření posouvajícího se textu v dokumentu Učíme se jazyk ActionScript 2.0.

 

Převedení dynamického textu na rolovací

  1. Proveďte jeden z následujících úkonů:
    • Se stisknutou klávesou Shift dvakrát klikněte na táhlo v pravé dolní části dynamického textového pole. Táhlo se změní z prázdného čtverečku (nerolovací) na vyplněný čtvereček (rolovací).

    • S použitím nástroje pro výběr vyberte dynamické textové pole a pak zvolte Text > Rolovací.

    • Nástrojem pro výběr vyberte dynamické textové pole. Klikněte pravým tlačítkem (Windows) nebo s klávesou Ctrl (Macintosh) do pole dynamického textu a z kontextové nabídky vyberte Rolovací.

Maskování textu s písmem zařízení

Můžete použít filmový klip k maskování textu s písmem zařízení v jiném filmovém klipu (nelze maskovat písma zařízení s použitím vrstvy masky na ploše). Pokud má toto maskování filmového klipu fungovat, musí mít uživatel přehrávač Flash Player 6 (6.0.40.0) nebo novější.

Pokud k maskování textu s písmem ze zařízení použijete filmový klip, Animate použije jako maskovací tvar obdélníkový ohraničovací rámeček masky. To znamená, že pokud ve vývojovém prostředí Animate vytvoříte pro text s písmem zařízení masku pomocí filmového klipu, který má jiný než obdélníkový tvar, pak maska, která se zobrazí v souboru SWF, převezme tvar obdélníkového ohraničovacího rámečku masky, nikoli tvar samotné masky.

Další informace o používání filmových klipů jako masek najdete v části Používání filmových klipů jako masek v dokumentu Učíme se jazyk ActionScript 2.0.

Ukázku maskování písma zařízení naleznete na webové stránce ukázek Animate na www.adobe.com/go/learn_fl_samples_cz. Chcete-li zobrazit určitou ukázku, stáhněte a dekomprimujte soubor zip ukázek a přejděte do složky Masking\DeviceFontMasking.

Kódování textu Unicode v aplikacích SWF

Aplikace Flash Player 7 a novější podporuje kódování textu Unicode pro soubory SWF ve formátu Flash Player. Tato podpora značně zlepšuje možnosti používat vícejazyčný text ve vašich souborech SWF, například dva jazyky uvnitř jediného textového pole. Libovolný uživatel s Flash Playerem 7 nebo novějším může prohlížet vícejazyčný text v aplikaci Flash Playeru 7 nebo novějšího bez ohledu na jazyk používaný operačním systémem, ve kterém je přehrávač spuštěný.

Logo Adobe

Přihlaste se ke svému účtu.

[Feedback V2 Badge]