Přečtěte si, jak můžete v Animate CC změnit nastavení publikování jazyka ActionScript.

Změna nastavení publikování jazyka ActionScript

Když vytvoříte nový dokument FLA, aplikace Animate CC (dříve Flash Professional CC) se zeptá, jakou verzi jazyka ActionScript chcete použít. Toto nastavení můžete změnit, pokud se později rozhodnete napsat skript v jiné verzi jazyka ActionScript.

Poznámka:

Jazyk ActionScript 3.0 není kompatibilní s jazykem ActionScript 2.0. Kompilátor jazyka ActionScript 2.0 může kompilovat veškerý kód jazyka ActionScript 1.0 s výjimkou syntaxe lomítka (/), která se používá k označení cesty filmového klipu (například parentClip/testMC:varName= "hello world"). Chcete-li se vyhnout tomuto problému, buď přepište kód pomocí tečkové (.) notace, nebo vyberte kompilátor ActionScriptu 1.0.

  1. Vyberte příkaz Soubor > Nastavení publikování.
  2. Z nabídky Skript vyberte verzi jazyka ActionScript.

Soubory tříd a konfigurační soubory

Když nainstalujete aplikaci Animate, do vašeho systému se umístí několik konfiguračních složek a souborů vztahujících se k jazyku ActionScript. Pokud tyto soubory upravujete, abyste přizpůsobili vývojové prostředí, vytvořte si zálohu původních souborů.

Složka tříd jazyka ActionScript

Obsahuje všechny vestavěné třídy jazyka ActionScript 2.0 (soubory AS) Typické cesty k této složce jsou následující:

  • Windows 7 a 8: Pevný disk\Program Files\Adobe\Adobe Animate CC\Common\Configuration\ActionScript 3.0\Configuration\Classes

  • Macintosh: Pevný disk/Users/uživatel/Library/Application Support/Adobe/Animate CC/jazyk/Configuration/Classes

    Složka tříd je uspořádána také do tříd pro aplikaci Flash Player 10 a tříd pro aplikaci Flash Player 11. Další informace o uspořádání tohoto adresáře najdete v souboru Čtěte ve složce Classes.

Složka tříd pro zahrnutí

Obsahuje všechny globální soubory zahrnutí jazyka ActionScript. Umístění jsou následující:

  • Windows 7 a 8: Pevný disk\Program Files\Adobe\Adobe Animate CC\Common\Configuration\ActionScript 3.0\libs\

  • Macintosh: Pevný disk/Users/uživatel/Library/Application Support/Adobe/Animate CC/jazyk/Configuration/Include

Konfigurační soubor ActionsPanel.xml

Zahrnuje konfigurační soubor pro rady při psaní kódu jazyka ActionScript. Konfiguraci každé verze jazyků ActionScript a JavaScript a prostředí Flash Lite zajišťují samostatné soubory. Umístění jsou následující:

  • Windows 7 a 8: Pevný disk\Program Files\Adobe\Adobe Animate CC\Common\Configuration\ActionScript 3.0\libs\

  • Macintosh: Pevný disk/Users/uživatel/Library/Application Support/Adobe/Animate CC/jazyk/Configuration/ActionsPanel

Konfigurační soubor AsColorSyntax.xml

Konfigurační soubor pro barevné zvýrazňování syntaxe kódu jazyka ActionScript. Umístění jsou následující:

  • Windows 7 a 8: Pevný disk\Program Files\Adobe\Adobe Animate CC\Common\Configuration\ActionScript 3.0\libs\

  • Macintosh: Pevný disk/Users/uživatel/Library/Application Support/Adobe/Animate CC/jazyk/Configuration/ActionsPanel

Deklarace třídy dokumentu jazyka ActionScript 3.0

Když používáte ActionScript 3.0, soubor SWF může mít přiřazenou třídu nejvyšší úrovně. Tato třída se nazývá třída dokumentu. Když Flash Player načte SWF, vytvoří se instance této třídy a stane se objektem nejvyšší třídy pro soubor SWF. Tímto objektem souboru SWF může být instance libovolné vlastní třídy, kterou zvolíte.

Například soubor SWF, který implementuje komponentu kalendáře, může mít jako třídu nejvyšší úrovně přiřazenou třídu Calendar, která má náležité metody a vlastnosti pro komponentu kalendáře. Když se soubor SWF načte, vytvoří aplikace Flash Player instanci této třídy Calendar.

  1. Zrušte výběr všech objektů ve vymezené ploše a na časové ose tím, že klepnete do prázdné části vymezené plochy. Tím se zobrazí vlastnosti dokumentu v inspektoru Vlastnosti.
  2. Zadejte v inspektoru vlastností v textovém poli Třída dokumentu název tohoto souboru jazyka ActionScript pro tuto třídu. Vynechejte příponu názvu souboru .as.

Poznámka:

Informace o třídě dokumentu můžete také zadat v dialogovém okně Nastavení publikování.

Poznámka:

Nebo zadejte název třídy v souboru SWC propojený s cestou knihovny, kterou chcete nastavit jako třídu dokumentu.

Nastavení umístění souborů jazyka ActionScript

Abyste mohli použít třídu jazyka ActionScript, kterou jste definovali, musí aplikace Animate vyhledat externí soubory jazyka ActionScript s definicí této třídy. Seznam složek, ve kterých aplikace Animate vyhledává definice tříd, se v jazyce ActionScript 2.0 nazývá cesta pro třídy a v jazyce ActionScript 3.0 se nazývá zdrojová cesta. Cesty pro třídy a zdrojové cesty existují na aplikační (globální) úrovni i na úrovni dokumentů. Další informace o cestách pro třídy naleznete v části o třídách v dokumentu Učíme se ActionScript 2.0 v aplikaci Adobe Animate nebo v části Balíčky v dokumentu Učíme se ActionScript 3.0.

V aplikaci Animate lze nastavit následující umístění jazyka ActionScript:

  • ActionScript 2.0

    • Úroveň aplikace (dostupná pro všechny soubory AS2 FLA):

      • Třída pro cesty (nastavená v předvolbách jazyka ActionScript)

    • Úroveň dokumentu (dostupná pouze pro soubor FLA, který určuje jeho cestu):

      • Třída pro cesty (nastavená v okně Nastavení publikování)

  • ActionScript 3.0

    • Úroveň aplikace (dostupná pro všechny soubory AS3 FLA):

      • Zdrojová cesta (nastavená v předvolbách jazyka ActionScript)

      • Cesta knihovny (nastavená v předvolbách jazyka ActionScript)

      • Externí cesta knihovny (nastavená v předvolbách jazyka ActionScript)

    • Úroveň dokumentu (dostupná pouze pro soubor FLA, který určuje tyto cesty):

      • Zdrojová cesta (nastavená v okně Nastavení publikování)

      • Cesta knihovny (nastavená v okně Nastavení publikování)

      • Třída dokumentu (nastavená v inspektoru vlastností dokumentu)

Cesta knihovny určuje umístění předem nakompilovaného kódu jazyka ActionScript, který je obsažený ve vámi vytvořených souborech SWC. Soubor FLA, který tuto cestu určuje, načítá každý soubor SWC na nejvyšší úrovni této cesty a každé další zdroje kódu, které jsou určeny v samotných souborech SWC. Pokud použijete cestu knihovny, nezapomeňte, že žádný zkompilovaný kód v těchto souborech SWC nesmí být duplikovaný v nezkompilovaných souborech jazyka ActionScript ve zdrojové cestě. Nadbytečný kód bude kompilaci vašeho souboru SWF zpomalovat.

Můžete určit více cest, které má aplikace Animate prohledat. Použijí se zdroje, které budou nalezeny v kterékoli určené cestě. Když přidáváte nebo upravujete cestu, můžete přidat absolutní adresářové cesty (například C:/moje_tridy) a relativní adresářové cesty (například ../moje_tridy nebo ".").

Nastavení cesty pro třídy pro jazyk ActionScript 2.0

 

Poznámka: ActionScript 2.0 je v aplikaci Animate CC zastaralý. Další informace naleznete v tomto článku.

Nastavení cesty pro třídy na úrovni dokumentu:

 

  1. Zvolte Soubor > Nastavení publikování a klikněte na Flash.

  2. Ujistěte se, že v rozbalovací nabídce Verze ActionScriptu je vybraná volba ActionScript 2,0, a klikněte na Nastavení.
  3. V textovém poli Exportní snímek pro třídy určete snímek, ve kterém by měla být definice tříd umístěna.
  4. Chcete-li do seznamu cest pro třídy přidat cesty, proveďte libovolné z následujících úkonů:
    • Chcete-li k cestám pro třídy přidat složku, klikněte na tlačítko Vyhledat cestu , najděte složku, kterou chcete přidat, a klikněte na tlačítko OK.

    • Chcete-li do seznamu Cesta pro třídy přidat další řádek, klikněte na tlačítko Přidat novou cestu . Poklepejte na nový řádek, zadejte relativní nebo absolutní cestu a klepněte na tlačítko OK.

    • Chcete-li existující složku cesty tříd upravit, vyberte danou cestu v seznamu Cesta pro třídy, klepněte na tlačítko Vyhledat cestu, vyhledejte složku, kterou chcete přidat, a klepněte na OK. Nebo dvakrát klikněte na cestu v seznamu Cesta pro třídy, zadejte požadovanou cestu a klikněte na OK.

    • Chcete-li některou složku z cesty pro třídy odstranit, vyberte danou cestu v seznamu Cesta pro třídy a klikněte na tlačítko Odstranit vybranou cestu .

Nastavení cesty pro třídy na úrovni aplikace:

  1. Vyberte příkaz Úpravy > Předvolby (v systému Windows) nebo Flash > Předvolby (na počítačích Macintosh) a klikněte na kategorii jazyka ActionScript.

  2. Klepněte na tlačítko Nastavení jazyka ActionScript 2.0 a přidejte cesty do seznamu Cesta pro třídy.

Nastavení zdrojové cesty pro jazyk ActionScript 3.0

Nastavení zdrojové cesty na úrovni dokumentu:

  1. Zvolte Soubor > Nastavení publikování a klikněte na Flash.

  2. Ujistěte se, že v rozbalovací nabídce Verze jazyka ActionScript je vybraná volba ActionScript 3,0, a klikněte na Nastavení. Abyste mohli používat jazyk ActionScript 3.0, musí být verze vašeho přehrávače Flash Player nastavena na Flash Player 9.
  3. V textovém poli Exportovat třídy ve snímku určete snímek, ve kterém má být definice tříd umístěna.
  4. Určete nastavení Chyb. Můžete vybrat přísný režim nebo režim výstrah. V přísném režimu se varování kompilátoru oznamují jako chyby, což znamená, že pokud takové typy chyb existují, kompilace se nezdaří. V režimu výstrah se zobrazují zvláštní varování, která jsou užitečná pro odhalení nekompatibilit při aktualizování kódu v jazyce ActionScript 2.0 na kód v jazyce ActionScript 3.0.
  5. (Volitelně) Zvolte Vymezená plocha, pokud chcete, aby se automaticky deklarovaly instance ve vymezené ploše.
  6. Jako požadovaný dialekt určete ActionScript 3.0 nebo ECMAScript. Doporučuje se používat ActionScript 3.0.
  7. Chcete-li do seznamu zdrojových cest přidat cesty, proveďte libovolné z následujících úkonů:
    • Chcete-li ke zdrojové cestě přidat složku, klikněte na kartu Zdrojová cesta a pak na tlačítko Vyhledat cestu , přejděte ke složce, kterou chcete přidat, a klikněte na tlačítko OK.

    • Chcete-li do seznamu Zdrojová cesta přidat další řádek, klikněte na tlačítko Přidat novou cestu . Poklepejte na nový řádek, zadejte relativní nebo absolutní cestu a klepněte na tlačítko OK.

    • Chcete-li existující složku zdrojové cesty upravit, vyberte danou cestu v seznamu Zdrojová cesta, klepněte na tlačítko Vyhledat cestu, vyhledejte složku, kterou chcete přidat, a klepněte na tlačítko OK. Nebo dvakrát klikněte na cestu v seznamu Zdrojová cesta, zadejte požadovanou cestu a klikněte na tlačítko OK.

    • Chcete-li některou složku ze zdrojové cesty odstranit, vyberte ji v seznamu Zdrojová cesta a klikněte na tlačítko Odstranit z cesty .

Nastavení zdrojové cesty na úrovni aplikace:

  1. Zvolte Úpravy > Předvolby (Windows) nebo Animate > Předvolby (Macintosh) a klikněte na kategorii jazyka ActionScript.

  2. Klepněte na tlačítko Nastavení jazyka ActionScript 3.0 a přidejte cesty do seznamu Zdrojová cesta.

Nastavení cesty knihovny pro soubory jazyka ActionScript 3.0

Postup nastavení cesty knihovny na úrovni dokumentu je stejný jako nastavení zdrojové cesty:

  1. Vyberte příkaz Soubor > Nastavení publikování.
  2. Ujistěte se, že je v nabídce Skript vybrána volba ActionScript 3.0 a klikněte na tlačítko Nastavení jazyka ActionScript.
  3. V dialogovém okně Další nastavení jazyka ActionScript 3.0 klikněte na kartu Cesta knihovny.
  4. Přidejte cestu knihovny do seznamu Cesta knihovny. Do seznamu cest můžete přidávat složky nebo jednotlivé soubory SWC.
  5. Chcete-li nastavit vlastnost Typ odkazu, dvakrát klikněte na položku Typ odkazu ve stromu vlastností cesty. K dispozici jsou následující volby:
    • Vnořený do kódu: Zdroje kódu nalezené v určené cestě budou vnořeny do publikovaného souboru SWF.

    • Externí: Zdroje kódu nalezené v určené cestě nebudou přidány do publikovaného souboru SWF, ale kompilátor ověří, zda se nacházejí v určeném umístění.

    • Knihovna RSL (Runtime shared library): Přehrávač Flash Player stahuje zdroje za běhu.

Nastavení cesty knihovny na úrovni aplikace:

  1. Zvolte Úpravy > Předvolby (Windows) nebo Animate > Předvolby (Macintosh) a klikněte na kategorii jazyka ActionScript.

  2. Klepněte na tlačítko Nastavení jazyka ActionScript 3.0 a přidejte cesty do seznamu Cesta knihovny.

Podmíněné kompilování jazyka ActionScript

V jazyku ActionScript 3.0 můžete používat podmíněné kompilování stejným způsobem, jako se používalo u programovacího jazyka C++ a jiných. Podmíněné kompilování můžete například použít k vypnutí nebo zapnutí bloků kódu v rámci celého projektu, například u kódu implementujícího určitou funkci nebo u kódu, který se používá k ladění.

Konstanty konfigurace jsou definovány v nastavení publikování; můžete pomocí nich určit, zda jsou nebo nejsou kompilovány určité řádky kódu jazyka ActionScript. Jednotlivé konstanty vypadají takto:

CONFIG::SAMPLE_CONSTANT

U tohoto typu je CONFIG jmenným prostorem konfigurace a SAMPLE_CONSTANT je konstanta, kterou můžete v nastavení publikování nastavit na hodnotu true nebo false. Má-li tato konstanta hodnotu true, řádek kódu, který za touto konstantou v jazyku ActionScript následuje, se zkompiluje. Je-li hodnota false, řádek kódu za konstantou se nezkompiluje.

Například následující funkce obsahuje dva řádky kódu, které se zkompilují pouze tehdy, pokud je v nastavení publikování hodnota konstanty, která tyto řádky předchází, nastavena na hodnotu true:

public function CondCompTest() { 
    CONFIG::COMPILE_FOR_AIR { 
        trace("This line of code will be compiled when COMPILE_FOR_AIR=true."); 
    } 
    CONFIG::COMPILE_FOR_BROWSERS { 
        trace("This line of code will be compiled when COMPILE_FOR BROWSERS=true."); 
    } 
}

Definice konstanty konfigurace pomocí dialogového okna Nastavení publikování:

  1. Vyberte příkaz Soubor > Nastavení publikování.

  2. Ujistěte se, že je v nabídce Skript nastavena položka ActionScript 3.0, a klepněte vedle této nabídky na tlačítko Nastavení.

  3. V dialogovém okně Rozšířené možnosti jazyka ActionScript 3.0 klepněte na kartu Konstanty konfigurace.

  4. Chcete-li přidat konstantu, klepněte na tlačítko Přidat.

  5. Zadejte název konstanty, kterou chcete přidat. Výchozí jmenný prostor je CONFIG a výchozí název konstanty je CONFIG_CONST.

    Poznámka:

    Kompilátor aplikace Animate deklaruje konfigurační jmenný prostor CONFIG automaticky. Vlastní jmenné prostory konfigurace můžete přidat tím, že je v nastavení publikování zadáte i s názvem konstanty a pomocí následující syntaxe je přidáte do kódu jazyka ActionScript:

    config namespace MY_CONFIG;
  6. Zadejte pro konstantu požadovanou hodnotu (true nebo false). Chcete-li vypnout nebo zapnout kompilování určitých řádků kódu, můžete tuto hodnotu změnit.

Přizpůsobení kontextových nabídek v dokumentech (CS5.5)

Můžete přizpůsobit standardní kontextovou nabídku a kontextovou nabídku pro upravování textu, které se zobrazují pro soubory SWF ve Flash Playeru 7 a novějších.

  • Standardní kontextová nabídka se zobrazí, když uživatel klepne pravým tlačítkem (Windows) nebo s klávesou Ctrl (Macintosh) na soubor SWF ve Flash Playeru kdekoliv s výjimkou upravitelného textového pole. Do nabídky můžete přidávat vlastní položky a skrýt libovolné vestavěné položky s výjimkou položek Nastavení a Debugger.

  • Kontextová nabídka pro úpravy se zobrazí, když uživatel klepne pravým tlačítkem (Windows) nebo s klávesou Ctrl (Macintosh) do upravitelného textového pole v souboru SWF ve Flash Playeru. Do této nabídky můžete přidat vlastní položky. Nemůžete skrýt žádné vestavěné položky.

Poznámka:

Flash Player také zobrazí chybovou kontextovou nabídku, když uživatel klepne pravým tlačítkem (Windows) nebo s klávesou Ctrl (Macintosh) ve Flash Playeru, když není načtený žádný soubor SWF. Tuto nabídku nemůžete upravit.

K přizpůsobení kontextových nabídek aplikace Flash Player 7 slouží v jazyce ActionScript 2.0 objekty ContextMenu a ContextMenuItem. Další informace o používání těchto objektů naleznete v části ContextMenu v dokumentu Referenční příručka jazyka ActionScript 2.0.

Při vytváření vlastní kontextové nabídku pro Flash Player pamatujte na následující podmínky:

  • Vlastní položky se do kontextové nabídky přidávají v pořadí, ve kterém je vytvoříte. Když už jsou položky vytvořené, nemůžete toto pořadí změnit.

  • Můžete určit viditelnost a přístupnost vlastních položek.

  • Vlastní položky kontextové nabídky jsou automaticky kódovány pomocí kódování Unicode UTF‑8.

Konfigurační složky instalované s programem Flash (CS5.5)

Aplikace Flash umístí do vašeho systému při instalaci aplikace několik konfiguračních složek. V konfiguračních složkách jsou soubory spojené s aplikací uspořádány do příslušných úrovní uživatelského přístupu. Když pracujete s jazykem ActionScript® nebo jeho komponentami, můžete chtít zobrazit obsah těchto složek. Konfigurační složky aplikace Flash jsou následující:

Konfigurační složka na úrovni aplikace

Protože je na úrovni aplikace, uživatelé bez oprávnění správce nemají do této složky právo zápisu. Typické cesty k této složce jsou následující:

  • V Microsoft Windows XP nebo Microsoft Windows Vista vyhledejte startovací disk\Program Files\Adobe\Adobe Flash CS3\jazyk\Configuration\.

  • Na Macintoshi vyhledejte Macintosh HD/Aplikace/Adobe Flash CS3/Configuration/.

Složka pro první spuštění

Tento sourozenec konfigurační složky na úrovni aplikace usnadňuje sdílení konfiguračních souborů mezi uživateli na stejném počítači. Složky a soubory ve složce prvního spuštění se automaticky zkopírují do uživatelské konfigurační složky. Libovolné nové soubory umístěné do složky prvního spuštění se zkopírují do uživatelské konfigurační složky, když spustíte aplikaci.

Typické cesty ke složce prvního spuštění jsou následující:

  • Ve Windows XP nebo Windows Vista vyhledejte startovací disk\Program Files\Adobe\Adobe Flash CS3\jazyk\First Run\.

  • Na Macintoshi vyhledejte Macintosh HD/Aplikace/Adobe Flash CS3/First Run/.

Konfigurační složka na úrovni uživatele

Nachází se v oblasti profilu uživatele a do této složky může aktuální uživatel vždy zapisovat. Typické cesty k této složce jsou následující:

  • Ve Windows XP nebo Vista vyhledejte startovací disk\Documents and Settings\jméno uživatel\Local Settings\Data aplikací\Adobe\Flash CS3\jazyk\Configuration.

  • Na Macintoshi vyhledejte Macintosh HD/Uživatelé/jméno uživatele/Knihovna/Podpora aplikací/Adobe/Flash CS3/jazyk/Configuration/.

Konfigurační složka pro všechny uživatele

Nachází se v společném uživatelském profilu. Tato složka je částí standardní instalace operačních systémů Windows a Macintosh a je sdílená všemi uživateli jednotlivého počítače. Operační systém zpřístupňuje všem uživatelům počítače všechny soubory umístěné v této složce. Typické cesty k této složce jsou následující:

  • Ve Windows XP nebo Vista vyhledejte startovací disk\Documents and Settings\All Users\Data aplikací\Adobe\Flash CS3\jazyk\Configuration\.

  • Na Macintoshi vyhledejte Macintosh HD/Uživatelé/Sdílené/Podpora aplikací/Adobe/Flash CS3/jazyk/Configuration/.

Konfigurační složka uživatelů s omezeními

Pro uživatele s omezenými právy na pracovní stanici, typicky v síťovém prostředí, mají pouze správci systému správcovský přístup k pracovní stanici. Všichni ostatní uživatelé mají omezený přístup, který obvykle znamená, že tito uživatelé nemohou zapisovat do aplikačních souborů (jako je adresář Program Files ve Windows nebo složka Aplikace v Mac OS X).

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online