V tomto článku se dočtete o různých nastavení publikování v Animate CC.

Nastavení publikování dokumentů HTML5 Canvas

Informace o nastavení publikování dokumentů HTML5 Canvas najdete tomto článku.

Nastavení publikování souborů SVG

Informace o nastavení publikování souborů SVG najdete v tomto článku.

Nastavení publikování dokumentů WebGL

Informace o nastavení publikování dokumentů WebGL najdete v tomto článku.

Nastavení publikování aplikací AIR

Android

Informace o nastavení publikování pro Android najdete v tomto článku.

iOS

Informace o nastavení publikování pro iOS najdete v tomto článku.

Počítač

Informace o nastavení publikování pro iOS najdete v tomto článku.

Publikování vrstev jako archivu SWF

V předchozích verzích animátoři při vytváření animací museli ručně vytvořit a upravit soubor SWF pro každou vrstvu a importovat ho do aplikace After Effects. Počínaje touto verzí nabízí Animate nový formát publikování, archiv SWF, který umožňuje zabalit různé vrstvy jako nezávislé soubory SWF a importovat je do Adobe After Effects.

  1. Vyberte dokument ActionScript a klikněte na Soubor > Nastavení publikování > Další formáty > Archiv SWF.

    publish_layers
    Publikování archivu SWF

  2. V poli Název výstupu vyhledejte a vyberte lokálně uložený archiv SWF. Ze souboru archivu bude vygenerován soubor ZIP. Soubory SWF všech vrstev budou sloučeny do jednoho souboru ZIP. Konvence pro vytváření názvu výsledného souboru ZIP zahrnuje předponu se čtyřmístným číslem, podtržítkem a názvem vrstvy.

Nastavení publikování pro soubory Animate (.swf)

Poznámka:

Pouze CS5.5: Nastavení publikování pro verzi přehrávače a ActionScriptu můžete určit také v inspektoru vlastností. Zrušte výběr všech položek ve vymezené ploše a tím zobrazíte vlastnosti dokumentu v inspektoru vlastností.

  1. Vyberte Soubor > Nastavení publikování a z rozbalovací nabídky přehrávače vyberte požadovanou verzi přehrávače. Ne všechny funkce aplikace pracují v publikovaných souborech SWF, které jsou určeny pro starší verze přehrávače než Flash Player 10. Chcete-li specifikovat detekování aplikace Flash Player, klepněte na kategorii HTML Wrapper v levém sloupci a vyberte možnost Detekovat verzi aplikace Flash a zadejte verzi Flash Player, kterou chcete detekovat.

    Poznámka: V aplikaci Flash Pro CS5.5 nastavení verze Flash Player 10.2 vytvoří soubor SWF používající verzi 11 formátu SWF. Nastavení verzí Flash Player 10 a 10.1 vytvoří soubor SWF používající verzi 10 formátu SWF.

  2. Z rozbalovací nabídky Skript vyberte verzi jazyka ActionScript®. Pokud vyberete ActionScript 2.0 nebo 3.0 a máte vytvořené třídy, klepněte na tlačítko Nastavení ActionScriptu a nastavte relativní cestu k souborům tříd, která se liší od cesty k výchozím adresářům nastavené v Předvolbách.

    Poznámka: Ve verzi Animate CC je podporován pouze jazyk ActionScript 3.0.

  3. Chcete-li určit míru komprese bitmap, klepněte v levém sloupci na kategorii Animate a upravte hodnotu Kvalita JPEG. Při použití nižší kvality obrazu vznikne menší soubor; při použití vyšší kvality obrazu vznikne větší soubor. Vyzkoušejte různá nastavení, abyste určili nejvhodnější poměr velikosti a kvality; hodnota 100 poskytuje nejvyšší kvalitu a nejmenší míru komprese.

    Chcete-li vytvořit snímky JPEG s vysokou kompresí s vyhlazeným vzhledem, zvolte Povolit odblokování JPEG. Tato možnost redukuje typické artefakty vzniklé kompresí JPEG, například běžný výskyt bloků 8x8 pixelů v obrazu. Některé obrázky JPEG mohou ztrácet některé detaily, pokud bude tato možnost vybrána.

  4. Chcete-li nastavit vzorkovací kmitočet a kompresi pro všechny zvukové streamy nebo zvuky událostí v souboru SWF, klepněte na hodnoty vedle položek Zvukový stream nebo Zvuková událost a vyberte volby podle potřeby.

    Poznámka:

    Zvukový stream se začne přehrávat, jakmile se načte dostatek dat pro prvních několik snímků, a je synchronizován s časovou osou. Zvuk události se nepřehraje, dokud se celý nenačte, a pak hraje tak dlouho, dokud není explicitně zastaven.

  5. Chcete-li změnit nastavení pro jednotlivé zvuky vybrané v části Zvuk v inspektoru Vlastnosti, zvolte Nahradit nastavení zvuku. Chcete-li vytvořit menší, ne zcela věrnou verzi souboru SWF, vyberte tuto volbu.

    Poznámka:

    Pokud je volba Nahradit nastavení zvuku vypnutá, Animate prozkoumá všechny streamingové zvuky v dokumentu (včetně zvuků v importovaném videu) a publikuje všechny zvukové streamy v nejvyšším individuálním nastavení. Pokud má jeden nebo více zvukových streamů vysoké nastavení exportu, může se tím zvětšit velikost souboru.

  6. Chcete-li exportovat zvuky vhodné pro mobilní zařízení, a ne původní zvuky z knihovny, zvolte Exportovat zvuky zařízení. Klikněte na tlačítko OK.
  7. Chcete-li nastavit další volby nastavení, vyberte některou z následujících možností:

    Komprimovat film

    (ve výchozím nastavení zapnutá) Zkomprimuje soubor SWF a tím zmenší velikost souboru a zkrátí čas načítání.

    Dostupné jsou dva režimy komprese:

    • Deflate - jedná se o starší režim komprese, který je kompatibilní s přehrávačem Flash 6.x a novějšími.
    • LZMA - Tento režim je až o 40 % účinnější než Deflate a je kompatibilní pouze s přehrávačem Flash Player 11.x nebo novějším nebo AIR 3.x nebo novější. Komprese LZMA je vhodná pro většinu souborů FLA, které obsahují spoustu skriptů ActionScript nebo vektorové grafiky. Pokud je v nastavení Publikovat vybrána položka SWC, bude k dispozici pouze komprese Deflate.

    Zahrnout skryté vrstvy

    (Výchozí) Vyexportuje všechny skryté vrstvy dokumentu Animate. Když volbu Exportovat skryté vrstvy vypnete, všechny vrstvy (včetně vrstev vnořených uvnitř filmových klipů) označené jako skryté se ve výsledném souboru SWF nevyexportují. Pokud tedy nastavíte určité vrstvy jako neviditelné, můžete snadno testovat různé verze dokumentů Animate.

    Zahrnout metadata XMP

    (Výchozí) Exportovat všechna metadata zadaná do dialogového okna Informace o souboru. Otevřete dialogové okno klepnutím na tlačítko Změnit metadata XMP. Dialogové okno Informace o souboru můžete také otevřít zvolením nabídky Soubor > Informace o souboru. Metadata lze prohlížet, až vyberete soubor SWF v aplikaci Adobe® Bridge.

    Vytvořit zprávu o velikosti

    Vygeneruje zprávu s přehledem množství dat ve finálním obsahu Animate podle jednotlivých souborů.

    Příkazy Vynechat sledování

    Určuje, že má Animate v aktuálním souboru SWF ignorovat příkazy ActionScript trace. Když vyberete tuto volbu, informace z příkazů trace se nebudou na panelu Výstup zobrazovat. 

    Povolit ladění

    Aktivuje Debugger a umožní vzdálené ladění souboru SWF Animate. Umožňuje použít u vašeho souboru SWF ochranu heslem.

    Zabránění importu

    Zabraňuje ostatním uživatelům importovat soubor SWF a převést ho zpět na dokument FLA. Umožňuje použít u vašeho souboru SWF Animate ochranu heslem.

  8. Pokud používáte ActionScript 2.0 a vybrali jste Povolit ladění nebo Zabránit importu, zadejte heslo do textového pole Heslo. Pokud přidáte heslo, musí ostatní uživatelé toto heslo zadat, jinak nemohou soubor SWF ladit nebo importovat. Chcete-li heslo odstranit, vymažte textové pole Heslo a publikujte znovu. 

    Poznámka: Animate CC nepodporuje ActionScript 1.0 a 2.0.

  9. Chcete-li nastavit maximální čas, po který se může skript v souboru SWF vykonávat, zadejte hodnotu pro Limit času skriptu. Aplikace Flash Player zruší vykonávání skriptů přesahujících tento limit.
  10. Z rozbalovací nabídky Lokální zabezpečení přehrávání vyberte požadovaný model zabezpečení aplikace Animate. Určete, zda má mít váš publikovaný soubor SWF lokální nebo síťový zabezpečený přístup.

    Pouze lokální přístup

    Umožňuje interakci publikovaného souboru SWF se soubory a zdroji v lokálním systému, nikoli však na síti.

    Použít pouze síť

    Umožňuje interakci publikovaného souboru SWF se soubory a zdroji na síti, nikoli však v lokálním systému.

  11. Chcete-li souboru SWF povolit použití hardwarové akcelerace, vyberte v nabídce Hardwarová akcelerace jednu z následujících voleb.

    Úroveň 1 – Přímo

    Přímý režim zlepšuje výkon přehrávání tím, že povolit aplikaci Flash Player vykreslovat přímo na obrazovce, namísto vykreslování prohlížečem.

    Úroveň 2 - GPU

    V režimu GPU využívá aplikace Flash Player k přehrávání videa a skládání grafik s vrstvami dostupný výpočetní výkon grafické karty. To poskytuje, v závislosti na grafické kartě uživatele, zcela jinou úroveň výkonu. Tuto volbu používejte v případě, že očekáváte, že budou mít příjemci špičkové grafické karty.

    Pokud nemá přehrávající systém k povolení akcelerace dostatečný hardware, vrátí se aplikace Flash Player zpět k normálnímu režimu kreslení. Nejlepšího výkonu na webových stránkách obsahujících několik souborů SWF dosáhnete povolením hardwarové akcelerace pouze pro jeden soubor SWF. Hardwarová akcelerace není použita v režimu testování filmu.

    Při publikování souboru SWF obsahuje soubor HTML, který soubor SWF vkládá, parametr jazyka HTML wmode. Zvolíte-li hardwarovou akceleraci první nebo druhé úrovně, nastavíte tím tento parametr HTML wmode na hodnotu „direct“ (přímá) nebo „gpu“. Zapnutím hardwarové akcelerace se potlačí nastavení Režim okna, které jste mohli vybrat v dialogovém okně Nastavení publikování na záložce HTML; také toto nastavení je totiž uloženo v parametru wmode tohoto souboru HTML.

Nastavení publikování pro soubory SWC a projektory

Soubor SWC se používá k distribuci komponent. Soubor SWC obsahuje zkompilovaný klip, soubor tříd ActionScript pro danou komponentu a další soubory, které komponentu popisují.

Projektory jsou soubory aplikace Animate, které obsahují publikovaný soubor SWF a Flash Player. Projektory lze přehrávat podobně jako běžnou aplikaci bez webového prohlížeče, zásuvného modulu Flash Player nebo prostředí Adobe AIR.

  • Chcete-li publikovat soubor SWC, vyberte soubor SWC v levém sloupci dialogového okna Nastavení publikování a klepněte na tlačítko Publikovat.

  • Chcete-li publikovat Projektor Windows, vyberte v levém sloupci Projektor Win a klepněte na tlačítko Publikovat.

  • Chcete-li publikovat Projektor Macintosh, vyberte v levém sloupci Projektor Mac a klepněte na tlačítko Publikovat.

Chcete-li soubor SWC nebo projektor uložit s jiným názvem souboru než původní soubor FLA, zadejte název pro výstupní soubor.

Nastavení publikování pro soubory HTML Wrapper

Pro přehrávání obsahu Animate ve webovém prohlížeči je potřeba dokument HTML, který aktivuje soubor SWF a určuje nastavení prohlížeče. Příkazem Publikovat se tento dokument automaticky vygeneruje z parametrů uvedených v dokumentu předlohy HTML.

Dokumentem předlohy může být libovolný textový soubor obsahující vhodné proměnné předlohy – včetně prostého souboru HTML, souboru obsahujícího kód pro speciální interpretery, jako je aplikace ColdFusion® nebo Active Server Pages (ASP), nebo předloha obsažená v aplikaci Animate.

Chcete-li parametry HTML pro Animate zadat ručně nebo chcete-li přizpůsobit vestavěnou předlohu, použijte editor HTML.

Parametry HTML určují, kde se má obsah v okně zobrazovat, jaká je barva pozadí, velikost souboru SWF a tak dále a také nastavují atributy pro tagy object a embed. Toto a další nastavení můžete změnit v panelu HTML uvnitř dialogového okna Nastavení publikování. Změna těchto nastavení má přednost před volbami nastavenými v souboru SWF.

Určení požadovaných nastavení

  1. Vyberte Soubor > Nastavení publikování a v levém sloupci dialogového okna klepněte na kategorii HTML Wrapper.
  2. Použijte výchozí název souboru, který je stejný jako název vašeho dokumentu, nebo zadejte jedinečný název s příponou .html.
  3. Chcete-li vybrat a použít nainstalovanou předlohu, vyberte předlohu z rozbalovací nabídky Předloha. Chcete-li zobrazit popis vybrané předlohy, klepněte na volbu Informace. Výchozím výběrem je předloha Pouze Animate.

  4. Pokud jste vybrali jakoukoli jinou předlohu HTML než Obrazová mapa a nastavili jste verzi přehrávače Flash Player 4 nebo novější, vyberte možnost Detekce verze Animate. Další informace naleznete v tématu Nastavení publikování pro detekci přehrávače Flash Player.

    Poznámka:

    Detekce verze Animate nakonfiguruje váš dokument tak, aby zjistil uživatelovu verzi přehrávače Flash Player a případně ho přesměroval na alternativní stránku HTML, nemá-li potřebný přehrávač. Alternativní stránka HTML obsahuje odkaz na stažení nejnovější verze přehrávače Flash Player.

  5. Výběrem volby Velikost nastavte hodnoty atributů width a height v tagu object a v tagu embed jazyka HTML:

    Přizpůsobit film

    (Výchozí nastavení) Používá velikost souboru SWF.

    Obr. body

    Použije šířku a výšku, které zadáte. Zadejte šířku a výšku v obrazových bodech.

    Procenta

    Soubor SWF zabírá v okně prohlížeče zadané procento. Zadejte procenta pro požadovanou šířku a výšku.

  6. Chcete-li ovládat přehrávání a funkce souboru SWF, vyberte volby v části Přehrávání:

    Pozastavený na začátku

    Přeruší přehrávání souboru SWF do té doby, dokud uživatel neklepne na tlačítko nebo z místní nabídky nevybere možnost Přehrát. (Výchozí nastavení) Tato volba je vypnutá a obsah se začne přehrávat ihned po načtení (parametr PLAY je nastaven na hodnotu true).

    Opakovat

    Po dosažení posledního snímku se obsah začne přehrávat znovu. Tuto volbu odznačte, pokud chcete, aby přehrávání obsahu po dosažení posledního snímku skončilo. (Výchozí nastavení) Parametr LOOP je zapnutý.

    Zobrazit nabídku

    Při klepnutí pravým tlačítkem (Windows) nebo s klávesou Control (Mac) na soubor SWF se zobrazí kontextová nabídka. Chcete-li, aby se v kontextové nabídce zobrazovala jen volba Animate, vypněte tuto volbu. Ve výchozím nastavení je tato volba vybraná (parametr MENU je nastavený na hodnotu true).

    Písmo zařízení

    (Pouze Windows) Písma, která nejsou v systému uživatele nainstalována, budou nahrazena systémovými písmy s vyhlazením (hladkými okraji). Používání písem zařízení zlepšuje čitelnost textu psaného malým písmem a může zmenšit velikost souboru SWF. Tato volba má vliv jen na soubory SWF, které obsahují statický text (který vytváříte při vytváření souboru SWF a který se při zobrazení obsahu nemění), pro který je nastaveno, že se má zobrazovat s použitím písem zařízení.

  7. Vyberte postupně jednotlivé volby z nabídky Kvalita, abyste zjistili nejvhodnější poměr mezi časem zpracování a vzhledem, jak je popsáno v následujícím seznamu. Tyto volby nastavují hodnotu parametru QUALITY v tagu object a v tagu embed.

    Nízká

    Upřednostňuje rychlost přehrávání před vzhledem a nepoužívá vyhlazování.

    Automaticky nízká

    Zprvu klade důraz na rychlost, ale kdykoli to je možné, zlepšuje i vzhled. Přehrávání začíná s vypnutým vyhlazováním. Pokud Flash Player zjistí, že to procesor zvládá, vyhlazování se automaticky zapne.

    Automaticky vysoká

    Zpočátku klade stejný důraz na rychlost přehrávání i vzhled, ale v případě potřeby upřednostňuje rychlost přehrávání před vzhledem. Přehrávání začíná se zapnutým vyhlazováním. Pokud skutečný kmitočet snímků klesne pod určenou hodnotu, vyhlazování se vypne, aby se zvýšila rychlost přehrávání. Chcete-li emulovat nastavení Zobrazení > Vyhlazení, použijte tuto volbu.

    Střední

    Aplikuje určité vyhlazování, ale nevyhlazuje bitmapy. Nastavení Střední poskytuje lepší kvalitu než nastavení Nízká, ale horší než nastavení Vysoká.

    Vysoká

    (Výchozí nastavení) Upřednostňuje vzhled před rychlostí přehrávání a vždy používá vyhlazování. Pokud soubor SWF neobsahuje animaci, jsou bitmapy vyhlazené; pokud obsahuje animaci, bitmapy nejsou vyhlazené.

    Nejlepší

    Poskytuje nejvyšší kvalitu zobrazení bez ohledu na rychlost přehrávání. Všechny výstupy i bitmapy jsou vždy vyhlazené.

  8. Vyberte požadovanou volbu z nabídky Režim okna, která určuje atributwmode pro HTML v tagu object a v tagu embed. Režim okna upravuje vztah mezi obsahem ohraničovacího rámečku obsahu nebo virtuálního okna a obsahem ve stránce HTML podle následujících zásad:

    Okno

    (Výchozí nastavení) Nevkládá do tagů object a embed žádné atributy týkající se oken. Pozadí obsahu je neprůhledné a používá barvu pozadí HTML. Kód HTML se nedá vykreslovat nad ani pod obsahem Animate.

    Neprůhledné bez okna

    Nastaví pozadí za obsahem Animate na neprůhledné, takže přes něj nebude vidět nic, co je pod ním. Obsah HTML se pak dá zobrazovat nad nebo přes obsahem Animate.

    Průhledné bez okna

    Nastaví pozadí za obsahem Animate na průhledné, takže se pak nad ním i pod ním může zobrazovat obsah HTML. 

    Pokud v dialogovém okně Nastavení publikování zapnete na záložce Animate volbu Hardwarová akcelerace, bude vybraný režim okna ignorován a použije se výchozím režim Okno.

    Ukázku nastavení režimu okna naleznete v dokumentu TechNote s názvem How to make a Flash movie with a transparent background (Jak vytvořit film Flash s průhledným pozadím).

    Poznámka:

    V některých případech může vykreslování složitého obsahu v režimu Průhledné bez okna zpomalovat animaci, když jsou obrazy HTML také složité.

    Přímo

    Použije metodu vykreslení Stage3D, která využívá GPU, kdykoli je to možné. Při použití přímého režimu není možné umístit obrázky jiného typu než SWF do souboru SWF na stránce HTML. 

    Seznam procesorů, které metodu Stage3D nepodporují, naleznete na stránkách http://kb2.adobe.com/cz/cps/921/cpsid_92103.html.

  9. Chcete-li, aby se v případě konfliktu nastavení tagů zobrazovaly chybové zprávy (například pokud předloha obsahuje kód odkazující na alternativní obraz, který nebyl určen), vyberte volbu Zobrazovat výstražné zprávy.
  10. Chcete-li obsah umístit v rámci určitých hranic, jestliže jste změnili původní šířku a výšku dokumentu, vyberte volbu Změnit velikost. Volba Změnit velikost nastaví parametr SCALE v tagu object a v tagu embed jazyka HTML.

    Výchozí (Zobrazit vše)

    Zobrazí celý dokument v určené oblasti bez zdeformování a přitom zachová původní poměr stran souborů SWF. Na dvou stranách aplikace mohou být volné okraje.

    Bez okrajů

    Změní velikost dokumentu tak, aby vyplnil určenou plochu a přitom zachová původní poměr stran souboru SWF bez zdeformování a v případě potřeby soubor SWF ořízne.

    Přesně vyplnit

    Zobrazí celý dokument v určené oblasti bez zachování původního poměru stran, což může způsobit jeho zdeformování.

    Neměnit velikost

    Zabraňuje změně velikosti dokumentu při změně velikosti okna přehrávače Flash Player.

  11. Chcete-li určit umístění okna souboru SWF v okně prohlížeče, vyberte jednu z následujících možností nabídky Zarovnání HTML:

    Výchozí

    Zarovná obsah v okně prohlížeče na střed a ořízne okraje, pokud je okno prohlížeče menší než aplikace.

    Doleva, Doprava nebo Nahoru

    Zarovná soubory SWF podle příslušné strany okna prohlížeče a podle potřeby ořízne zbývající tři strany.

  12. Chcete-li nastavit, jak se má obsah umístit v okně aplikace a jak se má oříznout, vyberte volby Vodorovné zarovnání Flash a Svislé zarovnání Flash. Tyto možnosti nastaví parametr SALIGN v tagu object a v tagu embed jazyka HTML.

Parametry a atributy pro tagy object a embed

Následující atributy a parametry tagů popisují kód HTML vytvořený příkazem Publikovat. Až budete psát vlastní HTML pro zobrazování obsahu Animate, můžete se s tímto seznamem radit. Pokud není uvedeno jinak, všechny položky se vztahují k tagu object i k tagu embed. Volitelné položky jsou označeny. Internet Explorer rozeznává parametry používané s tagem object; Netscape rozeznává tag embed. Atributy se používají s tagem object i s tagem embed. Když přizpůsobujete předlohu, můžete hodnotu nahradit nějakou proměnnou předlohy (označenou v následujícím seznamu v části Hodnota u každého parametru).

Poznámka:

Atributy a parametry uvedené v této části jsou psány malými písmeny, aby odpovídaly normě XHTML.

devicefont (písmo zařízení), atribut/parametr

(Volitelně) Určuje, zda se mají statické textové objekty vykreslovat s použitím písem zařízení, i když není volba Písmo zařízení vybraná. Tento atribut se aplikuje, když jsou potřebná písma dostupná z operačního systému.

Hodnota: true | false

Proměnná předlohy: $DE

src, atribut

Určuje název souboru SWF, který se má načíst. Vztahuje se pouze na tag embed.

Hodnota: movieName.swf

Proměnná předlohy: $MO

movie (film), parametr

Určuje název souboru SWF, který se má načíst. Vztahuje se pouze na tag object.

Hodnota: movieName.swf

Proměnná předlohy: $MO

classid (identifikátor třídy), atribut

Identifikuje prvek ActiveX pro prohlížeč. Hodnotu je nutno zadat přesně tak, jak je uvedena. Vztahuje se pouze na tag object.

Hodnota: clsid:d27cdb6e-ae6d-11cf-96b8-444553540000

šířka, atribut

Určuje šířku aplikace buď v obrazových bodech, nebo v procentech šířky okna prohlížeče.

Hodnota: n nebo n%

Proměnná předlohy: $WI

výška, atribut

Určuje výšku aplikace buď v obrazových bodech, nebo v procentech výšky okna prohlížeče.

Poznámka:

Jelikož velikost aplikací Animate se dá měnit, nedochází při různých velikostech ke zhoršení kvality, pokud je zachován poměr stran. (Například následující velikosti mají všechny poměr stran 4:3: 640 x 480 obr. bodů, 320 x 240 obr. bodů a 240 x 180 obr. bodů.)

Hodnota: n nebo n%

Proměnná předlohy: $HE


codebase (báze kódu), atribut

Identifikuje umístění prvku ActiveX přehrávače Flash Player, aby ho prohlížeč mohl automaticky stáhnout, pokud ještě není nainstalovaný. Hodnotu je nutno zadat přesně tak, jak je uvedena. Vztahuje se pouze na tag object.

Hodnota: http://fpdownload.adobe.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0

pluginspage (stránka zásuvných modulů), atribut

Identifikuje umístění zásuvného modulu přehrávače Flash Player, aby si ho mohl uživatel stáhnout, pokud ještě není nainstalovaný. Hodnotu je nutno zadat přesně tak, jak je uvedena. Vztahuje se pouze na tag embed.

Hodnota: http://www.adobe.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash

swliveconnect, atribut

(Volitelně) Určuje, zda má prohlížeč při prvním načítání přehrávače Flash Player spustit jazyk Java™. Pokud je tento atribut vynechán, pak výchozí hodnota je false. Pokud použijete JavaScript i Animate na stejné stránce, musí být spuštěná Java, jinak nebude funkce fscommand() fungovat. Pokud ale používáte JavaScript jen k detekci prohlížeče nebo k jinému účelu, který nesouvisí s akcemi funkce fscommand(), můžete spuštění Java zabránit tím, že atribut SWLIVECONNECT nastavíte na hodnotu false. Chcete-li zajistit, aby se Java spustila, když nepoužíváte JavaScript, explicitně nastavte atribut SWLIVECONNECT na hodnotu true. Spouštění Javy podstatně prodlužuje čas potřebný ke spuštění souboru SWF; nastavte tento tag na hodnotu true jen v případě, že je to skutečně potřebné. Vztahuje se pouze na tag embed.

Použijte akci fscommand() ke spuštění Javy ze souboru samostatného projektoru.

Hodnota: true | false

play (přehrát), atribut/parametr

(Volitelně) Určuje, zda se má aplikace začít přehrávat hned po načtení do webového prohlížeče. Pokud je vaše aplikace Animate interaktivní, nechejte uživatele, aby si přehrávání spouštěl sám klepnutím na tlačítko nebo provedením jiného úkonu. V tomto případě nastavte atribut play na hodnotu false, aby se aplikace nespouštěla automaticky. Pokud je tento atribut vynechán, pak výchozí hodnota je true.

Hodnota: true | false

Proměnná předlohy: $PL

loop (opakovat), atribut/parametr

(Volitelně) Určuje, zda se má přehrávání obsahu neustále opakovat, nebo zda se má zastavit, jakmile dojde na poslední snímek. Pokud je tento atribut vynechán, pak výchozí hodnota je true.

Hodnota: true | false

Proměnná předlohy: $LO

quality (kvalita), atribut/parametr

(Volitelně) Určuje, jaká úroveň vyhlazení se má použít. Jelikož vyhlazování potřebuje rychlejší procesor, aby mohl být každý snímek souboru SWF před vykreslením na obrazovce uživatele vyhlazen, vyberte jednu z následujících hodnot podle toho, zda je pro vás důležitější rychlost, nebo vzhled:

Nízká

Upřednostňuje rychlost přehrávání před vzhledem a nikdy nepoužívá vyhlazování.

Auto. nízká

Zprvu klade důraz na rychlost, ale kdykoli to je možné, zlepšuje i vzhled. Přehrávání začíná s vypnutým vyhlazováním. Pokud Flash Player zjistí, že to procesor zvládá, vyhlazování se zapne. Poznámka: Soubory SWF vytvořené pomocí jazyka ActionScript 3.0 nerozpoznávají hodnotu autolow.

Automaticky vysoká

Zpočátku klade stejný důraz na rychlost přehrávání i vzhled, ale v případě potřeby upřednostňuje rychlost přehrávání před vzhledem. Přehrávání začíná se zapnutým vyhlazováním. Pokud kmitočet snímků klesne pod určenou hodnotu, vyhlazování se vypne, aby se zvýšila rychlost přehrávání. Toto nastavení použijte, chcete-li emulovat příkaz Vyhlazení (Zobrazení > Režim náhledu > Vyhlazení).

Střední

Aplikuje určité vyhlazování, ale nevyhlazuje bitmapy. Poskytuje lepší kvalitu než nastavení Nízká, ale horší než nastavení Vysoká.

Vysoká

Upřednostňuje vzhled před rychlostí přehrávání a vždy používá vyhlazování. Pokud soubor SWF neobsahuje animaci, jsou bitmapy vyhlazené; pokud obsahuje animaci, bitmapy nejsou vyhlazené.

Nejlepší

Poskytuje nejvyšší kvalitu zobrazení bez ohledu na rychlost přehrávání. Všechny výstupy i bitmapy jsou vždy vyhlazené.

Pokud je tento atribut vynechán, pak výchozí hodnota quality je high.

Hodnota: low | medium | high | autolow | autohigh | best

Proměnná předlohy: $QU


bgcolor, atribut/parametr

(Volitelně) Určuje barvu pozadí aplikace. Tento atribut slouží ke změně nastavení barvy pozadí určeného v souboru SWF. Tento atribut nemá vliv na barvu pozadí stránky HTML.

Hodnota: #RRGGBB (šestnáctková hodnota RGB)

Proměnná předlohy: $BG

scale (změnit velikost), atribut/parametr

(Volitelné) Definuje, jak se má aplikace umístit v okně prohlížeče, když jsou atributy width (šířka) a height (výška) uvedeny v procentech.

Showall (výchozí nastavení)

Zobrazí celý dokument v určené oblasti bez zdeformování a přitom zachová původní poměr stran aplikace. Na dvou stranách aplikace mohou být volné okraje.

Noborder

Změní velikost tak, že aplikace vyplní určenou oblast bez deformace, ale pravděpodobně s určitým oříznutím, se zachováním původního poměru stran aplikace.

Exactfit

Celý obsah bude viditelný v určené oblasti bez snahy zachovat původní poměr stran. Může dojít ke zkreslení.

Výchozí hodnota je showall pokud je tento atribut vynechán (a hodnoty width a height jsou uvedeny v procentech).

Hodnota: showall | noborder | exactfit

Proměnná předlohy: $SC


align (zarovnat), atribut

Určuje hodnotu align (zarovnat) pro tagy object, embed a img a určuje způsob umístění souboru SWF v okně prohlížeče.

Výchozí

Umístní aplikaci na střed v okně prohlížeče a ořízne okraje, pokud je okno prohlížeče menší než aplikace.

L, R a T

Zarovná aplikaci podle levého (L), pravého (R) nebo horního (T) okraje okna prohlížeče a podle potřeby ořízne zbývající tři strany.

salign, parameter

(Volitelně) Určuje, kde se má soubor SWF s upraveným měřítkem umístit v ploše definované nastavením atributů width (šířka) a height (výška).

L, R a T

Zarovná aplikaci podle levého (L), pravého (R) nebo horního (T) okraje okna prohlížeče a podle potřeby ořízne zbývající tři strany.

TL a TR

Zarovná aplikaci podle levého horního, nebo pravého horního rohu okna prohlížeče a podle potřeby ořízne pravou nebo levou stranu.

Pokud je tento atribut vynechán, je obsah v okně prohlížeče zarovnán na střed.

Hodnota: L | R | T | B | TL | TR

Proměnná předlohy: $SA


base, atribut

(Volitelně) Určuje základní adresář nebo URL sloužící k rozlišení všech příkazů s relativními cestami obsažených v souboru SWF. Tento atribut je užitečný, když máte soubory SWF v jiné složce než ostatní soubory.

Hodnota: základní adresář nebo URL

menu (nabídka), atribut nebo parametr

(Volitelně) Určuje typ nabídky, která se zobrazí, když uživatel klepne pravým tlačítkem (Windows) nebo s klávesou Apple (Macintosh) na plochu aplikace v prohlížeči.

true

zobrazí úplnou nabídku, která uživateli nabízí několik voleb pro zlepšení nebo ovládání přehrávání.

false

zobrazí nabídku, která obsahuje pouze volbu O přehrávači Adobe Flash Player 6 a volbu Nastavení.

Pokud je tento atribut vynechán, pak výchozí hodnota je true.

Hodnota: true | false

Proměnná předlohy: $ME


wmode, atribut nebo parametr

(Volitelně) Umožňuje používat průhledný obsah Animate, absolutní pozice a možnost vrstvení dostupné v prohlížeči Internet Explorer 4.0. Parametr wmode se taky používá k hardwarové akceleraci v přehrávači Flash Player 9 a novějším.

Pokud je tento atribut vynechán, pak výchozí hodnota je Window. Vztahuje se pouze na tag object.

Okno

Přehraje aplikaci v jejím vlastním obdélníkovém okně na webové stránce. Hodnota Okno značí, že aplikace Animate nemá žádnou interakci s vrstvami HTML a je vždy úplně navrchu.

Neprůhledný

Způsobí, že aplikace skryje vše, co je na stránce za ní.

Průhledný

Zajistí, že skrz všechny průhledné plochy aplikace bude vidět pozadí stránky HTML; tato volba může zpomalit animaci.

Opaque windowless (Neprůhledné bez okna) a Transparent windowless (Průhledné bez okna)

Obě tyto volby mají interakci s vrstvami HTML, přičemž vrstvy nad souborem SWF vyblokují aplikaci. Volba Průhledný povoluje průhlednost, takže skrz pozadí souboru SWF lze vidět vrstvy HTML pod souborem SWF, což v případě volby Neprůhledný nelze.

Přímo

Úroveň 1 – Zapíná přímý režim hardwarové akcelerace. Další nastavení režimu okna lze používat pouze tehdy, když je hardwarová akcelerace vypnuta.

GPU

Úroveň 2 – Zapíná režim hardwarové akcelerace využívající GPU. Další nastavení režimu okna lze používat pouze tehdy, když je hardwarová akcelerace vypnuta.

Hodnota: Window | Opaque | Transparent | Direct | GPU

Proměnná předlohy: $WM


allowscriptaccess, atribut nebo parametr

Atribut nebo parametr allowscriptaccess umožňuje aplikaci Animate komunikovat s její hostitelskou stránkou HTML. Operace fscommand() agetURL() mohou způsobit, že JavaScript bude používat oprávnění stránky HTML, která se mohou lišit od oprávnění vaší aplikace Animate. To má důležité dopady na zabezpečení napříč doménami.

always (vždy)

Vždy umožňuje skriptovací operace.

never (nikdy)

Zakazuje všechny skriptovací operace.

samedomain

Povoluje skriptovací operace jen v případě, že aplikace Animate pochází ze stejné domény jako stránka HTML.

Výchozí hodnota používaná všemi předlohami publikování HTML je samedomain.

Hodnota: always | never | samedomain


SeamlessTabbing, parametr

(Volitelně) Umožňuje nastavit prvek ActiveX tak, aby uživatel mohl plynule opustit aplikaci Animate stisknutím tabulátoru. Tento parametr funguje pouze ve Windows u prvků ActiveX pro Flash Player verze 7 a vyšší.

true

(nebo je vynecháno) Nastaví prvek ActiveX pro plynulé přepínání pomocí tabulátoru: Když uživatel pomocí tabulátoru přejde přes aplikaci Animate, následujícím stisknutím tabulátoru se výběr přesune mimo aplikaci Animate, a to do okolního obsahu HTML nebo na stavový řádek prohlížeče (pokud už po aplikaci Animate není možné přesunout výběr na jinou část HTML).

false

Nastaví prvek ActiveX tak, aby se choval stejně jako ve verzi 6 a starších: Jakmile uživatel pomocí tabulátoru přejde přes aplikaci Animate, následujícím stiskem tabulátoru se výběr přesune znovu na začátek aplikace Animate. V tomto režimu nelze pomocí tabulátoru přesunout výběr mimo aplikaci Animate.

Hodnota: true | false


Příklady použití objektů a vložených tagů

Co se týče tagu object, existují čtyři nastavení (height (výška), width (šířka), classid (identifikátor třídy) a codebase (báze kódu)) jsou atributy, které se uvádějí v tagu object; všechny ostatní jsou parametry, které se uvádějí v rámci samostatných, pojmenovaných tagů param, jak ukazuje následující příklad:

<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" width="100" 
height="100" codebase="http://fpdownload.adobe.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0"> 
<param name="movie" value="moviename.swf"> 
<param name="play" value="true"> 
<param name="loop" value="true"> 
<param name="quality" value="high"> 
</object>

Co se týče tagu embed, všechna nastavení (jako například height (výška), width (šířka), quality (kvalita) a loop (opakovat)) jsou atributy, které se uvádějí mezi lomenými závorkami počátečního tagu embed, jak ukazuje následující příklad:

<embed src="moviename.swf" width="100" height="100" play="true" 
loop="true" quality="high" 
pluginspage="http://www.adobe.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash"> 
</embed>

Chcete-li použít oba tagy, umístěte tag embed před koncový tag object, jak ukazuje následující příklad:

<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" width="100" 
height="100" codebase="http://fpdownload.adobe.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0"> 
<param name="movie" value="moviename.swf"> 
<param name="play" value="true"> 
<param name="loop" value="true"> 
<param name="quality" value="high"> 
<embed src="moviename.swf" width="100" height="100" play="true” 
loop="true" quality="high" 
pluginspage="http://www.adobe.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash"> 
</embed> 
</object>

Poznámka:

Pokud použijete tagy object a embed, použijte identické hodnoty pro každý atribut nebo parametr, abyste zajistili stejné přehrávání v různých vyhledávačích. Parametr swflash.cab#version=9,0,0,0 je nepovinný; vynechte ho jen v případě, že nechcete kontrolovat číslo verze.

Prohlížeče, které podporují režim bez okna

Podrobné informace o podpoře atributu WMODE ve webovém prohlížeči naleznete v tabulce v článku TechNote 12701: Flash OBJECT Tag Attributes (TechNote 12701: Atributy tagů OBJECT v aplikaci Flash).

Zadání nastavení publikování pro zjištění přehrávače Flash Player

Detekce verze Flash nakonfiguruje váš dokument, aby zjišťoval verzi přehrávače Flash Player uživatele, a případně jej přesměroval na alternativní stránku HTML, nemá-li přehrávač určený pro tento dokument. Alternativní stránka HTML obsahuje odkaz na stažení nejnovější verze přehrávače Flash Player.

Detekce přehrávače Flash Player je dostupná, jen pokud je nastavení publikování nastaveno na Flash Player 4 nebo novější a používáte soubor SWF vložený v předlohách Pouze Animate nebo HTTPS.

Poznámka:

Přehrávače Flash Player 5 a novější jsou nainstalované na 98 % počítačů připojených k internetu, takže detekce přehrávače Flash Player je vhodnou metodou, jak zajistit, že budou mít koncoví uživatelé nainstalovanou správnou verzi Animate pro přehrávání vašeho obsahu.

Následující předlohy HTML nepodporují detekci přehrávače Flash Player, protože JavaScript v těchto předlohách je v konfliktu s JavaScriptem používaným k detekci přehrávače Flash Player:

  • Animate pro PocketPC 2003

  • Animate se sledováním AICC

  • Animate s funkcí FSCommand

  • Animate s pojmenovanými kotvami

  • Animate se sledováním SCORM

Poznámka:

Předloha HTML Obrazová mapa nepodporuje detekci přehrávače, protože v ní není vložen přehrávač Flash Player.

  1. Vyberte Soubor > Nastavení publikování a v levém sloupci klepněte na kategorii HTML Wrapper.
  2. Z rozbalovací nabídky Předloha vyberte předlohu Pouze Animate nebo Animate HTTPS. Tyto předlohy podporují detekční sadu pro jednostránkový HTML. Všechny tyto předlohy umožňují zaškrtnout políčko Zjistit verzi Animate a mají textová pole pro zadání čísla verze.

  3. Vyberte zaškrtávací políčko Zjistit verzi Animate. Váš soubor SWF je vložený ve webové stránce zahrnující i kód pro detekci přehrávače Flash Player. Pokud tento detekční kód najde přijatelnou verzi přehrávače Flash Player nainstalovanou na počítači koncového uživatele, přehraje se soubor SWF správně.

  4. (Volitelně) Chcete-li přesně určit číslo verze přehrávače Flash Player, použijte textová pole Hlavní číslo verze a Vedlejší číslo verze. Určete například Flash Player verze 10.1.2, pokud obsahuje specifickou funkci, která je nezbytná pro zobrazení vašeho souboru SWF.

    Když publikujete soubor SWF, Animate vytvoří jednu stránku HTML, do které vloží soubor SWF spolu s kódem pro detekci přehrávače Flash Player. Pokud koncový uživatel nemá tu verzi Animate, kterou jste pro zobrazování tohoto souboru SWF určili, objeví se stránka HTML s odkazem na stažení nejnovější verze přehrávače Flash Player.

Nastavení publikování pro soubory GIF

Soubory GIF slouží k exportu kreseb a jednoduchých animací z Animate pro použití na webových stránkách. Standardní soubory GIF jsou komprimované bitmapy.

Animovaný soubor GIF (někdy označovaný jako GIF89a) nabízí jednoduchý způsob, jak exportovat krátké sekvence animací. Animate optimalizuje animovaný GIF tím, že ukládá jen změny mezi jednotlivými snímky.

Do statického souboru GIF vyexportuje Animate jen první snímek souboru SWF, pokud pro export neoznačíte jiný klíčový snímek tím, že inspektoru Vlastnosti zadáte popis snímku #Static. Do animovaného souboru GIF vyexportuje Animate všechny snímky otevřeného souboru SWF, pokud v příslušných klíčových snímcích neurčíte jiný rozsah snímků pro export tím, že zadáte popisy snímku #First a#Last.

Animate může vygenerovat obrazovou mapu souboru GIF, aby se u tlačítek v původním dokumentu uchovaly odkazy na URL. Pomocí inspektoru Vlastnosti umístěte popis snímku #Map do klíčového snímku, ve kterém chcete obrazovou mapu vytvořit. Pokud popis snímku nevytvoříte, Animate vytvoří obrazovou mapu s použitím tlačítek v posledním snímku souboru SWF. Obrazovou mapu vytvořte jen v případě, že vybraná předloha obsahuje proměnnou $IM.

  1. Vyberte Soubor > Nastavení publikování a v levém sloupci dialogového okna klepněte na položku Obraz GIF.
  2. Jako název souboru GIF použijte výchozí název nebo zadejte nový název s příponou .gif.
  3. Vyberte možnosti pro soubor GIF:

    Velikost

    Vyberte možnost Přizpůsobit film, aby byl obraz GIF stejné velikosti jako soubor SWF a aby se zachoval poměr stran původního obrazu, nebo zadejte hodnoty pro šířku a výšku exportovaného bitmapového obrazu v obrazových bodech.

    Přehrávání

    Určuje, zda má Animate vytvořit statický obraz (volba Statický), nebo animovaný GIF (volba Animace). Pokud vyberete Animace, zvolte Nepřetržitě opakovat nebo zadejte počet opakování.

  4. Chcete-li zadat další nastavení vzhledu exportovaného souboru GIF, rozbalte část Barvy a vyberte jednu z následujících možností:

    (Pouze CS6 a starší verze) Optimalizovat barvy

    Z tabulky barev souboru GIF odstraní všechny nepoužité barvy. Tato volba zmenší velikost souboru bez ovlivnění kvality obrazu, ale mírně zvyšuje nároky na paměť. Na adaptivní paletu nemá tato volba žádný vliv. (Adaptivní paleta analyzuje barvy v obrazu a vytvoří jedinečnou tabulku barev pro vybraný soubor GIF.)

    (Pouze CS6 a starší verze) Prokládaně

    Zobrazuje exportovaný soubor GIF v prohlížeči postupně, jak se načítá. Umožňuje, aby uživatel viděl základní grafický obsah ještě před dokončením stahování souboru, a urychluje načítání souboru při pomalém připojení k síti. Animovaný soubor GIF neprokládejte.

    Vyhladit

    Aplikuje na exportovanou bitmapu vyhlazení, což zvýší kvalitu bitmapového obrazu i zobrazení textu. Vyhlazení ale může způsobovat aureolu z šedých obrazových bodů kolem vyhlazeného obrazu umístěného na barevném pozadí a zvětšuje velikost souboru GIF. Obraz exportujte bez vyhlazení, pokud se objeví aureola nebo pokud umísťujete průhledný obraz GIF na vícebarevné pozadí.

    (Pouze CS6 a starší verze) Rozklad plných barev

    Aplikuje rozklad na plné barvy i na přechody.

    (Pouze CS6 a starší verze) Odstranit přechody

    (Ve výchozím nastavení je vypnutá) Tato volba převede všechny výplně přechodem v souboru SWF na plné barvy s použitím první barvy v přechodu. Přechody zvětšují velikost souboru GIF a často mají nízkou kvalitu. Aby při použití této volby nedocházelo k nečekaným výsledkům, pečlivě vyberte první barvu přechodu.

  5. (Pouze CS6 a starší verze) Chcete-li určit průhlednost pozadí aplikace a způsob, jakým se mají nastavení alfa převést na soubor GIF, vyberte jednu z následujících voleb průhlednosti:

    Neprůhledný

    Pozadí vybarví plnou barvou.

    Průhledný

    Zprůhlední pozadí.

    Alfa

    Nastaví částečnou průhlednost. Zadejte hodnotu Práh od 0 do 255. Čím nižší hodnota, tím větší průhlednost. Hodnota 128 odpovídá průhlednosti 50 %.

  6. (Pouze CS6 a starší verze) Chcete-li určit způsob, jakým se budou kombinovat obrazové body dostupných barev, aby simulovaly barvy, které nejsou k dispozici na aktuální paletě, vyberte možnost rozkladu barev. Rozklad barev může zlepšit kvalitu barev, ale zvyšuje velikost souboru.

    Neurčeno

    Rozklad barev vypne a barvy, které nejsou v základní tabulce barev, nahradí jinou barvou z tabulky, která se určené barvě nejvíce blíží. Vypnutí rozkladu barev může mít za následek zmenšení souboru, ale neuspokojivé barvy.

    Uspořádaný

    Poskytuje kvalitní rozklad barev při co nejmenším zvětšení velikosti souboru.

    Rozptýlený

    Poskytuje rozklad barev nejvyšší kvality, ale zvětšuje velikost souboru a prodlužuje čas potřebný k jeho zpracování. Funguje jen v případě, že je vybraná paleta 216 barev pro web.

  7. (Pouze CS6 a starší verze) Chcete-li definovat paletu barev, vyberte jeden z následujících typů palet:

    Webová (216)

    K vytvoření obrazu GIF používá paletu standardních 216 bezpečných barev pro web, která zajišťuje dobrou kvalitu obrazu a nejrychlejší zpracování na serveru.

    Adaptivní

    Analyzuje barvy v obrazu a vytvoří jedinečnou tabulku barev pro vybraný soubor GIF. Nejvhodnější je pro systémy zobrazující tisíce nebo milióny barev; umožňuje nejpřesnější barevné podání obrazu, ale zvětšuje velikost souboru. Chcete-li zmenšit velikost souboru GIF s adaptivní paletou, snižte počet barev v paletě zadáním hodnoty v poli pro maximální počet barev. Chcete-li nastavit počet barev použitých v obrázku GIF, zadejte hodnotu pro maximální počet barev. Menší počet barev může zmenšit velikost souboru, ale zároveň může dojít ke zhoršení barevného podání obrazu.

    Adaptivní s technologií Web Snap

    Tato volba je stejná jako volba palety Adaptivní, pouze s tím rozdílem, že podobné barvy převádí na paletu 216 webových barev. Výsledná paleta barev je optimalizovaná pro daný obraz, ale s tím, že bude-li to možné, použije Animate barvy z palety 216 webových barev. Díky tomu má obraz lepší barvy, když je v systému s 256 barvami aktivní webová paleta 216 barev. Chcete-li nastavit počet barev použitých v obrázku GIF, zadejte hodnotu pro maximální počet barev. Menší počet barev může zmenšit velikost souboru, ale zároveň může dojít ke zhoršení barevného podání obrazu.

    Vlastní

    Určuje paletu, kterou jste optimalizovali pro vybraný obraz. Vlastní paleta se zpracovává stejně rychle jako paleta 216 webových barev. Chcete-li použít tuto volbu, seznamte se s postupem vytváření a používání vlastních palet. Chcete-li vybrat některou vlastní paletu, klepněte na ikonu složky Paleta (ikona složky zobrazená na konci textového pole Paleta) a vyberte soubor palety. Animate podporuje palety uložené ve formátu ACT, jaké exportují některé grafické aplikace.

Nastavení publikování pro soubory JPEG

Formát JPEG umožňuje publikovat soubor FLA jako vysoce komprimovanou 24bitovou bitmapu. Obecně je formát GIF vhodnější pro export čárové grafiky a formát JPEG pro obrazy se spojitými tóny, jako jsou fotografie, přechody nebo vložené bitmapy.

Animate vyexportuje do souboru JPEG první snímek souboru SWF, pokud zadáním popisu snímku #Static na časové ose neoznačíte pro export jiný klíčový snímek.

  1. Vyberte Soubor > Nastavení publikování a v levém sloupci vyberte položku Obraz JPEG.
  2. Jako název souboru JPEG použijte výchozí název nebo zadejte nový název s příponou .jpg.
  3. Vyberte možnosti pro soubor JPEG:

    Velikost

    Vyberte možnost Přizpůsobit film, aby byl obraz JPEG stejné velikosti jako vymezená plocha a aby se zachoval poměr stran původního obrazu, nebo zadejte hodnoty pro šířku a výšku exportovaného bitmapového obrazu v obrazových bodech.

    Kvalita

    Nastavte jezdec nebo zadejte hodnotu určující míru komprese souboru JPEG. Čím nižší kvalita, tím menší velikost souboru a naopak. Abyste zjistili nejlepší kompromis mezi velikostí a kvalitou, vyzkoušejte různá nastavení.

    Poznámka: Chcete-li změnit nastavení komprese objektu, použijte dialogové okno Vlastnosti bitmapy a v něm nastavte kvalitu exportu bitmap pro jednotlivé objekty. Výchozí nastavení komprese v dialogovém okně Vlastnosti bitmapy aplikuje nastavení volby Kvalita JPEG z okna Nastavení publikování.

    Postupný

    V prohlížeči se při použití této volby obrazy JPEG zobrazují postupně tak, jak se načítají, takže je uživatel i při pomalém připojení k síti vidí dříve. Je to podobné jako prokládání v obrazech GIF a PNG.

  4. Klikněte na tlačítko OK.

Nastavení publikování pro soubory PNG

PNG je jediný bitmapový formát pro přenos mezi platformami, který podporuje průhlednost (alfa kanál). Je to zároveň nativní formát souborů pro aplikaci Adobe® Fireworks®.

Animate do souboru PNG vyexportuje první snímek souboru SWF, pokud zadáním popisu snímku #Static na časové ose neoznačíte pro export jiný klíčový snímek.

  1. Vyberte Soubor > Nastavení publikování a v levém sloupci vyberte položku Obraz PNG.
  2. Jako název souboru PNG použijte výchozí název nebo zadejte nový název s příponou .png.
  3. Pokud chcete, aby byl obraz PNG stejné velikosti jako soubor SWF a aby se zachoval poměr stran původního obrazu, vyberte možnost Přizpůsobit film, nebo zadejte pro exportovanou bitmapu hodnoty pro šířku a výšku v obrazových bodech.
  4. Pro bitovou hloubku nastavte požadovaný počet bitů na obrazový bod a počet barev, jaký se má použít k vytvoření obrazu. Čím vyšší bitová hloubka, tím větší bude soubor.

    8bitový

    na kanál (bpc) pro obraz v 256 barvách

    24bitový

    pro tisíce barev

    24bitový s kanálem alfa

    pro tisíce barev s průhledností (32 bitů na kanál)

  5. K nastavení požadovaného vzhledu exportovaného souboru PNG použijte následující volby:

    (Pouze CS6 a starší verze) Optimalizovat barvy

    Z tabulky barev souboru PNG odstraní všechny nepoužité barvy, čímž se sníží velikost souboru o 1000 až 1500 bajtů bez ovlivnění kvality obrazu, ale mírně se tím zvýší nároky na paměť. Na adaptivní paletu nemá tato volba žádný vliv.

    (Pouze CS6 a starší verze) Prokládaně

    Zobrazuje exportovaný soubor PNG v prohlížeči postupně, jak se načítá. Umožňuje, aby uživatel viděl základní grafický obsah ještě před dokončením stahování souboru, a urychluje načítání souboru při pomalém připojení k síti. Animovaný soubor PNG neprokládejte.

    Vyhladit

    Aplikuje na exportovanou bitmapu vyhlazení, což zvýší kvalitu bitmapového obrazu i zobrazení textu. Vyhlazení ale může způsobovat aureolu z šedých obrazových bodů kolem vyhlazeného obrazu umístěného na barevném pozadí a zvětšuje velikost souboru PNG. Obraz exportujte bez vyhlazení, pokud se objeví aureola nebo pokud umísťujete průhledný obraz PNG na vícebarevné pozadí.

    (Pouze CS6 a starší verze) Rozklad plných barev

    Aplikuje rozklad barev na plné barvy a přechody.

    (Pouze CS6 a starší verze) Odstranit přechody

    (Ve výchozím nastavení je vypnutá) Tato volba převede všechny výplně přechodem v aplikaci na plné barvy s použitím první barvy v přechodu. Přechody zvětšují velikost souboru PNG a často mají nízkou kvalitu. Aby při použití této volby nedocházelo k nečekaným výsledkům, pečlivě vyberte první barvu přechodu.

  6. (Pouze CS6 a starší verze) Pokud jste jako bitovou hloubku vybrali 8 bitů na kanál, výběrem některé volby z nabídky Rozklad barev určete, jak se mají obrazové body dostupných barev míchat, aby simulovaly barvy, které nejsou k dispozici na aktuální paletě. Rozklad barev může zlepšit kvalitu barev, ale zvětšuje velikost souboru. Vyberte některou z následujících voleb:

    Neurčeno

    Rozklad barev vypne a barvy, které nejsou v základní tabulce barev, nahradí jinou barvou z tabulky, která se určené barvě nejvíce blíží. Vypnutí rozkladu barev může mít za následek zmenšení souboru, ale neuspokojivé barvy.

    Uspořádaný

    Poskytuje kvalitní rozklad barev při co nejmenším zvětšení velikosti souboru.

    Rozptýlený

    Poskytuje rozklad barev nejvyšší kvality, ale zvětšuje velikost souboru a prodlužuje čas potřebný k jeho zpracování. Funguje také jen v případě, že je vybraná paleta 216 barev pro web.

  7. (Pouze CS6 a starší verze) Pokud jste jako bitovou hloubku vybrali 8 bitů na kanál, výběrem jednoho z následujících typů palet definujte paletu barev pro obraz PNG:

    Webová (216)

    K vytvoření obrazu PNG používá paletu standardních 216 bezpečných barev pro webové prohlížeče, která zajišťuje dobrou kvalitu obrazu a nejrychlejší zpracování na serveru.

    Adaptivní

    Analyzuje barvy v obrazu a vytvoří jedinečnou tabulku barev pro vybraný soubor PNG. Nejvhodnější je pro systémy zobrazující tisíce nebo milióny barev; umožňuje nejpřesnější barevné podání obrazu, ale velikost výsledného souboru je větší než u souboru PNG vytvořeného s použitím palety 216 barev.

    Adaptivní s technologií Web Snap

    Tato volba je stejná jako volba palety Adaptivní, pouze s tím rozdílem, že podobné barvy převádí na bezpečnou paletu 216 webových barev. Výsledná paleta barev je optimalizovaná pro daný obraz, ale s tím, že bude-li to možné, použije Animate barvy z palety 216 webových barev. Díky tomu má obraz lepší barvy, když je aktivní bezpečná webová paleta 216 barev na systému s 256 barvami. Chcete-li zmenšit velikost souboru PNG s adaptivní paletou, snižte počet barev v paletě zadáním hodnoty v poli Max. počet barev.

    Vlastní

    Určuje paletu, kterou jste optimalizovali pro vybraný obraz. Vlastní paleta se zpracovává stejně rychle jako bezpečná paleta 216 webových barev. Chcete-li použít tuto volbu, seznamte se s postupem vytváření a používání vlastních palet. Chcete-li vybrat některou vlastní paletu, klepněte na ikonu složky Paleta (ikona složky zobrazená na konci textového pole Paleta) a vyberte soubor palety. Animate podporuje palety uložené ve formátu ACT, jaké exportují přední grafické aplikace.

  8. (Pouze CS6 a starší verze) Pokud jste vybrali paletu Adaptivní nebo Adaptivní s technologií Web Snap, zadáním hodnoty Maximální počet barev určete, kolik barev má obrázek PNG používat. Menší počet barev může zmenšit velikost souboru, ale zároveň může dojít ke zhoršení barevnosti.

  9. (Pouze CS6 a starší verze) Chcete-li vybrat metodu filtrování po jednotlivých řádcích, aby bylo možné soubor PNG více komprimovat, a chcete-li u konkrétního obrazu experimentovat s různými volbami, vyberte jednu z následujících voleb filtrování:

    Neurčeno

    Tato volba filtrování vypne.

    Dolů

    Přenese rozdíl mezi každým bajtem a hodnotou odpovídajícího bajtu předchozího obrazového bodu.

    Nahoru

    Přenese rozdíl mezi každým bajtem a hodnotou odpovídajícího bajtu obrazového bodu ležícího těsně nad daným obrazovým bodem.

    Průměr

    K odhadu hodnoty obrazového bodu použije průměr dvou sousedních obrazových bodů (vlevo a nahoře).

    Cesta

    Vypočítá jednoduchou lineární funkci tří sousedních obrazových bodů (vlevo, nahoře a vlevo nahoře) a jako nástroj pro odhad barvy obrazového bodu vybere ten sousední obrazový bod, který se nejvíce blíží vypočtené hodnotě.

    Adaptivní

    Analyzuje barvy v obrazu a vytvoří jedinečnou tabulku barev pro vybraný soubor PNG. Nejvhodnější je pro systémy zobrazující tisíce nebo milióny barev; umožňuje nejpřesnější barevné podání obrazu, ale velikost výsledného souboru je větší než u souboru PNG vytvořeného s použitím palety 216 barev. Velikost souboru PNG vytvořeného s použitím adaptivní palety můžete zmenšit snížením počtu barev v paletě.

Nastavení publikování pro export OAM

Obsah aplikace Animate ve formátech ActionScript, WebGL nebo HTML5 Canvas teď můžete exportovat do animovaných souborů ovládacích prvků OAM (.oam). Soubory OAM generované z aplikace Animate se dají vložit do aplikací Dreamweaver, Muse a InDesign. Při exportu obsahu Animate do formátu OAM postupujte následujícím způsobem:

  1. Klikněte na Soubor > Nastavení publikování.

  2. Na levém panelu dialogového okna Nastavení publikování vyberte možnost OAM.

    OAM1
    Nastavení formátu OAM

  3. V poli Výstupní soubor vyberte umístění a zadejte název balíčku.

  4. V části Obrázek plakátu vyberte jednu z následujících možnosti:

    • Pokud chcete generovat balíček OAM z obsahu aktuálního snímku, vyberte možnost Generovat z aktuálního snímku (PNG). Chcete-li generovat transparentní obrázek PNG, vyberte možnost Transparentní.
    • Pokud chcete generovat OAM z jiného souboru, zadejte cestu k souboru do pole Použít tento soubor.
    • Chcete-li generovat průhledné soubory OAM, nastavte průhledné pozadí plochy a publikujte soubor OAM. Další informace o nastavení pozadí plochy získáte v tématu Průhlednost plátna.
    • Chcete-li generovat responzivní soubory OAM, nastavte responzivní chování v dialogovém okně Nastavení publikování. Další informace o nastavení responzivního chování najdete v tématu Responzivní změny velikosti.
  5. Klikněte na tlačítko Publikovat. Balíček OAM můžete zobrazit v uloženém umístění.

Zobrazování náhledů formátu a nastavení publikování

Příkaz Náhled publikování vyexportuje soubor a otevře náhled ve výchozím prohlížeči. Když zobrazíte náhled videa QuickTime, příkaz Náhled publikování spustí přehrávač videa QuickTime. Když zobrazíte náhled projektoru, Animate spustí projektor.

  1. Zvolte Soubor > Náhled publikování a vyberte požadovaný formát souboru pro náhled.

    Animate s použitím aktuálních hodnot Nastavení publikování vytvoří soubor určeného typu se stejným umístěním jako soubor FLA. Tento soubor zůstane na tomto místě, dokud ho nepřepíšete nebo nesmažete.

    Poznámka:

    Když soubor FLA vytvořený v Animate CC otevřete v aplikaci Flash Professional CS6, pak se nastavení publikování pro pole, která v Animate CC nejsou dostupná, změní na výchozí hodnoty.

Používání profilů publikování

Profily publikování umožňují:

  • Uložit konfiguraci nastavení publikování, exportovat ji a importovat profil publikování do jiných dokumentů nebo ho poskytnout k použití jiným uživatelům.

  • Importovat profily publikování, které chcete použít ve svém dokumentu.

  • Vytvářet profily pro publikování v několika různých formátech médií.

  • Vytvořit profil publikování pro interní použití, které se liší od způsobu, jakým byste soubory publikovali pro klienta.

  • Vytvořit standardní profil publikování pro vaši společnost, který zajistí, že budou soubory publikovány jednotně.

Profily publikování se ukládají spíše na úrovni dokumentu než na úrovni aplikace.

Vytvoření profilu publikování

  1. V dialogovém okně Nastavení publikování klepněte na nabídku Možnosti profilu a zvolte možnost Vytvořit profil.
  2. Profil publikování pojmenujte a klepněte na OK.
  3. Určete nastavení publikování pro dokument a klepněte na tlačítko OK.

Duplikování, úpravy a smazání profilu publikování

  1. Z rozbalovací nabídky Profil v dialogovém okně Nastavení publikování (Soubor > Nastavení publikování) vyberte požadovaný profil publikování:
    • Chcete-li vytvořit duplicitní profil, klepněte na nabídku Možnosti profilu a zvolte možnost Duplikovat profil. Profil pojmenujte v textovém poli Název duplikátu a klepněte na OK.
    • Chcete-li změnit profil publikování, vyberte jej z nabídky Profil, určete nové nastavení publikování pro daný dokument a klepněte na tlačítko OK.
    • Chcete-li odstranit profil publikování, klepněte na nabídku Možnosti profilu a zvolte možnost Odstranit profil. Pak klepněte na tlačítko OK.

Export profilu publikování

  1. Vyberte Soubor > Nastavení publikování, klikněte na nabídku Možnosti profilu a zvolte možnost Exportovat profil.

  2. V nabídce Možnosti profilu vyberte možnost Exportovat profil. Vyexportujte profil publikování jako soubor APR, který lze importovat do jiných dokumentů.

  3. Potvrďte výchozí umístění pro uložení profilu publikování nebo přejděte do nového umístění a klikněte na tlačítko Uložit.

Import profilu publikování

Poznámka:

Import profilů publikování ve formátu XML je zastaralý a není doporučován. Profily publikování jsou nyní exportovány pouze ve formátu APR.

Jiní uživatelé mohou vytvořit a exportovat profily publikování, které můžete importovat a vybrat jako volbu nastavení publikování.

  1. Vyberte Soubor > Nastavení publikování, klikněte na nabídku Možnosti profilu a zvolte možnost Importovat profil.

  2. Vyhledejte soubor APR s profilem publikování a klikněte na tlačítko Otevřít.

Vlastní šablony HTML5

Aplikace Animate CC podporuje vlastní šablony pro soubor HTML Wrapper během publikování projektů HTML5 Canvas. Můžete použít výchozí šablonu, importovat vlastní soubor šablony HTML nebo exportovat stávající šablonu do externího souboru.

Můžete použít následující možnosti:

  • Použít výchozí: Použijte ke generování souboru HTML Wrapper během publikování výchozí šablonu.
  • Importovat nové: Importujte vlastní šablonu, na základě které je při publikování vytvořen soubor HTML Wrapper.
  • Export: Exportujte stávající šablonu použitou pro publikování.

Vytvoření vlastní šablony

Exportujte výchozí šablonu, změňte ji a importujte pro publikování výstupu plátna s provedenými úpravami. Změněná (vlastní) šablona by měla obsahovat všechny řetězce (vysvětlené ve výchozí šabloně), které jsou ve výchozí šabloně.

Připojení šablony k profilu publikování

Šablony HTML5 Canvas nyní můžete připojit ke svým profilům publikování pro efektivní vytvoření obsahu HTML5, který je konzistentní.  Postup přidání existující šablony do profilu:

  1. Klikněte na možnosti Soubor > Nastavení publikování.
  2. V dialogovém okně Nastavení publikování vyberte kartu Další volby.
  3. V poli Profil vyberte profil, do kterého chcete importovat a přidat novou šablonu.
  4. Klikněte na možnost Importovat nové, vyberte šablonu a klikněte na tlačítko Otevřít.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online