Začínáme s jazykem ActionScript

Skriptovací jazyk ActionScript® umožňuje do aplikací přidávat složitou interaktivitu, ovládání přehrávání a zobrazování dat. ActionScript můžete přidávat ve vývojovém prostředí pomocí panelu Akce, okna Skript, nebo v externím editoru.

ActionScript má vlastní syntaktická pravidla, vyhrazená slova a pro ukládání a načítání informací umožňuje používat proměnné. ActionScript zahrnuje velkou knihovnu vestavěných tříd, které umožňují vytvářet objekty pro provádění mnoha užitečných úloh. Další informace o jazyce ActionScript najdete v následujících dokumentech nápovědy:

Ke skriptování není nutné pochopit každý element jazyka ActionScript. Pokud máte jasný cíl, můžete začít vytvářet skripty s jednoduchými akcemi.

ActionScript i JavaScript jsou odvozené od standardu ECMA-262, mezinárodního standardu pro skriptovací jazyky ECMAScript. Proto by vývojářům, kteří znají JavaScript, měl být ActionScript okamžitě srozumitelný. Více informací o standardu ECMAScript najdete na webových stránkách ecma-international.org.

Společnost Adobe doporučuje...

Společnost Adobe doporučuje...

Jakou verzi ActionScriptu můžete používat?

Aplikace Animate obsahuje několik verzí ActionScriptu, aby splňovala požadavky různých skupin vývojářů a různého hardwaru. Jazyky ActionScript 3.0 a 2.0 nejsou vzájemně kompatibilní.

 

  • ActionScript 3.0 se provádí velmi rychle. Tato verze vyžaduje větší znalosti pojmů objektově orientovaného programování než jiné verze jazyka ActionScript. ActionScript 3.0 plně vyhovuje specifikaci ECMAScript, nabízí lepší zpracování XML, vylepšený model událostí a vylepšenou architekturu pro práci s obrazovkovými elementy. Soubory FLA, které používají ActionScript 3.0, nemohou obsahovat starší verze ActionScriptu.

  • (Zastaralé pouze v aplikaci Animate CC) Jazyk ActionScript 2.0 je na čtení jednodušší než jazyk ActionScript 3.0. Ačkoli v aplikaci Animate běží kompilovaný kód ActionScript 2.0 pomaleji než kompilovaný kód ActionScript 3.0, je ActionScript 2.0 stále užitečný pro celou řadu projektů. ActionScript 2.0 lze také využít pro projekty, které nejsou náročné na výpočetní prostředky. Může jít například o obsah, který se spíše orientuje na design. Jazyk ActionScript 2.0 je také založen na specifikaci ECMAScript, ale není s ní zcela kompatibilní.

  • (Zastaralé v aplikaci Animate CC) ActionScript 1.0 je nejjednodušší forma jazyka ActionScript, která se stále používá v některých verzích přehrávače Adobe Flash Lite Player. ActionScript 1.0 a 2.0 mohou existovat dohromady v jednom souboru FLA.

  • (Zastaralé v aplikaci Animate CC) Flash Lite 2.x ActionScript je podmnožina jazyka ActionScript 2.0, kterou podporuje systém Flash Lite 2.x používaný v mobilních telefonech a zařízeních.

  • (Zastaralé v aplikaci Animate CC) Flash Lite 1.x ActionScript je podmnožina jazyka ActionScript 1.0, kterou podporuje systém Flash Lite 1.x používaný v mobilních telefonech a zařízeních.

 

Používání dokumentace k ActionScriptu

Protože existuje více verzí jazyka ActionScript (2.0 a 3.0) a celá řada způsobů, jak jej začlenit do souborů FLA, existují i různé postupy, jak se ActionScript naučit.

Můžete nalézt popis grafického uživatelského rozhraní pro práci s jazykem ActionScript. Rozhraní zahrnuje panel Akce, okno Skript, režim Skriptovací asistent, panel Chování, panel Výstup a panel Chyby kompilátoru. Tato témata platí pro všechny verze jazyka ActionScript.

Z další dokumentace k ActionScriptu od společnosti Adobe se dozvíte více o jednotlivých verzích jazyka ActionScript.

Způsoby práce s ActionScriptem

Existuje několik způsobů, jak pracovat s ActionScriptem.

  • (Zastaralé v aplikaci Animate CC) V režimu Skriptovací asistent můžete přidávat jazyk ActionScript do souboru FLA, aniž byste museli sami psát kód. Vybíráte požadované akce a software zobrazuje pro každou akci uživatelské rozhraní pro zadání potřebných parametrů. Je potřeba mít alespoň základní znalosti o tom, které funkce použít k provádění požadovaných úloh, ale nemusíte se učit syntaxi. Tento režim používá mnoho návrhářů a jiných uživatelů, kteří nejsou programátory.

  • (Zastaralé v aplikaci Animate CC) Chování umožňují také přidávat kód do souboru, aniž byste jej museli sami psát. Chování jsou předpřipravené skripty pro běžné úlohy. Můžete přidat chování a pak ho snadno nakonfigurovat v panelu Chování. Chování jsou dostupná pouze pro ActionScript 2.0 a starší.

  • Psaní vlastního ActionScriptu vám poskytuje největší míru pružnosti a kontroly nad dokumentem, ale vyžaduje, abyste se seznámili s jazykem a pravidly ActionScriptu.

  • Komponenty jsou předem vytvořené filmové klipy, které vám umožní implementovat složité funkce. Komponenta může být jednoduchý prvek uživatelského rozhraní, například zaškrtávací pole, nebo to může být složitý ovládací prvek, například rolovací panel. Můžete upravovat vzhled a funkčnost komponent a stahovat komponenty vytvořené jinými vývojáři. Většina komponent vyžaduje, abyste napsali kód jazyka ActionScript, který komponentu spouští nebo ovládá. Další informace najdete v dokumentu Používání komponent jazyka ActionScript 3.0.

 

Psaní ActionScriptu

Když píšete kód ActionScriptu ve vývojovém prostředí, používáte panel Akce nebo okno Skript. Panel Akce a okno Skript obsahují plnohodnotný editor kódu, který zahrnuje rady pro psaní kódu, barevné zvýrazňování kódu, formátování kódu, zvýrazňování syntaxe, ladění, čísla řádků, zalamování řádků a podporu kódování Unicode.

  • Když píšete skripty, které jsou součástí dokumentu Animate (tzn. skripty vložené v souboru FLA), použijte panel Akce. Panel Akce obsahuje funkce, jako je panel nástrojů Akce, který poskytuje rychlý přístup k základním prvkům jazyka ActionScript. Při vytváření skriptů se zobrazují dotazy na potřebné prvky.

  • Použijte okno Skript, když chcete psát externí skripty – tedy skripty nebo třídy uložené v externích souborech. (K vytvoření externího souboru AS můžete použít také textový editor.) Okno Skript zahrnuje pomocné funkce pro psaní kódu, jako jsou rady pro psaní kódu, barevné zvýrazňování kódu, kontrola syntaxe a automatické formátování.

Další doporučený obsah z komunity

Následující články a výukové lekce obsahují další podrobné informace o používání jazyka ActionScript:

Přehled panelu Výstup

Při práci s libovolným typem dokumentu se na panelu Výstup zobrazují informace nebo varování týkající se různých operací, například převodu dokumentů nebo publikování. Chcete-li tyto informace zobrazovat, přidejte do kódu příkazy trace() nebo použijte příkazy Zobrazit seznam objektů nebo Zobrazit seznam proměnných.

Pokud ve skriptech používáte příkaz trace(), můžete při běhu souboru SWF posílat do panelu Výstup konkrétní informace. Ty zahrnují poznámky o stavu souboru SWF nebo hodnoty výrazů.  

Output_panel
Panel Výstup

Panel Výstup obsahuje následující položky nabídky:

  • Kopírovat: Zkopíruje celý obsah panelu Výstup do schránky počítače. Chcete-li zkopírovat jen část výstupu, vyberte požadovanou oblast, a pak vyberte Kopírovat.
  • Vymazat: Vymaže obsah panelu Výstup.
  • Zobrazit výstup: Zobrazí obsah panelu Výstup.
  • Zamknout: Zamkne panel. Následně můžete pouze měnit velikost panelu, nemůžete jej však přesouvat ani přetahovat. 
  • Nápověda: Načte online nápovědu pro panel Výstup.
  • Zavřít: Zavře panel Výstup.
  • Zavřít skupinu: Zavře celou skupinu panelů. Umožňuje zavřít více panelů najednou, například panely Časová osa, Výstup a Chyby kompilátoru.

Chcete-li zobrazit nebo skrýt panel Výstup, vyberte Okno > Výstup nebo stiskněte klávesu F2.

Panel Akce

Hledáte referenční příručky k jazyku?

Chcete-li najít referenční dokumentaci pro určitý element jazyka ActionScript, proveďte jeden z následujících úkonů:

Poznámka:

Pokud chcete místo nápovědy komunity otevřít nápovědu ve webovém prohlížeči, přečtěte si tento článek: http://kb2.adobe.com/community/publishing/916/cpsid_91609.html.

Jak se naučit jazyk ActionScript

Informace o psaní skriptů ActionScript naleznete v následujících zdrojích:

Poznámka:

Jazyky ActionScript 3.0 a 2.0 nejsou vzájemně kompatibilní. Pro každý soubor FLA vyberte pouze jednu verzi.

Přehled panelu Akce

Chcete-li vytvořit skripty vložené v souboru FLA, zadejte ActionScript přímo do panelu Akce (Okno > Akce nebo stiskněte klávesu F9).

actions-frame-view
Panel Akce

Panel Akce se skládá ze dvou podoken:

Dílčí panel Skript

Umožňuje psát kód ActionScript, který je přiřazen aktuálně vybranému snímku.

Navigátor skriptů

Zobrazuje seznam skriptů v dokumentu Animate a umožňuje mezi nimi rychle přecházet. Kliknutím na položku v navigátoru skriptů zobrazíte vybraný skript na panelu Skript.

Panel Akce nabízí přístup k funkcím nápovědy při psaní kódu, které zjednodušují a zefektivňují programování v jazyce ActionScript. Tato funkce umožňuje v aplikaci Animate přidávat globální skripty a skripty třetích stran, které nejsou vázány na konkretní snímek animace, a poté je použít na celou animaci. Další informace naleznete v části Přidávání globálních skriptů askriptů třetíchstran na této stránce.

  • Spustit skript: Spustí zvolený skript.
  • Přidržet skript: Umožňuje připínat skripty ke kartám jednotlivých skriptů na panelu Skript a podle potřeby je přesouvat. Tato funkce se hodí, když v rámci souboru FLA nemáte všechen kód uspořádaný do jednoho centrálního umístění nebo pokud používáte víc skriptů najednou. Přidržením skriptu uložíte aktuální umístění kódu na panelu Akce a budete moct přepínat mezi různými otevřenými skripty. To se hodí při ladění.
  • Vložit cestu a název instance: Nastaví u akce ve skriptu absolutní nebo relativní cílovou cestu.
  • Hledat: Vyhledá a nahradí text ve skriptu.
  • Formátovat kód: Umožňuje formátovat kód.
  • Fragmenty kódu: Otevře panel Fragmenty kódu, na kterém se zobrazují dostupné fragmenty kódu.
  • Přidat průvodcem: Kliknutím na toto tlačítko vyvoláte jednoduchého průvodce, který vám umožní přidávat akce bez nutnosti psaní kódu.
  • Nápověda: Zobrazí referenční informace o prvku jazyka ActionScript, který máte vybraný v podokně Skript. Například když kliknete na nějaký příkaz sloužící k importu a pak kliknete na Nápověda, zobrazí se na panelu Nápověda referenční informace k importu.

Průvodce kódy akcí

Přidejte do svých kompozic HTML5 interaktivní prvky pomocí funkce Přidat průvodcem, která je dostupná v panelu Akce. Funkce Přidat průvodcem nabízí zjednodušené uživatelské rozhraní pro přidávání kódu do vašich kompozic.

Video zobrazující přidávání kódu pomocí průvodce kódy akcí.

  1. Vytvořte dokument HTML5 Canvas a klikněte na Okno > Akce.

  2. Klikněte na tlačítko Přidat průvodcem v panelu Akce. Viz následující snímek obrazovky.

    addusingwizard-button
    Panel Akce s tlačítkem Přidat průvodcem
  3. V průvodci vyberte akci, pro kterou chcete vytvořit kód.

    Vzorový snímek obrazovky zobrazující možnosti průvodce kódy akcí pro akce

    Na výše uvedeném snímku obrazovky je vybrána akce Získat číslo snímku a v okně akce je zobrazen aktualizovaný kód pro tuto akci.

    V závislosti na vybraném typu akce můžete také vybrat odpovídající objekt, pro který chcete akci použít. Pokud má objekt název instance, můžete jej vyhledat na ploše. Akci můžete také použít na současný výběr. 

    actions-code-currentselection
    Seznam objektů, pro které chcete použít akci
  4. Klikněte na tlačítko Další a zvolte událost spuštění. V závislosti na akci a objektu, které jste vybrali v předchozích krocích, je v okně k dispozici určitá sada událostí spuštění.

    action-trigger
    Seznam událostí spuštění
  5. Zvolte požadovanou událost spuštění a odpovídající objekt spuštění, pokud existuje, a potom klikněte na tlačítko Dokončit a přidat .

Při výběru objektu na ploše a spuštění průvodce kódy akcí si můžete v nabídce vybrat položku Aktuální výběr . Nebo si při tvorbě kódu můžete vybrat časovou osu a komponenty akce.

Používání okna Skript

V okně Skript můžete vytvářet soubory externích skriptů, které pak importujete do své aplikace. Tyto skripty mohou být soubory jazyka ActionScript nebo soubory jazyka JavaScript pro aplikaci Animate.

Můžete také přidávat globální skripty a skripty třetích stran do dokumentů HTML5 Canvas. Další informace najdete v části Přidávání globálních skriptů a skriptů třetích stran v tématu Vytváření a publikování dokumentů HTML5 Canvas v aplikaci Animate CC.

actions-add-script
Okno Skript

Pokud máte otevřeno více externích souborů, názvy souborů se zobrazují na kartách v horní části okna.

V okně Skript můžete používat přidržení skriptu, hledání a nahrazení, barevné zvýrazňování syntaxe, formátování kódu, návrhy při psaní kódu, komentáře v kódu, sbalení kódu, možnosti ladění (pouze soubory ActionScript) a zalamování řádků. V okně Skript můžete zobrazit také čísla řádků a skryté znaky.

Vytvoření externího souboru v okně Skript

  1. Vyberte nabídku Soubor > Nový.

    Nový dokument
    Nový dokument
  2. Zvolte si záměr podle vlastního výběru z karet v horní části obrazovky, jako jsou Animace postav, Sociální média, Hry, Vzdělávání, Reklamy, Web a Další volby. Vyberte typ externího souboru, který chcete vytvořit (soubor jazyka ActionScript nebo soubor jazyka JavaScript pro aplikaci Animate).

Úpravy existujícího souboru v okně Skript

  • Chcete-li otevřít existující skript, vyberte Soubor > Otevřít a pak otevřete existující soubor AS.

  • Pokud chcete upravit skript, který je už otevřený, klikněte na kartu dokumentu, na které je uveden název skriptu.

Nástroje v panelu Akce a v okně Skript

Na panelu Akce se zobrazují funkce pro pomoc s psaním kódu, které zjednodušují a urychlují programování v jazyce ActionScript.

Hledat 

Vyhledá a nahradí text ve skriptu.

 

Vložit cílovou cestu 

(Pouze panel Akce) Pomáhá nastavit absolutní nebo relativní cílovou cestu pro akci ve skriptu.

 

Nápověda 

Zobrazuje referenční informace o elementu jazyka ActionScript, který je vybraný v panelu Skript. Když například kliknete na příkaz import a pak kliknete na tlačítko Nápověda, zobrazí se pro příkaz import referenční informace na panelu Nápověda.

 

Fragmenty kódu

Slouží k otevření panelu Fragmenty kódu, kde se zobrazují ukázkové fragmenty kódu.

 

Přidat průvodcem

Umožňuje přidat kód pro akce pomocí rozhraní bez nutnosti psaní kódu. 

Přístup ke kontextově závislé nápovědě z panelu Akce

  1. Chcete-li vybrat určitou položku jako referenční, proveďte libovolný z následujících úkonů:
    • Vyberte termín jazyka ActionScript v okně panelu nástrojů v panelu Akce (na levé straně panelu Akce).

    • Vyberte některý výraz jazyka ActionScript v okně Skript v panelu Akce.

    • Před některý výraz jazyka ActionScript v okně Skript v panelu Akce umístěte textový kurzor.

  2. Chcete-li otevřít referenční stránku panelu Nápověda pro vybranou položku, proveďte jeden z následujících úkonů:
    • Stiskněte F1.

    • Klepněte na položku pravým tlačítkem a vyberte Zobrazit nápovědu.

    • Nad oknem Skript klikněte na tlačítko Nápověda .

Nastavení předvoleb jazyka ActionScript

Můžete nastavit nebo upravit jen jednu sadu předvoleb bez ohledu na to, jestli upravujete kód na panelu Akce nebo v okně Skript.

  1. Vyberte Upravit > Předvolby (Windows) nebo Animate > Předvolby (Mac) a v seznamu Kategorie vyberte Editor kódu.

  2. Nastavte libovolný počet těchto předvoleb:

    Automatické odsazení

    Když je zapnuté automatické odsazování, text, který zadáte za počáteční závorkou „(“, se automaticky odsadí podle nastavení Velikost tabulátoru. Toto chování lze také použít, když použijete počáteční složenou závorku „{“.

    Velikost tabulátoru

    Určuje počet znaků odsazení nového řádku.

    Rady při psaní kódu

    Zapne na panelu Skript rady při psaní kódu.

    Zpoždění

    Určuje zpoždění (v sekundách) před zobrazením rad při psaní kódu. Tato možnost je v aplikaci Animate CC zastaralá.

    Písmo

    Určuje písmo použité pro skript.

    Otevřít/importovat

    Určuje kódování znaků, které se používá k otevírání nebo importu souborů ActionScriptu.

    Uložit/exportovat

    Určuje kódování znaků, které se používá k ukládání nebo exportu souborů ActionScriptu.

    Znovu načíst změněné soubory

    Určuje, co se má stát, když je soubor skriptu upraven, přesunut nebo odstraněn. Vyberte Vždy, Nikdy nebo Dotaz.

    Vždy

    Nezobrazí se žádné upozornění a soubor se automaticky znovu načte.

    Nikdy

    Nezobrazí se žádné upozornění a soubor zůstane v aktuálním stavu.

    Dotaz

    (Výchozí) Zobrazí se upozornění a vy můžete zvolit, zda chcete soubor znovu načíst.

    Když vytváříte aplikace s externími skripty, pomáhá tato předvolba zabránit přepsání skriptu, nebo zabraňuje publikování aplikace se staršími verzemi skriptů. Upozornění vám umožňuje automaticky zavřít skript a znovu otevřít novější upravenou verzi.

    Barvy syntaxe

    Určuje barevné zvýraznění kódu ve skriptech.

    Nastavení ActionScriptu 3.0

    Tato tlačítka otevírají dialogová okna Nastavení jazyka ActionScript, která slouží k nastavení zdrojové cesty, cesty knihovny a cesty externí knihovny pro jazyk ActionScript 3.0.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online