Příručka uživatele Zrušit

Transformace a kombinování grafických objektů v aplikaci Animate

  1. Příručka uživatele aplikace Adobe Animate
  2. Úvod do aplikace Animate
    1. Novinky v aplikaci Animate
    2. Grafický glosář
    3. Systémové požadavky pro aplikaci Animate
    4. Klávesové zkratky aplikace Animate
    5. Práce s různými typy souborů v aplikaci Animate
  3. Animace
    1. Základy animování v aplikaci Animate
    2. Používání snímků a klíčových snímků v aplikaci Animate
    3. Animace po jednotlivých snímcích v aplikaci Animate
    4. Práce s animacemi klasických doplnění v aplikaci Animate
    5. Nástroj Štětec
    6. Vodítko pohybu
    7. Doplnění pohybu a ActionScript 3.0
    8. O animacích s doplněními pohybu
    9. Animace s doplněním pohybu
    10. Vytvoření animace s doplněním pohybu
    11. Používání klíčových snímků vlastností
    12. Animování polohy pomocí doplnění
    13. Úpravy doplnění pohybu v editoru pohybu
    14. Úpravy cesty pohybu u animace s doplněním
    15. Úpravy doplnění pohybu
    16. Přidání vlastního náběhu nebo doběhu
    17. Vytváření a aplikování přednastavení pohybu
    18. Nastavení rozsahu doplnění animace
    19. Práce s doplněními pohybu uloženými jako soubory XML
    20. Srovnání doplnění pohybu a klasických doplnění
    21. Doplňování tvarů
    22. Používání animací nástroje Kost v aplikaci Animate
    23. Sestavování postav v aplikaci Animate
    24. Používání vrstev masek v aplikaci Adobe Animate
    25. Práce se scénami v aplikaci Animate
  4. Interaktivita
    1. Vytváření tlačítek v aplikaci Animate
    2. Převod projektů aplikace Animate na jiné typy dokumentů
    3. Vytváření a publikování dokumentů HTML5 Canvas v aplikaci Animate
    4. Přidání interaktivity pomocí fragmentů kódu v aplikaci Animate
    5. Vytváření vlastních komponent HTML5
    6. Používání komponent v dokumentech HTML5 Canvas
    7. Vytváření vlastních komponent: Příklady
    8. Fragmenty kódu pro vlastní komponenty
    9. Osvědčené postupy – Tvorba reklam v aplikaci Animate
    10. Vytváření a publikování virtuální reality
  5. Pracovní plocha a pracovní postupy
    1. Vytváření a správa malířských štětců
    2. Používání písem Google v dokumentech HTML5 Canvas
    3. Používání knihoven Creative Cloud v aplikaci Adobe Animate
    4. Používání vymezené plochy a panelu nástrojů v aplikaci Animate
    5. Pracovní postupy a pracovní plocha aplikace Animate
    6. Používání webových písem v dokumentech HTML5 Canvas
    7. Časové osy a ActionScript
    8. Práce s více časovými osami
    9. Nastavení předvoleb
    10. Používání vývojových panelů aplikace Animate
    11. Vytváření vrstev časové osy v aplikaci Animate
    12. Export animací pro mobilní aplikace a herní moduly
    13. Přemísťování a kopírování objektů
    14. Předlohy
    15. Příkaz Hledat a nahradit v aplikaci Animate
    16. Vrácení akce, její zopakování a panel Historie
    17. Klávesové zkratky
    18. Používání časové osy v aplikaci Animate
    19. Vytvoření rozšíření HTML
    20. Možnosti optimalizace obrázků a animovaných souborů GIF
    21. Export nastavení pro obrázky a soubory GIF
    22. Panel Datové zdroje v aplikaci Animate
  6. Multimédia a video
    1. Transformace a kombinování grafických objektů v aplikaci Animate
    2. Vytváření a práce s instancemi symbolů v aplikaci Animate
    3. Vektorizace obrazu
    4. Používání zvuku v aplikaci Adobe Animate
    5. Export souborů SVG
    6. Vytváření souborů videa používaných v aplikaci Animate
    7. Přidání videa v aplikaci Animate
    8. Práce se startovacími body videa
    9. Kreslení a vytváření objektů v aplikaci Animate
    10. Změna čar a tvarů
    11. Tahy, výplně a přechody v aplikaci Animate
    12. Práce s aplikacemi Adobe Premiere Pro a After Effects
    13. Panely barev v aplikaci Animate
    14. Otevírání souborů aplikace Flash CS6 v aplikaci Animate
    15. Práce s klasickým textem v aplikaci Animate
    16. Vložení grafiky do aplikace Animate
    17. Importované bitmapy v aplikaci Animate
    18. 3D grafika
    19. Práce se symboly v aplikaci Animate
    20. Kreslení čar a tvarů v aplikaci Adobe Animate
    21. Práce s knihovnami v aplikaci Animate
    22. Export zvuků
    23. Výběr objektů v aplikaci Animate
    24. Práce se soubory aplikace Illustrator (AI) v aplikaci Animate
    25. Nanášení vzorů pomocí nástroje Stopa spreje
    26. Používání režimů prolnutí
    27. Uspořádání objektů
    28. Automatizace úloh pomocí nabídky Příkazy
    29. Vícejazyčný text
    30. Používání kamery v aplikaci Animate
    31. Používání aplikace Animate s nástrojem Adobe Scout
    32. Práce se soubory aplikace Fireworks
    33. Grafické filtry
    34. Zvuk a ActionScript
    35. Předvolby kreslení
    36. Kreslení nástrojem Pero
  7. Platformy
    1. Převod projektů aplikace Animate na jiné typy dokumentů
    2. Podpora vlastní platformy
    3. Vytváření a publikování dokumentů HTML5 Canvas v aplikaci Animate
    4. Vytvoření a publikování dokumentu ve formátu WebGL
    5. Balení aplikací pro prostředí AIR for iOS
    6. Publikování aplikací prostředí AIR for Android
    7. Publikování pro prostředí Adobe AIR pro počítače
    8. Nastavení publikování jazyka ActionScript
    9. Osvědčené postupy – Uspořádání ActionScriptu v aplikaci
    10. Používání jazyka ActionScript v aplikaci Animate
    11. Osvědčené postupy – Pravidla usnadnění přístupu
    12. Usnadnění přístupu v pracovním prostoru aplikace Animate
    13. Psaní a správa skriptů
    14. Povolení podpory vlastních platforem
    15. Přehled podpory vlastních platforem
    16. Vytváření přístupného obsahu
    17. Práce se zásuvným modulem pro podporu vlastní platformy
    18. Ladění jazyka ActionScript 3.0
    19. Povolení podpory vlastních platforem
  8. Export a publikování
    1. Export souborů z aplikace Animate
    2. Publikování OAM
    3. Export souborů SVG
    4. Export grafiky a videa v aplikaci Animate
    5. Publikování dokumentů AS3
    6. Export animací pro mobilní aplikace a herní moduly
    7. Export zvuků
    8. Export videosouborů QuickTime
    9. Ovládání externího přehrávání videa s použitím jazyka ActionScript
    10. Osvědčené postupy – Tipy pro vytváření obsahu pro mobilní zařízení
    11. Osvědčené postupy – Konvence videa
    12. Osvědčené postupy – Pravidla pro vývoj aplikací SWF
    13. Osvědčené postupy – Strukturování souborů FLA
    14. Osvědčené postupy pro optimalizaci souborů FLA pro Animate
    15. Nastavení publikování jazyka ActionScript
    16. Nastavení publikování v aplikaci Animate
    17. Export souborů projektoru
    18. Export obrázků a animovaných souborů GIF
    19. Předlohy publikování HTML
    20. Práce s aplikacemi Adobe Premiere Pro a After Effects
    21. Rychlé sdílení a publikování animací

Transformace objektů

Můžete transformovat grafické objekty, skupiny, textové bloky a instance pomocí nástroje Libovolná transformace nebo pomocí voleb z nabídky Změnit > Transformace. Podle toho, jaký typ prvku vyberete, ho můžete transformovat, otáčet, zkosit, zdeformovat nebo změnit jeho velikost. Během transformování můžete výběr změnit nebo k němu přidat další prvky.

Při transformování objektu, skupiny, textového bloku nebo instance se v inspektoru Vlastnosti pro danou položku zobrazují veškeré změny jejích rozměrů nebo polohy.

Během transformování, při kterém se používá přetažení, se objeví ohraničovací rámeček. Ohraničovací rámeček je obdélníkový (pokud nebyl pozměněn příkazem Deformovat nebo modifikátorem Obálka) a jeho okraje jsou zpočátku rovnoběžné s okraji vymezené plochy. Na každém rohu a uprostřed každé strany jsou transformační táhla. Při tažení se v ohraničovacím rámečku zobrazuje náhled transformací.

Přemísťování, úpravy zarovnání, změny a sledování transformačního bodu

Během transformace se uprostřed vybraného prvku zobrazuje transformační bod. Zpočátku je transformační bod ve středu objektu. Transformační bod můžete přemístit, vrátit ho do jeho výchozí polohy a také můžete přemístit výchozí počáteční bod.

Při změnách velikosti, zkosení nebo otáčení grafických objektů, skupin a textových bloků je počátečním bodem standardně bod, který je naproti bodu, za který táhnete. Transformačním bodem je například standardně počáteční bod. Pro určitou transformaci můžete výchozí bod přesunout.

  1. Vyberte nástroj Libovolná transformace  nebo vyberte jeden z příkazů Změnit > Transformovat.

    Po zahájení transformace můžete sledovat polohu transformačního bodu v panelu Informace a v inspektoru vlastností.

  2. Proveďte jeden z následujících úkonů:
    • Chcete-li transformační bod přemístit, přetáhněte ho v rámci vybraného grafického objektu.

    • Chcete-li obnovit zarovnání transformačního bodu se středovým bodem prvku, poklepejte na transformační bod.

    • Chcete-li přepnout počáteční bod pro změnu velikosti nebo zkosení, podržte během transformace klávesu Alt a táhněte za zvolený řídicí bod objektu.

    • Na panelu Informace lze přepínat zobrazení vztažných a transformačních bodů. Tlačítko se zobrazí jako , což značí, že jsou zobrazeny souřadnice vztažného bodu. Kliknutím na stejné tlačítko se změní na , což značí, že jsou zobrazeny souřadnice transformačního bodu.

    Mřížka souřadnic; panel Informace s tlačítkem Vztažný/transformační bod v režimu transformačního bodu a se souřadnicemi x a y transformačního bodu výběru

Používání nástroje Libovolná transformace

Můžete používat jednotlivé transformace nebo je můžete různě kombinovat, například přemístění, pootočení, změnu velikosti, zkosení a deformování.

 Nástrojem Libovolná transformace nelze transformovat symboly, bitmapy, objekty videa, zvuky, přechody a text. Pokud vícenásobný výběr obsahuje kteroukoli z těchto položek, zdeformují se jen objekty tvarů. Chcete-li transformovat textový blok, nejdříve znaky převeďte na objekty tvarů.

  1. Na ploše vyberte grafický objekt, skupinu, instanci nebo textový blok.
  2. Kliknutím vyberte nástroj Libovolná transformace  .

    Když ukazatelem pohybujete po výběru, ukazatel se změní, aby vám naznačil, jaká transformační funkce je právě dostupná.

  3. Chcete-li transformovat výběr, táhněte za táhla:
    • Chcete-li výběr přemístit, umístěte ukazatel na objekt v ohraničovacím rámečku a přetáhněte ho do nové polohy. Netáhněte za transformační bod.

    • Chcete-li nastavit střed otáčení nebo změny velikosti, přetáhněte transformační bod do nové polohy.

    • Chcete-li výběr pootočit, umístěte ukazatel vně od rohového táhla a táhněte myší. Výběr se otáčí kolem transformačního bodu. Chcete-li otáčení omezit na násobky 45 stupňů, podržte při tažení klávesu Shift.

    • Chcete-li objekt otáčet kolem protilehlého rohu, táhněte se stisknutou klávesou Alt.

    • Chcete-li změnit velikost výběru, můžete diagonálním tažením za rohové táhlo měnit velikost ve dvou směrech. Podržte klávesu Shift, chcete-li změnit velikost proporcionálně.

    • Chcete-li změnit velikost jen v jednom směru, táhněte za rohové nebo boční táhlo vodorovně nebo svisle.

    • Chcete-li výběr zkosit, umístěte ukazatel na obrys mezi transformačními táhly a táhněte myší.

    • Chcete-li tvary zdeformovat, stiskněte Ctrl (Windows) nebo Apple (Macintosh) a táhněte za rohové nebo boční táhlo.

    • Chcete-li objekt zahrotit, přesuňte vybraný roh jedním směrem a vedlejší roh posuňte o stejnou vzdálenost opačným směrem, klikněte se stisknutými klávesami Shift+Ctrl (Windows) nebo Shift+Apple (Macintosh) a přetáhněte rohové táhlo.

  4. Chcete-li transformaci ukončit, klikněte vně vybrané položky.

Deformování objektů

Když na vybraný objekt aplikujete deformaci, při tažení za rohové nebo boční táhlo ohraničovacího rámečku se pohybuje příslušný roh nebo strana a vedlejší strany se dorovnávají podle ní. Pokud chcete deformaci zahrocení omezit, podržte při tažení za rohový bod klávesu Shift a posuňte tento roh i vedlejší roh o stejnou vzdálenost v opačném směru. Za vedlejší roh se považuje ten, který je na stejné ose ve směru tažení jako roh, za který táhnete. Chcete-li celou stranu volně přemístit, klikněte s klávesou Ctrl (Windows) nebo Apple (Macintosh) a táhněte za středový bod dané strany.

Grafické objekty lze deformovat pomocí příkazu Deformovat. Objekty také můžete deformovat, když na ně aplikujete libovolnou transformaci.

 Příkazem Deformovat nelze modifikovat symboly, základní tvary, bitmapy, objekty videa, zvuky, přechody, skupiny objektů a text. Pokud vícenásobný výběr obsahuje kteroukoli z těchto položek, zdeformují se jen objekty tvarů. Chcete-li transformovat text, nejprve znaky převeďte na objekty tvarů.

  1. Ve vymezené ploše vyberte grafický objekt nebo objekty.
  2. Zvolte Změnit > Transformace > Deformovat.

  3. Ukazatel umístěte na jedno z transformačních táhel a táhněte myší.
  4. Chcete-li transformaci ukončit, klikněte vně vybraného objektu nebo objektů.

Změny tvarů pomocí modifikátoru Obálka

Modifikátor Obálka umožňuje pokřivovat a deformovat objekty. Obálka je ohraničovací rámeček obsahující jeden nebo více objektů. Změny tvaru obálky ovlivňují tvar objektů v ní. Tvar obálky se upravuje změnami jejích bodů a tangenciálních táhel.

 Pomocí modifikátoru Obálka nelze modifikovat symboly, bitmapy, objekty videa, zvuky, přechody, skupiny objektů a text. Pokud vícenásobný výběr obsahuje kteroukoli z těchto položek, zdeformují se jen objekty tvarů. Chcete-li transformovat text, nejprve znaky převeďte na objekty tvarů.

  1. Ve vymezené ploše vyberte požadovaný tvar.
  2. Zvolte Změnit > Transformace > Obálka.

  3. Tažením za body a tangenciální táhla obálku pozměňte.

Změny velikosti objektů

Objekt můžete zvětšit nebo zmenšit ve vodorovném směru, ve svislém směru, nebo v obou směrech.

  1. Ve vymezené ploše vyberte grafický objekt nebo objekty.

  2. Zvolte Změnit > Transformace > Měřítko.

  3. Proveďte jeden z následujících úkonů:
    • Chcete-li změnit velikost objektu vodorovně i svisle, táhněte za některé z rohových táhel. Při změně velikosti zůstanou proporce objektu zachovány. Táhněte se stisknutou klávesou Shift, chcete-li změnit velikost nerovnoměrně.

    • Chcete-li změnit velikost objektu buď vodorovně, nebo svisle, táhněte za středové táhlo.

  4. Chcete-li transformaci ukončit, klikněte vně vybraného objektu nebo objektů.

     Když zvětšíte velikost některých položek, může se stát, že se položky blízko okrajů ohraničovacího rámečku dostanou mimo vymezenou plochu. Pokud k tomu dojde, zvolte Zobrazení > Pracovní plocha, abyste viděli i prvky, které jsou za hranicemi vymezené plochy.

Otočení a zkosení objektů

Při otáčení se objekt točí kolem svého transformačního bodu. Transformační bod se zarovná se vztažným bodem, který se standardně nachází uprostřed objektu, ale můžete ho přetáhnout i jinam.

Objekt můžete otočit následujícími způsoby:

  • Tažením nástrojem Libovolná transformace  (v rámci téže operace můžete objekt zároveň zkosit a změnit jeho velikost).

  • Zadáním úhlu v panelu Transformace (v rámci téže operace můžete zároveň změnit velikost objektu).

Otáčení a zkosení objektů tažením

  1. Ve vymezené ploše vyberte objekt nebo objekty.
  2. Zvolte Změnit > Transformace > Otočit a zkosit.

  3. Proveďte jeden z následujících úkonů:
    • Tažením za rohové táhlo objekt pootočte.

    • Tažením za středové táhlo objekt zkoste.

  4. Chcete-li transformaci ukončit, klikněte vně vybraného objektu nebo objektů.

Otáčení objektů o 90 stupňů

  1. Vyberte jeden nebo více objektů.
  2. Zvolte Změnit > Transformace > Otočit o 90° vpravo, chcete-li objekt otočit po směru hodinových ručiček, nebo Otočit o 90° vlevo, chcete-li objekt otočit proti směru hodinových ručiček.

Zkosení objektů

Při zkosení se objekt transformuje tak, že se jeho strany podél jedné nebo obou os nakloní. Objekt můžete zkosit tažením nebo zadáním hodnoty v panelu Transformace.

  1. Vyberte jeden nebo více objektů.
  2. Zvolte Okno > Transformovat.

  3. Klepněte na Zkosit.
  4. Zadejte hodnoty úhlů pro vodorovnou a svislou osu.

Převracení objektů

Objekty můžete převracet kolem jejich svislé nebo vodorovné osy, aniž byste změnili jejich vzájemnou polohu ve vymezené ploše.

  1. Vyberte objekt.
  2. Zvolte Změnit > Transformace > Překlopit svisle nebo Překlopit vodorovně.

Obnovování transformovaných objektů

Když použijete nástroj Volná transformace nebo panel Transformace ke změně velikosti, otočení nebo zkosení instancí, skupin nebo textu, aplikace Animate uloží s objektem jeho původní velikost a údaje o jeho natočení. Díky tomu lze odstranit aplikované transformace a obnovit původní hodnoty.

Výběrem příkazu Úpravy > Zpět je možné vrátit zpět pouze poslední transformaci. Chcete-li odstranit všechny transformace, klepněte v panelu na tlačítko Odstranit transformaci ještě předtím, než objekt odznačíte. Po odznačení objektu původní hodnoty zmizí a transformaci již nelze odstranit.

Obnovení původního stavu transformovaného objektu

  1. Je nutné, aby byl transformovaný objekt stále vybraný.

  2. Proveďte jeden z následujících úkonů:
    • Na panelu Transformace klikněte na tlačítko Odstranit transformaci .

    • Zvolte Změnit > Transformace > Odstranit transformaci.

Vytváření datových zdrojů pro vektorový a bitmapový obsah

Ve verzi Animate 19.0 byl představen nový nástroj Pokřivení podkladu. Tento nástroj můžete používat k vytvoření táhel pokřivení na tvarech, objektech kresby a bitmapách v aplikaci Animate. Přetahováním táhel pokřivení pomocí nástroje Pokřivení podkladu můžete deformovat tvary, objekty kresby a bitmapy. 

Nástroj Pokřivení podkladu
Nástroj Pokřivení podkladu

Pomocí táhel pokřivení zobrazujících se na objektech můžete změnit tvar určitých oblastí objektů nebo je deformovat a zároveň zachovat ostatní oblasti, tak jak jsou. Všechny zvolené objekty se při vytvoření prvního táhla pokřivení seskupí. Při vložení klíčového snímku se táhla pokřivení zkopírují z předchozího klíčového snímku do nového klíčového snímku.

Některé ze stylů kurzoru, které se zobrazí při umístění kurzoru myši na objekty s nástrojem Pokřivení podkladu, jsou zobrazeny níže.

Tento kurzor se zobrazí v případě, že nástroj Pokřivení podkladu není u objektu podporován.

– Tento kurzor indikuje, že u objektu můžete vytvořit táhla pokřivení pomocí nástroje Pokřivení podkladu.

– Tento kurzor indikuje, že můžete kliknout na táhlo pokřivení a změnit tvar objektu.

Přesunutí kurzoru na

– Tento kurzor indikuje, že můžete otáčet objektem.

Použití nástroje Pokřivení podkladu

  1. Vytvořte tvar nebo importujte bitmapový obrázek na plochu. 

  2. Klikněte na nástroj Pokřivení podkladu na panelu nástrojů.

  3. Když najedete myší na tvar nebo objekt kresby, zobrazí se symbol . Pak můžete kliknout a přidat táhla pokřivení.

    Umístění myši na tvar nebo objekt kresby
    Umístění myši na tvar nebo objekt kresby

  4. Táhla pokřivení se zobrazují jako malá vyplněná kolečka na tvaru nebo objektu kresby. K účinnému pokřivení objektu můžete použít tolik táhel, kolik potřebujete. Pro odstranění táhla pokřivení loutky můžete použít klávesu Delete na klávesnici.

    Táhla pokřivení
    Táhla pokřivení

  5. Se stisknutou klávesou Shift klikněte na táhla pokřivení loutky a vyberte více táhel. Táhla můžete přetáhnout pomocí nástroje Pokřivení podkladu a podle svých požadavků daný tvar deformovat.

    Deformace tvarů pomocí táhel
    Deformace tvarů pomocí táhel

    Deformace bitmap pomocí táhel

  6. Vyberte jeden ze dvou režimů dostupných pro táhla pokřivení.

        a.    Volný režim – poskytuje více stupňů volnosti kolem táhla během deformace. Táhlo je v tomto režimu vykresleno jako bílé kolečko.

        b.   Pevný režim – poskytuje méně stupňů volnosti kolem táhla během deformace. Táhlo je v tomto režimu vykresleno jako černé kolečko.

    Mezi těmito dvěma režimy můžete přepínat kliknutím na táhla pokřivení se stisknutou klávesou Alt.

Oživte bitmapy pomocí nástroje Pokřivení podkladu

Bitmapy jsou důležitou součástí vytváření animací. Chcete se naučit importovat tyto bitmapy a oživit je? Podívejte se na výukové video na konci tohoto příkladu a postupujte podle těchto kroků.

  1. Klikněte na Soubor> Importovat> Importovat plochu.

  2. Vyberte požadovaný obraz.

  3. V okně Vlastnosti vyberte nástroj Pokřivení podkladu.

Jak snadno oživit importované bitmapy

Podívejte se na video, ve kterém se dozvíte, jak deformovat obraz a animovat ho pomocí nástroje Pokřivení podkladu.

Usnadnění práce s nástrojem Pokřivení podkladu

Vytváření animace je zdlouhavý proces. S nástrojem Pokřivení podkladu je navrhování animací jednodušší. Chcete se dozvědět, jak se nástroj Pokřivení podkladu používá ke zkrácení doby kreslení. Podívejte se na výukové video na konci tohoto příkladu a postupujte podle těchto kroků.

  1. V nabídce Nástroje klikněte na nástroj Pokřivení podkladu.

  2. Když najedete myší na tvar nebo objekt kresby, zobrazí se symbol. Pak můžete kliknout a přidat táhla pokřivení.

  3. Táhla pokřivení se zobrazují jako malá vyplněná kolečka na tvaru nebo objektu kresby. K účinnému pokřivení objektu můžete použít tolik táhel, kolik potřebujete.

  4. Se stisknutou klávesou Shift klikněte na táhla pokřivení loutky a vyberte více táhel. Táhla můžete přetáhnout pomocí nástroje Pokřivení podkladu a podle svých požadavků daný tvar deformovat.

Jak snadno vytvářet animace pomocí nástroje pro pokřivení podkladu

Podívejte se na video a dozvíte se více o nástroji Pokřivení podkladu a dalších nástrojích, které jej podporují.

Úpravy základního tvaru

Základní tvar je tvar před použitím pokřivení. Pokřivení podkladu funguje u mřížek překrývajících horní část základního tvaru. Základní tvar můžete změnit také přepnutím na nástroj Výběr a poklikáním na pokřivený tvar. Jakékoli vámi provedené změny základního tvaru se použijí na všechny pokřivené instance tohoto tvaru. Tato funkce funguje pouze u vektorových tvarů.

Vlastnosti tvaru pro funkci Pokřivení podkladu
Vlastnosti tvaru pro funkci Pokřivení podkladu

Doplnění pro nástroj Pokřivení podkladu

S nástrojem Pokřivení podkladu můžete použít klasické doplnění. Můžete například použít Klasické doplnění pro doplnění pozic loutky. 

Kliknutím sem zobrazíte další informace o klasickém doplnění. 

 K doplnění pozic byste měli použít stejnou sadu táhel ve tvaru.

Kombinování objektů

Chcete-li vytvořit nové tvary zkombinováním nebo pozměněním existujících objektů, použijte příkazy Kombinovat objekty v nabídce Změnit (Změnit > Kombinovat objekty). V některých případech závisí výsledek této operace na pořadí překrývání vybraných objektů.

Každý příkaz se vztahuje na určité typy grafických objektů; tyto typy jsou uvedeny níže. Tvar sloučení je tvar, který je kreslený pomocí sady nástrojů ve slučovacím režimu kreslení. Objekt kresby je tvar, který je kreslený pomocí sady nástrojů v režimu kreslení objektu.

Mezi příkazy Kombinovat objekty patří:

Sjednotit

Sjednocuje dva nebo více tvarů sloučení nebo objektů kresby. Výsledkem je jeden tvar režimu kreslení objektu tvořený částmi všech jednotlivých tvarů, které byly viditelné, než jste je sjednotili. Překryté části tvarů, které nejsou vidět, se odstraní.

 

 Na rozdíl od použití příkazu Seskupit (Změnit > Seskupit) nelze už tvary spojené příkazem Sjednotit navzájem oddělit.

Průsečík

Vytvoří objekt z průniku dvou nebo více objektů kresby. Výsledný tvar objektového kreslicího modelu je tvořen překrývajícími se částmi zkombinovaných tvarů. Všechny části tvaru, které se nepřekrývají s jiným tvarem, se odstraní. Výsledný tvar bude mít výplň a tah tvaru, který leží v pořadí překrývání zcela navrchu.

Vyseknout

Odstraní části vybraného objektu kresby určené překrytím s jiným vybraným objektem kresby umístěným v pořadí překrývání nad ním. Všechny části objektu kresby překryté objektem zcela navrchu se odstraní a objekt zcela navrchu se odstraní celý. Výsledné objekty zůstanou odděleny a nezkombinují se do jednoho objektu (jak je tomu u příkazů Sjednotit a Průsečík).

Oříznout

Ořízne pomocí obrysu jednoho objektu kresby jiný objekt kresby. Oříznutou oblast určuje tvar, který je v pořadí překrývání zcela navrchu. Všechny části níže ležícího objektu kresby, které jsou překryté vrchním objektem, zůstanou zachovány, zatímco všechny jeho ostatní části se odstraní a objekt zcela navrchu se odstraní celý. Výsledné objekty zůstanou odděleny a nezkombinují se do jednoho objektu (jak je tomu u příkazů Sjednotit a Průsečík).

Logo Adobe

Přihlaste se ke svému účtu.