Arbeta med symboler i Animate

  1. Användarhandbok för Adobe Animate
  2. Introduktion till Animate
    1. Nyheter i Animate
    2. Visuell ordlista
    3. Systemkrav för Animate
    4. Tangentbordsgenvägar för Animate
    5. Arbeta med flera filtyper i Animate
  3. Animering
    1. Grunderna vid animering i Animate
    2. Så här använder du bildrutor och nyckelbildrutor i Animate
    3. Animering bildruta för bildruta i Animate
    4. Arbeta med klassiska interpolerade animeringar i Animate
    5. Pensel
    6. Rörelseguide
    7. Rörelseinterpoleringar och ActionScript 3.0
    8. Om animeringar med rörelseinterpolering
    9. Animeringar med rörelseinterpolering
    10. Skapa en animering med rörelseinterpolering
    11. Använda nyckelbildrutor för egenskaper
    12. Animera placering med en interpolering
    13. Så här redigerar du rörelseinterpoleringar med rörelseredigeraren
    14. Redigera rörelsebanan för en interpolerad animering
    15. Ändra rörelseinterpoleringar
    16. Lägga till anpassade övergångar
    17. Skapa och använda förinställda rörelser
    18. Konfigurera interpoleringsintervall för animeringar
    19. Arbeta med rörelseinterpoleringar sparade som XML-filer
    20. Rörelseinterpoleringar jämfört med klassiska interpoleringar
    21. Forminterpolering
    22. Använda animeringar med benverktyget i Animate
    23. Arbeta med figurriggning i Animate
    24. Så här använder du maskeringslager i Adobe Animate
    25. Så här arbetar du med scener i Animate
  4. Interaktivitet
    1. Så här skapar du knappar med Animate
    2. Konvertera Animate-projekt till andra dokumenttypsformat
    3. Skapa och publicera HTML5 Canvas-dokument i Animate
    4. Lägga till interaktivitet med kodfragment i Animate
    5. Skapa anpassade HTML5-komponenter
    6. Använda komponenter i HTML5 Canvas
    7. Skapa anpassade komponenter: Exempel
    8. Kodfragment för anpassade komponenter
    9. God praxis - annonsera med Animate
    10. Redigera och publicera VR
  5. Arbetsyta och arbetsflöde
    1. Skapa och hantera målarpenslar
    2. Använda Google Fonts i HTML5 Canvas-dokument
    3. Använda Creative Cloud Libraries och Adobe Animate
    4. Använda scen- och verktygspanelerna i Animate
    5. Arbetsflöde och arbetsyta i Animate
    6. Använda webbteckensnitt i HTML5 Canvas-dokument
    7. Tidslinjer och ActionScript
    8. Arbeta med flera tidslinjer
    9. Ange inställningar
    10. Använda redigeringspanelerna i Animate
    11. Skapa tidslinjelager med Animate
    12. Exportera animeringar för mobilprogram och spelplattformar
    13. Flytta och kopiera objekt
    14. Mallar
    15. Söka och ersätta i Animate
    16. Ångra, gör om och panelen Historik
    17. Kortkommandon
    18. Så här använder du tidslinjen i Animate
    19. Skapa HTML-tillägg
    20. Optimeringsalternativ för bilder och animerade GIF-filer
    21. Exportinställningar för bilder och GIF-filer
    22. Panelen Resurser i Animate
  6. Multimedia och video
    1. Omforma och kombinera grafikobjekt i Animate
    2. Skapa och arbeta med symbolinstanser i Animate
    3. Bildkalkering
    4. Så här använder du ljud i Adobe Animate
    5. Exportera SVG-filer
    6. Skapa videofiler för användning i Animate
    7. Så här lägger du till en video i Animate
    8. Arbeta med videoreferenspunkter
    9. Rita och skapa objekt med Animate
    10. Omforma linjer och former
    11. Linjer, fyllningar och övertoningar med Animate CC
    12. Arbeta med Adobe Premiere Pro och After Effects
    13. Färgpaneler i Animate CC
    14. Öppna Flash CS6-filer i Animate
    15. Arbeta med klassisk text i Animate
    16. Placera grafik i Animate
    17. Importerade bitmappar i Animate
    18. 3D-grafik
    19. Arbeta med symboler i Animate
    20. Rita linjer och former med Adobe Animate
    21. Arbeta med bibliotek i Animate
    22. Exportera ljud
    23. Markera objekt i Animate CC
    24. Arbeta med Illustrator AI-filer i Animate
    25. Tillämpa mönster med sprejpenseln
    26. Använda blandningslägen
    27. Ordna objekt
    28. Automatisera uppgifter med kommandomenyn
    29. Flerspråkig text
    30. Använda kameran i Animate
    31. Använda Animate med Adobe Scout
    32. Arbeta med Fireworks-filer
    33. Grafikfilter
    34. Ljud och ActionScript
    35. Ritinställningar
    36. Rita med ritstift
  7. Plattformar
    1. Konvertera Animate-projekt till andra dokumenttypsformat
    2. Stöd för anpassade plattformar
    3. Skapa och publicera HTML5 Canvas-dokument i Animate
    4. Skapa och publicera ett WebGL-dokument
    5. Så här paketerar du AIR för iOS-program
    6. Publicera AIR for Android-program
    7. Publicera för Adobe AIR för datorprogram
    8. Inställningar för ActionScript-publicering
    9. God praxis – organisera ActionScript i ett program
    10. Så här använder du ActionScript med Animate
    11. God praxis – riktlinjer för hjälpmedel
    12. Hjälpmedel på arbetsytan i Animate
    13. Skriva och hantera skript
    14. Aktivera stöd för anpassade plattformar
    15. Översikt över stöd för anpassade plattformar
    16. Skapa hjälpmedelsanpassat innehåll
    17. Arbeta med plugin-program för anpassade plattformar
    18. Felsöka ActionScript 3.0
    19. Aktivera stöd för anpassade plattformar
  8. Exportera och publicera
    1. Så här exporterar du filer från Animate CC
    2. OAM-publicering
    3. Exportera SVG-filer
    4. Exportera bilder och video med Animate
    5. Publicera AS3-dokument
    6. Exportera animeringar för mobilprogram och spelplattformar
    7. Exportera ljud
    8. Exportera QuickTime-videofiler
    9. Styra extern videouppspelning med ActionScript
    10. God praxis – tips för att skapa innehåll på mobila enheter
    11. God praxis – videokonventioner
    12. God praxis – riktlinjer för utveckling av SWF-program
    13. God praxis – strukturera FLA-filer
    14. De bästa sätten att optimera FLA-filer för Animate
    15. Inställningar för ActionScript-publicering
    16. Ange publiceringsinställningar för Animate
    17. Exportera projektorfiler
    18. Exportera bilder och animerade GIF-filer
    19. Publiceringsmallar för HTML
    20. Arbeta med Adobe Premiere Pro och After Effects
    21. Dela och publicera animeringar snabbt

Om symboler

En symbol är en bild, en knapp eller ett videoklipp som du skapar i Animate-redigeringsmiljön (tidigare Flash Professional CC) eller genom att använda klasserna SimpleButton (AS 3.0) och MovieClip. Du kan sedan återanvända symbolen i dokumentet eller i andra dokument.

En symbol kan innehålla teckningar som du importerar från ett annat program. Alla symboler som du skapar hamnar automatiskt i biblioteket för det aktuella dokumentet.

En instans är en kopia av en symbol som ligger på scenen eller är kapslad i en annan symbol. En instans kan skilja sig från dess överordnade symbol vad gäller färg, storlek och funktion. Om du redigerar symbolen uppdateras alla dess instanser, men om du använder effekter på en instans uppdateras bara instansen.

Om du använder symboler i dina dokument minskas filstorleken drastiskt; att spara flera instanser av en symbol kräver mindre lagringsutrymme än att spara flera kopior av symbolens innehåll. Du kan till exempel minska filstorleken på dina dokument genom att konvertera statisk grafik, till exempel bakgrundsbilder, till symboler och återanvända dem. Om du använder symboler kan det också gå snabbare att spela upp SWF-filen, eftersom symbolen bara behöver hämtas till Flash® Player en gång.

Du kan dela symboler mellan dokument som delade biblioteksobjekt vid redigering eller körning. För objekt som delas vid körning kan du länka objekt i ett källdokument till valfritt antal måldokument, utan att importera objekten till måldokumentet. För objekt som delas vid redigering kan du uppdatera eller ersätta en symbol med alla symboler som finns tillgängliga i det lokala nätverket.

Om du importerar biblioteksobjekt med samma namn som objekt som redan finns i biblioteket kan du åtgärda detta utan att riskera att skriva över befintliga objekt.

Mer anvisningar om hur du kommer igång med symboler finns på följande resurser:

Symboltyper

Varje symbol har en unik tidslinje och scen med lager. Du kan lägga till bildrutor, nyckelbildrutor och lager på en tidslinje för en symbol, precis som med huvudtidslinjen. När du skapar en symbol väljer du en symboltyp.

  • Använd grafiska symboler  för statiska bilder och för att skapa återanvändbara animeringar som är knutna till huvudtidslinjen. Grafiska symboler fungerar synkroniserat med huvudtidslinjen. Interaktiva kontroller och ljud fungerar inte i animeringssekvenser för en grafisk symbol. Grafiksymboler ökar inte filstorleken på FLA-filen lika mycket som knappar eller filmklipp, eftersom de inte har någon tidslinje.

  • Använd knappsymboler för att skapa interaktiva knappar som reagerar på musklick, rollovers eller andra åtgärder. Du definierar grafiken som är kopplad till olika knapplägen och tilldelar sedan åtgärder till en knappinstans. Mer information finns i Hantera händelser i Utvecklarhandbok för ActionScript 3.0.

  • Använd filmklippssymboler för att skapa återanvändbara animeringar. Filmklipp kan ha en egen tidslinje med flera bildrutor som är oberoende av huvudtidslinjen. Föreställ dig att de är kapslade i en huvudtidslinje som kan innehålla interaktiva kontroller, ljud och till och med andra filmklippsinstanser. Du kan också placera filmklippsinstanser i tidslinjen för en knappsymbol och på så sätt skapa animerade knappar. Det går dessutom att styra filmklipp med ActionScript®.

  • Använd teckensnittssymboler om du vill exportera ett teckensnitt och använda det i andra Animate-dokument.

    Animate innehåller inbyggda komponenter, filmklipp med definierade parametrar som du kan använda för att lägga till gränssnittselement, till exempel knappar, kryssrutor och rullningslister, i dina dokument. Mer information finns i Om ActionScript 3.0-komponenter i Använda ActionScript 3.0-komponenter.

    Obs! Om du vill förhandsgranska animering i komponentinstanser och skalning av filmklipp som är skalade med nio segment i Animate-redigeringsmiljön väljer du Kontroll > Aktivera direktförhandsgranskning.

Skapa symboler

Du kan skapa en symbol med hjälp av valda objekt på scenen, skapa en tom symbol och skapa eller importera innehållet i symbolredigeringsläge, samt skapa teckensnittssymboler i Animate. Symboler kan innehålla alla funktioner som Animate kan skapa, inklusive animeringar.

Med symboler som innehåller animeringar kan du skapa Animate-program med mycket rörelse samtidigt som du minskar filstorleken. Du kan skapa en animering i en symbol som upprepas – till exempel en fågel som flaxar med vingarna.

Om du vill lägga till symboler i dokumentet använder du delade biblioteksobjekt vid redigering eller körning.

Konvertera valda element till en symbol

  1. Markera ett eller flera element på scenen. Gör något av följande:
    • Välj Ändra > Konvertera till symbol.

    • Dra markeringen till bibliotekspanelen.

    • Högerklicka (Windows) eller Control-klicka (Macintosh) och välj Konvertera till symbol på snabbmenyn.

  2. I dialogrutan Konvertera till symbol anger du namnet på symbolen och väljer beteendet.
  3. Placera registreringspunkten för symbolen genom att klicka i registreringsrutnätet.
  4. Klicka på OK.

    Animate lägger till symbolen i biblioteket. Markeringen på scenen blir en instans av symbolen. När du har skapat en symbol kan du redigera den i symbolredigeringsläge genom att välja Redigera > Redigera symboler, eller redigera den på scenen genom att välja Redigera > Redigera på plats. Du kan också ändra registreringspunkten för en symbol.

Skapa en tom symbol

  1. Gör något av följande:
    • Välj Infoga > Ny symbol.

    • Klicka på knappen Ny symbol längst ner till vänster på bibliotekspanelen.

    • Välj Ny symbol i Bibliotekspanel-menyn längst upp till höger på bibliotekspanelen.

  2. I dialogrutan Skapa ny symbol anger du namnet på symbolen och väljer beteende.
  3. Klicka på OK.

    Animate lägger till symbolen i biblioteket och växlar till symbolredigeringsläge. I symbolredigeringsläge visas namnet på symbolen längst upp till vänster på scenen och symbolens registreringspunkt markeras med ett hårkors.

  4. Om du vill skapa innehåll för symbolen använder du tidslinjen, ritar med ritverktygen, importerar media eller skapar instanser av andra symboler.
  5. Om du vill återgå till dokumentredigeringsläge gör du något av följande:
    • Klicka på knappen Tillbaka.

    • Välj Redigera > Redigera dokument.

    • Klicka på scenens namn i redigeringsfältet.

      När du skapar en symbol placeras registreringspunkten mitt i fönstret i symbolredigeringsläge. Du kan placera symbolinnehållet i fönstret i förhållande till registreringspunkten. Om du vill ändra registreringspunkten flyttar du symbolinnehållet i förhållande till registreringspunkten när du redigerar en symbol.

  6. I delen ActionScript-länkning kan du välja att exportera för ActionScript genom att markera kryssrutan Exportera för ActionScript. Klass och basklass visas automatiskt (du kan byta namn på klasserna om du vill). Animate söker efter klassdefinitioner i en extern AS-fil eller en länkad SWC-fil. Om inga klassdefinitioner hittas på dessa platser genereras klassfilerna automatiskt i Animate. Du hittar mer information i den här artikeln.

(Endast Animate ) Byta ut flera symboler

Med alternativet Växla symbol kan du byta ut symboler mot en vald symbol eller bitmapp.

  1. I ditt Animate-dokumentet väljer du flera symboler på scenen.

  2. Klicka på Växla på egenskapspanelen.
  3. I dialogrutan Växla symbol väljer du den symbol du vill ersätta alla markerade symboler/bitmappar med.
  4. Klicka på OK.

Konvertera animering på scenen till ett filmklipp symbol

Om du vill återanvända en animerad sekvens på scenen eller hantera den som en instans markerar du den och sparar den som en filmklippssymbol.

  1. På huvudtidslinjen markerar du alla bildrutor i alla lager i animeringen på scenen som du vill använda. Mer information om hur du markerar bildrutor finns i Infoga bildrutor på tidslinjen.
  2. Gör något av följande om du vill kopiera bildrutorna:
    • Högerklicka (Windows) eller Control-klicka (Macintosh) på en markerad bildruta och välj Kopiera bildrutor i snabbmenyn. Om du vill radera sekvensen när du har konverterat den till ett filmklipp väljer du Klipp ut.

    • Välj Redigera > Tidslinje > Kopiera bildrutor. Om du vill radera sekvensen när du har konverterat den till ett filmklipp väljer du Klipp ut bildrutor.

  3. Avmarkera markeringen och kontrollera att inget på scenen är markerat. Välj Infoga > Ny symbol.
  4. Ge symbolen ett namn. För Typ väljer du Filmklipp och klickar sedan på OK.
  5. På tidslinjen klickar du på bildruta 1 på lager 1 och väljer Redigera > Tidslinje > Klistra in bildrutor.

    Den här åtgärden klistrar in bildrutorna (och eventuella lager och lagernamn) som du kopierat från huvudtidslinjen på tidslinjen för den här filmklippssymbolen. Eventuella animeringar, knappar eller interaktivitet från bildrutorna som du kopierade blir nu en självständig animering (en filmklippssymbol) som du kan återanvända.

  6. Om du vill återgå till dokumentredigeringsläge gör du något av följande:
    • Klicka på knappen Tillbaka.

    • Välj Redigera > Redigera dokument.

    • Klicka på scenens namn i redigeringsfältet ovanför scenen.

Duplicera symboler

Genom att duplicera en symbol kan du använda en befintlig symbol som utgångspunkt när du skapar en ny symbol.

Om du vill skapa versioner av symbolen med olika utseenden bör du också använda instanser.

Duplicera en symbol i bibliotekspanelen

  1. Markera en symbol i bibliotekspanelen och gör något av följande:
    • Högerklicka (Windows) eller Control-klicka (Macintosh) och välj Duplicera på snabbmenyn.

    • Välj Duplicera i menyn Bibliotekspanel.

Duplicera en symbol genom att markera en instans

  1. Markera en instans av symbolen på scenen.
  2. Välj Ändra > Symbol > Duplicera symbol.

    Symbolen dupliceras och instansen ersätts av en instans av den duplicerade symbolen.

Redigera symboler

När du redigerar en symbol i Animate uppdateras alla instanser av den symbolen i ditt dokument. Redigera symbolen på följande sätt:

  • I förhållande till de andra objekten på scenen genom att använda kommandot Redigera på plats. Andra objekt dämpas för att skilja dem från symbolen som du redigerar. Namnet på symbolen som du redigerar visas i ett redigeringsfält högst upp på scenen, till höger om namnet på aktuell scen.

  • I ett separat fönster med kommandot Redigera i nytt fönster. Om du redigerar en symbol i ett separat fönster kan du se symbolen och huvudtidslinjen samtidigt. Namnet på symbolen som du redigerar visas i redigeringsfältet högst upp på scenen.

    Du redigerar symbolen genom att växla fönstret från scenvyn till en vy med endast symbolen, med hjälp av symbolredigeringsläge. Namnet på symbolen som du redigerar visas i redigeringsfältet högst upp på scenen, till höger om namnet på aktuell scen.

    När du redigerar en symbol i Animate uppdateras alla instanser av symbolen i dokumentet med dina ändringar. När du redigerar en symbol kan du använda ritverktygen, importera media eller skapa instanser av andra symboler.

  • Ändra registreringspunkten för en symbol (punkten anges med koordinaterna 0, 0) med någon symbolredigeringsmetod.

 

Redigera en symbol på plats

  1. Gör något av följande:
    • Dubbelklicka på en instans av symbolen på scenen.

    • Markera en instans av symbolen på scenen, högerklicka (Windows) eller Control-klicka (Macintosh) och välj Redigera på plats.

    • Markera en instans av symbolen på scenen och välj Redigera > Redigera på plats.

  2. Redigera symbolen.
  3. Om du vill avsluta läget redigera-på-plats och återgå till dokumentredigeringsläge gör du något av följande:
    • Klicka på knappen Tillbaka.

    • Markera namnet på aktuell scen i menyn Scen i redigeringsfältet.

    • Välj Redigera > Redigera dokument.

    • Dubbelklicka utanför symbolinnehållet.

Redigera en symbol i ett nytt fönster

  1. Markera en instans av symbolen på scenen, högerklicka (Windows) eller Control-klicka (Macintosh) och välj Redigera i nytt fönster.
  2. Redigera symbolen.
  3. Klicka på stängningsrutan i det övre högra hörnet (Windows) eller övre vänstra hörnet (Macintosh) när du vill stänga det nya fönstret, och klicka i huvuddokumentfönstret när du vill återgå till att redigera huvuddokumentet.

Redigera en symbol i symbolredigeringsläge

  1. Gör något av följande om du vill markera symbolen:
    • Dubbelklicka på symbolens ikon på bibliotekspanelen.

    • Markera en instans av symbolen på scenen, högerklicka (Windows) eller Control-klicka (Macintosh) och välj Redigera på snabbmenyn.

    • Markera en instans av symbolen på scenen och välj Redigera > Redigera symboler.

    • Markera symbolen i bibliotekspanelen och välj Redigera i menyn Bibliotekspanel, eller högerklicka (Windows) eller Control-klicka (Macintosh) på symbolen i bibliotekspanelen och välj Redigera.

  2. Redigera symbolen.
  3. Om du vill avsluta symbolredigeringsläge och återgå till att redigera dokumentet gör du något av följande:
    • Klicka på knappen Tillbaka till vänster om redigeringsfältet högst upp på scenen.

    • Välj Redigera > Redigera dokument.

    • Klicka på scenens namn i redigeringsfältet högst upp på scenen.

    • Dubbelklicka utanför symbolinnehållet.

Adobes logotyp

Logga in på ditt konto