Användarhandbok Avbryt

Arbeta med bibliotek i Animate

  1. Användarhandbok för Adobe Animate
  2. Introduktion till Animate
    1. Nyheter i Animate
    2. Visuell ordlista
    3. Systemkrav för Animate
    4. Tangentbordsgenvägar för Animate
    5. Arbeta med flera filtyper i Animate
  3. Animering
    1. Grunderna vid animering i Animate
    2. Så här använder du bildrutor och nyckelbildrutor i Animate
    3. Animering bildruta för bildruta i Animate
    4. Arbeta med klassiska interpolerade animeringar i Animate
    5. Pensel
    6. Rörelseguide
    7. Rörelseinterpoleringar och ActionScript 3.0
    8. Om animeringar med rörelseinterpolering
    9. Animeringar med rörelseinterpolering
    10. Skapa en animering med rörelseinterpolering
    11. Använda nyckelbildrutor för egenskaper
    12. Animera placering med en interpolering
    13. Så här redigerar du rörelseinterpoleringar med rörelseredigeraren
    14. Redigera rörelsebanan för en interpolerad animering
    15. Ändra rörelseinterpoleringar
    16. Lägga till anpassade övergångar
    17. Skapa och använda förinställda rörelser
    18. Konfigurera interpoleringsintervall för animeringar
    19. Arbeta med rörelseinterpoleringar sparade som XML-filer
    20. Rörelseinterpoleringar jämfört med klassiska interpoleringar
    21. Forminterpolering
    22. Använda animeringar med benverktyget i Animate
    23. Arbeta med figurriggning i Animate
    24. Så här använder du maskeringslager i Adobe Animate
    25. Så här arbetar du med scener i Animate
  4. Interaktivitet
    1. Så här skapar du knappar med Animate
    2. Konvertera Animate-projekt till andra dokumenttypsformat
    3. Skapa och publicera HTML5 Canvas-dokument i Animate
    4. Lägga till interaktivitet med kodfragment i Animate
    5. Skapa anpassade HTML5-komponenter
    6. Använda komponenter i HTML5 Canvas
    7. Skapa anpassade komponenter: Exempel
    8. Kodfragment för anpassade komponenter
    9. God praxis - annonsera med Animate
    10. Redigera och publicera VR
  5. Arbetsyta och arbetsflöde
    1. Skapa och hantera målarpenslar
    2. Använda Google Fonts i HTML5 Canvas-dokument
    3. Använda Creative Cloud Libraries och Adobe Animate
    4. Använda scen- och verktygspanelerna i Animate
    5. Arbetsflöde och arbetsyta i Animate
    6. Använda webbteckensnitt i HTML5 Canvas-dokument
    7. Tidslinjer och ActionScript
    8. Arbeta med flera tidslinjer
    9. Ange inställningar
    10. Använda redigeringspanelerna i Animate
    11. Skapa tidslinjelager med Animate
    12. Exportera animeringar för mobilprogram och spelplattformar
    13. Flytta och kopiera objekt
    14. Mallar
    15. Söka och ersätta i Animate
    16. Ångra, gör om och panelen Historik
    17. Kortkommandon
    18. Så här använder du tidslinjen i Animate
    19. Skapa HTML-tillägg
    20. Optimeringsalternativ för bilder och animerade GIF-filer
    21. Exportinställningar för bilder och GIF-filer
    22. Panelen Resurser i Animate
  6. Multimedia och video
    1. Omforma och kombinera grafikobjekt i Animate
    2. Skapa och arbeta med symbolinstanser i Animate
    3. Bildkalkering
    4. Så här använder du ljud i Adobe Animate
    5. Exportera SVG-filer
    6. Skapa videofiler för användning i Animate
    7. Så här lägger du till en video i Animate
    8. Arbeta med videoreferenspunkter
    9. Rita och skapa objekt med Animate
    10. Omforma linjer och former
    11. Linjer, fyllningar och övertoningar med Animate CC
    12. Arbeta med Adobe Premiere Pro och After Effects
    13. Färgpaneler i Animate CC
    14. Öppna Flash CS6-filer i Animate
    15. Arbeta med klassisk text i Animate
    16. Placera grafik i Animate
    17. Importerade bitmappar i Animate
    18. 3D-grafik
    19. Arbeta med symboler i Animate
    20. Rita linjer och former med Adobe Animate
    21. Arbeta med bibliotek i Animate
    22. Exportera ljud
    23. Markera objekt i Animate CC
    24. Arbeta med Illustrator AI-filer i Animate
    25. Tillämpa mönster med sprejpenseln
    26. Använda blandningslägen
    27. Ordna objekt
    28. Automatisera uppgifter med kommandomenyn
    29. Flerspråkig text
    30. Använda kameran i Animate
    31. Använda Animate med Adobe Scout
    32. Arbeta med Fireworks-filer
    33. Grafikfilter
    34. Ljud och ActionScript
    35. Ritinställningar
    36. Rita med ritstift
  7. Plattformar
    1. Konvertera Animate-projekt till andra dokumenttypsformat
    2. Stöd för anpassade plattformar
    3. Skapa och publicera HTML5 Canvas-dokument i Animate
    4. Skapa och publicera ett WebGL-dokument
    5. Så här paketerar du AIR för iOS-program
    6. Publicera AIR for Android-program
    7. Publicera för Adobe AIR för datorprogram
    8. Inställningar för ActionScript-publicering
    9. God praxis – organisera ActionScript i ett program
    10. Så här använder du ActionScript med Animate
    11. God praxis – riktlinjer för hjälpmedel
    12. Hjälpmedel på arbetsytan i Animate
    13. Skriva och hantera skript
    14. Aktivera stöd för anpassade plattformar
    15. Översikt över stöd för anpassade plattformar
    16. Skapa hjälpmedelsanpassat innehåll
    17. Arbeta med plugin-program för anpassade plattformar
    18. Felsöka ActionScript 3.0
    19. Aktivera stöd för anpassade plattformar
  8. Exportera och publicera
    1. Så här exporterar du filer från Animate CC
    2. OAM-publicering
    3. Exportera SVG-filer
    4. Exportera bilder och video med Animate
    5. Publicera AS3-dokument
    6. Exportera animeringar för mobilprogram och spelplattformar
    7. Exportera ljud
    8. Exportera QuickTime-videofiler
    9. Styra extern videouppspelning med ActionScript
    10. God praxis – tips för att skapa innehåll på mobila enheter
    11. God praxis – videokonventioner
    12. God praxis – riktlinjer för utveckling av SWF-program
    13. God praxis – strukturera FLA-filer
    14. De bästa sätten att optimera FLA-filer för Animate
    15. Inställningar för ActionScript-publicering
    16. Ange publiceringsinställningar för Animate
    17. Exportera projektorfiler
    18. Exportera bilder och animerade GIF-filer
    19. Publiceringsmallar för HTML
    20. Arbeta med Adobe Premiere Pro och After Effects
    21. Dela och publicera animeringar snabbt

Arbeta med bibliotek

I biblioteket i Animate-dokument lagras mediefiler som du skapat i Animate-miljön eller importerat för användning i dokumentet. Du kan skapa vektorgrafik eller text direkt i Animate, importera vektorgrafik, bitmappar, video och ljud och skapa symboler. En symbol är en bild, en knapp, ett filmklipp eller en text som du skapar en gång och kan återanvända flera gånger. Du kan även lägga till mediainnehåll dynamiskt i ett dokument i ActionScript.

Biblioteket innehåller även alla komponenter som du har lagt till i dokumentet. Komponenter kan vara antingen kompilerade klipp eller MovieClip-baserade komponenter.

Du kan öppna biblioteksfilen i alla Animate-dokument när du arbetar i Animate och göra biblioteksobjekten från den filen tillgängliga för det aktuella dokumentet. Du kan söka efter symboler i biblioteket efter deras namn eller deras ActionScript-länkningsnamn.

Du kan skapa permanenta bibliotek i Animate-programmet som finns tillgängliga när du startar Animate. I Animate finns även flera exempel på bibliotek som innehåller knappar, bilder, filmklipp och ljud.

Du kan exportera biblioteksresurser som en SWF-fil till en URL och skapa bibliotek som delas vid körning. Detta gör att du kan skapa en länk till biblioteksmaterialet från Animate-dokument som importerar symboler som använder körtidsdelning.

På bibliotekspanelen (Fönster > Bibliotek) visas en listruta med namnen på alla objekt i biblioteket, vilket innebär att du kan visa och ordna dessa element när du arbetar. En ikon bredvid ett objektnamn på bibliotekspanelen anger objektets filtyp.

Obs!

Funktionen för att dra objekt från scenen till bibliotekspanelen för att konvertera en symbol är borttagen och kan inte användas i Animate.

Funktionen för att dra objekt till scenen över två dokument som inte dockats är borttagen och kan inte användas i Animate.

Öppna ett bibliotek i en annan Animate-fil

  1. Välj Arkiv > Importera > Öppna externt bibliotek från det aktuella dokumentet.
  2. Bläddra till den Animate-fil vars bibliotek du vill öppna och klicka på Öppna.

    Den valda filens bibliotek öppnas i det aktuella dokumentet, med filnamnet längst upp på bibliotekspanelen. Om du vill använda objekt från den valda filens bibliotek i det aktuella dokumentet drar du objekten till det aktuella dokumentets bibliotekspanel eller till scenen.

Ändra storlek på bibliotekspanelen

  1. Gör något av följande:
    • Dra i panelens nedre högra hörn.

    • Klicka på knappen Brett biblioteksfönster om du vill förstora bibliotekspanelen så att alla kolumner visas.

    • Klicka på knappen Smalt biblioteksfönster om du vill minska bredden på bibliotekspanelen.

Ändra bredden för kolumner

  1. Placera pekaren mellan kolumnrubrikerna och dra så ändras storleken.

Arbeta med mappar i bibliotekspanelen

Du kan ordna biblioteksobjekten på bibliotekspanelen med hjälp av mappar. När du skapar en ny symbol sparas den i den markerade mappen. Om ingen mapp är markerad sparas symbolen i rotbiblioteket.

Animerade GIF-filer importeras också på ett mer ordnat sätt i Animate eftersom de placeras i en separat mapp i bibliotekets rotmapp och alla associerade bitmappar namnges baserat på ordningsföljden. 

Skapa en ny mapp

  1. Klicka på knappen Ny mapp längst ner på bibliotekspanelen.

Öppna eller stänga en mapp

  1. Dubbelklicka på mappen eller markera mappen och välj Visa mappinnehåll eller Dölj mappinnehåll på panelmenyn för bibliotekspanelen.

Öppna eller stänga alla mappar

  1. Välj Visa alla mappars innehåll eller Dölj alla mappars innehåll från panelmenyn för bibliotekspanelen.

Flytta ett objekt mellan mappar

  1. Dra objektet från en mapp till en annan.

    Om det finns ett objekt med samma namn på den nya platsen uppmanas du att ersätta det med det objekt som du flyttar i Animate.

Sortera objekt på bibliotekspanelen

I kolumnerna på bibliotekspanelen listas namnet på ett objekt, objekttypen, antal gånger det används i filen, objektets länkstatus och identifierare (om objektet associeras med ett delat bibliotek eller om det exporteras för ActionScript) och det datum som det senast ändrades.

Du kan sortera objekt i en kolumn på bibliotekspanelen i alfanumerisk ordning. Objekten sorteras i mappar.

Animerade GIF-filer som importeras till Animate-biblioteket placeras i en separat mapp i bibliotekets rotmapp och alla associerade bitmappar namnges baserat på ordningsföljden. 

  1. Klicka på den kolumnrubrik vars kolumn du vill sortera. Klicka på triangelknappen till höger om kolumnrubrikerna om du vill sortera i omvänd ordning.

Konflikter mellan biblioteksobjekt

Om du importerar eller kopierar ett biblioteksobjekt till ett dokument som redan innehåller ett annat objekt med samma namn måste du välja om du vill ersätta det befintliga objektet med det nya objektet. Det här alternativet är tillgängligt med alla metoder för att importera eller kopiera biblioteksobjekt.

Dialogrutan Lös biblioteksobjekt visas när du försöker placera ut objekt som hamnar i konflikt med befintliga objekt i ett dokument. En konflikt uppstår om du kopierar ett objekt från ett källdokument som redan finns i måldokumentet och objekten har olika ändringsdatum. Undvik namnkonflikter genom att ordna objekten i mappar i dokumentets bibliotek. Dialogrutan visas också när du klistrar in en symbol eller komponent på dokumentets scen och redan har en kopia av symbolen eller komponenten som har ett annat ändringsdatum än den som du vill klistra in.

Om du väljer att inte ersätta befintliga objekt i Animate används det befintliga objektet istället för det objekt som du vill klistra in. Om du till exempel kopierar en symbol med namnet Symbol 1 och klistrar in kopian på scenen i ett dokument som redan innehåller en symbol med namnet Symbol 1 skapas en instans av den befintliga Symbol 1 i Animate.

Om du väljer att ersätta befintliga objekt i Animate ersätts befintliga objekt (och alla deras instanser) med de nya objekten med samma namn. Om du avbryter importen eller kopieringen avbryts den för alla objekt (inte bara för dem som hamnar i konflikt i måldokumentet).

Endast identiska biblioteksobjekttyper kan ersätta varandra. Det går alltså inte att ersätta ljudet Test med bitmappen Test. I sådana fall läggs de nya objekten till i biblioteket med ordet kopia i namnet.

Obs!

Det går inte att ångra om du ersätter biblioteksobjekt med den här metoden. Spara en säkerhetskopia av FLA-filen innan du klistrar in, när konflikter måste lösas genom ersättning av biblioteksobjekt.

Om dialogrutan Lös bibliotekskonflikt visas när du importerar eller kopierar biblioteksobjekt till ett dokument måste du lösa namnkonflikten.

Lösa namnkonflikter mellan biblioteksobjekt

  1. Gör något av följande i dialogrutan Lös bibliotekskonflikt:

    • Om du vill bevara befintliga objekt i måldokumentet klickar du på Ersätt inte befintliga objekt.

    • Om du vill ersätta befintliga objekt och deras instanser med de nya objekten med samma namn klickar du på Ersätt befintliga objekt.

Arbeta med biblioteksobjekt

När du markerar ett objekt på bibliotekspanelen visas en miniatyrbild av objektet längst upp på bibliotekspanelen. Om det markerade objektet är animerat eller om det är en ljudfil kan du använda knappen Spela upp i bibliotekets förhandsgranskningsfönster eller kontrollenheten för att förhandsgranska objektet.

Söka bland biblioteksobjekt via länkningsnamn

Du kan söka efter symboler på bibliotekspanelen efter deras namn eller deras ActionScript-länkningsnamn.

  • Sök efter ett biblioteksobjekt genom att skriva in de första bokstäverna i symbolnamnet eller ActionScript-länkningsnamnet. Efterhand som du skriver visas en lista med matchande symboler på bibliotekspanelen.

Använda ett biblioteksobjekt i det aktuella dokumentet

  1. Dra objektet från bibliotekspanelen till scenen.

    Objektet läggs till i det aktuella lagret.

Konvertera ett objekt på scenen till en symbol i biblioteket

  1. Markera objektet på scenen, högerklicka och välj Konvertera till symbol.

Använda ett biblioteksobjekt från det aktuella dokumentet i ett annat dokument

  1. Dra objektet från bibliotekspanelen eller scenen till bibliotekspanelen eller scenen i ett annat dokument.

Kopiera biblioteksobjekt från ett annat dokument

  1. Markera dokumentet som innehåller biblioteksobjekten.
  2. Markera biblioteksobjekten på bibliotekspanelen.
  3. Välj Redigera > Kopiera.
  4. Markera dokumentet som du vill kopiera biblioteksobjekten till.
  5. Markera dokumentets bibliotekspanel.
  6. Välj Redigera > Klistra in.

Redigera ett biblioteksobjekt

  1. Markera objektet på bibliotekspanelen.
  2. Välj något av följande från panelmenyn för bibliotekspanelen:
    • Om du vill redigera ett objekt i Animate väljer du Redigera.

    • Om du vill redigera ett objekt i ett annat program väljer du Redigera med och sedan väljer du ett externt program.

Obs!

När du startar ett externt redigeringsprogram öppnas det importerade originaldokumentet i Animate.

Byta namn på ett biblioteksobjekt

Om du byter namn på biblioteksobjektet för en importerad fil ändras inte filnamnet.

  1. Gör något av följande:
    • Dubbelklicka på objektnamnet.

    • Markera objektet och välj Byt namn på panelmenyn för bibliotekspanelen.

    • Högerklicka (Windows) eller Control-klicka (Macintosh) på objektet och välj Byt namn på snabbmenyn.

  2. Ange det nya namnet i rutan.

Ta bort ett biblioteksobjekt

När du tar bort ett objekt från biblioteket tas även alla instanser eller förekomster av det objektet i dokumentet bort.

  1. Markera objektet och klicka på papperskorgsikonen längst ned på bibliotekspanelen.

Söka efter oanvända biblioteksobjekt

Om du vill ordna ditt dokument kan du söka efter oanvända biblioteksobjekt och ta bort dem.

Obs!

Du behöver inte ta bort oanvända biblioteksobjekt för att minska filstorleken på ett Animate-dokument, eftersom oanvända biblioteksobjekt inte inkluderas i SWF-filen. Däremot tas objekt som är länkade för export med i SWF-filen.

  1. Gör något av följande:
    • Markera alternativet för oanvända objekt på panelmenyn för bibliotekspanelen.

    • Sortera biblioteksobjekt efter kolumnen Antal, som anger om ett objekt används.

Uppdatera importerade filer i biblioteket

Om du använder ett externt redigeringsprogram när du ändrar filer som du har importerat till Animate, till exempel bitmappar eller ljudfiler, kan du uppdatera filerna i Animate utan att importera dem på nytt. Du kan även uppdatera symboler som du har importerat från externa Animate-dokument. Om du uppdaterar en importerad fil ersätts filens innehåll med innehållet i den externa filen.

Obs! Importerade animerade GIF-filer placeras i en separat mapp i bibliotekets rotmapp, där alla associerade bitmappar namnges baserat på ordningsföljden. 

  1. Markera den importerade filen på bibliotekspanelen.
  2. Välj Uppdatera från panelmenyn för bibliotekspanelen.

Kopiera biblioteksobjekt mellan dokument

Du kan kopiera biblioteksobjekt från ett källdokument till ett måldokument på flera olika sätt. Du kan också dela symboler mellan dokument som delade biblioteksobjekt vid redigering eller körning.

Om du försöker kopiera objekt som har samma namn som befintliga objekt i måldokumentet kan du i dialogrutan Lös bibliotekskonflikter välja om du vill skriva över befintliga objekt eller bevara befintliga objekt och lägga till nya objekt med ändrade namn. Ordna biblioteksobjekt i mappar för att minska namnkonflikter när du kopierar objekt mellan dokument.

Kopiera ett biblioteksobjekt genom att kopiera och klistra in

  1. Markera objektet på scenen i källdokumentet.

  2. Välj Redigera > Kopiera.

  3. Gör måldokumentet till aktivt dokument.

  4. Om du vill klistra in objektet mitt på det synliga klippbordet placerar du pekaren på scenen och väljer Redigera > Klistra in i mitten. Om du vill placera objektet på samma plats som i källdokumentet väljer du Redigera > Klistra in på plats.

Kopiera ett biblioteksobjekt genom att dra

  1. Med måldokumentet öppet markerar du objektet i bibliotekspanelen i källdokumentet och drar objektet till bibliotekspanelen i måldokumentet.

Kopiera ett biblioteksobjekt genom att öppna källdokumentbiblioteket i måldokumentet

  1. Med måldokumentet aktivt väljer du Arkiv > Importera > Öppna externt bibliotek.

  2. Markera källdokumentet och klicka på Öppna.

  3. Dra ett objekt från biblioteket i källdokumentet till scenen eller till biblioteket i måldokumentet.

Adobes logotyp

Logga in på ditt konto