Klassiska interpoleringar är ett äldre sätt att skapa animeringar i Animate. Dessa interpoleringar liknar de nyare rörelseinterpoleringarna, men är något mer komplicerade att skapa och mindre flexibla. Med klassiska interpoleringar har du dock möjlighet att styra animeringarna på sätt som du inte kan göra om du använder rörelseinterpoleringar. De flesta användare väljer att arbeta med de nyare rörelseinterpoleringarna, men vissa användare vill fortfarande använda klassiska interpoleringar. Mer information om skillnaderna finns i Skillnader mellan rörelseinterpoleringar och klassiska interpoleringar.

Innan du börjar:

Innan du arbetar med klassiska interpoleringar bör du tänka på följande punkter:

  • Klassiska interpoleringar är det äldre sättet att skapa interpolerade animeringar i Animate. Det nyare, enklare sättet är att använda rörelseinterpoleringar. Se Animering med rörelseinterpolering.

  • Det går inte att interpolera 3D-egenskaper med klassiska interpoleringar.

Exempel på animeringar med klassisk interpolering finns på Animate-exempelsidan på www.adobe.com/go/learn_fl_samples_se. Följande exempel är tillgängliga:

  • Animerad skugga: Ladda ner och expandera filen Samples.zip och navigera sedan till mappen Graphics\AnimatedDropShadow för att komma åt exemplet.

  • Animering och övertoningar: Ladda ner och expandera filen Samples.zip och navigera sedan till mappen Graphics\AnimationAndGradients för att komma åt exemplet.

Obs!

Animering liksom många andra funktioner i Animate kräver inte ActionScript. Men du kan skapa animering med ActionScript om du vill.

Skapa och redigera nyckelbildrutor för animering med klassiska interpoleringar

Ändringar i en animering med klassisk interpolering definieras i en nyckelbildruta. I en interpolerad animering definierar du nyckelbildrutor vid lämpliga punkter i animeringen och sedan skapas innehållet i mellanliggande bildrutor automatiskt i Animate. De interpolerade bildrutorna i en interpolerad animering visas i ljusblåttt, och en pil ritas ut mellan nyckelbildrutorna. Eftersom Animate-dokument sparar formerna i varje nyckelbildruta skapar du bara nyckelbildrutor vid de punkter i grafiken där någonting ändras.

Nyckelbildrutor markeras i tidslinjen. En fylld cirkel representerar en nyckelbildruta med innehåll, medan en tom cirkel framför bildrutan representerar en tom nyckelbildruta. Efterföljande bildrutor som läggs till i samma lager har samma innehåll som nyckelbildrutan.

Det går bara att redigera nyckelbildrutor i en klassisk interpolering. Du kan visa interpolerade bildrutor, men du kan inte redigera dem direkt. Om du vill redigera interpolerade bildrutor ändrar du en av de definierande nyckelbildrutorna eller infogar en ny nyckelbildruta mellan den inledande och den avslutande nyckelbildrutan. Dra objekt från bibliotekspanelen till scenen för att lägga till objekten i den aktuella nyckelbildrutan.

Information om hur du visar och redigerar flera bildrutor i taget finns i Använda cellanimering.

Obs!

Det här funktionen är till för att skapa nyckelbildrutor för de äldre klassiska interpoleringarna. Mer information om nyckelbildrutor för egenskaper för de nyare rörelseinterpoleringarna finns i Skapa interpoleringsanimering.

Skapa nyckelbildrutor

  1. Gör något av följande:
    • Markera en bildruta i tidslinjen och välj Infoga > Tidslinje > Nyckelbildruta.

    • Högerklicka (Windows) eller Control-klicka (Macintosh) på en bildruta i tidslinjen och välj Infoga nyckelbildruta.

Infoga bildrutor på tidslinjen

  • Om du vill infoga en ny bildruta väljer du Infoga > Tidslinje > Bildruta.

  • Om du vill skapa en nyckelbildruta väljer du Infoga > Tidslinje > Nyckelbildruta eller högerklickar (Windows) eller Control-klickar (Macintosh) på bildrutan för att placera en nyckelbildruta. Välj Infoga nyckelbildruta.

  • Om du villl skapa en tom nyckelbildruta väljer du Infoga > Tidslinje > Tom nyckelbildruta eller högerklickar (Windows) eller Control-klickar (Macintosh) på bildrutan för att placera nyckelbildrutan. Välj Infoga tom nyckelbildruta.

Ta bort eller ändra en bildruta eller nyckelbildruta

  • Om du vill ta bort en bildruta, nyckelbildruta eller bildrutesekvens markerar du den, högerklickar (Windows) eller Control-klickar (Macintosh) och väljer Ta bort bildrutor. Omgivande bildrutor påverkas inte.

  • Om du vill flytta en nyckelbildruta eller bildrutesekvens och dess innehåll markerar och drar du den till önskad plats.

  • Om du vill utöka varaktigheten för en nyckelbildruta håller du ned Alt (Windows) eller Option (Macintosh) och drar den till den sista bildrutan i den nya sekvensen.

  • Om du vill kopiera och klistra in en nyckelbildruta eller bildrutesekvens markerar du den och väljer Redigera > Tidslinje > Kopiera bildrutor. Markera en bildruta eller bildrutesekvens och välj Redigera > Tidslinje > Klistra in bildrutor. Om du vill klistra in och ersätta det exakta antalet kopierade bildrutor på måltidslinjen använder du alternativet Klistra in och skriv över bildrutor.

  • Om du vill konvertera en nyckelbildruta till en bildruta markerar du nyckelbildrutan och väljer Ändra > Tidslinje > Rensa nyckelbildruta eller högerklickar (Windows) eller Control-klickar (Macintosh) på den och väljer Rensa nyckelbildruta. Den rensade nyckelbildrutan och alla bildrutor fram till nästa nyckelbildruta ersätts med innehållet i bildrutan framför den rensade nyckelbildrutan.

  • Om du vill kopiera en nyckelbildruta eller bildrutesekvens genom att dra markerar du den och håller ned Alt (Windows) eller Option (Macintosh) samtidigt som du drar den till önskad plats.

  • Om du vill ändra längden för en interpolerad sekvens drar du den inledande eller den avslutande nyckelbildrutan till vänster eller höger.

  • Om du vill lägga till ett biblioteksobjekt till den aktuella nyckelbildrutan drar du objektet från bibliotekspanelen till scenen.

  • Om du vill spegelvända en animeringssekvens markerar du de aktuella bildrutorna i ett eller flera lager och väljer Ändra > Tidslinje > Spegelvänd bildrutor. Nyckelbildrutor måste finnas i början och i slutet av sekvensen.

Lägga till animering med klassisk interpolering i en instans, en grupp eller text

Obs!

Det här funktionen är till för att skapa äldre klassiska interpoleringar. Mer information om hur du skapar de nyare rörelseinterpoleringarna finns i Skapa interpoleringsanimering.

Om du vill interpolera ändringar av egenskaper för instanser, grupper och typer kan du använda en klassisk interpolering. Animate kan interpolera position, storlek, rotation och skevning av instanser, grupper och typer. Animate kan även interpolera färgen för instanser och typer, skapa gradvisa färgändringar och få en instans att tona in eller ut.

Om du vill interpolera färgen för grupper eller typer gör du om dem till symboler. Om du vill animera enskilda tecken i ett textblock för sig, placerar du varje tecken i ett separat textblock.

Om du använder en klassisk interpolering och ändrar antalet bildrutor mellan de båda nyckelbildrutorna, interpoleras bildrutorna på nytt automatiskt. Eller om du flyttar gruppen eller symbolen i någon av nyckelbildrutorna, interpoleras bildrutorna på nytt.

 

Skapa en klassisk interpoleringsanimation.

  1. Om du vill göra ett lager till ett aktivt lager klickar du på ett lagernamn och väljer en tom nyckelbildruta i lagret för att starta. Det här bildrutan blir den första bildrutan i den klassiska interpoleringen.

  2. Om du vill lägga till innehåll i den första bildrutan för den klassiska interpoleringen gör du något av följande:
    • Skapa ett grafiskt objekt med något av verktygen Ritstift, Oval, Rektangel, Penna eller Pensel och konvertera det sedan till en symbol.

    • Skapa en instans, en grupp eller ett textblock på scenen.

    • Dra en instans av en symbol från bibliotekspanelen.

    Obs!

    Om du vill skapa en interpolering kan du bara ha ett objekt i lagret.

  3. Skapa en ny nyckelbildruta där du vill att animeringen ska sluta och behåll den nya nyckelbildrutan markerad.
  4. Gör något av följande om du vill ändra objektet i den sista bildrutan:
    • Flytta objektet till en ny position.

    • Ändra storlek, rotation och skevning för objektet.

    • Ändra objektets färg (endast instanser och textblock). Använd forminterpolering om du vill skapa interpolering för färg på andra element än instanser och textblock.

  5. Om du vill skapa en klassisk interpolering gör du något av följande:
    • Klicka på någon av bildrutorna i interpoleringens bildruteintervall och välj Infoga > Klassisk interpolering.

    • Högerklicka (Windows) eller Control-klicka (Macintosh) på en bildruta i interpoleringens bildruteintervall och välj Skapa klassisk interpolering på snabbmenyn.

    Om du skapade ett grafiskt objekt i steg 2 konverteras objektet automatiskt i Animate till en symbol med namnet tween1.

  6. Om du vill interpolera storleken på det markerade objektet väljer du skala i avsnittet Interpolering i egenskapsinspektören. En nödvändig förutsättning är att du ändrar objektets storlek i steg 4.

  7. Om du vill skapa en mer realistisk upplevelse av rörelse använder du en övergång för den klassiska interpoleringen. Om du vill använda en övergång på en klassisk interpolering använder du fältet Övergång i egenskapsinspektören. Använd dialogrutan Anpassad övergång för att mer exakt kontrollera den klassiska interpoleringens hastighet.

    Om du vill justera ändringshastigheten mellan interpolerade bildrutor drar du i värdet i fältet för övergångar eller anger ett värde.

    • Om du vill börja den klassiska interpoleringen långsamt och öka interpoleringshastigheten mot slutet av animeringen anger du ett negativt värde mellan -1 och -100.

    • Om du vill börja den klassiska interpoleringen snabbt och minska interpoleringshastigheten mot slutet av animeringen anger du ett positivt värde mellan 1 och 100.

    • Om du vill skapa en mer komplex ändring av hastigheten i interpoleringens bildruteintervall klickar du på knappen Redigera bredvid fältet Övergång. Då öppnas dialogrutan Anpassad övergång.

      Som standard är ändringshastigheten mellan interpolerade bildrutor konstant. En övergång skapar en naturligare hastighetsökning eller hastighetsminskning genom att ändringshastigheten gradvis justeras.

  8. Om du vill rotera det markerade objekt under interpoleringen väljer du ett alternativ på menyn Rotera i egenskapsinspektören:
    • Välj Ingen (standardinställningen) om du vill förhindra rotering.

    • Välj Auto om du vill rotera objektet en gång i den riktning som kräver minst rörelse.

    • Välj Medurs eller Moturs om du vill rotera objektet med- eller moturs och ange sedan ett värde för antal rotationer.

    Obs!

    Rotationen i steg 8 sker utöver eventuell rotation i den sista bildrutan i steg 4.

  9. Om du använder en rörelsebana väljer du Orientera mot bana i egenskapsinspektören för att orientera det interpolerade elementets baslinje längs rörelsebanan.
  10. Om du vill synkronisera animeringen av grafiksymbolinstanser med huvudtidslinjen väljer du alternativet Synka i egenskapsinspektören.

    Obs!

    Både alternativet Synka symboler och alternativet Synka omberäknar antalet bildrutor i en interpolering så att de matchar antalet bildrutor som interpoleringen tilldelas på tidslinjen. Använd alternativet Synka om antalet bildrutor i en animeringssekvens inte är en jämn multipel av antalet bildrutor i grafikinstansen.

  11. Om du använder en rörelsebana väljer du Fäst för att fästa det interpolerade elementet till rörelsebanan från registreringspunkten.

Arbeta med klassiska interpoleringar sparade som XML-filer

I Animate kan du arbeta med klassiska interpoleringar sparade som XML-filer. I Animate kan du använda följande kommandon på en klassisk interpolering:

  • Kopiera rörelse som XML

  • Exportera rörelse som XML

  • Importera rörelse som XML

Kopiera rörelse som XML

Gör att du kan kopiera rörelseegenskaper tillämpade på objekt på scenen vid den specificerade bildrutan. 

  1. Skapa en klassisk interpolering.

  2. Markera en bildruta på tidslinjen.

  3. Välj Kommandon > Kopiera rörelse som XML.

Rörelseegenskaperna kopieras till urklipp som XML-data. Du kan sedan använda valfri textredigerare för att arbeta med XML-filen.

Exportera rörelse som XML

Gör att du kan exportera rörelseegenskaper tillämpade på objekt på scenen till en XML-fil som kan sparas.

 

  1. Skapa en klassisk interpolering. 

  2. Välj Kommandon > Exportera rörelse som XML.

  3. Bläddra till en plats där du vill spara filen.

  4. Ange ett namn på XML-filen och klicka på Spara.

    Den klassiska interpoleringen exporteras som en XML-fil till den angivna platsen.

Importera rörelse som XML

Gör att du kan importera en befintlig XML-fil som innehåller definierade rörelseegenskaper.

  1. Markera ett objekt på scenen.

  2. Välj Kommandon > Importera rörelse som XML.

  3. Bläddra till platsen och markera XML-filen. Klicka på OK.

  4. I dialogrutan Klistra in rörelse-special väljer du de egenskaper som du vill tillämpa på det markerade objektet.

  5. Klicka på OK.

Skapa ett lager med rörelsestödlinjer

Om du vill styra hur objekt i en rörelseinterpolerad animering rör sig skapar du ett lager med rörelsestödlinjer.

Du kan inte dra ett lager med rörelseinterpolering eller attitydlager med omvänd kinematik till ett stödlinjelager.

  1. Dra ett normalt lager till ett stödlinjelager. Denna åtgärd gör att stödlinjelagret konverteras till ett lager med rörelsestödlinjer och det normala lagret länkas till det nya lagret med rörelsestödlinjer.

    Obs!

    Om du vill förhindra att du råkar konvertera ett stödlinjelager placerar du alla stödlinjelager längst ned i lagerordningen.

Skapa animering med klassisk interpolering längs en bana

Obs!

Den här funktionen är till för att arbeta med äldre klassiska interpoleringar. Mer information om hur du använder de nyare rörelseinterpoleringarna med rörelsebanor finns i Redigera rörelsebanan för en interpoleringsanimering.

Med hjälp av lager med rörelsestödlinjer kan du rita banor längs vilka interpolerade instanser, grupper och textblock kan animeras. Du kan länka flera lager till ett lager med rörelsestödlinjer så att flera objekt följer samma bana. Ett normalt lager som är länkat till ett lager med rörelsestödlinjer blir ett stödlinjelager.

Rörelsebana
I det här exemplet är två objekt i olika lager kopplade till samma rörelsebana.

Skapa en rörelsebana för en klassiskt interpolerad animering

  1. Skapa en klassiskt interpolerad animeringssekvens.

    Om du väljer Orientera mot bana i egenskapsinspektören orienteras det interpolerade elementets baslinje längs rörelsebanan. Om du väljer Fäst fäster registreringspunkten för det interpolerade elementet till rörelsebanan.

  2. Högerklicka (Windows) eller Control-klicka (Macintosh) på namnet på det lager som innehåller den klassiska interpoleringen och välj Lägg till klassisk rörelsestödlinje.

    Animate lägger till ett lager med rörelsestödlinjer ovanför det klassiska interpoleringslagret och drar in namnet på det klassiska interpoleringslagret. Det betyder att det klassiska interpoleringslagret är knutet till lagret med rörelsestödlinjer.

    Obs!

    Om du redan har en stödlinjelager i tidslinjen kan du dra ett lager som innehåller den klassiska interpoleringen under stödlinjelagret. Den här åtgärden konverterar stödlinjelagret till en rörelsestödlinje och knyter den klassiska interpoleringen till den.

    Lager med rörelsestödlinjer
    Ett lager med rörelsestödlinjer ovanför lagret med den klassiska interpoleringen.
  3. Om du vill lägga till en sökväg till lagret med rörelsestödlinjer väljer du lagret med rörelsestödlinjer och använder verktyget Ritstift, Penna, Linje, Cirkel, Rektangel eller Pensel.

    Du kan också klistra in en linje på lagret med rörelsestödlinjer.

  4. Dra objektet du interpolerar för att fästa det vid början av den första bildrutan eller vid slutet av den sista bildrutan.

    En bild som är fäst vid början av en stödlinje
    En bild av en bil, fäst vid början av en stödlinje.

    Obs!

    Bäst resultat för fästningen får du genom att dra symbolen vid dess omformningspunkt.

  5. Om du vill dölja lagret med rörelsestödlinjer och banan klickar du på ögonikonskolumnen på lagret med rörelsestödlinjer. Om du döljer dem syns endast objektets rörelse när du arbetar. 

    Gruppen eller symbolen följer rörelsebanan när du spelar animeringen.

Mer information om animeringar som baseras på streck med varierande bredd och färg finns i animeringsguiden

  1. Gör något av följande:
    • Dra ett befintligt lager under lagret med rörelsestödlinjer. Lagret dras in under lagret med rörelsestödlinjer. Alla objekt i det här lagret fästs automatiskt till rörelsebanan.

    • Skapa ett lager under lagret med rörelsestödlinjer. Objekt som interpoleras på det här lagret interpoleras automatiskt längs rörelsebanan.

    • Markera ett lager under ett lager med rörelsestödlinjer. Välj Ändra > Tidslinje > Lageregenskaper och välj sedan Stödlinje.

  1. Om du vill bryta länken markerar du lagret och gör något av följande:

    • Dra lagret ovanför lagret med rörelsestödlinjer.

    • Välj Ändra > Tidslinje > Lageregenskaper och välj sedan Normalt som lagertyp.

Klistra in egenskaper för animering med klassiska interpoleringar

Obs!

Den här funktionen är till för att klistra in egenskaper för äldre klassiska interpoleringar. Mer information om hur du klistrar in egenskaper för de nyare rörelseinterpoleringarna finns i Kopiera och klistra in egenskaper för rörelseinterpolering.

Med kommandot Klistra in rörelse kan du kopiera en klassisk interpolering och klistra in enbart de specifika egenskaper som ska gälla för ett annat objekt.

  1. Markera de bildrutor på tidslinjen som innehåller den klassiska interpolering som du vill kopiera. Bildrutorna du markerar måste finnas i samma lager, men de behöver inte omfatta en enskild klassisk interpolering. Markeringen kan omfatta en interpolering, tomma bildrutor eller två eller flera interpoleringar.
  2. Välj Redigera > Tidslinje > Kopiera rörelse.

  3. Om du vill ta emot den kopierade klassiska interpoleringen väljer du symbolinstansen.

  4. Välj Redigera > Tidslinje > Klistra in rörelse-special. Markera de specifika interpoleringsegenskaper du vill klistra in för symbolinstansen. Interpoleringsegenskaperna är:

    X-position

    Hur långt ett objekt flyttas längs x-axeln.

    Y-position

    Hur långt ett objekt flyttas längs y-axeln.

    Vågrät skala

    Proportionsvärdena mellan objektets aktuella storlek och dess naturliga storlek i horisontell riktning (X).

    Lodrät skala

    Anger proportionsvärdena mellan objektets aktuella storlek och dess naturliga storlek i vertikal riktning (Y).

    Rotation och skevning

    Rotation och skevning för objektet. Dessa egenskaper måste användas tillsammans för ett objekt. Skevning är ett mått på rotation i grader och när du roterar och skevar påverkar egenskaperna varandra.

    Färg

    Alla färgvärden tillämpas på objektet, t.ex. färgton, intensitet och alfavärden.

    Filter

    Alla filtervärden och ändringar för det valda intervallet. Om filter tillämpas på ett objekt klistras filtret in med alla värden intakta, och dess läge (aktiverat eller inaktiverat) tillämpas även på det nya objektet.

    Blandningsläge

    Tillämpar objektets blandningsläge.

    Ersätt målobjektets skalegenskaper

    När alternativet är avmarkerat klistras alla egenskaper in i förhållande till målobjektet. När alternativet är markerat åsidosätts målets skalegenskaper.

    Ersätt målets rotations- och skevningsegenskaper

    När alternativet är avmarkerat klistras alla egenskaper in i förhållande till målobjektet. När alternativet är markerat åsidosätter de inklistrade egenskaperna objektets befintliga rotations- och skalegenskaper.

    Den nödvändiga bildrute-, interpolerings- och symbolinformationen infogas så att den överensstämmer med den ursprungliga kopierade interpoleringen.

    Använd kommandot Kopiera rörelse som ActionScript 3.0 för att kopiera en klassisk interpolering för en symbol till åtgärdspanelen eller för att använda den som ActionScript i ett annat projekt.

Skapa förinställda övergångar

Förinställningar för övergångar är förkonfigurerade övergångar som du kan använda på ett objekt på scenen.

Det finns en uppsättning vanliga förinställningar för övergångar för klassiska interpoleringar. Du kan välja önskad förinställning i en lista och använda den på den valda egenskapen.

  1. Klicka på ett lager som innehåller en interpolering på tidslinjen i Animate.

  2. Öppna interpoleringsegenskaper genom att klicka på kategorin Interpolering på egenskapspanelen. Du kommer åt egenskapsbaserade övergångar i listrutan Övergångstyp.

    Interpoleringsegenskaper
    Interpoleringsegenskaper

    Du kan använda förinställda övergångar för klassiska interpoleringar på egenskapsbasis. På egenskapspanelen finns ett alternativ för egenskapsbaserade övergångar. Du kan välja Alla egenskaper för sig för att använda olika förinställda övergångar för varje egenskap. 

    Förinställningar på egenskapsbasis
    Förinställningar på egenskapsbasis

    Du kan välja unika förinställningar för övergångar för positions-, rotations-, skal-, färg- och filteregenskaperna hos en klassisk interpolering. 

    Position anger övergångsinställningarna för positionen hos ett animerat objekt på scenen.

    Rotation anger övergångsinställningarna för rotationen hos ett animerat objekt på scenen.  

    Skala anger övergångsinställningarna för skalningen av ett animerat objekt på scenen. 

    Färg anger övergångsinställningarna för färgövergångarna som tillämpas på ett animerat objekt på scenen. 

    Filter anger övergångsinställningarna för filter som tillämpas på ett animerat objekt på scenen. 

  3. Om du vill använda samma övergång för alla egenskaper i interpoleringen väljer du i stället Alla egenskaper tillsammans. Välj förinställd övergång i dialogrutan för övergångar och dubbelklicka på den förinställda övergång som ska användas.

    Om du väljer en klassisk övergång kan du även öka och minska övergångens intensitet genom att flytta reglaget. 

    Lista över förinställda övergångar
    Lista över förinställda övergångar
  4. Klicka på redigeringsikonen bredvid Övergång om du vill använda en anpassad övergång.

Om du använder dokumenttypen HTML5 Canvas kan du skapa en optimerad js-utdatafil för förinställda övergångar. I HTML5 Canvas används övergångsfunktionerna i Tween JS när utdata skapas. 

Använda anpassad övergång på klassisk interpolering

Obs!

Den här funktionen är till för att lägga till övergångar i äldre klassiska interpoleringar. Mer information om hur du lägger till övergångar för de nyare rörelseinterpoleringarna finns i Övergångar för interpoleringsanimeringar.

I dialogrutan Anpassad övergång visas ett diagram över graden av rörelse över tiden. Bildrutor visas på den vågräta axeln och den procentuella ändringen visas på den lodräta axeln. Den första bildrutan visas som 0 % och den sista som 100 %.

Lutningen på diagrammets kurva visar ändringshastigheten för objektet. När kurvan är vågrät (ingen lutning) är hastigheten noll och när kurvan är lodrät sker en omedelbar ändring.

Diagram för Anpassad övergång till/övergång från
Diagram över anpassad övergång som visar konstant hastighet. Öppna den här dialogrutan genom att markera en bildruta i en klassisk interpolering och klicka på knappen Redigera i avsnittet Övergång i egenskapsinspektören.

Spara anpassade övergångar

Du kan spara anpassade övergångar genom att klicka på en knapp och återanvända dem genom att välja en anpassad övergång i listan över egna anpassningar. Klicka på Spara och använd i redigeringsläget när du har gjort ändringarna. I följande skärmbild visas den egna förinställningen för övergångar med namnet MyEase1.

Obs!

Du kan endast återanvända de egna förinställda övergångarna i samma dokumenttyp.

Egen förinställning för övergångar
Egen förinställning för övergångar

Du kan använda förinställda övergångar på flera intervall på tidslinjen genom att markera intervallen och lägga till övergången.

Förinställning för övergångar för flera intervall
Förinställning för övergångar för flera intervall

Fler kontroller för dialogrutan Anpassad övergång

Knapparna Spela upp och Stoppa

Gör det möjligt att förhandsgranska en animering på scenen med alla rörelsekurvor som har definierats i dialogrutan Anpassad övergång.

Ta bort

Tar bort den aktuella anpassade övergången. 

Spara och använd

Sparar och använder ändringarna du har gjort på de förinställda övergångarna. 

Återställningsknapp

Gör det möjligt att återställa hastighetskurvan till standardläge (linjärt).

Position för den markerade kontrollpunkten

I dialogrutans nedre högra hörn visar ett numeriskt värde nyckelbildrutan och positionen för den markerade kontrollpunkten. Om ingen kontrollpunkt är markerad visas inget värde.

Klicka en gång på den diagonala linjen för att lägga till en kontrollpunkt på den. Om du vill ha en mer exakt kontroll över ett objekts rörelse drar du kontrollpunkternas positioner.

Med hjälp av bildruteindikatorer (fyrkantiga handtag) kan du klicka där du vill att hastigheten ska öka eller minska för ett objekt. När du klickar på det fyrkantiga handtaget för en kontrollpunkt markeras den aktuella kontrollpunkten och tangerande punkter på båda sidor visas. Ofyllda cirklar representerar tangerande punkter. Om du vill positionera dem drar du kontrollpunkten eller dess tangerande punkter med musen eller använder piltangenterna på tangentbordet.

Tips! Som standard fäster kontrollpunkterna mot ett rutnät. Du kan inaktivera fästfunktionen genom att trycka ned X-tangenten medan du drar kontrollpunkten.

Om du klickar i ett område på kurvan utanför en kontrollpunkt läggs en kontrollpunkt till på kurvan vid den punkten. Denna åtgärd ändrar inte formen på kurvan. Om du klickar utanför kurvan och kontrollpunkterna avmarkeras den markerade kontrollpunkten.

Lägga till en anpassad övergång

  1. Markera ett lager på tidslinjen där en klassisk interpolering används.

  2. Klicka på knappen Redigera bredvid skjutreglaget för övergång i egenskapsinspektören för bildrutan.
  3. Om du vill lägga till en kontrollpunkt Ctrl-klickar (Windows) eller Kommando-klickar (Macintosh) du på den diagonala linjen.
  4. Om du vill öka hastigheten för objektet drar du kontrollpunkten uppåt och om du vill minska hastigheten drar du den nedåt.
  5. Dra i hörnhandtagen om du vill göra ytterligare ändringar av övergångskurvan och finjustera interpoleringens övergångsvärde.
  6. Klicka på knappen Spela upp i det nedre vänstra hörnet om du vill visa animeringen på scenen.

  7. Justera kontrollerna tills du uppnår önskad effekt.

Obs!

Om du använder dialogrutan Anpassad övergång visar redigeringsfältet --. Om du använder Redigera eller skjutreglaget ställs diagrammet för förinställd övergång in efter motsvarande kurva. Och kryssrutan Använd en inställning för alla egenskaper är markerad.

Kopiera och klistra in en övergångskurva

  • Tryck på Ctrl+C (Windows) eller Kommando+C (Macintosh) om du vill kopiera den aktuella övergångskurvan.

  • Tryck på Ctrl+V (Windows) eller Kommando+V (Macintosh) om du vill klistra in den kopierade kurvan i en annan övergångskurva.

    Du kan kopiera och klistra in övergångskurvan. Den kopierade kurvan är tillgänglig tills du avslutar Animate-programmet.

Övergångskurvor som ej stöds

Vissa typer av övergångskurvor stöds inte. Ingen del av diagrammet kan representera en icke-linjär kurva (t.ex. en cirkel).

Dialogrutan Anpassad övergång till/övergång från hindrar automatiskt att en kontrollpunkt eller ett tangenthandtag flyttas till en position som ger en ogiltig kurva:

  • Alla punkter måste finnas i diagrammet. Det går inte att flytta kontrollpunkter utanför diagrammets gränser.

  • Alla segment i kurvan måste finnas i diagrammet. Kurvan blir flackare för att förhindra att den sträcker sig utanför diagrammets gränser.

Denna produkt är licensierad enligt en Creative Commons Erkännande-Ickekommersiell-Dela Lika 3.0 Unported-licens  Twitter™- och Facebook-inlägg omfattas inte av villkoren i Creative Commons-licensen.

Juridiska meddelanden   |   Onlinesekretesspolicy