Skapa tidslinjelager med Animate

  1. Användarhandbok för Adobe Animate
  2. Introduktion till Animate
    1. Nyheter i Animate
    2. Visuell ordlista
    3. Systemkrav för Animate
    4. Tangentbordsgenvägar för Animate
    5. Arbeta med flera filtyper i Animate
  3. Animering
    1. Grunderna vid animering i Animate
    2. Så här använder du bildrutor och nyckelbildrutor i Animate
    3. Animering bildruta för bildruta i Animate
    4. Arbeta med klassiska interpolerade animeringar i Animate
    5. Pensel
    6. Rörelseguide
    7. Rörelseinterpoleringar och ActionScript 3.0
    8. Om animeringar med rörelseinterpolering
    9. Animeringar med rörelseinterpolering
    10. Skapa en animering med rörelseinterpolering
    11. Använda nyckelbildrutor för egenskaper
    12. Animera placering med en interpolering
    13. Så här redigerar du rörelseinterpoleringar med rörelseredigeraren
    14. Redigera rörelsebanan för en interpolerad animering
    15. Ändra rörelseinterpoleringar
    16. Lägga till anpassade övergångar
    17. Skapa och använda förinställda rörelser
    18. Konfigurera interpoleringsintervall för animeringar
    19. Arbeta med rörelseinterpoleringar sparade som XML-filer
    20. Rörelseinterpoleringar jämfört med klassiska interpoleringar
    21. Forminterpolering
    22. Använda animeringar med benverktyget i Animate
    23. Arbeta med figurriggning i Animate
    24. Så här använder du maskeringslager i Adobe Animate
    25. Så här arbetar du med scener i Animate
  4. Interaktivitet
    1. Så här skapar du knappar med Animate
    2. Konvertera Animate-projekt till andra dokumenttypsformat
    3. Skapa och publicera HTML5 Canvas-dokument i Animate
    4. Lägga till interaktivitet med kodfragment i Animate
    5. Skapa anpassade HTML5-komponenter
    6. Använda komponenter i HTML5 Canvas
    7. Skapa anpassade komponenter: Exempel
    8. Kodfragment för anpassade komponenter
    9. God praxis - annonsera med Animate
    10. Redigera och publicera VR
  5. Arbetsyta och arbetsflöde
    1. Skapa och hantera målarpenslar
    2. Använda Google Fonts i HTML5 Canvas-dokument
    3. Använda Creative Cloud Libraries och Adobe Animate
    4. Använda scen- och verktygspanelerna i Animate
    5. Arbetsflöde och arbetsyta i Animate
    6. Använda webbteckensnitt i HTML5 Canvas-dokument
    7. Tidslinjer och ActionScript
    8. Arbeta med flera tidslinjer
    9. Ange inställningar
    10. Använda redigeringspanelerna i Animate
    11. Skapa tidslinjelager med Animate
    12. Exportera animeringar för mobilprogram och spelplattformar
    13. Flytta och kopiera objekt
    14. Mallar
    15. Söka och ersätta i Animate
    16. Ångra, gör om och panelen Historik
    17. Kortkommandon
    18. Så här använder du tidslinjen i Animate
    19. Skapa HTML-tillägg
    20. Optimeringsalternativ för bilder och animerade GIF-filer
    21. Exportinställningar för bilder och GIF-filer
    22. Panelen Resurser i Animate
  6. Multimedia och video
    1. Omforma och kombinera grafikobjekt i Animate
    2. Skapa och arbeta med symbolinstanser i Animate
    3. Bildkalkering
    4. Så här använder du ljud i Adobe Animate
    5. Exportera SVG-filer
    6. Skapa videofiler för användning i Animate
    7. Så här lägger du till en video i Animate
    8. Arbeta med videoreferenspunkter
    9. Rita och skapa objekt med Animate
    10. Omforma linjer och former
    11. Linjer, fyllningar och övertoningar med Animate CC
    12. Arbeta med Adobe Premiere Pro och After Effects
    13. Färgpaneler i Animate CC
    14. Öppna Flash CS6-filer i Animate
    15. Arbeta med klassisk text i Animate
    16. Placera grafik i Animate
    17. Importerade bitmappar i Animate
    18. 3D-grafik
    19. Arbeta med symboler i Animate
    20. Rita linjer och former med Adobe Animate
    21. Arbeta med bibliotek i Animate
    22. Exportera ljud
    23. Markera objekt i Animate CC
    24. Arbeta med Illustrator AI-filer i Animate
    25. Tillämpa mönster med sprejpenseln
    26. Använda blandningslägen
    27. Ordna objekt
    28. Automatisera uppgifter med kommandomenyn
    29. Flerspråkig text
    30. Använda kameran i Animate
    31. Använda Animate med Adobe Scout
    32. Arbeta med Fireworks-filer
    33. Grafikfilter
    34. Ljud och ActionScript
    35. Ritinställningar
    36. Rita med ritstift
  7. Plattformar
    1. Konvertera Animate-projekt till andra dokumenttypsformat
    2. Stöd för anpassade plattformar
    3. Skapa och publicera HTML5 Canvas-dokument i Animate
    4. Skapa och publicera ett WebGL-dokument
    5. Så här paketerar du AIR för iOS-program
    6. Publicera AIR for Android-program
    7. Publicera för Adobe AIR för datorprogram
    8. Inställningar för ActionScript-publicering
    9. God praxis – organisera ActionScript i ett program
    10. Så här använder du ActionScript med Animate
    11. God praxis – riktlinjer för hjälpmedel
    12. Hjälpmedel på arbetsytan i Animate
    13. Skriva och hantera skript
    14. Aktivera stöd för anpassade plattformar
    15. Översikt över stöd för anpassade plattformar
    16. Skapa hjälpmedelsanpassat innehåll
    17. Arbeta med plugin-program för anpassade plattformar
    18. Felsöka ActionScript 3.0
    19. Aktivera stöd för anpassade plattformar
  8. Exportera och publicera
    1. Så här exporterar du filer från Animate CC
    2. OAM-publicering
    3. Exportera SVG-filer
    4. Exportera bilder och video med Animate
    5. Publicera AS3-dokument
    6. Exportera animeringar för mobilprogram och spelplattformar
    7. Exportera ljud
    8. Exportera QuickTime-videofiler
    9. Styra extern videouppspelning med ActionScript
    10. God praxis – tips för att skapa innehåll på mobila enheter
    11. God praxis – videokonventioner
    12. God praxis – riktlinjer för utveckling av SWF-program
    13. God praxis – strukturera FLA-filer
    14. De bästa sätten att optimera FLA-filer för Animate
    15. Inställningar för ActionScript-publicering
    16. Ange publiceringsinställningar för Animate
    17. Exportera projektorfiler
    18. Exportera bilder och animerade GIF-filer
    19. Publiceringsmallar för HTML
    20. Arbeta med Adobe Premiere Pro och After Effects
    21. Dela och publicera animeringar snabbt

Skapa och ordna lager

Med lager kan du ordna grafiken i dokument. Du kan rita och redigera objekt på ett lager utan att det påverkar objekt på ett annat lager. I områden på scenen utan något på ett lager kan du se igenom det till lagren under.

Om du vill rita, måla eller ändra ett lager eller en mapp på något annat sätt markerar du lagret på tidslinjen så att det blir aktivt. En pennikon bredvid ett lager- eller mappnamn på tidslinjen anger att lagret eller mappen är aktiv(t). Endast ett lager i taget kan vara aktivt (men fler än ett lager i taget kan markeras).

När du skapar ett Animate-dokument innehåller det endast ett lager. Om du vill ordna teckningar, animeringar och andra element i ett dokument lägger du till fler lager. Du kan även dölja, låsa och ordna om lager. Antalet lager som du kan skapa begränsas endast av datorns minne. Lager ökar inte storleken på den publicerade SWF-filen. Endast objekt som du skapar i lager ökar filstorleken.

Om du vill ordna och hantera lager skapar du lagermappar och lägger lagren i dem. Du kan utöka och komprimera lagermappar på tidslinjen utan att det påverkar det som visas på scenen. Använd separata lager eller mappar för ljudfiler, ActionScript, bildruteetiketter och bildrutekommentarer. Separata lager gör det enklare att snabbt hitta objekten när du vill redigera dem.

Om du vill skapa avancerade effekter kan du använda speciella stödlinjelager för att göra det enklare att rita och redigera samt för att skapa maskeringslager.

Du kan använda fem typer av lager i Animate:

  • Normala lager innehåller större delen av grafiken i en fla-fil.

  • Maskeringslager innehåller objekt som används som masker för att dölja delar av lager under dem. Mer information finns i Använda maskeringslager.

  • Maskerade lager ligger under ett maskeringslager och associeras med maskeringslagret. Endast den del av maskeringslagret som visas av masken syns. Mer information finns i Använda maskeringslager.

  • Stödlinjelager innehåller linjer som kan användas för att hjälpa dig placera objekt i andra lager. Du kan även använda dem som stöd när det gäller rörelse för klassiska interpoleringar i andra lager. Mer information finns i Stödlinjelager och Skapa klassisk rörelseinterpolering längs en bana.

  • Lager med stödlinjer är lager som är associerade med ett stödlinjelager. Objekten i lagret med stödlinjer kan ordnas och animeras längs linjerna i stödlinjelagret. Lager med stödlinjer kan innehålla statisk grafik och klassiska interpoleringar, men inte rörelseinterpoleringar.

  • Rörelseinterpoleringslager innehåller objekt animerade med rörelseinterpoleringar. Mer information finns i Interpolerad animering.

  • Armaturlager innehåller objekt med kopplade IK-ben (omvänd kinematik). Mer information finns i Använda benverktyget för animeringar med omvänd kinematik.

Normala lager, maskeringslager, maskerade lager och stödlinjelager kan innehålla rörelseinterpoleringar eller IK-ben (omvänd kinematik). När det finns sådana objekt i något av de här lagren begränsas vilka typer av innehåll som kan läggas till i lagret. Mer information finns i Rörelseinterpoleringar och Använda benverktyget för animeringar med omvänd kinematik.

Skapa ett lager

När du skapar ett lager visas det ovanför det markerade lagret. Det nya lagret blir aktivt lager.

  1. Gör något av följande:
    • Klicka på knappen för nytt lager under tidslinjen.

    • Välj Infoga > Tidslinje > Lager.

    • Högerklicka (Windows) eller Control-klicka (Macintosh) på ett lagernamn på tidslinjen och välj Infoga lager på snabbmenyn.

Skapa en lagermapp

  1. Gör något av följande:
    • Markera ett lager eller en mapp på tidslinjen och välj Infoga > Tidslinje > Lagermapp.

    • Högerklicka (Windows) eller Control-klicka (Macintosh) på ett lagernamn på tidslinjen och välj Infoga mapp på snabbmenyn. Den nya mappen visas ovanför det markerade lagret eller den markerade mappen.

    • Klicka på ikonen för ny mapp under tidslinjen. Den nya mappen visas ovanför det markerade lagret eller den markerade mappen.

Ordna lager och lagermappar

Om du vill ordna dina dokument kan du ordna om lager och mappar på tidslinjen.

Med lagermappar kan du ordna arbetsflödet genom att placera lagren i en trädstruktur. Om du vill visa lagren i en mapp utan att påverka vilka lager som visas på scenen utökar eller komprimerar du mappen. Mappar kan innehålla både lager och andra mappar, vilket gör det möjligt att ordna lager på ungefär samma sätt som du ordnar filer på din dator.

Lagerkontrollerna på tidslinjen påverkar alla lager i en mapp. Om du låser en mapp låses till exempel alla lager i mappen.

  • Om du vill flytta ett lager eller en lagermapp till en lagermapp drar du namnet på lagret eller lagermappen till namnet på lagermappen dit du vill flytta dem.
  • Om du vill ändra ordningen på lager eller mappar drar du ett eller flera lager eller mappar på tidslinjen till rätt plats.
  • Om du vill utöka eller komprimera en mapp klickar du på triangeln till vänster om mappnamnet.
  • Om du vill utöka eller komprimera alla mappar högerklickar (Windows) eller Control-klickar (Macintosh) du och väljer Visa alla mappars innehåll eller Dölj alla mappars innehåll.

Byta namn på ett lager eller en mapp

Som standard tilldelar Animate namn till nya lager namn efter ordningen de skapas i: Lager 1, Lager 2 och så vidare. Du kan byta namn på lagren efter innehållet.

  1. Gör något av följande:
    • Dubbelklicka på namnet på lagret eller mappen på tidslinjen och ange ett nytt namn.

    • Högerklicka (Windows) eller Control-klicka (Macintosh) på namnet på lagret eller mappen och välj Egenskaper på snabbmenyn. Ange det nya namnet i textrutan Namn och klicka på OK.

    • Markera lagret eller mappen på tidslinjen och välj Ändra > Tidslinje > Lageregenskaper. Ange det nya namnet i textrutan Namn och klicka på OK.

Markera ett lager eller en mapp

  1. Gör något av följande:
    • Klicka på namnet på lagret eller mappen på tidslinjen.

    • Markera genom att klicka på en bildruta på tidslinjen.

    • Markera ett objekt på scenen som ligger i lagret som du vill markera.

    • Om du vill markera sammanhängande lager eller mappar Skift-klickar du på namnen på tidslinjen.

    • Om du vill markera icke sammanhängande lager eller mappar Ctrl-klickar (Windows) eller Kommando-klickar (Macintosh) du på namnen på tidslinjen.

Kopiera bildrutor från ett enskilt lager

  1. Markera ett intervall av bildrutor på ett lager. Om du vill markera hela lagret klickar du på lagernamnet på tidslinjen.
  2. Välj Redigera > Tidslinje > Kopiera bildrutor.

  3. Klicka på bildrutan där du vill börja klistra in och välj sedan Redigera > Tidslinje > Klistra in bildrutor. Om du vill klistra in och ersätta det exakta antalet kopierade bildrutor på måltidslinjen använder du alternativet Klistra in och skriv över bildrutor.

    Arbetsflöde för att klistra in och skriva över bildrutor

    A. Markera bildrutorna och kopiera dem. B. Högerklicka på den bildruta du vill klistra in över och välj Klistra in och skriv över bildrutor. C. De inklistrade bildrutorna skriver över samma antal bildrutor på tidslinjen. 

Kopiera bildrutor från en lagermapp

  1. Om du vill markera hela mappen ska du komprimera mappen (klicka på triangeln till vänster om mappnamnet på tidslinjen) och klicka på mappnamnet. 

  2. Välj Redigera > Tidslinje > Kopiera bildrutor.

  3. Om du vill skapa en mapp väljer du Infoga > Tidslinje > Lagermapp.

  4. Klicka på den nya mappen och välj Redigera > Tidslinje > Klistra in bildrutor.

Ta bort ett lager eller en mapp

  1. Om du vill markera lagret eller mappen klickar du på namnet på tidslinjen eller en bildruta i lagret.
  2. Gör något av följande:
    • Klicka på knappen Ta bort lager på tidslinjen.

    • Dra lagret eller mappen till knappen Ta bort lager.

    • Högerklicka (Windows) eller Control-klicka (Macintosh) på lager- eller mappnamnet och välj Ta bort lager på snabbmenyn.

    Obs!

    När du tar bort en lagermapp tas även lagren i den och innehållet i dem bort.

Låsa eller låsa upp ett eller flera lager eller en eller flera mappar

  • Om du vill låsa ett lager eller en mapp klickar du i låskolumnen till höger om namnet. Om du vill låsa upp lagret eller mappen klickar du i kolumnen Lås igen.

  • Om du vill låsa alla lager och mappar klickar du på hänglåsikonen. Om du vill låsa upp alla lager och mappar klickar du på den igen.

  • Om du vill låsa eller låsa upp flera lager eller mappar drar du genom kolumnen Lås.

  • Om du vill låsa alla andra lager eller mappar Alt-klickar (Windows) eller Option-klickar (Macintosh) du i låskolumnen. Om du vill låsa upp alla lager eller mappar Alt-klickar eller Option-klickar (Macintosh) du i låskolumnen igen.

Kopiera och klistra in lager (endast CS5.5)

Du kan kopiera hela lager och lagermappar på tidslinjen, och klistra in dem på samma tidslinje eller på olika tidslinjer. Det går att kopiera alla typer av lager.

När du kopierar och klistrar in lager behålls lagermappsstrukturen för det kopierade lagret.

  1. Markera ett eller flera lager på tidslinjen genom att klicka på lagernamnet. Skift-klicka om du vill markera flera intilliggande lager. Ctrl-klicka (Windows) eller Command-klicka (Macintosh) för att markera lager som inte ligger intill varandra.

  2. Välj Redigera > Tidslinje > Kopiera lager eller Klipp ut lager. Du kan även högerklicka på lagren och välja Kopiera lager eller Klipp ut lager på snabbmenyn.

  3. På den tidslinje som du vill klistra in i markerar du lagret omedelbart under där du vill att det inklistrade lagret ska infogas.

  4. Välj Redigera > Tidslinje > Klistra in lager.

Lagren visas på tidslinjen ovanför det markerade lagret. Om du har en lagermapp markerad kommer de inklistrade lagren att visas i den mappen.

Om du vill placera ett lager i en mask eller ett stödlinjelager, måste du först markera ett lager under masken eller stödlinjen och sedan klistra in det. Du kan varken klistra in en mask, en stödlinje eller ett mapplager under ett mask- eller stödlinjelager.

Du kan även duplicera lager genom att markera dem och välja Redigera > Tidslinje > Duplicera lager. De nya lagren kommer att ha ordet ”kopia” bifogat till lagernamnet.

Ange egenskaper för flera lager

  1. Skapa en FLA-fil eller öppna en befintlig fil i Animate.

  2. Markera de lager vars egenskaper du vill ändra, högerklicka och välj Egenskaper.

  3. Ändra egenskaperna i dialogrutan Lageregenskaper.

  4. Klicka på OK.

Visa eller dölja ett lager eller en mapp

Ett rött X bredvid ett lager- eller mappnamn på tidslinjen anger att lagret eller mappen är dold. I publiceringsinställningarna kan du välja om dolda lager ska inkluderas när du publicerar en SWF-fil.

  • Om du vill dölja ett lager eller en mapp klickar du i ögonkolumnen till höger om namnet på lagret eller mappen på tidslinjen. Om du vill visa lagret eller mappen klickar du i den igen.

  • Om du vill dölja alla lager och mappar på tidslinjen klickar du på ögonikonen. Om du vill visa alla lager och mappar klickar du på den igen.

  • Om du vill visa eller dölja flera lager eller mappar drar du genom ögonikonskolumnen.

  • Om du vill dölja alla lager och mappar utom det aktuella lagret eller den aktuella mappen Alt-klickar (Windows) eller Option-klickar (Macintosh) du i ögonikonskolumnen. Om du vill visa alla lager och mappar Alt-klickar eller Option-klickar du i den igen.

Visa innehållet i ett lager som konturer

Om du vill avgöra vilket lager ett objekt tillhör visar du alla objekt i lagret som färgade konturer.

  • Om du vill visa alla objekt på lagret som konturer klickar du i konturkolumnen till höger om lagrets namn. Om du vill slå av konturvisning klickar du i den igen.

  • Om du vill visa objekt på alla lager som konturer klickar du på konturikonen. Om du vill slå av konturvisning på alla lager klickar du på den igen.

  • Om du vill visa objekt i alla lager utom det aktuella lagret som konturer Alt-klickar (Windows) eller Option-klickar (Macintosh) du i konturkolumnen. Om du vill stänga av konturvisning för alla lager Alt‑klickar eller Option-klickar du i den igen.

Obs!

Lagrets konturfärg används även för rörelsebanorna i lagret.

Ändra ett lagers konturfärg

  1. Gör något av följande:
    • Dubbelklicka på lagrets ikon (ikonen till vänster om lagernamnet) på tidslinjen.

    • Högerklicka (Windows) eller Control-klicka (Macintosh) på lagernamnet och välj Egenskaper på snabbmenyn.

    • Markera lagret på tidslinjen och välj Ändra > Tidslinje > Lageregenskaper.

  2. I dialogrutan Lageregenskaper klickar du i paletten Konturfärg, väljer en ny färg och klickar på OK.

Visa lager och lagermappar

Visa eller dölja ett lager eller en mapp

Ett rött X bredvid ett lager- eller mappnamn på tidslinjen anger att lagret eller mappen är dold. I publiceringsinställningarna kan du välja om dolda lager ska inkluderas när du publicerar en SWF-fil.

  • Om du vill dölja ett lager eller en mapp klickar du i ögonkolumnen till höger om namnet på lagret eller mappen på tidslinjen. Om du vill visa lagret eller mappen klickar du i den igen.

  • Om du vill dölja alla lager och mappar på tidslinjen klickar du på ögonikonen. Om du vill visa alla lager och mappar klickar du på den igen.

  • Om du vill visa eller dölja flera lager eller mappar drar du genom ögonikonskolumnen.

  • Om du vill dölja alla lager och mappar utom det aktuella lagret eller den aktuella mappen Alt-klickar (Windows) eller Option-klickar (Macintosh) du på i ögonikonskolumnen. Om du vill visa alla lager och mappar Alt-klickar eller Option-klickar du i den igen.

Visa innehållet i ett lager som konturer

Om du vill avgöra vilket lager ett objekt tillhör visar du alla objekt i lagret som färgade konturer.

  • Om du vill visa alla objekt på lagret som konturer klickar du i konturkolumnen till höger om lagrets namn. Om du vill slå av konturvisning klickar du i den igen.

  • Om du vill visa objekt på alla lager som konturer klickar du på konturikonen. Om du vill slå av konturvisning på alla lager klickar du på den igen.

  • Om du vill visa objekt på alla lager utom det aktuella lagret Alt-klickar (Windows) eller Option-klickar (Macintosh) du i konturkolumnen. Om du vill slå av konturvisning för alla lager Alt‑klickar eller Option-klickar du i den igen.

Ändra ett lagers konturfärg

  1. Gör något av följande:
    • Dubbelklicka på lagrets ikon (ikonen till vänster om lagernamnet) på tidslinjen.

    • Högerklicka (Windows) eller Control-klicka (Macintosh) på lagernamnet och välj Egenskaper på snabbmenyn.

    • Markera lagret på tidslinjen och välj Ändra > Tidslinje > Lageregenskaper.

  2. I dialogrutan Lageregenskaper klickar du i paletten Konturfärg, väljer en ny färg och klickar på OK.

Obs!

Lagrets konturfärg används även för rörelsebanorna i lagret.

Ställa in lagergenomskinlighet

  1. Skapa en FLA-fil eller öppna en befintlig i Animate.

  2. Skift-klicka på ögonikonskolumnen på tidslinjen för att ställa in synligheten på genomskinligt.

    Obs!

    Skift-klicka har ingen effekt på dolda lager.

    Ställa in lagergenomskinlighet
    Ställa in lagergenomskinlighet

  3. Använd något av följande alternativ för att ange genomskinlighet för lager:

    • Högerklicka på ett lager och välj Egenskaper på snabbmenyn. I dialogrutan Lageregenskaper väljer du Synlighet > Genomskinlig.
    • Högerklicka på ett lager och välj Visa andra som genomskinliga.
    Lageregenskaper
    Lageregenskaper

  4. Klicka på OK.

Obs!

Lagergenomskinlighet har ingen effekt på dolda lager. 

Använda avancerade lager

I Animate med läge för avancerade lager publiceras alla lager i tidslinjen som symboler. I läget för avancerade lager kan du använda följande funktioner:

Läget för Avancerade lager är aktiverat som standard. Du kan aktivera eller inaktivera avancerade lager med hjälp av inställningen Ändra > Dokument. När du har tillämpat ändringarna klickar du på Använd som standard om du vill bevara aktuell inställning för kommande dokument och i alla Animate-sessioner. 

Läge för avancerade lager
Läge för avancerade lager

När du vill komma åt de här symbolerna med hjälp av skript i Animate måste du anropa dem med "layer" som objekt. När du inte använder avancerade lager kan du till exempel komma åt en symbol direkt med ett skript som ser ut ungefär som detta: 

getchildbyname("symbol1");

Om du använder avancerade lager kan du däremot bara komma åt symbolen genom ett lager och genom att använda ett skript som ser ut ungefär som detta:

Layer=getchildbyname("L1");

Layer.getchildbyname("symbol1");

En exempelkod för att komma åt symboler med avancerade lager för dokumenttypen AS3: 

Var Layer:MovieClip =MovieClip(getchildbyname("L1"));
Layer.getchildbyname("symbol1");

En exempelkod för att komma åt symboler med avancerade lager för dokumenttypen HTML5 Canvas: 

Layer=this.getchildbyname("L1");
Layer.getchildbyname("symbol1");

Följande bild visar hur du kommer åt en symbol med hjälp av skript med avancerade lager och utan avancerade lager. 

Bild som visar hur du kommer åt en symbol med och utan avancerade lager
Bild som visar hur du kommer åt en symbol med och utan avancerade lager

Obs!

Storleken på publicerade animeringsprojekt kan öka när du använder avancerade lager i Animate. Om du stöter på problem när du använder kamera- eller lagerdjupsfunktioner ska du kontrollera om de avancerade lagren är PÅ. Om läget är inaktiverat ska du aktivera det för att få förväntad funktion. 

Tillämpa lagereffekter

Filtren och färgeffekterna brukade endast kunna tillämpas på filmklipp. Med de avancerade lagren kan filter och färgeffekter nu tillämpas på markerade bildrutor, där de i sin tur tillämpas på allt deras innehåll inklusive former, ritobjekt, grafiska symboler och så vidare. Lagereffekter kan också interpoleras med hjälp av klassiska, form- och IK-interpoleringar på alla bildrutor.

Du kan tillämpa lagereffekter på individuella eller flera bildrutor genom att välja önskade bildrutor. Du kan också tillämpa lagereffekter på alla bildrutor i ett lager genom att välja hela lagret. Lagereffekter kan också tillämpas på en symbols tidlinje, som filmklipp och grafiska symboler och på alla scener.

Obs!

Lagereffekter kan endast tillämpas när läget för avancerade lager är PÅ. Du kanske måste aktivera läget för avancerade lager uttryckligen specifikt för filer för att kunna använda denna funktionalitet.

Använda filter för bildrutor

Om du vill lägga till filter för en viss bildruta väljer du först bildrutan. Panelen Egenskapsinspektören läser in de bildrutespecifika egenskaperna. Klicka på +-ikonen i Filter-listrutan. 

Bildrutefilter
Bildrutefilter

När du lägger till filter på bildrutor visas egenskapsinspektören som i följande skärmbild. 

Du kan ställa in egenskaperna för varje filter enligt vad du behöver och tillämpa dem på bildrutenivå. Interpolering kan tillämpas på alla bildrutefilter. 

Filteregenskaper för bildrutor i egenskapsinspektören
Filteregenskaper för bildrutor i egenskapsinspektören

Obs!

Lagereffekter stöds endast i dokumenttypen ActionScript 3. Rörelseinterpolering och kameralager stödjer inte lagereffekter. 

Använda färgeffekter

Välj först bildrutan för att tillämpa färgeffekt på en viss bildruta. Panelen Egenskapsinspektör läser in de bildrutespecifika egenskaperna. Välj önskad färgegenskap på panelen Egenskapsinspektör.

Färgeffekter
Färgeffekter

Använda blandningslägen

Om du vill använda blandningslägen på en viss bildruta måste du först välja bildruta och sedan ett blandningsläge i avsnittet Visa på bildrutepanelen.

När du använder blandning på lager eller bildrutor används det på allt dess innehåll, inklusive former, ritobjekt och grafiska symboler. Alla objekt på ett lager blandas med objekt på ett annat lager enligt det blandningsläge som används på den bildrutan.

Lagerblandningslägen

Mer information om blandningslägen finns i Använda blandningslägen.

Tillämpa lagerdjup

Som animatör kan du placera lager på olika plan i en 2D-animering, vilket skapar en illusion av djup. 

Du kan ändra djupet på lagren dynamiskt på panelen Lagerdjup. Klicka på Fönster > Lagerdjup när du vill öppna panelen Lagerdjup.

Lagerdjup som representerar varje lager
Lagerdjup som representerar varje lager

Obs!

Du kan ställa in minimi- och maximivärdena för lagerdjup inom intervallet –-5 000 till 10 000.

Värdena för lagerdjup står bredvid varje lagernamn för respektive bildruta så som bilden ovan visar.

  • Håll musen över ett värde, klicka och dra skjutreglaget åt höger eller vänster.
  • Om du vill minska djupet drar du skjutreglaget åt vänster. Om du vill öka djupet drar du skjutreglaget åt höger. 
  • Du kan använda lägre positiva värden för objekt som är närmare och högre positiva värden för objekt som är längre bort.

Du kan interpolera lagerdjupsvärdena i samtliga interpoleringsintervall för animeringen. 

Varje lager representeras med unika färgade linjer på panelen för lagerdjup. Du kan visa färgerna som representerar de olika lagren i tidslinjen. 

Du kan också öka eller minska djupet på objekten i varje lager genom att flytta de flerfärgade linjerna uppåt eller nedåt.

  • Klicka på och dra linjen uppåt om du vill minska djupet för objekten i ett lager.
  • Klicka på och dra linjen nedåt om du vill öka djupet för objekten i ett lager.

En bild som visar animeringar med och utan lagerdjup:

Innehåll utan lagerdjup
Innehåll utan lagerdjup

Innehåll med lagerdjup
Innehåll med lagerdjup

En bild som visar en animering när lagerdjup används:

Du kan använda kameran på lager med flera plan för att skapa en parallaxeffekt eller zooma in i innehållet på ett plan. Du kan även låsa kameran på ett specifikt lager eller använda kameraeffekter vid körning med hjälp av interaktiva API:er. Mer information finns i Skapa parallaxeffekt med kamera och lagerdjup.

Obs!

Lagerdjup är endast tillämpbart endast på huvudtidslinjen.

Bevara lagerdjupets storlek

Du kan ändra objekts lagerdjup utan att påverka objektens format och position. Klicka på Bevara storlek i det övre högra hörnet på panelen Lagerdjup när du vill använda funktionen för att bevara storlek.

Du kan använda alternativet för att bevara storleken på två sätt:

  • Klicka på Bevara storlek och ändra lagerdjupet på det önskade lagret. Knappen Bevara storlek ändras automatiskt.
  • Håll Alt-tangenten intryckt när du tillfälligt vill aktivera Bevara storlek samtidigt som du drar värdena för lagerdjup.
Bevara lagerdjupets storlek
Bevara lagerdjupets storlek

Tillämpa lagerdjup vid körning

Du kan också använda kameran på objekt vid körning och lägga till effekter genom att använda kamera-API:er. Mer information finns i Använda den interaktiva kameran vid körning

Lagerdjups-API för AS3

Du kan hantera lagren vid körning genom att använda API:er, till exempel om du vid körning vill lägga till ett extra lager i animeringen eller minska djupet för ett av lagren i animeringen. 

Metod

Prototyp

Exempel

Beskrivning

setLayerZDepth

fl.Layer.setLayerZDepth(timeline,
layerName,zDepth)

fl.Layer.setLayerZDepth("layerName", 100);

Ställa in Z-djupvärde för ett visst lager.

getLayerZDepth

fl.Layer.getLayerZDepth(layerName) :zDepth

fl.Layer.getLayerZDepth("layerName");

Returnera Z-djupvärdet för ett visst lager.

addNewLayer

fl.Layer.addNewLayer(layerName,
zDepth=0)

fl.Layer.addNewLayer("layerName",-80);

Lägga till nytt lager på tidslinjen och ställa in Z-djupet.

removeLayer

fl.Layer.removeLayer(layerName)

fl.Layer.removeLayer("layerName");

Ta bort ett lager från tidslinjen.

Lagerdjups-API för HTML Canvas

Metod

Prototyp

Exempel

Beskrivning

setLayerZDepth

AdobeAn.Layer.setLayerZDepth(layerName,
zDepth)

console.log(fl.Layer.setLayerZDepth
("layerName",100));

Ställa in Z-djupvärde för ett visst lager.

getLayerZDepth

AdobeAn.Layer.getLayerZDepth(layerName)
:zDepth

console.log(fl.Layer.getLayerZDepth
("layerName"));

Returnera Z-djupvärdet för ett visst lager.

Överordnade lager

Med Animate kan ett lager underordnas ett annat. Med överordnade lager är det lätt att göra så att ett lager/objekt i animeringen styr ett annat lager/objekt. Det gör att animeringstiden minskar för animerings- och speldesigners eftersom rörelserna i figurens olika delar kan styras lättare.

Avancerade lager måste vara aktiverade när du vill använda den överordnade lagervyn. Som standard är Avancerade lager aktiverade för nya filer. Du kan aktivera den överordnade lagervyn genom att klicka på hierarkiikonen överst till höger på tidslinjen.

Visa överordnad lagervy
Visa överordnad lagervy

Obs!

Överordning för förvrängda objekt fungerar endast när det underordnade lagerobjektets omformningspunkt finns på det överordnade lagerobjektet.

Överordnade och underordnade lager

Om du drar lager 1 ovanpå lager 2 i den överordnade lagervyn blir lager 1 underordnat lager till det överordnade lagret 2. Objektet på det underordnade lagret ärver positionen och rotationen hos objektet på det överordnade lagret i tillägg till sina egna egenskaper. När du flyttar eller roterar det överordnade objektet kommer det underordnade objektet att flyttas eller roteras tillsammans med det överordnade objektet. Du kan skapa flera överordnade och underordnade relationer för att skapa en hierarki.

Överordnade lager

Du kan koppla ett lager till ett annat genom att klicka på lagerhandtaget (färghuvud) och dra det över ett annat lager. Eller också kan du så klickar du någonstans på det vågräta rektangulära området bredvid ett lagernamn och dra det över det andra lagret. Du kan också klicka en gång på ett lager och välja överordnat lager åt det i popup-listan. 

En streckad linje visas i närheten av lagrets färghuvud när du klickar och drar i linjen. En överordnad/underordnad koppling skapas mellan de två lagren så fort du slutar att klicka och dra.

Ställa in överordnat lager
Ställa in överordnat lager

Färghuvudet längst till vänster i hierarkivyn representerar det överordnade lagret. Hierarkin flyttar sig från vänster till höger.

Du kan ta bort kopplingen genom att klicka på något lagers färghuvud och att dra den streckade linjen och släppa den. Eller också kan du klicka på det vågräta utrymmet och klicka på Ta bort överordnad som i skärmbilden nedan. 

Ta bort överordnad
Ta bort överordnad

På skärmbilderna nedan kan du se lagrens hierarki och deras positioner före och efter det att du använt överordnade lager.

Före och efter det att du tillämpat överordnade lager
Före och efter det att du tillämpat överordnade lager

Ett exempel som visar användningen av överordnade lager på mänskliga kroppsdelar visas nedan.

Exempel på kroppsdelar med överordnade lager
Exempel på kroppsdelar med överordnade lager

På bilden ovan

  • Överkroppen är överordnad alla andra kroppsdelar.
  • Ben_lår är överordnat andra delar av benet som gymnastiksko, ben_under och ankel.
  • Huvudet är underordnat halsen och överkroppen är överordnad halsen. När du drar halsen bort från kroppen så flyttas huvudet tillsammans med den.
Obs!

Överordnade lager är en bildruteegenskap som du måste ställa in för varje nyckelbildruta i det underordnade lagret. I en nyckelbildruta kan du koppla bort och ansluta ett underordnat lager till ett annat överordnat lager.

En självstudiekurs om överordnade lager

Lär dig skapa en hierarki med över- och underordnade lager och manipulera dina kompositioner med lätthet.
Adobes logotyp

Logga in på ditt konto