Användarhandbok Avbryt

Så här använder du ljud i Adobe Animate

  1. Användarhandbok om Adobe Animate
  2. Introduktion till Animate
    1. Nyheter i Animate
    2. Visuell ordlista
    3. Systemkrav för Animate
    4. Tangentbordsgenvägar för Animate
    5. Arbeta med flera filtyper i Animate
  3. Animering
    1. Grunderna vid animering i Animate
    2. Så här använder du bildrutor och nyckelbildrutor i Animate
    3. Animering bildruta för bildruta i Animate
    4. Så här arbetar du med klassiska övergångsanimeringar i Animate
    5. Pensel
    6. Rörelseguide
    7. Rörelseinterpoleringar och ActionScript 3.0
    8. Om övergångsanimeringar med rörelse
    9. Animeringar med rörelseinterpolering
    10. Skapa en animering med rörelseinterpolering
    11. Använda nyckelbildrutor för egenskaper
    12. Animera placering med en interpolering
    13. Så här redigerar du rörelseinterpoleringar med rörelseredigeraren
    14. Redigera rörelsebanan för en interpolerad animering
    15. Ändra rörelseinterpoleringar
    16. Lägga till anpassade övergångar
    17. Skapa och använda förinställda rörelser
    18. Konfigurera interpoleringsintervall för animeringar
    19. Arbeta med rörelseinterpoleringar sparade som XML-filer
    20. Rörelseinterpoleringar jämfört med klassiska interpoleringar
    21. Skapa övergångar
    22. Använda animeringar med benverktyget i Animate
    23. Arbeta med figurriggning i Animate
    24. Så här använder du maskeringslager i Adobe Animate
    25. Så här arbetar du med scener i Animate
  4. Interaktivitet
    1. Så här skapar du knappar med Animate
    2. Konvertera Animate-projekt till andra dokumenttypsformat
    3. Skapa och publicera HTML5 Canvas-dokument i Animate
    4. Lägga till interaktivitet med kodfragment i Animate
    5. Skapa anpassade HTML5-komponenter
    6. Använda komponenter i HTML5 Canvas
    7. Skapa anpassade komponenter: Exempel
    8. Kodfragment för anpassade komponenter
    9. God praxis - annonsera med Animate
    10. Redigera och publicera VR
  5. Arbetsyta och arbetsflöde
    1. Skapa och hantera målarpenslar
    2. Använda Google Fonts i HTML5 Canvas-dokument
    3. Använda Creative Cloud Libraries och Adobe Animate
    4. Använda scen- och verktygspanelerna i Animate
    5. Arbetsflöde och arbetsyta i Animate
    6. Använda webbteckensnitt i HTML5 Canvas-dokument
    7. Tidslinjer och ActionScript
    8. Arbeta med flera tidslinjer
    9. Ange inställningar
    10. Använda redigeringspanelerna i Animate
    11. Skapa tidslinjelager med Animate
    12. Exportera animeringar för mobilprogram och spelplattformar
    13. Flytta och kopiera objekt
    14. Mallar
    15. Söka och ersätta i Animate
    16. Ångra, gör om och panelen Historik
    17. Kortkommandon
    18. Så här använder du tidslinjen i Animate
    19. Skapa HTML-tillägg
    20. Optimeringsalternativ för bilder och animerade GIF-filer
    21. Exportinställningar för bilder och GIF-filer
    22. Panelen Resurser i Animate
  6. Multimedia och video
    1. Omforma och kombinera grafikobjekt i Animate
    2. Skapa och arbeta med symbolinstanser i Animate
    3. Bildkalkering
    4. Så här använder du ljud i Adobe Animate
    5. Exportera SVG-filer
    6. Skapa videofiler för användning i Animate
    7. Så här lägger du till en video i Animate
    8. Rita och skapa objekt med Animate
    9. Omforma linjer och former
    10. Linjer, fyllningar och övertoningar med Animate CC
    11. Arbeta med Adobe Premiere Pro och After Effects
    12. Färgpaneler i Animate CC
    13. Öppna Flash CS6-filer i Animate
    14. Arbeta med klassisk text i Animate
    15. Placera grafik i Animate
    16. Importerade bitmappar i Animate
    17. 3D-grafik
    18. Arbeta med symboler i Animate
    19. Rita linjer och former med Adobe Animate
    20. Arbeta med bibliotek i Animate
    21. Exportera ljud
    22. Markera objekt i Animate CC
    23. Arbeta med Illustrator AI-filer i Animate
    24. Använda blandningslägen
    25. Ordna objekt
    26. Automatisera uppgifter med kommandomenyn
    27. Flerspråkig text
    28. Använda kameran i Animate
    29. Grafikfilter
    30. Ljud och ActionScript
    31. Ritinställningar
    32. Rita med ritstift
  7. Plattformar
    1. Konvertera Animate-projekt till andra dokumenttypsformat
    2. Stöd för anpassade plattformar
    3. Skapa och publicera HTML5 Canvas-dokument i Animate
    4. Skapa och publicera ett WebGL-dokument
    5. Så här paketerar du AIR för iOS-program
    6. Publicera AIR for Android-program
    7. Publicera för Adobe AIR för datorprogram
    8. Inställningar för ActionScript-publicering
    9. God praxis – organisera ActionScript i ett program
    10. Så här använder du ActionScript med Animate
    11. Hjälpmedel på arbetsytan i Animate
    12. Skriva och hantera skript
    13. Aktivera stöd för anpassade plattformar
    14. Översikt över stöd för anpassade plattformar
    15. Arbeta med plugin-program för anpassade plattformar
    16. Felsöka ActionScript 3.0
    17. Aktivera stöd för anpassade plattformar
  8. Exportera och publicera
    1. Så här exporterar du filer från Animate CC
    2. OAM-publicering
    3. Exportera SVG-filer
    4. Exportera bilder och video med Animate
    5. Publicera AS3-dokument
    6. Exportera animeringar för mobilprogram och spelplattformar
    7. Exportera ljud
    8. God praxis – tips för att skapa innehåll på mobila enheter
    9. God praxis – videokonventioner
    10. God praxis – riktlinjer för utveckling av SWF-program
    11. God praxis – strukturera FLA-filer
    12. De bästa sätten att optimera FLA-filer för Animate
    13. Inställningar för ActionScript-publicering
    14. Ange publiceringsinställningar för Animate
    15. Exportera projektorfiler
    16. Exportera bilder och animerade GIF-filer
    17. Publiceringsmallar för HTML
    18. Arbeta med Adobe Premiere Pro och After Effects
    19. Dela och publicera animeringar snabbt
  9. Felsökning
    1. Åtgärdade fel
    2. Kända fel

 

Översikt

I Adobe Animate kan du använda ljud på flera olika sätt. Du kan skapa ljud som spelas upp hela tiden, oberoende av tidslinjen, eller synkronisera animering och ljudspår på tidslinjen. Du kan lägga till ljud för knappar så att de blir mer interaktiva och göra ljudspåret mer elegant med ljud som tonas in och ut.

Det finns två typer av ljud i Animate: händelseljud och direktuppspelningsljud. Ett händelseljud måste laddas ned helt innan det kan spelas upp och fortsätter spelas upp tills det stoppas explicit. Direktuppspelningsljud börjar spelas upp så snart tillräckligt mycket data har laddats ned för de första bildrutorna. Direktuppspelningsljud är synkroniserade mot tidslinjen för uppspelning på en webbplats.

Om du skapar Animate-innehåll för mobila enheter kan du även använda enhetsljud i den publicerade SWF-filen. Enhetsljud kodas i de ljudformat som enheten själv stöder, till exempel MIDI, MFi eller SMAF.

Du kan använda delade bibliotek för att länka ett ljud till flera dokument. Du kan också använda ActionScript ® 2.0-händelsen onSoundComplete eller ActionScript® 3.0 soundComplete-händelsen för att aktivera en händelse när ett ljud har spelats färdigt.

Du kan läsa in ljud och styra ljuduppspelning med färdigskrivna beteenden eller mediekomponenter. Med mediekomponenter kan du dessutom lägga till kontroller för stopp, paus, tillbakaspolning och så vidare. Du kan också använda ActionScript 2.0 eller 3.0 för att läsa in ljud dynamiskt.

Mer information finns i attachSound (metoden Sound.attachSound) och loadSound (metoden Sound.loadSound) i Språkreferens för ActionScript 2.0 eller klassen Sound i språk- och komponentreferensen för ActionScript 3.0.

 ActionScript 2.0 och ActionScript 1.0 stöds inte i Animate.

Importera ljud

Du placerar ljudfiler i Animate genom att importera dem till biblioteket eller direkt till scenen.

Om du använder menyalternativet Arkiv > Importera > Importera till biblioteket placeras ljudet bara i biblioteket, och inte på tidslinjen.

När du importerar en ljudfil med menyalternativet Arkiv > Importera > Importera till scenen, eller genom att dra och släppa ljudfilen direkt på tidslinjen, placeras ljudet i den aktiva bildrutan i det aktiva lagret. Om du drar och släpper flera ljudfiler importeras bara en fil, eftersom en bildruta bara kan innehålla ett ljud. 

Importera ljud på något av följande sätt:

  • Om du vill importera en ljudfil till biblioteket väljer du Arkiv > Importera > Importera till biblioteket och väljer sedan önskad ljudfil.
  • Om du vill importera en ljudfil till scenen väljer du Arkiv > Importera > Importera till scenen och väljer sedan önskad ljudfil. 
  • Dra och släpp ljudfilen direkt på scenen.

 Du kan också dra ljud från ett vanligt bibliotek till biblioteket för det aktuella dokumentet.

I Animate lagras ljuden i biblioteket tillsammans med bitmappar och symboler. Du behöver bara en kopia av en ljudfil för att kunna använda ljudfilen på flera sätt i dokumentet.

Om du vill att flera Animate-dokument ska dela ljud kan du lägga ljuden i delade bibliotek.

Ljud kan ta stor plats på hårddisken och i RAM-minnet. Mp3-ljuddata är dock komprimerat och mindre än WAV- och AIFF-ljuddata. I allmänhet är det bäst att använda 16–22 kHz monoljud för WAV- och AIFF-filer (stereo kräver dubbelt så mycket minne som mono), men du kan även importera 8- eller 16-bitars ljud med samplingsfrekvenserna 11, 22 eller 44 kHz i Animate. Ljud som spelats in i format som inte är delbara med 11 kHz (till exempel 8, 32 eller 96 kHz) samplas om när de importeras till Animate. Animate kan konvertera ljud till lägre samplingsfrekvenser när de exporteras.

Om du vill lägga till effekter för ljud i Animate är det bäst att importera 16-bitars ljud. Om det är ont om RAM-minne håller du ljudklippen korta eller arbetar med 8-bitars ljud i stället för 16-bitars ljud.

 Du behöver inte förinstallera QuickTime eller iTunes för att importera eller spela upp ljud i Animate.

Ljudfilformat som stöds

Du kan importera följande ljudfilformat till Animate:

  • Adobe-ljud (.asnd). Det här är det inbyggda ljudformatet i Adobe® Soundbooth™.

  • Wave (.wav)

  • AIFF (.aif, .aifc)

  • mp3

    Du kan dessutom importera dessa ljudfilformat:

  • Sound Designer® II (.sd2)

  • Sun AU (.au, .snd)

  • FLAC (.flac)

  • Ogg Vorbis (.ogg, .oga)

 ASND-formatet är ett icke-förstörande ljudformat, som är inbyggt i Adobe Soundbooth. ASND-filer kan innehålla ljuddata med effekter som kan ändras senare, flerspårssessioner i Soundbooth och ögonblicksbilder som gör att du kan återställa en tidigare version av ASND-filen. Dokumenttyperna WebGL och HTML5 Canvas har bara stöd för formaten MP3 och WAV.

Lägga till ljud i Animate

Lägga till ett ljud på tidslinjen direkt från datorn

Du kan importera ljud till tidslinjen direkt från datorn på följande sätt:

  • Välj Arkiv > Importera > Importera till scenen och välj sedan ljudfilen som du vill importera.
  • Dra och släpp ljudfilen på scenen/tidslinjen. 

Observera att du bara kan lägga till en ljudfil i taget. Om du drar och släpper flera ljudfiler importeras ändå bara en fil till tidslinjen.

Lägga till ett ljud på tidslinjen från biblioteket

Du kan lägga till ett ljud i ett dokument med biblioteket eller läsa in ett ljud i en SWF-fil under körning med metoden loadSound i Sound-objektet. Mer information finns i avsnittet Ljudklassen i referensen för ActionScript 3.0.

  1. Importera ljudet till biblioteket om det inte redan har importerats.
  2. Välj Infoga > Tidslinje > Lager.

  3. Markera det nya ljudlagret och dra ljudet från bibliotekspanelen till scenen. Ljudet läggs till i det aktuella lagret.

    Du kan placera flera ljud i ett lager eller i lager som innehåller andra objekt. Varje ljud bör dock placeras i ett eget lager. Varje lager fungerar som en separat ljudkanal. Ljuden i alla lager kombineras när du spelar upp SWF-filen.

  4. Markera den första bildrutan på tidslinjen som innehåller ljudfilen.
  5. Välj Fönster > Egenskaper och klicka på pilen i det övre högra hörnet så att egenskapsinspektören utökas.

  6. I egenskapsinspektören väljer du ljudfilen från popup-menyn Ljud.
  7. Välj ett effektalternativ på popup-menyn Effekter:

    Inga

    Inga effekter tillämpas på ljudfilen. Använd det här alternativet när du vill ta bort tidigare valda effekter.

    Vänster kanal/Höger kanal

    Spelar upp ljud enbart i den vänstra eller högra kanalen.

    Tona från vänster till höger/Tona från höger till vänster

    Flyttar ljudet från en kanal till den andra.

    Tona in

    Ökar volymen gradvis för ett ljud under dess varaktighet.

    Tona ut

    Minskar volymen gradvis för ett ljud under dess varaktighet.

    Anpassat

    Gör att du kan skapa anpassade in- och utpunkter för ljud med Redigera omslag.

     Effekter stöds inte i WebGL- och HTML5 Canvas-dokument.

  8. Välj ett synkroniseringsalternativ på popup-menyn Synka:

    Händelse

    Synkroniserar ljudet med en händelse. En ljudhändelse spelas upp när den inledande nyckelbildrutan visas första gången och den spelas upp i sin helhet, oberoende av spelhuvudet på tidslinjen, även om uppspelningen av SWF-filen upphör. Händelseljud blandas när du spelar upp den publicerade SWF-filen.

    Om en ljudhändelse spelas upp och ljudet återigen instansieras (till exempel genom att en användare på nytt klickar på knappen eller att spelhuvudet passerar den inledande nyckelbildrutan för ljudet) fortsätter den första instansen av ljudet att spelas och en annan instans av samma ljud börjar spelas upp samtidigt. Tänk på detta när du använder ljud som varar länge eftersom det eventuellt kan överlappa och orsaka oönskade effekter.

    Början

    Samma som Händelse, förutom att om ljudet redan spelas upp, skapas ingen ny instans av ljudet.

    Stopp

    Avbryter uppspelningen av det angivna ljudet.

    Ström

    Synkroniserar ljudet för uppspelning på en webbplats. Animate synkroniserar animeringar med direktuppspelade ljud. Om Animate inte kan rita animeringsbildrutorna tillräckligt snabbt, hoppas bildrutor över. Till skillnad från händelseljud avbryts direktuppspelningsljud om SWF-filen slutar spelas upp. Ett direktuppspelningsljud kan heller aldrig spelas upp längre än de bildrutor det finns i. Direktuppspelningsljud blandas när du publicerar SWF-filen.

    Ett exempel på ett direktuppspelningsljud är rösten för en figur i en animering som spelas upp på flera bildrutor.

    Animate kommer ihåg alternativen för ljudsynkronisering i egenskapsinspektören. Om du väljer ett ljud i delen Ljud i egenskapsinspektören och sedan försöker ange ett annat ljud i en ny nyckelbildruta via egenskapsinspektören kommer Animate ihåg synkroniseringsalternativen Direktuppspelning och Händelse från det föregående ljudet.

     Om du använder ett mp3-ljud för direktuppspelning måste du komprimera om ljudet för export. Du kan exportera ljudet som en mp3-fil med samma komprimeringsinställningar som den hade när den importerades. Strömningsinställningen stöds inte i WebGL-dokument.

  9. Ange ett värde för Upprepa och ange hur många gånger ljudet ska upprepas, eller välj Slinga om du vill upprepa ljudet oavbrutet.

    Om du vill att ljudet ska spelas upp kontinuerligt anger du ett tal som är tillräckligt stort för att ljudet ska spelas upp en längre tid. Om du till exempel vill att ett 15-sekunders ljud ska spela upp i 15 minuter anger du 60. Direktuppspelningsljud bör inte upprepas. Om ett direktuppspelningsljud upprepas läggs bildrutor till i filen och filstorleken ökas med antalet gånger ljudet spelas upp.

  10. Testa ljudet genom att dra spelhuvudet över bildrutorna som innehåller ljudet eller använda kommandona i kontrollenheten eller på Kontroll-menyn.

Ta bort ljud från tidslinjen

  1. I tidslinjelagret, som innehåller ljudet, väljer du en bildruta som även innehåller ljudet.
  2. I egenskapsinspektören väljer du avsnittet Ljud och markerar Inget på menyn Namn.

    Animate tar bort ljudet från tidslinjelagret.

Lägga till ett ljud för en knapp

Ljud kan kopplas till en knappsymbols olika lägen. Eftersom ljuden sparas med symbolen fungerar de för alla instanser av symbolen.

  1. Markera knappen på bibliotekspanelen.
  2. Välj Redigera på panelmenyn i panelens övre högra hörn.
  3. Lägg till ett lager för ljud i knappens tidslinje (Infoga > Tidslinje > Lager).

  4. I ljudlagret skapar du en vanlig eller en tom nyckelbildruta som motsvarar knappläget som du vill lägga till ett ljud för.

    Klicka på Infoga > Tidslinje > Nyckelbildruta eller Infoga > Tidslinje > Tom nyckelbildruta.

    Om du till exempel vill lägga till ett ljud som spelas upp när du klickar på knappen skapar du en nyckelbildruta i bildrutan med etiketten Ned.

  5. Klicka på nyckelbildrutan du skapade.
  6. Välj Fönster > Egenskaper.

  7. I egenskapsinspektören väljer du ljudfilen från popup-menyn Ljud.
  8. Välj Händelse på popup-menyn Synka.

    Koppla olika ljud till knappens olika nyckelbildrutor genom att skapa en tom nyckelbildruta och lägga till en ljudfil för varje nyckelbildruta. Du kan också använda samma ljudfil och lägga på olika ljudeffekter på knappens nyckelbildrutor.

Synkronisera ett ljud med animering

Om du vill synkronisera ett ljud med en animering ska det börja och sluta i nyckelbildrutor.

  1. Lägg till ett ljud på tidslinjen i ett eget lager (mer information finns här ovan).
  2. Om du vill synkronisera ljudet med en händelse på scenen, ska du skapa en inledande nyckelbildruta för ljudet som motsvarar nyckelbildrutan för händelsen på scenen som du vill ska utlösa ljudet. Du kan välja vilket synkroniseringsalternativ som helst av dem som beskrivs ovan (se Lägga till ett ljud på tidslinjen).
  3. Skapa en nyckelbildruta i ljudlagrets tidslinje vid den bildruta där du vill att ljudet ska sluta. En beteckning för ljudfilen visas på tidslinjen.
  4. Välj Fönster > Egenskaper och klicka på pilen i det övre högra hörnet så att egenskapsinspektören utökas.

  5. I egenskapsinspektören väljer du samma ljud från popup-menyn Ljud.
  6. Du fortsätter i egenskapsinspektören genom att välja Stopp på popup-menyn Synkronisera.

    När du spelar upp SWF-filen avbryts uppspelningen av ljudet när den kommer till den avslutande nyckelbildrutan.

  7. Spela upp ljudet genom att dra spelhuvudet på tidslinjen.

Redigera ljud

Redigera ljud i Animate

I Animate kan du definiera startpunkten för ett ljud eller styra ljudets volym när det spelas upp. Du kan också ändra var uppspelningen av ljudet börjar och slutar. Det är ett bra sätt att göra ljudfilerna mindre genom att ta bort delar som inte behövs.

  1. Lägg till ett ljud i en bildruta eller markera en bildruta som redan innehåller ett ljud.
  2. Välj Fönster > Egenskaper.

  3. Klicka på knappen Redigera på egenskapsinspektörens högra sida.
  4. Gör något av följande:
    • Dra kontrollerna Starttid och Sluttid i Redigera omslag om du vill ändra start- och slutpunkt för ett ljud.

    • Ändra ljudomslaget genom att dra omslagets handtag för att ändra nivåerna på olika ställen i ljudet. Omslagslinjerna visar ljudets volym när det spelas upp. Klicka på omslagslinjerna om du vill skapa fler omslagshandtag (upp till åtta totalt). Om du vill ta bort ett omslagshandtag drar du det utanför fönstret.

    • Om du vill visa mer eller mindre av ljudet i fönstret klickar du på Zooma in eller Zooma ut.

    • Om du vill växla mellan tidsenheterna sekunder och bildrutor klickar du på knapparna Sekunder och Bildrutor.

  5. Om du vill höra det redigerade ljudet klickar du på Spela upp.

Dela eller loopa ett ljud på tidslinjen

Dela ett ljud på tidslinjen

Du kan dela direktuppspelat ljud som är inbäddat på tidslinjen via snabbmenyn Dela ljud. Med Dela ljud kan du pausa ljudet när det behövs och sedan återuppta ljuduppspelningen från då den stoppades i en senare bildruta på tidslinjen. Du kan välja att dela direktuppspelat ljud i flera delar genom att behålla effekterna.

Du kan dela upp ett ljudklipp på en tidslinje och bevara dess effekter:

  1. Välj Arkiv > Importera > Importera till biblioteket.

  2. Markera ljudklippet och importera det till biblioteket.

  3. Skapa ett nytt lager på tidslinjen och lägg till ljudklippet på lagret. 

  4. Under Egenskaper > Ljud markerar du effekten.

  5. Välj Synkroniseringstyp som Direktuppspelning.

  6. Högerklicka på bildrutan där du vill dela ljudet och klicka på Dela ljud.

     Ljudeffekter behålls, även om ljudet flyttas eller ändras till en annan tids- eller bildruteperiod.

Skapa en ljudslinga på tidslinjen

En ljudslinga gör att ett litet ljudavsnitt spelas kontinuerligt över ett antal bildrutor på tidslinjen. När alternativet Loopa är aktiverat på tidslinjen kan du loopa direktuppspelat ljud inom ett intervall av bildrutor tillsammans med andra animeringar.

Aktivera alternativet Loopa på tidslinjen på följande sätt när du vill skapa en slinga:

Knappen Ljudslinga på tidslinjen

 Adobe

Få hjälp snabbare och enklare

Ny användare?

Adobe MAX 2024

Adobe MAX
Kreativitetskonferensen

14–16 okt i Miami Beach och online

Adobe MAX

Kreativitetskonferensen

14–16 okt i Miami Beach och online

Adobe MAX 2024

Adobe MAX
Kreativitetskonferensen

14–16 okt i Miami Beach och online

Adobe MAX

Kreativitetskonferensen

14–16 okt i Miami Beach och online