Så här använder du bildrutor och nyckelbildrutor i Animate

  1. Användarhandbok för Adobe Animate
  2. Introduktion till Animate
    1. Nyheter i Animate
    2. Visuell ordlista
    3. Systemkrav för Animate
    4. Tangentbordsgenvägar för Animate
    5. Arbeta med flera filtyper i Animate
  3. Animering
    1. Grunderna vid animering i Animate
    2. Så här använder du bildrutor och nyckelbildrutor i Animate
    3. Animering bildruta för bildruta i Animate
    4. Arbeta med klassiska interpolerade animeringar i Animate
    5. Pensel
    6. Rörelseguide
    7. Rörelseinterpoleringar och ActionScript 3.0
    8. Om animeringar med rörelseinterpolering
    9. Animeringar med rörelseinterpolering
    10. Skapa en animering med rörelseinterpolering
    11. Använda nyckelbildrutor för egenskaper
    12. Animera placering med en interpolering
    13. Så här redigerar du rörelseinterpoleringar med rörelseredigeraren
    14. Redigera rörelsebanan för en interpolerad animering
    15. Ändra rörelseinterpoleringar
    16. Lägga till anpassade övergångar
    17. Skapa och använda förinställda rörelser
    18. Konfigurera interpoleringsintervall för animeringar
    19. Arbeta med rörelseinterpoleringar sparade som XML-filer
    20. Rörelseinterpoleringar jämfört med klassiska interpoleringar
    21. Forminterpolering
    22. Använda animeringar med benverktyget i Animate
    23. Arbeta med figurriggning i Animate
    24. Så här använder du maskeringslager i Adobe Animate
    25. Så här arbetar du med scener i Animate
  4. Interaktivitet
    1. Så här skapar du knappar med Animate
    2. Konvertera Animate-projekt till andra dokumenttypsformat
    3. Skapa och publicera HTML5 Canvas-dokument i Animate
    4. Lägga till interaktivitet med kodfragment i Animate
    5. Skapa anpassade HTML5-komponenter
    6. Använda komponenter i HTML5 Canvas
    7. Skapa anpassade komponenter: Exempel
    8. Kodfragment för anpassade komponenter
    9. God praxis - annonsera med Animate
    10. Redigera och publicera VR
  5. Arbetsyta och arbetsflöde
    1. Skapa och hantera målarpenslar
    2. Använda Google Fonts i HTML5 Canvas-dokument
    3. Använda Creative Cloud Libraries och Adobe Animate
    4. Använda scen- och verktygspanelerna i Animate
    5. Arbetsflöde och arbetsyta i Animate
    6. Använda webbteckensnitt i HTML5 Canvas-dokument
    7. Tidslinjer och ActionScript
    8. Arbeta med flera tidslinjer
    9. Ange inställningar
    10. Använda redigeringspanelerna i Animate
    11. Skapa tidslinjelager med Animate
    12. Exportera animeringar för mobilprogram och spelplattformar
    13. Flytta och kopiera objekt
    14. Mallar
    15. Söka och ersätta i Animate
    16. Ångra, gör om och panelen Historik
    17. Kortkommandon
    18. Så här använder du tidslinjen i Animate
    19. Skapa HTML-tillägg
    20. Optimeringsalternativ för bilder och animerade GIF-filer
    21. Exportinställningar för bilder och GIF-filer
    22. Panelen Resurser i Animate
  6. Multimedia och video
    1. Omforma och kombinera grafikobjekt i Animate
    2. Skapa och arbeta med symbolinstanser i Animate
    3. Bildkalkering
    4. Så här använder du ljud i Adobe Animate
    5. Exportera SVG-filer
    6. Skapa videofiler för användning i Animate
    7. Så här lägger du till en video i Animate
    8. Arbeta med videoreferenspunkter
    9. Rita och skapa objekt med Animate
    10. Omforma linjer och former
    11. Linjer, fyllningar och övertoningar med Animate CC
    12. Arbeta med Adobe Premiere Pro och After Effects
    13. Färgpaneler i Animate CC
    14. Öppna Flash CS6-filer i Animate
    15. Arbeta med klassisk text i Animate
    16. Placera grafik i Animate
    17. Importerade bitmappar i Animate
    18. 3D-grafik
    19. Arbeta med symboler i Animate
    20. Rita linjer och former med Adobe Animate
    21. Arbeta med bibliotek i Animate
    22. Exportera ljud
    23. Markera objekt i Animate CC
    24. Arbeta med Illustrator AI-filer i Animate
    25. Tillämpa mönster med sprejpenseln
    26. Använda blandningslägen
    27. Ordna objekt
    28. Automatisera uppgifter med kommandomenyn
    29. Flerspråkig text
    30. Använda kameran i Animate
    31. Använda Animate med Adobe Scout
    32. Arbeta med Fireworks-filer
    33. Grafikfilter
    34. Ljud och ActionScript
    35. Ritinställningar
    36. Rita med ritstift
  7. Plattformar
    1. Konvertera Animate-projekt till andra dokumenttypsformat
    2. Stöd för anpassade plattformar
    3. Skapa och publicera HTML5 Canvas-dokument i Animate
    4. Skapa och publicera ett WebGL-dokument
    5. Så här paketerar du AIR för iOS-program
    6. Publicera AIR for Android-program
    7. Publicera för Adobe AIR för datorprogram
    8. Inställningar för ActionScript-publicering
    9. God praxis – organisera ActionScript i ett program
    10. Så här använder du ActionScript med Animate
    11. God praxis – riktlinjer för hjälpmedel
    12. Hjälpmedel på arbetsytan i Animate
    13. Skriva och hantera skript
    14. Aktivera stöd för anpassade plattformar
    15. Översikt över stöd för anpassade plattformar
    16. Skapa hjälpmedelsanpassat innehåll
    17. Arbeta med plugin-program för anpassade plattformar
    18. Felsöka ActionScript 3.0
    19. Aktivera stöd för anpassade plattformar
  8. Exportera och publicera
    1. Så här exporterar du filer från Animate CC
    2. OAM-publicering
    3. Exportera SVG-filer
    4. Exportera bilder och video med Animate
    5. Publicera AS3-dokument
    6. Exportera animeringar för mobilprogram och spelplattformar
    7. Exportera ljud
    8. Exportera QuickTime-videofiler
    9. Styra extern videouppspelning med ActionScript
    10. God praxis – tips för att skapa innehåll på mobila enheter
    11. God praxis – videokonventioner
    12. God praxis – riktlinjer för utveckling av SWF-program
    13. God praxis – strukturera FLA-filer
    14. De bästa sätten att optimera FLA-filer för Animate
    15. Inställningar för ActionScript-publicering
    16. Ange publiceringsinställningar för Animate
    17. Exportera projektorfiler
    18. Exportera bilder och animerade GIF-filer
    19. Publiceringsmallar för HTML
    20. Arbeta med Adobe Premiere Pro och After Effects
    21. Dela och publicera animeringar snabbt

Översikt

I Adobe Animate-dokument delas tidslängden in i bildrutor på ungefär samma sätt som i filmer. Bildrutor är kärnan i en animering och de bestämmer varje segment av tid och rörelse. Det totala antalet bildrutor i filmen och hur snabbt de spelas upp avgör filmens totala längd. Några av de koncept som används för bildrutor förklaras nedan som referens.

Bildrutor

På tidslinjen arbetar du med bildrutor för att ordna och styra dokumentets innehåll. Du placerar bildrutor på tidslinjen i den ordning du vill att objekten i bildrutorna ska visas i det slutliga innehållet.

Nyckelbildrutor

En nyckelbildruta är en bildruta där en ny symbolinstans visas på tidslinjen. En nyckelbildruta kan också vara en bildruta som innehåller ActionScript®-kod för att styra någon del av dokumentet. Du kan också lägga till en tom nyckelbildruta på tidslinjen som en platshållare för symboler som du planerar att lägga till senare eller om du vill lämna bildrutan tom.

Med nyckelbildrutor kan du ange en position, lägga till ankarpunkter, åtgärder, kommentarer med mera. 

Intervall

Med intervallsbaserad bildrutemarkering kan du markera ett intervall av bildrutor mellan två nyckelbildrutor med ett enda klick.

Statiskt bildruteintervall

I ett statiskt bildruteintervall är samma innehåll tillgängligt under intervallets hela längd. Du kan använda den här typen av intervall när du behöver visa grafik under en viss tid. 

Interpolerat bildruteintervall

I interpolerade bildruteintervall ändras innehållet i intervallet med varje bildruta. Du kan använda den här typen av intervall för animeringar. 

Lägga till eller infoga bildrutor på tidslinjen

  • Om du vill infoga en ny bildruta väljer du Infoga > Tidslinje > Bildruta (F5).

  • Om du vill skapa en nyckelbildruta väljer du Infoga > Tidslinje > Nyckelbildruta (F6) eller högerklickar (Windows) eller Kontroll-klickar (Macintosh) på den bildruta där du vill infoga en nyckelbildruta och väljer Infoga nyckelbildruta på snabbmenyn.

  • Om du vill skapa en ny tom nyckelbildruta väljer du Infoga > Tidslinje > Tom nyckelbildruta eller högerklickar (Windows) eller Control-klickar (Macintosh) på den bildruta där du vill placera nyckelbildrutan och väljer Infoga tom nyckelbildruta på snabbmenyn.

Effekt på bildrutor

Filtren och färgeffekterna kunde tidigare bara användas på filmklipp och grafiska symboler. Med de avancerade lagren kan filter och färgeffekter nu tillämpas på markerade bildrutor, där de i sin tur tillämpas på allt deras innehåll inklusive former, ritobjekt, grafiska symboler och så vidare. Lagereffekter kan också interpoleras med hjälp av klassiska, form- och IK-interpoleringar på alla bildrutor.

Mer information finns i Använda lagereffekter.

Markera och märka bildrutor på tidslinjen

Du kan markera bildrutor på två sätt i Animate. Du kan också märka bildrutor när du vill ordna innehållet. 

Det finns två olika metoder för att markera bildrutor på tidslinjen i Animate. Vid bildrutebaserad markering (standard) markerar du enskilda bildrutor på tidslinjen. Vid intervallsbaserad markering markeras hela bildrutesekvensen, från en nyckelbildruta till nästa, när du klickar på en bildruta i sekvensen. 

Välja bildrutor på tidslinjen

Markera en eller flera bildrutor

  • Om du vill markera en bildruta klickar du på bildrutan. 
  • Om du vill markera flera bildrutor efter varandra drar du markören över dem eller Skift-klickar på extrarutorna.

  • Om du vill markera flera icke sammanhängande bildrutor Ctrl-klickar (Windows) eller Kommando-klickar (Macintosh) du på bildrutorna.

  • Om du vill markera alla bildrutor på tidslinjen väljer du Redigera > Tidslinje > Markera alla bildrutor.

Intervallsbaserad markering av bildrutor

Du kan förbereda för intervallsbaserad markering genom att ange det redan på tidslinjen i Animate genom att klicka på streckikonen i det övre högra hörnet och välja menyalternativet Intervallsbaserad markering

  • Klicka på bildrutan om du vill markera ett helt bildruteintervall (rörelseinterpolering eller omvänd kinematik). 
  • Om du vill markera flera intervall klickar du på vart och ett samtidigt som du håller ner Skift-tangenten.

Märka bildrutor på tidslinjen

Du kan märka bildrutor på tidslinjen för att göra det enklare att ordna innehållet. Du kan även märka en bildruta för att kunna referera till bildrutan i ActionScript med hjälp av dess etikett. Detta innebär att om du ordnar om tidslinjen och flyttar etiketten till ett annat bildrutenummer, kommer ActionScript ändå att referera till bildruteetiketten och den behöver inte uppdateras.

Bildruteetiketter kan endast tillämpas på nyckelbildrutor. Ett tips är att skapa ett separat lager på tidslinjen som kan innehålla dina bildruteetiketter. Om du använder separata lager för etiketter kan du ordna innehållet och nyckelbildrutorna bättre. 

Så här lägger du till en bildruteetikett:

  1. Markera bildrutan som du vill märka på tidslinjen.

  2. När bildrutan är markerad anger du etikettnamnet i avsnittet Etikett i egenskapsinspektören. Tryck på Enter eller Retur.

  3. Du bör skapa ett separat lager för alla etiketter i bildrutan. 

Aktivera intervallsbaserad bildrutemarkering

Med intervallsbaserad bildrutemarkering kan du markera ett intervall av bildrutor mellan två nyckelbildrutor med ett enda klick.

  1. Klicka på streckikonen längst upp till höger i tidslinjeavsnittet. 

    En popup-meny visas. 

  2. Markera alternativet Intervallsbaserad markering på popup-menyn. 

Distribuera till nyckelbildrutor

Med alternativet Distribuera till nyckelbildrutor kan du distribuera flera objekt (symboler och bitmappar) på scenen till enskilda nyckelbildrutor.

  1. Markera flera objekt i ett lager på scenen.
  2. Högerklicka var som helst på scenen och välj Distribuera till nyckelbildrutor.

Kopiera, klistra in, ta bort eller flytta en bildruta eller bildrutesekvens

En nyckelbildruta och intervallet med vanliga bildrutor som kommer efter den, kallas för en nyckelbildrutesekvens. Tidslinjen kan innehålla valfritt antal nyckelbildrutesekvenser.

Gör något av följande om du vill kopiera eller klistra in en bildruta eller bildrutesekvens:

Kopiera eller klistra in en bildruta eller bildrutesekvens

  • Markera bildrutan eller sekvensen och välj Redigera > Tidslinje > Kopiera bildrutor. Markera bildrutan eller sekvensen som du vill ersätta och välj Redigera > Tidslinje > Klistra in bildrutor.

  • Alt-dra (Windows) eller Alternativ-dra (Macintosh) en nyckelbildruta till platsen dit du vill kopiera den.

Ta bort en bildruta eller bildrutesekvens

Ta bort en bildruta, bildrutesekvens eller nyckelbildruta

Markera bildrutan eller sekvensen och välj Redigera > Tidslinje > Ta bort bildrutor eller högerklicka (Windows) eller Control-klicka (Macintosh) på bildrutan eller sekvensen och välj Ta bort bildrutor på snabbmenyn.

Omgivande bildrutor påverkas inte.

Ta bort nyckelbildruta

Markera nyckelbildrutan och välj Redigera > Tidslinje > Rensa nyckelbildruta eller högerklicka (Windows) eller Control-klicka (Macintosh) på bildrutan och välj Rensa nyckelbildruta på snabbmenyn.

Flytta en nyckelbildruta eller bildrutesekvens

Markera en nyckelbildruta eller bildrutesekvens och dra sedan nyckelbildrutan eller bildrutesekvensen till den önskade platsen.

Ändra längd på en sekvens med statiska bildrutor

Ctrl-dra (Windows) eller Kommando-dra (Macintosh) den första eller sista bildrutan i intervallet åt vänster eller höger.

Information om hur du ändrar längden på en bildruta-för-bildruta-animeringssekvens finns i Skapa bildruta-för-bildruta-animeringar.

Förhandsgranska bildruteinnehåll på tidslinjen

Välj Förhandsgranska på alternativmenyn i det övre högra hörnet på panelen Tidslinje.

I varje nyckelbildruta på tidslinjen kan du visa en miniatyr av objektet i nyckelbildrutan.

Adobes logotyp

Logga in på ditt konto