Update to Illustrator CC available

For more information, see the New features summary.

Live Corners

You can easily edit the corners of shapes and paths in your artwork. Select one or more corner anchor points and then drag the new Live Corners widget to change the shape of the corner. Choose from three corner types -  round, inverted round, or chamfer.

Types of rounding with the Live Corners Tool
Modifying settings in the Corners dialog cause a corner to appear differently

A. Live Corners widget B. Round corner C. Associated anchor points D. Inverted round corner E. Chamfer corner 

For more information, see the article Working with Live Corners.

Enhanced Pencil Tool

The Pencil Tool has been improved to facilitate better curve-fitting, auto-closing of paths, and drawing of constrained and unconstrained straight-line segments. Enhancements have been extended to the Brush, Blob Brush, and Smooth tools.

  • Curve fitting. The Pencil and Smooth tools have a Fidelity slider that enable you to select the most suitable curve fitting. The type of curve fitting is set in the Pencil Tool Options dialog box > Fidelity slider.
  • Path closing. When you draw a path, you can choose to close the path if the endpoints are within a specific number of pixels of each other. The predefined number of pixels is set in the Pencil Tool Options dialog box > Within field.
  • Segments and Paths. The enhanced Pencil tool allows you to draw constrained or unconstrained paths. Also, you can continue, or merge paths using the new tool.
  • Smoothing Presets. When you double-click the Smooth Tool icon in the Toolbox, the Smooth Tool Options dialog appears. A preset-based Fidelity slider is available in this dialog.

For more information, see the article on the Enhanced Pencil tool.

Reshape segment workflows & touch support

Workflows used to reshape path segments have been enhanced and made touch-friendly. Use the Pen tool (while drawing), or the Anchor Point or the Direct Selection tools to perform unconstrained reshaping of path segments.

For example, you can now press the Alt/Option key and then use the Pen tool to reshape individual path segments as show in this illustration:

Reshape segment workflows and touch support
A combination of the path segments, reshaped using the Pen tool

A. Original shape B. The Reshape Segement cursor indicates a reshape-ready segement C. When the Reshape Segment cursor is visible, modify the shape of the segment by clicking and dragging. D. Reshape as many segments as required E. Final shape when all paths have been reshaped 

For more information, see the article on Enhanced reshape workflows and touch support.

Working with Typekit fonts

Choose from thousands of fonts available from Typekit, from within Illustrator CC. When you enable Typekit fonts to be synced to your desktop through the Creative Cloud application, the fonts you have subscribed to on Typekit appear alongside locally installed fonts.

Working with type-kit fonts
A. Typekit font filter B. Typekit website access button C. Typekit-based fonts 

For more information on how to access and use Typekit fonts in Illustrator CC, see the article Working with Typekit fonts.

For more information, on Typekit and the Creative Cloud, see the Typekit Help Center.

Perspective Grid

The Perspective Grid tool has been enhanced to provide a more flexible and intuitive way of working with the tool. From Illustrator CC, modifying the Perspective Grid affects any attached artwork, too. For example, manipulating the horizon line or the vanishing point controls changes the perspective of the artwork, too. This enhancement is available for two- or three-point Perspective Grids only.

Note: In previous versions of Illustrator, modifying the Perspective Grid had no effect on attached artwork.

  1. Attach artwork to a Perspective Grid.
  2. In Perspective Grid view (View > Perspective Grid > Show Grid), select the Perspective Grid tool.
  3. Lock the Station Point on the Perspective Grid (View > Perspective Grid > Lock Station Point).
  4. Select a vanishing point, and modify the Perspective Grid. The artwork moves in tandem with modified Perspective Grid.
perspective grid
Normal artwork, attached to a Perspective Grid.

The vanishing point has been pulled in from the right. The Perspective Grid and the artwork are modified simultaneously.

Perspective Grid
The vanishing point has been pulled in from the left. The Perspective Grid and the artwork are modified simultaneously.

Enhanced Windows Support

HiDPI devices

Adobe Illustrator extends HiDPI support to Windows-based devices. You can now view Illustrator in enlarged mode, as per text size preferences on a high-resolution displays. 

  • For displays with resolution greater than or equal to 1920*1080 & less than 2560*1440, Illustrator can be launched at 1.5 times scaled-up UI, depending on the OS text size.
  • For displays with resolution greater than or equal to 2560*1440, Illustrator can be launched at 1.5 times or 2 times scaled-up UI, depending on the OS text size.

Pen-pressure support on Windows 8 devices

In previous versions of Illustrator one could use Wacom tablets to draw art (for example, brush strokes), based on input parameters like Pressure, Rotation, Tilt, and more.

This version of Illustrator CC now includes native support for Windows 8 -based input devices that support pressure feedback. For example, you can leverage this capability while working with a Windows 8 device with a newer Stylus device that provides pressure feedback, for drawings that require pressure-input.  

For information on viewing or making adjustments in Windows, see:

Custom Tools Panels

Create groups of preferred tools using the new feature to create your own specialized tools panels. Simply drag and drop tools from the existing Tool Box into a new tool panel, or remove tools from a created tool panel.

Custom Tools Panels
Tools from three tool groups (left) have been added to create a new tools panel (right)

For more information, see the article on Custom Tools Panels.

Import and Export Settings

You can share Illustrator CC settings and preferences with a different computer, using settings packages. Create a settings package on one computer (Edit > My Settings > Export Settings), and then copy the package to a different computer and import the settings package (Edit > My Settings > Import Settings).

SVG workflow enhancements

SVG-related enhancements (SVG Options > More Options > Advanced Options) have been implemented:

  1. In the SVG Options dialog:
    1. A new option to enable Responsive Design is available. The Responsive checkbox  removes absolute width and height information from the artwork file, so that the image resizes and scales proportionately.
    2. The default for Type (Fonts) is set to SVG, by default.
    3. The precision for Decimal Places (More Options > Advanced Options) is 1, by default.
  2. Also, when you open an SVG in Illustrator, visual fidelity is maintained by aligning objects correctly with the pixel grid.

Other significant enhancements

This version of Illustrator CC includes usability enhancements requested by Illustrator users.

What's New dialog

whats new dialog

A What’s New dialog is displayed at first launch, after Illustrator is updated. The dialog lists the top new features that have been introduced in the updated release. The list has a description about each feature and thumbnails of associated videos. Clicking a thumbnail plays a brief, feature-related video, in the What's New dialog.  

Tip: To view the What's New dialog at any point in time, in Illustrator, click Help > What's New.

Note: To prevent the What's New dialog from opening each time you launch Illustrator, select the Don't Show Again checkbox.

Opacity slider

opacity slider
The new opacity scrubby slider replaces the drop-down list of values

The Opacity drop-down has now been converted to a scrubby slider. The slider is available from two locations:

  • Windows > Transparency panel (Shift + Ctrl/Cmd + F10)
  • Control Panel > Opacity slider

Layers panel enhancements

Maintain state in the Layers panel

  • The Layers panel (F7) now keeps track of which layers have been expanded or collapsed, even when you close and reopen a document.

Visual feedback for Layers panel operations

  • When you copy a layer, the mouse cursor includes a plus symbol ().
  • When you hover over the target icon for a layer, the cursor turns into a pointer ().

Fill stroke proxy enhancements

fill stroke proxy enhancements
A. Fill and Stroke Proxy in the Swatches panel B. Small list and thumbnail view icons 

To enable a more convenient workflow, the Fill proxy has been added to:

  • Windows > Swatches panel
  • Custom tools panels (automatically added when you a new tools panel)

Also, the Swatches panel now has two buttons that enable you to toggle views. Click the buttons to toggle between a list or thumbnail view.

Create or resize an Artboard from the center

Two enhancements have been effected for artboard creation/resizing scenarios:

  • Pressing the Alt/Opt key while creating or resizing an artboard will keep the center of the artboard fixed.
  • Pressing the Alt/Opt + Shift key while creating or resizing an artboard will keep the width and height of the artboard in its original proportion (constrained scaling) while keeping the center of the artboard fixed.  

Canceling drag operations quickly

Some workflows have been enhanced to enable  you to cancel operations or actions while using certain tools. With this enhancement, pressing the Esc key cancels the action of the following tools or actions:

  • Zoom
  • Ruler
  • Guide
  • Splitter Guides
  • Selection
  • Page Tiling Tools

New shortcut: Place command

You can now initiate the Place command from a keyboard shortcut: Ctrl/Cmd + Shift + P.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy