מדריך למשתמש ביטול

Buttons

  1. מדריך למשתמש של InDesign
  2. הכרת InDesign
    1. מבוא ל-InDesign
      1. מה חדש ב-InDesign
      2. דרישות מערכת
      3. שאלות נפוצות
      4. שימוש בספריות Creative Cloud
    2. סביבת עבודה
      1. עקרונות עבודה בסיסיים בסביבת עבודה
      2. Toolbox
      3. הגדרת העדפות
      4. סביבת עבודה מבוססת מגע
      5. קיצורי מקשים המוגדרים כברירת מחדל
      6. שחזור מסמך וביטול פעולה
      7. ההרחבה Capture
  3. צור ופרוס מסמכים
    1. מסמכים ודפים
      1. יצירת מסמכים
      2. עבודה עם דפי מאסטר
      3. עבודה עם דפי מסמך
      4. הגדרת גודל עמוד, שוליים וגלישה
      5. עבודה עם קבצים ותבניות
      6. יצירת קובצי ספרים
      7. הוספת מספור עמודים בסיסי
      8. מספור עמודים, פרקים ומקטעים
      9. המרת מסמכי QuarkXPress ו-PageMaker
      10. שיתוף תוכן
      11. הבנת תהליך עבודה בסיסי של ניהול קבצים
      12. שמירת מסמכים
    2. רשתות
      1. רשתות
      2. עיצוב רשתות
    3. עזרי פריסה
      1. סרגלים
  4. הוספת תוכן
    1. טקסט
      1. הוספת טקסט למסגרות
      2. שרשור טקסט
      3. תכונות של עברית וערבית ב-InDesign
      4. יצירת טקסט על נתיב
      5. תבליטים ומספור
      6. גליפים ותווים מיוחדים
      7. יצירת טקסט
      8. משתני טקסט
      9. יצירת קודי QR
      10. עריכת טקסט
      11. יישור טקסט
      12. גלישת טקסט סביב אובייקטים
      13. אובייקטים מעוגנים
      14. תוכן מקושר
      15. עיצוב פסקאות
      16. עיצוב תווים
      17. Find/Change
      18. בדיקת איות ומילוני שפות
    2. טיפוגרפיה
      1. שימוש בגופנים ב-InDesign
      2. צימוד אותיות וריווח טקסט
    3. עיצוב טקסט
      1. עיצוב טקסט
      2. כרטיסיות וכניסות
    4. בדיקת טקסט
      1. מעקב אחר שינויים ובדיקת שינויים
      2. הוספת הערות עורך ב-InDesign
      3. ייבוא הערות PDF
    5. הוספת הפניות
      1. יצירת תוכן עניינים
      2. הערות שוליים
      3. יצירת אינדקס
      4. הערות סיום
      5. כתוביות
    6. סגנונות
      1. סגנונות פסקה ותו
      2. סגנונות אובייקטים
      3. אות פתיח וסגנונות מקוננים
      4. עבודה עם סגנונות
      5. ריווח שורות
    7. טבלאות
      1. עיצוב טבלאות
      2. יצירת טבלאות
      3. סגנונות טבלה ותא
      4. בחירה ועריכה של טבלאות
      5. משיחות ומילויים של טבלאות
    8. אינטראקטיביות
      1. היפר-קישורים
      2. מסמכי PDF דינמיים
      3. סימניות
      4. לחצנים
      5. טפסים
      6. הנפשה
      7. הפניות מקושרות
      8. מבנה בקובצי PDF
      9. מעברי דפים
      10. סרטים וצלילים
      11. טפסים
    9. גרפיקה
      1. הבנת נתיבים וצורות‬
      2. ציור באמצעות הכלי Pencil
      3. ציור באמצעות הכלי Pen
      4. החלת הגדרות קו (משיחה) 
      5. נתיבים מורכבים וצורות מורכבות
      6. עריכת נתיבים
      7. נתיבי מסיכה
      8. שינוי מראה של פינה
      9. יישור ופיזור של אובייקטים
      10. גרפיקה מקושרת ומוטבעת
      11. שילוב נכסי AEM
    10. צבע ושקיפות
      1. החלת צבע
      2. שימוש בצבעים מגרפיקה מיובאת
      3. עבודה עם דוגמיות צבע
      4. ערבוב צבעי דפוס
      5. רשתות צבע
      6. הבנת צבעי ספוט וצבעי פרוצס‬
      7. מיזוג צבעים
      8. מעברי צבע
      9. שיטוח גרפיקה הכוללת שקיפות
      10. הוספת אפקטי שקיפות
  5. Share
    1. שתף ועבוד בשיתוף עם אחרים        
    2. שיתוף לצורך בדיקה
    3. בדיקת מסמך InDesign משותף
    4. ניהול משוב 
  6. פרסום
    1. ‏‫ייצוא ופרסום
      1. פרסום מקוון
      2. ייצוא תוכן עבור EPUB
      3. אפשרויות Adobe PDF
      4. ייצוא תוכן אל HTML
      5. ייצוא אל Adobe PDF
      6. ייצוא לפורמט JPEG
      7. ייצוא HTML
      8. סקירה כללית של DPS ושל AEM Mobile
    2. הדפסה
      1. הדפסת חוברות
      2. סימונים וגלישות של מדפסת
      3. הדפסת מסמכים
      4. צבעי דפוס, הפרדה וקצב רענון מסך
      5. הדפסת רכב
      6. יצירת קובצי PostScript ו-EPS
      7. בדיקת תקינות של קבצים לפני המסירה
      8. ‏‫הדפסת תמונות ממוזערות ומסמכים בגודל חריג
      9. הכנת קובצי PDF לספקי שירות
      10. הכנה להפרדות הדפסה
  7. הרחב את InDesign
    1. אוטומציה
      1. מיזוג נתונים
      2. תוספים
      3. שימוש בהרחבה Adobe Capture ב-InDesign
      4. כתיבת סקריפטים
הערה:

שפה שוויונית: אנו מחליפים שפה לא מכילה מתוך InDesign 2022 (גרסה 17.0) ואילך, שתשקף את ערכי ההכלה של Adobe. כל אזכור של המונח Master page מוחלף במונח Parent page במאמרי העזרה שלנו Help עבור אזורים דוברי אנגלית, דנית, הונגרית, ספרדית, איטלקית, פורטוגזית של ברזיל, פורטוגזית ויפנית.

הערה:

החל מגרסה 15.0 של InDesign, סוגי קבצים של Flash ‏(FLV ו-‏F4V) אינם זמינים עוד. כל האפשרויות הנוגעות לסוגי קבצים אלה הוסרו מהחלוניות המתאימות. למידע נוסף: Flash Player מגיע לסוף חיי השימוש | השפעה על InDesign.

יצירת לחצנים

ניתן ליצור לחצנים שיבצעו פעולות שונות לאחר ייצוא המסמך לתבנית EPUB בפריסה קבועה, PDF או EPUB. לדוגמה, ניתן ליצור לחצן המדלג לעמוד אחר או פותח אתר אינטרנט.

הגדרת לחצנים להפעלת סרט במסמך PDF לאחר ייצוא

בעת יצירת לחצן, ניתן לבצע את הפעולות הבאות:

הערה:

בעת העבודה על לחצנים ועיצוב מסמכים דינמיים, בחר בסביבת העבודה 'אינטראקטיבי עבור PDF'.

יצירת לחצן

  1. יש להשתמש בכלי Pen או באחד מכלי הציור, כמו הכלי Rectangle או Ellipse, כדי לצייר את צורת הלחצן. אם צריך, ניתן להשתמש בכלי Type להוספת טקסט ללחצן, כמו "הבא" או "רכישה".
    הערה:

    במקרה של יצירת לחצני ניווט (כמו Next Page או Previous Page) שיופיעו בדפים מרובים, ניתן להוסיף אותם לדף המאסטר כדי להימנע מיצירה חוזרת של לחצנים בכל דף מסמך. לחצנים אלה יופיעו בכל דפי המסמך שעליהם הוחל דף המאסטר.

  2. יש להשתמש בכלי Selection כדי לבחור תמונה, צורה או מסגרת טקסט שרוצים להמיר.

    לא ניתן להמיר סרט, קובץ שמע או כרזה ללחצן.

  3. לחץ על הסמל Convert To Button בחלונית Buttons and Forms (בחר Window > Interactive > Buttons and Forms). לחלופין, בחר Object > Interactive > Convert to Button.

    המר ללחצן

  4. בחלונית Buttons and Forms, בצע אחת מהפעולות הבאות:

    • יש לבחור לחצן מהתפריט הנפתח Type.
    • בתיבת הטקסט Name יש לציין שם ללחצן כדי להבדיל בינו לבין שאר הלחצנים שיצרת.
    • יש לציין את האירוע שיגרום לפעולה הרצויה.
    • ציין פעולה אחת או יותר עבור הלחצן כדי לקבוע מה יקרה כאשר מפעילים את האירוע במסמך EPUB בפריסה קבועה או בקובץ PDF לאחר הייצוא. ראה: הפיכת לחצנים לאינטראקטיביים.
    • יש להפעיל מצבי מראה נוספים ולשנות את המראה שלהם כדי לקבוע איך ייראה הלחצן, בעת השימוש בעכבר להצבעה או לחיצה על הלחצן במסמך EPUB בפריסה קבועה או ב-PDF לאחר ייצוא. ראה שינוי מראה הלחצן עבור הצבעה ולחיצה.
  5. השתמש בחלונית Preview panel (Window > Interactive > EPUB Interactivity Preview) כדי לבדוק את הלחצן לפני שתייצא את המסמך ל- EPUB בפריסה קבועה אינטראקטיבית, EPUB או PDF. תוכל גם לפרסם את המסמך באמצעות פרסום מקוון.

הוספת לחצן מהחלונית Sample Buttons

החלונית Sample Buttons כוללת מספר לחצנים שנוצרו מראש שניתן לגרור למסמך. לחצנים לדוגמה אלה כוללים אפקטים, כגון ריכוך קצוות של מעבר צבע והצללות, עם מראה שונה במקצת במראה Rollover. ללחצנים לדוגמה גם מוקצות פעולות. לדוגמה, לחצני החצים לדוגמה הוגדרו מראש עם הפעולות Go To Next Page או Go To Previous Page. ניתן לערוך לחצנים אלה בהתאם לדרישותיך.

החלונית Sample Buttons היא ספריית אובייקטים. כמו בכל ספריית אובייקטים, ניתן להוסיף לחצנים לחלונית ולהסיר לחצנים שאין בהם צורך. ‏(ראה שימוש בספריות אובייקטים). הלחצנים לדוגמה מאוחסנים בקובץ ButtonLibrary.indl, הנמצא בתיקייה Presets/Button Library בתיקיית היישום של InDesign.

  1. בחר Sample Buttons And Forms בחלונית Buttons and Forms כדי לפתוח את החלונית Sample Buttons And Forms.

    פתח את החלונית Sample Buttons And Forms

  2. גרור לחצן מהחלונית Sample Buttons And Forms למסמך. אם רוצים שלחצני הניווט יופיעו בכל דף ודף, יש להוסיף אותם לדף המאסטר.

    Sample Buttons and forms
    החלונית Sample Buttons And Forms

  3. בחר לחצן באמצעות הכלי Selection ולאחר מכן ערוך את הלחצן במידת הצורך באמצעות החלונית Buttons and Forms.

    כשעורכים את הלחצנים לדוגמה, יש לזכור את הפרטים הבאים:

    • אם מוסיפים טקסט ללחצן, יש לזכור להעתיק ולהדביק את הטקסט ממצב הלחצן Normal למצב הלחצן Rollover. אחרת, הטקסט שתוסיף לא יופיע במצב הצבעה על הלחצן במסמך EPUB בפריסה קבועה או PDF.

    • ניתן לשנות גודל של לחצנים. אם תגרור זוג לחצני חצים של Next Page/Previous Page, שנה את גודל הלחצן הראשון, בחר את הלחצן השני ובחר Object > Transform Again > Transform Again.

  4. השתמש בחלונית Preview panel (Window > Interactive > EPUB Interactivity Preview) כדי לבדוק את הלחצן לפני שתייצא את המסמך ל- EPUB בפריסה קבועה אינטראקטיבית, EPUB או PDF. תוכל גם לפרסם את המסמך באמצעות פרסום מקוון.

המרת לחצן לאובייקט

אם ממירים לחצן לאובייקט, תוכן הלחצן יישאר בדף, אך בלי תכונות הלחצן. כל תוכן המשויך למצבים אחרים של הלחצן מוסר גם הוא.

  1. יש להשתמש בכלי Selection כדי לבחור בלחצן הרצוי.
  2. בחר Object > Interactive > Convert To Object.

הפיכת לחצנים לאינטראקטיביים

לחצן מוגדר להשמיע צליל
לחצן זה הוגדר כך שישמיע צליל כשהמשתמש ילחץ על לחצן העכבר.

ניתן ליצור, לערוך ולנהל אפקטים אינטראקטיביים ב- InDesign. כאשר המסמך מיוצא לפורמט EPUB בפריסה קבועה או PDF, פעולות אינטראקטיביות אלה יכולות להיות פעילות.

לדוגמה, נניח שברצונך ליצור לחצן שיגרום להשמעת קובץ קול במסמך PDF. ניתן למקם את קובץ הקול במסמך InDesign, וליצור לחצן שיגרום להשמעת הקובץ כשהמשתמש ילחץ על הלחצן במסמך PDF.

בדוגמה זו, לחיצה על לחצן העכבר היא האירוע, והשמעת הצליל היא הפעולה.

הערה:

פעולות מסוימות נתמכות בקובצי PDF ובקובצי EPUB, ופעולות מסוימות נתמכות רק ב-PDF או ב-EPUB. בעת בחירה בפעולה, הימנע מבחירה בפעולת PDF בלבד אם אתה מייצא ל-EPUB בפריסה קבועה. כמו כן, הימנע מבחירה בפעולת EPUB בלבד אם אתה מייצא ל-PDF.

הוספת פעולות ללחצנים

ניתן להקצות פעולות לאירועים שונים. לדוגמה, ניתן לציין צליל שיושמע כשהמצביע יעבור לאזור הלחצן, וסרט שיופעל כשהמשתמש ילחץעל לחצן העכבר וישחרר אותו בקובץ PDF לאחר הייצוא. ניתן גם להקצות מספר פעולות לאותו אירוע. לדוגמה, ניתן ליצור אירוע שמפעיל סרט ומגדיר את הגדלת התצוגה למצב Actual Size.

  1. יש להשתמש בכלי Selection כדי לבחור בלחצן שיצרת.
  2. בחלונית Buttons and Forms, בחר אירוע, כגון On Release, הקובע כיצד יתבצעו פעולות.

  3. יש ללחוץ שוב על לחצן הסימן פלוס שליד Actions ולבחור בפעולה שרוצים להקצות לאירוע.
  4. יש לציין את הגדרות הפעולה.

    לדוגמה, אם בוחרים Go To First Page, יש לציין את מידת ההגדלה/הקטנה של התצוגה. אם בוחרים Go To URL, יש לציין את כתובת דף האינטרנט. לפעולות מסוימות, כמו Go To Next View, אין הגדרות נוספות.

  5. אם צריך, ניתן להמשיך להוסיף את מספר הפעולות הרצוי לכל אירוע.
  6. לבדיקת הלחצן, ייצא את המסמך לקובץ EPUB בפריסה קבועה או PDF והצג את הקובץ לאחר הייצוא. אם אתה מייצא לקובץ PDF, ודא שהאפשרות Interactive Elements נבחרה.

סוגי אירועים

אירועים קובעים את אופן ההפעלה של פעולות בלחצנים לאחר ייצוא מסמך ל-EPUB או PDF. ‏‏(ב- Acrobat, אירועים נקראים גורמי ביצוע).

On Release or Tap

כאשר לחצן העכבר משוחרר לאחר לחיצה. זהו האירוע הנפוץ ביותר, משום שהוא מעניק למשתמש הזדמנות אחרונה לגרור את הסמן מהלחצן מבלי להפעיל את הפעולה.

On Click

כשלוחצים על לחצן העכבר (מבלי לשחרר אותו). אם אין סיבה מיוחדת להשתמש במצב On Click, עדיף להשתמש במצב On Release כדי להעניק למשתמש הזדמנות לבטל את הפעולה.

On Roll Over

כשמצביע העכבר נכנס לאזור הלחצן המוגדר לפי התיבה התוחמת של הלחצן.

On Roll Off

כשמצביע העכבר יוצא מאזור הלחצן.

On Focus ‏(PDF)

בעת התמקדות בלחצן בקובץ PDF, באמצעות פעולה של העכבר או בהקשת Tab.

On Blur ‏(PDF)

כשהמוקד עובר ללחצן או שדה טופס אחר בקובץ ה- PDF.

סוגי פעולות

כשיוצרים פעולה, יש לציין מה יקרה כשהאירוע שצוין יתרחש – בדרך כלל כשמשתמש לוחץ על הלחצן. ניתן להקצות את הפעולות הבאות לסוגי אירועים:

Go To Destination

מעבר אל עוגן הטקסט שצוין אשר נוצא באמצעות החלונית Bookmarks או Hyperlinks. ראה יצירת מעברים לעוגני טקסט

Go To First/Last/Next/Previous Page

מעבר לעמוד הראשון, האחרון, הקודם או הבא בקובץ EPUB בפריסה קבועה או PDF. בחר אפשרות מהתפריט Zoom כדי לקבוע את אופן ההצגה של העמוד.

Go To URL

פותח את דף האינטרנט של כתובת ה- URL שצוינה.

הצג/הסתר את Buttons and Forms

מציג או מסתיר לחצנים שצוינו בקובץ EPUB בפריסה קבועה או PDF לאחר הייצוא. לדוגמה, אם ברצונך שלחצן אחד יופיע כאשר אתה מעביר את סמן העכבר ללחצן אחר, באפשרותך להסתיר את לחצן היעד עד שהוא יופעל וליצור פעולה שמציגה את הלחצן המוסתר בעת הצבעה. ראה הצגת לחצן אחר בעת הצבעה.

חל על EPUB/פרסום מקוון בלבד

הנפשה

מאפשר הפעלה, השהיה, עצירה או חידוש של ההנפשה שנבחרה. רק הנפשות שנוספו למסמך מופיעות בתפריט Animation.

עבור לעמוד

מעבר לעמוד שצוין בקובץ EPUB.

עבור למצב

מעבר למצב ספציפי באובייקט רב-מצבי. לדוגמה, אם אובייקט רב-מצבי כולל מספר תמונות שונות כמצבים, באפשרותך להשתמש בפעולה זו כדי להציג תמונה מסוימת.

Go To Next/Previous State

מעבר למצב הבא או המצב הקודם באובייקט רב-מצבי. אפשרויות אלה שימושיות בפרט עבור לחיצה במצגת שקופיות. ראה יצירת אובייקטים רב-מצביים.

Sound

מאפשרת הפעלה, השהיה, עצירה או חידוש של קובץ הקול שנבחר. רק קובצי קול שנוספו למסמך מופיעים בתפריט Sound.

Video

מאפשרת הפעלה, השהיה, עצירה או חידוש של הסרט שנבחר. רק סרטים שנוספו למסמך מופיעים בתפריט Video.

חל על PDF בלבד

Clear Form

מנקה את כל הנתונים שהוזנו בשדות הטופס ומביא את הטופס למצבו המקורי.

עבור לתצוגה הבאה

מעבר לדף לאחר חזרה לתצוגה הקודמת. בדומה ללחצן Forward בדפדפן אינטרנט, שהופך לזמין רק לאחר לחיצה על הלחצן Back, אפשרות זו זמינה רק אם המשתמש עבר לתצוגה קודמת.

עבור לתצוגה הקודמת

מעבר לדף האחרון שהוצג במסמך PDF, או חזרה לערך הגדלת התצוגה האחרון שנעשה בו שימוש.

פתח קובץ

הפעלה ופתיחה של הקובץ שציינת. אם מציינים קובץ שלא בפורמט PDF, הקורא יזדקק ליישום המקורי כדי לפתוח את הקובץ בהצלחה. יש לציין נתיב מוחלט (כמו c:\docs\sample.pdf).

Print Form

פותח את תיבת הדו-שיח להדפסה לצורך הדפסת הטופס.

Submit Form

שולח נתונים שהוזנו בשדות הטופס לכתובת האתר שהוזכרה. עליך להזין mailto‎ : בשדה URL ולאחר מכן לציין כתובת דוא"ל כדי לשלוח טופס מלא לדוא"ל שצוין. ודא שאין רווח לפני ואחרי הנקודותיים (:).

זום לתצוגה

הצגת הדף בהתאם לאפשרות הגדלת התצוגה שציינת. ניתן לשנות את ערך ההגדלה לדף (למשל, Actual Size), את פריסת הדף (כמו Continuous - Facing), או את כיוון הסיבוב.

עריכה או מחיקה של פעולות לחצן

  1. יש להשתמש בכלי Selection כדי לבחור בלחצן הרצוי.
  2. בחלונית Buttons and Forms, יש לבצע אחת מהפעולות הבאות:

    • לביטול פעולות, יש לבטל את הסימון בתיבת הסימון שליד הפריט. ביטול אירועים ופעולות יכול להיות שימושי למטרות בדיקה.
    • כדי לשנות את הסדר, יש לגרור ולשחרר פעולות.
    • למחיקת פעולה, יש לבחור בפעולה בתיבת הרשימה וללחוץ על הלחצן Delete Selected Action .
    • לעריכת פעולה, יש לבחור באירוע שפעולה זו הוקצתה לו, לבחור בפעולה בתיבת הרשימה ולשנות את ההגדרות. אם צריך להחליף פעולה של אירוע קיים, יש למחוק את הפעולה ולהוסיף את הפעולה החדשה לאירוע.

יצירת מעברים לעוגני טקסט

אם יוצרים עוגן טקסט במסמך InDesign, ניתן לגרום ללחצן לעבור לעוגן זה, גם אם הוא נמצא במסמך אחר של InDesign. ניתן להשתמש בחלונית Bookmarks ובחלונית Hyperlinks כדי להוסיף עוגני טקסט. לא ניתן ליצור מעברים מלחצנים לסימניות שלא עוגני טקסט.

הערה:

אם הגדרת ללחצן יעד מסוג היפר-קישור, ההיפר-קישור לא יפעל בקובץ EPUB בפריסה קבועה או ב-PDF לאחר הייצוא.

  1. יש להשתמש בכלי Selection כדי לבחור בלחצן הרצוי.
  2. בחלונית Buttons and Forms יש לבחור את האירוע, למשל On Release, שיפעיל את המעבר.

  3. יש ללחוץ על לחצן סימן הפלוס שליד Actions ולבחור Go To Destination.
  4. יש לבחור באחד ממסמכי InDesign הפתוחים בתפריט Documents, או ללחוץ על סמל התיקייה מימין לתפריט ולציין את הקובץ.
  5. יש לבחור עוגן שנוצר באמצעות החלונית Bookmarks או החלונית Hyperlinks.
  6. יש לבחור אפשרות מהתפריט Zoom כדי לקבוע את אופן ההצגה של הדף.
הערה:

אם מציינים עוגן במסמך אחר, יש לזכור לייצא את מסמך היעד אל PDF ולהשתמש בשם קובץ זהה לזה של מסמך InDesign, תוך החלפה של הסיומת INDD בסיומת PDF. בנוסף, יש לאחסן את מסמכי PDF באותה תיקייה, כדי להבטיח שהקישורים יישארו בתוקף עבור Acrobat ועבור Adobe Reader.

שינוי מראה הלחצן עבור הצבעה ולחיצה

לחצן מורכב מקבוצה של אובייקטים בודדים, שכל אחד מהם מייצג מראה לחצן (מכונה לעתים "מצב"). לכל לחצן יכולים להיות עד שלושה מראות: Normal‏, Rollover ו-Click. בקובץ המיוצא, המראה Normal נמצא בשימוש, אלא אם מצביע העכבר עובר לאזור הלחצן (Rollover) או כשלוחצים על לחצן העכבר באזור הלחצן (Click). ניתן להפוך כל מראה לשונה כדי לתת משוב חזותי.

כברירת מחדל, כל לחצן שנוצר מוגדר למראה Normal המכיל את הטקסט או התמונה של הלחצן. כשמפעילים מראה חדש, מתבצעת העתקה של המראה Normal. כדי להבחין בין מראה אחד למראות אחרים, ניתן לשנות את הצבע, או להוסיף טקסט או תמונה.

מצבי לחצנים

A. המצביע אינו נמצא מעל אזור הלחצן (Normal)‏ B. ‏המצביע נכנס לאזור הלחצן (Rollover)‏ C. ‏לחיצה במיקום של המצביע (Click)‏ 

הערה:

האזור הניתן ללחיצה של הלחצן, או האזור החם שלו, הוא התיבה התוחמת המלבנית של המצב הגדול ביותר של הלחצן. לדוגמה, לחצן עגול כולל אזור חם מרובע.

שינוי מראות הלחצן

אם יוצרים לחצן הכולל מראות מרובים (Normal‏, Rollover ו-Click), מומלץ לסיים את עיצוב הלחצן לפני הפעלה של מראות אחרים. כשמפעילים את המראה Rollover או Click, מתבצעת העתקה של המראה Normal.

חלק מהשינויים משפיעים רק על המראות שנבחרו, בעוד ששינויים אחרים משפיעים על כל המראות הפעילים. אם בוחרים מראה ומחילים צבע רקע אחר או עורכים את הטקסט, השינוי ישפיע על המראה שנבחר. אם משתמשים בכלי Selection כדי להזיז או לשנות את גודל העכבר, השינוי ישפיע על כל המראות.

  1. בחר Window > Interactive > Buttons and Forms כדי להציג את החלונית Buttons and Forms.

  2. באמצעות הכלי Selection , יש לבחור בלחצן שרוצים לערוך בפריסה.
  3. לחץ על [Rollover] כדי להפעיל את המראה Rollover.

    מתבצעת העתקה של המראה Normal ל- Rollover.

  4. כאשר המצב Rollover מסומן, יש לשנות את מראה הלחצן.
    • כדי לשנות את הצבע, יש לבחור דוגמית צבע מהתפריט Stroke או Fill בחלונית Control.
    • כדי להציב תמונה במראה, בחר את התמונה הקיימת באמצעות כלי הבחירה הישירה או על ידי לחיצה כפולה על תמונת הלחצן הקיימת, בחר File > Place ולחץ פעמיים על קובץ.
    • כדי להדביק תמונה למסגרת טקסט, העתק אותה ללוח, בחר את המראה בחלונית Buttons ובחר Edit > Paste Into.
    • להקלדת טקסט, בחר בכלי Type, לחץ על הלחצן והקלד את הטקסט. ניתן גם לבחור Edit > Paste Into כדי להעתיק מסגרת טקסט שהודבקה.
  5. להוספת המראה Click, יש ללחוץ על [Click] להפעלתו ולבצע את אותו הליך כדי לשנות את מראהו.
  6. ניתן להשתמש בחלונית Preview כדי לבדוק את מראות הלחצן השונים.
הערה:

לשינוי גודל התמונות הממוזערות של State Appearance בחלונית Buttons, בחר Panel Options מתפריט החלונית Buttons and Forms, בחר אפשרות ולחץ על OK.

מחיקה וביטול של מראות

  1. בחר במראה בחלונית Buttons and Forms.

  2. בצע אחת מהפעולות הבאות:
    • למחיקת המראה Rollover או Click, לחץ על הסמל Delete בתחתית החלונית. מחיקת מראה שימושית במיוחד אם אתה עורך את המראה Normal במידה ניכרת ומחליט שברצונך לבסס את Rollover או Click על המראה החדש של Normal.
    • כדי לבטל מראה מבלי למחוק אותו, לחץ על הסמל Eye שליד המראה כדי לבטל את הבחירה בו. לא יתבצע ייצוא לקובץ EPUB בפריסה קבועה או PDF של מצבים שלא הופעלו.
הערה:

לא ניתן למחוק או לבטל את המצב Normal.

יצירת אובייקטים רב-מצביים

החלונית Object States מאפשרת יצירת גרסאות מרובות של אובייקט. מצב הוא גרסה של פריט דף. אובייקט שכולל מספר מצבים מכונה אובייקט רב-מצבי.

כשמשתמשים בחלונית Object States, אין מגבלה על מספר המצבים שניתן ליצור עבור אובייקט. בכל פעם שיוצרים מצב, נוצרת גרסה נוספת של פריט הדף. רק מצב אחד גלוי לעין בדף בכל עת. במקרה של פלט הדפסה ו-PDF, רק המצב הפעיל מופיע בפלט הסופי.

יצירת מצגת שקופיות של אובייקטים רב-מצביים

אחד מהשימושים הנפוצים ביותר של אובייקט רב-מצבי הוא מצגת שקופיות שמאפשרת לצופים בקובץ ה- EPUB לעבור בעזרת לחיצות בין סדרת תמונות. לדוגמה, ניתן ליצור מצגת שקופיות של 20 תמונות מבלי למקם את התמונות ב- 20 עמודים שונים.

  1. השמת תמונות שיופיעו במצגת שקופיות.

    לקבלת התוצאות הטובות ביותר, יש לוודא שהגודל של מסגרות התמונות זהה.

    מצב לא חייב להיות פריט בודד - הוא יכול להיות אוסף פריטים.

  2. כדי לסדר תמונות בערימה, יש לבחור אותן וללחוץ על Align Horizontal Centers  ועל Align Vertical Centers  בחלונית Control.

  3. מבלי לבטל את הבחירה, יש לפתוח את החלונית Object States (Window > Interactive > Object States), וללחוץ על Convert Selection To Multi-State Object.

    התמונות יופיעו כמצבים בחלונית Object States ומסגרת מקווקוות תקיף את התמונות שנבחרו.

    המר את הבחירה לאובייקט רב-מצבי

  4. צור לחצני ניווט שיפעילו את הפעולות Go To Next State ו-Go To Previous State כאשר לחצן העכבר משוחרר. ראה יצירת לחצנים.

  5. השתמש בחלונית Preview (Window > Interactive > EPUB Interactivity Preview) כדי לבדוק את לחצני הניווט.

  6. ייצא את המסמך לתבנית EPUB. ראה מסמכים אינטראקטיביים.

עריכת אובייקט רב-מצבי

  1. בחר אובייקט רב-מצבי.

  2. בחלונית Object States, בצע אחת מהפעולות הבאות:

    • כדי לערוך מצב, יש לבחור אותו בחלונית Object States ואז לערוך את האובייקט. לדוגמה, ניתן להוסיף משיחה או מילוי, או לשנות את האובייקט.

    • כדי להוסיף אובייקט למצב קיים, יש לבחור את האובייקט ואת האובייקט הרב-מצבי וללחוץ על הלחצן Add Objects To Visible State .

    • כדי להוסיף אובייקט לאובייקט רב-מצבי קיים, יש לבחור את האובייקט ואת האובייקט הרב-מצבי וללחוץ על הלחצן Convert Selection To Multi-State Object .

    • כדי לשכפל מצב, יש לבחור מצב שעליו יתבסס המצב החדש ולבחור New State מתפריט החלונית. ניתן להוסיף, להסיר או לערוך את התוכן של מצב זה.

    • כדי להדביק אובייקט במצב קיים, יש לגזור או להעתיק אובייקט אחד או יותר, לבחור את האובייקט הרב-מצבי, לבחור את המצב בחלונית Object States ולבחור Paste Into State בתפריט החלונית Object States.

    • כדי להמיר אובייקטים רבי-מצבים בחזרה לערכה של אובייקטים עצמאיים, יש לבחור את המצב בחלונית Object States ולבחור Release State To Object מתפריט החלונית. כדי להמיר את כל המצבים באובייקט הרב-מצבי לאובייקטים, יש לבחור Release All States To Objects.

    • כדי למחוק מצב ולהסיר את התוכן שלו, יש לבחור את המצב ולבחור Delete State מתפריט החלונית.

    • כדי להסתיר את האובייקט הרב-מצבי בקובץ המיוצא עד שהוא יופעל ע"י לחצן, יש לבחור Hide Until Triggered מתפריט החלונית.

    • כדי לאפס את כל האובייקטים הרב-מצביים במסמך למצב הראשון, יש לבחור Reset All Multi-State Objects To First State מתפריט החלונית. כשבוחרים מצב, האובייקט יישאר במצב זה גם אם סוגרים ופותחים מחדש את המסמך. זו האפשרות המהירה ביותר לאיפוס כל האובייקטים הרב-מצביים.

יצירת אזורים חמים עבור לחצנים

במקרים מסוימים רצוי שאזור הלחצן (הנקרא "אזור חם" או "קישור חם") לא יהיה גלוי עד שמצביע העכבר ירחף מעליו. לדוגמה, כשמעבירים מצביע מעל לחצן במפה, ייתכן שתוצג תמונה שמייצגת אזור, והתמונה עשויה להיעלם כשהמצביע זז מהאזור.

בקובץ PDF המיוצא, הצבת המצביע מעל אזור חם גורמת לתמונה להיעלם.

הצגת תמונה מוסתרת בעת הצבעה

דרך אחת ליצירת אפקט "אזור חם" היא החלת תמונה על המצב Rollover בחלונית Buttons. כדי לעשות זאת, יש ליצור לחצן שבו המצב [Rollover] מציג תמונה, בעוד שהמצב [Normal] לא מציג את התמונה.

  1. יש לבחור את התמונה שבה רוצים להשתמש כאזור חם. יש לוודא שלמסגרת התמונה אין גבול או רקע.

  2. בחלונית Buttons and Forms (בחר Window > Interactive > Buttons and Forms), לחץ על המראה [Normal] כדי להמיר את התמונה שנבחרה ללחצן.

  3. לחץ על המראה [Rollover] בחלונית Buttons and Forms כדי להפעיל אותו.

  4. יש ללחוץ שוב על המראה [Normal]. אז יש לבחור את התמונה באמצעות הכלי Direct Selection  ולמחוק את התמונה.

    יש להקפיד למחוק את התמונה (את תוכן המסגרת), ולא את המסגרת ואת התוכן. מחיקת המסגרת מוחקת את הלחצן כולו.

  5. השתמש בחלונית Preview כדי להציג בתצוגה מקדימה את אפקט האזור החם.

הצגת לחצן אחר בעת הצבעה

ניתן ליצור אזור חם שבו לחיצה על אובייקט או ריחוף מעליו בעזרת העכבר מציגים אובייקט אחר. כדי לעשות זאת, יש ליצור שני לחצנים, להסתיר אחד מהלחצנים ולהשתמש בפעולה Show/Hide Button כדי להציג ולהסתיר את לחצן היעד.

  1. יצירת אובייקט שישמש כלחצן המקור. בחלונית Buttons and Forms, לחץ על הסמל Convert Object To A Button.

  2. יש להציב את התמונה שרוצים שתשמש כלחצן היעד ולהמיר אותה ללחצן.
  3. בחר את תמונת היעד ובחר Hidden Until Triggered בתחתית החלונית Buttons and Forms.

    יש להסתיר את התמונה במסמך המיוצא כדי שיהיה ניתן להציג אותה כאשר לוחצים על המקור בעזרת העכבר.

  4. יש לבחור את לחצן המקור וליצור שתי פעולות שונות, אחת כדי להציג את תמונת היעד ושנייה כדי להסתיר את תמונת היעד.

    אם ברצונך שהתמונה תופיע כאשר הלחצן מרחף מעל לחצן המקור, השתמש באירוע On Roll Over ו- On Roll Off. אם ברצונך שהתמונה תופיע בעת לחיצה על לחצן המקור ותיעלם בעת שחרורו, השתמש באירוע On Click ו- On Release. בכל מקרה, השתמש בפעולה Show/Hide Buttons כדי להציג ולהסתיר את לחצן היעד. ראה הפיכת לחצנים לאינטראקטיביים.

  5. השתמש בחלונית Preview כדי לבדוק את הלחצנים.

שינוי אפשרויות PDF עבור לחצנים

  1. יש להשתמש בכלי Selection כדי לבחור בלחצן הרצוי.
  2. בתפריט החלונית Buttons and Forms, יש לבחור PDF Options.

  3. יש להקליד תיאור שישמש כטקסט חלופי למשתמשים עם ליקויי ראייה.
  4. יש לציין האם להדפיס את הלחצן בקובץ PDF, ואז ללחוץ על OK.

הגדרת סדר הטאבים של לחצנים

סדר הטאבים קובע את השדה הבא (או הקודם) כדי לקבל מוקד כאשר משתמש מקיש על Tab (או Shift+Tab) במסמך ה-PDF. סדר הכרטיסייה כולל לחצנים בשכבות מוסתרות, אך לא לחצנים בדפי מאסטר.

  1. עבור לדף הכולל את הלחצנים.
  2. בחר Object > Interactive > Set Tab Order.

  3. יש לבחור כל לחצן שרוצים להזיז ולגרור אותו למיקומו החדש, או ללחוץ על הלחצנים Move Up ו-Move Down. לאחר סיום יש ללחוץ על OK.

אם משתמשים ב-Acrobat לעריכת מסמך PDF ומוסיפים עוד לחצנים או שדות טופס לדף, ייתכן שיהיה צורך לציין סדר עצירות טאב חדש ב-Acrobat.

נושאים קשורים

לוגו של Adobe

כניסה לחשבון