macOS において Illustrator をより速く、より効率的にできる対策をご紹介します。

Adobe Illustrator のパフォーマンスの速度と効率に影響する要因には、オペレーティングシステムとハードウェアの構成、ワークフロー、選択するオプションなどがあります。 Illustrator の実行が通常より遅くなった場合は、Illustrator のパフォーマンスだけでなく、他のアプリケーションのパフォーマンスも最適化できるテクニックがあります。

パフォーマンスの向上がはっきり分かるのは、大きなファイルを操作する場合です。

開始する前に

以下のタスクを遂行する前に、Illustrator の最新バージョンか、使用中のバージョンのアップデートがインストールされていることを確認してください。ソフトウェアアップデートには、多くの場合、パフォーマンスに関する修正または機能拡張が含まれています。

Illustrator CC を使用している場合は、Creative Cloud デスクトップアプリケーションから Illustrator をアップデートできます。

macOS の最適化

効率的に実行されるようにオペレーティングシステムを設定すると、アプリケーションに使用できるメモリ量が増加し、アプリケーションをスムーズに実行できます。 以下のテクニックで、macOS を最適化し、Illustrator のパフォーマンスを向上させます。

フォントの管理

フォントをインストールするたびに、macOS で使用する RAM 量が増大します。システムパフォーマンス、およびフォントにアクセスするアプリケーションのパフォーマンスを改善するには、必要なフォントのみをインストールします。 フォント管理ユーティリティを使用することで、多数のフォントの管理が容易になります。

PostScript プリンタードライバーを使用する

PostScript 対応でないプリンタードライバーは、Illustrator と競合します。 したがって、アドビでは、PostScript プリンタードライバーを macOS のデフォルトに設定することを推奨しています。

手順 1. PostScript 対応プリンターをデフォルトのプリンターに設定します。

注意:

この手順を完了するには、PostScript プリンターが直接またはネットワークを介してコンピューターに接続していることを確認してください。

  1. Apple メニューから、「システム環境設定」を選択し、「プリントとスキン」をクリックします。

  2. PostScript プリンターがリストにない場合は、「+」をクリックして PostScript プリンターに移動し、「追加」をクリックします。

  3. デフォルトプリンターポップアップメニューから PostScript プリンターを選択します。

手順 2. デフォルト以外のプリンターからプリントするようにIllustrator を設定します。

  1. Illustrator で任意の文書を開き、「ファイルプリント」を選択します。

  2. プリントダイアログボックスで、「Adobe PostScript ファイル 」を選択するか、プリンターメニューからプリンターの名前を選択します。

  3. 保存」をクリックします。

ハードウェア構成の最適化

使用するハードウェアは、Illustrator のパフォーマンスに影響を及ぼします。高速なプロセッサーまたはハードディスクドライブを使用すると、Illustrator は情報を高速に処理できます。 追加のRAMの搭載、マルチプロセッサーシステムの使用またはドライブの最適化のような他のハードウェア強化を行うと、パフォーマンスが改善される可能性があります。 以下のタスクを試すと、ハードウェア構成を最適化し、Illustrator のパフォーマンスを改善できます。

より高速のプロセッサーの使用

コンピューターの中央演算装置(CPU)の速度は、Illustrator の速度に影響を及ぼします。 Illustrator は大量のデータを操作し、多くの計算を実行するので、Illustrator の速度はプロセッサーの速度に左右されます。 より高速のプロセッサーを備えたコンピューターの使用を検討してください。

追加の RAM のインストール

Illustrator は RAM が不足すると、情報を処理するためにハードディスクスペース(つまり、仮想記憶ディスク)を使用します。Illustrator が最も高速に動作するのは、ハードディスクを使用せずに、情報をメモリ内で処理できる場合です。

ディスク容量の最適化

以下に、ディスクスペースを最適化する方法をいくつか示します。

  • エラーの有無についてハードディスクをチェックしたり、サードパーティのディスクユーティリティ(Norton Utilities など)でファイルをデフラグします。macOS を実行している場合は、ドライブをデフラグする必要はありませんが、サードパーティのディスクユーティリティで修理することが必要な場合があります。
  • より高速なアクセス速度で、ファイルをドライブに保存します。 例えば、ネットワークサーバー(ネットワークドライブ)や外部ドライブでなく、内部ハードドライブを使用します。

Illustrator の機能を効率的に使用

Illustrator で作業をする方法、特にアートワークを表示する方法は、Illustrator のパフォーマンスに影響を及ぼす可能性があります。 以下に、Illustrator のスムーズな実行に役立つ Illustrator 機能の使用方法を示します。

「アウトライン」表示で作業する

[Outline] ビューでは、ペイントの属性を非表示にして、塗りつぶされていないパスとしてアートワークを表示します。 [Outline] ビューを使用すると、グラデーションやパターンが含まれているオブジェクトなどの複雑なアートワークを高速表示できます。 また、[Outline] ビューを使用すると、他の塗りつぶされたオブジェクトに隠れたオブジェクトを簡単に編集できます。

「アウトライン」ビューで Illustrator 文書を表示するには、表示アウトラインを選択します。

カスタムビューの作成

文書のカスタムビューを作成できます。 カスタムビューを使用すると簡単に表示モード、拡大率、スクロール位置およびレイヤーオプションを変更できます。

Illustrator 文書のカスタムビューを作成するには、保存したい表示属性を設定します。 次に、表示新規表示を選択し、新規表示ダイアログボックスに名前を入力します。表示メニューにカスタムビューが表示されます。

ラスタライズ効果の設定を変更する

ラスタライズ効果の解像度を変更することで、Illustrator のパフォーマンスを最適化できます。

ラスタライズ効果の解像度を変更するには、効果ドキュメントのラスタライズ効果設定を選択して、解像度 ドロップダウンリストから以下のいずれかを選択します。

  • ファイルを編集する場合は、「スクリーン」をクリックします。 Illustratorはラスタライズ効果に72ppiの解像度を使用し、表示速度を向上させます。
  • ファイルをプリントする場合は、「」をクリックします。 Illustratorはラスタライズ効果に300ppiの解像度を使用します。プリント速度は低下しますが、プリント品質は向上します。

OK」をクリックします。

レイヤーを隠し、サムネールを削除する

複雑なアートワークや高解像度のビットマップイメージを含むレイヤーを非表示にすると、Illustrator による画面の再描画が速くなります。

レイヤーを非表示にするには、レイヤー名の左側にある目のアイコンをクリックし、「レイヤーを表示」の選択を解除し、「OK」をクリックします。 選択したレイヤー以外のすべてのレイヤーを非表示にするには、目のアイコンをAltキーを押しながらクリックします。

レイヤーパネルでは、最上位レイヤー、ネストしたレイヤー、グループおよびオブジェクトのサムネールを表示できます。 サムネールの数を減らして Illustrator による画面の再描画を速くするには、レイヤーパネルメニューから「パネルオプション 」を選択して、サムネールの数を減らします。

  • レイヤーパネルからすべてのサムネールを削除するには、「行サイズ」セクションで「 」を選択し、「OK」をクリックします。
  • レイヤーパネル内の特定の要素に対応するサムネールを削除するには、「サムネール」セクションの「レイヤー」、「グループ」、または「オブジェクト 」の選択を解除し、「OK」をクリックします。

オーバープリントプレビューの無効化

オーバープリントプレビューを使用すると、「インクプレビュー」、つまり描画、透明およびオーバープリントが色分版でどのように表示されるかが近似表示されます。 パフォーマンスを向上させるには、オーバープリントプレビューを使用しないようにします。

オーバープリントプレビューを有効、または無効にするには、表示オーバープリントプレビューを選択します。

使用されていないアートボードの削除

アートボードはプリント可能なアートワークを収容できる領域を表します。 パフォーマンスを最適化するためには、使用していない、または不要なアートボードを削除することを検討してください。

アートボードの管理は、ウィンドウアートボードを選択します。次に、削除したいアートボードを選択して、「削除」をクリックします。

仮想記憶ディスクの環境設定を変更する

埋め込まれたビットマップイメージで作業していて、システムの RAM が不十分な場合、Illustrator は仮想記憶ディスクとしてハードディスク容量を使用します。 メモリ上よりハードディスクにある情報にアクセスする方が時間がかかります。 そのため、ハードディスクの一部を仮想メモリとして使用すると、パフォーマンスが低下する可能性があります。 Illustrator での作業にメモリがさらに必要な場合は、RAM を追加してみてください。

デフォルトでは、Illustratorはシステムドライブをプライマリ仮想記憶ディスクとして使用します。 Illustratorのプライマリ仮想記憶ディスク設定を、使用中の最も高速なハードディスクドライブに変更します。

仮想記憶ディスクの環境設定を変更するには、以下の操作を行います。

  1. Illustrator環境設定プラグインと仮想記憶ディスクを選択します。

  2. プライマリポップアップメニューからハードディスクを選択します。 多数のイメージの操作をする予定で複数のハードディスクを使用している場合は、セカンダリポップアップメニューから他のディスクを選択します。
  3. OK」をクリックし、Illustrator を再起動します。

使用されていない要素を文書プロファイルから削除

Illustrator ドキュメントプロファイルには、新しいIllustorator文書で表示されるデフォルトのパターン、グラデーション、グラフデザイン、カラー、カラーライブラリ、およびブラシが含まれています。 これらのファイルは、新規ドキュメントのズームレベル、ウィンドウサイズ、環境設定およびスクロール位置も決定します。 Illustratorの新規ドキュメントプロファイルから不要なスウォッチとブラシを削除することにより、新規ドキュメントのファイルサイズを最小化します。

カスタムのドキュメントプロファイルの作成方法については、「Startup Profiles: A great tool to customize your new documents (起動プロファイル:新規ドキュメントをカスタマイズする素晴らしいツール)」を参照してください。

テンプレートから未使用の要素を削除する

テンプレートを使用すると、一般設定とデザイン要素を共有する複数のドキュメントを作成できます。テンプレートから不要なスウォッチ、シンボル、グラフィックスタイルおよびブラシを削除することにより、新規ドキュメントのファイルサイズを最小化できます。

テンプレートファイルの作成方法については、「ファイルとテンプレート」を参照してください。

画像へのリンクを有効にする

埋め込まれたビットマップイメージ(例えば、TIFF、BMPまたはPhotoshop EPS)はIllustratorドキュメントのサイズを大幅に増加させ、パフォーマンスを低下させる可能性があります。 パフォーマンスを改善するには、ビットマップ画像の配置時に「リンク」オプションを有効にします。 「リンク」オプションは、ハードディスク上にある、配置されたイメージを参照します。

  • ファイル配置に移動します。配置ダイアログボックスで「リンク」を選択します。

サービスビューローが埋め込まれた画像を必要としている場合には、ファイルのコピーを保存するようにします。 Illustrator ネイティブフォーマットオプションまたはEPS フォーマットオプションダイアログボックスで、「リンクされたファイルを含める」を選択します。

低解像度 EPS プレビューを使用

文書が、高解像度プレビュー付きのリンク付けされたEPSイメージを含んでいる場合、Illustratorはアートワークを編集するよりも画面の再描画が低速になります。 Illustrator で画面の再描画の高速化を有効にするには、低解像度 EPS プレビューを使用します。 次の操作を実行します :

  1. Illustrator 環境設定ファイル管理とクリップボードを選択します。

  2. リンクされた EPS に低解像度のプロキシを使用」を選択し、「OK」をクリックします。

「DCS 透明のインタラクティブ表示」を無効にする

リンクパネルオプションダイアログボックスには、「DCS 透明のインタラクティブ表示」オプションが含まれています。 このオプションが選択されている場合は、リンクパネルでは黄色いアイコンが表示され、リンクされているDCS EPSグラフィックが透明オブジェクトまたはオーバーラップ透明オブジェクトであることを識別します。 このオプションにより、リンクされているEPSファイルの透明のインタラクティブ状態がIllustratorで常に判定されるようになるので、パフォーマンスが低下する可能性があります。

「透明の影響を表示」オプションを無効にするには、次の手順に従います。

  1. ウィンドウリンクを選択します。リンクパネルメニューから「パネルオプション」を選択します。

  2. DCS 形式への透明の影響を表示 」を選択解除し、「OK」をクリックします。

ナビゲーターパネルを隠す

ナビゲーターパネルでは、ナビゲーションが簡単に実行できるように、現在のアートワークのサムネールビューが表示されます。 文書を変更するたびサムネイルを更新するのに必要な処理時間は、アートワークの複雑さに依存します。 複雑なドキュメントの画面再描画の速度とパフォーマンスを改善するには、「ナビゲーター」パネルを非表示にします。

  • 「ウィンドウ」メニューで、「ナビゲーター」の選択を解除します。

文書の特定の領域をより効率的にズームするには、カスタムビューを設定できます。

アンチエイリアスアートワークを無効にする

アートワークのアンチエイリアスオプションは、オブジェクトのエッジピクセルの色を隣り合ったピクセルの色と混合することにより、テキストとグラフィックをスムーズにします。 ただし、このプロセスが原因で、画面の再描画が低速になる可能性があります。 このオプションを無効化するには、次の操作を行います。

  1. Illustrator環境設定環境設定一般を選択します。

  2. アートワークのアンチエイリアス」を選択解除し、「OK」をクリックします。

単純化コマンドを適用

「単純化」コマンドを使用すると、パス内およびパスシェイプ内のアンカーポイントの量が減り、ファイルサイズが小さくなり、パフォーマンスが向上します。 「単純化」コマンドを適用するには、目的のパスまたはオブジェクトを選択し、次にオブジェクトパス単純化を選択します。

「単純化」コマンドの詳細については、「パスの編集」を参照してください。

スマートガイドを無効にする

スマートガイドを使用すると、他のオブジェクトを基準にしてIllustratorオブジェクトの作成、整列、編集および変形ができます。 アートワークに多数のオブジェクトがある場合、Illustratorはスマートガイドを表示するのにより時間がかかります。

  • スマートガイドを無効にするには、表示メニューをクリックし、「スマートガイド」を選択解除します。

スマートガイドの詳細をご覧ください。

本作品は Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License によってライセンス許可を受けています。  Twitter™ および Facebook の投稿には、Creative Commons の規約内容は適用されません。

法律上の注意   |   プライバシーポリシー